# Table of Contents

## Introduction to Tecplot 360

1. **Introduction** ................................................................. 13
   - Interface ................................................................................. 14
   - Getting Help ........................................................................... 35

2. **Using the Workspace** ......................................................... 37
   - Data Hierarchy ........................................................................ 37
   - Interface Coordinate Systems .................................................. 39
   - Frames ................................................................................... 40
   - Workspace Management Options Menu ................................... 49
   - View Modification .................................................................... 51
   - Edit Menu .............................................................................. 54

3. **Data Structure** ................................................................. 57
   - Connectivity List ..................................................................... 57
   - Ordered Data .......................................................................... 58
   - Finite Element Data ................................................................. 61
   - Variable Location (Cell-centered or Nodal) ............................... 62
   - Face Neighbors ....................................................................... 63
   - Working with Unorganized Datasets ......................................... 63
Loading Your Data

Data Loaders .......................................................... 69
CGNS Loader .............................................................. 70
DEM Loader ................................................................. 74
DXF Loader ................................................................. 75
EnSight Loader ............................................................. 76
Excel Loader ................................................................. 77
FEA Loader ................................................................. 81
FLOW-3D Loader .......................................................... 88
FLUENT Loader ............................................................. 92
General Text Loader ....................................................... 97
HDF Loader ................................................................. 106
HDF5 Loader ............................................................... 107
Kiva Loader ................................................................. 109
PLOT3D Loader ............................................................. 110
PLY Loader ................................................................. 115
Tecplot-Format Loader ................................................... 116
Text Spreadsheet Loader ............................................ 123
Overwriting Data Files ................................................. 124

Creating Plots

Creating Plots .......................................................... 129
Data Journaling ........................................................... 130
Dataset Information ..................................................... 131
Select Color ............................................................... 137

XY and Polar Line Plots ................................................. 143
Mapping Style and Creation ........................................... 144
Line Map Layer .......................................................... 149
Symbols Map Layer .................................................... 163
XY Line Error Bars ..................................................... 165
XY Line Bar Charts ..................................................... 167
I, J, and K-indices ......................................................... 167
Line Legend ............................................................... 168
Polar Drawing Options ................................................ 170

Field Plots ............................................................... 173
Field Plot Modification - Zone Style Dialog ...................... 174
Time Aware ...................................................................................................................... 179
Data Point and Cell Labels..........................................................................................181
Three-dimensional Plot Control .............................................................................182

8 Mesh Layer and Edge Layer .................................................................................. 189
Mesh Layer ....................................................................................................................189
Edge Layer ....................................................................................................................191

9 Contour Layer ........................................................................................................... 193
Contour Layer Modification .........................................................................................194
Contour Details Dialog .................................................................................................195
Extract Contour Lines .................................................................................................204

10 Vector Layer .......................................................................................................... 207
Vector Variables ............................................................................................................207
Vector Plot Modification ...............................................................................................208
Vector Arrowheads .........................................................................................................210
Vector Length ................................................................................................................211
Reference Vectors .........................................................................................................212

11 Scatter Layer .......................................................................................................... 215
Scatter Plot Modification ...............................................................................................215
Scatter Size/Font ..............................................................................................................217
Reference Scatter Symbols ...........................................................................................218
Scatter Legends .............................................................................................................219

12 Shade Layer ............................................................................................................. 221
Shade Layer Modification .............................................................................................221

13 Translucency and Lighting ....................................................................................... 223
Translucency ..................................................................................................................223
Lighting Effects ..............................................................................................................224
Three-dimensional Light Source ...................................................................................225

14 Slices .......................................................................................................................... 227
Interactively Created Slices ..........................................................................................228
Slices Extracted Directly to Zones ..............................................................................232

15 Streamtraces ............................................................................................................ 235
Streamtrace Details dialog ...........................................................................................236
Streamtrace Animation .................................................................................................246
Surface Streamtraces on No-slip Boundaries ............................................................246
25  *Printing* ................................................................. 415
  Plot Printing ......................................................... 415
  Setup ........................................................................ 416
  Print Render Options ............................................ 419
  Print Preview ........................................................ 420

26  *Exporting* ............................................................. 421
  The Tecplot Viewer ................................................ 422
  Vector Graphics Format .......................................... 423
  Image Format .......................................................... 426
  X3D Export ............................................................. 432
  Movie Format .......................................................... 432
  Clipboard Exporting to Other Applications ............... 435
  Antialiasing Images ................................................ 436

### Scripting

27  *Introduction to Scripting* ........................................ 439

28  *Macros* ................................................................. 441
  Macro Creation ...................................................... 441
  Macro Play Back ..................................................... 443
  Macro Debugging .................................................... 445
  Moving Macros Among Computers or Directories ....... 447

29  *Batch Processing* .................................................... 449
  Batch Processing Setup .......................................... 449
  Batch Processing Using a Layout File ......................... 450
  Multiple Data File Processing .................................. 450
  Batch Processing Diagnostics ................................... 451

30  *Working With Python Scripts* ............................... 453
  Combining Python scripts with macro commands .......... 453
  Using the Python Quick Scripts Panel ....................... 454
  Running an entire Python Module .............................. 455
  Modifying the Python Path ...................................... 456
  Python Installation Notes ....................................... 456
Advanced Topics

31 Animation ........................................................................................................ 461
  Animation Tools ......................................................................................................................... 461
  Movie File Creation Manually ................................................................................................. 471
  Movie File Creation with Macros .......................................................................................... 472
  Advanced Animation Techniques ......................................................................................... 473
  Movie File Viewing ................................................................................................................... 474

32 Customization ............................................................................................................. 479
  Configuration Files .................................................................................................................. 479
  Interactive Customization ...................................................................................................... 484
  Performance Dialog ................................................................................................................. 486
  Interface Configuration (UNIX) .............................................................................................. 490
  Tecplot.phy .............................................................................................................................. 490
  Custom Character and Symbol Definition .............................................................................. 491

33 Add-ons ..................................................................................................................... 495
  Add-on Loading ....................................................................................................................... 495
  Add-ons included in the Tecplot 360 distribution ............................................................... 497
  Working with Tecplot 360 Add-ons ...................................................................................... 499

Appendices

A Command Line Options .................................................................................................. 545
  Tecplot 360 Command Line .................................................................................................. 545
  Using Command Line Options in Windows Shortcuts ...................................................... 547
  Additional Command Line Options in UNIX ....................................................................... 548

B Tecplot 360 Utilities ....................................................................................................... 549
  Excel Macro ............................................................................................................................ 549
  Framer ..................................................................................................................................... 551
  LPK View ................................................................................................................................. 552
  Preplot .................................................................................................................................... 554
  Raster Metafile to AVI (rmtoavi) ............................................................................................ 554
  Pltvew .................................................................................................................................... 555

C Shortcuts .......................................................................................................................... 557
  Keyboard Shortcuts ............................................................................................................... 557
  Extended Mouse Operations ................................................................................................. 561
D

Glossary ................................................................. 563

E

PLOT3D Function Reference ........................................ 573
  Symbols ........................................................................ 573
  Scalar Grid Quality Functions ....................................... 574
  Vector Grid Quality Functions ...................................... 577
  Scalar Flow Variables .................................................. 577
  Vector Flow Variables .................................................. 582
  The Velocity Gradient Tensor ....................................... 583

F

Limits of Tecplot 360 .................................................. 585
  Hard Limits .................................................................. 585
  Soft Limits .................................................................. 587
  Limits When Working Remotely ................................... 587
Part 1 Introduction to Tecplot 360
Introduction

Tecplot 360 is a powerful tool for visualizing a wide range of technical data. It offers line plotting, 2D and 3D surface plots in a variety of formats, and 3D volumetric visualization. The user documentation for Tecplot 360 includes these nine books:

- **User’s Manual** (this document) - This manual provides a complete description of working with Tecplot 360 features.
- **Getting Started Manual** - New Tecplot 360 users are encouraged to work through the tutorials provided in the Getting Started Manual. These tutorials highlight how to work with key features in Tecplot 360.
- **Scripting Guide** - This guide provides Macro and Python command syntax and information on working with Macro and Python files and commands.
- **Quick Reference Guide** - This guide provides syntax for zone header files, macro variables, keyboard shortcuts, and more.
- **Data Format Guide** - This guide provides information on outputting simulator data to Tecplot 360 file format.
- **Add-on Developer’s Kit - User’s Manual** - This manual provides instructions and examples for creating add-ons for Tecplot 360.
- **Add-on Developer’s Kit - Reference Manual** - This manual provides the syntax for the functions included in the add-on kit.
- **Installation Instructions** - These instructions give a detailed description of how to install Tecplot 360 on your machine.
- **Release Notes** - These notes provide information about new and/or updated Tecplot 360 features.
- **Tecplot Talk** - A user-supported forum discussing Tecplot 360, Tecplot Focus, Python scripting, Add-on development, TecIO and more. Visit www.tecplotalk.com for details.
1 - 1 Interface

Five major sections make up the Tecplot 360 interface

1 - 1.1 Menu Bar

The menu bar offers rapid access to most of Tecplot 360’s features.

Tecplot 360’s features are organized into the following menus:

- **File** - Use the File menu to read or write data files and plot layouts, print and export plots, and set configuration preferences.
- **Edit** - Use the Edit menu to select, undo, cut, copy, paste, and clear objects, open the Quick Edit dialog, and change the draw order for selected items (push or pop).
- **View** - Use the View menu to manipulate the point of view of your data, including scale, view range, and 3D rotation. You can also use the View menu to copy and paste views between frames.

Cut, Copy, and Paste work only within Tecplot 360. To place a graphic image of your layout into another program, use Copy Plot to Clipboard. This option is available on Windows® and Macintosh® platforms.

The View menu includes the following convenient sizing options:

- **Fit Everything (3D Only)** - This option resizes plots so that all data points, text, and geometries are included in the frame.
- **Fit Surfaces (3D Only)** - This option resizes plots so that all surfaces are included in the frame, excluding any volume zones.
• Fit to Full Size - This option fits the entire plot into the frame. This option does not affect the axis ranges.
• Nice Fit to Full Size - This option sets the axis range to begin and end on major axis increments (if axes are dependent, the vertical axis length is adjusted to accommodate a major tick mark).
• Data Fit - This option fits the data points to the frame.
• Make Current View Nice - This option modifies the range on a specified axis to fit the minimum and maximum of the variable assigned to that axis, and then snaps the major tick marks to the ends of the axis. (If axis dependency is not set as independent, this may affect the range on another axis.)
• Center - This option moves the plot image so that the data points are centered within the frame. (Only the data is centered; text, geometries, and the 3D axes are not considered.)

Plot - Use the Plot menu to control the style of your plots. The menu items available are dependent upon the active plot type (chosen in the Sidebar).

Insert - Use the Insert menu to add text, geometries (polylines, squares, rectangles, circles, and ellipses), or image files. If you have a 3D zone, you may also use the Insert menu to insert a slice. If the plot type is set to 2D or 3D Cartesian, you may insert a streamtrace.

Animate - Use the Animate menu to animate IJK Planes, IJK Blanking, iso-surfaces, mappings, slices, streamtraces, time, and zones.

Data - Use the Data menu to create, manipulate, and examine data. Types of data manipulation available in Tecplot 360 include zone creation, interpolation, triangulation, and creation or alteration of variables.

Frame - Use the Frame menu to create, edit, and control frames.

Options - Use the Options menu to control the attributes of your workspace, including the color map, paper grid, display options, and rulers.

Scripting - Use the Scripting menu to play or record macros, and to access the Quick Macros Panel dialog.

Tools - Use the Tools menu to launch the Quick Edit dialog or an add-on.

Analyze - Use the Analyze menu to examine grid quality, perform integrations, generate particle paths, extract flow features, and estimate numerical errors.

Help - Choose “Tecplot 360 Help” from the Help menu to get specific, complete help on features or operations within Tecplot 360. By choosing “About Tecplot 360” from this menu, you can obtain specific information about your license.

1 - 1.2 Sidebar
The Sidebar provides easy access for frequently used plot controls. The functions available in the Sidebar depend on the plot type of the active frame. For 2D or 3D Cartesian plot types, you can add or subtract zone layers, zone effects, and derived objects from your plot using the Sidebar. For line plots (XY and polar) you can add or subtract mapping layers using the Sidebar.

To customize your plot, simply:
• Select a plot type from the Plot Types drop-down menu in the Sidebar.
• Use the toggle switches to add or subtract Zone Surfaces, Zone Effects, or Derived Objects. Use the Zone Style/Mapping Style dialogs to further customize your plot by adding or subtracting
zones from specific plot layers/mappings, changing the way a zone or group of zones is displayed, or changing various plot settings.

![Figure 1-1. The Tecplot 360 Sidebar](image)

The features available in the Sidebar are dependent upon the plot type.

For 3D Cartesian plots, you may add and subtract zone layers, derived objects, and effects for your plot. You may also use the Placement Plane for positioning some 3D objects (3D plots only).

For 2D Cartesian plots (not shown), you may add and subtract zone layers and some derived objects for your plot. For field plots (3D or 2D), you may animate transient data directly from the Sidebar. For Line plots you may add and subtract map layers. XY Line plots have more available map layers than polar line plots.

**Plot Types**

The Plot Type, combined with a frame’s dataset, active layers, and their associated attributes, define a plot. Each plot type represents one view of the data. There are five plot types available:

- **3D Cartesian** - 3D plots of surfaces and volumes.
- **2D Cartesian** - 2D plots of surfaces, where the vertical and horizontal axis are both dependent variables (i.e. \( x = f(A) \) and \( y = f(A) \), where \( A \) is another variable).
- **XY Line** - Line plots of independent and dependent variables on a Cartesian grid. Typically the horizontal axis (x) is the independent variable and the y-axis a dependent variable, \( y = f(x) \).
- **Polar Line** - Line plots of independent and dependent variables on a polar grid.
- **Sketch** - Create plots without data such as drawings, flow charts, and viewgraphs.
Zone Surfaces

Zone Layers

A layer is a way of representing a frame's dataset. The complete plot is the sum of all the active layers, axes, text, geometries, and other elements added to the data plotted in the layers. The six zone layers for 2D and 3D Cartesian plot types are:

- **Mesh** - A grid of lines connecting the data points within each zone.
- **Contour** - Iso-valued lines, the region between these lines can be set to contour flooding.
- **Vector** - The direction and magnitude of vector quantities.
- **Scatter** - Symbols at the location of each data point.
- **Shade** - Used to tint each zone with a solid color, or to add light-source shading to a 3D surface plot. Used in conjunction with the Lighting zone effect you may set Paneled or Gouraud shading. Used in conjunction with the Translucency zone effect, you may create a translucent surface for your plot.
- **Edge** - Zone edges and creases for ordered data and creases for finite element data.

Zone Effects

For 3D Cartesian plot types, use the Sidebar to turn lighting and translucency on or off. Only shaded and flooded contour surface plot types are affected. Refer to Chapter 12: “Shade Layer” and Chapter 13: “Translucency and Lighting” for additional information.

Zone Style

Select the [Zone Style] button to launch the Zone Style dialog. The Zone Style dialog is used to customize the zone layers that you have added to your plot. Refer to the chapter for each zone layer for details on working with the Zone Style dialog.

Map Layers

A layer is a way of representing a frame's dataset. The complete plot is the sum of all the active layers, axes, text, geometries, and other elements added to the data plotted in the layers.

The four XY Line map layers are:

- **Lines** - Plots a pair of variables, X and Y, as a set of line segments or a fitted curve.
- **Symbols** - A pair of variables, X and Y, as individual data points represented by a symbol you specify.
- **Bars** - A pair of variables, X and Y, as a horizontal or vertical bar chart.
- **Error Bars** - Allows you to add error bars to your plot.
The two map layers for Polar Line are:

- **Lines** - A pair of variables, X and Y, as a set of line segments or a fitted curve.
- **Symbols** - A pair of variables, e.g. X and Y, as individual data points represented by a symbol you specify.

Select the [Mapping Style] button to launch the **Mapping Style** dialog. The **Mapping Style** dialog allows you to customize the style settings for each of the plot layers and specify the points to plot. The pages of the dialog are discussed in detail in Chapter 6: “XY and Polar Line Plots”.

**Derived Objects**

For Cartesian plot types (2D and 3D): Toggle-on Iso-surfaces, Slices, or Streamtraces from the Sidebar to add any or all of these elements to your plot. Their corresponding Details dialogs can be accessed via the Details [...] button. Refer to Chapter 16: “Iso-surfaces”, Chapter 14: “Slices”, or Chapter 15: “Streamtraces” for details on working with these objects.

**Transient Controls**

When working with transient data, simply press the Play button in the Sidebar to animate over time. The active frame will be animated from the Current Solution Time to the last time step. You may also drag the slider to change the Current Solution Time of your plot.

The Animation Controls have the following functions:

- \( \text{[ } \) - Jumps to the Starting Value.
- \( \text{[ } \) - Jumps toward the Starting Value by one step.
- \( \text{[ } \) - Runs the animation as specified by the ‘Operation’ field of the Time Details dialog. The Play button becomes a Stop button while the animation is playing.
- \( \text{[ } \) - Jumps toward the Ending Value by one step.
- \( \text{[ } \) - Jumps to the Ending Value.

Use the Details [...] button to launch the Time Details dialog.

**Placement Plane**

When you are using certain tools to add objects to your plot, toggle-on “Use Placement Plane” in the Sidebar to place them along a given plane (3D Plots only). Use the [X], [Y], and [Z] buttons to select the plane to use, and use the slider to reposition the Placement Plane. The Placement Plane will appear as a gray slice in your plot. The Placement Plane is available for:

- Placing streamtraces (using the Add Streamtrace Tool)
- Placing slices (using the Slice Tool)
Adding Contour Levels (using the Add Contour Level Tool)

Deleting Contour Levels (using the Remove Contour Level Tool)

Probing (using the Probing tool)

**Snap Modes**

Snap Modes allow you to place objects precisely by locking them to the nearest reference point, either on the axis grid or on the workspace paper.

- **Snap to Grid** - Constrain object movement to whole steps on the axis grid. This can be useful for aligning text and geometries with specific plot features.
- **Snap to Paper** - Constrain object movement to whole steps on the paper's ruler grid. This can be useful for positioning frames precisely for printing, or for absolute positioning of text, geometries, and other plot elements.

**Details Button**

The [Details] button is located immediately below the snap modes. It is context sensitive. Use this button to call up the dialog most directly applicable to your current action. When the currently selected tool is either the Selector or the Adjustor, but no objects are selected in the workspace, the [Details] button is labeled [Quick Edit]. Otherwise, the button is labeled **Object Details** when an object is selected and **Tool Details** when your mouse cursor is not in "selector" mode and an object is not selected.

**Object Details**

The [Object Details] button in the Sidebar calls up the dialog that most closely reflects the current state of the cursor. For example, if you select a legend and then [Object Details], the **Legend** dialog will open.

**Tool Details**

[Tool Details] calls up the dialog related to the current state of the cursor. For example, if a rotate tool is selected, [Tool Details] calls up the **3D Rotate** dialog.

**Redraw Buttons**

The redraw buttons allow you to keep your plot up to date: [Redraw All] CTRL-D redraws all frames (SHIFT-[Redraw All] completely regenerates the workspace); [Redraw] CTRL-R redraws only the active frame.

**Auto Redraw**

Use Auto Redraw - When selected, the plot will be automatically redrawn, whenever style or data changes. Some users prefer to turn this option off while setting multiple style settings and then manually press the [Redraw] or [Redraw All] button on the Sidebar to see a full plot.

You can interrupt an auto-redraw at any time with a mouse click or key press.
Cache Graphics

Tecplot 360 uses OpenGL® to render plots. OpenGL provides for the ability to cache graphic instructions for rendering and can re-render the cached graphics much faster than if Tecplot 360 sends the instructions again. This is particularly true for interactive manipulation of a plot. However, this performance potential comes at the cost of using more memory. If the memory need is too high, the overall performance could be less. There are three graphics cache modes: cache all graphics, cache only lightweight graphics objects, and do not cache graphics.

When “Cache Graphics” is selected in the Sidebar, Tecplot 360 assumes there is enough memory to generate the graphics cache. Assuming this is true, Tecplot 360’s rendering performance will be optimal for interactive manipulation of plots.

When memory constraints are very limited, consider toggling-off “Cache Graphics”. If you intend to interact with the plot, also consider setting the Plot Approximation mode set to “All Frames Always Approximated”.

See Section “Graphics Cache” on page 487 for more information.

Plot Approximations

When Plot Approximation is selected and if the number of data points is above the point threshold, an approximate plot for style, data, and interactive view changes is rendered. The approximate plot is followed immediately by the full plot. This option provides for good interactive performance with the final plot always displayed in the full representation.

See Section “Plot Approximation” on page 486 for more information.

1 - 1.3 Toolbar

Each of the tools represented in the Toolbar changes the mouse mode and allows you to interactively edit your plot.

Double-click on a tool to launch the Details dialog associated with the tool.

Selector Tool

Use the Selector tool to select objects in your workspace. The selected objects can be modified using the Quick Edit dialog and (in some cases) the Selector tool itself.

The following objects can be moved (translated) using the Selector tool:

- frames
- axis grid area
- text
- geometries
- contour labels
- streamtraces
- streamtrace termination line
- legends
- 3D frame axis
Interface

To select an object and open that object’s attributes dialog, either double-click on any object or drag the cursor to select groups of objects (calls up Group Select dialog). Select the [OK] button, then select [Object Details].

Adjustor Tool

Use the Adjustor tool to perform any of the following modifications to your plot and data:

• Location of individual or groups of data points in the grid.
• Values of the dataset variables at a particular point.
• Length or placement of individual axes (2D Cartesian and XY Line plot types only).
• Spacing between an axis label and its associated axis (2D Cartesian and XY Line plot types only).
• Shape of a polyline.

For all other scenarios, the behavior of the Adjustor mode is identical to that of the Selector tool.

To select multiple points - You can either SHIFT-click after selecting your initial point to select additional points, or you can draw a group select band to select the points within the band. (In line plots, you can select points from only one mapping at a time.)

Once you have selected all desired points, move the Adjustor over the selection handles of one of the points, then click-and-drag to the desired location of the first data point. The other selected points will move as a unit with respect to the chosen data point, maintaining their relative positions.

For XY Line plots, if several mappings are using the same data for one of the variables, adjusting one of the mappings will result in simultaneous adjustments to the others. You can avoid this by pressing the h or v key on your keyboard while adjusting the selected point. The h and v keys restrict the adjustment to the horizontal and vertical directions, respectively.

Group Select

The Group Select dialog is opened when you select a group of objects with the Selector or Adjustor tool.

The Group Select dialog allows you to specify the following object types (if the selection rectangle does not include a specific object, its associated check box is inactive):

• Text
• Geometries
• Frames
• Zones or Mappings
• Axis Grid Area
• Contour Labels
• Streamtraces

The Group Select dialog offers the following attribute filters:

• Geoms of Type - Choose geometries of a particular type from the drop-down menu.
• Geoms with Line Pattern - Choose all geometries having a particular line pattern.
• Text with Font - Choose all text displayed in a particular font.
• Objects with Color - Choose all objects of a particular color. You choose the appropriate color from the Select Color dialog.

**Zoom Tool**

Zoom into or away from the plot.

When a mouse-click occurs (without dragging), the zooming is centered at the location of your click.

There are two zoom modes: plot zooming and paper zooming.

**For plot zooming** - drag the magnifying glass cursor to draw a box around the region that you want to fit into the frame. The box may be larger than the frame. Making the box larger than the frame zooms away from the plot. The region within the view box will be resized to fit into the frame.

If Snap to Grid (located in the Sidebar) is selected, you cannot make the zoom box larger than the grid area.

To return to the previous view, choose “Last” from the View menu (CTRL-L). To restore the original 2D view, choose “Fit to Full Size (CTRL-F).”

The results of plot zooming for the 2D plot type are dependent upon the axis mode selected in the Axis Details dialog (accessed via the Plot menu):

• **2D Independent Axis Mode** - Allows the selected region to expand to exactly fit in the frame. The axes are rescaled independently to fit the zoom box.

• **2D Dependent Axis Mode** - In dependent mode, the axes are not fit perfectly to the zoom box. The longest dimension from the zoom box is applied to an associated axis, and the other axis is resized according to the dependency relation.

**For paper zooming** - SHIFT-drag the magnifying glass cursor to draw a box about the region that you want to magnify. The plot is resized so that the longest dimension of the zoom box fits into the workspace.

You can fit one or all frames to the workspace by using the “Fit Selected Frames to Workspace” or “Fit All Frames to Workspace” options from the View>Workspace menu. To return to the default paper view, choose “Fit Paper to Workspace” from the View>Workspace menu.

Clicking anywhere in your plot while the zoom tool is active will center the zoom around your click. Alternatively, CTRL-click centers the plot on the point that was clicked and zooms out.

Use the center mouse button and drag (or hold down the rollerball and drag) to interactively zoom into or out of the plot.

**Translate Tool**

Use the Translate/Magnify tool to translate or magnify data within a frame or the paper within the workspace.
While in Translate/Magnify mode, drag the cursor to move the data with respect to the frame, or SHIFT-drag to move the paper with respect to the workspace.

Use the right mouse button to interactively translate objects. You can rescale your image by pressing '+' to magnify, '-' to shrink. If you are SHIFT-dragging to move the paper, the rescale buttons '+' and '-' will magnify or shrink the paper, as long as you have the mouse button depressed.

**Three-dimensional Rotation**

There are six 3D rotation mouse modes:

- **Spherical** - Drag the mouse horizontally to rotate about the Z-axis; drag the mouse vertically to control the tilt of the Z-axis.

- **Rollerball** - Drag the mouse in a direction to move with respect to the current orientation on the screen. In this mode, your mouse acts much like a rollerball.

- **Twist** - Drag the mouse clockwise around the image to rotate the image clockwise. Drag the mouse counterclockwise around the image to rotate the image counterclockwise.

- **X-axis** - Drag the mouse to rotate the image about the X-axis.

- **Y-axis** - Drag the mouse to rotate the image about the Y-axis.

- **Z-axis** - Drag the mouse to rotate the image about the Z-axis.

Once you have selected a rotation mouse mode, you can quickly switch to any of the others using the following keyboard shortcuts:

<table>
<thead>
<tr>
<th>Key Sequence</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drag</td>
<td>Rotate about the defined rotation origin with your current Rotate tool.</td>
</tr>
<tr>
<td>ALT-drag</td>
<td>Rotate about the viewer position using your current Rotate tool.</td>
</tr>
<tr>
<td>Middle-click-and-drag/ALT-right-click-and-drag</td>
<td>Smooth zoom in and out of the data.</td>
</tr>
<tr>
<td>Right-click-and-drag</td>
<td>Translate the data.</td>
</tr>
<tr>
<td>CTRL-right-click-and-drag</td>
<td>This option can be used without first selecting a rotation mouse mode. Simply hover over your intended point of origin, and then CTRL-right-click-and-drag to translate the image.</td>
</tr>
<tr>
<td>C</td>
<td>Move rotation origin to probed point, ignoring zones.</td>
</tr>
</tbody>
</table>
Slice Tool

Use the Slicing tool to add a slice interactively by clicking anywhere in your plot. You can also use this tool to control your slice(s) interactively.

The following keyboard/mouse options are available when the Slice tool is active:

<table>
<thead>
<tr>
<th>Key</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>Move rotation origin to probed point of data. This shortcut can be used without first selecting a rotation mouse mode. Simply hover over your intended point of origin, type O, and then CTRL-right-click-and-drag to rotate the image.</td>
</tr>
<tr>
<td>R</td>
<td>Switch to Rollerball rotation.</td>
</tr>
<tr>
<td>S</td>
<td>Switch to Spherical rotation.</td>
</tr>
<tr>
<td>T</td>
<td>Switch to Twist rotation.</td>
</tr>
<tr>
<td>X</td>
<td>Switch to X-axis rotation.</td>
</tr>
<tr>
<td>Y</td>
<td>Switch to Y-axis rotation.</td>
</tr>
<tr>
<td>Z</td>
<td>Switch to Z-axis rotation.</td>
</tr>
<tr>
<td>+</td>
<td>Primary Slices, Start End Slices Active - Turn on intermediate slices (if not already active) and adds a slice. Primary Slices active [ONLY] - Turns on Start/End Slices and adds a slice. Start/End Slices active [ONLY] - Turns on Start/End Slices and adds a slice.</td>
</tr>
<tr>
<td>-</td>
<td>Primary Slices, Start End Slices Active - Removes start and end slices. Primary Slices active [ONLY] - Removes the primary slice. Start/End Slices active [ONLY] - Removes the Start and End Slices.</td>
</tr>
<tr>
<td>Click/Drag</td>
<td>Updates the position of the primary slice (if active). If only start and end slices are visible, click updates the position of the starting slice.</td>
</tr>
<tr>
<td>ALT-click/ALT-drag</td>
<td>Determine the XYZ-location by ignoring zones and looking only at derived volume objects (streamtraces, slices, iso-surfaces).</td>
</tr>
<tr>
<td>SHIFT-click</td>
<td>Switches from one Primary slice to Start/End Slices by adding a slice.</td>
</tr>
<tr>
<td>SHIFT-drag</td>
<td>Move the start or end slice (whichever is closest to the initial click location). Show Start/End Slices is activated, if necessary.</td>
</tr>
<tr>
<td>I, J, K (ordered zones only)</td>
<td>Switch to slicing constant I, J, or K-planes respectively.</td>
</tr>
<tr>
<td>X, Y, Z</td>
<td>Switch to slicing constant X, Y, or Z-planes respectively.</td>
</tr>
<tr>
<td>1-8</td>
<td>Numbers one through eight switch to the corresponding slice group.</td>
</tr>
</tbody>
</table>
Add Streamtrace

Select the Add Streamtrace tool to add a streamtrace interactively by clicking anywhere in your plot. Select the number of streamtraces to include with each click (rake) using 1-9 on the keyboard.

**Keyboard Shortcuts**

- D Switch to streamrods
- S Switch to streamribbons
- S Switch to surface lines
- V Switch to volume lines
- 1-9 Change the number of streamtraces to be added when placing a rake of streamtraces
- SHIFT - Draws a rake on concave 3D volume surfaces. These rakes are normally not drawn, as they occur outside of the data

Refer to Chapter 15: “Streamtraces” for more information.

Streamtrace Termination Line

Select the Add Streamtrace Termination Line tool to add a streamtrace termination line interactively.

To draw a Streamtrace Termination Line:

- Move the cursor into the data region.
- Click once at the desired starting point for the line.
- Click again at each desired break point.
- When the polyline is complete, double-click on the last point of the polyline, or press ESC on your keyboard.
- The drawn polyline ends any streamtraces that pass through it.

Add Contour Level

Select the Add Contour Level tool to add a contour level by clicking anywhere in the active data region. A new contour level, passing through the specified location, is calculated and drawn.

The following keyboard and mouse shortcuts are related to the Add Contour Level tool.

<table>
<thead>
<tr>
<th>Modifier</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT-click</td>
<td>Place a contour line by probing on a streamtrace, slice, or iso-surface.</td>
</tr>
<tr>
<td>Click</td>
<td>Place a contour line.</td>
</tr>
<tr>
<td>CTRL-Click</td>
<td>Replace the nearest contour line with a new line.</td>
</tr>
<tr>
<td>Drag</td>
<td>Move the new contour line.</td>
</tr>
<tr>
<td></td>
<td>Switch to the Delete Contour Level tool.</td>
</tr>
</tbody>
</table>
**Delete Contour Level**

Select the Delete Contour Level tool to delete a contour level by clicking anywhere in the active data region. The contour line nearest the specified location is deleted.

Use the "+" key to switch to the Add Contour Level tool and the "-" key to switch back to the Delete Contour Level tool.

**Add Contour Labels**

Select the Add Contour Label tool to switch to the Contour Label mode, enabling you to add a contour label by clicking anywhere in the active data region.

A contour label is added to the plot at the specified location; its level or value information is taken from the nearest contour line. This allows you to place labels at a slight offset from the lines they label.

The Contour type must be lines or lines and flood in order for this tool to be active. You can set the contour type on the Contour page of the Zone Style dialog.

**Probe Tool**

Select the Probe At Tool to probe for values of the dataset’s variables at a particular point.

To obtain interpolated values of the dataset variables at the specified location, click at any point in the data region.

To obtain exact values for the data point nearest the specified location, CTRL-click at the desired location.

For XY plots, when you move into the axis grid area, the cursor cross hair is augmented by a vertical or horizontal line, depending on whether you are probing along the X-axis or the Y-axis. You can change the axis to probe simply by pressing X to probe the X-axis or Y to probe the Y-axis.

**Insert Text**

Select the Add Text tool to add text to any frame.

**Insert Geometries**

Use the corresponding geometry buttons in the Toolbar to insert geometries into your plot.

- Polylines
- Squares
- Rectangles
- Circle
- Ellipse
Create New Frame
Select the Create Frame tool to create a new frame.
To add a frame:
- Click once in the workspace to anchor one corner of the frame.
- Drag the diagonal corner until the frame is the desired size and shape.

If you have data loaded before you create a new frame, you can attach the existing dataset to the new frame by changing the plot type.

Extract Discrete Points
Select the Extract Discrete Points tool to extract selected points to a data file or a new zone.
To select points:
- Click your left-hand mouse button at each location where you would like to extract a point.
- To end extraction, either double-click on the last point, or right click, or press the ESC key.
- The Extract Data Points dialog appears; use it to specify how many points to extract and how to save the data.

Extract Points along Polyline
Select the Extract Line tool to extract points along a specified polyline to a data file or a new zone.
To select points:
- Click your left-hand mouse button at each location where you would like to extract a point.
- To end extraction, either double-click on the last point, or right click, or press the ESC key.
- The Extract Data Points dialog appears; use it to specify how many points to extract and how to save the data.

Create Rectangular Zone
Select the Create Rectangular Zone tool to add 2D rectangular zones to the active dataset.
To create a rectangular zone:
- Click once in the active data region to anchor one corner of the zone.
- Drag the diagonal corner until the zone is the desired size and shape. The new zone created is IJ-ordered.
To specify the maximum I-index and J-index, use the Create Rectangular Zone dialog (accessed via Data>Create Zone).

Create Circular Zone
Select the Create Circular Zone tool to add new 2D circular zones to the active dataset.
To create a circular zone:

- Click once in the active data region to specify the center of the zone.
- Drag until the zone has the desired radius. The new zone created is IJ-ordered.

To specify the maximum I-index and J-index, use the Create Circular Zone dialog (accessed via Data>Create Zone).

The active frame must have a dataset attached to it in order for the Create Circular Zone tool to be active. This tool is available in 2D plots only.

1 - 1.4 Status Line

The status line appears along the bottom of the Tecplot 360 window to give “hover help”, as well as a progress bar and information when Tecplot 360 computes calculations. The hover help appears when you move the pointer over a tool in the Toolbar, a button or item in the sidebar, or a menu item, and gives a description of the control.

A progress bar and information about the calculation Tecplot 360 is completing appears in the status line during lengthy calculations or other longer operations.

1 - 1.5 Tecplot 360 Workspace

In the Tecplot 360 workspace, you can create sketches and plots. You can create each sketch or plot within a window called a frame. Each visible measure of the workspace is called a page. The current state of the workspace, including the sizing and positioning of frames, the number and contents of pages, the location of the data files used by each frame, and all current attributes for all frames, makes up a layout. By default, the workspace displays a representation of where the paper plots are drawn, as well as a reference grid and rulers. The frame most recently selected is called the active frame.

You can include multiple pages in your layout. To create a new page, modify pages or move between them, use the Quick Macro Panel. See Section 28 - 2.1 "Quick Macro Panel" for more information about the panel.
1 - 1.6 Quick Edit

The map and zone layer controls affecting how the individual layers are drawn can be altered using controls on the Sidebar. You can also control many of these attributes using the Quick Edit dialog.

The Quick Edit dialog is accessed via the [Quick Edit] button located at the bottom of the Sidebar when the mouse-mode is a standard arrow (i.e. you are using either the Selector Tool or Adjustor Tool). If you are in a different mouse mode, or you have selected a Text or Geometry object, the Object Details or Tool Details will be launched in lieu of the Quick Edit dialog.

To use the Quick Edit dialog, select one or more objects in the workspace, then select the appropriate button in the dialog to change the attributes of the selected object(s). The functionality of each button is described in the following sections.

Mesh

This area of the Quick Edit dialog controls whether the mesh is displayed for selected zones, and if so, using which types of mesh. The following options are available:

- **Y** - Show the mesh for the selected zones. The first time you turn on the Mesh layer by either the Quick Edit dialog or the Zone Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.
- **N** - Turn off the mesh for the selected zones.
Wire Frame - Mesh lines are drawn underlying all other field layers (i.e., Contour, Vector, Scatter, Shade); hidden lines are not removed.

Overlay - Mesh lines are drawn above all other field plot layers except vectors and scatter symbols.

Hidden - Similar to Overlay, except that in the 3D Cartesian, plot type hidden lines are removed from behind the mesh. In essence, the cells of the mesh are opaque. Surfaces and lines that are hidden behind another surface are removed from the plot.

Contour

This area of the Quick Edit dialog controls whether contours are displayed for selected zones, and if so, using which plot type. The following options are available:

- Y - Show the contours for the selected zones. The first time you turn on the Contour layer by either the Quick Edit dialog or the Zone Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.
- N - Turn off the contour for the selected zones.
- Lines - Plots contour lines. If you choose this plot type, you can use the Cont Color attribute to specify Multi-Color to make the line color vary with the contour-variable value.
- Flood - Flood the area between adjacent contour lines with a color according to the value of the contour variable, number of contour levels, and the Color Map.
- Both Lines and Flood - Contour lines are drawn with color flooding between them.
- Average Cell - Each cell or element is flooded with one solid color based upon the average value of the contour variable at the data points of the cell or element.
- Primary Value - Each cell or element is flooded with one solid color based upon the primary cell value.

Vector

This area of the Quick Edit dialog controls whether vectors are displayed for selected zones, and if so, using which plot type. The following options are available:

- Y - Show the vectors for the selected zones. The first time you turn on the Vector layer by either the Quick Edit dialog or the Zone Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.
- N - Turn off the vectors for the selected zones.
- Tail at Point - Display regular vectors – a simple stick vector with length proportional to the local magnitude. The tail of the vector is positioned at the data point.
• **Head at Point** - Display regular vectors – a simple stick vector with length proportional to the local velocity magnitude (the square root of the sum of the squares of the vector components). The head of the vector is positioned at the data point.

• **Anchor at Midpoint** - Display regular vectors – a simple stick vector with length proportional to the local velocity magnitude. The midpoint of the vector is positioned at the data point.

• **Head Only** - Display vectors as heads only, without the vector shaft.

### Scatter

This area of the Quick Edit dialog controls whether scatter symbols are displayed for selected zones, and if so, whether to use plain or filled symbols. The following options are available:

- **Y** - Show the scatter symbols for the selected zones. The first time you turn on the Scatter layer by either the Quick Edit dialog or the Zone Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.
- **N** - Turn off the scatter symbols for the selected zones.
- **Plain** - Use un-filled symbols for the scatter plot.
- **Filled** - Use filled symbols for the scatter plot.

### Shade

This area of the Quick Edit dialog controls whether shading is used for selected zones. This option allows you to turn off just the Shade layer for specific zones, without completely deactivating the zones. The following options are available:

- **Y** - Show light-source shading for the selected zones. The first time you turn on the Shade layer by either the Quick Edit dialog or the Zone Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.
- **N** - Turn off light-source shading for the selected zones.

### Edge Border

This area of the Quick Edit dialog controls whether the zone edge border is displayed for selected ordered zones, and if so, what edge type. The following options are available:

- **Y** - Show edges borders for the selected zones. The first time you turn on the Edge layer by either the Quick Edit dialog or the Zone Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.
- **N** - Turn off edges for the selected zones.
- **Show Entire Border** - Shows border lines on all boundaries of the selected zone(s).
- **Show Border Line** - Shows the edge border line closest to the selected point.

- **Hide Border Line** - Hides the edge border line that is closest to the selected point.

- **Show Only Nearest Border Line** - Shows only the edge border line that is closest to the selected point and hides all others.

  The first time you turn on the Line layer by either the Quick Edit dialog or the Mapping Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.

### Symbols Mapping Layer

This area of the Quick Edit dialog controls whether symbols are plotted at each data point, and whether those symbols are filled or plain. The following options are available:

- **Y** - Show the symbol plots for the selected maps. The first time you turn on the Symbols layer by either the Quick Edit dialog or the Mapping Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.

- **N** - Turn off the symbol plots for the selected maps.

- **Plain** - Use un-filled symbols for the scatter plot.

- **Filled** - Use filled symbols for the scatter plot.

### XY Error Bars Mapping Layer

This area of the Quick Edit dialog controls whether error bars are displayed for the selected mappings, and in which direction the error bars are drawn. The options are:

- **Y** - Show the error bars for the selected maps. The first time you turn on the Error Bars layer by either the Quick Edit dialog or the Mapping Style dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.

- **N** - Turn off the error bars for the selected maps.

- **Top** - Error bar extends upward for positive values (and downward for negative values) of the error bar variable.

- **Bottom** - Error bar extends downward for positive values (and upward for negative values) of the error bar variable.

- **Left** - Error bar extends to the left for positive values (and to the right for negative values) of the error bar variable.

- **Right** - Error bar extends to the right for positive values (and to the left for negative values) of the error bar variable.

- **Horizontal** - Error bar extends both left and right.
Interface

- **Vertical** - Error bar extends both up and down.
- **Cross** - Error bar extends up, down, left, and right.

**Bars Mapping Layer**

This area of the **Quick Edit** dialog controls whether bars are plotted to represent each data point, and whether those bars are filled or plain.

- **Y** - Show the selected maps as bar charts. The first time you turn on the Bars layer by either the **Quick Edit** dialog or the **Zone Style** dialog, a dialog appears asking if you wish it activated. Select [Yes] to confirm turning on the layer.
- **N** - Turn off bar charting for the selected maps.
- **Plain** - Use un-filled bars for the bar chart.
- **Filled** - Use filled bars for the bar chart.

**Color**

This area of the **Quick Edit** dialog controls color options for filled objects, lines, and text.

- **Object-type** - Use the Fill, Line, and Text radio buttons to identify the object-type to modify.
- **Color** - Select the [Color] button to activate the **Select Color** dialog. **Multi** color is not available for line plots.
- **X** button - The behavior of the [X] button depends on the object-type selected.
  - **Fill** - [X] turns off the fill color.
  - **Line** - [X] causes the line color to match the fill color. If no fill color is specified, the [X] button has no effect.
  - **Text** - [X] has no effect.

**Symbols**

Use this region of the **Quick Edit** dialog to change the symbol for the Scatter Zone layer or Symbols Map layer.

Use the [Size] button to specify the size of the scatter symbols as a percentage of the frame width (in the 2D Cartesian plot type) or of the median-axis length (in the 3D Cartesian plot type).
**Line Pattern**

This area of the Quick Edit dialog controls the line pattern, pattern length, and line thickness for all selected objects.

- **Line Pttrn** - Choose the line pattern for the selected zones.
- **Pttrn Lngth** - Specify the pattern length for the selected line pattern, as a percentage of the frame width.
- **Line Thcknss** - Specify the line thickness for the vectors as a percentage of the frame width.

**Arrows**

This area of the Quick Edit dialog controls arrowhead placement on polylines.

**Arrowheads**

This area of the Quick Edit dialog controls the type, size, and angle of arrowhead for both selected vectors and selected polylines and vectors. The following options are available:

- **Head Style** - Choose the vector head style for the selected zones. The following options are available:
  - **Plain** - Display arrowheads as lines drawn from the head of the vector.
  - **Filled** - Display arrowheads as filled triangles at the end of each vector.
  - **Hollow** - Display arrowheads as hollow triangles at the end of each vector.
- **Size** - Specify the size of the arrowhead as a percentage of frame height.
- **Angle (deg)** - Specify the angle between the vector and the arrowhead.
- **Enter Value** - For both the [Size] and [Angle] buttons, you can choose “Enter” and type in an exact percentage in the Enter Value dialog.

**Font**

This area of the Quick Edit dialog controls the font family and size used for selected text. (See Section 18.1.2 “Font Folders and Fallback” on page 273 for more information on how fonts work with Tecplot 360.)

The following options are available:

- **Font menu** - Select the font family.
- **B, I, R** - Select the boldface, italic, bold/italic, or regular version of the font.
- **Size (%)** - Specify the height for the text in frame units (i.e. as a percentage of frame height).
- **Size (pt)** - Specify the height for the text in points.
Getting Help

Order and Alignment

Use the Order and Alignment buttons of the Quick Edit dialog to align text within textboxes or the alignment between selected geometries/textboxes.

- **Left, Center, or Right** - Use the Left, Center, or Right alignment buttons to align text.

- **Top or Bottom** - Use the Top or Bottom alignment buttons to align selected geometries and text with respect to one another.

- **Push** - Use the Push button to push the selected geometries, frames, or text to the bottom of the draw order. If you select frames including the active frame and use the [Push] button, Tecplot 360 will activate the new topmost frame. Otherwise, the [Push] button will not affect the active frame.

- **Pop** - Use the Pop button to pop the selected geometries or text to the top of the draw order. If you select inactive frames and use the [Pop] button, Tecplot 360 will activate the newest topmost frame. Otherwise, the [Pop] button will not affect the active frame.

For more information about active frames, see Section 2 - 3.1 “The Active Frame Receives All Actions”.

1 - 2 Getting Help

Tecplot 360 features a fully integrated Help system. Quick help on menu items and Sidebar controls is available from the status line or tool tips.

Detailed help is accessible by:

- Pressing the F1 key anywhere in the Tecplot 360 window. If the pointer is over the Sidebar, Quick Edit dialog, or a menu, the F1 key provides context-sensitive help on that control or menu. Otherwise, F1 calls up the Contents page of Help via your Web browser.

- Selecting “Contents” from the Help menu.

- Selecting Help on any dialog.

The Help dialog supports text search, has hypertext links, and provides detailed information on all menus and dialogs.

Your answer may be in Technical Support Notes at www.tecplot.com/support.

If you are covered by Tecplot's Software Maintenance Service, help is also available from 6:30 A.M. to 5 P.M. Pacific Standard Time from Tecplot Technical Support at 425.653.9393.

You may also send an e-mail to support@tecplot.com with your questions.
Using the Workspace

This chapter discusses the structures and features of Tecplot 360 that act the same regardless of the data type or plot layers you are using. These include:

- **Data Hierarchy** - How Tecplot 360 manages data
- **Interface Coordinate Systems** - Tecplot 360’s use of different coordinate systems, and when and where they occur
- **Frames** - Areas in the workspace in which you can create plots and control formatting
- **Workspace Management Options Menu** - Factors that determine the color and orientation of your paper, as well as the ruler and grid, in order to precisely size and position objects. For in-depth information on Display Performance, refer to Section 32 - 3 “Performance Dialog”
- **View Modification** - The commands to zoom, translate, and fit plots within frames
- **Edit Menu** - The commands to cut or copy plot elements from a workspace, and the command to paste plot elements

### 2 - 1 Data Hierarchy

Tecplot 360 structures data in two levels: datasets, which display in frames, and zones, which make up a dataset. Each dataset is composed of one or more zones, and each zone contains one or more variables. All zones within a dataset contain the same set of variables.
This chart, Figure 2-1, displays a visual representation of Tecplot 360's method of data hierarchy.

Figure 2-1. Data Hierarchy in Tecplot 360. Frames 1 & 2 display Dataset 1, and Dataset 1 contains three zones from one data file. Frame 3 contains Dataset 2, which is composed of five zones (two from data file 2 and three from data file 3).

2 - 1.1 Data Displays in Frames
Tecplot 360 always displays data in a window called a “frame”. By default, Tecplot 360 opens one frame when you launch Tecplot 360 or open a new layout, but you can display multiple plots concurrently in Tecplot 360 by adding additional frames. You can add frames to the workspace using the Frame menu. You can display one dataset in one frame, or you can share one dataset between multiple frames. Using the same dataset in multiple frames allows you to generate different plots of the same data. To learn more about working with frames, go to Section 2 - 3 “Frames”.

2 - 1.2 A Dataset Includes All Data in a Frame
A dataset is defined as “all of the data in a frame”. To create a dataset, load one or more data files into an empty frame in Tecplot 360, or create a zone in a frame.

2 - 1.3 Datasets Are Made of Zones
A zone represents a subset of a dataset. A dataset can be composed of a single zone or several zones. Zones are either defined in the data file or created directly in Tecplot 360. The number of zones in a dataset is the sum of the number of zones in each of the data files included in the dataset.

Typically, a data file is divided into zones based on its physical coordinates. For example, a dataset of an airplane may consist of a zone for each wing, each wheel, the nose, etc. Alternatively, zones may be
defined based on the material. For example, a dataset of a fluid tank may have a zone for the tank itself and additional zones for each fluid inside the tank.

All zones in a given dataset must have the same variables defined for each data point.

2 - 2 Interface Coordinate Systems

Tecplot 360 incorporates a number of coordinate systems, including the paper, frame, and the physical coordinate systems for the plot (2D, 3D, XY, or Polar). The origins of each coordinate system and their relationship to one another is shown in Figure 2-2.

Figure 2-2. Tecplot 360 Coordinate System. The physical coordinate system(s) of the dataset (for example, 3D Cartesian or 2D Cartesian) are encompassed in the Frame Coordinate System.

The physical coordinate system (2D or 3D) depends on the plot type of the active frame. Two-dimensional physical coordinates are often referred to as grid coordinates. The Grid coordinate system is aligned with the coordinate system used by the plot axes; the Frame coordinate system is fixed to the frame and does not change when the plot is zoomed, translated, or rotated.

In 2D Cartesian plots, objects such as text labels and geometries are drawn in either the Frame or the Grid coordinate system. In 3D Cartesian plots, these objects are drawn in either the Frame coordinate system, or in what is known as the Eye coordinate system. The eye coordinate system is aligned with the Grid coordinate system; so objects drawn in the Eye coordinate system move with the data as you zoom and translate, but remain fixed when you rotate the plot.
Figure 2-3 shows a 3D volume plot with streamribbons and a streamtrace termination line. This figure illustrates how the termination points vary as the plot is rotated. Notice that the termination line itself remains in place on the screen as the plot is rotated.

Figure 2-3. Rotating Volume streamtraces with a termination line in the eye coordinate system.

2 - 3 Frames

All plots and sketches display within frames. By default, the Tecplot 360 workspace contains one frame. You may add additional frames, resize and reposition frames, modify background color, and specify border and header appearance. Tecplot 360 acts upon only one frame, the The Active Frame Receives All Actions, at any given time (except when frames are linked). The active frame displays with a darker and thicker border than the inactive frames so that if you display multiple frames, you can easily see which frame is active.

Tecplot 360 uses the height of the frame for objects scaled by frame units, such as font size. When you enter a frame unit value into a dialog or when you set frame size and position on the paper, you may specify a different unit system (inches, points, centimeters, or pixels). Tecplot 360 automatically converts the values into frame units.

2 - 3.1 The Active Frame Receives All Actions

The active frame, indicated by default with a darker and thicker border, is the frame in your workspace which operations affect. To make a frame the active frame, select anywhere inside that frame with your Selector tool (or any other tool except the Create New Frame tool). Reference the following sections for additional actions you can perform on frames.

2 - 3.2 Frame Creation

To create a new frame, which you can use to display a new dataset or another view of an already-loaded data set, select the New Frame button in the toolbar. Or select “Create New Frame” from the Frame menu. Selecting either the New Frame tool or “Create New Frame” in the Frame menu will change your selector tool into a small “+” symbol. Click with this tool in your workspace where you want one corner of your new frame, and drag across the workspace to where you would like the opposite corner of your new frame.

Tecplot 360 will automatically make the new frame the active frame.
Frames

For optimal printing of your plot(s), draw frames that sit completely within the paper displayed in the workspace. To view the paper coordinate system (to easily arrange frames for printing), go to Options>Paper Setup and toggle-on "Show Paper on Screen". See Section 3.6 "Create Multiple Frames" for information on simultaneously creating multiple frames.

2 - 3.3 Edit Active Frame

The Edit Active Frame dialog (accessed from the Frame menu) allows you to adjust the dimensions and style of your active frame. When you are working with multiple frames, select a frame with your selector tool to make that frame active. Then select "Edit Active Frame" from the Frame menu to adjust the position and properties of that frame.

Frame Dimensions

You can size and position a frame by several methods. To use only your mouse, select the frame to activate the resizing toggles (black boxes on the edges and corners of the frame). Click and drag on a resizing toggle to resize a frame, or click and drag on an edge in a location without a resizing toggle to change the frame location. To specify size or position with a dialog, select "Edit Active Frame" from the Frame menu. To have Tecplot 360 resize frames for you, choose "Fit all Frames to Paper" from the Frame menu.
In the Edit Active Frame dialog, you may specify the exact location for the frame's left and top sides, along with width and height.

- **Left Side** - Left edge of the frame, relative to the workspace
- **Top Side** - Top edge of the frame, relative to the workspace
- **Width** - Width of the frame (coordinates are: left side to left side + width).
- **Height** - Height of the frame (coordinates are: top side to top side - height).

The units in the Frame Dimensions region of the dialog are based on the units set for the Ruler Spacing in Options>Ruler/Grid.

You may also use the mouse or the arrow keys to resize and position frames. Click anywhere on a frame’s header or border to activate resizing handles for the frame. To scale frames proportionally (maintaining the vertical to horizontal aspect ratio) select the frames, then press “+” on your keyboard to enlarge or “-” to reduce.

After selecting frames, you may position them using the arrow keys on your keyboard. You can move frames up, down, left, or right in one-pixel increments for precise location.

To fit the active frame to the entire printable region of the paper (landscape orientation), set Left Side=0.127, Top Side=0.125, Width=10.75, and Height=8.25. Or, set Width=8.25 and Height=10.75 for portrait orientation. The pink border viewed when “Show Paper on Screen” is toggled on in Options>Paper Setup marks the printable region of the paper.

**Frame Border and Header Controls**

Use the Edit Active Frame dialog (accessed from the Frame menu) to adjust the frame border or header.

Toggling-off “Show Border” makes the frame border invisible. To show a dashed line for invisible borders, go to Options>Show Invisible Frame Borders. Use the Thickness box in the Edit Active Frame dialog to adjust the line thickness of the border.

Remember that Tecplot 360 uses a thicker border to indicate the The Active Frame Receives All Actions, so if you change border settings, it may become difficult to determine which frame you have active.

The frame header displays when both “Show Border” and “Show Header” are toggled-on. If you turn off the border by toggling-off “Show Border”, the header turns off as well.

The frame header contains user-configurable information which defaults to:

```
&A(FrameName) | &A(date) | &A(DataSetTitle)
```

where FrameName is the frame’s name, date is the date the frame was created or revised, and DataSetTitle is the title of the active dataset. You can change these defaults in your configuration file; see the $GLOBALFRAME command in the Scripting Guide.
**Frame Background Color Modification**

Select the Color box in the **Edit Active Frame** dialog (accessed from the **Frame** menu) to adjust the frame background color. Toggle-off “Show Background” to set the frame background to transparent.

When you select a background color, a Question dialog will appear to ask you whether you would like to modify all other basic color styles that match the frame background by default. Basic color styles include, but are not limited to, axis, text, vectors, and edges (layer, edges on slices, scatter). When inverting the background color from black to white (or white to black), the dialog will ask whether to invert the colors for other objects as well (for example, text or gridlines).

Selecting “Yes” in this dialog will modify the following features:

- For all line type basic colors that match the new basic frame color, the basic line color will be set to the best show color of the basic frame color.
- For all fill type basic colors that match the new basic frame color, the fill color will be set to the best show color of new frame color.

Exceptions:

- For geometries and text boxes - If the line and fill colors are the same and filling is active, then both lines and fill follow the fill rules above.
- For zone, slice, iso-surface, and streamtrace object types - The basic color shading (fill) only follows the fill rules above if lighting effects are not being used.

**Frame Name Modification**

Enter text in the Frame Name region of the **Edit Active Frame** dialog (accessed from the **Frame** menu) to change the name of the active frame. The text entered here will display as the name of the frame.

2 - 3.4 **Frame Linking**

The **Set Links for Active Frame** dialog allows you to link specific style attributes either between frames or within a frame. Linking between frames, on the Between Frames page of the dialog, allows you to quickly make changes in one frame and propagate them to a number of other frames. Linking within frames, on the Within Frame page, links attributes between similar objects within a frame.
Attribute Linking Between Frames

Use the Between Frames page of the Set Links for Active Frame dialog (accessed from Frame-Frame Linking) to link the following attributes (shown below):

- **Frame Size and Position** - Use this option to overlay transparent frames. (See Section “Frame Background Color Modification” on page 43.)
- **Solution Time** - All frames display the same solution time.
- **X-Axis Range, Y-Axis Range** (For XY Line and 2D plots) - Links the X-Axis or Y-Axis range and the positioning of the left and right sides of the viewport.
- **XY-Axis Position** (For XY Line and 2D plots) - Links the positioning of the X and Y-Axes between frames, including the method used for positioning the axes, such as aligning with an opposing axis value.
- **Polar Plot View** - Link views for frames using the Polar Line plot type.
- **3D Plot View** - Link the 3D axes and 3D view.
- **Slice Positions** - Link slice positions and slice planes for active slices (not slice style).
- **Iso-Surface Locations** - Link iso-surface values (but not iso-surface plot style).
- **Contour Levels** - Link the values and number of contour levels for 2D and 3D plots.
- **Value Blanking Constraints** - Link all value-blanking attributes.

It is not necessary to close and reopen the dialog between frames. Simply select another frame with the dialog open to change the newly active frame.

Frame Linking Groups

You can segregate frames into groups so that only frames in that group receive changes made in the linked attributes. By default, all frames are added to Group 1. Add a frame to a group by selecting the appropriate group number from the “Frame is a Member of” drop-down menu on the Between Frames page of the Set.
**Frames**

**Links for Active Frame** dialog. You can assign frames to groups 1-20. New frames added to a group take on the characteristics of previous members of the group.

![Diagram](image)

Figure 2-4. Five frames in two groups with different linking options.

**Propagating Between Frame Link Attributes to Other Frames**

Once link attributes are set in a frame group, you must set these same attributes in other frames for linking to occur. Each frame may have each of the attributes selected or not linked. If you want all or a select group of frames to have the same link attributes, select the appropriate [Apply Settings to All Frames] button to quickly propagate the link settings. Alternatively, you can select each frame individually, making the same selections on the Set Links for Active Frame dialog for each chosen frame.

When 2D or XY Line frames have dependent axes and these axis ranges are linked, a "best-fit" attempt is made to match the axis ranges between frames. Misalignments can occur when the aspect ratios for the lengths of the axes is not the same between two frames with linked X and Y-axes. Setting the X and Y-axes to be independent allows a precise match.

Keep in mind, Within-Frame Linking only links attributes between similar objects within a frame. These attributes are not linked to other frames. The [Apply Settings] buttons turn on the same Within-Frame Linking properties in other frames.
**Attribute Linking Within A Frame**

The Within Frame page of the Set Links for Active Frame dialog (shown below) allows you to link the following attributes:

![Set Links for Active Frame dialog]

- **Axis Style** - Link activation, colors, line styles, and font styles for objects associated with axes.
- **Gridline Style** - Link activation, colors, and line styles for gridlines.
- **Zone/Map Color between Plot Layers** - Link the color of meshes, contour lines, and other zone layers for Cartesian plots, or link the color of lines, symbols, and other map layers for line plots.
- **Zone Line Pattern between Plot Layers** - Link line pattern style and length for meshes, vector, and contour lines for Cartesian plots.

**2 - 3.5 Frame Deletion**

Delete the active frame by going to Frame>Delete Active Frame, or by selecting the frame and then going to Edit>Clear or pressing the Delete key. (If you have another tool active with your mouse, you will need to change to the Selector Tool to select a frame.)

To delete a group of frames, click and drag the mouse to encompass a group of frames, toggle-on "Frames" in the Objects region of the Group Select dialog, and use either Edit>Clear or the Delete key to delete the selected group of frames.

**2 - 3.6 Pop Active Frame**

To move the active frame to the top of the frame drawing order, select “Pop Active Frame” from the Frame menu. The active frame will display in front of all other frames. If the active frame is already at the top (or if you have only one frame), this action will have no effect.

You can also move your active frame to the front by selecting it again (after selecting it to make it active). Use Edit>Undo to get back to the prior frame order.

**2 - 3.7 Push Active Frame**

To move the active frame to the bottom of the frame drawing order, select “Push Active Frame” from the Frame menu. The active frame will display behind all other frames. If the active frame is already at the bottom (or if you have only one frame), this action will have no effect.
2 - 3.8 Push Top Frame
To move the top-most (front-most) frame to the bottom of the drawing order, select “Push Top Frame” from the Frame menu. This will move the frame displayed in front of all other frames to display behind all other frames. If you have only one frame in your workspace, this action will have no effect.

2 - 3.9 Activate Next Frame
To change the active frame to the next one up in the frame drawing order (or to the bottom frame if the active frame is at the top), select “Activate Next Frame” from the Frame menu. This action will not rearrange the frame drawing order. If you have only one frame in your workspace, this action will have no effect.

2 - 3.10 Activate Previous Frame
To change the active frame to the next frame down in the frame drawing order (or to the topmost frame, if the active frame is at the bottom of the frame drawing order), select “Previous Active Frame” from the Frame menu. This action will not rearrange the frame drawing order. If you have only one frame in your workspace, this action will have no effect.

2 - 3.11 Activate Top Frame
To make the frame that displays in front of all other frames active, select “Activate Top Frame” from the Frame menu. This action will not rearrange the frame drawing order. If you already have the top frame active (or if you have only one frame in your workspace), this action will have no effect.

2 - 3.12 Order Frames
Use the Order Frames dialog (accessed from the Frame menu) to rearrange the frame drawing order, with the buttons included in the dialog. To rearrange your frames, select a frame in the dialog, and then select a button to act on that frame.
- Pop Select [Pop] to move the selected frame to display in front of all other frames.
- Push Select [Push] to move the selected frame to display behind all other frames.
- Activate Select [Activate] to make the selected frame the active frame. This button does not rearrange the frame drawing order.

You can also double-click a frame in the list to pop that frame to display in front of all other frames.

To sort the frame list by name or by the order in which the frames were created, use the drop-down List By menu at the top of the dialog.

2 - 3.13 Fit All Frames to Paper
To resize all frames proportionally so that one dimension, either the horizontal or the vertical dimension, is exactly filled, select “Fit All Frames to Paper” in the Frame menu. This action preserves the relative size and position of all frames.

2 - 3.14 Save Frame Style
You may find it useful to save a particular frame style for later use or to share with another frame. You can do this by selecting “Save Frame Style” in the Frame menu. This will open the Save Style dialog, in which
you can name and save the style of your active frame as a stylesheet (with the extension `.sty`). Use the Load Frame Style action to retrieve your frame style in another frame or layout.

The Save Frame Style dialog has the following options:

- **Use Relative Path** - By default, Tecplot 360 saves the names of the image files used in the stylesheet with their relative file paths. If you want to save your stylesheet using absolute file paths, toggle-off “Use Relative Path”.

  A stylesheet (saved frame style) does not contain any information about the frame's data or where that data set comes from.

- **Options** - The [Options] button launches the Save Style Options dialog. Use the Save Style Options dialog to select the aspects of the frame style to save.

2.3.15 Load Frame Style

To load a saved frame style into your active frame, select “Load Frame Style” in the Frame menu. With the Load Frame Style dialog that appears, you can load all or part of a frame style (with the extension `.sty`) to dictate the frame attributes of your active frame. This will affect only the The Active Frame Receives All Actions. You must first Save Frame Style before loading the frame style into a frame.

Selecting the [Options] button in the Load Frame Style dialog will open the Load Style Options dialog, with which you can customize which frame details to load to your active frame.

In the Details to Load region of the Load Style Options dialog, specify style items to paste.

In the Merge and Replace region of the dialog, select whether to merge or replace the loaded frame styles with your current frame styles.

- **Merging** replaces the selected portions of the style with the saved settings and leaves the other portions “as-is”.
- **Replacing** replaces the selected portions of the style with the saved settings and resets all other portions to the factory defaults.
2 - 4 Workspace Management Options Menu

The workspace is the region in which you can create frames. The paper layout is a subset of the workspace and is correlated to the printer settings.

The paper is turned off by default in Tecplot 360. Select "Show Paper on Screen" in the Paper Setup dialog under the File menu to include the paper.

2 - 4.1 Paper Setup

Tecplot 360’s representation of paper in the workspace allows you to lay out plots precisely the way you want them printed. If you place a frame on the paper and print the resulting plot, the frame appears in the exact relative location on the printed paper.

You can control the size, orientation, and color of your paper by going to File>Paper Setup.

Paper Size Controls

Tecplot 360 offers the following six paper sizes:

- **Letter** - Standard U.S. letter size, 8 1/2 by 11 inches.
- **Double** - Standard U.S. ledger size, 11 by 17 inches.
- **A4** - Standard European letter size, 21 by 29.7 centimeters.
- **A3** - Standard European size, 29.7 by 42 centimeters.
- **Custom 1** - Default is 8.5 by 14 inches.
- **Custom 2** - Default is 8 by 10 inches.

All paper sizes may be customized using options in configuration or macro files. It is recommended that you only change the dimensions of the Custom 1 and Custom 2 paper sizes. To change the Custom sizes see the $!PAPER command in the Scripting Guide.

Paper Orientation Controls

Layouts can be landscape or portrait plots. In landscape (the default), the long axis of the paper is horizontal, while in portrait, the long axis is vertical. Portrait orientation uses the width of the specified
paper for the horizontal dimension, while landscape uses this for the vertical dimension. You specify the orientation as part of paper set-up.

**Screen Paper Controls**

If you are creating plots for display on your screen, you can toggle-off the screen representation of the paper and use the full workspace by deselecting “Show Paper on Screen”.

**Dimensions (display only)**

The units displayed in the “Dimensions” region of the Paper Setup dialog are determined by the units established in Options>Ruler/Grid.

**Paper Color Controls**

You can set up your paper to show any color as a background color (the “paper fill color”) on your screen, as well as use that color when printing to a color printer. When you are printing, the paper can be flooded with your specified fill color. (By default, the paper fill color is ignored during printing.) To use the paper fill color when printing, select “Use Paper Fill Color when Printing” from the Paper Setup dialog.

**2 - 4.2 Grid and Ruler Set-Up**

The workspace grid provides a convenient guide for placing objects on your paper. When placing text or geometric shapes, you can choose to snap the anchor points of the shapes to the grid. Rulers provide a reference length for sizing objects.

To customize the ruler/grid settings, select “Ruler/Grid” from the Options menu.

**Workspace Grid Controls**

Tecplot 360 allows you to select grid spacing from several pre-set sizes in centimeters (cm), inches (in), or points (pt) with the Grid Spacing drop-down menu. You can also specify not to show the grid by toggling-off “Show Grid”.

The grid does not display if “Show Paper on Screen” or “Show Grid” are toggled-off.

**Workspace Ruler Controls**

You can select the ruler markings from several pre-set sizes in centimeters (cm), inches (in), or points (pt) with the Ruler Spacing drop-down menu. You can also specify not to show the ruler by toggling-off “Show Ruler”. With “Show Ruler” toggled-on, rulers appear on the bottom and right-hand sides of the workspace.

**2 - 4.3 Show Invisible Frame Borders**

Select “Show Invisible Frame Borders” from the Options menu to temporarily turn on dashed lines to mark all invisible frame borders. These dashed lines will not print with your plot.
2 - 4.4 Show Sidebar or Toolbar
You may turn off the Sidebar by going to Options>Sidebar>None. Similarly, you may turn the Sidebar on by going to Options>Sidebar>Standard. You may turn off or on the Toolbar by selecting Options_TOOLBAR.

2 - 5 View Modification
Use the View menu to adjust the view of the active frame or to adjust the view of the entire workspace. The View menu is discussed in the following subsections.

2 - 5.1 Redraw Frame
When “Auto Redraw” is toggled-off, go to View>Redraw Frame, select the [Redraw Frame] button from the Sidebar or type CTRL-R to redraw the active frame.

2 - 5.2 Redraw All
When “Auto Redraw” is toggled-off, go to View>Redraw All, select the [Redraw All] button from the Sidebar or type CTRL-D to redraw all frames in the workspace.

2 - 5.3 Zoom
There are two zoom modes: axis (dataset) zooming and paper zooming.

Plot Zooming
Activate plot zooming by selecting View>Zoom or the button from the Toolbar. Drag the magnifying glass cursor to draw a box. The region within the view box will be resized to fit into the frame according to the longest dimension of the view box. If “Snap to Grid” is selected (from the Sidebar), you cannot make the zoom box larger than the grid area.

To return to the previous view: Select "Last" (CTRL-L) from the View menu or "Undo" (CTRL-Z) from the Edit menu.

Paper Zooming
SHIFT-drag the magnifying glass cursor to draw a box about the region that you want to magnify. The plot is resized such that the longest dimension of the zoom box fits into the workspace.

Alternatively, you can fit one or all frames to the workspace by using the "Fit Selected Frames to Workspace" or the "Fit All Frames to Workspace" options of the View>Workspace menu.

Mouse Zoom and Translation
The middle and right mouse buttons allow you to smoothly zoom and translate data. Your middle mouse button zooms smoothly, and your right mouse button translates data. (Refer to the Quick Reference Guide for additional functionality.)
2 - 5.4  Fit Everything (3D Only)

View>Fit Everything (CTRL-E) resizes the plot so that all data points, text, and geometries are included in the frame. Use “Fit Everything” to restore the initial view of your data after extensive zooming, scaling, or translating. Use View>Data Fit to neglect text and geometry in the resizing.

2 - 5.5  Fit to Full Size

View>Fit to Full Size (CTRL-E) resizes the plot so that all data points, text, and geometries are included in the frame. Use “Fit to Full Size” to restore the initial view of your data after extensive zooming, scaling, or translating. The “Fit to Full Size” operation is performed when your dataset is first displayed. Use View>Data Fit to neglect text and geometry in the resizing.

2 - 5.6  Fit Surfaces (3D Only)

View>Fit Surfaces (CTRL-F) resizes the plot so that all surfaces are included in the frame, excluding any volume zones. The “Fit Surfaces” operation is performed when your dataset is first displayed. If there are no surfaces plotted, View>Fit Surfaces reverts to View>Fit Everything behavior and fits all data points, text, and geometries to the frame.

2 - 5.7  Data Fit

View>Data Fit resizes the plot so all data points are included in the frame. Text and geometries are not considered. The text and geometries must be set to grid coordinates to be included in the resizing.

2 - 5.8  Nice Fit to Full Size

View>Nice Fit to Full Size (CTRL-N) is available for 2D Cartesian, XY Line, and Sketch plot types only. The command sets the axis range to begin and end on major axis increments. (If axes are dependent, the vertical axis length is adjusted to accommodate a major tick mark.)

2 - 5.9  Make Current View Nice

View>Make Current View Nice (CTRL-K) is available for 2D Cartesian, XY Line, and Sketch plot types only. The command modifies the range on a specified axis to fit the minimum and maximum of the variable assigned to that axis, then snaps the major tick marks to the ends of the axis. (If axis dependency is not independent, this may affect the range on another axis.)

2 - 5.10  Center

Centers the plot within the frame. Only the data is centered; text, geometry, and the 3D axes are not considered. Neither the axes nor the plot is changed in size.
2 - 5.11 Translate/Magnify

The Translate/Magnify dialog (accessed via the View menu), allows you to move and resize your plot within a frame (shown below). Translating using this dialog moves the image of your data with respect to the active frame. You can translate plots in any direction within a frame.

The following options are available in the Translate/Magnify dialog:

- **Up, Down, Left, Right** - Use the arrows to translate the image.
- **Magnification Factor** - Change magnification using the up and down arrows to the right of the text field, or enter a value in the text field.
- **Step Size (%)** - Control the step size for each arrow using pre-set ranges from the drop-down, or enter your own value.

The Translate/Magnify tool  (located in the Toolbar) allows you to translate/magnify the data within the frame or the entire workspace. Use the SHIFT key to translate/magnify the workspace instead of the data.

When the Translate/Magnify tool is active, type +/- on your keyboard to increase/decrease the scale of the image.

2 - 5.12 Last

View> Last (CTRL-L) restores the previous view. The “Last” command allows you to step backward through the resizings and repositionings of plots. Any time you change the view of a frame, either by zooming, centering, translating, or fitting the plot, the previous view is placed in a view stack. Each frame is allotted four view stacks, one for each plot type. Each view stack stores up to sixteen views, including the active view.

2 - 5.13 Rotate

(3D Cartesian plot type only) Calls up the Rotate dialog for image rotation. For further information, see Section “Three-dimensional Rotation” on page 23.

2 - 5.14 3D View Options

(3D Cartesian plot type only): Calls up the 3D View Details dialog for setting the view position and angle of 3D images. For further information, see Section “Three-dimensional Rotation” on page 23.

2 - 5.15 Copy View

Use the View> Copy View menu option to copy the active frame view to the frame view buffer, where it can then be pasted to other frames having the same plot type. The copied view includes all the attributes of the view that are affected by the View menu: the amount of zoom, translation and scale, and (in 3D Cartesian plot type) the amount of rotation and perspective projection.
2 - 5.16 Paste View

View>Paste View (CTRL-A) pastes a copied view onto the active frame. When you are working with multiple frames attached to the same dataset, it is often useful to make your view changes to one frame and then propagate those changes to the other frames.

2 - 5.17 View>Workspace Options

- **Fit Selected Frames to Workspace (CTRL-SHIFT-F)** - Resizes all frames proportionally so that the selected frame(s) fill the workspace either vertically or horizontally.
- **Fit All Frames to Workspace (CTRL-SHIFT-A)** - Resizes all frames proportionally so that all frame(s) fill the workspace either vertically or horizontally.
- **Fit Paper to Workspace (CTRL-SHIFT-P)** - Resizes paper to fill the workspace.
- **Last Workspace View (CTRL-SHIFT-L)** - Restores the workspace to the previous view. This command undoes the last:
  - SHIFT-Magnify
  - Fit Selected Frames to Workspace
  - Fit All Frames to Workspace
- **Maximize Workspace (CTRL-SHIFT-M)** - Maximizes the work area view by suppressing the menu bar, status bar, and Sidebar. To restore the normal view, click anywhere in the maximized workspace.

2 - 6 Edit Menu

You can duplicate frames, text, and geometries with the copy and paste options of the Edit menu (or their keyboard equivalents, CTRL-C, CTRL-V). You can also cut objects from one location and paste them into another, or throw them away completely.

2 - 6.1 Undo

All plot and mapping style modifications can be undone. In addition, you can undo a variety of other plot alterations. As a rule, Tecplot 360 allows undo for reversible operations that can be restored without significant impact on the operation's performance. To undo an operation, select “Undo” from the Edit menu, or press CTRL-Z in the workspace.

Specifically, the Undo option is allowed for the following conditions:

- All zone and map style changes.
- Some (though not all) frame control operations, push, and pop.
- Creating new frames.
- Moving and copying line maps.
- View operations.
- Some pick operations.
- Streamtrace actions.
- The following data alterations:
  - Deleting zones and variables.
  - Renaming datasets and zones.
  - Creating rectangular or circular zones.
  - Duplication zones.
• Processing Equations. (Except equations containing derivatives.)

Undo is unavailable for all data operations once an Undo operation has been performed on an un-allowed item. In addition, once an operation is performed that cannot be undone, the entire undo history for that frame is erased.

2 - 6.2 Select All
To select all geometries, zones, text, or streamtraces in a frame, choose the “Select All” option from the Edit menu. The Select All dialog box allows you to specify whether to select all frames, zones, text, geometries, and/or streamtraces.

2 - 6.3 Quick Edit
Refer to Section 1 - 1.6 “Quick Edit”.

2 - 6.4 Push
Push the selected item to the bottom of the active draw stack. The plot is drawn on your screen from the bottom of the draw stack to the top; elements lying further down in the stack may be partially obscured by elements higher up. The following types of objects may be pushed: text, geometries, 2D or X-Y grid areas, and frames.

2 - 6.5 Pop
Pop the selected item to the top of the active draw stack. The following types of objects may be popped: text, geometries, 2D, or X-Y grid areas, and frames.

2 - 6.6 Cut
Edit>Cut or CTRL-X removes the selected item from the plot and the active dataset (if applicable), and stores the removed item in the Paste buffer.

In Windows and Macintosh platforms, the Cut, Copy, and Paste options work only within Tecplot 360. However, the Edit menu’s “Copy Plot to Clipboard” option allows you to copy Tecplot 360 frames and paste them into other applications. See Section 26 - 6 “Clipboard Exporting to Other Applications” for a discussion of this feature.

2 - 6.7 Copy
Edit>Copy or CTRL-C stores the selected item in the Paste buffer. The Paste buffer is specific to Tecplot 360.
2 - 6.8 Paste
Use Edit>Paste or CTRL-V to add the contents of the Paste buffer to the active plot. If the object is being copied into the same frame, the new object will be overlaid directly over the original object. Use the Selector or the Adjustor tool to move the copied item to different locations in the frame.

- Pasting from the Paste buffer is allowed only between compatible frames. Attempting to copy an object into a frame that does not hold an appropriate data type results in an error message.

2 - 6.9 Clear
Remove the selected item from the plot and from the active dataset. Cleared items are not stored in the Paste buffer.

- If you cut or clear the only Tecplot 360 frame in the workspace, Tecplot 360 automatically creates a blank frame to replace it.
Data Structure

Tecplot 360 accommodates two different types of data: Ordered Data and Finite Element Data.

3 - 1 Connectivity List

A connectivity list is used to define which nodes are included in each element of an ordered or cell-based finite element zone. You should know your zone type and the number of elements in each zone in order to create your connectivity list.

The number of nodes required for each element is implied by your zone type. For example, if you have a finite element quadrilateral zone, you will have four nodes defined for each element. Likewise, you must provide eight numbers for each cell in a BRICK zone, and three numbers for each element in a TRIANGLE zone. If you have a cell that has a smaller number of nodes than that required by your zone type, simply repeat a node number. For example, if you are working with a finite element quadrilateral zone and you would like to create a triangular element, simply repeat a node in the list (e.g., 1,4,5,5).

In the example below, the zone contains two quadrilateral elements. Therefore, the connectivity list must have eight values. The first four values define the nodes that form Element 1. Similarly, the second four values define the nodes that form Element 2.

![Diagram of Connectivity List](image)

The connectivity list for this example would appear as follows:

```
ConnList[8] = {4,5,2,1,  /* nodes for Element 1 */
```
3.2 Ordered Data

Ordered data is defined by one, two, or three-dimensional logical arrays, dimensioned by IMAX, JMAX, and KMAX. These arrays define the interconnections between nodes and cells. The variables can be either nodal or cell-centered. Nodal variables are stored at the nodes; cell-centered values are stored within the cells.

- **One-dimensional Ordered Data (I-ordered, J-ordered, or K-ordered)**
  A single dimensional array where either IMAX, JMAX or KMAX is greater than or equal to one, and the others are equal to one. For nodal data, the number of stored values is equal to IMAX * JMAX * KMAX. For cell-centered I-ordered data (where IMAX is greater than one, and JMAX and KMAX are equal to one), the number of stored values is (IMAX-1) - similarly for J- and K-ordered data.

- **Two-dimensional Ordered Data (II-ordered, JK-ordered, IK-ordered)**
  A two-dimensional array where two of the three dimensions (IMAX, JMAX, KMAX) are greater than one, and the other dimension is equal to one. For nodal data, the number of stored values is equal to IMAX * JMAX * KMAX. For cell-centered II-ordered data (where IMAX and JMAX are greater than one, and KMAX is equal to one), the number of stored values is (IMAX-1)(JMAX-1) - similarly for JK- and IK-ordered data.
Ordered Data

- Three-dimensional Ordered Data (IJK-ordered)

A three-dimensional array where all IMAX, JMAX, and KMAX are each greater than one. For nodal ordered data, the number of nodes is the product of the I-, J-, and K-dimensions. For nodal data, the number of stored values is equal to IMAX * JMAX * KMAX. For cell-centered data, the number of stored values is (IMAX-1)(JMAX-1)(KMAX-1).

3 - 2.1 Indexing Nodal Ordered Data

For nodal ordered data, the n-dimensional array of values are treated as a one-dimensional array. For example, given an IJK-ordered zone dimensioned by 10x20x30. To access the value at I=3, J=4, K=5 (one-based) you would use:

\[
\text{NodeIndex} = I + (J-1) \times \text{IMax} + (K-1) \times \text{IMax} \times \text{JMax}
\]

3 - 2.2 Indexing Cell-centered Ordered Data

For cell-centered ordered data, the index that represents the cell center is the same as the nodal index that represents the lowest indexed corner of the cell.

For example, the figure below shows an IJ-ordered zone dimensioned 3x4.

Figure 3-1. An IJ-ordered zone dimensioned 3x4. Cell index numbers are based on the point number in the lowest corner of the cell.

To access a cell-centered value for the cell in the upper right hand corner, use the following:

\[
\text{IMax} = 3
\]
\[ \text{CellIndex} = I + (J-1) \cdot IMax + (K-1) \cdot IMax \cdot JMax \]

You’ll notice that the equations are exactly the same as with nodal data. As a result there are gaps of unused values at IMax, JMax, and KMax that must be left unassigned. NOTE: The above equation is generic for 1D, 2D and 3D data. It simplifies for the lower dimensions.

### 3 - 2.3 One-dimensional Ordered Data (I, J, or K)

Values for XY Line plots are usually arranged in a one-dimensional array indexed by one parameter: I for I-ordered, J for J-ordered, or K for K-ordered, with the two remaining index values equal to one. At each node, \( N \) variables (\( V_1, V_2, \ldots, V_N \)) are defined. If you arrange the data in a table where the values of the variables (\( N \) values) at a node are given in a row, and there is one row for each node, the table would appear something like that shown below:

<table>
<thead>
<tr>
<th>V1</th>
<th>V2</th>
<th>V3</th>
<th>\ldots</th>
<th>VN</th>
<th>(Values at node ( I = 1 ))</th>
</tr>
</thead>
<tbody>
<tr>
<td>V1</td>
<td>V2</td>
<td>V3</td>
<td>\ldots</td>
<td>VN</td>
<td>(Values at node ( I = 2 ))</td>
</tr>
<tr>
<td>V1</td>
<td>V2</td>
<td>V3</td>
<td>\ldots</td>
<td>VN</td>
<td>(Values at node ( I = 3 ))</td>
</tr>
<tr>
<td>V1</td>
<td>V2</td>
<td>V3</td>
<td>\ldots</td>
<td>VN</td>
<td>(Values at node ( I = IMax ))</td>
</tr>
</tbody>
</table>

Table 3 - 1: Table of values for I-ordered Nodal Data (typical for XY plots).

### IJK-ordered Data Plotting

In one or two-dimensional datasets, all data points are typically plotted. However, for IJK-ordered data you can designate which surface will be plotted by using the Surfaces page of the Zone Style dialog. You may choose to plot just outer surfaces, or you may select combinations of I, J, and K-planes to be plotted. Refer to Section 7 - 1.2 “Surfaces” for in-depth information.

### 3 - 2.4 Logical versus Physical Representation of Data

A family of I-lines results by connecting all of the points with the same I-index, similarly for J-lines and K-lines. For IJK-ordered data, both families of lines are plotted in a two-dimensional coordinate system resulting in a 2D mesh. When both the I and J-lines are plotted in a three-dimensional coordinate system, a
Finite Element Data

3D surface mesh plot results. An example of both meshes is shown below. As you can see, logical data points can transform into an arbitrary shape in physical space.

Figure 3-2. Left, a 2D mesh of IJ-ordered data points. Right, a 3D mesh of IJ-ordered data points.

3 - 3 Finite Element Data

While finite element data is usually associated with numerical analysis for modeling complex problems in 3D structures (heat transfer, fluid dynamics, and electromagnetics), it also provides an effective approach for organizing data points in or around complex geometrical shapes. For example, you may not have the same number of data points on different lines, there may be holes in the middle of the dataset, or the data points may be irregularly (randomly) positioned. For such difficult cases, you may be able to organize your data as a patchwork of elements. Each element can be independent of the other elements, so you can group your elements to fit complex boundaries and leave voids within sets of elements. The figure below shows how finite element data can be used to model a complex boundary.

Figure 3-3. This figure shows finite element data used to model a complex boundary. This plot file, *feexchng.plt*, is located in your Tecplot 360 distribution under the *examples/2D* subdirectory.

Finite element data defines a set of points (nodes) and the connected elements of these points. The variables may be defined either at the nodes or at the cell (element) center. Finite element data can be divided into three types:

- **Line data** is a set of line segments defining a 2D or 3D line. Unlike I-ordered data, a single finite element line zone may consist of multiple disconnected sections. The values of the variables at each data point (node) are entered in the data file similarly to I-ordered data, where the nodes are numbered with the I-index. This data is followed by another set of data.
defining connections between nodes. This second section is often referred to as the connectivity list. All elements are lines consisting of two nodes, specified in the connectivity list.

- **Surface data** is a set of triangular, quadrilateral, or polygonal elements defining a 2D field or a 3D surface. When using polygonal elements, the number of sides may vary from element to element. In finite element surface data, you can choose (by zone) to arrange your data in three point (triangle), four point (quadrilateral), or variable-point (polygonal) elements. The number of points per node and their arrangement are determined by the element type of the zone. If a mixture of quadrilaterals and triangles is necessary, you may repeat a node in the quadrilateral element type to create a triangle, or you may use polygonal elements.

- **Volume data** is a set of tetrahedral, brick or polyhedral elements defining a 3D volume field. When using polyhedral elements, the number of sides may vary from element to element. Finite element volume cells may contain four points (tetrahedron), eight points (brick), or variable points (polyhedral). The figure below shows the arrangement of the nodes for tetrahedral and brick elements. The connectivity arrangement for polyhedral data is governed by the method in which the polyhedral facemap data is supplied.

![Connectivity arrangements for FE-volume datasets](image)

3 - 3.1 **Finite Element Data Limitations**

Working with finite element data has some limitations:

- XY-plots of finite element data treat the data as I-ordered; that is, the connectivity list is ignored. Only nodes are plotted, not elements, and the nodes are plotted in the order in which they appear in the data file.

- Index skipping in vector and scatter plots treats finite element data as I-ordered; the connectivity list is ignored. Nodes are skipped according to their order in the data file.

3 - 4 **Variable Location (Cell-centered or Nodal)**

Data values can be stored at the nodes or at the cell centers.

- For finite element meshes, cell-centers are the centers (centroids) of elements.
- For many types of plots, cell-centered values are interpolated to the nodes internally.
3 - 5 Face Neighbors

A cell is considered a neighbor if one of its faces shares all nodes in common with the selected cell, or if it is identified as a neighbor by face neighbor data in the dataset. The face numbers for cells in the various zone types are defined below.

![Figure 3-1. A: Example of node and face neighbors for an FE-brick cell or IJK-ordered cell. B: Example of node and face numbering for an IJ-ordered/ FE-quadrilateral cell. C: Example of tetrahedron face neighbors.](image)

The implicit connections between elements in a zone may be overridden, or connections between cells in adjacent zones established by specifying face neighbor criteria in the data file. Refer to Section "TECFACE112" on page 30 of the Data Format Guide for additional information.

3 - 6 Working with Unorganized Datasets

Tecplot 360 loads unorganized data as a single I-ordered zone and displays them in XY Mode, by default. Tecplot products consider an I-ordered zone irregular if it has more than one dependent variable. An I-ordered data set with one dependent variable (i.e. an XY or polar line) is NOT an irregular zone.

To check for irregular data, you can go to the Data>Data Set Info dialog (accessed via the Data menu). The values assigned to: IMax, JMax, and KMax are displayed in the lower left quadrant of that dialog. If IMax is greater than 1, and JMax and KMax are equal to 1, then your data is irregular.

It is also easy to tell if you have irregular data by looking at the plot. If you are looking at irregular data with the Mesh layer turned on, the data points will be connected by lines in the order the points appear in the data set.

You can organize your data set for Tecplot 360 in several ways.

1. Manually order the data file using a text editor.

   Use the "Label Points and Cells" feature from the Plot menu to see if your data set can be easily corrected using a text editor by correcting the values for I, J, and/or K.

2. Use the Data-Triangulate feature (2D only). See Section 21 - 12 "Irregular Data Point Triangulation".

3. Use one of the Data-Interpolation options. See Section 21 - 11 "Data Interpolation".
4. If you have multiple zones of irregular data that you would like to combine into one finite element zone, use the Create Zone>Create Zone From Polylines from the Data menu. Refer to Section 21 - 7.6 “FE Surface Zone Creation (from Polylines)” for more information.

5. Special Cases (use when interpolation results appear skewed):
   - Well data - If points are closely positioned along the depth axis and far apart in physical space, use the Tetra Grid add-on to create a new zone with all points connected into 3D zones. See Section 33 - 3.23 “Tetra Grid”.
   - Fluid Measurements - When measurements are taken of fluid properties or containments, and interpolating to a rectangular zone does not yield good results, use the Prism Grid add-on to create a 3D volume zone. See Section 33 - 3.17 “Prism Grid”.

3 - 6.1 Example - Triangulate a Data Set

One common source of finite-element surface data is the triangulation option. If you have 2D data without a mesh structure, it is probably simplest to enter your data points as an I-ordered dataset, then use the triangulation feature to create a finite-element dataset. You can then edit the file—particularly the connectivity list—to obtain the set of elements you want, rather than having to create the entire connectivity list by hand.

We can triangulate a data set as follows:

1. Create a simple ordered data file, as follows:

<table>
<thead>
<tr>
<th>VARIABLES = &quot;X&quot;, &quot;Y&quot;, &quot;P&quot;, &quot;T&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.0 1.0 100.0 1.6</td>
</tr>
<tr>
<td>1.0 1.0 150.0 1.5</td>
</tr>
<tr>
<td>3.0 1.0 300.0 2.0</td>
</tr>
<tr>
<td>0.0 0.0 50.0 1.0</td>
</tr>
<tr>
<td>1.0 0.0 150.0 1.4</td>
</tr>
<tr>
<td>3.0 0.0 200.0 2.2</td>
</tr>
<tr>
<td>4.0 0.0 400.0 3.0</td>
</tr>
<tr>
<td>2.0 2.0 280.0 1.9</td>
</tr>
</tbody>
</table>

2. Save the file, with extension *.dat
3. Load the data file and switch the plot type to 2D Cartesian.
4. From the Data menu, choose “Triangulate”.
5. Select the simple ordered zone as the source zone, and select [Compute].

Irregular Data Point Triangulation

Figure 3.2 shows a plot of the resulting data. With triangulation, we obtain more elements (seven) than when we created the dataset by hand (four), and the elements are triangles rather than quadrilaterals.
3 - 6.2 Example - Unorganized Three-Dimensional Volume

To use 3D volume irregular data in field plots, you must interpolate the data onto a regular, IJK-ordered zone. (Tecplot 360 does not have a 3D equivalent for triangulation.) To interpolate your data, perform the following steps:

1. Place your 3D volume irregular data into an I-ordered zone in a data file.
2. Read in your data file and create a 3D scatter plot.
3. From the Data menu, choose Create Zone>Rectangular. (Circular will also work.)
4. In the Create Rectangular Zone dialog, enter the I-, J-, and K-dimensions for the new zone; at a minimum, you should enter 10 for each dimension. The higher the dimensions, the finer the interpolation grid, but the longer the interpolating and plotting time.
5. Enter the minimum and maximum X, Y, and Z values for the new zone. The default values are the minimums and maximums of the current (irregular) dataset.
6. Click [Create] to create the new zone, and [Close] to dismiss the dialog.
7. From the Data menu, choose Interpolate>Kriging. (Linear or Inverse distance Interpolation also work.)
8. In the Kriging dialog, choose the irregular data zone as the source zone, and the newly created IJK-ordered zone as the destination zone. Set any other kriging parameters as desired (see Section 21.11.3 “Kriging” for details).
9. Select the [Compute] button to perform the kriging.

Once the interpolation is complete, you can plot the new IJK-ordered zone as any other 3D volume zone. You may plot iso-surfaces, volume streamtraces, and so forth. At this point, you may want to deactivate or delete the original irregular zone so as not to conflict with plots of the new zone.

Figure 3-3 shows an example of irregular data interpolated into an IJK-ordered zone, with iso-surfaces plotted on the resultant zone.

Figure 3-3. Irregular data interpolated into an IJK-ordered zone.
Part 2 Loading Your Data
Data Loaders

Tecplot 360 allows you to load data in a number of formats with loaders that Tecplot 360 or third parties have produced using the Add-on Developer’s Kit. Use the File>Load Data File(s) command to load a data file. The Select Import Format dialog is shown below.

The Select Import Format dialog allows you to select from the following list of data loaders:

- CGNS Loader
- DEM Loader
- DXF Loader
- EnSight Loader
- Excel Loader
- FEA Loader
- FLOW-3D Loader
• FLUENT Loader
• General Text Loader
• HDF Loader
• HDF5 Loader
• Kiva Loader
• PLOT3D Loader
• Ply Loader
• Tecplot-Format Loader
• Text Spreadsheet Loader

See also: the Data Format Guide and Section 4-17 “Overwriting Data Files”.

We post new data loaders on our website www.tecplot.com as they become available. You can also build your own data loaders using the Add-on Developer’s Kit (refer to Chapter 1, “Introduction” in the ADK User’s Manual for details).

4 - 1 CGNS Loader

The CGNS Loader supports files created with CGNSLib Version 3.1 or earlier with either ADF or HDF5 internal representation. You can choose to load either all or specific bases, zones, and solutions into Tecplot zones. You can also select field variables individually, or define index ranges to load specific sub-zone blocks or planes for structured-grid zones.

CGNS Boundary Conditions can be loaded for both structured and unstructured data with the exception that unstructured boundaries will only be loaded if they have corresponding sections. Only CGNS bases and zones with valid grids can be read by the CGNS Loader. For unstructured grids, the CGNS Loader supports BAR_2, TRI_3, QUAD_4, TETRA_4, PYRA_5, PENTA_6, HEXA_8, MIXED element types and their combinations on every section. However, the CGNS Loader does not support higher-order element types. Unstructured sections that are cell-centered and have more cells than are declared in the CGNS Zone_t node will be ignored.

Only vertex and cell-centered field variable locations are supported. Cell-centered data can be read in directly or averaged to the nodes when the file is read. For cell-centered structured grids, arithmetic averaging is used. Rind data is used in the averaging if available. For cell-centered unstructured grids, either Laplacian averaging or arithmetic averaging can be selected to average the cell data to the surrounding nodes.

The CGNS Loader assigns strand IDs for zones by grouping them into time steps based on their solution times. The first zone from each time step is assigned to strand 1, the second to strand 2, and so on until all zones have been assigned to a strand. CGNS Base Names and Zone Names are converted to Tecplot zone auxiliary data under the keys “CGNS.CGNSBase_t” and “CGNS.Zone_t,” respectively.
The CGNS Loader dialog has the following options:

- **Files** - Click the buttons to add or remove files from the list of files to be loaded.
- **Load Preference** - Choose to load either grid and solution data, or global convergence history data. If a file contains both types of information, they must be loaded separately.
- **Specify Options** - Active when a valid file is entered or selected. This option allows you to control the data loaded from your CGNS file, including loading only particular zones, field variables, or partial zones.

If “Specify Options” is not selected, every base, zone, solution, and variable is loaded into Tecplot 360.

- **Load Cell-centered Data Directly** - Toggle-on to load cell-centered data directly [default]. When the option is toggled-off, cell-centered data will be averaged to the nodes (using the averaging method specified below).
- **Averaging** - This option is available only if “Load Cell-centered Directly” is not selected. When the field variables are stored at cell centers, either Laplacian averaging or arithmetic averaging may be used to average the cell data to the nodes they surround. This can result in a bias at the boundary nodes. Arithmetic averaging is automatically used for ordered/structured zones. When available, Rind data is used in the averaging.
- **Select Zones** - Launches the Load CGNS Options: Zones Dialog, which allows you to select specific zones and partial zones to load.
- **Select Variables** - Launches the Load CGNS Options: Variables dialog, which allows you to select specific field variables to load. Grid variables are always loaded automatically.
- **CGNS Section Mapping** - CGNS files sometimes have multiple node-maps (referred to as sections) for each finite element zone. A zone may contain sections with different cell types and cell dimensions.
  - **One Tecplot zone per CGNS zone/solution (default)** - All sections will be combined with the zone cell dimension into one Tecplot 360 zone.
  - **Load each section/boundary as separate Tecplot zone** - A separate Tecplot 360 zone will be created for each section or boundary regardless of cell dimension.
- **Transient Options**
• Assign Strand IDs to all zones - Toggle-on to assign Strand IDs to transient zones. Refer to Section 7.2 "Time Aware" for more information on working with transient data.

4-1.1 Load CGNS Options: Zones Dialog

Tecplot 360 zones are not always equivalent to CGNS zones. The Load CGNS Options: Zones dialog allows you to specify zones to load from CGNS data files.

Each solution for a CGNS zone is considered a unique Tecplot 360 zone. The CGNS base (B), zone (Z), and solution (S) hierarchy orders the zones. The integer preceding the word Zone is the Tecplot 360 zone number assigned to that zone. The integer following Zone represents the order the zone was found in the CGNS file.

Table 4-1 describes the zone description listed in the dialog box. The zone description includes the CGNS hierarchy information. "CGNS B, Z, S = " followed by three integers representing the CGNS order for the base, zone, and solution, respectively. "CGNS Z, S = " and two integers are displayed if a single base is found. The description also indicates whether the zone is ordered (structured) or finite element (unstructured). I, J, and K-dimensions are provided for ordered zones; the number of nodes and elements are provided for finite element zones.

<table>
<thead>
<tr>
<th>int</th>
<th>Zone</th>
<th>int</th>
<th>[CGNS B, Z, S = x, y, z]</th>
<th>[Ordered, FE]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>&quot;Zone&quot;</td>
<td></td>
<td>[Ordered, FE]</td>
<td></td>
</tr>
<tr>
<td>Tecplot Zone number</td>
<td>order in CGNS file</td>
<td>x = Base number</td>
<td>y = Zone number</td>
<td>z = Structure number</td>
</tr>
</tbody>
</table>

Table 4-1: Zone Description in the Load CGNS: Zones dialog

By default, all zones are selected for reading and displayed in Zones to Load. Use the [Move], [Move All], [Remove], or [Remove All] buttons to edit the list.

CGNS Loader Options: Index Ranges Dialog

The Load CGNS: Index Ranges dialog allows you to specify a sub-set of the selected ordered/structured zone(s) to be loaded, or define a block, plane, or line of points for extraction on loading. To load a partial zone or sub-zone, highlight the zone of interest in Zones to Load region of the CGNS Loader: Zones dialog, and select the [Index Ranges for Zone(s)] button.

Each index requires Start, End, and Skip values. Start and End points are always loaded. If multiple zones are selected prior to calling up the CGNS Loader: Index Ranges dialog, "Max" (the maximum value for each zone) is the default value for End. You may enter any value for End. However, if the value is greater than the maximum index for a zone, End is replaced by the maximum index.

For multi-dimensional zones, more than one point must be specified to load in the I and J-directions. If the inputs for Start, End, and Skip result in a single point in either direction, an error message appears.
4- 1.2 Load CGNS Options: Variables dialog

The CGNS Loader: Variables dialog includes the Variables from CGNS and Variables to Load boxes.

The “Variables from CGNS” list includes all field variables in the CGNS data file, independent of their zone(s). The “Variables to Load” list contains the field variables that have been selected to be loaded into Tecplot 360. Initially, both lists are the same. A Tecplot 360 variable number is assigned to each CGNS field variable that appears in the “Variables to Load” list.

Because Tecplot 360 requires every zone to have the same number of variables, each zone that is loaded into Tecplot 360 will include every variable in the “Variables to Load” list (regardless of whether the zone included that field variable in the CGNS file). The variables that were not originally in the zone will be set to zero. The field variables that do not appear in the “Variables to Load” list will not have a Tecplot 360 variable number assigned to them.

Use the [Move], [Move All], [Remove], or [Remove All] buttons to edit the Variables to Load list.

4- 1.3 Macro Commands for the CGNS loader

The syntax for loading CGNS data files with the Tecplot macro language is as follows:

```
$!READDATASET "STANDARDSYNTAX "1.0"
...any of the name value pairs in the following table...
DATASETREADER = "CGNS LOADER"
```

Each name/value pair should be in double quotes. Refer to the Scripting Guide for details on working with the Tecplot macro language.

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Available Value(s)</th>
<th>Default</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>STANDARDSYNTAX</td>
<td>“1.0”</td>
<td>n/a</td>
<td>Must be the first instruction.</td>
</tr>
<tr>
<td>FILENAME_CGNSFILE</td>
<td>“filename”</td>
<td>n/a</td>
<td>The name of the file to load.</td>
</tr>
<tr>
<td>AverageToNodes</td>
<td>“Yes” “No”</td>
<td>“Yes”</td>
<td>Used to average the cell data to the nodes they surround.</td>
</tr>
<tr>
<td>AveragingMethod</td>
<td>“Laplacian” “Arithmetic”</td>
<td>“Arithmetic”</td>
<td>If AverageToNodes is set to “yes”, specify the AveragingMethod to use.</td>
</tr>
</tbody>
</table>
The DEM Loader allows you to load Digital Elevation Map files that have the same file format as the U.S. Geological Survey's standard DEM format. The DEM Loader will not accept Spatial Data Transfer Standard (SDTS) formatted data.

DEM files are available on the Web for a number of states within the U.S. For more information, refer to http://data.geocomm.com/dem/.

| SectionLoad | “Combine” | “SeparateZones” | CGNS files may have multiple node-maps (or sections) for each finite element zone. If you specify “Combine”, all sections are combined with the zone cell-dimension into one Tecplot zone. If you specify “SeparateZones”, a separate Tecplot zone is created for each section or boundary regardless of cell dimension. |
| LoadBCs | “Yes” | “No” | “No” | Specify whether to load the boundary conditions. |
| AssignStrandIDs | “Yes” | “No” | “Yes” | Set to “Yes” to automatically assign the strandIDs to your data file. |
| ZoneList | “Z1, Z2, Z3-Z7, ...” | All zones | Specify the zone number(s) of the zone(s) you wish to load. |
| VarList | “V1, V2, V3-V7, ...” | All variables | Specify the variable number(s) of the variable(s) you wish to load. |
| IIndexRange | “Zn, Min, Max, Skip” | All | If you are loading a subset of zones, you may specify the index ranges for each zone. Specify the zone number, minimum, maximum, and skip value for each index. Set Zn to “0” to apply the index ranges to all zones. |
| JIndexRange | “Zn, Min, Max, Skip” | All |  |
| KIndexRange | “Zn, Min, Max, Skip” | All |  |
| LoadConvergenceHistory | “Yes” | “No” | “No” | Loads global convergence history data in the CGNS file, if any, rather than grid and solution data. |

4 - 2 DEM Loader

The DEM Loader allows you to load Digital Elevation Map files that have the same file format as the U.S. Geological Survey's standard DEM format. The DEM Loader will not accept Spatial Data Transfer Standard (SDTS) formatted data.

DEM files are available on the Web for a number of states within the U.S. For more information, refer to http://data.geocomm.com/dem/.
The DEM Loader first launches a multi-file selection dialog. After choosing one or more DEM files to load, you are presented with a simple dialog where you can set the I and J-skipping. Since DEM files are quite large, you will likely want to set both of these to be 10 or more.

4 - 3 DXF Loader

The DXF Loader add-on can import AutoCAD® DXF™ (drawing interchange) files. When importing a file, Tecplot 360 creates an appropriate geometry for each of the following entity types:

- Text
- Lines
- Arcs
- Circles
- Points
- Solid
- 3D faces

When importing a DXF file, no zones are created. Instead, the geometries representing each entity type are simply added to the frame. Be aware that a typical DXF file can contain several thousand geometries, and these are all included when you save a layout file.

4 - 3.1 Load DXF File Dialog

The Load DXF File dialog has a variety of features, most of which are straightforward.
You can select any of the following:

- **Import** - Select any or all geometries to import: Text, Lines, Arcs, Circles, Points, Solids, 3D Faces.
- **Font** - Select the font to use for text. (See Section 18 - 1.2 “Font Folders and Fallback” on page 273 for more information on how fonts work with Tecplot 360.)
- **Attach Imported Items to Zone** - Specify a zone to which all imported geometries will be attached. Clicking the [Select Zone] button produces a menu of zone options.
- **Polylines/Import as 2D** - All lines and polylines are stored with three coordinates in DXF files. If you select this option, the loader will add 2D line geometries for all lines and polylines in the DXF file (the third coordinate will be ignored).
- **Polylines/Import as 3D** - If you select this option, the loader will add 3D line geometries for all lines and polylines in the DXF file. To view a 3D DXF file, create or load a 3D zone, import your DXF file, then choose “Fit Everything” from the View menu.
- **Hide Invisible Layers** - If this option is checked, objects in layers that are “off” in the DXF file will be imported with the background color.

### 4 - 3.2 DXF Loader Limitations

The DXF Loader does not create any field data. Loading a DXF file only adds geometries to your existing frame.

Since most geometries in Tecplot 360 are 2D, best results will be obtained by loading “flat” DXF files, such as maps.

Binary AutoCAD® DWG™ are not supported in this release.

### 4 - 4 EnSight Loader

The EnSight Data Loader allows you to load EnSight Gold and EnSight 6 files of types case (.case or .encase), geometry (.geo), or variable (.var). Geometry and variable files can be in either ASCII or binary format, although binary is recommended. Files from earlier versions of EnSight need to be resaved in Gold format using File>Save>Geometric Entities. To determine what format the files are in, view the case file and look under the FORMAT section.
EnSight data is stored in a case file, which contains references to all associated geometry and variable files. Loading the case file will load all the associated files. EnSight parts are translated into Tecplot zones with the caveat that unstructured parts with dissimilar element types (i.e. a volume element and a surface element) will only load the primary element type. Unstructured zone names will be prefixed by the type of zone they represent (point, line, surface, or volume). Vector, tensor, and tensor9 variables are expanded into the appropriate number of variables with the variable name followed by a suffix. Complex 'imaginary' variables will have an 'I' following the name to distinguish them from the 'real' variable.

Invoking the EnSight data loader immediately displays a file open dialog that allows you to select the case file. Simply choose the desired EnSight case file, and the associated data files will be loaded.

### 4- 4.1 Macro Commands for the EnSight Loader

The syntax for loading EnSight data files with the Tecplot macro language is as follows:

```
!READDATASET
"STANDARDSYNTAX" "1.0"
FILENAME_CASEFILE "filename"
DATASETREADER = 'EnSight Loader'
```

Each name/value pair should be in double quotes. Refer to the Scripting Guide for details on working with Tecplot 360’s macro language.

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Available Value(s)</th>
<th>Default</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>STANDARDSYNTAX</td>
<td>1.0</td>
<td>n/a</td>
<td>Must be the first instruction.</td>
</tr>
<tr>
<td>FILENAME_CASEFILE</td>
<td>&quot;filename&quot;</td>
<td>n/a</td>
<td>Specify the full or relative path of the case file name.</td>
</tr>
</tbody>
</table>

Previous versions of the EnSight loader supported options for loading a subset of the data using IJK skipping, part selection, or variable selection. These options will not generate syntax errors, so old macros will continue to work. However, IJK skipping is ignored, and part/variable selection is supported only for EnSight 6 files.

### 4 - 5 Excel Loader

The Excel Loader can read numeric data from `.xls` files for Microsoft Excel version 5.0 or higher.

The Excel Loader is available for Windows platforms ONLY.

The Excel Loader is useful for basic formats only. Your Excel file must contain only values (no equations). Tecplot 360 recommends the use of the Excel add-on from the Util/Excel folder as an easier method to open Excel data with Tecplot 360 (see Section B. 1 "Excel Macro"). Use the Text Spreadsheet loader for delimited files (Section 4 - 16 "Text Spreadsheet Loader").

If your spreadsheet is arranged as Table Format or Carpet Format, the Excel Loader is a point-and-click operation. Once you have selected an Excel file to load into Tecplot 360, the Excel Loader leads you through a series of dialogs, prompting you to specify a variety of attributes, including the data format in the Excel spreadsheet, the variables to read into Tecplot 360, and zone information.

Refer to Section B - 1 "Excel Macro" for instructions on loading Excel data into Tecplot 360 via the Excel interface.
4 - 5.1 Spreadsheet Data Formats

The Excel Loader will automatically identify blocks of data in **Table Format** or **Carpet Format**. The loader will list blocks of data in standard notation for Microsoft Excel. For example, a block found on worksheet sheet1, cells A1-D8, is listed as follows: (sheet1! A1:D8).

If you select a user-defined format (or if the loader did not identify any carpet or table blocks), you will be prompted to enter the names and number of variables, and one or more zones and associated properties. You will also need to enter the location of the field data in the spreadsheet for each zone.

**Table Format**

Use Table format for data that will be plotted in line plots (i.e. data with an independent and one or more dependent variables). Many spreadsheets containing data to be plotted in 2D or 3D Cartesian plots will also satisfy the conditions of table format.

A table formatted dataset has the following characteristics:

- The dataset is arranged in one or more adjacent columns.
- Each column is the same length.
- Each cell contains numeric data.
- The first row is a header row containing the variable name for its corresponding column.
- The spreadsheet dataset is imported as a single I-ordered zone in **POINT** format with N variables, where N is the number of columns in the table.

The block of data must be surrounded by empty cells, text-filled cells, or table boundaries. The loader will not recognize a block of data as being in table format if any cell adjacent to the block contains a number.

The block of data can contain no empty cells. An empty cell will prevent the loader from recognizing the block. You can satisfy this condition by filling blank cells with 0.0.
Excel Loader

Figure 4-1 shows a block of data in table format in Excel.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Month</td>
<td>Seattle Rainfall</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>4.3</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>4.5</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>4.2</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>4</td>
<td>3.5</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>5</td>
<td>2.1</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>6</td>
<td>3.3</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>7</td>
<td>2.5</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>8</td>
<td>2.1</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>9</td>
<td>3.3</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>10</td>
<td>2.5</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>11</td>
<td>3.5</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>12</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 4-1. A block of data in table format.

**Carpet Format**

Use carpet format for spreadsheet data to be plotted in a 2D or 3D Cartesian plot. The carpet formatted dataset, shown in Figure 4-2, has the following characteristics:

- The spreadsheet dataset is imported as an IJ-ordered zone. See Chapter 6: “XY and Polar Line Plots”.
  - In Figure 4-2, the spreadsheet is imported as I=4 and J=4. The three variables are X, Y, and V. In the spreadsheet cell 2B is index 1, 1; cell 3B is index 2, 1.
- The top row in the block contains the values of the X-variable, the first column of the block contains the values of the Y-variable, and the V-values are the interior data. This format is useful if your dataset was generated from a function $f$, such that $f(X, Y) = V$.
- The block is a rectangular arrangement of numeric data in the spreadsheet, with a blank cell in the upper left hand corner.
- There must be no blank cells within the block of data. An empty cell will prevent the loader from recognizing the block. You can satisfy this condition by filling blank cells with 0.0.
• The block of data must be surrounded by empty cells, text-filled cells, or table boundaries. The loader will not recognize a block of data as being in carpet format if any cell adjacent to the block is filled with a number.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>2</td>
<td>2</td>
<td>4</td>
<td>6</td>
<td>8</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>3</td>
<td>3</td>
<td>6</td>
<td>9</td>
<td>12</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>4</td>
<td>4</td>
<td>8</td>
<td>12</td>
<td>16</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 4-2. The carpet table shows values as a simple arithmetic function of X and Y.

**Other Formats**

The Other format option gives you a great deal of flexibility in loading data into Tecplot 360. A series of dialogs leads you through the process of describing your data, similar to the way you would specify this information in a Tecplot 360 ASCII file.

• **Default format** - The Excel Loader offers a semiautomatic option that requires only that you specify the upper left and lower right corners of your data block. Once you’ve specified those corners, it handles the data in the same way that Tecplot 360 handles an unformatted block in an ASCII file. It assumes one zone of I-ordered data in POINT format.

• **Custom format** - Using the Custom format option, you can specify characteristics of your dataset. Custom format has the following features:
  • It allows you to work with spreadsheets containing blank cells or text cells.
  • For XY, IJ, and IJK-ordered data, specify the boundaries of the block to load, and how many data points there are within that block (I_{Max}, J_{Max}, K_{Max}).
  • For finite element data, the number of data points is implied by the number of nodes and number of elements.
  • Allows you to load blocks of cells that you delimit interactively.
  • It is the only option for loading finite element, IJK-ordered, or zone data from Excel. If a user wants to read in data from an Excel spreadsheet into more than one Tecplot 360 zone, the custom format must be used. The default assumes that all data read should be put in a single I-ordered zone.

4 - 5.2 **Excel Loader Restrictions**

A block of data is a rectangular group of numbers in the spreadsheet. The Excel Loader places the following restrictions on blocks:

• Carpet and table format (which the loader detects and loads automatically) are narrowly defined. All other formats must be loaded on the user-defined pathway.
• Numeric cells within each block should contain only numbers or numeric characters such as +, -, and so forth. A cell containing “X=34” is interpreted by the loader as text, because it begins with text.
• Cells containing formulas (therefore displaying calculated values) will be skipped by the loader. You can convert the formulas to values within Excel, by pasting your table using the “Paste Special” function, with “values only” selected.
• The spreadsheet file must have been written by Excel Version 5.0 or higher.
Tecplot 360 includes the ability to load input and solution files from many popular finite element analysis (FEA) solvers. Supported formats include:

<table>
<thead>
<tr>
<th>Solver/File Format</th>
<th>File Name/Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Systems STL</td>
<td>.stl</td>
</tr>
<tr>
<td>ABAQUS Data</td>
<td>.fil</td>
</tr>
<tr>
<td>ABAQUS Input</td>
<td>.inp</td>
</tr>
<tr>
<td>ABAQUS Output Database</td>
<td>.odb</td>
</tr>
<tr>
<td>ANSYS CDWRITE Input</td>
<td>.cdb</td>
</tr>
<tr>
<td>ANSYS CFX</td>
<td>.res</td>
</tr>
<tr>
<td>ANSYS Result</td>
<td>.rst,.rth,.rfl</td>
</tr>
<tr>
<td>Fluent/FIDAP Neutral</td>
<td>.fdneut</td>
</tr>
<tr>
<td>LSTC-DYNA Input</td>
<td>.dyn,k</td>
</tr>
<tr>
<td>LSTC-DYNA Taurus State</td>
<td>.D3PLOT</td>
</tr>
<tr>
<td>MSC/NASTRAN Bulk Data</td>
<td>.bdf</td>
</tr>
<tr>
<td>MSC/NASTRAN Output2</td>
<td>.op2</td>
</tr>
<tr>
<td>MSC/PATRAN Neutral</td>
<td>.out</td>
</tr>
<tr>
<td>OpenFOAM</td>
<td>n/a</td>
</tr>
<tr>
<td>PTC/Mechanica Design Study</td>
<td>.neu</td>
</tr>
<tr>
<td>SDRC/IDEAS Universal</td>
<td>.unv</td>
</tr>
</tbody>
</table>

ABAQUS Output Database files are supported on Windows only. Other ABAQUS formats are supported on all platforms.

The file formats supported for each solver’s formats are:

<table>
<thead>
<tr>
<th>Solver</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Systems STL</td>
<td>all</td>
</tr>
<tr>
<td>ABAQUS</td>
<td>up to 6.11-1</td>
</tr>
<tr>
<td>ANSYS</td>
<td>up to 14.0</td>
</tr>
<tr>
<td>ANSYS CFX</td>
<td>up to 13.0</td>
</tr>
<tr>
<td>Fluent</td>
<td>up to 12.1</td>
</tr>
<tr>
<td>LST-DYNA</td>
<td>up to 970.0</td>
</tr>
<tr>
<td>MSC/NASTRAN</td>
<td>up to 2010</td>
</tr>
<tr>
<td>OpenFOAM</td>
<td>2.0, including compressed files</td>
</tr>
</tbody>
</table>
Files of each of these formats may be loaded by selecting “Load Data File” from the File menu, choosing the file format from the resulting dialog, and selecting [OK]. FEA formats have “(FEA)” appended to the format names. Choosing any one of these formats will display the main dialog for the corresponding FEA Loader. The selected format will be displayed in the title bar.

The FEA Loader dialog for the ANSYS Result file format is shown here.

- Select the Browse […] button to choose the file you wish to load.
- Subdividing Zones - Each zone loaded from an FEA file typically represents the entire solution at a particular time step or load increment. Sometimes a solution will consist of many components that you may wish to display individually. To activate this option, choose the “Subdivide Zones” toggle and select the desired subdivision option from the menu. Tecplot 360 provides you with two ways to subdivide zones: by Component and by Element Type.
  - Subdividing Zones by Component - Some FEA file formats include the ability to identify components or sub-regions. If this information is available, you may direct Tecplot 360 to apply it by selecting the “by Component” option. Components within each solution step will be identified by sequentially numbered zone names in Tecplot 360, for example, “Component 1 Step 1 Incr 1,” “Component 2 Step 1 Incr 1,” and so on.
  - Subdividing Zones by Element Type - If component information is not available in a solution file, the above option will produce only one component per solution step and increment. In this case, it may still be possible to achieve the desired effect if sub-regions in the solution are represented by different element types, such as shell elements and brick elements. Selecting “by Element Type” from the subdivision option menu creates a separate Tecplot 360 zone for each element type present in the solution file. Tecplot 360 zone names will then represent each element type, for example, “Quadrilaterals Step 1 Incr 1” and “Tetrahedrals Step 1 Incr 1.” This makes it easy to operate on individual components or sub-regions in Tecplot 360’s Zone Style dialog by selecting the desired zones by name.
- Selecting Zones and Variables to Load - See Section 4.6.1 “Selecting Zones and Variables to Load” on page 83.

<table>
<thead>
<tr>
<th>Solver</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>PTC/Mechanica Wildfire</td>
<td>up to 4.0</td>
</tr>
<tr>
<td>SDRC/IDEAS NX</td>
<td>up to Series 11</td>
</tr>
</tbody>
</table>
• **Auto Assign Strand IDs for Zones** - Regions or components of solutions throughout an unsteady solution are tracked by Strand IDs. All zones that represent a particular region or component are assigned the same Strand ID. Selecting this option directs Tecplot 360 to assign Strand IDs to the loaded zones. This ensures that only the zones representing the chosen solution time are displayed in Tecplot 360. Zones that do not have Strand IDs assigned are displayed at all solution times. See also **Section 7 - 2 “Time Aware”**.

• **Add Zones to Existing Strands** - If you are appending data to an existing dataset, select Auto Assign Strand IDs to Zones to append the new zones to existing strands. This is appropriate where the new data represents the same regions or components as are represented in the existing dataset, such as an additional solution time level of an unsteady solution.

### 4 - 6.1 Selecting Zones and Variables to Load

By default, Tecplot 360 loads all zones and variables present in the solution file, unless multiple steps or increments are present. In this case, Tecplot 360 will not load step 0 increment 0 (which normally has no solution data associated with it). If you wish to load step 0 increment 0, or a subset of the available zones or variables, choose the “Select Zones and Variables” toggle in the main loader dialog. When you then click OK, the FEA Loader Options dialog will be displayed, as shown below:

![FEA Loader Options](image)

Use the [Move All], [Move], [Remove], and [Remove All] buttons to add or subtract zones or variables from the list.
The Variables page is displayed above. The Zones page displays the zone list. If you elect to subdivide zones, the zones will be subdivided in the list. The figure below shows a zone list where “Subdivide Zones by Component” has been chosen:

When you have selected the zones and variables you wish to load, select [OK]. The resulting Tecplot 360 zones for each step and increment in the file will be named accordingly in Tecplot 360, beginning with Step 1 Incr 1. The precise meanings of “Step” and “Increment” are solver and problem-dependent, but normally correspond to time steps in unsteady cases, load increments in steady-state cases, or frequencies or vibrational modes in harmonic analyses.

4 - 6.2 Appending Finite Element Data to an Existing Dataset

If you wish to add a finite element solution to data you have already loaded, select “Add to current data” set in the Load Data File Warning dialog. The Load Data File Warning dialog will appear after you have selected the file and zones and/or variables to load.

Zones from the file will be added sequentially at the end of the current zone list, and new variables, if any, will be appended to the current variable list. The new zones will not be plotted initially. To plot the appended zones, select them in the Zone Style dialog, click the [Zone Show] button, and choose “Activate”.

84
4 - 6.3 Post-processing Finite Element Data

When you load an FEA solution into Tecplot 360, the FEA Post-processing dialog may be displayed (unless you are appending to an existing solution). You may re-display it at any time by selecting “FEA Post-processing” from the Tools menu.

The following formats will trigger the automatic display of the FEA Post-Processing dialog:
- ABAQUS
- ANSYS Input
- ANSYS Results
- ESI/PAM-CRASH
- LSTC/DYNA
- MSC/Nastran
- MSC/Patran
- PTC/Mechanica
- SDRC/IDEAS

The three sections of this dialog allow you to: deform the plot using deformation read from the solution file, animate the deformation, and derive new variables from the solution variables.

- **Deforming the FEA Plot** - Finite element solutions commonly include deformations calculated from applied loads. When a solution is initially read in, the un-deformed geometry is displayed. If the file contains deformation data, you can display the deformed geometry by toggling-on “Deform Plots by Factor”. The deformation factor is displayed to the right of this toggle. You may enter the deformation factor in this text field, or use the up or down arrows next to it to change it. By default, the Deform Plot by Factor toggle is checked and the field is set to “1”.

- **Animating the FEA Plot** - This feature is normally used only with steady-state deformations after you have set the deformation factor as described above. If your FEA solution file contains multiple steps of an unsteady solution, it is more likely that you will animate your entire solution using Tecplot 360’s zone or time animation features. For steady-state solutions, or for a single step of an unsteady solution, the animation available via this dialog animates the deformation of that step by sequentially applying positive or negative factors to the
deformation. To use this feature, choose whether to animate to the screen or to a file in the Animate Deformation menu, enter the number of steps (frames) you wish to see in the animation and the number of cycles, then click [Animate]. For one cycle, the animation will begin at zero deformation, then step up to maximum deformation, then down to the negative of that maximum, and then back to zero. Upon completion of the animation, the plot will be restored to the previous deformed plot.

• Deriving New Variables from an FEA Solution - FEA solutions may consist of various types of stress and strain, or gradients of scalar quantities such as temperature. The lowest section of this dialog allows you to calculate certain other quantities of interest that may be derived from these basic solution variables. For tensor quantities such as stress and strain, the principal stresses or strains plus Von Mises stress are available. For vector quantities, the vector magnitude may be calculated. Choose the derivation you want in the Derive list, and a list of candidate source variables in the solution will be displayed in the From list. Choose the source variable and click [Calculate] to add the desired quantity to the dataset. If Tecplot 360’s Calculate-on-demand feature is active, the variable will only actually be calculated when it is displayed. In this case, you may notice no delay when you select [Calculate], but some delay later when you choose to display the variable by selecting it, for example, as the contour variable.

Animate Options

Select the [Animate] button from the FEA Post-processing dialog to launch the Animation Options dialog. (See Chapter 31: “Animation” for more details on animation.)

This allows you to specify options for saving the deformation animation to a file. The following options are available:

• Width (pixels) - Enter a value in the text field to designate your exported image’s width. The image region is rendered to the image file to the exact Width by Height specifications. This text field initially displays the frame’s actual width.

• Height (pixels) - Displays the height of the image based on the value entered for Width, preserving the shape of the region to be exported. (Calculated by Tecplot 360.)

• Animation Speed (frames/sec) - Applicable only to AVI files. Enter a value in the text field to set your speed in frames per second.

• Use Multiple Color Tables - Selecting this check box will create a color table for each frame of the animation. If this check box is not selected, Tecplot 360 will scan each frame in your AVI file and create an optimal color table from 256 colors for the entire animation.

4 - 6.4 Abaqus Files in Layout Files

Abaqus, .odb files from older versions will be converted to the current format before being loaded through the user interface. However, this conversion will not occur automatically for files loaded with a layout file or via a macro command. To work around this, you will need to convert the older .odb file by loading it.
explicitly and saving the new .odb file. Then replace the file names in their layouts/macros with the new names.

4 - 6.5 Macro Commands for the FEA loader

You may also load FEA data files with Tecplot 360's macro language. The syntax is as follows:

```plaintext
$!READDATASET "STANDARDSYNTAX" "1.0"
...any of the name value pairs in the following table...
DATASETREADER = "FEA LOADER" See List below
```

The value for the DATASETREADER parameter should match the name of the loader as shown in the Select Import Format dialog, or as listed below.

- ANSYS® CDWRITE Input (FEA)
- ANSYS® Results (FEA)
- FLUENT/FIDAP® Neutral (FEA)
- ABAQUS Input (FEA)
- ABAQUS .fil Data (FEA)
- ABAQUS Output Database (FEA)
- LS/DYNA Input (FEA)
- LS/DYNA Taurus State Database (FEA)
- MSC/NASTRAN Bulk Data (FEA)
- MSC/NASTRAN Output2 (FEA)
- MSC/Patran Neutral (FEA)
- OpenFOAM (FEA)
- PTC/Mechanica Design Study (FEA)
- SDRC/IDEAS Universal (FEA)
- 3D Systems STL (FEA)

Each name/value pair should be in double quotes. Refer to the Scripting Guide for details on working with Tecplot 360's macro language.

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Available Values</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>STANDARDSYNTAX</td>
<td>1.0</td>
<td>Required as the first instruction.</td>
</tr>
<tr>
<td>Append</td>
<td>&quot;Yes&quot; or &quot;No&quot;</td>
<td>Specify whether to append the current dataset with the FEA file(s).</td>
</tr>
<tr>
<td>FILENAME_File</td>
<td>&quot;filename&quot;</td>
<td>Specify the full or relative path of the file name.</td>
</tr>
<tr>
<td>SubdivideZonesBy</td>
<td>&quot;DoNotSubdivide&quot;</td>
<td>Specify method of zone division.</td>
</tr>
<tr>
<td></td>
<td>&quot;Component&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ElementType&quot;</td>
<td></td>
</tr>
<tr>
<td>AutoAssignStrandIDs</td>
<td>&quot;Yes&quot; or &quot;No&quot;</td>
<td>Set to &quot;Yes&quot; to have Tecplot 360 assign the strand IDs.</td>
</tr>
<tr>
<td>AddToExistingStrands</td>
<td>&quot;Yes&quot; or &quot;No&quot;</td>
<td>Available only if Append is set to &quot;Yes&quot;.</td>
</tr>
<tr>
<td>ZoneList</td>
<td>&quot;Z1,Z2,Z3-Z9,...&quot;</td>
<td>Specify the list of zones to load. You may specify a comma-separated list or use a range (-).</td>
</tr>
<tr>
<td>VarNameList</td>
<td>&quot;VarName1&quot;+&quot;VarName2&quot;+...</td>
<td>Specify the list of variables to load. Use the &quot;+&quot; symbol between each variable name.</td>
</tr>
</tbody>
</table>
Example

The following example loads "myfile.odb" with the Abaqus Output Database loader. Zones 1 & 2 are loaded, along with the following variables: external force, stress, material ID, and part ID.

```
$!READDATASET
  "STANDARDSYNTAX" "1.0"
  "FILENAME_File" "myfile.odb"
  "SubdivideZonesby" "Component"
  "AutoAssignStrandIDs" "Yes"
  "ZoneList" "1-2"
  "VarNameList" "External Force"+"Stress"+"Material ID"+"Part ID"
  "InitialPlotType" "Cartesian3D"
  "ShowFirstZoneOnly" "No"
DATASETREADER = 'ABAQUS Output Database (FEA)'
```

4 - 7 FLOW-3D Loader

The FLOW-3D loader allows you to load restart and selected FLOW-3D data files into Tecplot 360.

When working with FLOW-3D data in Tecplot 360, we recommend linking the solution time between frames using Frame>Frame Linking.

To load FLOW-3D data, select “Load Data File(s)” from the File menu. In the Select Import dialog, select the “FLOW-3D data” option.

The FLOW-3D Loader dialog has the following options:

- **File** - Use the [...] browse button to launch the Read FLOW-3D Data File dialog which will allow you to navigate to the data file you would like to load. You may load data files with the .flsgrf extension only. Alternatively, you may type the full path of the data file in the File text field.

- **Data Selection** - Use the Data Selection region of the dialog to specify whether to load restart or selected data. You may also opt to Include Particle Data or to select a Data Subset.
• **Load Restart Data** - Select this option to load restart data into Tecplot 360. Restart data contains every simulation variable at a small number of time steps.

• **Load Selected Data** - Select this option to load selected data. Selected data typically includes fewer variables than restart data. However, it usually has a larger number of time steps. Selected data is used to output variables of interest at many time steps without bloating the output file with “uninteresting” variables.

• **Include Particle Data** - Toggle-on “Include Particle Data” to load the particle data from your data file.

• **Data View** - Use the Data View region of the dialog to specify whether to view the data as external or internal flow. This option affects how the solid surfaces are drawn at block boundaries. For external flows, surfaces are drawn only at blocked boundaries in the mesh. This option is recommended for solutions that involve flow around obstructions in free space. For internal flows, surfaces are drawn around open space in the mesh, and blocked surfaces are eliminated. This option is recommended for solutions that involve flow into an enclosed volume, such as casting results.

• **Specify Additional Options** - Select the “Specify Additional Options” toggle to launch the FLOW-3D Loader Options dialog after selecting [OK] on the FLOW-3D Loader dialog. The FLOW-3D Loader Options dialog allows you to load a subset of zones and/or variables from the data file. The Options page of the dialog allows you to specify transient options, specify boundary cell options, and calculate the complement of \( R \).

4 - 7.1 **FLOW-3D Loader Options**

The FLOW-3D Loader Options dialog is launched when you select the “Specify Additional Options” toggle in the FLOW-3D Loader dialog.

**Variables Page**

Use the Zones page of the dialog to select which zones from your dataset to load into Tecplot 360. The box on the left lists the available zones, and the box on the right lists the variables selected to load into Tecplot 360.

Selected data is available in the file only when you request it before the simulation run.
**Zones Page**

Similarly, use the Variables page of the dialog to select which variables to load.

![Variables page](image)

**Other Page**

Use the Other page of the dialog to specify transient options, boundary options, and whether to calculate the complement of \( F \).

![Other page](image)

The page has the following options:

- **Transient Options** - Use the Transient Options region of the dialog to specify:
  - **Time Skip** - Specify the interval between each loaded time step. A value of one loads all time steps, a value of two loads every other time step, and so forth.
  - **Auto Assign Strand IDs** - Select this option to allow Tecplot 360 to assign the Strand IDs to your data. Regions or components of solutions throughout an unsteady solution are tracked by Strand IDs. All zones that represent a particular region or component are assigned the same Strand ID. Selecting this option directs Tecplot 360 to assign Strand IDs to the loaded zones. This ensures that only the zones representing the chosen solution time are displayed in Tecplot 360. Zones that do not have Strand IDs assigned are displayed at all solution times. See also Section 7 - 2 “Time Aware”.
  - **Add Zones to Existing Strands** - If you are appending data to an existing dataset, select Auto Assign Strand IDs to Zones in order for Tecplot 360 to append the new zones to existing strands. This is appropriate where the new data represents the same regions or components as are represented in the existing dataset, such as an additional solution time level of an unsteady solution.
For more information on working with transient data, refer to Section 7.2 "Time Aware."

- **Calculate Derived Variables** - Use the Calculate Derived Variables region of the dialog to opt to include the Complement of F. The complement of F is calculated as:

\[
\text{Complement of } F = (1 - f) \cdot \{vf\}
\]

where \( f \) is the fluid fraction and \( vf \) is the volume fraction.

The Fluid Surface, where \( \text{Fluid Surface} = \{vf\} \cdot \{f\} \), is always calculated and added to the dataset.

- **Include Boundary Cells On** - Use the boundary cell region of the dialog to specify whether to load boundary cells on the I, J, or K extrema. An additional layer of boundary cells will be loaded on the given side of each block for each extremum selected.

- **Load on Demand** - Toggle-on "Cache unloaded data in temporary directory" to enable Tecplot 360 to create a temporary directory to cache the data. The data in the temporary directory is formatted such that it may be quickly read back into Tecplot 360 as needed.

### 4 - 7.2 FLOW-3D Macro Commands

The \$READDATASET macro command extended for the FLOW-3D loader with the following options:

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Default</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>FILENAME_File</td>
<td>Path to flow-3d results file name</td>
<td>none</td>
<td>Specifies the path to the file to load.</td>
</tr>
<tr>
<td>DataGroup</td>
<td>Selected or Restart</td>
<td>&quot;Restart&quot;</td>
<td>Specifies which data group to load from the file.</td>
</tr>
<tr>
<td>IncludeParticleData</td>
<td>&quot;Yes&quot; or &quot;No&quot;</td>
<td>&quot;No&quot;</td>
<td></td>
</tr>
<tr>
<td>DeriveCompOfF</td>
<td>&quot;Yes&quot; or &quot;No&quot;</td>
<td>&quot;No&quot;</td>
<td></td>
</tr>
<tr>
<td>Append</td>
<td>&quot;Yes&quot; or &quot;No&quot;</td>
<td>&quot;No&quot;</td>
<td></td>
</tr>
<tr>
<td>AutoAssignStrandIDs</td>
<td>&quot;Yes&quot; or &quot;No&quot;</td>
<td>&quot;Yes&quot;</td>
<td></td>
</tr>
<tr>
<td>ZoneList</td>
<td>Set of zone numbers to load from the file</td>
<td>All</td>
<td>FLOW-3D refers to these as &quot;blocks.&quot; Really, they are a set of zones that will belong to the same StrandID.</td>
</tr>
<tr>
<td>VarNumList</td>
<td>Set of variable names to load from the file</td>
<td>All</td>
<td>X, Y, Z, and Fluid Surface are always loaded.</td>
</tr>
<tr>
<td>DataView</td>
<td>&quot;Internal&quot; or &quot;External&quot;</td>
<td>External</td>
<td>Specify whether to view the data as an internal or external flow solution.</td>
</tr>
<tr>
<td>IncludeBoundaryCells</td>
<td>&quot;YES/NO&quot;</td>
<td>&quot;YES/NO&quot;</td>
<td>Specifies 6 boolean values for including boundary cells. The values are used the following order for the boundary cells:</td>
</tr>
<tr>
<td></td>
<td>&quot;YES/NO&quot;</td>
<td>&quot;YES/NO&quot;</td>
<td>IMIN, JMIN, JMAX, KMIN, KMAX</td>
</tr>
</tbody>
</table>

Refer to Scripting Guide for additional information regarding Tecplot 360’s macro language.

### 4 - 7.3 FLOW-3D Auxiliary Data

The following auxiliary data is added to the dataset by the loader:

<table>
<thead>
<tr>
<th>Auxiliary name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common.UVar</td>
<td>Number of variable &quot;U&quot;</td>
</tr>
<tr>
<td>Common.VVar</td>
<td>Number of variable &quot;V&quot;</td>
</tr>
<tr>
<td>Common.WVar</td>
<td>Number of variable &quot;W&quot;</td>
</tr>
<tr>
<td>Common.VectorVarsAreVelocity</td>
<td>TRUE</td>
</tr>
<tr>
<td>Common.PressureVar</td>
<td>Number of variable &quot;P&quot;</td>
</tr>
</tbody>
</table>
The FLUENT® Data Loader reads FLUENT Version 5 and newer case (.cas) and data (.dat) files. To load files from earlier versions of FLUENT, you must first import them into FLUENT 5 or newer, then resave them in the newer format.

When possible, and assuming the user has the necessary permissions to create new files in the directory containing the FLUENT files, the FLUENT loader creates an index file for each case and data file it loads. These files are stored in a subdirectory called `tecplot-derived` located in the same directory as the case and data files and are used to load the data faster in future sessions. The FLUENT loader assumes that any files it finds in the `tecplot-derived` directory relate to the case and data files found in the parent directory. If the FLUENT data files are updated, delete the files in the `tecplot-derived` directory so that the FLUENT loader will regenerate them. (Be sure all Tecplot 360Engine sessions using the files are closed first.)

Tecplot 360Engine does not automatically calculate CFD variables from your existing FLUENT data variables. You may add the variables to your plots by performing calculations via the Analyze menu. Refer to Chapter 22: “CFD Data Analysis” for details.

Additionally, Tecplot 360 does not perform the same wall-boundary calculations that are performed by FLUENT. Instead, the cell-centered data will be extrapolated to the boundary.

See also Section 7.2 “Time Aware” for information on working with transient datasets in Tecplot 360.

### Auxiliary Data

<table>
<thead>
<tr>
<th>Auxiliary name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common.DensityVar</td>
<td>Number of variable &quot;RHO&quot;</td>
</tr>
<tr>
<td>Common.TemperatureVar</td>
<td>Number of variable &quot;TN&quot;</td>
</tr>
<tr>
<td>Common.StagnationEnergyVar</td>
<td>Number of variable &quot;RHOE&quot;</td>
</tr>
<tr>
<td>Common.TurbulentKineticEnergyVar</td>
<td>Number of variable &quot;TKE&quot;</td>
</tr>
</tbody>
</table>

Auxiliary Data can be viewed on the Auxiliary Data Page of the Dataset Information dialog (accessed via the Data menu).
The following options are available:

- **Load Case and Data Files** - Loads both a case and a data file. The grid comes from the case file, and the solution comes from the data file.
- **Load Case File Only** - Loads the grid from a case file.
- **Load Residuals Only** - Loads the residual data (convergence history) from a data file. The residuals are not scaled or normalized.
- **Load Multiple Case and Data Files [DEFAULT]** - Displays the File List form in the dialog. You can load matched pairs of case and data files, or one case file and any number of data files that match it (that is, that have the same zones).

For all load options above, except Load Multiple Case and Data Files, the following controls are available:

- **Case File** - Type the name of the case file you wish to load, or click [Select], then select the name of the file from the resulting dialog.
- **Data File** - The data (.dat) file contains the solution and the residual (convergence history) data. Type the name of the data file, or click Select, then select the name of the file from the resulting dialog.

For the Load Multiple Case and Data Files load option, the following controls are available:

- **Add Files** - Choose case and data files to load from a file selection dialog. Selected files are appended to the file list.
- **Remove** - Remove files you have selected in the file list.
- **Remove All** - Remove all files in the file list.
- **Flow is Unsteady** - Indicates that the set of case and data files represents an unsteady solution. The loader adds a TIME auxiliary data item to each loaded zone. Tecplot 360 does not use this data, but other add-ons may.
• **Flow Solution is Unsteady/Time Interval** - The FLUENT data loader saves the problem time of each solution as the solution time variable. There are two options for determining the time to save for each one: (1) reading the flow-time entry from each .dat file, or (2) applying a constant time interval to successive .dat files.

  - **Read Time from Data Files** - If this option is selected, Tecplot 360 reads the flow-data parameter from each .dat file. If no .dat files are included (i.e. only .cas files are loaded), the solution time variable will not be created for the zones.

  - **Apply Constant Time Interval** - If this option is selected, Tecplot 360 applies the time interval specified in the Time Interval text field to zones created from successive .cas or .dat files. The zones from the first .cas/.dat files are given time 0. Times for successive files are calculated by incrementing the time of the previous files by the specified time interval.

  - **Assign Strand IDs for Zones** - Toggle-on to have Tecplot 360 assign Strand IDs to transient zones. Common strand IDs will be assigned to each cell or boundary zone with matching FLUENT zone IDs.

  - **Add Zones to existing Strands** - Toggle-on to add the appended zones to StrandIDs in the current dataset.

• **Time Interval** - If “Apply Constant Time Interval” is selected, the time interval entered in the text field is included.

For the load options other than Load Residuals, some or all of the following controls are available:

• **Load Cells and Boundaries** - Loads the cell (solution) and boundary zones from the case file. Each fluid or solid cell zone and each boundary zone will be displayed as a separate zone in Tecplot 360.

• **Load Cells Only** - Loads only the cell (solution) zones. Each zone will be displayed as a separate zone in Tecplot 360.

• **Load Boundaries Only** - Loads only the boundary zones. Each zone will be displayed as a separate zone in Tecplot 360.

• **Select Zones and Variables to Load** - Select in a separate dialog which zones and variables to load. The option requires the loader to pre-scan all files, which can be time-consuming.

• **Create All Zones As Polyhedral** - Select this option to load all FLUENT zones as Tecplot 360 polytope (polygonal or polyhedron) zones. We recommend you select this option, as converting all zones to polyhedral zones eliminates the possibility of hanging nodes and holes in your iso-surfaces or slices. In this case, the number of faces per element is derived from the element-type, and the number of nodes per face is derived from the face-type. The existence of hanging nodes (determined from the existence of a cell-tree and/or face-tree section) adds to the number of faces in the element and the number of nodes in the face that contains the hanging node. Since polygons must have at least 3 nodes, line segment elements will not be converted. When this option is not selected, only FLUENT polytope zones will become Tecplot 360 polytope zones. In this case, if hanging nodes are encountered, Tecplot 360 will create larger faces, compress connectivity, and expand face neighbors.

• **Include Particle Data** - Some FLUENT simulations include the effects of discrete particles, such as sand grains or water droplets. Select this option to load this particle data along with the flow solution. All particles from a particular injection will be displayed in a single Tecplot 360 zone (one zone per injection). If you have chosen to select which zones and variables to load,
this option is disabled, but the particle zones and variables will be displayed in the selection lists, allowing you to load them with the flow solution.

- **Average to Nodes** - Selecting this option directs the loader to average FLUENT’s cell-centered data to the grid nodes. This can speed up subsequent operations in Tecplot 360, especially slicing. FLUENT stores solution data at cell centers (face centers for boundary zones). By default, the FLUENT data loader loads the data cell-centered as well. However, you have the option to average the data to the nodes using Arithmetic or Laplacian averaging. Arithmetic averaging is faster, but calculates values at hanging nodes (nodes in the center of a cell face or edge) only from those cells where the node is a corner. This can lead to discontinuous contours. Laplacian averaging option takes additional neighboring cells into account, and results in smoother contours when hanging nodes are present. By default, non-grid variables are stored at cell centers, consistent with FLUENT.
  - **Arithmetic** - A simple, fast arithmetic averaging will be performed.
  - **Laplacian** - A more accurate, much slower averaging will be performed that accounts for hanging nodes and cell sizes.

If you chose the Select Zones and Variables to Load option, select only those zones and variables you wish to load from the files. Fluent Loader Options dialog.

This dialog has a Zones page and a Variables page. The left-hand list of each page shows, respectively, all zones and variables contained in the files you selected. The right-hand list of each page shows the zones and variables that will be loaded when you select [OK]. Use the [Move], [Move All], [Remove], or [Remove All] buttons to edit the Zones/Variables to Load lists.

### 4- 8.1 Macro Commands for the FLUENT loader

The syntax for loading FLUENT data files with the Tecplot macro language is as follows:

```plaintext
$!READDATASET
   "STANDARDSYNTAX" "1.0"
   "$any of the name value pairs in the following table...
   DATASETREADER = "FLUENT DATA LOADER"
```
Each name/value pair should be in double quotes. Refer to the Scripting Guide for details on working with the Tecplot macro language.

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Available Value(s)</th>
<th>Default</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>STANDARDSYNTAX</td>
<td>1.0</td>
<td>n/a</td>
<td>Must be the first instruction.</td>
</tr>
<tr>
<td>Append</td>
<td>“Yes” “No”</td>
<td>“No”</td>
<td>Specify whether to append the current dataset with the FLUENT file(s).</td>
</tr>
<tr>
<td>LoadOption</td>
<td>“CaseAndData” “CaseOnly” “ResidualsOnly” “MultipleCaseAndData”</td>
<td>n/a</td>
<td>Specify whether to load case and data files, a case file only, residual data only, or multiple case and data files.</td>
</tr>
<tr>
<td>FILENAME_CaseFile</td>
<td>“filename”</td>
<td>n/a</td>
<td>Specify the full or relative path of the case file name. Used if the LoadOption is CaseAndData or CaseOnly.</td>
</tr>
<tr>
<td>FILENAME_DataFile</td>
<td>“filename”</td>
<td>n/a</td>
<td>Specify the full or relative path of the data file name. Used if the LoadOption is CaseAndData or ResidualsOnly.</td>
</tr>
<tr>
<td>FILELIST_Files</td>
<td>“n” “file1” “file2” ... “filen”</td>
<td>n/a</td>
<td>Specify the number of files, followed by each file name. Only available if the LoadOption is MultipleCaseAndData.</td>
</tr>
<tr>
<td>UnsteadyOption</td>
<td>“ReadTimeFromDataFiles” “ApplyConstantTimeInterval”</td>
<td>“ReadTimeFromDataFiles”</td>
<td>Only available if LoadOption is MultipleCaseAndData. For “ApplyConstantTimeInterval”, the TimeInterval parameter is required.</td>
</tr>
<tr>
<td>TimeInterval</td>
<td>“&lt;double&gt;”</td>
<td>“1.0”</td>
<td>Specify the value of the time interval. Only available if the UnsteadyOption is set to ApplyConstantTimeInterval.</td>
</tr>
<tr>
<td>AssignStrandIDs</td>
<td>“Yes” “No”</td>
<td>“No”</td>
<td>Only available if LoadOption is MultipleCaseAndData.</td>
</tr>
<tr>
<td>AddZonesToExistingStrands</td>
<td>“Yes” “No”</td>
<td>“No”</td>
<td>Only applicable when Append is set to “yes”.</td>
</tr>
<tr>
<td>GridZones</td>
<td>“CellsAndBoundaries” “CellsOnly” “BoundariesOnly” “SelectedZones”</td>
<td>“CellsAndBoundaries”</td>
<td>If “SelectedZones” is specified, either the ZoneList parameter, the VarList parameter, or both parameters are required.</td>
</tr>
<tr>
<td>ZoneList</td>
<td>“Z1,Z2,...Z3-37”</td>
<td>all zones</td>
<td>Specify the list of zones to load. You may specify a comma-separated list or use a range (.). This option is only available if GridZones is set to SelectedZones.</td>
</tr>
</tbody>
</table>
The General Text Loader add-on allows you to read ASCII text data files in a variety of formats. You can specify variable and dataset title information or indicate specific places to read them from in your data file. Instruction settings for reading a type of file can be saved and restored so they do not have to be entered again each time a new file of the same type is loaded.

The following options are available:

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Available Value(s)</th>
<th>Default</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>VarList</td>
<td>&quot;V1&quot;+&quot;V2&quot;+&quot;V3&quot;+....</td>
<td>all variables</td>
<td>Specify the list of variables to load. Use the &quot;+&quot; symbol between each variable number. This option is only available if GridZones is set to SelectedZones.</td>
</tr>
<tr>
<td>IncludeParticleData</td>
<td>&quot;Yes&quot; &quot;No&quot;</td>
<td>&quot;No&quot;</td>
<td>Available only for CaseAndData and MultipleCaseAndData load options.</td>
</tr>
<tr>
<td>AllZonesArePoly</td>
<td>&quot;Yes&quot; &quot;No&quot;</td>
<td>&quot;No&quot;</td>
<td>Not available if the load option is ResidualsOnly. Set to &quot;Yes&quot; to convert all zones to Tecplot polytope zones (polyhedral or polygonal).</td>
</tr>
<tr>
<td>AverageToNodes</td>
<td>&quot;Yes&quot; &quot;No&quot;</td>
<td>&quot;Yes&quot;</td>
<td>Specify whether to average the cell-centered data to the grid nodes.</td>
</tr>
<tr>
<td>AveragingMethods</td>
<td>&quot;Arithmetic&quot; &quot;Laplacian&quot;</td>
<td>&quot;Arithmetic&quot;</td>
<td>Specify the averaging method to use. Available only if AverageToNodes is set to &quot;yes&quot;.</td>
</tr>
</tbody>
</table>

### 4 - 9 General Text Loader

The General Text Loader add-on allows you to read ASCII text data files in a variety of formats. You can specify variable and dataset title information or indicate specific places to read them from in your data file. Instruction settings for reading a type of file can be saved and restored so they do not have to be entered again each time a new file of the same type is loaded.
• Titles - Launches the Dataset Title dialog, which allows you to specify dataset title properties.
• Variables - Launches the Variable Import Instructions dialog which allows you to specify dataset variable properties.
• Data - Launches the General Text Loader: Data dialog which allows you to specify dataset field properties.
• General Filters - Launches the General Text Loader: Filters dialog which allows you to specify general filters when reading your file.
• Configuration File List - This list shows available configuration files. Configuration files can be edited using a text editor, although this is not usually necessary and is not recommended. The format of these files is listed on the Configuration page.
  • Load - Loads a single configuration file from any location.
  • Save - Saves a single configuration file to any location.
  • Rename - Renames a configuration file.
  • Delete - Deletes a configuration file.
  • New - Creates a new, untitled configuration file.
• Data Preview
  • View Raw Data - This displays the data exactly how it looks in the file without any processing.
  • View Processed Data - This displays the processed and filtered data that will be loaded.
  • View Options - Launches the General Text Loader: View Options that allows you to select the viewing options.

4 - 9.1 Dataset Title

The Dataset Title dialog allows you to specify options for General Text Loader titles.

![Dataset Title Dialog](image)

• Use Title - Manually enter the dataset title, rather than have General Text Loader scan the file for it.
• Use line number - Enter the line number of the dataset title in the file. The General Text Loader skips white space on the line until text, and then reads until the delimiter indicated is found. To include spaces in the title, enclose them in double quotes.
• Use first line containing keyword - Enter a keyword for the dataset title line. The title will read the first line containing this keyword (case insensitive). General Text Loader searches for a title on this line in the following order, (unless the delimiter is specified as fixed):
  a. First, it will look for any text enclosed in double quotes. If it finds this, then the enclosed text will be read as the title.
b. If no text in double quotes is found, the first non-white space text after the keyword ending with the indicated delimiter will be used.

- **Text Delimiter** - The text delimiter indicates when the end of text has been reached. You can set it to one of the following:
  - *Auto* - Space, tab, comma, semicolon.
  - *Fixed* - Each width number of characters on the line is a token field. White space is removed from the beginning and end of the field.
  - *Width* - If the delimiter is fixed, enter the width of each field here.

### 4 - 9.2 Variable Import Instructions

The **Variable Import Instructions** dialog of the General Text Loader allows you to scan for the location of the variable names in the data file, and enter which variables to load.

- **Scan for variable names** - Specify the following:
  - **Start line** - Enter the starting line of variable names in the file.
  - **End line** - Enter the ending line of the variable names in the file. This is typically the same as the starting line.
  - **Delimiter** - The delimiter indicates when the end of each variable name has been reached.
    You can set it to one of the following:
    - *Auto* - Space, tab, comma, semicolon.
    - *Fixed* - Each 'width=n' number characters on the line is a variable. White space is removed from the beginning and end of the field. For example, if the line length is 60 and the width is ten, the columns 1-10, 11-20, 21-30, and so forth, are variable names. Spaces are removed from the beginning and end of the variable names.
  - **Width** - If the delimiter is fixed, enter the width of each field here.
  - **Enter Variable Names** - Select this option to enter a list of variable names in the dialog box. Variable names should be separated by carriage returns.
- **Select Variables to Load** - Launches the **Variable to Load** dialog.

- **Variables to Skip** - Displays a list of variables that will be skipped.
- **Variables to Load** - Displays a list of variables that will be loaded.

Use the [Move], [Move All], [Remove], or [Remove All] buttons to edit the “Variables to Load” list.
4 - 9.3 General Text Loader: Data

The Data Import Instructions dialog of the General Text Loader allows you to specify the location of the data names in the data file, and what data to load.

- **Start Identification**
  - First all-numeric line - Select if the data begins at the first line of a file that contains only numbers. If you have specified multiple zones, all non-numeric lines will be skipped at the beginning of each zone.
  - First line after line with keyword - Select if the data begins at the first non-blank line after the line containing the specified keyword. The keyword is case insensitive.
  - Start at line number - Select to specify the line number where the data begins. Blank lines are ignored in the data section.

- **End Identification**
  - All lines up to first non-numeric line - Select if the data ends at the first non-blank line containing any text.
  - Stop at line number - Select to specify the line number where the data ends.
  - All lines up to line with keyword - Select if the data ends at the first line before the line with the specified keyword. The keyword is case insensitive.
  - End of file - Select if the data ends at the end of file.

- **Data Identification**
  - Point format - In this format all values of all variables are given for the first point, then the second point, etc.
• Block format - In this format all values for the first variable are given, then all values for the second variable, etc.

• Data value delimiter - The data value delimiter indicates when the end of a data value has been reached. You can set it to one of the following:
  • Auto - Space, tab, comma, semicolon.
  • Fixed - Each 'width=n' number characters on the line is a token field. White space is removed from the beginning and end of the field. For example, if the line length is 60 and the width is ten, the columns 1-10, 11-20, 21-30, and so on, are token fields.
  • Width - If the delimiter is 'fixed', enter the width of each field here.

• Data Dimension - If the data dimensions are entered, General Text Loader adds zones as necessary depending on the number of data points found in the file. There must be an equal number of data points for each zone (equal to the product of the IJK dimensions).

• Auto-Calculate IMAX - The I-dimension is calculated based on the number of data points found. J and K-max are set to one.

• Specify Dimensions - Specify the I, J, and K-dimensions for the data. There must be enough data points found in the file to match the indicated dimensions.

• Allow Multiple Zones - If checked, General Text Loader will attempt to read more than one zone from the data file.

• Zone ends on line with keyword - If Allow multiple zones is selected and Auto-calculate IMax is selected, then you must enter a keyword here to mark the end of one zone and the beginning of the next. Zones are ended when a line containing this text is found.

• Ignore non-numeric tokens - If checked, then any non-numeric information in the data sections is ignored. If not checked, General Text Loader displays an error if any non-numeric data is found in the data section.

4 - 9.4 General Text Loader: Filters

Use the General Filters dialog of the General Text Loader to filter the data file.

• Ignore All Lines Starting With - If checked, all lines beginning with the entered string are ignored.

• Ignore All Lines Containing - If checked, all lines containing the indicated text are ignored.
General Text Loader

- **Ignore Character Column Position(s)** - If checked, then the entered columns are ignored when scanning the file. Columns are entered as a single number or a hyphenated range, one or more of which may be separated by commas.

  If there are tabs in the data file, they are not expanded in this filter. For example, if column 1 is a tab and you wish to skip column 2, you should enter 2, even though a text editor will show more than one space after expanding the tab.

- **Ignore Specific Lines** - If checked, entered lines are ignored when scanning the file. Lines are entered as a single number or a hyphenated range, one or more of which may be separated by commas. You may also use “end” to specify the last line of the file.

- **Specify Values for Blanked Cell** - If checked, you can specify a value which the loader uses for blank cells.

  This option is only available if the data delimiter is a comma or semicolon. You can change the data value delimiter using the **Data Import Instructions** dialog.

**4 - 9.5 General Text Loader: View Options**

The **View Options** dialog of the General Text Loader allows you to specify the data display.

**General Options**

- **Limit lines displayed** - Limits the number of lines displayed in the preview window. For large files, you may want to set this to a number less than the total number of lines. The fewer number of lines, the faster the preview display.

- **Do not limit** - If you select this toggle, the entire file will be displayed in preview mode.

- **Auto Process** - If selected, General Text Loader automatically refreshes all information about the file whenever any loader settings are changed. For very large files (multi-megabyte), this option is not recommended, since re-scanning a large file can be time consuming.

**Processed Data**
• **Show variable names and data** - If selected, variable names and processed data will be displayed in the preview window.

• **Show variable names only** - If selected, only variable names will be displayed in the preview window.

• **Show all non-processed lines** - If selected, all lines which will not be loaded will be displayed in the preview window.

• **Show data in columns** - Shows the data in columns where each column is a variable.

• **Show data in blocks** - Shows the data in blocks where each block is a variable.

4 - 9.6 General Text Loader Configuration File

A configuration file contains all of the instructions that tell General Text Loader how to load a particular type of text file. This information is collected from the dialog fields and written to a file when you click [Save] on the main dialog. The configuration file format is similar to the Tecplot 360 macro language format. Configuration files for the general text loader are ASCII text files which use a command set that can describe all loading instructions. Normally you do not need to edit these files, as they are automatically written by the loader when you select New on the main dialog.

Editing these configuration files by hand is not recommended.

**General Text Loader CONFIGFNAME Command**

When reading a dataset using General Text Loader, instead of specifying individual parameters in $!READDATASET, you may use the CONFIGFNAME command.

This consists of:

```
CONFIGFNAME = <string>
VERSION = <integer>
# version of the template file (default is 100)
# Note: changing the version number may cause unpredictable behavior
TITLE
    {SEARCH = [NONE|LINE|KEYWORD] # default = NONE
     NAME = <string>
     # default = "New Dataset", ignored if SEARCH is not LINE
     default = "New Dataset", ignored if SEARCH is not LINE
     KEYWORD = <string> # ignored if SEARCH is not KEYWORD
     DELIMITER = [AUTO|TAB|SPACE|SEMICOLON|COMMA|FIXED]
     WIDTH = <integer> # Valid only if DELIMITER = FIXED
     }
VARIABLES
    {SEARCH = [NONE|LINE]
     NAMES = <string> # ignored if SEARCH is SCAN
     loaded = <all|n1,n2,...,nn> # list of variables to be loaded
     STARTLINE = <integer> # 1-based, ignored if SEARCH=NONE, default = 1
     STARTID = [FIRSTNUMERICLINE | LINE | KEYWORD]
     }
     {KEYWORD = <string> # ignored if STARTID is not KEYWORD
      ENDLINE = <integer> # 1-based, ignored if SEARCH=NONE, default = 1
      DELIMITER = [AUTO|TAB|SPACE|SEMICOLON|COMMA|FIXED]
    }
```
Where <string> is a file name or file path. Settings will be loaded from the file name specified in <string>.
This command is only allowed in conjunction with the $!READDATASET command as described below. It may not be used inside a configuration file.

For example, instead of:

```
WIDTH = <integer> # Valid only if DELIMITER = FIXED
```
```
DATA {
  IGNORONUMERIC_TOKENS = <boolean> # default = TRUE
  IMPORT LINE = <integer> # 1-based, ignored if STARTIDENTIFICATION is not LINE
  ENDID = [FIRSTNONNUMERICLINE | LINE | KEYWORD] (# ignored if ENDID is not KEYWORD
  LINE = <integer> # 1-based, ignored if ENDID is not LINE
  FORMAT = [POINT | BLOCK] # default POINT
  DELIMITER = [AUTO | TAB | SPACE | SEMICOLON | COMMA | FIXED]
  WIDTH = <integer> # Valid only if DELIMITER = FIXED
}
DIMENSION {
  AUTO = <boolean> # default = TRUE
  IMAX = <integer> # ignored if AUTO = TRUE, default = 1
  JMAX = <integer> # ignored if AUTO = TRUE, default = 1
  KMAX = <integer> # ignored if AUTO = TRUE, default = 1
  USEMULTIPLEZONES = <boolean> # ignored if USEMULTIPLEZONES = FALSE
  KEYWORD = <string> # ignored if USEMULTIPLEZONES = FALSE
}
GLOBALFILTERS # filters are applied cumulatively, so lines matching any of the criteria are filtered
{
  COMMENT = <string> # ignore lines beginning with <string>
  NUMBER = <integer> # ignore all lines starting with line number <integer>
  KEYWORD = <string> # ignore all containing <string> (case insensitive)
  COLUMNS = <list> #<list> is a UNIX-style comma separated list of numbers
    # example: "1-80,100-end", etc. Must be in double quotes
  ROWS = <list> # same as above
  USEBLANKCELLVALUE = <boolean> # if TRUE, then the value of blank cells
    # is BLANKCELLVALUE
  BLANKCELLVALUE = <double> # blank cell value. Ignored if
    # USEBLANKCELLVALUE is FALSE
}
```

This command is only allowed in conjunction with the $!READDATASET command as described below. It may not be used inside a configuration file.

For example, instead of:

```
$!READDATASET "C:\test.txt" "VERSION=100 FILEEXT="*.txt" FILEDESC="general text" "+" "TITLE{SEARCH=NONE NAME="New Dataset" LINE=1 DELIMITER=AUTO WIDTH=10}
```

```
DIMENSION-auto=TRUE CREATEMULTIPLEZONES=false
```

```
GLOBALFILTERS-USEBLANKCELLVALUE=TRUE BLANKCELLVALUE=0.000000
```

```
DATASETREADER = 'General Text Loader'
```

Using the `CONFIGFNAME` command, you can write:

```
$!READDATASET "myfile.dat"
"CONFIGFNAME=c:\config_files\myconfig.lgc" # contains all of the instructions in the example above
DATASETREADER='General Text Loader'
```

**Components of the Configuration File**

- All General Text Loader configuration files must start with the line:
  
  `#TECPLOT_LOADGEN`

- **Instruction Syntax** - Each instruction file contains commands which describe the loading instructions.

- **Comments** - Any text following `#` to the end of the line is ignored.

- **String Format** - The `<string>` parameter must be enclosed in double quotes. You can include a double quote character in the string by preceding it with a backslash '\'. For example:
  
  - "This is a normal string"
  - "This is a "quote" inside a string"

- **List Format** - The `<list>` parameter type is defined as one or more number ranges, separated by commas, enclosed in double quotes. A number range may be a single number or two numbers separated by a dash. Optionally, you may use "end" to indicate the last valid number. For example:
  
  - "1"
  - "1-2,7,3"
  - "10-end,3,2-5"

- **Command List** - The commands in the file may appear in any order, and any command may be divided into any number of lines (that is, all white space, including carriage returns, is ignored).

**4 - 10 HDF Loader**

The Tecplot HDF Loader add-on can load 1D, 2D, and 3D Scientific Data Sets (SDS) from HDF files. When a dataset from an HDF file is imported, the file is scanned and a list of all SDS in the file is displayed in the Scientific Data Sets to load portion of the HDF Loader dialog. Select one or more SDS to import. **Every SDS that you select must have the same dimension.** A rectangular I, II, or IJK-ordered zone (for 1, 2, or 3D data, respectively) is created for each SDS that you select to load.

---

1. The HDF Loader uses the public-domain HDF API code library from the National Center for Supercomputing Applications (NCSA), University of Illinois, Urbana-Champaign.
The HDF Loader dialog has the following options:

- **Scientific Data Sets to load** - Select one or more SDS’s to load. Each SDS that you select must have the same rank (dimension).
- **I-Skip** - Select the I-Skip value. A skip value of one loads every data point, a skip value of two loads every second data point, and so on.
- **J-Skip** - Select the J-Skip value.
- **K-Skip** - Select the K-Skip value.
- **Select File** - Select an HDF file.
- **Attributes** - Displays attributes of each SDS found, such as number type, rank, label, and so on.

### 4 - 10.1 HDF Loader Limitations

The HDF Loader can import only Scientific Data Sets from HDF files, and these are imported in a manner similar to NCSA's own HDF viewer. The way in which the data file is interpreted cannot be altered in this release of the loader. However, it is possible to write a Tecplot 360 add-on (using the NCSA code library) that loads HDF data in a manner more suited to your particular use of the HDF format. See the ADK User's Manual for more information on writing add-ons.

### 4 - 11 HDF5 Loader

The HDF5 loader add-on allows you to import general HDF5 files into Tecplot 360. The loader provides a mechanism for importing generic data from multiple HDF5 datasets or groups. The HDF5 loader will load datasets within user selected groups, load one or more user selected datasets to one zone, load multiple user selected datasets to multiple zones, execute macros after data has been loaded, create implicit X, Y, and Z grid vectors as needed, sub-sample loaded data, and reference user selected vectors for X, Y, and Z grids. Datasets must be ordered data. The HDF5 library used is version 1.8.5.


### 4 - 11.1 Data Selection

HDF5 files may be viewed and selected by pressing the [Select File] button in the HDF5 Loader dialog. One or more files may be selected if all selected files have an identical hierarchy. Hierarchy information for the selected HDF5 files is displayed in the Available Datasets window in the form: /group/[group].../dataset - the dimension of each dataset is displayed immediately following the dataset name. In this window, one or more datasets or groups may be selected for loading.

### 4 - 11.2 Importing/Loading Data

Datasets may be loaded using one of three methods: 1) **Loading Multiple Datasets to One Zone (default)**, 2) **Loading Multiple Datasets to Separate Zones**, or 3) **Loading Datasets by Group**.

#### Loading Multiple Datasets to One Zone (default)

Loading multiple datasets to one zone is the default method of importing HDF5 files. Using this method, the HDF5 loader will create one zone with N variables, where N is the number of HDF5 datasets selected in the Available Datasets window. Selected datasets may have one to three dimensions. The dimension of loaded Tecplot 360 variables will match the I, J, and K values of the selected datasets. Variable names are...
assigned the corresponding names of selected datasets - all selected datasets must have equivalent dimensions.

To import your data, select one or more datasets from the Available Datasets window. All selected datasets must be identical in dimension; dataset dimensions are shown immediately to the right of dataset names in the Available Datasets window.

**Loading Multiple Datasets to Separate Zones**

Using this method, the HDF5 loader will create N zones, where N is the number of datasets selected in the Available Datasets window. Each zone contains one variable per selected dataset where each dataset must have one to three dimensions. The I, J, and K values of each Tecplot 360 zone will match the dimensionality of each selected dataset. Variable and zone names are automatically assigned. Dimensionality may vary between selected datasets.

To import your data using this method, select the “Load to Separate Zones” toggle. Select one or more datasets from the Available Datasets window. One zone will be created for each selected dataset and each zone will contain exactly one variable (unless you selected Create Implicit Grid Values or Reference Data Grids).

**Loading Datasets by Group**

Using this method, the HDF5 loader will create N zones with M variables, where N is the number of groups selected in the Available Datasets window and M is the number of datasets in each group. The I, J, and K indices of the Tecplot 360 variables will be equivalent to the respective dimension of selected datasets. Datasets in any selected group must be equal in dimension; however, datasets may be unequal in dimension between groups. When selecting multiple groups, all groups must contain an equal number of datasets and dataset names must be identical between groups. The HDF5 loader will only load datasets within the root directory or within a subgroup, i.e., the HDF5 loader will not load data within nested groups.

To import your data using this method, select the “Load Datasets by Group” toggle. Press [Select File] to open a HDF5 file. Select one or more groups from the Available Datasets window; all groups must contain an equal number of datasets where all datasets have identical names between groups. The number of selected groups determines the number of zones that load into Tecplot 360. Zone names will match the name of the corresponding group. Variable names will match the respective dataset name. Each zone will include as many variables as datasets per selected groups.

### 4 - 11.3 Additional Options

Additional options may be specified when loading HDF5 data into Tecplot 360. These options include: Using Macros, Sub-Sampling Data, Referencing Data Grids, and Grid Generation.

**Using Macros**

Macros may be defined within a HDF5 vector and placed in any group. Each character string in the selected vector must be a valid one-line Tecplot 360 macro. Macros are executed in the order encountered after all data are loaded.

To run a macro defined as a character vector in your HDF5 file, select the “Run Macros in Selected Group” toggle. Select the macro you want to execute from the Select Macro pull-down menu. Your macro will run after your data has been successfully loaded into Tecplot 360.

**Sub-Sampling Data**

The HDF5 loader will sub-sample the first, second, and third dimensions of loaded datasets respectively as defined by the user. The default skip-value is 1. When specifying non-unitary skip values, the
dimensionality of all selected datasets must be equivalent. Datasets will be sub-sampled using the user defined I-Skip, J-Skip, and/or K-Skip values – skip values must be whole numbers.

To sub-sample data in the first, and/or second, and/or third dimensions of selected datasets, change the respective I-Skip, and/or J-Skip, and/or K-Skip values located in the HDF5 loader dialog. If the skip-values are non-unitary then selected datasets must have equivalent dimensions.

**Referencing Data Grids**

The HDF5 loader allows users to specify X, and/or Y, and/or Z grid vectors. Selected vectors are used for plotting all zones. Vectors are of dimension 1 and length M. The X grid vector length must be equal to the first dimension of selected datasets, the Y grid vector length must be equal to the second dimension of selected datasets, and the Z grid vector length must be equal to the third dimension of selected datasets. The number of selected grid vectors must equal the rank of selected datasets.

To define the grid vectors you may choose them from a drop-down menu. Begin by deselecting the Create Implicit Grid Values option and select the [Reference Data Grids] button. A child dialog will appear (Fig. 2), from the X, Y, and Z menus select the vector you want to use as the corresponding grid. You MUST select the toggle “Use Data Grids”. The number of grid vectors you specify must equal the rank of selected datasets.

**Grid Generation**

The HDF5 loader can automatically create X, Y, and Z grid vectors as necessary for selected datasets. Grid vectors will be of length equal to the corresponding dimension.

To automatically create X, Y, and Z grid vectors, accept the default setting of “Create Implicit Grid Values” in the HDF5 loader dialog – this is selected by default. The grid vectors will be created upon loading your data into Tecplot 360.

4 - 12 Kiva Loader

The Kiva loader imports GMV format files that were exported from Kiva.

- **Select Input Files** – From this button, multiple files can be selected in the Read Kiva/GMV File dialog. Those that are in GMV format will be added to the list of Kiva/GMV files. Once files are added to this list, they will remain in the list throughout the Tecplot 360 session, unless the [Clear List] button is selected.

- **File Selections** – Use the File Selection options for long file lists. Identify the first file to load by entering a number in the Start field, and the last file to load by entering a number in the Stop field.

  Enter a value of 2 in the Skip field to load every other file, or 3 or greater to skip more files. To see the list selections updated according to the values in the Start, Stop, and Skip fields, click the [Apply Skip] button. At any time, you can choose to Select All or Deselect All files.

- **Velocity Vector** – Identify the naming convention for your velocity vectors.

- **Loading Options**:  
  - **IsDouble** - Allows greater precision for your data values.  
  - **LoadParticleData** - Adds a zone for any files containing particle data.

4 - 12.1 Select Variable to Load

After clicking the [OK] button with one or more files selected, the Select Variables dialog appears. Clear All allows only variables X, Y, and Z to be loaded. You can use the [Select All] button to load all variables, or you can highlight variable names in the list.
4 - 13 PLOT3D Loader

The PLOT3D Loader add-on can import data files formatted for the PLOT3D program developed by Pieter Buning at the NASA Ames Research Center. Some extensions such as unstructured data that are now available in FAST, the successor to PLOT3D, are also supported.

4- 13.1 File Combinations

Use the File Selection page of the PLOT3D Loader dialog to specify whether to load just grid files, both the grid and solution files, or just solution files. When loading grid and solution files together, either one grid file must be loaded (in which case it is assumed that all solution files use this grid), or a number of grid files equal to the number of solution files must be loaded (in which case it is assumed that there is a grid file for each solution file). If multiple grid files are loaded, all must use the same organization (binary or ASCII, etc.). Only the first file is scanned for organization.

Choosing both solution and grid files will allow you to optionally specify a name file as well. The name file contains names to replace either the function or solution variable names on a 1-to-1 basis for as many names as are in either file.

If a boundary file exists, it must have a name of the form 'gridfilenamewithextension.fvbnd' and be in FieldView 1.4 format to be automatically loaded.

You may append the files being loaded to the current data set by toggling-on the Append option. The files being appended should have the same number of zones as data that has already been loaded. If some zones are static and some are time-aware, load the static zones and then append the time-aware zones.

If you are loading more than one grid file and they all have the same structure, make sure the Uniform Grid Structure option is toggled-on for best performance. If you are unsure, toggle-off this option to make sure that the data can be loaded without errors.

This page also allows you to automatically assign Strand IDs for transient zones. This option is toggled-on by default. An option to add zones to current strands can be used if you are appending zones to existing transient data. This option is toggled-off by default. Finally, you can have new strand IDs generated for each time step. This option is toggled-on by default.

Transient options do not apply to Plot3D function files since these do not contain time.
To force the loader to use attempt to use numbers in filenames as solution times for transient data, toggle-
on the checkbox “Extract Time from Solution File Names.” Both integers and decimal fractional values are
detected in filenames, and values may be negative. If multiple numeric fields are found in the data set’s
filenames, the one with a unique value in each filename being loaded is taken as the solution time; if
multiple such fields are found, the rightmost one is used.

Some solvers that write data in PLOT3D format use the same solution time for all time
steps. To accomodate such solvers, the PLOT3D loader will attempt to extract solution
times from filenames whenever the solution time information contained in the actual
data set is inconsistent or contradictory, even if the loader has not been explicitly
instructed to do so.

The following table describes what the PLOT3D loader does in all six grid/solution scenarios:

<table>
<thead>
<tr>
<th>Load</th>
<th>Not Appending</th>
<th>Appending</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grid Only</td>
<td>Existing dataset is deleted and zones (one per grid) are loaded.</td>
<td>New zones are added (one per grid). Solution variables in new zones are zeroed out.</td>
</tr>
</tbody>
</table>
| Grid and Solution | Existing dataset is deleted and zones (one for each grid in each solution file) are loaded.
Each set of zones loaded shares spatial variables with the first set of grids loaded. | Same as “Not Appending” except original dataset is preserved. Existing dataset must have at least as many variables as the number needed by the incoming data. |
| Solution Only | A dataset must already be present. The existing dataset is reduced to contain the same number of zones as there are grids in each incoming solution file. Solution variables in the first solution file replace the solution variables in the original zones. Subsequent solution files create new sets of zones with spatial variables shared with the first set of zones. | Same as “Not Appending” except original dataset is preserved. Existing dataset must have at least as many variables as the number contained in incoming solution file. Spatial variables are shared with last \( n \) original zones where \( n \) is the number of grids in each incoming solution file. |

You may also load function files with or without grid or solution files. If you load function files at the same
time as solution files, there must be an equal number of solution files and function files. The variables in
each function file will be added to the variables in the corresponding solution file. If you load only
function files, you must append the files, and the function files must contain the same number of zones as
have already been loaded. In this case, the variables in the specified function files will be added to the
zones defined in the previously-loaded solution file(s).

**4- 13.2 PLOT3D Loader Limitations**

The `-i<`, `-j<`, `-k<` options in older PLOT3D Loaders are not supported in this release. Tecplot 360 handles I,
J, and K-planes well, so loading 3D planar files as a single zone is typically sufficient. Refer to Section 7.2.
1.2 “Surfaces,” for additional information.
4- 13.3 PLOT3D File Structure

The File Structure page of the PLOT3D Loader dialog allows you to choose to have the PLOT3D Loader auto detect the file structure, or override and manually describe the structure.

The PLOT3D Loader can automatically detect most PLOT3D file variants. ASCII files are the most difficult to auto-detect as there are a few combinations that have the exact same signature. Pure binary files also have some combinations that have the same signature. You may also specify the file format manually.

To enhance performance when loading multiple solution/function files, the primary solution/function file can be chosen to represent the structure of all subsequent files. To activate this option, toggle-on "Assume all Solution/Function Files have the same structure". You must determine if this is appropriate.

Special File Conditions

Unstructured Data Files

The following ASCII file conditions require special attention:

<table>
<thead>
<tr>
<th>Condition</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Double Precision</td>
<td>You must tell the loader if the incoming file is single or double precision.</td>
</tr>
<tr>
<td>I-Blanking</td>
<td>You must tell the loader if the incoming file contains I-blanking.</td>
</tr>
<tr>
<td>3D Planar</td>
<td>There are some cases where these files can appear exactly the same if they are 3D Whole. If you need to load 3D Planar in 3D Planar ASCII files you must specify the data structure manually.</td>
</tr>
</tbody>
</table>

Pure Binary Files

The following pure binary files (binary files without record markers) require special attention:

<table>
<thead>
<tr>
<th>Condition</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Planar</td>
<td>There are some cases where these files can appear exactly the same if they are 3D Whole. If you need to load in 3D Planar pure binary files you must specify the data structure manually.</td>
</tr>
</tbody>
</table>
4- 13.4 PLOT3D Data Subsets

The Data Subset page of the PLOT3D Loader allows you to: read subsets of ordered zones within the files, specify the desired beginning and ending index values to read, and enter a skip value for each index direction. A skip value of one results in every value in the specified index range being read. A skip of 2 reads every second value, and so on.

4- 13.5 Macro Language Commands for the Plot3D Loader

The syntax for loading PLOT3D data files with the Tecplot macro language is as follows:

```plaintext
$!READDATASET
"STANDARDSYNTAX" "1.0"
"any of the name value pairs in the following table...
DATASETREADER = "PLOT3D Loader"
```

Each name/value pair should be in double quotes:

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Value(s)</th>
<th>Default</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>STANDARDSYNTAX</td>
<td>1.0</td>
<td>n/a</td>
<td>Must be the first instruction.</td>
</tr>
<tr>
<td>FILELIST_SOLUTIONFILES</td>
<td>&quot;n&quot; &quot;file-1&quot;</td>
<td>n/a</td>
<td>Specify the number of solution files, followed by each file name.</td>
</tr>
<tr>
<td></td>
<td>&quot;file-2&quot;...</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;file-n&quot;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FILELIST_GRIDFILES</td>
<td>&quot;n&quot; &quot;file-1&quot;</td>
<td>n/a</td>
<td>Specify the number of grid files, followed by each file name.</td>
</tr>
<tr>
<td></td>
<td>&quot;file-2&quot;...</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;file-n&quot;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FILENAME_NAMEFILE</td>
<td>&quot;filename&quot;</td>
<td>n/a</td>
<td>The associated name file.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Value(s)</td>
<td>Default</td>
<td>Notes</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------</td>
<td>---------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>INDEXRANGE</td>
<td>“Min, Max,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Skip”</td>
<td>all</td>
<td>The index ranges for the data to be loaded, minimum, maximum, and skip value.</td>
</tr>
<tr>
<td>INDEXRANGE</td>
<td>“Min, Max,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Skip”</td>
<td>all</td>
<td></td>
</tr>
<tr>
<td>KINDEXRANGE</td>
<td>“Min, Max,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Skip”</td>
<td>all</td>
<td></td>
</tr>
<tr>
<td>APPEND</td>
<td>“Yes” or “No”</td>
<td>“No”</td>
<td>Whether to append the read data from to the existing dataset.</td>
</tr>
<tr>
<td>ASCIIISDOUBLE</td>
<td>“Yes” or “No”</td>
<td>“No”</td>
<td>Whether the ASCII data format is double.</td>
</tr>
<tr>
<td>ASCIIHASBLANK</td>
<td>“Yes” or “No”</td>
<td>“No”</td>
<td>Whether the ASCII file contains blanks.</td>
</tr>
<tr>
<td>AUTODETECT</td>
<td>“Yes” or “No”</td>
<td></td>
<td>Whether to autodetect the PLOT3D file format variant. If set to “No,” the DATASTRUCTURE, ISMULTIGRID, and STYLE keywords are used to specify the file format.</td>
</tr>
<tr>
<td>DATASTRUCTURE</td>
<td>“1D”, “2D”,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>“3DP”, “3DW”,</td>
<td>none</td>
<td>Required if AUTODETECT is “No,” otherwise ignored.</td>
</tr>
<tr>
<td></td>
<td>“UNSTRUCTURED”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ISMULTIGRID</td>
<td>“Yes” or “No”</td>
<td>none</td>
<td>Required if AUTODETECT is “No,” otherwise ignored.</td>
</tr>
<tr>
<td>STYLE</td>
<td>“PLOT3DCLAS</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>SIC”</td>
<td>none</td>
<td>Required if AUTODETECT is “No,” otherwise ignored.</td>
</tr>
<tr>
<td></td>
<td>“PLOT3DFUN</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>CTION”</td>
<td>none</td>
<td></td>
</tr>
<tr>
<td></td>
<td>“OVERFLOW”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AUTOASSIGNSTRANDS</td>
<td>“Yes” or</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>“No”</td>
<td>“No”</td>
<td>Whether to automatically assign strand IDs.</td>
</tr>
<tr>
<td>ADDTOEXISTINGSTRANDS</td>
<td>“Yes” or</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>“No”</td>
<td>“No”</td>
<td>Whether to add data to existing strands.</td>
</tr>
<tr>
<td>UNIFORMGRIDSTRUCTURE</td>
<td>“Yes” or</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>“No”</td>
<td>“Yes”</td>
<td>Whether the grid structure is the same for all time steps.</td>
</tr>
<tr>
<td>APPENDFUNCTIONVARIABLES</td>
<td>“Yes” or</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>“No”</td>
<td>“No”</td>
<td>Whether to append variables in function files to those found in solution files.</td>
</tr>
<tr>
<td>EXTRACTTIMEFROMSOLFILENAMES</td>
<td>“Yes” or</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>“No”</td>
<td>“No”</td>
<td>Deprecated. If set to Yes, solution times will always be extracted from filenames, overriding solution times in the data set. If set to No or not given, solution times will still be extracted from filenames if the data set contains does not contain solution times or if the data set contains more than one time step specifying the same solution time.</td>
</tr>
</tbody>
</table>
### 4- 13.6 PLOT3D Auxiliary Data

The following auxiliary data is created by the PLOT3D Loader:

<table>
<thead>
<tr>
<th>Auxiliary Name</th>
<th>Assigned To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common.ReferenceMachNumber</td>
<td>Dataset and Individual Zones *</td>
</tr>
<tr>
<td>Common.AngleOfAttack</td>
<td>Dataset and Individual Zones *</td>
</tr>
<tr>
<td>Common.ReynoldsNumber</td>
<td>Dataset and Individual Zones *</td>
</tr>
<tr>
<td>Common.IsBoundaryZone</td>
<td>Individual Zones</td>
</tr>
<tr>
<td>Common.BoundaryCondition</td>
<td>Individual Zones</td>
</tr>
<tr>
<td>Common.DensityVar</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.UVar</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.VVar</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.WVar</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.StagnationEnergyVar</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.GammaVar</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.TurbulentKineticEnergyVar</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.TurbulentDissipationRateVar</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.VectorVarsAreVelocity</td>
<td>Dataset</td>
</tr>
<tr>
<td>Common.SpeedOfSound</td>
<td>Dataset</td>
</tr>
<tr>
<td>G0</td>
<td>Individual Zones</td>
</tr>
<tr>
<td>B0</td>
<td>Individual Zones</td>
</tr>
<tr>
<td>T0</td>
<td>Individual Zones</td>
</tr>
<tr>
<td>P0</td>
<td>Individual Zones</td>
</tr>
<tr>
<td>H10</td>
<td>Individual Zones</td>
</tr>
<tr>
<td>H1p</td>
<td>Individual Zones</td>
</tr>
<tr>
<td>H20</td>
<td>Individual Zones</td>
</tr>
</tbody>
</table>

---

**Auxiliary data assigned to both zones and the dataset assign the value from the last zone processed to the dataset.**

**b. Overflow specific constants.**

### 4 - 14 PLY Loader

Use this loader\(^1\) to load 3D triangular surface files with the .ply extension. This format is often used to store surfaces generated from tessellation of 3D range measurement data. Files may be either ASCII or binary, but must contain both vertex and face elements (sections). This loader is included in your Tecplot 360 installation.
4 - 15  Tecplot-Format Loader

This section describes the process for loading Tecplot-format data files. Tecplot 360 uses the standard extensions .dat for ASCII files and .plt for binary files. Refer to the Data Format Guide for information on outputting your data into Tecplot 360 file format.

There are four ways to work with Tecplot-format data files:

- Generate a Tecplot-format ASCII data file - Read the file into Tecplot 360 and work without conversion. If the dataset is altered, save it as an ASCII data file. This method works for smaller datasets where the convenience of an ASCII file outweighs any inefficiencies.
- Generate a Tecplot-format ASCII data file, then convert it to a binary file with Preplot - Preplot, a utility program included with Tecplot 360, converts ASCII and PLOT3D to binary Tecplot-format data files. Once the binary file is created, delete the ASCII version to save space. This works well for identifying problems with data files, since Preplot's error messages include precise details. This method also works well in batch processing, or if the ASCII data files are generated on another machine. (See Section “Polyhedral - complex example” in the Data Format Guide for a description of Preplot.)
- Generate a Tecplot-format binary data file - Read the binary data file into Tecplot 360 and work without conversion. You must use routines provided by Tecplot 360 to write Tecplot-format binary files from C or FORTRAN programs. See “Binary Data” in the Data Format Guide for complete details.

1. Copyright for Third Party Library. This loader utilizes a modified version of a library written by Greg Turk while at Stanford University. The copyright for this library is: Copyright © 1994 The Board of Trustees of The Leland Stanford Junior University. All rights reserved. Permission to use, copy, modify and distribute this software and its documentation for any purpose is hereby granted without fee, provided that the above copyright notice and this permission notice appear in all copies of this software and that you do not sell the software. The software is provided “as is” and without warranty of any kind, express, implied or otherwise, including without limitation, any warranty of merchantability or fitness for a particular purpose.
4 - 15.1 Tecplot Data File Loading

The Tecplot Data Loader (accessed via File>Load Data File(s)) allows you to load ASCII (.dat) and Tecplot-format (.plt) files.

For both ASCII and binary data files, Tecplot 360 supports full data files, grid files, and solution files, where the file types are defined as follows:

- **Full** - Full files contain both grid and solution data. Data files produced for Tecplot 360 Version 2006 and earlier are treated as full data files. Full files can be loaded in any order.
- **Grid** - Grid files contain static data for all zones. They have at least one variable or FE connectivity; they may contain both variables and connectivity simultaneously.
- **Solution** - Solution files contain time-varying data for all zones in the file.

Use the [Multiple Files] button to load more than one Tecplot 360 file simultaneously. This is required when loading solution data because the grid file must be loaded first.

Tecplot 360 allows you to specifically control what is loaded from your data files by toggling-on “Specify Options”. After you select the file(s) to load and select the [Open Files] button, use the Load Data File Options dialog to specify the information to load from your data file.

**Loading Grid and Solution Data Files**

When you are loading grid and/or solution files, please keep the following in mind:

- Solution files must be read in after the grid file it is associated with is loaded.
- If you load multiple grid and solution files into Tecplot 360, the order the files are listed will be used to determine which grid is used for which solution file(s). For example, if you load a set of grid and solution files in the following order:
  - Grid A
  - Solution A
  - Solution B
  - Solution C
  - Grid B
  - Solution D
Grid A will be shared for Solution Files A, B, and C. Grid B will be used for Solution File D.

On Windows operating systems, you may select multiple files to load by using the SHIFT key. However, the order is not always preserved with this method. We strongly recommend that you use the [Multiple Files] button when loading grid and solution data.

- You may load a grid file with variables or variables and connectivity without loading a solution file. However, you may not load a grid file that contains only FE connectivity data.

**Appending Data Files**

You may append your dataset at any time by going to File.Load Data File(s). After you select the data file(s), the **Load Data File: Simple Warning** will be launched. Select the “Add to current dataset” option to append your data.

You cannot append a grid file that contains only FE connectivity data without appending a solution file along with it. In addition, to append a solution file you must also append a grid file at the same time. In this case, the grid file must come before the solution file in the file loading list.

You may also load Tecplot 360 data files via the macro language. Refer to Section “$!READDATASET” in the [Scripting Guide](#) for details.

### 4 - 15.2 Load Data File Options

The **Load Data File Options** dialog has three pages—General, Zones, and Vars (Variables).

**Data File Loading General Options**

On the General page, you have the option to load a subset of record types or load only portions of the data.

![Tecplot Data Loader Options](image)

To load specific record types from the data file, select the desired record types by choosing the appropriate check boxes:

<table>
<thead>
<tr>
<th>Field Data</th>
<th>Load zone records (the actual data). If not selected, the Zones and Vars pages of the dialog are inactive.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Load text records.</td>
</tr>
</tbody>
</table>
The toggles are available only if those records exist in the data files. By default, all of the records in the data files are selected.

If you want to load a portion of the data points, specify skip factors for the I, J, and K-dimensions in the corresponding text fields. Each skip factor \( n \) tells Tecplot 360 to read in every \( n^{th} \) point in the specified direction. By default, all the skip factors are set to one, so every data point is loaded.

If data being loaded into Tecplot 360 has time associated with one or more of the zones but is missing explicit strand ID assignments, you can direct Tecplot 360 to assign strand ID’s by toggling-on “Assign Strand IDs for Zones”. This calls a simple algorithm that groups together solutions.

Additionally, if you are appending data, you can direct Tecplot 360 to either add the zones from the new data to matching strands in the dataset or simply append the new strands.

**Data File Loading Zone Options**

The Zones page allows you to select specific zones to load from data files and, if appropriate, whether to collapse the zone list. To specify which zones to load, select them in the “Select Zones to Load” box. By default, all zones are selected to be loaded.

If you have selected to only load specific zones and want them renumbered upon loading, select “Collapse Zone List”. (If you are loading variables by position, the check box reads Collapse Zone and Variable Lists.) See Section “Zone and Variable List Collapsing” on page 121 for more information.

**Data File Loading Variable Options**

Use the Variables page to load variables by name (default) or position. When loading variables by name, Tecplot 360 creates variables based on the variable names in the data files. When loading variables by position, Tecplot 360 creates variables based on their order in the data files. If you are loading multiple data files, the order of variables will be based on their order in the first data file.
Variable Loading by Name

Using the “Load Variables By Name” area of the Load Data File Options dialog’s Vars page, you may select specific variable names to load from the data files.

When loading variables by name, variables are associated by name then loaded into Tecplot 360. Variable names can be combined; two variables with different names in different files can be loaded into a single Tecplot 360 variable. When a variable name is missing, the variable is set to zero for all zones loaded from that file.

The Show Variables From box displays variable names from the data files. Filter the list with the drop-down menu above the list. Choosing All Data Files shows variable names from all data files in order by data file and then in order by name. Identical variable names from more than one file appears only once in the list. An asterisk (*) next to a variable name indicates the variable name does not exist in all the files. A number next to a variable name indicates the Tecplot 360 variable number to be assigned to the variable.

The Variables to Load box displays variables to be loaded into Tecplot 360. By default, it shows only variable names existing in all of the data files selected. If no matching variable names exist, the list is empty. An asterisk (*) next to a variable name indicates the name does not exist for all files. If you load a file with an asterisk, the file’s zones are set to zero for that variable. Duplicate variable names are not allowed. Use the [Move], [Move All], [Remove], or [Remove All] buttons to edit the “Variables to Load” list.

You have limited options in changing “Variables to Load” when appending data files to the current dataset or replacing the current dataset while retaining the plot style. The list is partially determined by the current dataset. You can add names or combine new names, but you cannot remove any variable names.

When appending data files to the current dataset by adding names to “Variables to Load”, adding a new name which exists in the current dataset, but which was not loaded initially, forces Tecplot 360 to reload the original data files to include the variable name.
Variable Loading by Position

The Load “Variables By Position” option of the Load Data File Options dialog’s Vars page allows you to select specific variables to load from data files, and to collapse the zone and variable lists when possible.

To specify variables to load from data files, select them in the “Select Variables to Load” box. This multiple selection box allows you to click-and-drag, CTRL-click, or SHIFT-click to choose variables. The variable names listed come from the first data file. If variable names in the other files do not match those in the first, an asterisk (*) appears next to the name. The number of variables listed is limited to the minimum number in all of the files. By default, all of the variables are selected to be loaded.

If you have chosen to load specific variables and want them renumbered, select the “Collapse Zone and Variable Lists” check box. See Section “Zone and Variable List Collapsing” on page 121 for more information.

When appending files to the current dataset or replacing the current dataset while retaining the plot style, you cannot select the variables to load. These are determined by the variables currently loaded in Tecplot 360. When appending files to the current dataset, the new files must have at least as many variables as are currently loaded in Tecplot 360.

Zone and Variable List Collapsing

When loading files, you have the option of reading only selected zones (and variables when loading by position). You may either preserve existing zone and variable numbering, or “collapse” the data read so zones and variables are renumbered according to their positions in Tecplot 360.

For example, zones 2 and 5 of a five zone data file are loaded. If the zones and variables are not collapsed (the default), Tecplot 360 reads them in as zones 2 and 5. Writing this dataset to an ASCII file, it has five zones; zones 1, 3, and 4 have no data (“Zombie” zones). Selecting the collapse option, Tecplot 360 reads them in as zones 1 and 2. Writing this dataset to a file yields only two zones.

In most cases collapsing zones and variables is unnecessary. All dialogs showing zones or variables list the zones read in, though they may not be numbered sequentially. Do not collapse zones and variables when:

- You have a large dataset and read a portion of the data to reduce the amount of memory used in processing. You then create a stylesheet to use at a later time with a different sub-set of the data.
- You have many zones and variables and you are familiar with certain ranges of them. (For example, you may know that zones 150-200 represent a known portion of the data.) If you
partially read the data and do not collapse it, these zones continue to be designated with their familiar numbers.

**Load Multiple Data Files**

Select the [Multiple File] button in [Load Data File(s)] dialog to load more than one .plt or .dat file into Tecplot 360.

**Load Data File: Simple Warning**

A warning dialog opens when you try to load a new Tecplot 360 file and the active frame has a dataset attached.

If only the active frame uses the current dataset, you have three options:

- **Replace dataset and reset plot style** - Select this to read in the new dataset in a frame with style sheet attributes redefined to the new frame defaults.
- **Replace dataset and retain plot style** - Select this to read in the new dataset, but keep the style sheet attributes in the current dataset.
- **Add to current dataset** - Select this to keep the current dataset and add to add the new specified data file into the current data, in the active frame.

**Load Data File: Complex Warning**

A warning dialog opens when you try to load a new Tecplot 360 file and the active frame has a dataset attached to it that is also attached to other frames.

The **Load Data File Warning** dialog has the following options:

- **Create a new dataset and reset the current plot style** - Select this to create a new dataset in the active frame with new frame default style sheet attributes. The other frames will retain the original dataset and style.
Text Spreadsheet Loader

• **Create a new dataset and retain the current plot style** - Select this to create a new dataset in the active frame with the style sheet attributes of the current dataset. The other frames will retain the original dataset and style sheet attributes.

• **Add to the current dataset** - Select this to attach the new specified data file into the current data, in the active frame. The other frames will retain the original dataset and style.

• **Completely replace the current dataset with the new dataset** - Select this to substitute the new dataset everywhere the current dataset is used while retaining the current dataset's style sheet attributes.

**Select Initial Plot Type**

Once you have loaded your file(s), the **Select Initial Plot** dialog will appear with the following options:

• **Initial Plot Type** - Set the plot type (2D or 3D, XY, Polar, Sketch, or Automatic). When Automatic is chosen, Tecplot 360 attempts to match the data to the best plot type using the following parameters:
  - **3D Cartesian** - If any finite element volumes or IJK-zones are present.
  - **2D Cartesian** - If finite element surfaces or IJ-zones are present.
  - **XY Line** - All other data structures.

• **Show First Zone Only** - Loads all zones, but displays only the first zone of a plot.

• **Use These Settings for All Datasets** - Applies your selections to any additional plots loaded.

**4 - 16 Text Spreadsheet Loader**

The Text Spreadsheet Loader add-on is both an example of how to write a loader add-on and a utility that allows you import simple data from ASCII files. The complete source code for the Text Spreadsheet Loader is included in the ADK Samples directory (located in your Tecplot 360 installation directory). Select the delimiter and I-skip (if necessary) from the **Simple Spreadsheet File Loader** dialog.

the **Text Spreadsheet Loader** dialog has the following options:

• **Filename** - Enter the path to the file you would like to load.

• **Delimiter** - Choose whether your data is separated by a comma, space, or tab.
• **I-Skip** - Select an I-skip value. A value of 1 loads all values, a value of 2 loads every other value, and so on.

The Text Spreadsheet Loader can read ASCII files of the following format (blank lines are ignored):

```
Variable 1, Variable 2, ..., Variable N
datapoint1,datapoint2, ..., datapoint N
-

datapoint1,datapoint2, ..., datapoint N
```

Here is an example of a valid ASCII spreadsheet file:

```
Month, Rainfall
1, 15.0
2, 21.0
3, 21.0
4, 32.0
5, 10.3
6, 5.1
7, 2.3
8, 0.2
9, 1.4
10, 8.3
11, 12.2
12, 15.4
```

**Text Spreadsheet Loader Limitation**
The first line must contain all of the variable names.

### 4 - 17 Overwriting Data Files

Tecplot 360 creates a tight bond between itself and a loaded datafile, by using a concept called load-on-demand. With load-on-demand, after you load a data file, the actual loading of individual variables may be delayed until the variables are needed. Some variables may experience repeated cycles of being loaded, then unloaded, and then loaded again.

If you are supplying data to Tecplot 360 via your own specialized add-on that can access and update Tecplot 360 field data directly, then this is not an issue for you. In this case, Tecplot 360 will take care of the read/write and load-on-demand issues for you (assuming your add-on has solved its own data overwrite issues).

If you have a workflow that requires a Tecplot 360 datafile be overwritten while it is in use (most likely to simulate real-time data acquisition or a similar process) and you do not have the luxury of doing so via an add-on, the following is suggested as a possible solution.
Overwriting Data Files

In this example, the cycle on the top illustrates the method used for Tecplot 360 to update flow.plt and the cycle on the bottom illustrates the method used by the application that generates the data to update flow.plt. Both systems are checking for the existence of read.lock. If you are using a macro in Tecplot 360 to do this, then you can use the extended macro command, query.fileexists, to determine if the file exists. If the file exists, Tecplot 360 will disconnect from flow.plt, copy flownew.plt to flow.plt, and delete read.lock. If read.lock exists and the application that generates the data has an update for flow.plt, the application should either wait a few seconds and try-again or skip the data set (this is determined by the application, not Tecplot 360). If the file does not exist, the application that generated the data is free to copy new data to flownew.plt.

Note that if you use a macro in Tecplot 360, you can use the capabilities of extendmcr to query for file existence (refer to the readme.txt file in $TEC_360_2013R1/adk/samples/extendmcr for additional information). Disconnecting from flow.plt can be done in a number of ways, one of which is to issue a $NEWLAYOUT command. This will completely disconnect Tecplot 360 from the dataset and thus from the associated datafile.

The file read.lock is like a baton. If it exists, then flownew.plt is said to be "owned" by Tecplot 360. If it does not exist, then flownew.plt is said to be "owned" by the data producing application, flow.plt is always owned by Tecplot 360.

One minor issue not addressed in the above example is what the data producing application should do if the data is being read by Tecplot 360. It can either block (wait) until Tecplot 360 is finished or discard the current solution and go back to generating another one.
Part 3 Creating Plots
Creating Plots

5 - 1 Creating Plots
The basic steps for creating a plot in Tecplot 360 are:

1. Define your dataset using one of the following methods:
   a. This is typically accomplished by using the “Load Data File(s)” command from the File menu. Please refer to Chapter 4: “Data Loaders” for information on working with a specific data loader.
   b. Use the “Open Layout” command from the File menu to load linked layout or layout package files. (See Section 24 - 1 “Layout Files, Layout Package Files, Stylesheets” for more information on layout files.)
   c. Use any combination of the options in the Create Zone submenu of the Data menu or the Insert menu to create your datasets directly within Tecplot 360. Section 21 - 7 “Zone Creation” and Chapter 18: “Text, Geometries, and Images” for more information.

2. Select the Plot Type (3D, 2D, XY Line, Polar Line, or Sketch) from the Sidebar. Refer to Chapter 7: “Field Plots” for information regarding 3D and 2D plots, Chapter 6: “XY and Polar Line Plots” for information on XY Line and Polar Line plots, and Chapter 18: “Text, Geometries, and Images” for information on sketch plots.

3. Toggle-on any mapping or zone layers from the Sidebar. The following mapping and zone layers are available:
   - Mesh Layer
   - Contour Layer
   - Vector Layer
   - Scatter Layer
   - Edge Layer
   - Line Map Layer
   - Symbols Map Layer
   - XY Line Error Bars
• XY Line Bar Charts

The layers available in the Sidebar are dependent upon the active plot type. Use the Details buttons [...] where available to customize zone layers.

In order to view surfaces on your plot, open the Zone Style dialog, select the Surfaces tab, and use the [Surfaces to Plot] drop-down menu to choose an available surface plotting option.

The Zone Style dialog is available by either double-clicking on your plot, selecting the [Zone Style] button from the Sidebar, or selecting Plot>Zone Style from the Menubar.

4. Use the options in the Plot menu (such as Blanking or Axis Details) to customize how your data is displayed. Refer to Section 7 - 4 “Three-dimensional Plot Control” or Chapter 17: “Axes” for additional information.

5. Use the options in the Data menu (such as Equations or Interpolation) to alter the dataset. Refer to Chapter 21: “Data Operations” and Chapter 22: “CFD Data Analysis” for additional information.

6. [3D only] toggle-on zone effects (translucency and lighting). Refer to Chapter 13: “Translucency and Lighting” for details.

7. Use the Zone Style or Mapping Style dialogs to opt zones in and out of plot layers or the entire plot. Refer to Section 7 - 1 “Field Plot Modification - Zone Style Dialog” and Section 6 - 1 “Mapping Style and Creation”, respectively, for details.

8. [2D or 3D only] add derived objects (Slices, Streamtraces or iso-surfaces). Use their respective Details buttons [...] to customize any derived objects.

You are not limited to working with only one plot at a time. You can create multiple files at one time using frames and frame linking. See Section 2 - 3 “Frames” for more information.

5 - 2 Data Journaling

On occasion you may modify data prior to making a final plot. Some (but not all) of the data operations mentioned in this chapter modify data. Tecplot 360 simultaneously “journals” the corresponding instructions. If you then save a layout file, the layout file can reference the original data and include the instructions necessary to reconstruct the final data.

If you perform an operation that Tecplot 360 is unable to journal, then you are prompted to save the dataset to a new file when you save a layout file. This is necessary for the layout to reproduce exactly what you have in your plot.

The following operations are included in the data journal:

• Data alteration (except for derivatives).
• Creation of rectangular zones, circular zones, and 1D zones.
• Zone duplication.
• Zone deletion.

The Data Journal is displayed on the Journal page of the Dataset Information dialog (accessed via the Data menu). See Section 5 - 4.4 “Journal Page” for more information.

5 - 3 Data Sharing

In order to conserve computer memory and disk space, Tecplot 360 shares variables between zones whenever possible. Variable sharing typically occurs with any of the following scenarios:
When a variable is calculated for two or more zones, Tecplot 360 determines if the results will be the same in the different zones, and shares the variable where appropriate. See Section 21 - 1.1 “Equation Syntax” and Section 21 - 1.7 “Variable Sharing Between Zones”.

- When zones are duplicated, all variables are shared between the source zones and their duplicates. See Section 21 - 7.4 “Zone Duplication”.
- When mirrored zones are created. See Section 21 - 7.5 “Mirror Zone Creation”.
- When a data loader supporting data sharing (Tecplot, Plot3D, FLUENT, CGNS, etc.) loads a variable that is identified for two or more zones. This often occurs with time dependent data, where the physical coordinates are typically the same for all time steps.

If a zone is altered (independently of zones it is sharing data with), any variable that is changed will no longer be shared.

Variable sharing and connectivity sharing (for finite element zones) can also be established in a Tecplot 360 data file using the TECZNE parameter. See Section “TECZNE112” on page 48 of the Data Format Guide. In addition, multiple Tecplot 360 solution files can share the same grid file.

The Sharing page of the Dataset Information dialog allows you to determine which variables are currently shared in your dataset. See Section 5 - 4.3 “Data Sharing Page”.

Refer to the Data Format Guide for more information on data sharing.

5 - 4 Dataset Information

The Dataset Information dialog, accessed from the “Data Set Info” option on the Data menu, gives summary information about the current dataset, including the dataset title, zone and variable names, and the minimum and maximum values of a selected variable. You can modify the dataset title, zone and variable names of any dataset.
5 - 4.1 Zone/Variable Info Page

The following information is provided on the Zone/Variable Info page:

- **Zone(s)**: Lists all zones by number, with their titles. Select one zone to display its name in the Zone Name field, where the zone name can be modified.

- **Zone Name**: Enter a new name for a selected zone.

- **Zone Type (Ordered or FE data)**: Displays the type of zone selected in the Zone(s) listing. For ordered data, it is followed by the index values for IMax, JMax, and KMax (shown below). For finite element data, it is followed by the element type, number of points, and number of elements:
  - **IMax (ordered data)**: Displays the IMax value of the zone selected in the Zone(s) listing.
  - **JMax (ordered data)**: Displays the JMax value of the zone selected in the Zone(s) listing.
  - **KMax (ordered data)**: Displays the KMax value of the zone selected in the Zone(s) listing.
  - **Pts (finite element data)**: Displays the number of data points in the zone selected in the Zone(s) listing.
  - **Elem (finite element data)**: Displays the number of elements in the zone selected in the Zone(s) listing.

- **Solution Time (Read-only)**: Displays the solution time for the selected zone (see also Section 7 - 2 "Time Aware").

- **Strand-ID (Read-only)**: Displays the Strand-ID for the selected zone (see also Section 7 - 2 "Time Aware").
Dataset Information

- **Variable(s)** - Lists all variables by number, with their names. Select one variable to display its name in the Variable Name field, where the name can then be modified.
- **Variable Name** - Enter a new name for a selected variable.
- **Var Type** - Displays the type of data of the selected variable in the Variable(s) field.
- **Var Location** - Indicates if variables are located at nodes or cell-centers.
- **Var Status** - Use the Var Status field in the dialog to determine the status of the current variable. The variable status can indicate the variable passivity, lock state, and additional system state information.
- **Var Range-Selected Zone** - Displays the Min and Max values for the selected variable in the selected zone.
- **Var Range - Active Zone** - Displays the Min and Max values for the selected variable for all active zones.
- **Load Variables** - If a variable was not initially loaded, “Not Loaded” will be displayed in Var Range portions of the dialog. Use the [Load Variables] button to load any variables from your dataset that were not initially loaded. See Section “Load On Demand” on page 489 for more information.

5 - 4.2 Data Set Page

The Data Set page provides information about your data set, including: title, filenames, number of zones, variables, elements, and lock status.

- **Data Set Title** - Enter a title for the current dataset, or edit an existing title. The default is the result of concatenating the titles specified in each Title record encountered in the data files making up the dataset.

The following information can be found on the Data Set page:

- **Data Set Title** - Enter a title for the current dataset, or edit an existing title. The default is the result of concatenating the titles specified in each Title record encountered in the data files making up the dataset.
• **Data File(s)** - Lists the names and paths of all external data files making up the current dataset.
• **Num Zones** - Number of zones in the dataset.
• **Num Vars** - Number of variables in the dataset.
• **Total Elements** - Total number of elements in the dataset.
• **Total Points** - Total number of points in the dataset.
• **Locked By** - This field will inform you if the current dataset has been locked by an add-on. Add-ons can lock a dataset which in turn prevents you from deleting zones or deleting the last frame associated with the dataset.

5 - 4.3 **Data Sharing Page**

The Data Sharing page of the [Data Set Information](#) dialog provides options for shared zone variables and connectivity lists:

The following options are provided on the Data Sharing page:

• **Zone** - Use the drop-down to select which zone to display its shared variables.
• **Variable** - Use the drop-down to select the appropriate variable.
• **Variable is Shared in Zone(s)** - This box displays and allows you to select individual shared variables.
• **Connectivity Shared with Zone(s)** - This box displays and allows you to select specific connectivity lists.
5 - 4.4 **Journal Page**

The Journal page of the dialog displays the macro commands required to recreate your current plot. You may save these command to a file by selecting “Save Layout” from the `File` menu.

The Journal page has the following options:

- **Journaled Data box** - Lists currently journaled data.
- **List Commands** - Briefly summarizes actions in Tecplot 360 as they apply to the dataset.
- **Expand Commands** - Displays the commands above in detail, including such things as the zone number, variable, and value.

Refer to Chapter 24: “Layout Files, Layout Package Files, Stylesheets” for additional information.
5 - 4.5 Auxiliary Data Page

Auxiliary data is metadata attached to zones, datasets, or frames. Auxiliary data is added to the plot via the data file.

The Auxiliary Data page has the following information:

- **Show Auxiliary Data** - Use the drop-down to display auxiliary data for zones, datasets, frames, or names.
- **Data Name/Value** - Displays the names and values of any auxiliary data.

Refer to the Data Format Guide for information on creating Tecplot 360 data files that include auxiliary data.
Select Color

5 - 5 Select Color

Each attribute of your plot can be set to a different color or color type using the Select Color dialog. Use the Select Color dialog to apply contour groups, a basic color palette, or RGB coloring to the selected plot attribute.

There are three types of color assignments:

- **Contour Groups** - The Contour Variables (Multi 1, 2, 3, 4, 5, 6, 7, and 8) are defined in the Contour Details Dialog, and the coloring is defined by the Global Color Map. The Contour Variables are typically used for coloring mesh, contour, vector, and scatter layers.
- **Global Color Map** - Select RGB to use RGB coloring established in Plot>RGB Coloring>Variables/Range. RGB coloring is used to illustrate the relationship between two or three variables in your dataset, by setting R, G, and B to each of the variables.
- **Basic Color Palette** - Use the basic color palette to apply a single, constant color to a plot attribute.

For example, you can create a 3D field plot with a contour layer (with colors defined by a contour variable), an edge layer (with colors from the basic color palette), and a vector layer (with colors defined by RGB vectors).

5 - 5.1 Global Color Map

The colors used to display contour variables are determined by the global color map, controlled in the Options menu. By default, Tecplot 360 uses the color map “Small Rainbow”, which is a rainbow of colors from blue to cyan to green to yellow to red. You can use the Select Color dialog to assign specific colormaps to your different contour groups. Refer to Section 9 - 2.3 “Contour Coloring” for details.

The color map is used by all frames; if you change the color map to modify the look of one frame, all frames with contour flooding or any form of multi-coloring are modified as well.

To select or modify a color map, select “Color Map” from the Options menu.
You can modify any color map, except the Raw User-Defined color map, using the controls in the Color Map dialog.

The Color Map dialog has the following options:

- **Link All Color Maps Together** - When on, each color map group (1-8) uses the same settings. When off, each color map group can have different attributes. If “Link All Color Maps Together” is toggled-on when different color map groups are set, all color maps inherit the settings of the current color map displayed in the dialog.

- **Color Map Number** - Color maps can be set for up to eight groups. The attributes for each group are established by selecting a color map number and making changes in the Color Map dialog. The Color Map Number buttons ([1], [2], [3], [4], [5], [6], [7], and [8]) are available when “Link All Color Maps Together” is toggled-off.

- **Base Color Map** - Select one of the following color maps:
  - **Small Rainbow** - Five point color spectrum from blue to cyan to green to yellow to red.
  - **Large Rainbow** - Seven point color spectrum from blue to cyan to green to yellow to red to purple to white.
  - **Modern** - Seven point color spectrum; within each color band, colors change in intensity from dark to light.
  - **Gray Scale** - Color spectrum from black to white.
  - **Wild** - Random Color spectrum. Wild is different each time you select it.
  - **Two Color** - A two-color spectrum. You may choose the two colors, which default to red and blue.
  - **User-Defined** - A version of one of the first four options above that you can customize. You can add or delete control points, as well as change RGB values for each control point.
  - **Raw User-Defined** - A version of one of the first four options above that can be customized by the user. To customize the color map, however, you must save your Raw User-Defined map to a file using the Save Color Map dialog accessible from the
Options menu. Then edit the resulting file, which consists of RGB triplets for every color in the spectrum. You can modify these RGB triplets as you want, using any ASCII text editor. See also Section “Color Map Files” on page 140.

You can have only one raw user-defined color map at a time.

- **Diverging** - Several color maps designed to emphasize data that diverges from a critical value, using a light value at the middle of the range and two darker colors at the extremes.
- **Doppler** - A color map for visualizing Doppler shifts, from Cyan to Blue for blue shifts, to black in the middle of the range, to red for red shifts.
- **Elevation** - Two color maps for elevation data, either above ground only or absolute (including water colors for below-ground data).
- **Hot Metal** - A black body radiation spectrum from black to red from yellow to white.
- **Magma** - Similar to a black body radiation spectrum but includes blue and purple colors for cooler areas.
- **Modified Rainbow** - Two modified Rainbow spectrums. One has darker blues and reds at the ends; the other has less green than the standard Rainbow.
- **Qualitative** - Uses difference in hue to indicate qualitative differences in data values. Numerous versions are available as starting points for different types of data.
- **Sequential** - Color maps intended to represent a progression of data from a minimum to a maximum value.

The Diverging, Qualitative, and Sequential color map families are based on the work of Dr. Cynthia A. Brewer, Professor of Geography at the Pennsylvania State University, for map coloring. For more information, see [http://www.personal.psu.edu/cab38/ColorSch/SchHome.htm](http://www.personal.psu.edu/cab38/ColorSch/SchHome.htm)

- **Color Spectrum** - Altering the position of the control points allows you to alter the proportions of colors in the spectrum. Click-and-drag control points to adjust the range of the color spectrum. CTRL+click-and-drag the control points to adjust the positions of the control points.
- **RGB Values for control point x** - In lieu of manually adjusting the control points, specify precise RGB values for control point “x” using the RGB sliders. Modifying the RGB values of the control points changes the spectrum itself.
- **Right RGB same as Left** - Toggle-on to define smoothly varying color maps for each two-sided control point (any control point except the first or last). Toggle-off to define sharp demarcations between color bands.
- **Number of Control Points** - Available for the User Defined Color Map only, use this field to adjust the number of control points. If you enter a number less than the current value, the control points are removed from right to left.
- **Color Standard Color Map** (user-defined and raw user-defined only) - Use this button to reset the color spectrum to either Small Rainbow, Large Rainbow, Modern, or Grayscale.
- **Redistribute Control Points** - Select this button to return the control points to their original positions.
- **Reset** - Select this button to reset the RGB values to their original values (and also reposition the control points in their original locations).
**Color Map Files**

The position of color map control points and their RGB values can be stored in color map files; you can then edit the color map files to modify either the position or RGB values of the control points.

To create a color map file, select “Save Color Map” from the Options menu. The resulting file includes the RGB triplet values for each point in the color spectrum and can be edited with any ASCII editor.

To use the saved color map in a new plot, choose “Load Color Map” from the Options menu. The color map file is a Tecplot 360 macro file with a limited set of commands (only $!COLORMAP and $!COLORMAPCONTROL commands are allowed).

**5 - 5.2 RGB Coloring**

RGB coloring occurs when Red, Green, and Blue values are supplied at each vertex. It may be used to create special flooding such as for Oil/Water/Gas or vector direction plots. RGB coloring may be used for each field plot object: zone layers, the mesh or contour layer for streamtraces or iso-surfaces, or any of the layers for slices. This affects multi-coloring for that object as well as any contour flooding. With RGB coloring, multi-colored objects such as vectors or scatter symbols have their color determined based on the RGB components of the field variables at their location. Multi-colored mesh and contour lines use the average value across the mesh line.

**Exported Vector-based Files Limitation in RGB Coloring**

Vector-based export files such as WMF cannot show continuous RGB flooding. Objects that use RGB flooding are reduced to contain average cell flooding where each cell is flooded a solid color based on the averages of the RGB values at each vertex. The user is warned before such output is generated.

**RGB Coloring Options**

If your data has only two RGB variables, or if the sum of the variables is not normalized, you can adjust the settings using the RGB Coloring Options dialog (accessed via Plot > RGB Coloring > Variables/Range). The RGB Coloring Options dialog (shown below) has the following options:

- **RGB Mode** - You can either specify all three variables or specify two of the three variables and calculate the third. The third variable is calculated using the following formula $f(R)+f(G)+f(B)=1.0$ (assuming $f$ is a function that maps R,G,B values into [0,1.0]).
- **Channel Variables** - Assign the variables which supply the values for the color components, as specified in the RGB Mode.
Channel Variable Range  - By default, it is assumed that the minimum value for any of the Channel Variables is zero, the maximum is one, and the sum of the three variables is one at every point. If the sum is not normalized, you can set a new minimum and maximum. For example, if your variables sum to 100 at every point, you can enter 100 in the field for Value at Maximum Intensity.

RGB Legend
To create an RGB legend, select RGB Coloring>Legend from the Plot menu. The RGB Legend is not available unless RGB coloring is in use. The RGB Legend dialog has the following options:

- **Show RGB Coloring Legend** - Toggle-on to include a RGB legend in your plot.
- **X(%)**, **Y(%)** - Specify the position of the anchor point as percentages of the frame width and height. (You can also move the legend interactively.)
- **Height (%)** - Specify the height of the legend in frame units.
- **Orientation** - Select the order of the coloring channels (i.e. RGB, GBR, BGR etc.). The first channel listed is shown on the lower left corner, the second on the lower right, and the third at the top.
- **Anchor** - Select the [Anchor] button to call up the Anchor Alignment dialog and specify which part of the legend is anchored to the position specified in **X(%)** and **Y(%)**.
- **Show Text Labels** - Toggle-on to include text labels in the legend. Use the [Color] and [Font] buttons to modify the labels. (See Section 18.1.2 “Font Folders and Fallback” on page 273 for more information on how fonts work with Tecplot 360.)
- **Red, Green, and Blue Label** - Each channel can be labeled by the name of the assigned variable, or by text you enter. To choose a new label for a channel, click [Specify], and type in the alternate label. When a channel has been calculated (no variable assigned), no label is shown unless the user enters text.
- **Legend Box** - Select which kind of box you want drawn around the legend (No Box, Filled, or Plain). If you choose Filled or Plain, format the box using the following controls:
  - **Line Thickness** - Specify the line thickness as a percentage of frame height.
  - **Box Color** - Choose a color for the legend box outline.
  - **Fill Color (filled only)** - Choose a color for the legend box fill.
  - **Margin** - Specify the margin between the legend text and legend box as a percentage of the text height.

5 - 5.3 Basic Color Palette

![Basic Color Palette](image)

Use the Basic Color Palette to define a constant color to the selected plot attribute(s). You may redefine a color in the Basic Color Palette with the Color Preferences Dialog, accessed via File>Preferences>Colors.
XY and Polar Line Plots

A line plot is the simplest type of graph produced by Tecplot 360. A line plot includes a dependent variable (typically the vertical axis, for XY plots) and an independent variable (typically the horizontal axis, for XY plots). Each line on the line plot represents one series of data points, where each data point is defined by its independent and dependent variable values. A series of data points is referred to as a mapping (or map, for short).

Tecplot 360 supports two types of line plots, XY plots and Polar plots. XY plots are plotted on Cartesian coordinates using X & Y as the independent and dependent variables (See Section 17 - 3 “Axis Variable Assignment”). XY plots can include line, symbols, bar and/or error bar layers. Polar plots are plotted on polar coordinates using Theta and R values. Polar plots can include line and/or symbol layers.

An example of XY and Polar Line plots is shown in Figure 6-1.

![Figure 6-1: A plot of speed versus angle in Tecplot 360’s XY Line (left) and Polar Line (right) plot types.](image)

Line plots are usually created from one-dimensional, I-ordered data. The data used for line plots must have at least two variables defined at each data point. The same number of variables must be defined at each data point.

You can also create line plots from two or three-dimensional data in the I or IJK-ordered structure, or from finite element data by selecting “XY Line” from the plot type menu in the Sidebar. If “XY Line” is selected, finite element data sets will be treated as I-ordered (the connectivity list is ignored), IJ-ordered datasets will be treated as a family of J-sets of I-ordered data, and IJK-ordered datasets will be treated as K-planes of J-families of lines. Use the Indices page of the **Mapping Style** dialog to select different ranges.

When you create a line plot, colors, symbol types, and line patterns are assigned to each mapping. These and other line plot attributes can be changed using the pages of the Mapping Style dialog. To bring up the Mapping Style dialog, go to the Plot menu and select “Mapping Style”, or select the [Mapping Style] button on the Sidebar.

6 - 1 Mapping Style and Creation

Line plots are composed of the graphs of one or more pairs of variables (XY pairs in XY Line plots or Theta-R pairs in Polar Line plots). These pairs and their dependency relations are referred to as mappings. Mappings are defined for each frame; the same dataset can have a different set of mappings in each frame it is attached to.

Mappings can include any combination of the following mapping layers:

- **Lines** - Can be drawn as linear segments or curve that fit the data points.
- **Symbols** - Each data point is represented by a symbol.
- **Bars (XY only)** - Each data point is represented by a vertical or horizontal bar.
- **Error Bars (XY only)** - Error bars are drawn for each data point. The error bar value is determined by a third variable.

XY Line plots can have up to five x-axes and five y-axes simultaneously. Polar Line plots can have only one Theta-axis and only one R-axis.

Use the Mapping Style dialog to set attributes for lines and symbols; and in XY Line plots, bar charts and error bars. You can also make many of these changes using the Quick Edit dialog (accessible from the Edit menu or the Sidebar). You can set the style of any mapping independently of all other mappings.

The options in the first three columns (Map Num, Map Name, and Map Show) are globally applied to the active frame and independent of the page of the dialog box.

6 - 1.1 Mapping Definitions

Existing mappings are edited with the Plot menu’s Mapping Style dialog. From the Definitions page of the Mapping Style dialog, you can: modify names, activate and deactivate mappings, assign axis variables, assign zones, sort data points in a mapping, control the mappings appearance in the line plot legend, and assign particular X and Y-axes to XY-line plots.

In general, select mappings you want to change, and then select the appropriate button above the list of mappings. Some buttons call up drop-downs, others call up dialogs. You may change mappings whether they are shown on the plot or not (activated or deactivated).
Mapping Style and Creation

- **Map Num** - Use the [Map Num] button to select one or more maps according to their map number(s).

- **Map Name** - Use the [Map Name] button to access one of the following options:
  - **Select by Name** - Use the Enter Text String dialog to select mapping(s) by name. You may use wildcards (*) and partial names to select a grouping of mappings at once. You may use regular expressions to select mappings based on part of their name. In regular expressions, letters and numbers match themselves, but many punctuation characters have special meaning. Sequences you will often find in regular expressions include:

<table>
<thead>
<tr>
<th>Character</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Matches 1 or more of the preceding character. For example, a+ means one or occurrences of the letter “a.”</td>
</tr>
<tr>
<td>*</td>
<td>Matches 0 or more of the preceding character. * (dot-star) is the equivalent of * in filename wildcards.</td>
</tr>
<tr>
<td>?</td>
<td>Matches an optional character (that is, 0 or 1 occurrences).</td>
</tr>
<tr>
<td>^</td>
<td>Forces the expression to match only at the beginning of text: ^wing matches only zones that start with “wing.”</td>
</tr>
<tr>
<td>$</td>
<td>Forces the expression to match only at the end of text: surface$ matches only zones that end with “surface.”</td>
</tr>
<tr>
<td>\</td>
<td>Forces the next character to be interpreted as itself. For example, * matches a literal asterisk. If a character a special meaning in a regular expression and do not want that meaning to apply, precede the character with a backslash.</td>
</tr>
</tbody>
</table>

For more information on regular expressions, see http://www.grymoire.com/Unix/Regular.html.

- **Edit Name** - Use the Enter Mapping Name dialog to change the name of the selected mapping.

- **Map Show** - Each mapping can be opted in and out of a plot using one of the following options:
  - **Activate** - Turns selected mappings on (denoted with “Yes” in the Map Show column).
  - **Deactivate** - Turns selected mappings off (denoted with “No” in the Map Show column).
  - **Show Selected Only** - Turns on selected mappings, and turns off all other mappings.
  - **Invert** - Switches the current activation settings for the selected map(s).

- **A-axis Variable** (where A = X, Y, Theta or R) - The choice of variables is the heart of the mapping. Each mapping is defined by two variables: X and Y in XY Line plots and Theta and R in Polar Line plots. You may change the variables assigned to a mapping using the Mapping Style dialog.

- **Zone Selection** - Each mapping uses variable values from a specified zone. If your dataset has multiple zones, specify the zone for each mapping by selecting the [Zone] button.

- **Data Point Sorting** - By default, mappings are sorted by the order in which they occur in the data file. You can change this order with the Sort option on the Definitions page of the Mapping Style dialog.

Choose from one of the following Sort options:
• **None** - Default behavior of sorting by the order in the data file.

• **By Independent Variable** - Points are sorted in ascending order of the values of the independent variable.

• **By Dependent Variable** - Points are sorted in ascending order of the values of the dependent variable.

• **By Specific Variable** - Select a variable from the *Select Variable* dialog. The points of the selected mappings are sorted in ascending order of the values of this variable.

Only Line Segment and ParaSpline are affected by the *Sort* options. Splines are always sorted by the independent variable. See *Section 6.2.2 "Curve Types"* for more information on curve types.

• **XY Line Plot Axis Assignment** - XY Line plots support five X-axes (X1-X5) and five Y-axes (Y1-Y5). Newly created mapping use the X1 and Y1-axes. You can change these assignments, using the *Which X-axis* and *Which Y-axis* fields on the *Mapping Style* dialog.

The ranges and scales for each axis are defined in the *Axis Details* dialog (accessed via the *Plot* menu).

![Figure 6-2. An XY Line plot using two Y-axes. This file, rainfall.lpk, is located in your Tecplot 360 distribution under the *examples/XY* subdirectory.](image)

By default, the X1 axis is placed at the bottom of your axis grid area, and subsequent X axes at the top. Similarly, it places axis Y1 at the left of your axis grid area and subsequent Y-axes at the right. Thus, in Figure 6-2, the Seattle rainfall observations are shown along axis Y1 at the left of the axis grid area, while the error observations are shown along Y2 at the right.

You can also use multiple axes to cycle through mappings with different ranges or axis settings. You may find it convenient to assign different mappings to different axes so that you can set axis ranges, axis positions, or other axis attributes independently for each mapping.

• **Show in Legend** - By default, all active mappings appear in the line legend. However, the legend only lists mappings with identical entries once. (See *Section 6.2.7 "Line Legend"* for details on the *Line Plot Legend*.) The *[Show in Legend]* button has three options:

  • **Always** - The mapping appears in the legend even if the mapping is turned off (deactivated) or its entry in the table looks exactly like another mapping's entry.
  
  • **Never** - The mapping never appears in the legend.
  
  • **Auto** - The mapping appears in the legend only when the mapping is turned on. If two mappings would result in the same entry in the legend, only one entry is shown.

---

146
Select Mapping Zone

Each mapping uses variable values from a specified zone. If your dataset has multiple zones, specify the zone for each mapping using the [Zone] button.

6 - 1.2 Map Creation

To define a new mapping, select the [Create Map] button in Mapping Style dialog. The Create Mappings dialog for each line plot type is shown in Figure 6-3.

In XY Line plots, you have the following options:

- **X-axis Var versus Y-axis Var for One Zone** (default) - Add a single mapping with one X and one Y-variable for one zone.
- **X-axis Var versus Y-axis Var for All Zones** - Define one map for each zone, with the specified X-axis and Y-axis variables. If you choose this option, you specify only the X-axis and Y-axis variables.
- **X-axis Var versus All Other Variables** - Create a new set of mappings using one variable as the X-variable and each of the other variables as Y-variables.

The options for polar line plots are the same as above, but with respect to the Theta-axis and R-axis variables.

Once you have selected a mapping option, you have the option to specify a mapping name and the axis variables.

- **Mapping Name** - Enter a name for the mapping in the Mapping Name text field. The default name is “Map n,” where n is the number of the mapping to be created.

When you first load an ordered dataset, some mappings are automatically created for you. If your dataset has more than two variables, mappings are created that associate the first variable with each of the other variables for the first zone only.

6 - 1.3 Enter Mapping Name

Tecplot 360 assigns each mapping a name. The nature of the name varies with the type of data used to create the mapping. If your data has only one dependent variable, the default is to use the zone name for
the mapping. If your data has multiple dependent variables, then the default is to use the dependent variable name for the mapping. You can modify any mapping’s name using the Enter Mapping Name dialog. This dialog is accessible from the Mapping Style dialog by selecting “Edit Name” from the Map Name drop-down. The Enter Mapping Name dialog is shown below.

Enter a new name for the selected mappings, or construct a new name by entering text combined with one or more of these pre-defined options:

- **Zone Name** - Adds the string “&ZN&” to the Map Name field, which is then replaced with the actual name of the zone assigned to that mapping.
- **Zone Number** - Adds the string “&Z#&” to the Map Name field, which is then replaced with the actual number of the zone assigned to the mapping.
- **Independent Var** - Adds the string “&IV&” to the Map Name field, which is then replaced with the actual name of the independent variable assigned to that mapping.
- **Independent Var Number** - Adds the string “&I#&” to the Map Name field, which is then replaced with the actual number of the independent variable assigned to the mapping.
- **Dependent Var** - Adds the string “&DV&” to the Map Name field, which is then replaced with the actual name of the dependent variable assigned to that mapping.
- **Dependent Var Number** - Adds the string “&D#&” to the Map Name field, which is then replaced with the actual number of the dependent variable assigned to the mapping.
- **Map Number** - Adds the string “&M#&” to the Map Name field, which is then replaced with the actual number of the mapping.
- **X-axis Num** - Adds the string “&X#&” to the Map Name field, which is then replaced with the actual number of the X-axis assigned to that mapping for XY Line plots. For Polar Line plots, this option is not available.
- **Y-axis Num** - Adds the string “&Y#&” to the Map Name field, which is then replaced with the actual number of the Y-axis assigned to that mapping for XY Line plots. For Polar Line plots, this option is not available.

In addition to the above items, any dynamic text item can be added to the Map Name field. See Section 18 - 1.5 “Dynamic Text” for more information on Dynamic Text.
6 - 2 Line Map Layer

The Line map layer is available for both XY and polar line plots. Activate the layer by toggling-on “Lines” in the Sidebar. When the Lines map layer is on, the dataset is represented by a connected line for each mapping, which may be either a simple collection of line segments connecting all the data points, or a curve fitted to the original data.

6 - 2.1 Line Attributes

The Lines page of the Mapping Style dialog (accessed via the Sidebar or Plot>Mapping Style) is shown below.

![Mapping Style dialog](image)

The first two columns, Map Num and Map Name, list the mapping number and the mapping name. The Map Show field lists which mappings are currently active. The remaining columns of the Lines page of the Mapping Style dialog contain specific line attributes.

- **Line Show** - This option allows you to turn off lines for selected mappings, while keeping both the selected mappings and the Lines map layer active overall.
- **Line Color** - Set line color for line plots.
- **Line Pattern** - Set line patterns for line plots.
- **Pattern Length** - Set the pattern length for patterned lines. Pattern length is measured as a percentage of the frame height for one complete cycle of the pattern.
- **Line Thickness** - Set the thickness of lines.

6 - 2.2 Curve Types

Tecplot 360 offers a variety of curve-fits and spline fits. By specifying the curve type, you control how the data points are connected. Set the type of curve plotted for a mapping using the Curve Type drop-down.
on the Curves page of the **Mapping Style** dialog, or by using the corresponding Line button on the **Quick Edit** dialog.

Tecplot 360 offers the following curve types (the names are as shown under the Curve Type drop-down and the buttons as shown in the **Quick Edit** dialog):

- **Line Segments (No Curve-fit)** - A series of linear segments connect adjacent data points. In XY Line plots, these will be line segments. See Section 6.8 "Polar Drawing Options" for a discussion of Line Segments in Polar Line plots.
- **Linear Fits** - A linear function is fit to the data points. In XY Line plots, this will be a straight line. (Linear fit is not available on **Quick Edit** dialog.)
- **Polynomial Curve-fits** - A polynomial of order N is fit to the data points (where 1 < N ≤ 10, for N=1 a Linear Fit is done).
- **Exponential Curve-fits** - An exponential curve-fit that finds the best curve of the form \( Y = a e^{b X} \) (equivalent to \( Y = a e^{b X} + c \), where \( a \) and \( c \) are both positive). To use this curve type, Y-values for this variable must be all positive or all negative. If the function dependency is set to \( X=f(Y) \) all X-values must be all positive or all negative.
- **Power Curve-fits** - A power curve fit that finds the best curve of the form \( Y = a X^b \) (equivalent to \( Y = a X^b + c \), where \( a \) and \( c \) are both positive). To use this curve type, Y-values for this variable must be all positive or all negative; X-values must be all positive. If the function dependency is set to \( X=f(Y) \), X-values must be all positive or all negative, and the Y-values must all be positive.
- **Splines** - A smooth curve is generated that goes through every point. The spline is drawn through the data points after sorting the points into increasing values of the independent variable, resulting in a single-valued function of the independent variable. The spline may be clamped or free. With a clamped spline, you supply the derivative of the function at each end point; with a non-clamped (natural or free) spline, these derivatives are determined for you. In XY Line plots, specifying the derivative gives you control over the initial and final slopes of the curve.
- **Parametric Splines** - Creates a smooth curve as with a spline, except the assumption is that both variables are functions of the index of the data points. (For example in XY Line plot, ParaSpline fits \( x=f(i) \) and \( y=g(i) \) where \( f(i) \) and \( g(i) \) are both smooth.) No additional sorting of the points is performed; the sorting specified on the Definitions page of the **Zone Style** dialog is used for the order of the data points. This spline may result in a multi-valued function (of either or both axis variables).
- **Extended Curve-fit** - Uses a curve-fit supplied by an add-on. These curve-fits may be provided by Tecplot 360, a third party, or written by users. The functionality of each extended curve-fit is defined by its creator. If you wish to write an extended curve fit add-on, see the **ADK User's Manual** for more information.
Linear Fit, Polynomial Fit, Exponential Fit, and Power Fit are all determined by using a least squares algorithm. Examples of each curve-fit type are shown in Figure 6-4.

Figure 6-4. Tecplot 360's curve-fit types.

The Curves page also contains fields for controlling the following attributes:

- **Dependent Variable** - The Dependent Variable drop-down controls how curve fits and splines are interpreted. Dependent Variable has no effect on mappings of the Line Segment curve type.
- **Curve Points** - Controls the number of points used to draw curve fits and splines. Raising the number of points increases the accuracy of curve but also increases plotting time and the size of print files.
- **Curve Settings** - Control options specific to the curve type. For example, weighting for curve fits or starting derivatives for splines.

The coefficients used to draw curve fits and splines may be output to a file, as can the actual points used to draw curve fits and splines.

**Linear Fits**

Tecplot 360 fits the data to a linear function using the standard least-squares algorithm. It calculates the function for which the sum of the squared differences from the data points is a minimum. For the XY Line plot type, the linear function is a straight line.

To fit a linear function to your data: select “Linear Fit” from the Curve Type drop-down on the Curves page of the Mapping Style dialog.
Use the Curve Fit Settings dialog (accessed via the [Curve Settings] button) to specify different settings. The dialog is shown below.

- **Polynomial Order** is shown on the dialog, but should always be “1” for a linear fit. If you change this from 1, the curve type is changed to Polynomial Curve-fits.
- To limit the points used in the mapping(s), select “Use Only Points Within Range”, and enter minimum and maximum values.
- To assign a curve weighting variable: select “Use Weighting Variable”, and select the variable from the drop-down. For more information on curve weighting, see Curve-fit Weighting Variables.

### Polynomial Curve-fits

Tecplot 360 uses a standard least-squares algorithm to fit data to a polynomial function. You specify the order of the polynomial (from one to ten), and the polynomial for which the sum of the squared differences from the data points is a minimum is calculated.

To fit a polynomial function to your data: select “Polynomial Fit” from the Curve Type drop-down on the Curves page of the Mapping Style dialog.

By default, this option fits a cubic polynomial, using all the points in the mapping and weighting them equally. Use the Curve Fit Settings dialog (accessed via the Curves page of the Mapping Style dialog) to specify different settings.

- Polynomial Order drop-down. Select the desired polynomial order (1 to 10). An order of 2 is a quadratic polynomial, an order of 3 is a cubic polynomial, etc. If you select 1, the curve type is set to Linear Fit, as a polynomial of order 1 is a linear function. (See Linear Fits.)
- To limit the points used in the mapping(s) - Select “Use Only Points Within Range”, and enter minimum and maximum values.
- To assign a curve weighting variable - Select “Use Weighting Variable”, and select the variable from the drop-down. For more information on curve weighting, see Curve-fit Weighting Variables.

### Exponential Curve-fits

Tecplot 360 fits the data to an exponential function using the standard least-squares algorithm.

The dependent-variable values must be either all positive or all negative.
Line Map Layer

For XY plots (where X is the independent variable): Tecplot 360 finds the best curve of the form:

\[ Y = e^{bX+c} \]

(equivalent to \( Y = a e^{bX} \) where \( a = e^c \)).

Similarly, when \( Y \) is the independent variable.

For Polar plots (where Theta is the independent variable): Tecplot 360 finds the best curve of the form:

\[ R = a e^{b \Theta + c} \]

or

\[ R = a e^{b \Theta} \]

Similarly when \( R \) is the independent variable.

To fit an exponential function to your data: select “Exponential Fit” from the Curve Type drop-down on the Curves page of the Mapping Style dialog.

By default, this option uses all the data points in the mapping, weighting them equally. Use the Exponential Fit Settings dialog (accessed via the [Curve Settings] button on the Curves page of the Mapping Style dialog) to specify different settings. The dialog is shown below.

To specify different settings:

- To limit the points used in the mapping(s) - Select “Use Only Points Within Range”, and enter minimum and maximum values.
- To assign a curve weighting variable - Select “Use Weighting Variable”, and select the variable from the drop-down. For more information on curve weighting, see Curve-fit Weighting Variables.

**Power Curve-fits**

Tecplot 360 fits a power function to data using the standard least-squares algorithm. The dependent-variable values must be either all positive or all negative, and the independent values should be all positive. Data points with zero or negative independent values are ignored.

For XY plots (where X is the independent variable): Tecplot 360 finds best curve of the form:

\[ Y = e^{b \ln X + c} \]

(equivalent to \( Y = a X^b \) where \( a = e^c \)).

Similarly, when \( Y \) is the independent variable.

For Polar plots (where Theta is the independent variable): Tecplot 360 finds the best curve of the form:
Similarly, when R is the independent variable.

To fit a power-curve function to your data: select “Power Curve” from the Curve Type drop-down on the Curves page of the Mapping Style dialog.

By default, this option uses all the data points in the mapping, weighting them equally. Use the Power Fit Settings dialog (accessed via the [Curve Settings] button) to specify different settings. The dialog is shown below.

- To limit the points used in the mapping(s) - Select “Use Only Points Within Range”, and enter minimum and maximum values.
- To assign a curve weighting variable - Select “Use Weighting Variable”, and select the variable from the drop-down. For more information on curve weighting, see Curve-fit Weighting Variables.

Splines

A spline is a mathematical function defined to link a specified set of points with a function that is continuous and smooth (differentiable) at every point. The most common type of spline, the cubic spline, is defined using a set of cubic polynomials, one for each interval between the data points.

Splines can be natural or clamped: natural splines are twice-differentiable at the end points and the second derivative is zero at those points, while clamped splines need have known first-derivatives at the boundary points. Before plotting the spline, the data points are sorted in increasing value along the independent axis.

The Sort option of the Definitions page of the Mapping Style dialog has no effect on splines.

To fit a spline function to your data: select “Spline” from the Curve Type drop-down on the Curves page of the Mapping Style dialog.

By default, this option fits a natural cubic spline. To specify a clamped spline:

\[
R = r^2 \sin(2\theta) \quad \text{or} \quad R = \sin^3\theta
\]
1. Select the [Curve Settings] button on the Curves page of the Mapping Style dialog.
2. In the Spline Settings dialog (shown below), select “Clamp the Spline”, and enter values for the derivative at the start and end of the spline.

**Parametric Splines**

The cubic spline fit assumes that the spline function is a single-valued function of the independent variable. Sometimes, however, you have data that curves back upon itself, but you would still like to have a spline-like curve fit to it. Parametric splines solve this problem by presuming that both variables (X&Y or Theta&R) are functions of the data-point index. The spline is then defined by two single-valued functions of the data-point index.

Unlike cubic splines, parametric splines are plotted in the order set in the Sort option of the Definitions page of the Mapping Style dialog. By default, the points are unsorted, and thus the spline is drawn in the order the data points appear in the data file. See Section 6.1.1 "Mapping Definitions" for a discussion of sorting.

To fit a paraspline function to your data: select "ParaSpline" from the Curve Type drop-down on the Curves page of the Mapping Style dialog.

By default, this option fits two natural cubic splines to the data point index. To specify a clamped spline:

1. Select Para Spline from the Curve drop-down menu, and then select Curve Settings.
2. In the Parametric Spline Settings dialog (shown below), select “Clamp the Spline”, and enter values for the derivative at the start and end of the spline.

For the XY Line plot type, the derivatives are either \( \frac{dy}{dx} \) or \( \frac{dx}{dy} \) depending on the Function Dependency for the mapping. Tecplot 360 calculates \( \frac{dx}{ds} \) and \( \frac{dy}{ds} \) from these values (where \( s \) is the parametric variable). For the Polar Line plot type, the derivatives are either \( \frac{dR}{d\theta} \) or \( \frac{d\theta}{dR} \) (depending on the Function Dependency for the mapping), and \( \frac{dR}{ds} \) and \( \frac{d\theta}{ds} \) are calculated from these values (where \( s \) is the parametric variable). See Section 6.1. "Dependent and Independent Variables" on page 158 for a full description of the Function Dependency option.
Extended Curve-fit

Tecplot 360 add-ons can provide new curve-fit types. These curve types are called extended curve-fits. These curve-fits may be provided by Tecplot 360, a third party, or written by users. The functionality of each extended curve-fit is defined by its creator. (If you wish to write an extended curve-fit add-on, see the ADK User’s Manual for more information.)

To fit an extended curve to your data:

1. Use the Curves page of the Mapping Style dialog to select the mappings for which you want to apply an extended curve-fit.
2. Select Curve Type, and select “Extended” from the drop-down.
3. Select the desired curve fit from the Choose Extended Curve Fit dialog (shown below).

Three extended curve fit add-ons are supplied with Tecplot 360:

- **Akima** - The Akima spline is an alternative that exhibits less dramatic overshoots and undershoots than the classical spline. The slopes at the end of each segment are computed using a nonlinear average of the segment slopes. The Akima spline is always unclamped. There are currently no options available for the Akima spline.
- **Extended Curve Fit - General**
- **Extended Curve Fit - Stineman**

---

Extended Curve Fit - General

The General Curve Fit add-on fits an equation composed of a linear combination of user-specified sub-functions to the data in the specified map. The optional parameters can be accessed by selecting the Curve Settings option on the Curves page of the Mapping Style dialog.

The curve fit computes (least squares) the optimal curve fit coefficients by multiplying these sub-functions.

The following options are available:

- **Number of Coefficients** - Specify the number of coefficients (and number of sub-functions) for the desired curve fit. The default is three. You must specify a sub-function for each coefficient in the text fields labeled f1(x) through fn(x), where n is the number of coefficients.
- **f1(x) through fn(x)** - Enter the sub-functions for the curve fit using the syntax described in Section 21.1 "Data Alteration through Equations".
- **Normalize X** - Causes the curve to be fit using a normalized independent variable. In particular, the independent variable will be translated and scaled to vary from zero at the smallest value of the independent variable to one at the largest value of the independent variable. For most curves other than polynomials, this option will alter the shape of the curve fit. It is useful when you get the “Rank reduced for at least one curve fit” warning message, but otherwise is not recommended.
- **Normalize Y** - Causes the curve to be fit using a normalized dependent variable. In particular, the dependent variable will be translated and scaled to vary from zero at the smallest value of the dependent variable to one at the largest value of the dependent variable. For most curves other than polynomials, this option will alter the shape of the curve fit. It is useful when you get the “Rank reduced for at least one curve fit” warning message, but otherwise is not recommended.

In these equations use the variable x as the independent variable, even if x is specified as the dependent variable in the Curves Fit Attributes dialog.
Extended Curve Fit - Stineman

This method of interpolation generates a curve that will never have more inflection points than are clearly required by the given set of data points. The interpolating curve passes through the data points and exactly matches the computed slopes at those points. The optional parameters can be accessed by selecting the Curve Settings option on the Curves page of the Mapping Style dialog.

![Stineman Interpolation](image)

Line Segments (No Curve-fit)

By default, a series of linear segments are drawn between each set of points for the XY Line plot type. (See Section 6 - 8 "Polar Drawing Options" for a discussion of Line Segments in Polar Line plots.)

To turn off curve fits for your data and use linear segments between points:
1. From the Curves page of the Mapping Style dialog, select the mappings you want to show as linear segments.
2. Select “Curve Type”. Select Line Segments from the drop-down.

Line Segments are plotted in the order set in the Sort option of the Definitions page of the Mapping Style dialog. By default, the points are unsorted, and lines segments are drawn in the order the data points appear in the data file. See Section 6 - 1.1 "Mapping Definitions" for a discussion of sorting.

Dependent and Independent Variables

Every mapping has a dependent variable and an independent variable. The dependency relationship determines the shape of your plot for most curve types. This dependency has no effect on line segment curve types, and for parametric splines, the dependency is only used to determine starting derivatives for clamped parametric splines. Extended curve-fits are free to use or not use this dependency depending on the type of curve-fit supplied.

You specify the dependency relationship between your axis variables using the Dependent Variable drop-down on the Curves page of the Mapping Style dialog.

For the XY Line plot type, the default setting is $y=f(x)$ (you may change the value to $x=f(y)$). With $y=f(x)$, the X-axis variable is the independent variable and the Y-axis variable is the dependent variable. With $x=f(y)$, $y=f(x)$.

---

the Y-axis variable is the independent variable and the X-axis variable as the dependent variable. Two polynomial curve-fits of the same data using different dependency settings are shown in Figure 6-5.

![Figure 6-5](image)

**Figure 6-5.** An XY Line plot type dependencies. This file, line_plots_ind_v_dep_var.lpk, is located in your Tecplot 360 distribution under the examples/XY subdirectory.

Similarly for Polar Line plots, the default setting is \( R = f(\Theta) \) (you may change the value to \( \Theta = f(R) \)). With \( R = f(\Theta) \), the Theta-axis variable is the independent variable and the R-axis variable is the dependent variable. With \( \Theta = f(R) \), the R-axis variable is the independent variable and the Theta-axis variable is the dependent variable.

To change the dependency setting:
1. From the Curves page of the Mapping Style dialog, select the mappings to change.
2. Select “Dependent Variable” and choose either \( R = f(\Theta) \) or \( \Theta = f(R) \).

For the XY plot type, the dependency setting determines the direction of bar charts. To create a vertical bar chart, set the dependency to \( y = f(x) \); to create a horizontal bar chart, set the dependency to \( x = f(y) \). See Section 6.5 “XY Line Bar Charts” for information on bar charts.

**Curve-fit Weighting Variables**

Linear, polynomial, exponential, and power fits allow you to specify a weighting variable. By default each data point is weighted equally. With the weighting variable, individual points can be given more or less weight. Relatively larger numbers in the curve weighting variable mean more significance for a given point. If the curve-weighting variable is zero at a data point, that data point has no effect upon the resulting curve.

The weighting coefficients must be integers in the range of zero to 9,999. Weighting coefficients defined as floating-point numbers are truncated. That is, a weighting coefficient of 1.99 is truncated to 1.0.

For example, consider the distance-temperature data in the example data file `simp1xy.dat` (found in the examples/dat directory in your Tecplot 360 home directory). There is a small cluster of points centered about Distance=0.1 and Temperature=550. If we add the following weighting variable to the original data file `simp1xy.dat`, we can omit this cluster from our analysis:

```
1 1 0 0 0 0 0 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
```

The data file `simp1xy2.dat` (also found in the examples/dat directory in your Tecplot 360 home directory) contains this additional variable as variable 6, Weight4.
The left side of Figure 6-6 shows an XY-line plot with weighted linear fit with the cluster of points omitted. For comparison, the original data points and the un-weighted least-squares fit are also plotted. The right side shows the same data in a Polar Line plot.

Figure 6-6. Weighted linear fits.

Curve Information

You can view information about curve-fits and splines using the Curve Information dialog (accessed via the Data menu) (shown here). The information presented in the Curve Details section and in the coefficient file is dependent on the curve type selected. For example, the dialog shown here shows the information for a linear fit. For extended curve-fits, the documentation for the extended curve-fit add-on supplies any necessary information on the format used.

In general, the Curve Information dialog provides the following:

- **Mapping** - Select the map from the drop-down for which you want information, or from which you want to extract coefficients or data points.
- **X-axis Var** - Number and name of the X-axis variable for the chosen map.
- **Y-axis Var** - Number and name of the Y-axis variable for the chosen map.
- **Zone** - Number and name of the zone for the chosen map.
- **Curve Details** - Detailed list of coefficients used in the equation to draw the line.
- **Goodness of Fit** - Measurement of the success of the curve-fit in modeling the variation of the data (where 1 is a perfect fit and zero is no fit).
  - Goodness of Fit (Residual Degrees of Freedom Adjustment) - Same as above, with degrees of freedom taken into consideration.
  - Write Curve Details to File
  - Write Data Points to File

Goodness of Fit

R² is displayed in Curve Details region of the Curve Info dialog for linear, polynomial, exponential, and power curve fits. It is statistical calculation that measures the success of the curve-fit in modeling the
variation of the data. $R^2$ is defined as the ratio of the sum of the squares of the regression (SSR) and the total sum of the squares (SST).

$$SSR = \sum_{i=1}^{n} Wi(y_{\text{curvefit},i} - y_{\text{mean}})^2$$

$$SST = \sum_{i=1}^{n} Wi(y_i - y_{\text{mean}})^2$$

$$R^2 = \frac{SSR}{SST}$$

Where:

$SSR$ = sum of the squares of the regression

$SST$ = total sum of the squares

$W_i$ = the value of the weight variable at index $i$

$y_i$ = the value of the dependent variable at index $i$

$y_{\text{mean}}$ = the mean value of the dependent variable $y$

$y_{\text{curvefit},i}$ = is the value computed using the curve-fit at the $i$-index value of the independent variable ($x_i$).

$i$ = current index number

$n$ = total number of data points

$R$-square can take any value between zero and one, with a value closer to one indicating a better fit.

A fundamental error term in least-squares curve fits is the sum of the squares residual (SSE), defined by

$$SSE = \sum_{i=1}^{n} W_i(y_{\text{curvefit},i} - y_i)^2$$
This is the number that is minimized when computing the curve-fit coefficients. Using the equation \( SST = SSE + SSR \), \( R^2 \) can be related to SSE:

\[
R^2 = 1 - \frac{SSE}{SST}
\]

Using this form to compute \( R^2 \), it is easier to see that an \( R^2 \) closer to one (SSE=0) indicates a better curve-fit.

**Goodness of Fit (Residual Degrees of Freedom Adjustment)**

One problem with \( R^2 \) is that it will always indicate a good curve-fit when the number of data points, \( n \), equals the number of degrees-of-freedom, \( m \). (For example, a quadratic curve-fit through three data points.) In this case, the curve passes through all data points so SSE=0 and \( r\)-square=1. However, there are no other data points so, in reality, no estimate can be made on the quality of the curve fit away from the specified data points. In general, any time \( m \) (degrees-of-freedom) is close to \( n \) (number of data points), \( r\)-square will overstate the quality of the curve fit. For this reason, we include the second goodness-of-fit parameter: degrees-of-freedom adjusted \( R^2 \):

\[
R^2_{dof} = 1 - \frac{SSE(n-1)}{SST(m-n)}
\]

Like the standard \( R^2 \), \( R^2_{dof} \) will vary from zero to one with values closer to one indicating a better curve fit. \( R^2_{dof} \) will be less than \( R^2 \) when the degrees-of-freedom are close to the number of data points, but will be nearly equal to \( R^2 \) when the number of data points is significantly greater than the degrees-of-freedom.

**Write Curve Details to File**

Using the **Curve Information** dialog (accessed via the **Data** menu), you can save the coefficients for each curve fit or spline for further analysis in later sessions.

To create an ASCII data file of the coefficients of the curve fits or splines:

1. From the **Data** menu, select “Curve Info”.
2. From the **Curve Information** dialog, select a mapping from the Mapping drop-down.
3. Select “Write Curve Info to File”.

**Write Data Points to File**

Using the **Curve Information** dialog (accessed via the **Data** menu), you can save the calculated data points along the curve for further analysis in later sessions.

To create an ASCII data file of the points of the curve fits:

1. From the **Data** menu, select “Curve Info”.
2. From the **Curve Information** dialog, select a mapping from the Mapping drop-down.
3. Select “Write Data Points to File”.

The data file contains one zone for each line in the mapping. For mappings made from I-ordered zones, there is one zone. See Section 6 - 6 “I, J, and K-indices” for details on mappings using IIJK and IJK-ordered data.

Each zone in the data file is I-ordered with the number of points equal to the active curve points setting (set via the Curve Points option on the Curves page of the Mapping Style dialog). The data file has two
variables: one for the independent variable and one for the dependent variable. The resulting file is a valid Tecplot 360 ASCII data file that can be read into another frame.

6 - 3   Symbols Map Layer

The Symbols map layer is available for both XY and polar line plots. Activate the layer by toggling-on “Symbols” in the Sidebar. When the Symbols map layer is on, each data point is represented by a symbol on the plot. For each mapping, you may choose the plotting symbol used, and whether to use filled or plain symbols.

6 - 3.1   Symbol Attributes

Use the Symbols page of the Mapping Style dialog (shown below) to modify the attributes of the Symbols layer.

The first two columns list the mapping number and name. The Map Show field lists currently active mappings. The remaining columns of the Symbols page of the Mapping Style dialog contain specific attributes: Symb Show, Symb Shape, Outline Color, Fill Mode, Fill Color, Symb Size, Line Thick, Symb Spacing. Each of these attributes can also be modified using the Quick Edit dialog.

• **Symb Show** - This option allows you to turn off symbols for selected mappings, while keeping both the selected mappings and the Symbols map layer active overall.
• **Symbol Shape** - Select the symbol type for each mapping. In addition to the predefined symbols, you may use any ASCII character by selecting Other. Enter the ASCII character to use as a symbol in the Enter ASCII Character dialog (shown below), and select a font from which to display the symbol.

You can change the base font in the Scatter Size/Font dialog, accessible via Plot-Symbol Font. See Section 11 - 2 “Scatter Size/Font” on page 217.
• **Outline Color** - Symbols can be filled or unfilled (default).
• **Fill Mode** - The Fill Mode options are:
  • None - The symbols are not filled.
  • Use Line Color - The symbols are filled with the same color specified in Outline Color and appear as a solid color.
  • Use Back Color - The symbols are filled with background color of the grid area, and appear hollow, blotting out objects behind the symbol (such as grid lines or other mappings).
  • Use Specific Color - The symbols are filled with the color specified in Fill Color.
• **Fill Color** - If the Fill Mode is set to “Use Specific Color”, use the [Fill Color] button to set the color.
• **Symbol Size** - Select the symbol size for your line plotting symbols. Symbol size is measured as percentage of the frame height.
• **Symbol Line Thickness** - Specify the thickness of lines used to draw the plotting symbols.
• **Symb Spacing** - Specify the spacing between symbols. The spacing is specified either as a percentage of the frame height or as a number of indices to skip. You may either enter a value or use one of the following pre-set values:
  • Draw All - All symbols are drawn at every data point.
  • ISkip=2, 3 or 4 - Symbols are drawn every second, third, or fourth data point.
  • Distance=1, 2 or 3% - Symbols are drawn at the first data point and subsequently at data points that are at least one, two, or three percent of the frame height distant from the previously plotted data point.
  • Enter Index - Enter an index skip between symbols (other than 2, 3, or 4).
  • Enter Distance - Enter a distance between symbols in frame units (other than 1%, 2%, or 3%).

### 6 - 3.2 **Enter ASCII Character**

Use the **Enter ASCII Character** dialog to specify an ASCII character to use as a plotting symbol in either a field scatter plot or an XY symbol plot. You enter the desired character, and then choose the character set from which to draw the character.

This dialog has one text field for specifying the ASCII character and four option buttons representing the available character sets, as follows:

• **Enter Character to use as a Symbol** - Enter the desired ASCII character in this text field.
• **Base** - Select this to use the English-text character set as the source of the plotting character.
• **Math** - Select this to use the math character set as the source of the plotting character.
• **Greek** - Select this to use the Greek character set as the source of the plotting character.
• **User-defined** - Select this to use the user-defined character set as the source of the plotting character.
6 - 4 XY Line Error Bars

In the XY Line plot type, you can assign one or more variables to be used to compute error bars for another variable. Each mapping can be associated with only one error bar variable. If you want to assign multiple error bar variables to a mapping, create a copy of the mapping for each error bar variable.

An example plot with error bars is shown in Figure 6-7.

Figure 6-7. An XY Line plot with symbols and error bars. This file, rainfall.plt, is located in your Tecplot 360 distribution under the examples/XY subdirectory.

You can use any variable in your dataset as an error bar variable. However, for them to be meaningful, they should have the same units as the axis along which they are drawn.

If error bar values are not included in your original dataset, you may create error variables using Tecplot 360’s data manipulation utilities. For example, if you know that the values of some measured variable are accurate only to within ten percent, you may create a new variable to use as the error bar variable by multiplying the measured variable by "0.10" via Data>Alter>Specify Equations. See Chapter 21: "Data Operations".

6 - 4.1 Select Variable

Use the Select Variables dialog to choose:

- A single variable, as when assigning a variable to the X or Y-axis in an mapping. The text and labels will vary with the particular action being performed, but the operation of the dialog is the same in all cases. Select a variable from the drop-down of the dataset's variables and select [OK].
- Two variables, as when assigning 2D axis variables or choosing 2D vector components. The text and labels will vary with the particular action being performed, but the operation of the dialog is the same in all cases. For each of the two variables required, select a variable from the drop-down of the dataset's variables.
- Three variables, as when assigning 3D axis variables or choosing 3D vector components. The text and labels will vary with the particular action being performed, but the operation of the dialog is the same in all cases. For each of the three variables required, select a variable from the drop-down of the dataset's variables.
6 - 4.2 Error Bar Attributes

You can modify most of the attributes with which error bars are drawn—their color, their thickness, their spacing, and the width of the endpoint crossbars. You can make these changes from the Error Bars page of the Mapping Style dialog (shown below), or for some settings you can use the Quick Edit dialog.

- **EBar Var** - Select the error bar variable.
- **EBar Type** - There are seven types of error bars:
  - **Top** - Extends upward for positive values (and downward for negative values) of the error bar variable.
  - **Bottom** - Extends downward for positive values (and upward for negative values) of the error bar variable.
  - **Left** - Extends to the left for positive values (and to the right for negative values) of the error bar variable.
  - **Right** - Extends to the right for positive values (and to the left for negative values) of the error bar variable.
  - **Horizontal** - Extends left and right.
  - **Vertical** - Extends up and down. (This is the default value.)
  - **Cross** - Extends up, down, left, right.

Although the values are called Left, Right, Up and Down, the direction is determined by the direction of positive values in your plot. If you reverse the direction of an axis (using the Reverse Axis Direction option on the Range page of the Axis Details dialog), the error bars point in the opposite direction.

- **EBar Color** - Specify the error bar line color.
- **EBar Size** - Specify the size of the crossbar. Crossbar size is measured as a percentage of frame height.
- **Line Thick** - Specify the line thickness of the error bars. The error bar line thickness is measured as a percentage of frame height.
- **EBar Spacing** - Specify the spacing between error bars. The spacing is specified either as a percentage of the frame height or as a number of indices to skip.

You may either enter a value or use one of the following pre-set values:

- **Draw All** - Error bars are drawn at every data point.
- **ISkip=2, 3 or 4** - Error bars are drawn every second, third or fourth data point.
• Distance=1, 2, or 3% - Error bars are drawn at the first data point and subsequently at data points that are at least one, two or three percent of the frame height distant from the previously plotted data point.

6 - 5 XY Line Bar Charts
A bar chart is an XY Line plot that uses vertical or horizontal bars placed along an axis to represent data points. You can create bar charts by activating the Bars map layer on the Sidebar.

6 - 5.1 Bar Chart Attributes
The style of the bar chart is controlled on the Bars page of the Mapping Style dialog, shown below.

Use the [Bar Dir] button to change between vertical or horizontal bars.
Changing the direction of the bars changes the dependent variable attribute used for line curves (either y=f(x) or x=f(y)), and vice versa. By default, all mappings use y=f(x) and appear as vertical bar charts. If a mapping uses horizontal bars, the mapping will also use x=f(y) for curve fits. Of course, this only matters if you plot bars and curve-fits for the same mapping. For more information about dependency, see Section "Dependent and Independent Variables" on page 158.

To modify other attributes (Bars Show, Outline Color, Fill Mode, Fill Color, Bar Size, Line Thick), use the Bars page, follow the same procedures used to set Section 6 - 3.1 "Symbol Attributes".

6 - 6 I, J, and K-indices
Each mapping can show either I, J, or K-varying families of lines. By default, Tecplot 360 displays the I-varying family of lines. Figure 6-8 shows the family of I-varying lines for Zone 1 of the data.

Figure 6-8. A family of I-varying lines for the cylinder data.
You can change the family of lines using the Indices page of the **Mapping Style** dialog as shown below.

![Mapping Style dialog](image)

You can also choose which members of the family are drawn (and using which data points), by specifying index ranges for each of I, J, and K. The index range for the varying index tells Tecplot 360 which points to include in each line, and the index ranges for the other indices tell Tecplot 360 which lines in the family to include. Thus, you may use this option for selecting a subset of an I-ordered zone to plot.

- **Varying Index** - To choose the varying index, and thus specify the family of lines to be drawn, select **Varying Index** on the Indices page of the **Mapping Style** dialog, and choose the desired family (I, J, or K-varying). K-varying is only available if the mapping is using an IJK-ordered zone.

- **Index Ranges** - By default, the entire range of points is plotted in your mapping. For IIJK and IJK-ordered data, you may want to specify an index range to limit the number of lines drawn. Or, for any type of data, you may want to limit the points drawn to a select range. Enter a starting index in the Begin field, an ending index in the End field, and a skip factor in the Skip field. A skip of one means “use every point in the range,” a skip of two means “use every other point,” and so on.

Use the **Enter Index Skipping** dialog to enter the respective skips for the I, J, and K-indices. A value of one means show all indices, two means show every other index, three means show every third, and so on.

### 6 - 7 Line Legend

You can generate a legend that shows the line and symbol attributes of the mappings. In XY Line plots, this legend includes the bar chart information. The legend can be positioned anywhere within the line plot frame.

The mappings that are shown in the legend are selected on the Definitions page of the **Mapping Style** dialog. By default, all mappings are shown, but Tecplot 360 removes redundant entries.

To include the line plot legend, open that **Line Legend** dialog (accessed via the **Plot** menu) and toggle-on “Show Line Legend”. The **Line Legend** dialog has the following options:
• **Show Mapping Names** - Toggle-on or off to include mapping names in the legend.

• **Text** - Format the text for the legend by choosing a color, font, style, text height, and line spacing between entries in the dialog. (See Section 18 - 1.2 “Font Folders and Fallback” on page 273 for more information on how fonts work with Tecplot 360.)

• **Position** - The legend is automatically placed for you. You may specify the position of the legend by entering values in the X (%) and Y (%) text fields. Enter X as a percentage of the frame width and Y as a percentage of the frame height.

• **Anchor** - You may also specify the anchor location of the legend using the Anchor Alignment dialog. By default, the legend is anchored in the top right.

• **Legend Box** - If the legend is Plain or Filled, the box attributes may be changed with the following controls.

• **Line Thickness** - Specify the line thickness as a percentage of frame height.

• **Box Color** - Choose a color for the legend box outline.

• **Fill Color** - Choose a color for the legend box fill.

• **Margin** - Specify the margin between the legend text and legend box as a percentage of the text height.

6 - 7.1 **Specify Number Format**

• **Format** - Choose the format for numbers in the contour legend from the drop-down:
  
  • **Integer** - Display the number as an integer; if the exact value is not an integer, it is truncated.
  
  • **Float** - Display the number as a floating-point number. The value is shown to the number of decimal places specified in the Precision field.
  
  • **Exponent** - Display the number using FORTRAN exponential format (for example, 1.0125E + 02). The number of decimal places is specified using the Precision field.
  
  • **Best Float** - Display the number as a floating-point number, with its exact form determined by Tecplot 360.
• **Range Best Float** - Tecplot 360 selects the best floating-point representation of the tick mark labels, taking into account the range of values on the axis. (Available only for axis labels.)

• **Superscript** - Display the number in scientific notation, using a number times a power of ten. The number of decimal places shown is specified using the Precision field.

• **Custom** - Not a number format at all, Custom specifies that a set of custom labels (specified by number in the Custom Set field) should be used in the contour legend. The first label in the set is used for the value one, the second label for two, and so on. All non-integer numbers are rounded to the nearest integer. If the number of levels exceeds the number of custom labels, the labels are reused cyclically as needed. For example, if you have defined the custom labels Mon., Tue, Wed, Thu, Fri, Sat, and Sun, then a value of eight would display Mon, nine would display Tue, and so on.

• **Time/Date** - You can specify a Time/Date format for your labels by selecting Time/Date from the Format drop-down menu. See Section 17.11 "Time/Date Format Options" for more information on specifying your labels in Time and/or Date format.

• **Precision** (Float, Exponent, or Superscript only) - Enter the number of decimal places each number is to show.

• **Custom Set** (Custom only) - Enter the number of the set of custom labels. You define custom label sets as records in standard Tecplot 360 data files.

• **Show Decimal on Whole Numbers** - When this toggle is checked, whole numbers include a trailing decimal (that is, the number 2 is displayed as 2).

• **Remove Leading Zeros** - When this toggle is checked, leading zeros are removed from numbers (that is, .25 is displayed as .25).

• **Show Sign on Negative Numbers** - When this toggle is checked, negative numbers show the negative sign. When unchecked the negative sign will be removed (that is, -1.43 is displayed as 1.43). This is useful if you have specified a special prefix or suffix for negative values.

• **Prefix and Suffix** - You can specify a custom prefix and/or suffix for numbers in Tecplot 360 using the Prefix/Suffix text fields. Tecplot 360 allows you to specify separate prefixes and suffixes for zero values and negative values as well.

### 6 - 8 Polar Drawing Options

In the Polar Line plot type, a line between two points may be drawn in one of two ways: it may be drawn as a straight line between the two points, or it may be drawn as an interpolation of the Theta-R values. In the latter case, the connection between the two points is a smooth curve. By default, lines are drawn straight. This works for plots where the angular differences between consecutive points are small. Use the **Polar Drawing Options** dialog (accessed via the Plot menu) to adjust the drawing mode.

The **Polar Drawing Options** dialog has the following options:

• **Curved Lines (Theta-R Interpolation)** - The connection between two points is a curve. This may slow plotting speed for large datasets.
Tecplot 360 will stop drawing a line that involves too many revolutions around the circle. For example, if adjacent points have angle values of 0 degrees and then 36000 degrees, the plot would involve 100 complete revolutions around the origin. If this is the case, Tecplot 360 will draw only ten revolutions. If you need that many revolutions, create a new zone that has points interpolated in between the two points.

- **Straight Lines (X-Y Interpolation)** - The connection between two points is a straight line.
- **Angle to Approximate Curved Lines (deg)** - All arcs are drawn as a series of lines with the maximum angular difference specified in this field. This includes the axes, grid lines, and lines drawn in Curved Line mode.

The settings in the **Polar Drawing Options** dialog apply to all mappings in the frame.

The difference between the two Polar Line Drawing Modes is shown in **Figure 6-9**.

*Figure 6-9.* The Polar Drawing Modes: Curved lines are shown on the left and straight lines are shown on the right.
Field Plots

Field plots are 2D Cartesian or 3D Cartesian plots. The axes in a field plot are all independent variables. In Tecplot 360, field plots can be created using any combination of the following zone layers:

- Mesh Layer
- Contour Layer
- Vector Layer
- Scatter Layer
- Shade Layer
- Edge Layer

By default, 2D and 3D field plots are initially displayed with Mesh and Edge zone layers (Figure 7-1).

Figure 7-1. A 2D mesh and edge plot of sample file cylinder.plt. This file is located in your Tecplot 360 distribution under the examples/2D subdirectory.

3D field plots may be enhanced with lighting effects and translucency (see Chapter 13: “Translucency and Lighting”).

Field plots may also contain any combination of the following objects (which are derived from the values in the dataset):

- Iso-surfaces (3D ONLY)
- Slices (3D ONLY)
- Streamtraces
This chapter discusses the plot attributes that are common to all of the plot layers.

7 - 1 Field Plot Modification - Zone Style Dialog

Once you have loaded your data, you can modify your field plot attributes using the Zone Style dialog or the Quick Edit dialog. The Zone Style dialog is accessible via the [Zone Style] button in the Sidebar and the Plot menu.

Field plots containing transient data are modified slightly differently in the Zone Style dialog than static datasets. See Section 7 - 2 "Time Aware" for more information on working with transient datasets.

The following pages are available in the Zone Style dialog:

- **Mesh** - See Chapter 8: "Mesh Layer and Edge Layer".
- **Contour** - See Chapter 9: "Contour Layer".
- **Vector** - See Chapter 10: "Vector Layer".
- **Scatter** - See Chapter 11: "Scatter Layer".
- **Shade** - See Chapter 12: "Shade Layer".
- **Edge** - See Chapter 8: "Mesh Layer and Edge Layer".
- **Points** - See Section 7 - 1.1 "Points"
- **Surfaces** - See Section 7 - 1.2 "Surfaces".
- **Volume** - See Section 7 - 1.3 “Derived Volume Object Plotting” (3D only)
- **Effects Attributes** - See Chapter 13: “Translucency and Lighting”.

The following attributes in the Zone Style dialog are independent of the active plot layer:

- **Zone Num** - Use the [Zone Num] button above the zone list to select a zone or group of zones according to zone number. Choose from “Select One”, “Select Range”, or “Select All”. Strands are indicated by an “*” after their Zone Num. You can also select your zones from the list by using either [Ctrl]-click (to select one-by-one) or [Shift]-click (to select a range).
- **Zone Name** - Choose “Select by Name” from the [Zone Name] button to open the Enter Text String dialog. Enter a text string to select a zone or group of zones according to zone name. Strands are indicated by an “*” after their Zone Name. If none of the zones in the active strand are displayed at the current time step, the entire line is grayed-out. See also Section 7 - 2 “Time Aware”.

You may use regular expressions to select zones based on part of their name. In regular expressions, letters and numbers match themselves, but many punctuation characters have special meaning. Sequences you will often find in regular expressions include:*

<table>
<thead>
<tr>
<th>Character</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Matches 1 or more of the preceding character. For example, a+ means one or occurrences of the letter “a.”</td>
</tr>
<tr>
<td>*</td>
<td>Matches 0 or more of the preceding character. .* (dot-star) is the equivalent of * in filename wildcards.</td>
</tr>
<tr>
<td>?</td>
<td>Matches an optional character (that is, 0 or 1 occurrence).</td>
</tr>
</tbody>
</table>
Field Plot Modification - Zone Style Dialog

For more information on regular expressions, see [http://www.grymoire.com/Unix/Regular.html](http://www.grymoire.com/Unix/Regular.html).

<table>
<thead>
<tr>
<th>Character</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>^</td>
<td>Forces the expression to match only at the beginning of text: “wing” matches only zones that start with “wing.”</td>
</tr>
<tr>
<td>$</td>
<td>Forces the expression to match only at the end of text: “surface$” matches only zones that end with “surface.”</td>
</tr>
<tr>
<td>\</td>
<td>Forwards the next character to be interpreted as itself. For example, * matches a literal asterisk. If a character a special meaning in a regular expression and do not want that meaning to apply, precede the character with a backslash.</td>
</tr>
</tbody>
</table>

For transient data, the first zone of the strand applicable to the current time step is displayed in the Zone Name and Zone Number columns.

- **Group Num** - Use the [Group Num] button to select a zone or group of zones according to their group number. By default, all zones are assigned to group 1. You can change the group number by selecting “Edit Group Number” from the Group Num menu.
- **Zone Show** - By default, all zones are displayed. Turn zones or groups of zones on or off by selecting: Activate, Deactivate, Show Selected Only, or Invert from the Zone Show menu.

The remaining columns in the Zone Style dialog are dependent upon the active page are discussed in their corresponding sections.

Each page of the Zone Style dialog is divided into 2 regions (separated by a thick vertical line). Options located in the columns in the left-hand region apply universally to all active layers in the plot. Options located in the right-hand region of any page are specific to the corresponding plot layer.

### 7 - 1.1 Points

You may select the source for the data points used to plot vectors and scatter symbols from the Points page of the Zone Style dialog (shown below).
Figure 7.2 shows a plot where zone 1 is plotting scatter symbols only on one plane ($J=5$) and zone 2 is plotting all symbols.

![Figure 7.2: A plot showing two zones set to show only J-planes equal to five, with scatter symbols plotted on the surface in zone 1 and all symbols in zone 2. This file, field_plot_scatter_example.lpk, is located in your Tecplot 360 distribution under the examples/3D subdirectory.](image)

- **Points to Plot** - Select how the points are plotted:
  - **Nodes on Surfaces** - Draws only the nodes that are on the surface of the zone.
  - **All Nodes** - Draws all nodes in the zone.
  - **All Connected** - Draws all the nodes that are connected by the node map. Nodes without any connectivity are not drawn.
  - **Cell Centers Near Surfaces** - Draws points at the cell centers which are on or near the surface of the zone.
  - **All Cell Centers** - Draws points at all cell centers in the zone.

- **Index Skip** - Specify the skip intervals for the I, J, and K-indices. The menu options are as follows:
  - **No Skip** - Set the I, J, and K-skip intervals to one; plot all vectors.
  - **Enter Skip** - Specify I, J, and K-skip intervals on the Enter Index Skipping dialog.

For irregular and finite element data, only the I-Skip has an effect. I-skip will allow you to skip through nodes in the order they are listed in the data file.

### 7 - 1.2 Surfaces

There are many ways to divide volume data for plotting. One way to view volume data is to select surfaces from part of the data. In Tecplot 360 you may choose which surfaces to plot for volume zones from the
Surfaces page of the Zone Style dialog (accessed by double-clicking on a zone via the Sidebar, or via Plot>Zone Style).

The [Surfaces to Plot] button allows you to choose one of the following:

- **None** - None of the volume zone surfaces are plotted (edges still appear). This is the default Surfaces setting for your plot.
- **Boundary Cell Faces** - Plots all surfaces on the outside of the volume zone. This includes:
  - **IJK-ordered data** - The minimum and maximum I, J, and K-planes are plotted.
  - **Finite element volume data** - All faces that do not have a neighbor cell (according to the connectivity list) are plotted.

If blanking is turned on, the boundary cells in the blanked region will not be drawn and you will be able to see the interior of the volume zone. Figure 7-3 shows plots of a volume zone with Surfaces to Plot set to “Boundary Cell Faces”: without blanking, with value blanking, and with IJK-blanking. See Chapter 19: “Blanking” for information on working with Blanking.

![Figure 7-3. Boundary Cell Face plotting without blanking, with value-blanking, and with IJK-blanking. This file, field_plots_boundary_cell_faces_ex.lpk, is located in your Tecplot 360 distribution under the examples/3D subdirectory.](image)

- **Exposed Cell Faces (default)** - This setting is similar to the “Boundary Cell Faces” setting, unless value blanking is active. When value blanking is used, the outer cell faces between blanked and non-blanked cells and the outer surfaces of the data are drawn. Figure 7-4 shows
a plot of a volume zone with Surfaces to Plot set to “Exposed Cell Faces” with and without value blanking. See Chapter 19: “Blanking” for information on working with Blanking.

**Figure 7-4.** Examples of plots where **Surfaces to Plot** has been set to “Exposed Cell Faces” with (left) and without (right) value-blanking.

- **Planes Settings (I, J, K, IJ, JK, IK, and IJK-planes)** - Plots the appropriate combination of I, J, and/or K-planes. The planes are determined by the Range for each plane, which can be set using the [Range] buttons to the right of the [Surfaces to Plot] button. **These settings are available only for IJK-ordered data.** **Figure 7-5** shows a number of examples of plotting I, J, and K-planes.

**Figure 7-5.** Examples of plotting I, J, and K-planes.

- **Every Surface (Exhaustive)** - This setting will plot every face of every cell in volume data. It is not recommended for large datasets. Unless the surfaces are translucent, the plot will appear the same as the Exposed Cell Faces setting.
7 - 1.3 Derived Volume Object Plotting

The Volume page of the Zone Style dialog allows you to specify whether or not to show streamtraces, iso-surfaces, or slices for the selected zone(s). Figure 7-6 shows a plot with two zones where streamribbons and an iso-surface have been excluded from zone 2.

Figure 7-6. A plot where streamribbons and an iso-surface have been excluded from zone 2. This file, jetflow.plt is available in your Tecplot 360 distribution under the examples/3D_Volume subdirectory.

7 - 2 Time Aware

For transient datasets, you can use the Tecplot 360 interface to display your data at a given time or to animate your data over time. The zones loaded into Tecplot 360 can be linked to a specific solution time, and the active solution time is used to determine which zones are displayed.

For the following definitions, consider the following fictitious dataset:

<table>
<thead>
<tr>
<th>Zone</th>
<th>Time</th>
<th>StrandID</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>n/a</td>
<td>n/a</td>
</tr>
<tr>
<td>2</td>
<td>0.0</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>0.18</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>0.22</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>0.25</td>
<td>2</td>
</tr>
<tr>
<td>6</td>
<td>0.28</td>
<td>1</td>
</tr>
<tr>
<td>7</td>
<td>0.32</td>
<td>3</td>
</tr>
<tr>
<td>8</td>
<td>0.38</td>
<td>2</td>
</tr>
<tr>
<td>9</td>
<td>0.42</td>
<td>1</td>
</tr>
<tr>
<td>10</td>
<td>0.52</td>
<td>1</td>
</tr>
<tr>
<td>11</td>
<td>0.57</td>
<td>2</td>
</tr>
<tr>
<td>12</td>
<td>0.58</td>
<td>3</td>
</tr>
<tr>
<td>13</td>
<td>0.62</td>
<td>1</td>
</tr>
<tr>
<td>14</td>
<td>n/a</td>
<td>n/a</td>
</tr>
</tbody>
</table>
• **Transient zones** - Zones associated with time. The transient zone(s) displayed in the current frame are dependent upon the current solution time. Zones 2-13 in Table 7-1 are transient zones.

• **Static zones** - Zones not associated with time. They are displayed regardless of the current solution time. Zones 1 and 14 from Table 7-1 are static.

• **Current Solution Time** - The value that determines which transient zones are displayed in the current frame. The value of Current Solution Time is specified on the Settings page of the Time Details dialog (see Section 7 - 2.1 “Time Details Dialog - Settings Page”).

• **Strand** - A series of transient zones that represent the same part of a dataset at different times. Zones 2, 5, 8, and 11 in Table 7-1 all have the same StrandID and therefore, they are part of the same strand.

• **StrandID** - An integer value defined for each transient zone. The StrandID of a given zone is determined by the data loader.

Changes made in the Zone Style dialog to any zone in a given StrandID are propagated to all zones with that StrandID. See also Section 7 - 1 “Field Plot Modification - Zone Style Dialog”.

• **Relevant Zone** - Only “relevant zones” are plotted at a given solution time. A relevant zone is defined as a zone for a given strand used for a certain solution time. If the strand exists at solution time n, the relevant zone is either the transient zone on that strand defined explicitly at solution time n, or the zone defined immediately prior to solution time n. If the strand does not exist at solution time n, there are no relevant zones for that strand at that time. Static zones are always considered relevant. Refer to Figure 7-7.

![Figure 7-7](image)

Figure 7-7. An illustration of how relevant zones are determined (based on the data in Table 7-1). For a given solution time, the relevant zones ONLY are displayed in the plot. NOTE: static zones are always considered relevant zones.

- **t = .2s** - The red-colored transient zones and both static zones are plotted. NOTE: no zones from the first strand are represented because the strand is not defined at that time.

- **t = .4s** - The green-colored transient zones and both static zones are plotted.

- **t = .6s** - The blue-colored transient zones and both static zones are plotted. NOTE: no zones from the second and third strands are represented because the strands are not defined at that time.
Data Point and Cell Labels

7 - 2.1 Time Details Dialog - Settings Page

Use the Settings page of the Time Details dialog to change the Current Solution Time of the plot. The Time Details dialog can be accessed via the Plot menu or by selecting the Details [...] button next to “Time” in the Sidebar. The page has the following options:

- **Solution Time** - Use the slider or spin control to interactively change the Current Solution Time.
- **Min** - Displays the minimum solution time in the data.
- **Max** - Displays the maximum solution time in the data.

7 - 2.2 Time Details Dialog - Animate Page

See Section 31 - 1.1 “Time Animation”.

7 - 3 Data Point and Cell Labels

**Field Plots** - You can label all or some of the data points or nodes in your field plots with either the index value(s) of the data point or the value of some specified variable at each point. You can also label each cell or element of the data with its index (which for finite element data is its element number).

**Line Plots** - You can label all or some of the data points or nodes in your line plots with either the index of the data point, the value of the dependent variable at the point, or both the values (X&Y or Theta & R) for the data point. For example, Figure 7-8 shows an XY Line plot with each data point labeled with its X-Y value pair.
To add data labels to your plot, go to Plot>Label Points and Cells dialog (accessed via the Plot menu). The Label Points and Cells dialog has the following options:

- **Show Node Labels** - Toggle-on to show node labels. Select either Index Value or Variable Value.
- **Show Cell Labels** - Toggle-on to show cell labels. Select either Index Value or Variable Value.
- **Index Skip** - If labeling by index values, select an index skip.
- **Color Text by Zone/Map** - For line plots, the color is set on the Symbols page of the Mapping Style dialog. For field plots, the color is set on the Scatter page of the Zone Style dialog.
- **Include Text box** - Toggle-on “Include Text Box” to include a box around each label.

### 7 - 3.1 Two-dimensional Plotting Order

In 2D plots, by default, each zone layer is drawn for all zones before the next layer is drawn. To plot the data zone-by-zone instead of layer-by-layer (default), toggle-on “By Zone” in the Plot>2D Draw Order dialog box.

### 7 - 4 Three-dimensional Plot Control

You can view any type of data as a 3D plot by selecting 3D Cartesian from the plot type drop-down menu in the Sidebar. By default, only IJK-ordered data and finite element volume data are displayed in 3D. Three-dimensional plots can be manipulated with the following controls that can be accessed via the Plot menu:

- **Reset 3D Axes** - Reset the 3D axis sizes and the 3D origin of rotation.
- **Three-dimensional Axis Limits** - Control the data and axis aspect ratios for 3D plotting.
- **Three-dimensional Orientation Axis** - Control the optional 3D orientation axis, which displays the current orientation of the three axes in the workspace.
Three-dimensional Plot Control

- **Light Source** - Control the light source position, as well as the intensity of the light, the background light, and the surface color contrast. See Section 13 - 3 “Three-dimensional Light Source” for more details.
- **Advanced 3D Control** - Specify the default lift fraction for 3D lines, symbols, and tangent vectors, as well as the 3D sorting algorithm for the plot.

The following controls can be accessed via the View menu.

- **The Rotate Dialog** - Control the 3D orientation of the plot.
- **Three-dimensional View Details** - Set the specifications for parameters affecting the 3D display of your plot, including the perspective, field of view, angular orientation of the plot, and view distance.

7 - 4.1 Reset 3D Axes

By default, the 3D axes are calculated to fit the data. If you alter your data to expand or contract the overall data size, the axes will not automatically adjust to the new size. Use the Reset 3D Axes option (accessed via the Plot menu) to reset the axes to fit the data.

The Reset 3D Axes option also resets the 3D origin. If you have modified your 3D origin using the 3D Rotate dialog (see Section 7 - 4.5 “The Rotate Dialog” for details), the Reset 3D Axes option will reset it to approximately the centroid of the data.

7 - 4.2 Three-dimensional Axis Limits

In a 3D plot, whenever you read a data file, manipulate the values of variables assigned to the axes, or change variables assigned to the axes, Tecplot 360 examines the data and determines how to plot it. The data may require scaling in one or more axis directions, a change of the axis dependency, an adjustment of the space between the data and the axis box, and/or an adjustment of the shape of the axis box.

Because there are many valid forms in which the data could be plotted, by using the 3D Axis Limits dialog (accessed via the Plot menu), you can input information to help Tecplot 360 determine how to automatically configure the plot the way you want.

- **Aspect Ratio** - Ratio of the range of the variable assigned to one axis (multiplied by the axis size factor) and the range of the variable assigned to another axis (multiplied by the axis size factor).

- **Data Aspect Ratio Limit** - When the data aspect ratio of any two axes exceeds the Data Aspect Ratio Limit, Tecplot 360 automatically rescales the longer axis so that the new data aspect ratio is equal to the Data Aspect Ratio Reset value.
If your plots are usually unscaled (such as plots of real physical objects), you should set the data aspect ratio maximum to a large number like 30. Use a smaller number for evenly scaled axes.

- **Axes Aspect Ratio Limit** - Works similarly to the Data Aspect Ratio Limit, except Axes Aspect Ratio Limit attends to the shape and size of the axes box.

### 7 - 4.3 Three-dimensional Orientation Axis

The 3D orientation axis is a representation of your axes that immediately shows you the orientation. By default, all 3D plots show the 3D orientation axis in the upper right of the frame. Using the **3D Orientation Axis** dialog under the **Plot** menu, you can control whether the 3D orientation axis is shown in your plot, and if so, its color, size, line thickness, and the position of the axis origin. You can also position the 3D orientation axis by simply clicking on it and dragging the axis to the desired location in the frame.

### 7 - 4.4 Advanced 3D Control

- **Lift Fractions** - The lift fraction is the fraction of the distance from the 3D origin of the object to your eye. If you specify lift fractions for 3D lines, tangent vectors, or scatter symbols, plotted objects of the appropriate type are lifted slightly towards you so that they lie on top of surface elements.

- **Perform Extra 3D Sorting** - For some 3D plots (i.e. plots with translucency), Tecplot 360 uses a painter’s algorithm. A quick sorting algorithm is used by default. The data objects are divided into smaller objects. The smallest object is usually a cell, finite element, vector, or scatter symbol. These objects are sorted based upon the distance from viewer, starting with the objects farthest from the viewer and working forward. This does not detect problems such as intersecting objects. If the “Perform Extra 3D Sorting” check box is selected, a slower, more accurate approach is used to detect problems for you.

There are instances when Tecplot 360 cannot sort correctly. For example, consider elements A, B, and C, where element A overlaps part of element B which overlaps part of element C which overlaps part of element A. Since Tecplot 360 draws only whole elements, one of these elements will be drawn last and each will cover (incorrectly) a portion of another element. If this occurs while printing or exporting, choosing an image format will often resolve the problem.

All of the settings in the **Advanced 3D Control** dialog are specific to the current frame.
Three-dimensional Plot Control

7 - 4.5 The Rotate Dialog

You may rotate your plots using the 3D Rotate dialog under the View menu. The 3D rotation tools located in the toolbar are discussed in Section “Three-dimensional Rotation” on page 23.

The Rotate dialog has the following options:

- **Rotation Mode**
  - XYZ-Axis: Rotation about one of the three axes: X, Y, or Z. To move around any of these axes, use the controls in this dialog. Click on the “+” (up) or “-” (down) arrows on either side of the axis that you want to rotate the plot around.
  - Spherical: Spherical rotation about the Z axis. There are four arrows in a cross: “+” (up) and “-” (down) are the vertical, top and bottom arrows of the cross; Right and Left are the horizontal, right and left arrows of the cross. There are also two twist arrows diagonal to the cross that twist about the Eye/Origin ray: one that does a twist up to the left and one that does a twist over to the right.
    - To tilt the plot in a vertical, spherical manner around the Z-axis, click the vertical “+” (up/top) or “-” (down/bottom) arrows. To rotate the plot in a horizontal, spherical manner around the Z-axis, click on the horizontal “+” (Right) or “-” (Left) arrows. To twist the plot about the Eye/Origin ray, click on the twist up to left or twist over right diagonal arrows.
  - RollerBall: Rotation like a roller ball, that is, horizontal movements are right and left from the current position; vertical movements rotate up or down from the current position; and twist is about the current screen Eye/Origin ray.

---

185
To tilt the plot in a vertical manner in respect to current screen orientation, click and hold on the vertical "+" (up/top) or "-" (down/bottom) arrows. To rotate the plot in a horizontal manner in respect to current screen orientation, click and hold on the horizontal "+" (right) or "-" (left) arrows. To twist the plot about the current screen Eye/Origin ray, click and hold on the twist up to the left or twist over to the right diagonal arrows.

- **Rotation Step Size (deg)** - Determines the amount of rotation per click on rotation buttons. To change the step size, either enter a new value between 0.001 and 180 in the text field, or select one of the following default values from the drop-down: 1, 5, 15. These default values are set and modified in the Step Size column in the **Size Preferences** dialog (accessed via File>Preferences>Sizes).

- **Center of Rotation**
  - **X** - Rotation of the eye/origin ray about the X-axis. Enter a value in the text field, or use the increase or decrease arrows at the right to specify a value.
  - **Y** - Rotation of the eye/origin ray about the Y-axis. Enter a value in the text field, or use the increase or decrease arrows at the right to specify a value.
  - **Z** - Rotation of the eye/origin ray about the Z-axis. Enter a value in the text field, or use the increase or decrease arrows at the right to specify a value.

- **Reset Center of Rotation** - Use this drop-down to set the center of rotation to be the Center of Data (the center of the bounding box of the data) or Center of View (the point hit by a probe at frame coordinates 50%, 50%).

Center of View can result in an error if there is no data in the center of the frame. If this is the case, the center of rotation will not move.

- **Plot Orientation** - Eye origin view. The angular orientation of the plot is defined by three spherical rotation angles:
  - **y (Psi)** - Tilt of eye origin ray away from Z-axis. (Range -720 to 720.)
  - **q (Theta)** - Rotation of the eye origin ray about the Z-axis. (Range -720 to 720.)
  - **a (Alpha)** - Twist about the eye origin ray. (Range -720 to 720.)

The eye origin ray is a line from the origin of the 3D object to your eye. The eye origin ray is perpendicular to the plane of the computer screen. These angles define a unique view. These angles are shown in **Figure 7-9**.

![Figure 7-9. 3D angles and 3D projection.](image)

- **Preset Views** - Specify one of three pre-defined orientations: the XY-Plane, the YZ-Plane, the XZ-Plane; or a default orientation with a Psi=60, Theta=225, and Alpha=0. (Psi=60, Theta=225, and Alpha=0).

186
**Three-dimensional Plot Control**

**Rotate About the Viewer Position**

In addition to the rotation capabilities described above, you may also use the [Alt] key and mouse to rotate about the viewer (instead of rotating the object). Although you may use this feature while in orthographic projection, it is best suited for when perspective projection is being used. The [Alt] key and your middle mouse button may be used to simulate fly-through type motion. You may move closer to the object using the [Alt] key and middle mouse button, then turn your head using the [Alt] key and left mouse button.

**7 - 4.6 Three-dimensional View Details**

Use the 3D View Details dialog (accessed via the View menu) to control a variety of parameters affecting the display of 3D plots.

- **Use Perspective** - Sets Tecplot 360's projection type. If selected, Tecplot 360 draws the current frame with perspective projection. If not selected, Tecplot 360 draws the current frame with orthographic projection. (Range is 0.1 to 179.9.)

- **Field of View (deg)** - Sets the amount of the plot (in terms of spherical arc) in front of the viewer that may be seen. Zooming in or out of a 3D perspective plot changes this number and the viewer’s position.

- **Maintain Object Size During Field of View Changes** - If selected, Field of View changes result in the viewer’s position being moved so that approximately the same amount of the plane is visible after the change. If not selected, Field of View changes do not change the viewer’s position and result in the entire plot appearing to grow or shrink.

- **View Width** - Sets the amount of the plot (in X-axis units) in front of the viewer that may be seen. Zooming in or out of a 3D orthographic plot changes this number, but not the viewer’s position.

- **Viewer Position** - Change the viewer’s relation to the image by resetting the X, Y, or Z-location, or by changing the view distance.

---

1. With orthographic projection, the shape of the objects is independent of distance. This is sometimes an "unrealistic" view, but it is often used for displaying physical objects when preserving the true lengths is important (such as drafting).
Three-Dimensional Zooming and Translating

Just as in all other plots, you may zoom and translate your plot using the mouse. This may be done using either the Zoom or Translate tools. For most tools, you may also use your middle and right mouse buttons (or [Ctrl]+right mouse button) to zoom and translate.

When the plot projection is orthographic, zooming with the middle mouse button magnifies the plot. When the plot projection is perspective, zooming with the middle mouse button changes the viewer angle, making the plot appear larger or smaller. If you want to change the viewer’s position by moving closer to or further away from an object, hold the [Alt] key down while using the middle mouse button.

Working with very large datasets may result in slow zooming, rotating, and translating. See Section 32 - 3 “Performance Dialog” for further information on plot approximation if zoom, rotate, or translate performance is poor.
Mesh Layer and Edge Layer

When working with two or three-dimensional field plots, Tecplot 360 allows you to interactively add or subtract any combination of plot layers. These layers can be applied to any set of zones in the active data set. This chapter discusses the Mesh Layer and the Edge Layer.

8 - 1 Mesh Layer

Toggle-on “Mesh” in the Sidebar to add a mesh layer to your plot. The mesh plot layer displays the lines connecting neighboring data points within a zone. For I-ordered data, the mesh is a single line connecting all of the points in order of increasing I-index. For II-ordered data, the mesh consists of two families of lines connecting adjacent data points of increasing I-index and increasing J-index. For IJK-ordered data, the mesh consists of three families of lines, one connecting points of increasing I-index, one connecting points of increasing J-index, and one connecting points of increasing K-index. For finite element zones, the mesh is a plot of every edge of all of the elements that are defined by the connectivity list for the node points. See Chapter 3: “Data Structure” for an in-depth description of ordered (IJK) and finite element data structures.

8 - 1.1 Mesh Layer Modification

Once you have loaded your data, you can modify your mesh plot attributes using either the Mesh page of the Zone Style dialog (accessed via the Sidebar or Plot Zone Style) or the Quick Edit dialog. As discussed in Section 7 - 1 “Field Plot Modification - Zone Style Dialog”, the changes made using the first four columns to the left of the black line apply to the entire plot, while changes from the columns to the right of the divider apply to the active plot layer.

In order for the changes made on the Mesh page to be visible in your plot, the Mesh layer must be turned on. You can turn on the Mesh layer by any of three methods: by toggling-on the Mesh layer in the Sidebar, by using the Quick Edit dialog, or by selecting “Yes” from the [Mesh Show] button drop-down menu on the Mesh page of the Zone Style dialog. The first time you activate this layer by either the Zone Style dialog or the Quick Edit dialog, a confirmation dialog will appear to confirm whether you wish to activate the Mesh layer.
8 - 1.2 Mesh Layer Types

Tecplot 360 has three distinct mesh types:

- **Wire Frame** - Wire frame meshes are drawn below any other zone layers on the same zone. In 3D Cartesian plots, no hidden lines are removed. For 3D volume zones (finite element volume or IJK-ordered), the full 3D mesh (consisting of all the connecting lines between data points) is not generally drawn because the sheer number of lines would make it confusing. The mesh drawn will depend upon your choice of “Surfaces to Plot” on the Surfaces page of the Zone Style dialog. See Section 7 - 1.2 “Surfaces” for further details. By default, only the mesh on exposed cell faces is shown.

- **Overlay** - Similar to Wire Frame, mesh lines are drawn over all other zone layers except for vectors and scatter symbols. In 3D Cartesian plots, the area behind the cells of the plot is still visible (unless another plot type such as contour flooding prevents this). As with Wire Frame, the visibility of the mesh is dependent upon your choice of “Surfaces to Plot” on the Surfaces page of the Zone Style dialog. See Section 7 - 1.2 “Surfaces” for further details.

- **Hidden Line** - Similar to Overlay, except hidden lines are removed from behind the mesh. In effect, the cells (elements) of the mesh are opaque. Surfaces and lines that are hidden behind another surface are removed from the plot. For 3D volume zones, using this plot type obscures everything inside the zone. If you choose this option for 3D volume zones, then choosing to plot every surface (using the Surfaces page of the Zone Style dialog) has the same effect as plotting only exposed cell faces, but is much slower.

The opaque surfaces created by Hidden Line are not affected by the Lighting Zone effect (there is no light source shading). However, it is affected by translucency.
Figure 8-10 shows the available mesh plot types, along with the effects of choosing Overlay and Wire Frame in combination with contour flooding.

Figure 8-10. Mesh plot types. This file, spaceship.lpk, is located in your Tecplot 360 distribution under the examples/3D subdirectory. To view the mesh layer, toggle-off Contour in the Sidebar, and toggle-on Mesh.

8 - 2 **Edge Layer**

An edge plot layer displays the connections of the outer lines (IJ-ordered zones), finite element surface zones, or planes (IJK-ordered zones). The Edge layer allows you to display the edges (creases and borders) of your data. Zone edges exist only for ordered zones or 2D finite element zones.

Three-dimensional finite element zones do not have boundaries, although you may use the Extract FE Boundary dialog to create a zone that is the outer boundary or surface of a finite element zone. See Section "Boundary Extraction of Finite Element Zones" on page 329 for details.
8 - 2.1 Edge Layer Modification

You can control any of the following attributes from the Edge page of the Zone Style dialog:

- **Show Edges** - Whether the edges are visible for each active zone.
- **Edge Type** - Borders and/or creases. See Section 8 - 2.2 “Edge Type” below.
- **I, J, or K-index Border** - Select whether to show the corresponding index border: None, Min, Max, or Both (Min and Max).
- **Edge Color** - The edge color.
- **Line Thick** - The edge line thickness.

8 - 2.2 Edge Type

There are two types of edges in Tecplot 360: creases and borders. An edge border is the boundary of a zone. An edge crease appears when the inside angle between two cells is less than a user-defined limit. The inside angle can range from 0-180 degrees (where 180 degrees indicates coplanar surfaces). The default inside angle for determining an edge crease is 135 degrees. You can change the crease angle by going to **Plot>Edge Details**.

You can change the Edge Type using the Edge Type column on the Edge page of the Zone Style dialog.

8 - 2.3 Edge Display

For IJ-ordered zones, the available edges are the lines I=1, I=IMax, J=1, and J=JMax.

When the Surfaces to Plot option is set to “Boundary Cell Faces”, “Exposed Cell Faces”, or “Every Surface” for IJK-ordered zones, the edges of the surface areas form a “box” that contains the data. Surfaces to Plot can be set on the Surfaces page of the Zone Style dialog.

When the Surfaces to Plot option is set to one of the planes options, such as I, J, or K-planes, for IJK-ordered zones the edges are the edges of each plane (I, J, or K-plane). By default, all available edges are drawn when the Edge layer is active. You can specify which of the available edges are plotted using either the Zone Style dialog or the Quick Edit dialog.
Contour Layer

Contour plots can be used to show the variation of one variable across the data field. To add a contour layer to your plot, toggle-on “Contour” in the Sidebar.

Contour plots can only be plotted with organized data, such as IJ-ordered, IJK-ordered, or FE-data. Refer to Section 3 - 6 “Working with Unorganized Datasets” for information on organizing your dataset.

Additional options can be set on the Contour Details Dialog (accessed via the Details [...] button to the right of Contour in the Sidebar or Plot>Contour/Multi-Coloring) and the Contour page of the Zone Style dialog.

An example of each contour plot type is shown in Figure 9-11.

Contour plots for streamtraces, iso-surfaces, and slices are controlled by their respective details dialogs and are not discussed here. (Refer to Section 15 - 1.3 “Rod/Ribbon Page”, Section 16 - 3 “Iso-Surface Style” and Section 14 - 1.4 “Contour Page”, respectively.)
9 - 1 Contour Layer Modification

You can modify the attributes of your contour plot using either the Contour page of the Zone Style dialog or the Quick Edit dialog. You can control any of the following attributes from the Contour page of the Zone Style dialog.

- **Contour Show** - Select whether or not to show the contour for the highlighted zone(s).
- **Contour Type** - Tecplot 360 allows you to create contour plots of five different types:
  - **Lines** - Draws lines of constant value of the specified contour variable.
  - **Flood** - Floods regions between contour lines with colors from the global color map. The distribution of colors used for contour flooding may be banded or continuous. When banded distribution is used for flooding, a solid color is used between contour levels. If continuous color distribution is used, the flood color will vary linearly in all directions. See “Color Distribution Methods” on page 198 for details regarding Tecplot 360’s color distribution methods.
  - **Both Lines and Flood** - Combines the above two options.
  - **Average Cell** - Floods cells or finite elements with colors from the global color map according to the average value of the contour variable over the data points bounding the cell. If the variables are located at the nodes, the values at the nodes are averaged. If the variables are cell-centered, the cell-centered values are averaged to the nodes and the nodes are then averaged.
  - **Primary Value** - Floods cells or finite elements with colors from the global color map according to the primary value of the contour variable for each cell. If the variable is cell centered, the primary value is the value assigned to the cell. If the variable is node located, the primary value comes from the lowest index node in the cell.

In order for the changes made on the Contour page to be visible in your plot, the Contour layer must be turned on. You can turn on the Contour layer by any of three methods: by toggling on the Contour layer in the Sidebar, by using the Quick Edit dialog, or by selecting “Yes” from the [Cont Show] button drop-down menu on the Contour page of the Zone Style dialog. The first time you activate this layer by either the Zone Style dialog or the Quick Edit dialog, a confirmation dialog will appear to confirm whether you wish to activate the Contour layer.
If the variables are located at the nodes, the value of the lowest indexed node in the cell is used. When plotting IJK-ordered, FE-brick or FE-tetra cells, each face is considered independently of the other faces. You may get different colors on the different faces of the same cell.

If the variables are cell-centered, the cell-centered value is used directly. When plotting I, J, or K-planes in 3D, the cell on the positive side of the plane supplies the value, except in the case of the last plane, where the cell on the negative side supplies the value.

Go to Data - Data Set Info to determine whether the variables are nodal or cell-centered.

- **Flood By** - Select either a contour group (C1, C2, C3, C4, C5, C6, C7, or C8) or assign variables to the RGB color map. See Section 9 - 2.1 “Contour Groups” and Section 5 - 5.2 “RGB Coloring” for more information.
- **Lines By** - Select which contour group identifies the contour lines (applicable only when the contour type is ‘lines’ or ‘both lines and flood’).
- **Use Lighting** (3D only) - Turn on or off the lighting effects. See Chapter 13: “Translucency and Lighting” for more information on lighting effects.

Options such as contour labels, contour legends, and special settings for contour bands or contour lines are set by the selected contour group (see Section 9 - 2.1 “Contour Groups”). The color map is set globally (see Section 5 - 5.1 “Global Color Map”).

### 9 - 2 Contour Details Dialog

Use the Contour Details dialog to specify:

- **Contour Groups**
- **Contour Levels**
- **Contour Coloring**
- **Contour Bands**
- **Contour Lines**
- **Contour Labels**
- **Contour Legend**

### 9 - 2.1 Contour Groups

The Contour Details dialog in its condensed form is shown in Figure 9-12.

![Contour Details Dialog](image)

Figure 9-12. The Contour Details dialog in its condensed form.

- **1, 2, 3, 4, 5, 6, 7, 8** - Use the [1], [2], [3], [4], [5], [6], [7], and [8] buttons to specify attributes for a specific contour group. Each contour group has its own settings for the contour attributes established in the Contour Details dialog.
- **Var** - Assign a variable from your dataset to the active Contour Group (1, 2, 3, 4, 5, 6, 7, or 8).

The Contour Group Variables (1-8) can be used to color contour, mesh, scatter, or vector zone layers, as specified in the Select Color dialog and the [Flood By] and [Lines By] buttons on the Contour page of the Zone Style dialog.
9 - 2.2 Contour Levels

A contour level is a value at which contour lines are drawn, or for banded contour flooding, the border between different colors of flooding. Adjust contour levels using the Levels page of the Contour Details dialog (accessed via the Sidebar or the Plot menu).

From the Levels page of the dialog, you can add, subtract, and rearrange contour levels.

**Contour Level Addition**

You can add new levels in any of three ways:

- Add a new range of contour levels to the existing set by selecting [Add Levels] on the Levels page of the Contour Details dialog, then using the Enter Contour Level Range dialog as described in Section “New Contour Level Specification” on page 197.
- Enter a value in the Level To Add text field in the Levels page of the Contour Details dialog and then select [Add Level] to propagate it to the Levels list on the left.
- Choose \( \text{Add Level} \) from the Toolbar, then click at any location in the contour plot where you would like to add a new contour level. Tecplot 360 adds a new contour level that goes through the specified point. By holding down the mouse button you can drag and interactively position the new contour level until you release the button.

**Contour Level Removal**

You can remove contour levels by:

- Selecting one or more contour levels on the Levels page of the Contour Details dialog, then selecting [Remove Selected Levels].
• Selecting \( \text{Contour Line} \) from the Toolbar, then select any contour line in your contour plot. Tecplot 360 deletes the specified contour level, or the nearest contour level to the specified point.

Contour Level Adjustment
You can interactively adjust a contour level with the \( \text{Contour Line} \) tool from the Toolbar. Hold down the CTRL key, then click-and-drag the contour level you want to adjust. Move the contour to the desired location and release the mouse button. The new value of the contour level can be viewed on the Levels page of the Contour Details dialog.

New Contour Level Specification
You may specify a new set of contour levels via the [Reset Levels] or [New Levels] options on Levels page of the Contour Details dialog. The Reset Levels dialog asks you to supply an approximate number of levels to use, and Tecplot 360 will estimate a starting point, an end point, and the spacing between contour levels.

If you want more control over the exact values generated for contour levels, select [New Levels]. This calls up the Enter Contour Level Range dialog.

You can specify the range and number of levels in any of three ways:

- Min, Max, and Number of Levels (default) - Enter a minimum and maximum level value, together with the number of levels to be distributed equally throughout the range.
- Min, Max, and Delta - Enter a minimum and maximum level value together with a delta (step-size between levels).
- Exponential Distribution - Enter a minimum and maximum level value together with the number of levels to be distributed exponentially throughout the range.
9 - 2.3 Contour Coloring

Although the color map is global (affecting all frames), there are some adjustments you can make that apply only to a contour group in the active frame by using the Coloring page of the Contour Details dialog.

Use Color Map - Select the color map group to use for contour coloring. The option is sensitive when “Link All Color Maps Together” is inactive in the Color Map dialog (accessed via Options>Color Map or the Details [...] button to the right of the Use Color Map drop-down menu). See Section 5 - 5.1 “Global Color Map” for more information on color map groups.

• Color Distribution Methods
  • Banded - A solid color is assigned for all values within the band between two levels. (See Section 9 - 2.4 “Contour Bands”)
  • Continuous - The color distribution assigns linearly varying colors to all multi-colored objects or contour flooded regions. You can vary the default assignment of colors by entering a “Min” or “Max” value for Color Map Endpoints.
  • Use Approximate Continuous Flooding - Causes each cell to be flooded using interpolation between the RGB values at each node. When the transition from a color at one node to another node crosses over the boundary between control points in the color spectrum, approximate flooding may produce colors not in the spectrum. Leaving this option unchecked is slower, but more accurate.

• Color Cutoff - Lets you specify a range within which contour flooding and multi-colored objects (such as scatter symbols) are displayed.

• Color Map Adjustments
Contour Details Dialog

- **Reversed Color Map** - You can reverse the color map by toggling on “Reverse”. Two plots, one with the color map going in the default direction and one with the color map reversed, are shown in Figure 9-13.

![Figure 9-13. Sample contour plots created using demo file cylinder.plt. This file is located in your Tecplot 360 distribution under the examples/2D subdirectory. A) Flooded contour plot with default settings. B) Flooded contour plot with a reversed colormap.](image)

- **Color Map Cycles** - You may choose to cycle the color map. This is useful if you have data where there is a great deal of activity in multiple ranges of the contour variable, and you want to cycle through all colors in each region. A plot with the color map cycled twice is shown in Figure 9-14.

![Figure 9-14. Sample contour plots created using demo file cylinder.plt. A) Flooded contour plot with default settings. B) Flooded contour plot with the color map cycled two times.](image)

9 - 2.4 Contour Bands

When Coloring Distribution for a group is set to “Banded” (via the Colors page of the Contour Details
dialog), you may customize the color bands on the Bands page of the dialog.

The Bands page of the Contour Details dialog has the following options:

- **Include Zebra Shading** - This effect colors every other band with a specific color (or no color at all).
- **Override Band Colors** - Specific contour bands can be assigned a unique basic color. This is useful for forcing a particular region to use blue, for example, to designate an area of water. You can define up to 16 color overrides.
9 - 2.5 Contour Lines

The contour line settings determine how contour lines are drawn for all zones in the active frame's dataset. The settings are established on the Lines page of the Contour Details dialog.

- Use Zone Line Pattern - For each zone, draw the contour lines using the line pattern and pattern length specified in the Contour page of the Zone Style dialog.
- Skip to Solid - Draw \( n \) dashed lines between each pair of solid lines, where \( n \) is an integer you enter in the text field Number of Dashed Lines to Draw between Solid Lines.
- Dashed Negative Lines - Draw lines of positive contour variable value as solid lines and lines of negative contour variable value as dashed lines.

9 - 2.6 Contour Labels

Contour labels are labels that identify particular contour levels either by number or by value. You can place contour labels interactively, or have Tecplot 360 create them for you automatically. You can also have Tecplot 360 create and save a set of contour labels automatically, then interactively add contour labels to this saved set.

The contour plot type must be lines or lines and flood in order to use Contour labels.
Customize contour labels with the Labels page of the Contour Details dialog (accessible from the Plot menu or the Sidebar), and with the Add Contour Label mouse mode tool from the Toolbar.

To add contour labels to your plot, you can use the Add Contour Label tool from the toolbar (see Section “Add Contour Labels” on page 26) or the Labels page of the Contour Details dialog.

You can modify the following options using the Labels page of the Contour Details dialog.

- **Show Labels** - Toggle-on “Show Labels” to include contour labels in your plot. You can label the contour levels by selecting either:
  - **Use Contour Number**
  - **Use Contour Value**

- **Number Format** - Use the [Number Format] button to specify the number formatting of the Contour labels. See Section 6 - 7.1 “Specify Number Format” for more details.

- **Label Format** - Use the midsection of the dialog to customize label color, font, and fill settings. (See Section 18 - 1.2 “Font Folders and Fallback” for more information on how fonts work with Tecplot 360.)

- **Generate Automatic Labels (with each Redraw)** - At each Redraw, Tecplot 360 creates a new set of contour labels. At any time, you can deselect the “Generate Automatic Labels” (with each Redraw) check box, and Tecplot 360 retains the last set of labels generated.

- **Align Labels with Contour Line** - Use the Spacing field to specify the spacing of the contour labels along the contour line, as a percentage of the frame. Use the Level Skip field to specify a skip value between the contour levels to be labeled.

- **Align Next User-Positioned Label** - If the “Align Next User-Positioned Label” is selected, the next label is aligned with the contour line. Otherwise, the label is written with normal, upright text.

- **Clear All Contour Labels** - When “Generate Automatic Labels” is deselected, you can select [Clear All Contour Labels] to erase the current set of contour labels.
9 - 2.7 Contour Legend

To include a contour legend, select the Legend page of the Contour Details dialog for the appropriate contour group.

The following options are available:

- **Show Contour Legend** - Select this option to show the contour legend on your plot.
- **Show Header** - Includes the name of the contour variable.
- **Separate Color Bands** - Select this check box to separate the color bands in the legend with black lines. Use this option to visually separate similar colors. If this box is not selected, similar adjacent colors may tend to blur together.
- **Alignment** - Select Vertical or Horizontal.
- **Position** - X (%) and Y (%) as percentages of the frame width and height. (You can also move the legend interactively.)
- **Anchor** - Specify which part of the legend is anchored in the selected position using the Anchor Alignment dialog.
- **Label Placement** - If you have selected “Continuous Color Distribution” on the Coloring page of the Contour Details dialog, you have three options for placement of labels on the legend:
  - **Label at Contour Levels** - This option places one label for each contour level. See Section 9 - 2.2 “Contour Levels”.
  - **Label at Specified Increment** - Enter a value in the Increment text field when selected.
  - **Label at Color Map Divisions** - Places one label for each control point on the global color map. See Section 5 - 5.1 “Global Color Map”.
- **Resize Automatically** - Automatically skips some levels to create a reasonably sized legend.
- **Include Cutoff Levels** - Color bands and labels for levels affected by Color Cutoff are shown in the legend.
- **Level Skip** - Enter the number of levels between numbers on the legend. This also affects the number of levels between contour labels on the plot. Skipping levels on the contour legend compresses the color bar (if one appears); it does not change the spacing between text entries on the legend.
• **Line Spacing** - Enter the spacing between contour legend numbers. This does not change the number of entries in the legend, so a large value here creates a large legend. Use Level Skip to reduce the number of entries in the legend.

• **Header Format** - Adjust the font and height for the legend header or the legend labels. (See Section 18-12 "Font Folders and Fallback" for more information on how fonts work with Tecplot 360.)

• **Color** - Affects the color of all text in the legend.

• **Number Format** - Adjust the font and format of numbers in the legend. See Section 6-7.1 "Specify Number Format" for more details on numeric formatting and see Section 18-1.2 "Font Folders and Fallback" for more information on how fonts work with Tecplot 360.

• **Legend Box (No Box, Filled, Plain)** - If you choose Filled or Plain, format the box using the following controls:
  - **Line Thickness** - Specify the line thickness as a percentage of frame height.
  - **Box Color** - Choose a color for the legend box outline.
  - **Fill Color (Filled only)** - Choose a color for the legend box fill.
  - **Margin** - Specify the margin between the legend text and legend box as a percentage of the text height.

**Anchor Alignment**

Available through the Legend page of the Contour Details dialog, the Anchor Alignment dialog allows you to specify the anchor point, or fixed point, of the object. As the box grows or shrinks, the anchor location is fixed while the rest of the box adjusts to accommodate the new size. There are nine possible anchor points, corresponding to the left, right, and center positions on the headline, midline, and baseline of the box.

![Anchor Alignment dialog](image)

**9 - 3 Extract Contour Lines**

Go to **Data > Extract > Contour Lines** to extract plotted contour lines as zones. Your data will be altered by the creation and naming of new zones.

![Extract Contour Lines dialog](image)
Using the Extract Contour Lines dialog, you have the following options:

- **Create a separate zone for each contour level** - A new zone will be created for each contour line plotted. The number of new zones will equal the number of contour levels. The created zones are FE-line segment type zones.

- **Create a separate zone for each independent line segment in each zone** - With this option you may create many more zones than there are contour levels. New I-ordered line segment zones are created in each source zone for each topologically independent contour line.

After generating the zones, we recommend you use the Mesh Layer when plotting the new zones.
Vector Layer

You can create vector plots by activating the Vector layer in the Tecplot 360 Sidebar, and specifying the vector component variables. Vector plot attributes can be modified using the Vector page of the Zone Style dialog.

Figure 10-15. A vector plot of the cylinder data (with the edge layer also active). This file, cylinder.plt, is located in your Tecplot 360 distribution under the examples/2D subdirectory.

10 - 1 Vector Variables

When you activate the Vector zone layer (via the Sidebar), Tecplot 360 checks to see whether vector components have been assigned for the current dataset in the current plot type. If you have not assigned vector components, the Select Variables dialog will be launched (Figure 10-16).
Choose variables by selecting the desired U, V, and W (3D only) variables from their respective drop-downs. You may select any of the current dataset's variables as any component. You can change the component variables at any time by choosing "Vector Variables" from the Vector submenu of the Plot menu.

Once you have selected the Vector check box and have chosen your vector components, your vector plot will appear. If vectors are not visible, refer to Section 10 - 4 "Vector Length".

10 - 2  Vector Plot Modification

You can modify your vector plot attributes using either the Vector page of the Zone Style dialog or the Quick Edit dialog. You can control any of the following attributes from the Vector page of the Zone Style dialog.

- **Vector Show** - Select whether or not to show the vector for the highlighted zone(s).
- **Vector Type** - Select from the following options:
  - **Tail at Point** (default) - Draws the tail of the vector at the data point.
  - **Head at Point** - Draws the head of the vector at the data point.
  - **Anchor at Midpoint** - Positions the midpoint of the vector at the data point.
  - **Head Only** - Draws the head of the vector at the data point and does not draw a tail.

In order for the changes made on the Vector page to be visible in your plot, the Vector layer must be turned on. You can turn on the Vector layer by any of three methods: by toggling-on the Vector layer in the Sidebar, by using the Quick Edit dialog, or by selecting "Yes" from the [Vect Show] button drop-down menu on the Vector page of the Zone Style dialog. The first time you activate this layer by either the Zone Style dialog or the Quick Edit dialog, a confirmation dialog will appear to confirm whether you wish to activate the Vector layer.
Figure 10-17 shows examples of each of the vector plot types.

**Figure 10-17.** The Vector plot types: tail at point, head at point, anchor at midpoint, and head only.

- **Head Style** - Figure 10-18 displays the available arrowhead styles.
  - Plain (default) - Line segments drawn from the head of the vector.
  - Filled - Filled isosceles triangles with apex at the head of the vector.
  - Hollow - Hollow isosceles triangles with apex at the head of the vector.

**Figure 10-18.** Arrowhead types for vector plots (plain, filled and hollow).

- **Line Color** - The vector color.
- **Vect Tang** - Select whether to display the vectors as 3D vectors with both the normal and tangent components or just the tangents components. Tangent vectors are drawn on 3D surfaces only where it is possible to determine a vector normal to the surface. A plot where multiple surfaces intersect each other using common nodes is a case where tangent vectors are not drawn because there is more than one normal to choose from. An example of this would be a volume IJK-ordered zone where both the I and J planes are plotted. If tangent vectors cannot be drawn, then regular vectors are plotted instead.
- **Line Pttm** - The vector line pattern.
- **Pttm Lngth** - The vector line pattern length.
- **Line Thck** - The vector line thickness.

The following attributes are assigned on a frame-by-frame basis, rather than zone-by-zone:

- Vector lengths. See Section 10 - 4 “Vector Length”.
- Arrowhead angle and size. See Section 10 - 3 “Vector Arrowheads”.

---

Vector Plot Modification

Figure 10-17 shows examples of each of the vector plot types.
Figure 10-19. Comparison of the Vect Tang options. A) vectors are drawn with both the normal and tangent components. B) vectors are drawn with only the tangent components.

• The reference vector. See Section 10 - 5 “Reference Vectors.”

If your data consists of a dense mesh of points, a vector plot may be too crowded to be of much use. You can “thin” the plot by plotting only a certain subset of the data points with the Index Skip attribute from the Points page of the Zone Style dialog.

10 - 3 Vector Arrowheads

You can specify arrowhead sizes as either a fraction of the vector length or in frame units (that is, as a percentage of the frame height). Arrowhead size is a global attribute; it applies to all arrowheads in all zones in the active frame. By default, Tecplot 360 specifies size as a fraction of the vector length.

To modify the arrowhead size select “Arrowheads” from the Vector sub-menu of the Plot menu.

The Vector Arrowheads dialog has the following options:

• **Angle (deg)** - The arrowhead angle is the angle that one side of the arrowhead makes with the vector, i.e. the apex angle is twice the arrowhead angle. To specify the arrowhead angle, enter a value from 1 to 90, or choose a value from the drop-down, indicated by the down-arrow button.

• **Set Size Based On:**
  - **Fraction of Length** - Enter a decimal value from zero to ten.
  - **Frame Units (%)** - Enter a percentage value from zero to 100.
10 - 4 Vector Length

Vector length is a global attribute—it applies to all zones in the active frame. To specify the vector length, select “Length” from the Vector sub-menu of the Plot menu.

The Vector Length dialog has the following options:

- **Relative (Grid Units/Magnitude)** - Specify the vector length as the number of grid units per unit of vector magnitude.
- **Relative (Cm/Magnitude)** - Specify the vector length as the number of centimeters per unit of vector magnitude.
- **Uniform (%)** - Specify the vector length as a percentage of frame height.
- **Recalculate Length** - The default vector length is based on the size of the longest vector. Select [Recalculate Length] to change the vector length to a relative vector length with the scale factor expressed in grid units per unit of vector magnitude.

For either of the “Relative” options, the value you specify is a scale factor that is multiplied by the vector magnitude to determine the length of the vector.

Since 3D vectors are plotted in the plane of the screen, a 3D vector’s length will depend on both the vector length settings and the orientation of the vector. The length may be distorted even further if the vector length setting is Relative and the 3D projection is Perspective.
A reference vector is a vector of specified magnitude placed on the plot as a measure against all other vectors. To display a reference vector, select “Reference Vector” from Vector sub-menu of the Plot menu.

The Reference Vector dialog has the following options:

- **Show Reference Vector** - Toggle-on to include a reference vector in your plot.
- **Origin (%)** - Enter the coordinates of the starting point of the reference vector, as a percentage of the frame width (X) and frame height (Y).
- **Color** - Choose a color from the Select Color dialog. Multi-color and RGB coloring are not available.
- **Angle (deg)** - Enter the orientation of the vector in degrees from horizontal, or choose a value from the drop-down.
- **Line Thickness (%)** - Enter the desired line thickness, or choose a value from the drop-down.
- **Magnitude** - Enter the magnitude of the reference vector. The units correspond to those of the vector components.
- **Include Magnitude Label** - Toggle-on to include the magnitude of the reference vector in the label. Select and modify any of the following options:
  - **Text Color** - Choose a color from the Select Color dialog. Multi-color and RGB coloring are not available.
  - **Font** - Select the Font button to choose the font typeface and size from the Select Font dialog, or select the up and down arrows to adjust the size alone. (See Section 18 - 1.2 “Font Folders and Fallback” for more information on how fonts work with Tecplot 360.)
  - **Number Format** - Select the [Number Format] button to specify how the number will be formatted. See Section 6 - 7.1 “Specify Number Format” for a discussion of this dialog.
  - **Offset** - Choose the spacing between the label and the reference vector as a percentage of frame height.
Reference Vectors

Figure 10-20 shows a plot with a reference vector.

Figure 10-20. An example of a vector plot with a reference vector included. The label for the reference vector was included using Insert-Text.
Scatter plots are plots of symbols at the data points in a field. The symbols may be sized according to the values of a specified variable, colored by the values of the contour variable, or may be uniformly sized or colored. Unlike contour plots, scatter plots do not require any mesh structure connecting the points, this allows you to make scatter plots of irregular data.

To add a scatter layer to your plot, activate the “Scatter” toggle in the Sidebar. You can modify your Scatter plot using the Scatter page of the Zone Style dialog and the Scatter submenu of the Plot menu.

11 - 1 Scatter Plot Modification

Once you have loaded your data, you can modify your scatter plot attributes using either the Scatter page of the Zone Style dialog or the Quick Edit dialog. You can control any of the following attributes for a zone or group of zones from the Scatter page of the Zone Style dialog.

In order for the changes made on the Scatter page to be visible in your plot, the Scatter layer must be turned on. You can turn on the Scatter layer by any of three methods: by toggling-on the Scatter layer in the Sidebar, by using the Quick Edit dialog, or by selecting "Yes" from the [Scat Show] button drop-down menu on the Scatter page of the Zone Style dialog. The first time you activate this layer by either the Zone Style dialog or the Quick Edit dialog, a confirmation dialog will appear to confirm whether you wish to activate the Scatter layer.
• **Scat Show** - Select whether or not to show the scatter layer for the highlighted zone(s).

• **Symbol Shape** - Select one of the following symbols shapes:
  - Square (default)
  - Delta
  - Gradient
  - Left Triangle
  - Right Triangle
  - Diamond
  - Circle
  - Point
  - Cube (rendered as a square in 2D)
  - Sphere (rendered as a circle in 2D)
  - Octahedron (rendered as a diamond in 2D)

• **Other** - Plot with a specified ASCII character (as specified in the Enter ASCII Character dialog.) In the dialog, enter a character to use as a symbol, and then specify the Tecplot 360 character set from which to obtain the symbol: Base (English Font), Greek, Math, or User Defined. See also: Figure 18-2.

You can change the base font in the Scatter Size/Font dialog, accessible via \textit{Plot-Symbol Font}. See Section 11 - 2 "Scatter Size/Font" on page 217.

3D scatter symbols should only be used if your dataset is on the order of thousands of points. If your dataset is large, (millions of points), try using 2D scatter symbols instead.

• **Outline Color** - Select from either the color palette or one of the contour groups.
  - **Multi-color** - Each plotting symbol is colored according to the value of the selected contour variable at that data point.
  - **RGB coloring** - Each plotting symbol is colored according to the values at that data point for the variables assigned to RGB.

• **Fill Mode** - The 3D symbol shapes, Cube, Sphere, and Octahedron are filled with the line color, but the other shapes have several optional fill modes:
  - None (default)
  - Use Line Color - Matches to outline color.
  - Use Back Color - Matches to frame color.
  - Use Specific Color - Select a specific Fill Color from the [Fill Mode] button.

• **Fill Color** - Select from either the color palette or one of the contour groups.

• **Scat Size** - Scale the symbol size by either a percentage of the frame width or a variable in the dataset. (See Section 11 - 2 "Scatter Size/Font" for complete instructions for sizing scatter symbols by variable.)
Scatter Size/Font

- **Line Thick** - Select the thickness of the scatter outlines for each highlighted zone(s).

Spheres, Cubes, and Octahedrons are always light-source shaded. Spheres are Gouraud shaded, and Cubes and Octahedrons are Panel shaded. Cube edges are aligned with X, Y, and Z-axes. Octahedrons are oriented so one vertex points in the Z-direction and one vertex points in the X-direction. For best appearance of 3D shapes, adjust the Light Source to use Specular Highlighting. Scat Size and Line Thick are not available for the point symbol. Points are always one pixel in size.

If your data consists of a dense mesh of points, a scatter plot may be too crowded to be of much use. You can "thin" the scatter plot by plotting only a certain subset of the data points with the Index Skip attribute from the Points page of the Zone Style dialog. The Point scatter symbol allows for quick viewing and panning in 3D plots. It is also a useful tool for identifying features in volume zones.

### 11 - 2 Scatter Size/Font

Use the Scatter Size/Font dialog (accessed via Plot>Scatter>Size/Font in 2D/3D or Plot>Symbol Font in line plot modes) to choose the base font used for ASCII character symbols and the scatter-size variable used to scale scatter symbols. The Scatter Size/Font dialog is shown below:

![Scatter Size/Font Dialog](image)

The following options are available:

- **Base Font for ASCII Symbols** - Select a font family from the drop-down and optionally a bold and/or italic style. (See Section 18 - 1.2 “Font Folders and Fallback” for more information on how fonts work with Tecplot 360.)
- **Scatter-size Variable** - Select a variable from the drop-down of the dataset's variables. If the Scat Size field is set to “Size by Variable” on the Scatter page of the Zone Style dialog, this variable is used to calculate the scatter symbol size at each data point. The actual size of each symbol is determined by multiplying the value of the variable at each point by the Size Multiplier. If the Scat Size field is not set to “Size by Variable”, this field has no effect.
- **Size Multiplier** - Enter the scale factor that multiplies the values of the Scatter-size Variable to size the scatter symbols. If the Scat Size field on the Zone Style dialog is not set to “Size by Variable”, this field has no effect. The Size Multiplier multiplied by the scatter variable value gives the size of the scatter symbol at a point, in units, specified by the following option buttons:
- **Grid Units/Magnitude** - Select this to express the Size Multiplier in terms of grid units per unit of variable magnitude.
• **Cm/Magnitude** - Select this to express the Size Multiplier in terms of screen centimeters per unit of variable magnitude.

• **Recalculate Size** - Select to reset the Size Multiplier to Tecplot 360’s initial value.

### 11.3 Reference Scatter Symbols

If you are using a scatter-size variable, it is sometimes useful to create a reference scatter symbol that shows the size at which a data point of a given magnitude will be represented. **Figure 11-1** shows a scatter plot with a reference scatter symbol.

![Figure 11-1](image)

**Figure 11-1.** Scatter plot with reference scatter symbol. The text label was added using **Insert>Text**.

You create the reference scatter symbol using the **Reference Scatter Symbol** dialog (accessed via **Plot>Scatter**). The dialog will open only if a scatter size variable is defined; if you have not yet created one,
select one by choosing Scatter Font/Size from the Plot menu, then choosing a “Scatter Size Variable” from the drop-down. The Reference Scatter Symbol dialog is shown below:

- **Show Reference Scatter Symbol** - Toggle-on to include a reference symbol in your plot.
- **Origin** - Choose the position of the reference symbol.
- **Magnitude** - Specify the size of the reference symbol.
- **Formatting** - Modify the color, fill mode, line thickness, and shape as desired.

### 11 - 4 Scatter Legends

To include the scatter legend, select “Scatter Legend” from the Scatter sub-menu of the Plot menu. Select the following options in the Scatter Legend dialog.

- **Show Scatter Legend** - Toggle-on to include a scatter legend in the plot.
- **Show Zone Names** - Toggle-on to include zone names in the legend.
- **Text** - Format the text for the legend by choosing a color and font, and specifying the text height as a percentage of the frame height or in units of points. (See Section 18 - 1.2 “Font Folders and Fallback” for more information on how fonts work with Tecplot 360.) Enter the desired line spacing in the Line Spacing text field.
- **Position** - Specify the location of the anchor point of the legend by entering values in the X (%) and Y (%) text fields. Enter X as a percentage of the frame width and Y as a percentage of the frame height.
- **Legend Box** - Select the type of box to draw around the legend (No Box, Filled, or Plain). If you choose Filled or Plain, format the box using the following controls:
  - **Line Thickness** - Specify the line thickness as a percentage of frame height.
  - **Box Color** - Choose a color for the legend box outline.
  - **Fill Color** - (Filled only) Choose a color for the legend box fill.
  - **Margin** - Specify the margin between the legend text and legend box as a percentage of the text height.
Shade Layer

Although most commonly used with 3D surfaces, shade plots can also be used to flood 2D plots with solid colors, or light source shade the exterior of 3D volume plots. In 3D plots, zone effects (translucency and lighting) cause color variation (shading) throughout the zone(s). Shading can also help you discern the shape of the plot.

Toggle-on “Shade” in the Sidebar to add shading to your plot. Use the Shade page of the Zone Style dialog to customize shading. Refer to Chapter 13: “Translucency and Lighting” for information on translucency and lighting zone effects.

Shade plots require 1J or IJK-ordered, or finite element data. I-ordered, or irregular data cannot be used to create shade plots.

12 - 1 Shade Layer Modification

You can modify your shading attributes using the Shade page of the Zone Style dialog (accessed via the Sidebar or Plot>Zone Style).

In order for the changes made on the Shade page to be visible in your plot, the Shade layer must be turned on. You can turn on the Shade layer by any of three methods: by toggling-on the Shade layer in the Sidebar, by using the Quick Edit dialog, or by selecting “Yes” from the [Shade Show] button drop-down menu on the Shade page of the Zone Style dialog. The first time you activate this layer by either the Zone Style dialog or the Quick Edit dialog, a confirmation dialog will appear to confirm whether you wish to activate the Shade layer.

You can control any of the following attributes from the Shade page of the Zone Style dialog:

121
- **Shade Show** - Select whether the shade layer is visible for each active zone.
- **Shade Color** - Select the shade color. In 2D Cartesian plots, only solid zone flooding is available (i.e., no lighting effects).
- **Use Lighting** - (3D only) Turns the lighting zone effect off or on. When "no" is selected, the shade color is used to uniformly color the zone. Refer to Chapter 13: "Translucency and Lighting" for information on translucency and lighting zone effects.
Translucency and Lighting

You can enhance the shade and contour zone layers in 3D plots using Translucency and Lighting Effects (referred to collectively as the “3D zone effects”). The 3D zone effects for streamtraces, slices, and iso-surfaces can be activated using their respective dialogs (accessed via the Plot menu or the Sidebar or via the Plot menu). The Effects page of the Zone Style dialog is shown below.

In order for changes related to lighting or translucency to be visible, the desired effect must be toggled-on in the Sidebar.

13 - 1 Translucency

Turn-on the translucency zone effect by toggling-on “translucency” in the Zone Effects region of the Sidebar. When a zone is translucent, you may view objects inside or beyond the zone. You can control the translucency of a zone using the Surface Translucency attribute in the Effects page of the Zone Style dialog. The level of translucency may be set to a value between 1 (nearly solid) and 99 (nearly invisible).
There are nine pre-set percentages ranging from 10 to 90. You may also use the “Enter” option to define a percentage of your own. An example of a translucent plot is shown in Figure 13-1.

Figure 13-1. An example of a plot using translucency.

All surfaces in 3D Cartesian plots may be made translucent. A different translucency may be assigned to individual zones, and may also be assigned to derived objects such as slices, streamtrace ribbons or rods, and iso-surfaces. Use the Effects page of the Zone Style dialog to change translucency settings for zones.

13 - 2 Lighting Effects

There are two types of lighting effects: Paneled and Gouraud.

- **Paneled** - Within each cell, the color assigned to each area by shading or contour flooding is tinted by a shade constant across the cell. This shade is based on the orientation of the cell relative to your 3D light source.

- **Gouraud** - This plot type offers a more continuous and much smoother shading than Paneled shading, but it also results in slower plotting and larger print files. Gouraud shading is not continuous across zone boundaries, unless face neighbors are specified\(^1\). Gouraud shading is not available for finite element volume zones when blanking is included. A finite element volume zone set to use Gouraud shading will revert to Paneled shading when blanking is included.

If IJK-ordered data with Surfaces to Plot is set to Exposed Cell Faces, faces exposed by blanking will revert to Paneled shading.

---

\(^1\) Refer to Section **TECFACE112** in the Tecplot Data Format Guide for details regarding face neighbors.
Figure 13-2 shows two shade plots. The one on the left uses a Paneled lighting effect and the one on the right uses a Gouraud lighting effect.

Figure 13-2. A comparison of the paneled (left) and Gouraud (right) lighting effects.

13 - 3 Three-dimensional Light Source

The light source is a point of light infinitely far from the drawing area. You can open the Light Source dialog (shown below) by selecting the Details [...] button next to “Lighting Zone” effect toggle the Sidebar, or by selecting “Light Source” from the Plot menu.

The Light Source dialog has the following options:

- **Light Source Position** - The 3D light source position is indicated by a dot over the origin of the 3D orientation axes in the Light Source Position region of the dialog. The 3D light source is a point of light infinitely far from the drawing area. The 3D light source applies to all objects within a frame and may be different among frames in the workspace. You can specify its location by clicking-and-dragging the point with your mouse in the Light Source Position region on the Light Source dialog. When the light source position moves away from the eye-origin ray, its representation changes from a point to an arrow. The length of the arrow indicates the distance between the eye-origin ray and the light source position.

- **Intensity (%)** - Controls the amount of lighting effect produced by the directional light source. An intensity of 100 produces the maximum contrast between lit and unlit areas, and fully lit
areas use the full surface color. Lesser values produce less contrast between lit and unlit areas, and fully lit areas use darker colors. An intensity of zero means the light source produces no contrast between lit and unlit areas, and all areas are black.

- **Background Light (%)** - Controls the amount of lighting effect applied to all objects regardless of the light source position. A background light of zero means that areas unlit by the directional light source receive no lighting at all and are entirely black, while areas lit by the directional light source get only the effect of that light. Larger values produce more lighting effect in areas not lit by the directional light source, making these areas show some of the surface color. A background light of 100 means that all areas are lit by the maximum amount, and areas unlit by the directional light source use the full surface color.

Intensity and Background Light are cumulative; they can add up to more than 100 and result in colors lightened beyond the base surface color. For example, reds will become pink and grays will become white.

- **Surface Color Contrast (%)** - Controls the contrast of the color of the light source shaded surfaces before applying lighting effects. A surface color contrast of 100 means that light source shaded surfaces use the full surface color for applying lighting effects. Lesser values mean that the surface color is blended with progressively more white, making light source shaded surface colors lighter. A surface color contrast of zero means that colors are pure white before applying lighting effects (the plot will only be shades of gray).

- **Include Specular Highlighting** - Turns on/off specular highlight for all light-source shaded objects in the plot. Specular Highlighting adds the semblance of reflected light to 3D shaded or flooded objects.
  - **Intensity (%)** - Controls intensity of specular highlights (that is, the amount of reflected light, which controls the amount of whiteness at the peak of the highlight).
  - **Shininess** - Controls shininess of specular highlight (that is, roughly the size and spread of specular highlight).

- **Lighting Optimizations** - Some combinations of lighting type and plot style may result in very slow redrawing of plots. Tecplot 360 provides lighting optimizations to avoid such conditions and instead draws a similar, but less intensive plot. These optimizations are on by default. Turn them off if you need to see the exact effects you have specified. You may want to turn off the graphics cache before turning off those optimizations for plots with large amounts of data. (See Section “Graphics Cache” on page 487 for information on the graphics cache.)
Slices

You can add slices to your plot in order to view X, Y, or Z planes within your data. With IJK-ordered data, you can also add slices on the I, J, or K planes. Slices can include lighting effects, contours, meshes, and more.

You can also use slices to clip (slice off) a portion of the displayed plot, yielding a cut-away along the X, Y, or Z plane.

To customize these and other attributes of slices, use the Slice Details dialog, accessible from the Sidebar or the Plot menu.

Tecplot 360 includes two methods for creating slices:

1. **Create a slice interactively** - To use this simple method, select the Slice tool in the Sidebar. This will activate a crosshair tool. Click anywhere within your plot to place a slice. Using the Slice tool, you can drag the slice to change its position. Refer to “Slice Tool” on page 24 for more information on working with the Slice tool.

   For additional control, additional slices, or another way to insert slices derived from the dataset, use the Position page of the Slice Details dialog. You can open the Slice Details dialog by selecting the Details button next to the Slices toggle in the Sidebar.

   Interactively created slices are derived from the dataset and are defined by a constant X, Y, or Z location (or constant I, J, or K indexes, for IJK ordered zones). Tecplot 360 considers this type of slice as a style of your plot and does not add it to the dataset unless you extract it to a zone (using Data>Extract>Current Slices).

   Use this method of slicing in order to use the slice to clip a portion of the displayed plot. See Chapter 20: “Surface Clipping” for information on how to do this.

2. **Extract a slice to a zone** - To create a slice as a zone extraction, select “Slice from Plane” from Data>Extract. The Extract Slice from Plane dialog that appears allows you to slice through 3D surfaces as well as 3D volume zones. You cannot move the position of an extracted slice, and you cannot use an extracted slice for clipping.

   Choose the method of slice creation according to the type of control you wish to have over the slice(s). The resulting slices are always 3D surfaces.
14 - 1 Interactively Created Slices

Use the Slice Details dialog to customize interactively created slices (that is, slices derived from your dataset). Select the Details button next to the Slices toggle in the Sidebar, or select “Slices” from the Plot menu, to launch the Slice Details dialog. To add slices to your plot, toggle-on “Show Group n” in the Slice Details dialog.

The Slice Details dialog includes the following pages: Position Page, Constraint Page, Contour Page, Vector Page, Other Page, and Animate Page.

You must toggle-on “Show Group n” in order for the changes made in the Slice Details dialog to be visible in your plot.

14 - 1.1 Slice Groups

Up to eight different slice groups can be set. Each slice group can use different slice planes or different ranges for the same slice plane. Changing the settings in the Slice Details dialog allows you to make the appearance of each slice group unique. The slice group is specified using the numbers at the top of the Slice Details dialog.

You must toggle-on "Show Group n" (where n = 1-8) in order to include the Slice group in your plot.

14 - 1.2 Position Page

Use the Position page of the Slice Details dialog to customize the position of the active slice group (accessed via the Sidebar or Plot>Slices). With this page of the dialog, you can also use the primary slice to clip off part of your displayed plot.

You can toggle-on “Show Start/End Slices” and use the Start slider to move the first (start) slice, or type in the slice position. Activate the last (end) slice and move it with the End slider.

The following options are available:

- **Slice Location** - Select which plane the slice is drawn on (X,Y,Z, I, J, or K).
- **Clip** - For slice groups 1-6, you can use the primary slice of each slice group to clip off part of the display of your plot. To do this, select “Below Primary Slice” or “Above Primary Slice” from the Clip menu. For more information about clipping, see “Surface Clipping”.
- **Below Primary Slice** - Choose this option to clip off the display of your plot from the primary slice toward the axis minimum.
Interactively Created Slices

• **Above Primary Slice** - Choose “Above Primary Slice” to clip off the display of your plot from the primary slice toward the axis maximum.
• **None** - Choose “None” to disable clipping by the current slice. This is the default setting.
• **Show Primary Slice** - Toggle-on to include the primary slice (first slice placed) in your plot. Use the slider or the text field to specify the position of the primary slice.
• **Show Start/End Slices** - Toggle-on to show intermediate slices between the start and end slices. Intermediate slices are distributed evenly between the start and end slices.
• **Num Slices** - Enter the number of intermediate slicing planes in the text field. (Range 1-5000.)
• **Range for all Sliders** - Limit the range for the sliders.
  • **Min, Step Size, Max** - Specify the start, end, and step for the slider range.
  • **Reset Slider Range** - Sets the slider range based on the range of the Slice Plane Location variable in the active zones.
• **Show Full Slice While Dragging** - Toggle-on to include a full image of the slice as you drag it to a new position. When “Show Full Slice While Dragging” is toggled-off, a solid-colored slice is shown during the dragging of slices or sliders. NOTE: Show Full Slice While Dragging is a global setting and is not specific to a Slice Group.

The Show Full Slice While Dragging option is not available if the slice plane is I, J, or K.

14 - 1.3 Constraint Page

The Constraint page allows you to constrain the active slice group to a particular region of the zone—for example, if a data set represents a complete airframe, but you wish to visualize the slice only near the wing rather than through the entire volume.

You define a constraint by specifying a grid-aligned rectangular region outside which a slice will not be displayed.

The following options are available:

• **Include** - Toggle-on this checkbox to constrain the slice.
• **Box Dimension** - The dimension of the constraining box in the X, Y, and Z axis directions.
• **Box Center** - The center point of the constraining box. Click the icon button, then click your plot, to move the box center to the clicked point.

On the screen and in exported raster image files, the constraint cuts through cells, and the edge looks straight and smooth. When exporting to vector formats, the constraint excludes or includes only whole cells in the slice, so the slice boundary may look ragged.
14 - 1.4 Contour Page

Use the Contour page to control the contour attributes of the active slice group (determined by the number buttons on the top of the page).

The following options are available:

- **Show Contours** - Select this check box to show contours.
- **Contour Type** - Select the contour type from the drop-down. Lines, Flood, Lines and Flood, Average Cell Flood, and Primary Value Flood are available.
- **Flood by** - If you chose contour flooding, select the contour group by which to flood, or RGB flooding.
  - [...] - Use this button to bring up the Contour Details dialog. See Section 9-2 "Contour Details Dialog" for details.
- **Contour Lines by** - If you chose contour lines or lines and flood, select the contour group by which to draw the lines.
  - [...] - Use this button to bring up the Contour Details dialog.
- **Line Color** - Choose the line color from the Select Color dialog. Multi-Color will color the slice contour lines based on the contour group variable.
  - **Line Thickness** - Specify the line thickness as a percentage of the frame width. You may enter a value in the text field, or choose one of the values in the drop-down.
- **Use Lighting Effect** - Select this check box to enable the lighting effect drop-down menu where you may choose "Paneled" or "Gouraud" shading. See Section "Translucency and Lighting" for more details on lighting effects.
- **Use Surface Translucency** - Select this check box to enable the surface translucency text field, where you may set the surface translucency from one (opaque) to 99 (translucent).
14 - 1.5 Vector Page

Use the Vector page of the Slice Details dialog to control the vector attributes of the active slice group (determined by the group number buttons on the top of the page).

The following options are available:

- **Show Vectors** - Select this check box to show vectors.
- **Tangent Vectors** - Select to use tangent vectors for your slices. See Section 10 - 2 “Vector Plot Modification” for more information.
- **Line Color** - Choose the line color from the Select Color dialog. Multi-color will color vectors based on the contour group variable. If no contour variable is set for the selected contour group, the Contour Details dialog will appear.
- **Line Thickness** - Specify line thickness as a percentage of the frame width. You may enter a value in the text field, or choose one of the values in the drop-down.
- **Vector Type** - Use this drop-down to set the vector type for your slices. Choose from Tail at Point, Head at Point, Anchor at Midpoint, and Head Only.
- **Vector Head Style** - Use this drop-down to set the vector head style for your slices. Choose from Plain, Filled, and Hollow.

14 - 1.6 Other Page

The Other page of the Slice Details dialog controls the mesh, shade, and edge attributes of the active slice group. (The active slice group is determined by the group number buttons on the top of the page.) This page also controls whether this slice group is affected by other slice groups that clip off part of the display.

The following options are available:

- **Show Mesh** - Select this check box to show mesh lines.
- **Color** - Choose the line color from the Select Color dialog. Multi-color will color meshes based on the contour group variable. If no contour variable is set for the selected group when selecting Multi-color, the Contour Details dialog will appear.
- **Line Thickness** - Specify the mesh line thickness as a percentage of the frame width. You may enter a value in the text field, or choose one of the values in the drop-down.
- **Show Shade** - Select this check box to show shading on the slice when Show Contour has not been selected or is set to Lines on the Contour page of this dialog.
  - **Color** - Choose the shade color from the Select Color dialog. Multi-color and RGB coloring are not available—use flooded contours for multi-color or RGB flooding.
  - **Use Lighting Effect** - Select this check box to enable the lighting effect drop-down, where you may choose “Paneled” or “Gouraud” shading.
  - **Use Surface Translucency** - Select this check box to enable the surface translucency text field, where you may set the surface translucency from one (opaque) to 99 (translucent). By default, slice translucency is toggled-on at 10 percent when your plot is loaded.

- **Show Edge** - Select this check box to show selected edge lines on all slices.
  - **Color** - Choose the edge color from the drop-down of Tecplot 360’s basic colors. Multi-color and RGB coloring are not available.
  - **Line Thickness** - Specify the edge thickness as a percentage of the frame width. You may enter a value in the text field, or choose one of the values in the drop-down.

- **Obey Source Blanking** - When active, slices are subject to any blanking used in for the data. When inactive, slices are generated for blanked and unblanked regions. See also Chapter 19, “Blanking”.

- **Obey Clipping Settings** - Toggle-on “Obey Clipping Settings” to instruct this slice group to be clipped by the clipping settings of any other slice groups.

For more information on clipping, see “Surface Clipping”.

**14 - 1.7 Animate Page**

See Section 31 - 1.6 “Slice Animation”.

**14 - 2 Slices Extracted Directly to Zones**

Use the Slice from Plane option (accessed via Data>Extract) to customize slices extracted directly to zones. In most cases it is not necessary to extract slices to zones. Most existing slice features allow you to set almost any style. There are cases where you may need to display multiple sets of slices in various directions, so it is necessary to extract at least some of the slices to zones. You can also generate arbitrarily oriented slices when extracting to a zone.

**14 - 2.1 Pre-defined Slice Extraction**

To extract slices that you have pre-defined with the Slice tool or the Slice Details dialog, choose the “Current Slices” option from the Extract sub-menu of the Data menu. This option will create a separate zone for each slice plane. The created zones are FE quadrilateral, regardless of the source zone types.
14 - 2.2  Arbitrary Slice Extraction

To extract a slice at an arbitrary orientation, or to slice a 3D surface instead of a volume, use the “Slice from Plane” option from the Extract sub-menu of the Data menu.

Specify any of four different types of cutting planes, as follows:

• **Arbitrary** - An arbitrary cutting plane. You may specify the position and orientation of the cutting plane using three points or an origin and a normal vector, or you can interactively place and rotate the cutting plane using the controls in the Extract Slice From Plane dialog. If you choose “Arbitrary” as your cutting plane, you can either use the Position sliders and Rotate About buttons to position the cutting plane, or choose one of the following buttons:
  
  • **Three Points** - Launches the Enter Three Points dialog, in which you specify the cutting plane by entering the X, Y, and Z-coordinates of three points on the cutting plane. These points must form a triangle; they cannot be coincident or collinear.
  
  • **Origin and Normal** - Launches the Enter Slice Origin and Normal dialog, in which you specify the cutting plane by entering the coordinates of a point and the components of a normal vector. Using this option, you enter six numbers to specify the cutting plane—the X, Y, and Z-coordinates of a point on the cutting plane (called the slice origin), and the X, Y, and Z-components of a vector normal to the cutting plane (called the slice normal).
  
  • **Constant X, Y, or Z** - A cutting plane of constant value. You may specify the value either by entering a value, or using a position slider.
  
  • **Position** - Enter the exact coordinate for the X, Y, and Z-coordinates of the origin of the cutting plane, or use the slider to specify each coordinate as a percentage of their respective axis ranges.
  
  • **Rotate About (Arbitrary ONLY)** - Use the increase button to rotate the cutting plane clockwise about the respective axes. Use the decrease button to rotate counter-clockwise.
  
  • **Show Trace** - To see a “trace” of the current slice, toggle-on “Show Trace”. If Show Trace is selected, Tecplot 360 draws an approximation of the intersection of the slicing plane with the active 3D zones. For finite element zones, the trace in fact draws all line segments of the intersections of the slicing plane with the cells in the zone. For IJK-ordered data, the trace is simply the line resulting from the intersection of the slicing plane and the outer surface of the zone.
  
  If Show Trace is not selected, Tecplot 360 simply draws the intersection of the slicing plane within the axis box.
  
  • **Force Extraction to Single Zone** - Choose this option to force the resulting object to be placed in a single zone. If “Force Extraction to Single Zone” is not selected, one zone per contiguous region is created.
• **Create Slice From** - Choose to Create Slices From volume zones, surface zones, or surfaces of a volume zone. A slice from a volume zone will create a plane. A slice from a surface zone, or the surface of a volume zone, will be a line or curve.

Once you have created the slice zone, you may plot it using the Zone Style Dialog, write it out to a data file, delete it, etc. It is the same as any zone that was read into Tecplot 360. If you slice volume zones, the resulting slice zones are finite element surface, quadrilateral element-types. If you slice surface zones, the resulting zones are finite element line segment element types.

See Figure 14-1 for an example of a zone created by a slice.

*Figure 14-1. Zone extracted by slicing 3D volume zone. This file, jetflow.plt is available in your Tecplot 360 distribution under the examples/3D_Volume subdirectory.*
Streamtraces

A streamtrace is the path traced by a massless particle placed at an arbitrary location in a steady-state vector field. Streamtraces may be used to illustrate the nature of the vector field flow in a particular region of the plot. See Section 22 - 9 “Calculating Particle Paths and streaklines” for information on adding streaklines and particle paths to your plot.

Because streamtraces are dependent upon a vector field, you must define vector components before creating streamtraces in Tecplot 360. However, it is not necessary to activate the Vector zone layer to use streamtraces.

To add streamtraces to your plot, toggle-on “Show Streamtraces” in the Streamtrace Details and use either the Add Streamtrace tool or the [Create Stream(s)] button on the Position page of the Streamtrace Details dialog (accessed via the Sidebar or the Plot menu) to specify the location of your streamtraces.

To create streamtraces with a format other than Surface Line, select a format from the “Create Streamtrace with Format” drop-down menu on the streamtrace(s) Position page of the Streamtrace Details dialog.

If you are drawing a rake on concave 3D volume surfaces using the Add Streamtrace tool, hold down the SHIFT key to draw the rake outside of the data.

There are two main categories of streamtraces:

- **Surface line streamtraces (or streamlines)** - Surface streamtraces are confined to the surface on which they are placed. They can only be placed in zones displayed as a 2D or 3D surface. If you try to place streamlines in a zone displayed as a 3D volume, an error dialog appears, and no streamlines are drawn. See Section 15 - 1.2 “Line Page”. When surface streamtraces are placed on a no-slip boundary surface, they will propagate according to the flow field very near the surface (see Section 15 - 3 “Surface Streamtraces on No-slip Boundaries” for more information).
• **Volume streamtraces** - Volume streamtraces can be created in 3D volume zones only (IJK-ordered or FE-volume zones). See Section 15 - 1.3 “Rod/Ribbon Page”. Volume streamtraces are subdivided into three categories:
  • Volume Lines, or volume streamlines.
  • Volume Ribbons, or streamribbons.
  • Volume Rods, or streamrods.

If you have added streamtraces to your plot, but cannot see them, go to the Volume page of the Zone Style dialog and verify that Show Streamtraces is set to “Yes”. Refer to Section 7 - 1.3 “Derived Volume Object Plotting” for details.

### 15 - 1 Streamtrace Details dialog

You can control the style of your streamtraces using the Streamtrace Details dialog (accessed via the Plot menu or the Details [...] button to the right of Streamtraces in the Sidebar). These style attributes affect all streamtraces in the active frame, including those already placed. They do not affect extracted streamtrace zones, discussed in Section 15 - 4 “Streamtrace Extraction as Zones”, because these are now ordinary ordered zones, and not streamtraces.

In order for the changes made on the Streamtrace Details dialog to be visible in your plot, you must have “Show Streamtraces” toggled-on.

### 15 - 1.1 Position Page

Use the Position page of the Streamtrace Details dialog (accessed via the Sidebar or Plot>Streamtraces) to control the next streamtrace or streamtrace rake to be placed.

Alternatively, you can add streamtraces using the Add Streamtrace tool. See also Section “Add Streamtrace” on page 25.
Streamtrace Details dialog

The following options are available:

- **Create Streamtraces with Format** - Choose the format for the next streamtrace from the dropdown. The options are as follows:
  - **Surface Line** - Two-dimensional and 3D surface streamlines. Surface lines are confined to the surface upon which they are placed. If placed in a 3D volume zone, these streamtraces are not plotted.
  - **Volume Line** - Three-dimensional volume streamline plotted through 3D space. The streamline path is integrated in three dimensions within the 3D volume field.
  - **Volume Ribbon** - Three-dimensional volume streamtrace with a defined thickness that twists in accordance with the local stream-wise vorticity of the vector field: a streamribbon. When you select this option, you should also check the ribbon width on the Rod/Ribbon page of the Streamtrace Details dialog. The width affects all streamtraces, including those already placed. The default width is often too large, but it is automatically calculated based upon the extent of your data. The center of the streamribbon is a 3D volume streamline. The streamribbon rotates about this streamline in accordance with the local vector field. Streamribbons have an orientation at each step.
  - **Volume Rod** - Three-dimensional volume streamtrace with a defined thickness and a polygonal cross-section: a streamrod. The cross-section of a streamrod rotates around a volume streamline in accordance with the local stream-wise vorticity. The center of the streamrod is a regular 3D volume streamline. Streamrods have an orientation at each step. As with streamribbons, you should check the rod width on the Rod/Ribbon page of the Streamtrace Details dialog, as well as the number of rod points (three, by default). The number of points indicates the cross-sectional shape of the rod. Three is an equilateral triangle; four, a square; five, a regular pentagon; and so forth. Like the width parameter, the number of points applies to all streamrods, including those already placed.

- **Seed Streamtraces By** - Choose the method for placing the streamtraces. This will determine the options available in the central portion of the dialog.
  - **Point/Rake Tool** - Click on the plot to create a stream at the clicked point. Click and drag to place a rake (a series of streamtraces) of the specified number of equally-spaced points along the path.
  - **Surfaces of Active Zones** - Tecplot 360 randomly distributes the specified number of seed points on the active zones.
  - **Surfaces of Selected Objects** - Tecplot 360 randomly distributes the specified number of seed points on the surfaces of the selected objects.
  - **User Defined Point or Rake** - Specify the placements of the seed point or rake numerically using the following fields, which appear when you choose method of placing streamtraces.

- **Direction** - Select the stream integration direction from the following options:
  - **Forward** - Select for forward integration from the starting point.
  - **Backward** - Select for backward integration from the starting point. When the streamlines are calculated backwards, the arrowheads still point in the forward direction.

D - Switches to streamrods
R - Switches to streamribbons
S - Switches to surface lines
V - Switches to volume lines
• **Both** - Select for both forward and backward integration from the starting point. (For streamribbons and streamrods, you should avoid this option.)

• **Seed Points** (Not for User Defined Point or Rake) - Enter the number of seed points here for use with the Point/Rake Tool, Surfaces of Active Zones, or Surfaces of Selected Objects methods of seeding.

• **Seed Point Position fields** (Only for User Defined Point or Rake) - Specify the position of the seed point, or the range of the rake, in IJK or XYZ coordinates.

• **Enter IJK Positions** - Select to specify the streamtrace starting point (and rake ending positions, if applicable) using the mesh indices I, J, and K.

• **Enter XYZ Positions** - Select to specify the streamtrace starting point (and rake ending positions, if applicable) using the spatial coordinates X, Y, and Z.

• **Zone** (only if Enter IJK Positions is selected) - Select from the drop-down the zone for which the I, J, (and K) indices are being specified.

• **Define Rake** - Select to identify the starting position as the start of a rake, and to activate the Rake Ending Position fields.

• **Streamtrace Start Position** - Specify the starting position for a single streamtrace, or (if “Create Rake” is selected) the beginning of a rake of streamtraces. There are two or three fields, labeled either X, Y, (and Z) or I, J, (and K). Enter the desired value in each field, or use the up and down arrows to increase or decrease the values.

• **Rake End Position** (Only if Create Rake is selected) - Specify the end position for a rake of streamtraces. There are two or three fields, labeled either X, Y, (and Z) or I, J, (and K). Enter the desired value in each field, or use the up and down arrows to increase or decrease the values.

• **Streamtraces per Rake** (Only if Create Rake is selected) - The number of streamtraces to create. The seed points will be positioned at equal intervals between the Streamtrace Start Position and the Streamtrace End Position.

• **Create** (Not for Point/Rake Tool) - Click to place the streamtrace or rake of streamtraces.

• **Number of Streamtraces** (Information only) - The number of streamtraces currently placed.

• **Delete All** - Select to delete all streamtraces in the current plot.
Streamtrace Details dialog

- **Delete Last** - Select to delete the last streamtrace placed.

1, 2, 3, 4, 5, 6, 7, 8, 9 - When the Streamtrace tool is selected, press 1-9 to change the number of streamtraces to add when placing a rake of streamtraces.

### 15 - 1.2 Line Page

Surface streamtraces or streamlines are confined to the surface on which they are placed. They can only be placed in zones displayed as a 2D or 3D surface. If you try to place streamlines in a zone displayed as a 3D volume, an error dialog appears, and no streamlines are drawn. The following attributes may be set with the Line page of the Streamtrace Details dialog. You cannot customize streamtraces using the Line page until after at least one streamtrace has been drawn.

- **Show Streamtraces** - Toggle-on to include streamtraces in your plot.
- **Line Color** - Enter the color for all streamtraces. You may set the color to Multi-color to color the streamtraces by the chosen contour group variable in the same manner as color flooding. (If the contour variable is not currently defined, the Contour Variable dialog appears so that you can define it.) You can use the Multi-color option, for example, to color the streamtraces by the local temperature or by the velocity magnitude. You can also specify RGB coloring.

The following attributes affect surface and volume streamlines:

- **Line Thickness** - Enter a value, or choose a pre-set value for the streamline thickness (as a percentage of the frame height for 2D lines and as a percentage of the median axis length for 3D surface lines and volume lines), or choose a pre-set value from the drop-down menu.
- **Arrows** - Toggle-on "Show Arrowheads on Lines" to display arrowheads along all streamlines (surface and volume) in the active frame. Arrows are not shown on volume ribbons or volume rods. You can also control the following attributes of the displayed arrows:
  - **Arrowhead Size** - Either enter a value for the arrowhead size (as a percentage of the frame height), or choose a pre-set value from the drop-down menu.
• Arrowhead Spacing - Enter the distance between arrowheads in terms of Y-frame units. A value of ten percent will space arrowheads approximately ten percent of the frame height apart from each other along each streamline.

15 - 1.3 Rod/Ribbon Page

The following attributes may be set with the Rod/Ribbon page of the Streamtrace Details dialog. They affect volume ribbons and volume rods only. You cannot customize streamtraces using the Rod/Ribbon page until after at least one streamtrace has been drawn.

• Rod/Ribbon Width - Enter a width for the volume ribbons and volume rods. The width is expressed in grid units. If you want two sets of streamtraces with different widths, you must create them individually by creating a set of streamtraces with a specific width, extracting the set as a zone, and then configuring a new set of streamtraces with the second width.

• Rod Points - Volume rods have a polygonal cross-section; this parameter tells Tecplot 360 what that cross-section should be. (Three is an equilateral triangle, four is a square, five is a regular pentagon, and so on.) If you want two sets of volume rods with different cross-sections, you must create one set and then extract the set as a zone, then configure a new set of streamtraces with the second cross-section. See Section 15 - 4 “Streamtrace Extraction as Zones.”

• Show Mesh - Toggle-on to display a mesh.
  • Mesh Color - Select a mesh color from the drop-down menu, or choose a custom color or multi-color.
  • Mesh Line Thickness - Select a line thickness from the drop-down menu, or enter your own number in the text field.

• Show Contour Flood - Toggle-on to display contour flooding.
  • Flood by - Select the contour group to flood.
  • [...] - Use this button to bring up the Contour Details dialog.

• Show Shade - Toggle-on to display shading.
  • Shade Color - Select a shade color from the Select Color dialog. Multi-color and RGB coloring are not available (use contour flooding instead).
**Streamtrace Details dialog**

- **Use Lighting Effect** - Toggle-on to enable the lighting effect drop-down menu. From this menu you can select “Paneled” or “Gouraud” shading.
- **Use Surface Translucency** - Toggle-on to enable the surface translucency text field, where you can set the surface translucency from one (opaque) to 99 (translucent).

### 15.4 Timing Page

Use the Timing page of the Streamtrace Details dialog (accessed via the Sidebar or Plot>Streamtraces) to control timed markers for streamlines, and timed dashes for all types of streamtraces. Stream markers are drawn at time locations along streamlines. The spacing between stream markers is proportional to the magnitude of the local vector field.

Stream markers are symbols plotted along streamtrace paths to identify the positions of particles at certain times. **Figure 15-1** shows a plot with both streamtrace markers and dashes.

![Figure 15-1](image)

**Figure 15-1.** Streamtrace markers (top), dashes (bottom), and both (middle). This file, `cylinder.plt`, is available in your Tecplot 360 distribution under the `examples/2D` subdirectory.

The spacing between stream markers is proportional to the magnitude of the local vector field. You can adjust the spacing between stream markers by specifying the time interval (or delta) between stream markers. Increasing the delta time will increase the space between stream markers and vice versa. The actual spacing is the product of the local vector magnitude and the specified delta.

You may also select the shape of your stream marker using the pre-set list under the Shape drop-down menu on the Timing page of the Streamtrace Details dialog. Selecting “Other” from the list activates the Enter ASCII Character option, where you may enter an ASCII character to be used as your stream marker.
To place stream markers or dashes along your streamtraces, open the Timing page of the Streamtrace Details dialog (accessed via the Sidebar or the Plot menu).

The Timing page has the following options:

- **Show Markers** [default = spheres (3D) / circles (2D)] - Toggle-on to include stream markers. Stream markers are only available for streamlines (surface and volume). Specify the size, color, and shape of the markers in the fields provided.
- **Show Dashes** - Toggle-on to include stream dashes. The lengths of the dashes and the spaces between the dashes are controlled by the value of Delta. Enter a value into the dash skip factor to control the number of time deltas used for the “off” sections of the streamtraces.
- **Time Start** - Enter the time at which the first marker should be drawn. A start time of zero means that the first marker is drawn at the starting point. A start time of 2.5 means that the first stream marker is drawn 2.5 time units downstream of the starting point.
- **Time End** - Enter the time after which no more stream markers are drawn.
- **Time Delta** - Enter the time interval that measures the time between stream markers. The actual distance between markers is the product of this number and the local vector magnitude.
- **Time Anchor** - Enter the time that a dash is guaranteed to start, provided the start and end time surround the dash.

**15 - 1.5 Termination Line Page**

A streamtrace termination line is a polyline that terminates any streamtraces that cross it. The termination line is useful for stopping streamtraces before they spiral or stall. Figure 15.2 shows the cylinder data with some streamtraces terminated by a 2D streamtrace termination line.
Streamtrace Details dialog

Figure 15-2. A streamtrace termination line drawn through surface streamlines. This figure was created with demo file cylinder.plt. This file is located in your Tecplot 360 distribution under the examples/2D subdirectory.

Streamtraces are terminated whenever any of the following occur:

- The maximum number of integration steps is reached.
- Any point where the streamtrace passes outside the available data.
- The streamtrace reaches a point where the velocity magnitude is zero.

You control the streamtrace termination line from the Term Line page of the Streamtrace Details dialog.

From the Term Line page, you can control the following attributes of the termination line:

- **Active Termination Line** - Toggle-on to activate the termination line and terminate any streamtraces that cross it. Toggle-off this option and redraw the plot to view unterminated streamtraces.
- **Show Termination Line** - Toggle-on to display the termination line. Toggle-off this option and redraw the plot to display terminated streamlines, but not the termination line.

You can select a termination line with the Selector or Adjustor tool. This allows you to interactively move the line (with the Selector), modify the line (with the Adjustor), or delete the line (with either tool).

Only one termination line can exist at any one time in a given frame. If you draw a second termination line, the first one is automatically deleted.

Termination Lines in the Eye Coordinate System

The streamtrace termination line is drawn in the grid coordinate system, which in 2D Cartesian plots moves with the data as you zoom and translate. In 3D Cartesian plots, the termination line is drawn in what is known as the eye coordinate system. Grid coordinates align with the eye coordinate system, therefore the termination line moves with the data as you zoom and translate, but remains fixed when you rotate the plot.
When you rotate a 3D dataset after drawing a streamtrace termination line, streamtraces previously terminated by the termination line may be terminated at different places, or not terminated at all if the rotated streamtrace no longer intersects the termination line. Figure 15-2 shows a 3D volume plot with streamribbons and a streamtrace termination line. This figure illustrates how the termination points vary as the plot is rotated. Notice that the termination line, being rendered in the eye coordinate system, remains in place on the screen as the plot is rotated.

![Figure 15-2](image)

Figure 15-3. Rotating Volume streamtraces with a termination line in the eye coordinate system.

### 15 - 1.6 Integration Page

Tecplot 360 uses an adaptive step-size, trapezoidal integration algorithm to calculate streamtraces. This creates the streamtrace by moving it in a series of small steps from the starting point in the direction of (or in opposition to) the local vector field. Each step is only a fraction of a cell or element. Tecplot 360 automatically adjusts the step size based on the local cell shape and vector field variation.
You can control the streamtrace integration by modifying the following parameters in the Integration page of the Streamtrace Details dialog:

- **Step Size** - Enter the initial and maximum step size Tecplot 360 uses while integrating through the vector field as a decimal fraction of the local cell or element width. A typical value (and the default) is 0.25, which results in four integration steps through each cell or element. The value for Step Size affects the accuracy of the integration. Setting Step Size too small can result in round-off errors, while setting it too large can result in truncation errors and missed cells.

- **Max Steps** - Enter the maximum number of steps before the streamtrace is terminated. This prevents streamtraces from spinning forever in a vortex, or from wandering into a region where the vector components are very small, very random, or both. If you choose a small Step Size, you should enter a larger Max Steps.

- **Minimum Step Size** - The smallest step size for Tecplot 360 to use. Setting this too small results in integration problems. Setting this greater than or equal to the Step Size results in a constant step size.

- **Obey Source Zone Blanking** - When active, streamtraces are generated for non-blanked regions only. When inactive, streamtraces are generated for both blanked and unblanked regions.

- **Obey Clipping Settings** - Toggle-on “Obey Clipping Settings” to clip each streamtrace by the clipping settings of any slice group that intersects that streamtrace. For more information on clipping, see “Surface Clipping”.

During the integration, a streamtrace is terminated if any of the following conditions occur:

- The maximum number of integration steps (Max Steps) have been taken.
- Any point the streamtrace passes outside the available data.
- The streamtrace reaches a point where the velocity magnitude is zero.
- The streamtrace crosses the stream termination line.
- The streamtrace crosses a clipping slice, if “Obey Clipping Settings” is toggled-on.

Streamtraces may terminate at a zone boundary even if there is an adjacent zone into which the streamtraces should proceed. This can happen if there is a small gap between the zones. Specifying face neighbors in the data file to connect the zones can reduce this issue. Increasing the minimum integration...
step size can also eliminate this problem. Refer to Section 3 - 5 “Face Neighbors” for more information on Face Neighbors.

15 - 2 Streamtrace Animation

See Section 31 - 1.7 “Streamtrace Animation”.

15 - 3 Surface Streamtraces on No-slip Boundaries

When surface streamtraces are placed on a no-slip boundary surface, they will propagate according to the normal gradient of tangential velocity (proportional to shear stress) near the surface. This velocity gradient is computed from the data in the 3D volume parent zone, as identified by the ParentZone parameter. The ParentZone value identifies the volume zone to which the surface zone is bound (i.e. from which velocity data will be taken) and is read from the data file itself. Refer to Section “Zone Header” on page 108 of the Data Format Guide for information on specifying the ParentZone in ASCII data files. In addition, the wall boundary surfaces must be identified by the following auxiliary data variables:

- Common.IsBoundaryZone = TRUE
- Common.BoundaryCondition = Wall.

The parent zone must be a volume zone, and must be coincident with the no-slip boundary zone for this feature to work.

15 - 4 Streamtrace Extraction as Zones

To extract your streamtraces as zones select Extract>Streamtraces from the Data menu.

If you want all streamtraces of a given format extracted to a single zone, select the toggle-on “Concatenate Common Streamtraces into One Zone” in the Extract Streamtraces dialog. If you select this option, Tecplot 360 extracts all surface lines into one zone, all volume lines into another, all volume ribbons into a third, and all volume rods into a fourth. Tecplot 360 uses value-blanking to blank out the intervals between streamtraces (and between stream dashes). If you do not select this option, each streamtrace is extracted into its own zone.

After you have extracted your streamtraces, you will still see the original streamtraces, which may obscure the plotted streamtrace zones. Once you have extracted the zones, you can delete the original streamtraces by selecting [Delete All] on the Position page of the Streamtrace Details dialog. If timed dashes are active, all extracted streamtraces will be finite element zones. Otherwise, all extracted streamline zones are I-ordered, and extracted volume ribbon and volume rod zones are IJ-ordered.

15 - 5 Streamtrace Errors

Streamtraces will not appear under the following conditions:

- Unorganized data (I-ordered zones). Refer to Section 3 - 6 “Working with Unorganized Datasets” for information on organizing unorganized data.
- Zero-valued vectors. Refer to Chapter 10: “Vector Layer” for information on working with vectors.
- The streamtrace was placed outside of the data. If you are drawing a rake on a concave 3D volume surfaces, hold down the SHIFT key to draw the rake outside of the data.
- Inappropriate integration step size. Refer to Section 15 - 1.6 “Integration Page” for information on integrating streamtraces.
Iso-surfaces

An iso-surface displays a constant value of the contour variable as a surface on your plot. Iso-surfaces require that the data set contains volume zones (IJK-ordered, finite element brick, polyhedral, or finite element tetrahedral zones). You can modify iso-surfaces in the Iso-Surface Details dialog, which you can access by selecting the Details [...] button next to the Iso-surfaces toggle in the Sidebar. Or you can open the Iso-surface Details dialog by selecting “Iso-surfaces” from the Plot menu.

To view changes made in the Iso-surface Details dialog in your plot, you must have “Iso-surfaces” toggled-on in the Sidebar.

16 - 1 Iso-Surface Groups

You can work with up to eight different iso-surface groups in Tecplot 360. Zone layers or other objects that reference the same group for an attribute show the same plot style for that attribute. Each iso-surface group has its own settings for the attributes set in the Iso-surface Details dialog. Refer to the following sections for details on each attribute. For each group, toggle-on “Show Group n” to include the corresponding iso-surface group in your plot (where n represents a number between and including 1 and 8).
16 - 2  Iso-Surface Definition

Use the Definition page of the Iso-Surface Details to control Tecplot 360's rendering of iso-surfaces. Tecplot 360 applies the attributes set on this page (and on every page of the dialog) to the Iso-Surface group selected at the top of the dialog next to the Show Group toggle.

The Definition page of the dialog includes the following controls:

- **Show Group n** - Select this check box to display iso-surfaces, where n can be Groups 1-8.
- **Define Iso-Surfaces using** - Use this drop-down menu to select the appropriate contour group.
- **Details [...]** - Use this Details [...] button to bring up the Contour Details dialog.
- **Draw Iso-Surfaces at** - Use this drop-down menu to have Tecplot 360 draw iso-surfaces at:
  - **Contour Group Levels** - Go to the Contour Details dialog (accessed with the Details [...] button) to alter the Contour Levels. Refer to Section 9 - 2.2 "Contour Levels" for details.
  - **At Specified Value(s)** - Specify up to three values of the contour variable at which to draw iso-surfaces.
- **Contour Variable Min** - Indicates the minimum value of the contour variable.
- **Contour Variable Max** - Indicates the maximum value of the contour variable.
- **Subdivide all volume cells (to resolve saddle point issues)** - Toggle-on this option to eliminate holes in iso-surfaces near saddle points. If selected, all cells are subdivided for the purpose of contouring, slicing, and iso-surface generation. This layout property applies to all frames and iso-surface groups. However, this option applies to IJ-Ordered, IJK-Ordered, FE-Quad and FE-Brick zone types only.

If you have added iso-surfaces to your plot, but cannot see them, go to the Volume page of the Zone Style dialog and verify that Show Iso-surfaces is set to "Yes". Refer to Section 7 - 1.3 "Derived Volume Object Plotting" for details.
16 - 3 Iso-Surface Style

The Style page of the Iso-Surface Details dialog controls style settings for all iso-surfaces. (These styles act independently of the style assigned to zones by the Zone Style dialog.) Tecplot 360 applies the attributes set on this page (and every page of the dialog) to the Iso-Surface group selected at the top of the dialog next to the Show Group toggle.

The Style page of the dialog includes the following controls:

- **Show Mesh** - Toggle-on “Show Mesh” to display the mesh on iso-surfaces.
  - **Mesh Color** - Select a mesh color from the color palette.
  - **Mesh Line Thickness** - Select a mesh line thickness from the drop-down menu, or enter a number in the text field.

- **Show Contour** - Toggle-on “Show Contour” to display contours on iso-surfaces.
  - **Contour Type** - Select the contour display type.
  - **Flood by** - If you chose contour flooding, select the contour group by which to flood the contours, or select RGB flooding.
  - **Details [..]** - Use this button to bring up the Contour Details dialog.
  - **Contour Lines by** - If you chose contour lines, select the contour group by which to draw lines.
  - **Details [..]** - Use this button to bring up the Contour Details dialog.
  - **Contour Line Color** - If you chose contour lines, select this button to display the Select Color dialog, and choose the line color.
  - **Line Thickness** - If you chose contour lines, select a contour line thickness from the drop-down menu, or enter your own number in the text field.

- **Show Shade** - Toggle-on to display shading on iso-surfaces.
  - **Shade Color** - Select a shade color from the Select Color dialog.
  - **Use Lighting Effect** - Toggle-on to enable the lighting effect drop-down menu, where you can select Paneled or Gouraud shading.
  - **Use Surface Translucency** - Toggle-on to enable the surface translucency text field, where you may set the surface translucency from 1 (opaque) to 99 (translucent).

- **Obey Source Blanking** - When active, iso-surfaces are generated for non-blanked regions only. When inactive, iso-surfaces are generated for blanked and unblanked regions.

- **Obey Clipping Settings** - Toggle-on “Obey Clipping Settings” to clip each iso-surface by the clipping settings of any slice group that intersects that iso-surface.

For more information on clipping, see “Surface Clipping”.

16 - 4 Iso-Surface Animation

Refer to Section 31 - 1.4 “Iso-surfaces Animation”.

---
16 - 5 Iso-Surface Extraction

Iso-surfaces are derived from the dataset and do not append the dataset. To extract existing iso-surfaces to Tecplot 360 zones and retain these surfaces after making changes to the contour variable, select Extract Iso-Surfaces from the Data menu.

In the Extract Iso-Surfaces dialog, select the [Extract] button to create the new iso-surface zones, one zone for each plotted iso-surface. All of the variables in the dataset are interpolated from the 3D volume zones to the data points of the iso-surfaces.

Iso-surface zones are FE-surface quadrilateral element-type zones, regardless of the original 3D volume zone types. The mesh of the iso-surfaces is derived from the mesh of the original zones so that, in regions where the original mesh was coarse, the iso-surface mesh is coarse, and where the original mesh was fine, the iso-surface mesh is fine.

After creating the new iso-surface zones, it is often a good idea to turn off or reconfigure the current settings for iso-surfaces because the new zones will occupy the same physical space as the original iso-surfaces.
Axes

Tecplot 360 automatically enables the axes for 3D, 2D, XY, and Polar plot types. Tecplot 360 maintains five distinct sets of axes, one for each plot type. When the axes are generated, the axis labels, position, spacing, and tick mark labels are created. You can adjust any of these settings by using the Axis Details dialog (accessed via the Plot menu). Each page of the Axis Details dialog controls a different aspect of the axis, and each page is available for each axis.

17 - 1 Axis Display

Use the “Show Axis” toggle in the Axis Details dialog to turn on an axis display. By default, displaying an axis shows the axis line, tick marks, tick mark labels, and title for the axis. It is possible to disable any of these components separately, including the axis line.

To edit an axis from the Axis Details dialog, use the axis buttons ([X1], [Y1], [R], etc.) at the top of the dialog to indicate which axis you are working with. To edit a different axis, select a different axis button.

17 - 2 Axis Variable Assignment

For 2D and 3D Cartesian plots, Tecplot 360 initially assigns the first and second variables in the dataset to the X and Y axes, respectively. For 3D axes, the third variable in the dataset is assigned to the Z-axis.

To change variable assignments for 2D and 3D axes, select “Assign XY” or “Assign XYZ” from the Plot menu. For line plots, assigning axis variables is part of defining the mappings. See Chapter 6: “XY and Polar Line Plots” for more information.

The axis range may be modified using the Range page of the Axis Details dialog, accessed via the Plot menu.

When working with axis ranges, please keep the following definitions in mind:
• **Axis Range** - Specifies the minimum and maximum data values displayed along the axis. The range for an axis fits the value of the first variable assigned to that axis. If you deactivate the current layer and activate another layer, it may be necessary to reset the axis range.

• **Axis Length** - Specifies the physical length of the axis on the screen or paper.

• **Axis Scale** - Specifies the ratio of the axis length to the axis range.

### 17 - 3 Axis Range Options for XY Line, 2D, and 3D Cartesian Coordinates

This section discusses the options for XY Line, 2D, and 3D Cartesian Coordinates that can be found on the Range page of the Axis Details dialog.

The Range page has the following options:

- **Show n-Axis** - Toggle-on this checkbox to show the selected axis (n) on the plot. Use the buttons [X1], [Y1], etc. to the right of this checkbox to select the axis to show.

- **Min** - Enter the minimum value of the axis range.

- **Max** - Enter the maximum value of the axis range.

- **Reset Range** - Reset the Max and Min fields by selecting one of three options:
  - **Reset to Nice Values** - Sets the range to slightly larger than the current axis variable range in order to begin and end the axis at major axis increments.
  - **Set to Var Min/Max** - Sets the range to the minimum and maximum variable values.
  - **Make Current Values Nice** - Rounds the axis range to the nearest major axis increment.

- **Number Format** - You can choose several numeric formats for your tick mark labels, or specify a set of text strings to use as custom labels. The following numeric formats are available:
  - **Integer** - Tick marks are labeled in integer format (for example, 12). If this format is selected, tick mark labels with a decimal part are truncated.
  - **Float** - Tick marks are labeled with floating-point numbers (for example, 10.2).
  - **Exponent** - Tick marks are labeled using numbers in exponential format (for example, 1.02E-03).
  - **Best Float** - Tecplot 360 selects the best floating-point representation of the tick mark labels.
Axis Range Options for XY Line, 2D, and 3D Cartesian Coordinates

- **Range Best Float** - Tecplot 360 selects the best floating-point representation of the tick mark labels, taking into account the range of values on the axis.
- **Superscript** - Tick marks are labeled with numbers in scientific notation (for example, 1.2x10^-3).
- **Custom** - Uses the specified custom label set to label the axes.
  Custom labels are text strings defined in your data file that allow you to print meaningful labels for variables that do not contain numeric data. Custom labels are defined using the CUSTOMLABELS record, where each CUSTOMLABELS record corresponds to one custom set. When you choose custom labels for an axis, you also choose which custom set should be used for that axis.
  An example of using custom formatting can be found at the end of this section.
- **Time/Date** - Tick marks are labeled in time/date format (for example, Sat-Jan-05-2008). See Section 17 - 11 “Time/Date Format Options” for details.

To modify the axis range for non-polar coordinates, the following options can be found on the lower portion of the Range page.

- **Use Log Scale (Available for XY and Polar plot types only)** - The X and Y axes of XY Line plot types and the R-axis of Polar Line plot types can have a linear scale (default) or a logarithmic scale. When “Auto Spacing” is selected with logarithmic scale, large numbers are displayed in scientific notation (i.e., 3.48x10^5). It is strongly recommended that you use “Auto Spacing” with log axes. Navigate to the Ticks or Labels page of the dialog, and toggle-on “Auto Spacing” to use this option.
- **Dependency** - Select whether to set the axes as dependent upon or independent of each other.
  For XY Line or 2D Cartesian, select “Independent” or “Dependent”. For 3D Cartesian, select from one of the following options:
  - **Independent** - All axes are independent.
  - **XY Dependent** - The X and Y axes are dependent upon each other. The Z axis is independent.
  - **XYZ Dependent** - Changing the scale on any axis results in a proportional change in scale on the other two axes, so that the specified X to Y Ratio and X to Z Ratio are preserved.
- **Ratios (For 2D and 3D plots only)**
  - **2D Plots** - If “Dependent” is selected, enter the X to Y Ratio.
  - **3D Plots** - If “XY Dependent” is selected, enter the X to Y Ratio.
• **3D Plots** - If “XYZ Dependent” is selected, enter the X to Y Ratio and the X to Z Ratio.

• **Automatically Adjust Axis Range to Nice Values** - Automatically adjusts the axis ranges to the nearest major axis increments.

• **Size Factors (for 2D and 3D plots only)** - If the axes are XY-dependent, changing the X or Y size factor changes the other. If the axes are XYZ-dependent, changing one size factor changes the other two.

If "Preserve Length when Changing Range" is selected and your axes are Independent, changes to the X to Y Ratio will affect the axes range, but not scale. Deselect "Preserve Length when Changing Range" to change both the axis range and axis scale simultaneously.

**Figure 17-4** depicts the effect of toggling-on or off the "Preserve Length when Changing Range" option.

---

17 - 4 **Axis Range Options for Polar Coordinates**

Polar axes are different than any other axis type due to their cyclical nature. Polar axes are composed of the Theta and R-axis. Each axis has very different settings, unlike XY or XYZ axes. For the Theta-axis you can change the Theta Mode, Theta Period, and Theta Value on Circle Right; for the R-axis you can change the origin; and for both axes you can clip the data to the axes.

The following options for Polar Coordinates can be found on the Range page of the **Axis Details** dialog.

• **Show n-Axis** - Toggle-on this checkbox to show the selected axis (n) on the plot. Use the buttons [X1], [Y1], etc. to the right of this checkbox to select an axis.

• **Min** - Enter the minimum value of the axis range.

• **Max** - Enter the maximum value of the axis range.

• **Reset Range** - Reset the Max and Min fields by selecting one of three options:
  - **Reset to Nice Values** - Sets the range to slightly larger than the current axis variable range in order to begin and end the axis at major axis increments.
  - **Set to Var Min/Max** - Sets the range to the minimum and maximum variable values.
  - **Make Current Values Nice** - Rounds the axis range to the nearest major axis increment.

---

254
To modify the axis range for polar coordinates, the following options can be found in the lower portion of the Range page.

- **Clip Data to Axes** - For Polar Line plots, it is possible to have data that extends beyond the edges of the axes. Use this feature to eliminate data drawn outside of the range of the axes. Clipping data can be set independently for each axis. To activate or deactivate clipping, toggle “Clip Data to Axis” on or off. This feature is illustrated in Figure 17-5.

- **Theta Mode** - By default, the Theta-axis is expressed in degrees mode with a range of 0 to 360. For the Theta axis, you can plot the angles in units of Radians, Degrees, or Arbitrary (where arbitrary sets the Theta range to the maximum and minimum values of the Theta-axis variable).
  - To set the Theta Mode, choose from the following options:
    - 0 - 360 Degrees
    - -180 – 180 Degrees
    - 0 – 2Pi Radians
    - Pi-Pi Radians
    - Fit to Var Min/Max
  - Selecting any of these options changes the Theta Mode, resets the Theta-axis range, and resets the Theta Period. When the Theta Mode is Radians, Tecplot 360 draws Theta labels as fractional units of Pi.

- **Theta Period** - The Theta Period specifies the Theta range that is required to create a complete circle. If your Theta Mode is “Degrees”, the Theta Period is forced to 360; for “Radians”, the period is 2 Pi; for “Fit to Var Min/Max”, the period can be set to any value.
• **Theta Value on Circle Right** - The “Theta Value on Circle Right” setting changes the orientation of the Theta-axis. By default, this value is zero, which means that the value zero (or equivalent value, 360 degrees, 720 degrees, and so forth) is displayed on the right hand side of the circle. You can change this value to change the orientation of the axis.

• **R-origin** - The R-origin specifies what value of R is represented at the center of the axis. The effect of changing the R-origin is displayed in Figure 17-6.

![Figure 17-6](image)

*Figure 17-6.* An example of changing the R-origin from a range of 0.3 to 0.6 on a polar plot.

### 17 - 5 Axis Grid Options

You control the gridlines and precise dot grid from the Grid page of the Axis Details dialog, as shown below. On this page, you can customize the line pattern, pattern length, line thickness, and gridline color for Gridlines, Minor Gridlines, and the Marker Gridline.

- **Gridlines** - Match the spacing of tick marks.
- **Minor Gridlines** - Subdivisions of Gridlines.
- **Marker Gridline** - A single gridline positioned to call attention to a location on the plot.

The spacing of Gridlines is controlled by the tick mark spacing; see Section 17 - 6 “Tick Mark Options”, for more information.

![Gridline options interface](image)

• **Gridlines, Minor Gridlines, Marker Gridlines** - To activate Gridlines, Minor Gridlines, or Marker Gridlines toggle-on “Show” under these headings on the Grid page. All three kinds of gridlines have the following options:
Axis Grid Options

- **Line Pattern** - From the Line Pattern drop-down menu, choose one of the following line patterns: Solid, Dashed, DashDot, Dotted, LongDash, or DashDotDot.
- **Pattern Length (%)** (Theta axis only) - Select a pattern length from the drop-down menu, or enter in your own.
- **Line Thickness (%)** - Select a line thickness from the drop-down menu, or enter in your own.
- **Gridline Color** - Select the color of your gridlines.
- **Gridline Draw Order** - For all axes except 3D, you may specify a gridline draw order. Gridlines may be drawn either first, before any of the other plotting layers, or last, so they overlay any plotting layers. You can also specify the gridline draw order by "pushing" or "popping" the axis grid area from the Edit menu. To "push" or "pop" your gridlines, select the axis grid area by clicking on a gridline, then choose "Push" from the Edit menu to plot the gridlines first, or choose "Pop" to plot the gridlines last.

Drawing an object "Last" brings it to the front of your plot, and drawing an object "First" puts it at the back of your plot.

- **Gridline Cutoff (R%)** (Theta axis only) - Select the point along the R-axis where you want to stop drawing Theta lines.

In a Polar Line plot, the abundance of gridlines at the center may obscure data. You can specify a gridline cutoff along the R-axis of Polar plots on the Grid page of the Axis Details dialog for the Theta-axis.

- **Show Precise Dot Grid** - The precise dot grid is a set of small dots drawn at the intersection of every minor gridline. In line plots, the axis assignments for the first active mapping govern the precise-dot grid. The precise dot grid option is disabled for the 3D Cartesian plots and Line plots when either axis for the first active line mapping uses a log scale.
- **Position Marker By** - For Marker Gridlines only, you can specify that the marker should be positioned by Solution Time (so that it will move through the frame as you animate the plot) or by a constant value. In the latter case, you may also enter that value.
17 - 6 Tick Mark Options

Tick marks can be placed on each axis and labeled with either numbers or text strings. You can define your tick marks and their placement using the Ticks page of the Axis Details dialog. You can define the tick mark labels using the Label page of the Axis Details dialog.

• Show Ticks On - For each plot type, you can display tick marks at different sections of the axis. (This description also applies to Labels and Titles.) Sketch, XY Line, and 2D Cartesian axes allow tick marks to be displayed in the following areas:
  • Axis Line - The line that represents the specified axis.
  • Grid Border Bottom - By default, the axis line and grid border left/bottom are in the same position. Grid Border Bottom is the lower left-most position of the grid as defined by the viewport settings on the Area page of the Axis Details dialog.
  • Grid Border Top - Grid Border Top is the top right-most position of the grid as defined by the viewport settings on the Area page of the Axis Details dialog.

3D Cartesian axis tick marks can be displayed in the following areas:
  • Axis Line - The line that represents the specified axis.
  • Opposite Edge - The complimentary line that is opposite the axis line.

Polar R-axis tick marks can be displayed in the following areas:
  • Axis Line - The line that represents the R-axis.
  • All R-axes - Only available if “Draw Axis in Both Directions” or “Draw Perpendicular Axis” is toggled-on for the R-axis. The All R-axes setting will draw tick marks on the additional axes that are drawn.
  • Grid Border Start - Start point of the polar grid area.
  • Grid Border End - End point of the polar grid area.

Grid Border Start and Grid Border End are only available if the polar plot does not form a complete circle. If the data forms a complete circle, there is no start or end point on which to draw the ticks.

Polar Theta-axis tick marks can be displayed in the following areas:
  • Axis Line - The line that represents the Theta-axis.
Tick Mark Label Options

• **Inner Circle** - Only available if the minimum (Min) value on the R-axis is greater than the R-origin (Max) value. The Min and Max values are located on the Range page of the Axis Details dialog. When this is the case, the center of the polar plot is a circle rather than a single point; therefore, ticks can be drawn on the inner circle.

• **Outer Circle** - The outer edge of the polar grid area.

• **Tick Mark Length and Thickness** - Tick mark length and thickness can be set independently for major and minor tick marks using the Length and Thickness fields on the Ticks page.

• **Number of Minor Ticks** - To specify the number of minor tick marks, you must first toggle-off “Auto Spacing” at the bottom of the page. The number of minor tick marks can be set in the “Number of Minor Ticks” text field on the Ticks page of the Axis Details dialog.

> There is not a separate control for showing minor tick marks. To hide minor tick marks, enter zero in the “Number of Minor Ticks” text field.

• **Tick Mark Direction** - The following options are available to specify the direction that the tick marks are drawn:
  - **In** - Major and minor tick marks are drawn from the axis toward the center of the plotting region.
  - **Out** - Major and minor tick marks are drawn from the axis away from the center of the plotting region.
  - **Center** - Major and minor tick marks are centered on the axis line.

• **Tick Mark and Label Spacing** - You can control tick mark and label spacing directly, or use “Auto Spacing” (the default) to calculate an optimal spacing for tick marks and tick mark labels. As you change views, particularly in zooming, Tecplot 360 recalculates the spacing. With “Auto Spacing” selected, Tecplot 360 also calculates the number of minor tick marks for you. Spacing values are shared between tick marks and tick labels. You can change the spacing by adjusting the Auto Spacing, Spacing, and Anchor controls at the bottom of the page under “Tick Mark and Label Spacing”.

### 17 - 7 Tick Mark Label Options

From the Labels page of the Axis Details dialog, you can specify the label attributes for the tick marks of each axis.

• **Show Labels On** - Toggle-on the appropriate options for label display. The available options are dependent on plot type.
  - For Sketch, XY line, and 2D Cartesian line plots, choose from:
    - **Axis Line** - When toggled-on, axis labels will display on the selected axis line.
    - **Grid Border Bottom** - When toggled-on, axis labels will display on the bottom of the grid.
  - For 2D Cartesian line plots, choose from:
    - **Axis Line** - When toggled-on, axis labels will display on the selected axis line.
  - **Opposite Edge** - When toggled-on, axis labels will display on the opposite edge of the plot.
  - For Polar Line plots, choose from:
    - **Axis Line** - When toggled-on, axis labels will display on the selected axis line.
• **Inner Circle** - When toggled-on, axis labels will display on the inner edge of the polar grid area. (Only available if the minimum value on the R-axis is greater than the R-Origin value.)

• **Outer Circle** - When toggled-on, axis labels will display on the outer edge of the polar grid area.

• **Color and Font** - Select the color and font in which you want your labels to appear. (See Section 18 - 1.2 "Font Folders and Fallback" for more information on how fonts work with Tecplot 360.)

• **Number Format** - You can choose several numeric formats for your tick mark labels, or specify a set of text strings to use as custom labels. The following numeric formats are available:
  
  • **Integer** - Tick marks are labeled in integer format (for example, 12). If this format is selected, tick mark labels with a decimal part are truncated.

  • **Float** - Tick marks are labeled with floating-point numbers (for example, 10.2).

  • **Exponent** - Tick marks are labeled using numbers in exponential format (for example, 1.02E-03).

  • **Best Float** - Tecplot 360 selects the best floating-point representation of the tick mark labels.

  • **Range Best Float** - Tecplot 360 selects the best floating-point representation of the tick mark labels, taking into account the range of values on the axis.

  • **Superscript** - Tick marks are labeled with numbers in scientific notation (for example, 1.2x10^-3).

  • **Custom** - Uses the specified custom label set to label the axes.

  • **Custom labels** are text strings defined in your data file that allow you to print meaningful labels for variables that do not contain numeric data. Custom labels are defined using the CUSTOMLABELS record, where each CUSTOMLABELS record corresponds to one custom set. When you choose custom labels for an axis, you also choose which custom set should be used for that axis.

  • An example of using custom formatting can be found at the end of this section.

• **Offset from Line (%)** - Enter the offset of the tick mark labels from the axis.

• **Orient Labels** - Select from the following additional options for label display:
  
  • **At Angle** - Labels oriented at the angle specified in the Angle drop-down menu.

  • **Parallel to Axis** - Labels are parallel to the axis.

  • **Perpendicular to Axis** - Labels are perpendicular to the axis.

  • **Angle (deg)** - If Orient Labels is set to “At Angle”, specify the orientation of the tick mark labels relative to the axis. The angle is measured in degrees counter-clockwise from the axis.

• **Show Label as Axis Intersection** [2D, XY, and Polar Only] - Toggle-on to draw a label at the point where two axes intersect. Use this toggle if you have axis labels that are colliding, or are stacked on top of one another at the intersection of two axes.

• **Erase Behind Labels** - Toggle-on to include a rectangle (with the color of the frame background) behind the label to increase the visibility of the label.

• **Label Skip** - Specify the interval between tick mark labels.

• **Tick Mark and Label Spacing** - You can control tick mark and tick mark label spacing directly, or use Auto Spacing (the default) to calculate an optimal spacing for tick marks and tick mark labels. As you change views, particularly in zooming, Tecplot 360 recalculate the spacing. With Auto Spacing selected, Tecplot 360 also calculates the number of minor tick marks for you.
Spacing values are shared between the tick marks and tick labels. You can change the spacing by adjusting the Auto Spacing, Spacing, and Anchor controls at the bottom of the Ticks or Label pages of the Axis Details dialog.

### 17 - 7.1 Creating Custom Labels

As a simple example of using custom labels, consider the following data file containing data about attendance at two schools:

<table>
<thead>
<tr>
<th>SCHOOL</th>
<th>ATTENDANCE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>950</td>
</tr>
<tr>
<td>2</td>
<td>640</td>
</tr>
<tr>
<td>1</td>
<td>1010</td>
</tr>
<tr>
<td>2</td>
<td>820</td>
</tr>
</tbody>
</table>

The numbers 1 and 2 represent the school number, and the CUSTOMLABELS record defines Cleveland as school 1 and Garfield as school 2. Once you assign custom labels in Tecplot 360, the School axis is labeled with Cleveland and Garfield rather than 1 and 2.

To create a plot with custom labels:

1. Create a data file with one or more CUSTOMLABELS records and one or more variables with ordered integer values 1, 2, 3, and so forth. The first string in the CUSTOMLABELS record corresponds to a value of 1, the second string to 2, and so on. Load the data file into Tecplot 360.
2. Create a plot. XY Line plots are the most likely to use custom labels, but you can use labels anywhere.
3. From the Plot menu, choose “Axis”, and select the Label page of the Axis Details dialog.
4. Choose the axis to which you want to assign custom labels, and select the [Number Format] button.
5. In the Specify Format dialog, select “Custom” from the Format drop-down menu. Choose a set of custom labels for the axis from among all the CUSTOMLABELS records in the data file. For this example, toggle-on “Show Axis”, select the X-axis, and choose custom set 1.
6. Go to the Ticks page of the Axis Details dialog. Toggle-off “Auto Spacing”, then set the spacing to one. (You may also want to set the number of minor ticks to zero.)
7. Go to the Range page of the Axis Details dialog. Set the Min and Max value to 0.5 and 2.5 respectively.
8. Close the Axis Details dialog.

VARIABLES = "SCHOOL", "ATTENDANCE"
CUSTOMLABELS "Cleveland", "Garfield"
ZONE T="1991"
  1 950
  2 640
ZONE T="1992"
  1 1010
  2 820
The attendance data are plotted in Figure 17-7.

![Figure 17-7. Bar charts with custom labels.](image)

As another example, consider the following data file containing temperature and rainfall data:

```plaintext
VARIABLES = "MONTH", "TEMPERATURE", "RAINFALL"
"Aug", "Sep", "Oct", "Nov", "Dec"
CUSTOMLABELS "Cold", "Cool", "Warm", "Hot"
CUSTOMLABELS "Dry", "Average", "Wet"
```

This data file adds custom labels to a 3D plot of weather data. See Figure 17-8 below.

![Figure 17-8. A 3D plot with custom labels on each axis.](image)

Custom labels are used cyclically. That is, if the variable assigned to the axis using custom labels goes over the number of custom labels, Tecplot 360 starts with the first label again. This is useful for days of the week, months of the year, or other cyclical data. In the weather dataset above, a value of 13 for the MONTH variable yields a tick mark label of “Jan”. Similarly, a value of five for TEMPERATURE yields a tick mark label of “Cold.”
17 - 8  Axis Title Options

An axis title is a text label that identifies the axis. By default, Tecplot 360 labels each axis with the name of the variable assigned to that axis.

From the Title page of the Axis Details dialog, you can specify the following attributes for each axis title:

- **Show Title On** - For any plot type, you can specify where to show the axis title. Toggle on “Axis Line” to show the axis title directly on the corresponding axis. The remaining available options are dependent upon plot type.
  - For 3D - Opposite Edge.
  - For 2D, XY Line or Sketch - Grid Border Bottom or Grid Border Top.
  - For Polar Line plots - Inner Circle or Outer Circle.
- **Color and Font** - Select the color and font in which you would like your axis to appear. (See Section 18 - 1.2 “Font Folders and Fallback” for more information on how fonts work with Tecplot 360.)
- **Offset from Line** - Prevents Tecplot 360 from printing your axis title directly on top of the axis. You may specify a positive or negative offset from one side or the other of the axis. An offset of zero prints the edge of the axis title on the axis.
  (OPTIONAL) - You may also adjust the axis title offset using the Adjustor tool from the Toolbar (not available for 3D Cartesian plots).
- **Position along Line** - Specify the start position of the axis title as a percentage of axis length.
- **Title** - Choose one of the following display options:
  - **Use Variable Name** - Use the axis variable name as the title.
  - **Use Text** - Enter the desired axis title in the appropriate text field.

17 - 9  Axis Line Options

The actual axis line is shown by default whenever the axis is shown. However, you can hide the axis line without turning off the axis as a whole.
To show or hide the axis line, select the Lines page of Axis Details dialog (accessed via the Plot menu).

- **Show Axis Line** - Toggle-on or off to display or hide an axis line.
  - **Color** - Select the color of your axis line.
  - **Thickness** - Select the thickness of your axis line.
- **Show Line on Opposite Edge** (3D Cartesian only) - Toggle-on or off to draw a line on the opposite edge from the selected axis line.
- **Show Grid Border** - Turning on the grid border draws a border around your grid. Toggle-on or off to display or hide the borders of your grid.
  - **Color** - Select the color of your grid border.
  - **Thickness** - Select the thickness of your grid border.
- **Align Axis With** - Select what part of your plot with which you would like to align your axis.
  - Sketch and 2D Cartesian line plots, choose from Y Value, Bottom, Top, or Viewport.
  - XY line plots, choose from Y1 Value, Bottom, Top, or Viewport.
  - Polar plots (Theta-axis), choose from R Value, Inner Circle, or Outer Circle. When aligning with an R Value, you may enter an R-axis Value to specify the position of the axis line. When aligning with the inner or outer circle, specify an offset. With a zero offset, the axis line is on the inner or outer circle, a positive offset moves the axis line outside the grid area. A negative offset moves the axis line within the grid area.
  - Polar plots (Theta-axis), choose from Theta Value, Inner Circle, or Outer Circle. When aligning with a Theta Value, you may enter a Theta axis value to specify the position of the axis line. When aligning with the inner or outer circle, specify an offset. With a zero offset, the axis line is on the inner or outer circle, a positive offset moves the axis line outside the grid area. A negative offset moves the axis line within the grid area.
  - **Theta Value** - Align the R-axis with a specific Theta B=Value. The axis is limited to the grid area.
  - **Grid Border Start** - Align the R-axis with the start of the grid border. The axis is limited to the grid area.
  - **Grid Border End** - Align the R-axis with the end of the grid border. The axis is limited to the grid area.
  - **Specific Angle** - Align the R-axis with a specific screen angle. The axis is limited to the grid area.
**Axis Line Options**

- **Top of Grid Area** - Align the R-axis with the top of the grid area. The axis may be drawn outside the grid area.
- **Bottom of Grid Area** - Align the R-axis with the bottom of the grid area. The axis may be drawn outside the grid area.
- **Left of Grid Area** - Align the R-axis with the left side of the grid area. The axis may be drawn outside the grid area.
- **Right of Grid Area** - Align the R-axis with the right side of the grid area. The axis may be drawn outside the grid area.
- **Theta-Axis Value** - Specify a Theta-axis value to specify the position of the axis line.
  - **Offset (%)** - Enter the offset of the line from the axis.
  - **Angle** - Enter the angle of the line from the axis.
- **Draw Axis in Both Directions** - In addition to setting the alignment of the R-axis, you may choose to extend the R-axis by drawing an axis line perpendicular or parallel to the existing axis line. Toggle-on “Draw Axis in Both Directions” to extend the axis line so that it spans the width of the grid area.
- **Draw Perpendicular Axis** - Toggle-on “Draw Perpendicular Axis” to draw an axis line perpendicular to the main axis line.
- **Show Viewport Border** (Polar line plots only) - Toggle-on “Show Viewport Border” to show the viewport border. The viewport border is defined on the Area page of the **Axis Details** dialog.
  - **Color** - Select the color of your viewport border.
  - **Thickness** - Select the thickness of your viewport border.
- **Show Grid Border** (2D, XY, Polar, and Sketch plots) - Toggle-on “Show Grid Border” to draw a complete border around your grid.
- **Show Line on Opposite Edge** (3D Cartesian only) - When toggled-on, axis lines will display on the opposite edge of the plot.
  - **Color** - Select the color of your grid border.
  - **Thickness** - Select the thickness of your grid border.
- **Show Axis Box** (3D Cartesian only) - Toggle-on “Show Axis Box” to display all edges of all axes.
- **Auto 3D Edge Assignment** (3D Cartesian only) - Toggle-on “Auto 3D Edge Assignment” to place the three axis lines so they will not interfere with the drawing of the plot. If toggled-off, you have the option to place the line at any pair of edges such as: Y-Min & Z-Min, Y-Max & Z-Min, Y-Min & Z-Max, or Y-Max & Z-Max. The available Min-Max pairs are dependent upon the axis selected to edit.
17 - 10 Grid Area Options

The grid area of your plot is the area defined by the axes. From the Area page of Axis Details, you control whether the grid area or viewport are color-filled. The Area page is shown below.

The Area page has the following options:

- **Fill Grid Area** - For Sketch, XY Line, and 2D Cartesian plots, you can alter the size of the grid area by changing the extents of the viewport. (For these plot types, the viewport and grid area are synonymous.)
  
  For 3D Cartesian and Polar Line plots, the grid area is altered by changes to the axis ranges.

  3D Cartesian options:
  - **Fill Behind Axes** - Select this option to fill the area behind the axes (your grid area) with a specific color.
  - **Fill Color** - Select the color with which to fill your grid area.
  - **Use Light Source Shading** - Select this option to light source shade the axis planes.

  Polar Line options:
  - **Fill Grid Area** - Select this option to fill the grid area with a specified color.
  - **Fill Viewport** - Select this option to fill the viewport area with a specified color.
  - **3D Axis Box Padding** - Enter a number as the minimum distance from the data to the axis box.
  - **Viewport Position (%)** - Select the position of the Viewport. The Viewport is the percentage of the entire plot area occupied by the plot grid. Select the location (as a percentage of the entire plot area) in which to place the Left, Right, Top, and Bottom borders of your grid area.

17 - 11 Time/Date Format Options

The Specify Number Format dialog is available for all plot types, including Sketch. You can use this dialog to display your axis labels in a number of different formats, including Time/Date format. The Specify Number Format dialog can be accessed by going to the Plot>Axis>Label or the ...
Time/Date Format Options

Plot>Axis>Range page, and selecting the [Number Format] button. See Section 6 - 7.1 “Specify Number Format” for more information on the Specify Number Format dialog.

You can also display elapsed time, instead of absolute time, on any axis. To do this, the original time/date data in your data file must indicate the elapsed time. View an example layout using elapsed time by loading elapsed_time_example.ipk from $TEC_360_2013R1/examples/XY/. (Use File>Open Layout to load this example.)

To specify your axis label using Time/Date format, select “Time/Date” from the Type drop-down menu. Data is read forward from December 30, 1899. Tecplot 360 also accepts negative values to support dates back to January 1, 1800.

You can format your labels by entering the available Time/Date codes in the Format field. When entering a format, any combination or subset of the Time/Date formula may be used.

If you use “m” immediately after the “h” or “hh” code or immediately before the “ss” code, Tecplot 360 displays minutes instead of the month.

Use the following formula and table to enter your Time/Date codes:
### Time Date Formula:

years-months-days hours:minutes:seconds

### Time/Date Codes:

<table>
<thead>
<tr>
<th>Time/Date Code</th>
<th>Display Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Years</td>
<td></td>
</tr>
<tr>
<td>yy</td>
<td>00-99</td>
</tr>
<tr>
<td>yyyy</td>
<td>1800-9999</td>
</tr>
<tr>
<td>Months[a]</td>
<td></td>
</tr>
<tr>
<td>mmmm</td>
<td>first letter of the month</td>
</tr>
<tr>
<td>m</td>
<td>1-12</td>
</tr>
<tr>
<td>mm</td>
<td>01-12</td>
</tr>
<tr>
<td>mmm</td>
<td>Jan-Dec</td>
</tr>
<tr>
<td>mmmm</td>
<td>January-December</td>
</tr>
<tr>
<td>Days</td>
<td></td>
</tr>
<tr>
<td>[d]</td>
<td>total number of elapsed days</td>
</tr>
<tr>
<td>d</td>
<td>1-31</td>
</tr>
<tr>
<td>dd</td>
<td>01-31</td>
</tr>
<tr>
<td>dddd</td>
<td>Sun-Sat</td>
</tr>
<tr>
<td>dddddd</td>
<td>Sunday-Saturday</td>
</tr>
<tr>
<td>Hours'</td>
<td></td>
</tr>
<tr>
<td>[h]</td>
<td>total number of elapsed</td>
</tr>
<tr>
<td>h</td>
<td>0-23 or 1-12</td>
</tr>
<tr>
<td>hh</td>
<td>00-23 or 1-12</td>
</tr>
<tr>
<td>AM/PM</td>
<td>AM or PM</td>
</tr>
<tr>
<td>A/P</td>
<td>AM or PM as “A” or “P”</td>
</tr>
<tr>
<td>Minutes</td>
<td></td>
</tr>
<tr>
<td>[m]</td>
<td>total number of elapsed</td>
</tr>
<tr>
<td>m</td>
<td>0-59</td>
</tr>
<tr>
<td>mm</td>
<td>00-59</td>
</tr>
<tr>
<td>Seconds</td>
<td></td>
</tr>
<tr>
<td>s</td>
<td>0-59</td>
</tr>
<tr>
<td>ss</td>
<td>00-59</td>
</tr>
<tr>
<td>.0</td>
<td>Tenths</td>
</tr>
<tr>
<td>.00</td>
<td>Hundredths</td>
</tr>
<tr>
<td>.000</td>
<td>Thousandths</td>
</tr>
</tbody>
</table>

---

[a] Codes can be entered as upper or lower case letters; however, letters will be displayed as shown in the display format. Numbers that cannot be formatted as a time or date will be displayed as asterisks.
Time/Date Format Options

b. Total number of elapsed days, hours, and minutes are valid for time values greater than or equal to zero, and equal to or less than 1,000,000 days.
c. NOTE: If you enter "AM/PM" or "A/P" in your Time/Date format, the "h" and "hh" hour codes are expressed using a 12-hour clock. Otherwise, hours are expressed in military time (24 hour clock).

Placing a backslash in front of a y, m, d, or s in the Time/Date formula will keep it from being processed as part of the formula. All characters not part of the Time/Date formula will appear as entered.
For example, \"year yyyy\" will appear as "year 2008", as the backslash keeps the first y from being processed as part of the formula.

Examples:

To display the time and date on your plot as a "Sat-Jan-05-2008", enter the following code:

```
ddd-mm-dd-yyyy
```

To display the time and date on your plot as a "1-3-08", enter the following code:

```
m-d-yy
```

To display the time and date on your plot as a "9:30:05 AM", enter the following code:

```
h:mm:ss AM
```

To display an elapsed time, such as "3:10:15", enter the following code:

```
[d]:hh:mm
```

17 - 11.1 Excel Support

Tecplot 360 supports Excel1 Time/Date number strings, with the exception of AM/PM time specifications, long day names, and long month names. This support allows you to create number formats in Excel and import them for use with your Tecplot 360 plots, or vice versa.

Time/Date number strings can be transferred from Excel to Tecplot 360 from Mar 1, 1900 forward.

17 - 11.2 Loading Time/Date Data

You can load time/date data into Tecplot 360 in the same way as any other data point. The following methods load time/date data as a floating-point number. (After loading, use Plot>Axis>Number Format to change the axis format to a time/date display.) The following loaders illustrate methods of loading time/date data into Tecplot 360.

1. Excel Loader (loadxls) If you have time/date data stored in Excel, you can use this loader to load your data file into Tecplot 360. For directions on using this loader, go to Section 4 - 5, "Excel Loader".

1. Tecplot 360 does not currently support Mac Excel "1904" format.
2. Excel Macro (add-on) This add-on offers more options to load data from Excel. Although it requires installation into Excel, after installing, this method enables quicker and simpler data loading from Excel into Tecplot 360. Refer to Section B - 1 “Excel Macro” for details.

3. Text Spreadsheet Loader For loading delimited files, use this loader. Refer to Section 4 - 16 “Text Spreadsheet Loader” for instructions. Time/date data included in this format must be represented by the floating point number used by Excel and Tecplot 360. (See Section 2 - 6 “Time and Date Representation”, in the Data Format Guide for more information on this formatting.)
**Text, Geometries, and Images**

You can enhance any plot or create a drawing from scratch using Tecplot 360's text and drawing tools. Tecplot 360 provides tools for creating polylines, circles, ellipses, squares, rectangles, and text. You can also insert BMP, JPEG, or PNG images to enhance your plot.

Pure sketches are created with the “Sketch” plot type. Figure 18-1 shows a sketch created with Tecplot 360 drawing tools.

![Figure 18-1. A sketch created with Tecplot 360.](image)

**18 - 1 Text**

To add text to your plot or sketch, either select the Text tool from the Toolbar or Text from the Insert menu. Click anywhere in a frame to indicate the location of the text. Use the Text Details dialog to enter and modify text and its formatting. To create multiple text elements click in the Tecplot 360 workspace at the desired location of the next text element before closing the dialog.
18 - 1.1 Text Details

The Text Details dialog has the following options:

- **Enter Text String** - Type the desired text.
- **Color** - Select a color for the text from the Select Color dialog.
- **Font** - Select a font, style, and size for the text. (See Section 18 - 1.2 “Font Folders and Fallback” for more information on how fonts work with Tecplot 360.)

You can embed Greek, Math, and User-defined characters into English-font strings by enclosing them with text formatting tags, together with the keyboard characters. The text formatting tags and their effects are as follows (format tags are not case sensitive and may be either upper or lower case):

- `<b>...</b>` - Bold
- `<i>...</i>` - Italics
- `<verbatim>...</verbatim>` - Verbatim
- `<sub>...</sub>` - Subscripts
- `<sup>...</sup>` - Superscripts
- `<greek>...</greek>` - Greek font.
- `<math>...</math>` - Math font.
- `<userdef>...</userdef>` - User-defined font.
- `<helvetica>...</helvetica>` - Helvetica font.
- `<times>...</times>` - Times font.
- `<courier>...</courier>` - Courier font.

Embedding and escaping special characters work only in English-font text; they have no effect in text created in Greek, Math, or User-defined character sets.
You can produce subscripts or superscripts by enclosing any characters with `<sub>...</sub>` or `<sup>...</sup>`, respectively. Tecplot 360 has only one level of superscripts and subscripts; expressions requiring additional levels, such as $e^2$, must be created by hand using multiple Tecplot 360 text strings. If you alternate subscripts and superscripts, Tecplot 360 positions the subscript directly above the subscript. Thus, the string `<sub>a</sub>` produces $a$...

To insert a tag into text literally, precede the first angle bracket with a backslash (“\”). To insert a backslash in the text, just type two backslashes (“\ \”). In ASCII input files, the number of backslashes must be doubled (two to precede a special character, four to create a backslash) because the Preplot program also requires a backslash to escape special characters.

- **Height** - Specify the height for the text. The height can be expressed in any of three ways, depending upon the setting of Coordinate System/Character Height. The default is in points; you can enter a value in the text field or choose a preset value from the drop-down.

- **Coordinate System/Character Height** - Select a combination of coordinate system and character height units from the following option buttons:
  - **Frame/Frame** - Specify character height as a percentage of frame height and place the text in a frame coordinate system.
  - **Frame/Point** - Specify character height in points and place the text in a frame coordinate system.
  - **Grid/Grid** - Specify character height in grid units, and place the text in the grid coordinate system.
  - **Grid/Frame** - Specify character height in frame units and place it in the grid coordinate system.

- **Clipping** - Clipping refers to displaying only that portion of an object that falls within a specified clipping region of the plot. If you have specified your text position in the Frame coordinate system, you can choose to clip your text to the frame or the viewport. The size of the viewport depends on the plot type as follows:
  - **3D Cartesian** - The viewport is the same as the frame, so viewport clipping is the same as frame clipping.
  - **2D Cartesian/XY Line** - The viewport is defined by the extents of the X and Y axes. You can modify this with the Area page of the Axis Details dialog.
  - **Polar Line/Sketch** - By default, the viewport is the same as the frame. You can modify this with the Area page of the Axis Details dialog.

- **Options** - Select [Options] to add a box around your text, modify the line spacing for multi-line text, or set a text anchor location. See Section 18 - 1.3 “Text Options”.

### 18 - 1.2 Font Folders and Fallback

Tecplot 360 supports TrueType (.ttf) fonts on most platforms it runs on. OpenType (.otf) font files are also supported, and .afont files are supported on Mac OS X. Fonts installed in the standard folder for fonts on your operating system (for example, C:\Windows\Fonts on a Windows computer) appear in the font selection menu in the Select Font dialog and in other places where you choose a font. A number of standard fonts are included with Tecplot products; these are always available and appear first in the font selection menu.
If the fonts you want to use with Tecplot 360 are installed in other folders, or if your operating system does not have a default system location for fonts, you can edit the tecplot.cfg file in your Tecplot 360 installation directory, using Notepad or another text editor, to indicate the directories where the fonts you want to use are installed. Add a line like one of the following:

```
$Interface FontPath = '/font/path'
$Interface FontPath = 'C:\Windows\Fonts' 'C:\More Fonts'
$Interface FontPath = '/first/path/ /second/path/ /third/path/'
```

Replace the paths with the paths to the folders that contain the fonts you wish to use, taking special note of the single quote marks that wrap the entire list of folders and the double quotes around each folder’s path. You can use just one or several font folders. As shown in the second example, if you wish to use your computer’s standard fonts as well as fonts from other folders, you must manually specify the standard font folder along with the others.

If you open a layout that specifies a font that Tecplot 360 does not have access to on your system, the text “falls back” to Times. If the layout specifies a style you do not have (for example, a bold version of a font you have but which does not include a bold version on your system), the correct font is used, but the style (boldface, in this case) is not displayed.

It is possible to choose a font by typing its name directly into the font selection field in the Select Font dialog and other places where a font can be chosen, instead of choosing the desired font from the provided menu. If the font you specify in this way is not available to Tecplot 360 on your system, the text will appear as Times on your computer. However, the name you typed is recorded when you save a layout, and the text appears in the correct font if the layout is later opened on a computer on which the font is available.

### 18 - 1.3 Text Options

Using the Text Options dialog (accessed via the [Options] button in the Text Details dialog) allows you to control boxed text, specify the text anchor position, control line spacing, and specify the scope of the text. The following options are available:

- **Text Box** - Specifies whether to box the text, and how the box appears on your plot, as follows:
  - **No Box** - Select this option to specify that no box is drawn around the text.
  - **Filled** - Select this option to specify a filled box around the text. A filled box is opaque; if you place it over another Tecplot 360 object, the underlying object cannot be seen.
  - **Plain** - Select this to specify a plain box around the text.
  - **Line Thickness (%)** - Specifies the thickness of the text box as a percentage of the frame width.
• **Box Color** - Select the box outline color from the Select Color dialog.
• **Fill Color** - Select the box fill color from the Select Color dialog.
• **Margin** - Specify the margin as a percentage of the text character height.
• **Text Anchor Location** - Specify the anchor point, or fixed point, for the text box. As the text box grows or shrinks, the anchor location is fixed, while the rest of the box adjusts to accommodate the new size. There are nine possible anchor points, corresponding to the left, right, and center positions on the headline, midline, and baseline of the text box. Select the radio button corresponding to the desired anchor position.
• **Line Spacing** - Specify the line spacing for the entered text. To specify the line spacing either enter a value in the text field, or use the up and down arrows to increase or decrease the existing value.
• **Attach to Zone/Map** - Toggle-on “Attach to Zone/Map” to attach the text to a particular zone or mapping. Text that is attached to an inactive or non-existent zone is not displayed. If you select this check box, enter the number of the zone or mapping to which you want to attach the text.
• **Show in All “Like” Frames** - Toggle-on this option to display the entered text in all frames sharing the active frame’s dataset.
• **Macro Function** - In the text field, specify the name of the macro function that you wish to link to a particular string of text. See Section 28 - 1.2 “Macro Linking to Text and Geometries” for more information.

### 18 - 1.4 Special Characters

Tecplot 360 supports Unicode text encoding. Your operating system should provide ways to enter Unicode text in non-English character sets, and any Unicode characters you can enter using these methods will display and print correctly in Tecplot 360.

If your system does not have the ability to enter Unicode text, characters in the ordinal range 160-255 provide support for most of the major European languages. Table 18 - 2 shows the characters in this range supported by Tecplot 360. Note that the two right-hand columns represent the extended European characters. Text formatting tags for Greek, Math, or User-defined characters work only with characters in the range 32-126 and is not available for the extended European characters. If your system is configured for European text entry, the European characters should appear and print automatically with no additional setup.

If your keyboard is not configured to produce a specific European character, you can generate it by including the sequence \nnn in your text, where nnn is from the character index table found in Table 18 - 2. For example, if your keyboard will not generate the é and you want to show the word “latté,” enter: latt\233
Custom Characters

You can create symbols, characters, and even custom fonts for use in Tecplot 360

Table 18 - 2: Character Indices in Tecplot 360.

See Section 32 - 6 “Custom Character and Symbol Definition” for further instructions.

18 - 1.5 Dynamic Text

You can add special placeholders to text that changes with the data or the display environment. For example, you can add a date placeholder that Tecplot 360 will replace with the current date at each redraw. Similarly, you can add a zone name or variable name placeholder.

For placeholders that represent an attribute of a Tecplot 360 object of which Tecplot 360 supports multiple instances (such as a frame, a dataset, or a zone), the placeholder by default refers to the current or active instance: for example, to the active frame if the placeholder refers to an attribute of frames. If there is no obvious default instance, the placeholder by itself usually refers to the first instance.
For such placeholders, you may specify the desired instance of the referenced type of object by enclosing an index in square brackets immediately following the placeholder name. For example, $(AUXZONE[3]:BC)$ refers to the zone auxiliary data named BC in the third zone.

In most cases, the index may also be written as ACTIVEOFFSET=n to specify the nth active instance of an object type. For example, $(ENDSLICEPOS[ACTIVEOFFSET=2])$ refers to the end position of the second active slice group. The complete list of placeholders is as follows:

<table>
<thead>
<tr>
<th>Variables</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>$(AUXDATASET:nnn)$</td>
<td>The value of the named auxiliary data attached to the dataset.</td>
</tr>
<tr>
<td>$(AUXFRAME:nnn)$</td>
<td>The value of the named auxiliary data attached to the frame.</td>
</tr>
<tr>
<td>$(AUXPAGE:nnn)$</td>
<td>The value of the named auxiliary data attached to the page.</td>
</tr>
<tr>
<td>$(AXISMAXn)$</td>
<td>Maximum value of the current n-axis range, where n is one of: Aa, R, X, Y, or Z.</td>
</tr>
<tr>
<td>$(AXISMINn)$</td>
<td>Minimum value of the current n-axis range, where n is one of: Aa, R, X, Y, or Z.</td>
</tr>
<tr>
<td>$(BYTEORDERING)$</td>
<td>Displays the platform’s byte ordering (INTEL or MOTOROLA).</td>
</tr>
<tr>
<td>$(DATE)$</td>
<td>The current date, in the format dd Mmm yyyy.</td>
</tr>
<tr>
<td>$(DATASETFNAME[nnn])$</td>
<td>Filename of the nnnth file associated with the current dataset. If nnn is omitted, then all dataset filenames are shown, separated by new lines.</td>
</tr>
<tr>
<td>$(DATASETTITLE)$</td>
<td>The current dataset title.</td>
</tr>
<tr>
<td>$(ENDSLICEPOS&lt;slice grouporactiveoffset&gt;)$</td>
<td>The position of the ending slice plane.</td>
</tr>
<tr>
<td>$(EXPORTISRECORDING)$</td>
<td>Returns “YES” if recording is active, otherwise returns “NO”.</td>
</tr>
<tr>
<td>$(FRAME)$</td>
<td>The frame name.</td>
</tr>
<tr>
<td>$(INBATCHMODE)$</td>
<td>Returns a value of 1 if the software is in batch mode, 0 if interactive.</td>
</tr>
<tr>
<td>$(ISDATASETAVAILABLE)$</td>
<td>Returns a value of 1 if a data set exists for the current frame, 0 if nonexistent.</td>
</tr>
<tr>
<td>$(ISOSURFACELEVEL&lt;iso surfacegrouporactiveoffset&gt;)[nnn]$</td>
<td>The value of the contour variable on the mnnth iso-surface.</td>
</tr>
<tr>
<td>$(LAYOUTFNAME)$</td>
<td>The name of the current layout file.</td>
</tr>
<tr>
<td>$(LOOP)$</td>
<td>Innermost loop counter.</td>
</tr>
<tr>
<td>$(MACROFILEPATH)$</td>
<td>Path to the folder containing the most recently opened macro file.</td>
</tr>
<tr>
<td>Variables</td>
<td>Notes</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>&amp;(\text{MAX}n)</td>
<td>Maximum value of the (n) variable, where (n) is one of: A, R, X, Y, or Z. For 2D or 3D Cartesian plots, the value is calculated from all active zones. For line plots, the value is calculated from the zone assigned to the first active linemap.</td>
</tr>
<tr>
<td>&amp;(\text{MAXB})</td>
<td>Maximum value of the blanking variable for the first active constraint. For 2D or 3D Cartesian plots, the value is calculated from the active zones. For line plots, the value is calculated from the zone assigned to the first active linemap.</td>
</tr>
<tr>
<td>&amp;(\text{MAXC})</td>
<td>Maximum value of the contour variable for contour group 1. For 2D or 3D Cartesian plots, the value is calculated from the active zones. For line plots, the value is calculated from the zone assigned to the first active linemap.</td>
</tr>
<tr>
<td>&amp;(\text{MAXI}), &amp;(\text{MAXJ}), &amp;(\text{MAXK})</td>
<td>([I, J, K])-dimension of the first active zone for 2D and 3D Cartesian plot types. For finite-element data, (I) represents the number of nodes in the first active zone, (J) represents the number of elements in the first active zone, and (K) represents the number of nodes per element (cell-based) or total number of faces (face-based) in the first active zone.</td>
</tr>
<tr>
<td>&amp;(\text{MAXS})</td>
<td>Maximum value of the scatter sizing variable of the active zones.</td>
</tr>
<tr>
<td>&amp;(\text{MAXU}), &amp;(\text{MAXV}), &amp;(\text{MAXW})</td>
<td>Maximum value of the variable assigned to the ([X, Y, Z])-vector component of the active zones.</td>
</tr>
<tr>
<td>&amp;(\text{MAXVAR}[nnn])</td>
<td>Maximum value of variable (nnn).</td>
</tr>
<tr>
<td>&amp;(\text{MIN}n)</td>
<td>Minimum value of the (n) variable, where (n) is one of: A, R, X, Y, or Z. For 2D or 3D Cartesian plots, the value is calculated from all active zones. For line plots, the value is calculated from the zone assigned to the first active linemap.</td>
</tr>
<tr>
<td>&amp;(\text{MINB})</td>
<td>Minimum value of the blanking variable of the first active blanking constraint. For 2D or 3D Cartesian plots, the value is calculated from all active zones. For line plots, the value is calculated from the zone assigned to the first active linemap.</td>
</tr>
<tr>
<td>&amp;(\text{MINC})</td>
<td>Minimum value of the contour variable of contour group 1. For 2D or 3D Cartesian plots, the value is calculated from all active zones. For line plots, the value is calculated from the zone assigned to the first active linemap.</td>
</tr>
<tr>
<td>&amp;(\text{MINS})</td>
<td>Minimum value of the scatter sizing variable for the active zones.</td>
</tr>
<tr>
<td>&amp;(\text{MINU}), &amp;(\text{MINV}), &amp;(\text{MINW})</td>
<td>Minimum value of the variable assigned to the ([X, Y, Z])-vector component for the active zones.</td>
</tr>
<tr>
<td>&amp;(\text{MINVAR}[nnn])</td>
<td>Minimum value of variable (nnn).</td>
</tr>
<tr>
<td>&amp;(\text{NUMFRAMES})</td>
<td>Number of frames.</td>
</tr>
<tr>
<td>&amp;(\text{NUMPROCESSORS USED})</td>
<td>Number of processors used. This may be different than the total number on the machine because of the /S!Limits MaxAvailableProcessors configuration file command, or because of a product limitation. Tecplot Focus is limited to one processor, while Tecplot 360 is limited to eight.</td>
</tr>
<tr>
<td>&amp;(\text{NUMVARS})</td>
<td>Number of variables in the current dataset.</td>
</tr>
<tr>
<td>&amp;(\text{NUMXYMAPS})</td>
<td>Number of XY-linemaps assigned to the current frame.</td>
</tr>
<tr>
<td>&amp;(\text{NUMZONES})</td>
<td>Number of zones in current dataset.</td>
</tr>
<tr>
<td>&amp;(\text{OPSYS})</td>
<td>Displays the current operating system. 1=UNIX/Linux/Macintosh, 2=Windows.</td>
</tr>
<tr>
<td>&amp;(\text{PAPERHEIGHT})</td>
<td>The paper height (in inches).</td>
</tr>
</tbody>
</table>
The placeholders should be typed exactly as shown, although the index or offset parameters shown must be replaced with the actual index or offset you wish to use.

You can, of course, embed the dynamic text strings in text records in a Tecplot-format data file, as in the following example:
Environment Variables

System environment variables can be accessed directly from Tecplot 360 by using the following: `&($string)`, where `string` is the name of your environment variable. Using environment variables within Tecplot 360 can add another degree of flexibility by taking advantage of your customized environment. If an environment variable is missing, the environment variable name itself will appear on the screen. Note that all environment variables are treated as text strings.

Formatting Numbers and Strings

If you want a dynamic text string to be formatted in a specific way, you may include C-style formatting strings in the macro variable specification.

The syntax for including a format string is:

```
&(DynamicTextString%formatstring)
```

The `formatstring` should be in the following format. Note that the flags, the width, and the precision are all optional; only the specifier is required. The square brackets [] are not a part of the format string.

```
[flags][width][.precision]specifier
```

The following are available as flags:

- `-` - Left-justify (default is right justification)
- `+` - Precede positive numbers with + sign (default is sign only for negative numbers)
- `space` - A blank space will be written in place of the sign if the number is positive
- `0` - Left-pads numbers with zeroes to fill the specified width (rather than spaces)

The `width` specifies the minimum number of characters to be printed. If the dynamic text string is shorter than this length, it is padded with spaces. The string is not truncated if it is longer than this length.

The `precision` specifies the following:

- For character strings: The maximum number of characters to be printed.
- For integers: The minimum number of digits printed; the number will be padded with leading zeroes to fulfill this requirement.
- For floating-point values: the number of digits to be printed after the decimal point.

When no `precision` is specified, the default is 1. When printing a character string value in a fixed-width field, then, you will want to specify the same value for both the `width` and the `precision` to achieve the desired result (otherwise you will print a maximum of 1 character due to the default `precision` of 1).

The following letters may be used as the `specifier`:

- `s` - string of characters
- `d` - signed integer
- `e` - scientific notation with a lowercase “e”
- `E` - scientific notation with an uppercase “E”
- `f` - floating point
- `g` - use `%e` or `%f`, whichever is shorter
- `G` - use `%e` or `%f`, whichever is shorter
- `u` - unsigned integer, written out in decimal format
- `o` - unsigned integer, written out in octal format
- `x` - unsigned integer, written out in hexadecimal (where a - f are lowercase)
Example 1:
To display the message "Maximum contour value is: \textit{xxxxxx}" where \textit{xxxxxx} only has two digits to the right of the decimal place. You would use:

\verb|\Maximum contour value is: &(|\texttt{MAXC%.2f}|)|

If \texttt{MAXC} currently has a value of 356.84206 then the dialog would show:

"Maximum contour value is: 356.84"

Example 2:
If, in the above example, you wanted to use exponential format you could use:

\verb|\Maximum contour value is: &(|\texttt{MAXC%12.6e}|)|

Here the result would be:

"Maximum contour value is: 3.568421e+02"

**Formatting Dates and Times**
For dynamic text strings that represent a date and/or time, such as \verb|&(|\texttt{SOLUTIONTIME}|\texttt{)}|, the following may be used:

- \texttt{yy} - Two-digit year ("09")
- \texttt{yyyy} - Four-digit year ("2009")
- \texttt{m} - Month number ("3", "12"), or minute if preceded by hours token
- \texttt{mm} - Zero-padded two-digit month ("09") or minute if preceded by hour token
- \texttt{mmm} - Abbreviated month ("Oct" for October)
- \texttt{mmmm} - Full month ("October")
- \texttt{mmmnnn} - Single-letter month ("O")
- \texttt{d} - Day of month ("9", "10")
- \texttt{dd} - Zero-padded two-digit day of month ("09")
- \texttt{ddd} - Abbreviated day of week ("Sun" for Sunday)
- \texttt{dddd} - Spelled-out day of week ("Sunday")
- \texttt{h} - Hour ("7", "11")
- \texttt{hh} - Zero-padded two-digit hour ("07")
- \texttt{s} - Seconds ("5", "22")
- \texttt{ss} - Zero-padded two-digit seconds ("04")
- \texttt{.0, .00, .000} - Milliseconds to 1, 2, or 3 digits
- \texttt{am/pm, a/p} - AM/PM indicator. All times are 24-hour unless an AM/PM indicator is included in the format string, in which case 12-hour formatting is used.
- \texttt{[dl, lh, [nm]} - Elapsed days, hours, or minutes.
- \texttt{\textbackslash} - Escapes (removes the special meaning of) the following character. May be used if your format string includes static text containing any of the above tokens.
Example:
Here is a date and time format string for a solution time:

"Recorded on &(SOLUTIONTIME%dddd dd-mm-yyyy at hh:mm:ss am/pm)"

The result would be similar to:

"Recorded on Monday 14-Sep-2009 at 04:31:42 PM"

18 - 2 Geometries

Geometries in Tecplot 360 are simply line drawings. Geometries include polylines (a set of line segments), circles, ellipses, rectangles, and squares. Images are also considered geometries, and are discussed in Section 18 - 3 "Images". Figure 18-2 shows some examples of geometries.

Figure 18-2. Sample Geometries

18 - 2.1 Geometry Creation

Geometries are created by drawing them in a frame using the Toolbar or the Insert menu.

Polyline

Add a polyline to your plot, using the button from the Toolbar or by selecting Insert-Polyline. To draw the polyline, move the mouse (without dragging) to the desired end point of the first line segment, then click the left mouse button. Move the pointer to the next end point, click, and so on. After placing the last segment, double-click on the final end point, right-click, or press ESC on your keyboard. To draw a horizontal or vertical line segment, press the H or V keys, respectively, while drawing the segment. After you place the segment's end point, the horizontal or vertical restriction is lifted. To lift the horizontal or vertical line segment restriction without placing the end point, press A on your keyboard. You can draw unconnected line segments in a single polyline; press U on your keyboard to "lift the pen." You can then move the pointer to the start of the next line segment.

<table>
<thead>
<tr>
<th>A</th>
<th>Allow translation of polyline segments in all directions.</th>
</tr>
</thead>
<tbody>
<tr>
<td>H</td>
<td>Restrict translation of current polyline segment to horizontal.</td>
</tr>
</tbody>
</table>

Table 18 - 3: Keyboard Shortcuts for Polylines
Geometries

Circle
Add a circle to your plot, using the button from the Toolbar or by selecting Insert>Circle. To draw the circles, click at the desired center point of the circle; drag the mouse until the circle is the desired radius, then release.

Ellipse
Add an ellipse to your plot, using the button from the Toolbar or by selecting Insert>Ellipse. To draw the ellipse, click at the desired center point of the ellipse; drag the mouse until the ellipse is the desired size and shape, then release.

Square
Add a square to your plot, using the button from the Toolbar or by selecting Insert>Square. The anchor point of the square is either the lower left-hand corner or the upper right corner of the square. Drag the mouse to the right of the anchor to create a square with the anchor at lower left; drag the mouse to the left to create a square with the anchor at upper right. Release when the square is the desired size.

Rectangle
Add a rectangle to your plot, using the button from the Toolbar or by selecting Insert>Rectangle. To draw the rectangle, drag the mouse until the rectangle is the desired size and shape. In contrast to squares, rectangles can propagate in any direction.

18 - 2.2 Geometry Details
Use the Geometry Details dialog to specify attributes of polylines, circles, ellipses, squares and rectangles. To access the Geometry Details dialog either select a geometry and select the [Object Details] button in the Sidebar, or double-click on the geometry object itself.

The following options are available:

- Line Color - Select a color for the geometry from the Select Color dialog.
- Line Pattern - Select the desired pattern (Solid, Dashed, Dotted, LongDash, or DashDotDot).
- Pattern Length (%) - Specify the length of the line pattern as a percentage of the frame width.
- Line Thickness (%) - Specify the thickness of the line as a percentage of the frame width.
- Fill Color - Toggle-on to fill a circle, ellipse, square, rectangle or line segment polygon. Then select a color for the geometry fill from the Select Color dialog.
- Origin - Enter the X and Y-coordinates of the anchor position of the geometry (in frame units if the coordinate system is frame; in grid units if the coordinate system is grid).
- Coordinate System - Specify the coordinate system for the geometry (Frame or Grid).
  - Frame - The geometry is always displayed at constant size when you zoom in or out of the plot.
  - Grid - The geometry resizes with the data grid.
- Clipping - Clipping refers to displaying only that portion of an object that falls within a specified clipping region of the plot. If you have specified your geometry position in the Frame coordinate system, the geometry will be clipped to the frame—any portion of the

<table>
<thead>
<tr>
<th>U</th>
<th>Pen up, while drawing polyline.</th>
</tr>
</thead>
<tbody>
<tr>
<td>V</td>
<td>Restrict translation of current polyline segment to vertical.</td>
</tr>
</tbody>
</table>

Table 18 - 3: Keyboard Shortcuts for Polylines
geometry that falls outside the frame is not displayed. If you have specified the Grid coordinate system, you can choose to clip your geometry to the frame or the viewport. The size of the viewport depends on the plot type as follows:

- **3D Cartesian** - The viewport is the same as the frame, so viewport clipping is the same as frame clipping.
- **2D Cartesian/XY Line** - The viewport is defined by the extents of the X and Y-axes. You can modify this with the **Area** page of the **Axis Details** dialog.
- **Polar Line/Sketch** - By default, the viewport is the same as the frame. You can modify this with the **Area** page of the **Axis Details** dialog.
- **Draw Order** - Geometries can be drawn either before the data, or after the data. If a geometry is drawn before the data, the plot layers, such as mesh, contour lines, etc. will be drawn on top of the geometry. If a geometry is drawn after the data, the geometry will be drawn last, obscuring the data.
- **Attach to Zone/Map** - Toggle-on “Attach to Zone/Map” to attach the geometry to a particular zone or mapping by entering the number of the zone or mapping. Geometries that are attached to an inactive or non-existent zone are not displayed.
- **Show in All “Like” Frames** - Toggle-on this option to display the geometry in all frames sharing the active frame’s dataset.
- **Macro Function** - In the text field, specify the name of the macro function that you wish to link to a particular geometry. See Section 28 - 1.2 “Macro Linking to Text and Geometries” for more information.

The following fields are specific to a single geometry type:

- **Polyline Arrowhead** - These options control the appearance of an arrowhead on a drawn polyline.
  - **Attachment** - Choose the end or ends of the polyline by selecting the appropriate check boxes.
  - **Size(&%)** - Specify the size of the arrowhead, as a percentage of frame height.
  - **Style**
    - Plain arrowhead style.
    - Filled arrowhead style.
    - Hollow arrowhead style.
  - **Angle** - Specify the angle the arrowhead makes with the polyline. You can either enter a value (in degrees) in the text field, or choose a preset value from the drop-down.
  - **Circle** - Controls the radius and precision of approximation of the circle:
    - **Radius** - Set the radius of the circle (in coordinate system units, **Frame** or **Grid**).
    - **Approximated by Number of Sides** - Enter the number of polylines used to approximate the circle.
  - **Ellipse** - Controls the shape and precision of approximation of the ellipse, as follows:
    - **Horizontal Axis** - Set the horizontal axis of the ellipse (in coordinate system units, **Frame** or **Grid**).
• **Vertical Axis** - Set the vertical axis of the ellipse (in coordinate system units, Frame or Grid).
• **Approximated by Number of Sides** - Enter the number of polylines used to approximate the ellipse.
• **Square** - Controls the size of the square, as follows:
  • **Size** - Set the size of the square (in coordinate system units, Frame or Grid).
• **Rectangle** - Controls the size and shape of the rectangle, as follows:
  • **Width** - Set the width of the rectangle (in coordinate system units, Frame or Grid).
  • **Height** - Set the height of the rectangle (in coordinate system units, Frame or Grid).

### 18 - 2.3 Three-dimensional Line Geometries

Three-dimensional line geometries cannot be created interactively; they must be created in a data file or using an add-on. In order to display 3D geometries, you must either include at least one zone in the data file with the 3D geometries or read the 3D geometries in, using the Add to Current Data Set option, after having first read a dataset into the frame.

### 18 - 3 Images

Tecplot 360 can import images from JPEG, BMP, and PNG files. These images can be used as logos or as a backdrop to your plot. To add an image to your plot, go to Insert>Image and browse to the desired image file.

When you insert an image, the image is initially centered in the frame at a preset size.

### 18 - 3.1 Modifying Images

The Image Geometry Details dialog (accessed via the [Object Details] button in the Sidebar) is used to modify an image just like it is used to modify other geometries. The dialog also displays the file name of the image and its resolution (number of pixels in each direction) for informational purposes.

The following options are available:
• **Origin** - Enter the X and Y-coordinates of the anchor position of the geometry (in frame units if the coordinate system is frame; in grid units if the coordinate system is grid).

• **Coordinate System** - Specify the coordinate system for the geometry (Frame or Grid).
  - **Frame** - The geometry is always displayed at constant size when you zoom in or out of the plot.
  - **Grid** - The geometry resizes with the data grid.

• **Clipping** - Clipping refers to displaying only that portion of an object that falls within a specified clipping region of the plot. If you have specified your geometry position in the Frame coordinate system, the geometry will be clipped to the frame—any portion of the geometry that falls outside the frame is not displayed. If you have specified the Grid coordinate system, you can choose to clip your geometry to the frame or the viewport. The size of the viewport depends on the plot type as follows:
  - **3D Cartesian** - The viewport is the same as the frame, so viewport clipping is the same as frame clipping.
  - **2D Cartesian/XY Line** - The viewport is defined by the extents of the X and Y-axes. You can modify this with the **Area** page of the **Axis Details** dialog.
  - **Polar Line/Sketch** - By default, the viewport is the same as the frame. You can modify this with the **Area** page of the **Axis Details** dialog.

• **Height and Width** - Enter a new value in one of the text fields labeled **Width** or **Height**. Units may be specified by typing them after the number. Use “cm” for centimeters, “in” for inches, or “pix” for pixels.

• **Preserve Aspect Ratio** - When the **Preserve Aspect Ratio** toggle is off, the width and height of the image can be set independently. If the **Preserve Aspect Ratio** is then turned back on, the current image aspect ratio is used. To return the image to its original shape, press the [Reset] button.

• **Draw Order** - Geometries can be drawn either before or after the data. If a geometry is drawn before the data, the plot layers, such as mesh, contour lines, etc. will be drawn on top of the geometry. If a geometry is drawn after the data, the geometry will be drawn last, obscuring the data.

• **Attach to Zone/Map** - Toggle-on “Attach to Zone/Map” to attach the geometry to a particular zone or mapping by entering the number of the zone or mapping. Geometries that are attached to an inactive or non-existent zone are not displayed.

• **Show in All “Like” Frames** - Toggle-on this option to display the geometry in all frames sharing the active frame’s dataset.

• **Macro Function** - In the text field, specify the name of the macro function that you wish to link to a particular geometry.

• **Filter** - The Resize filter determines how the image is resized to fit the screen. The following filters are available:
  - **Fast (textures)** - Tecplot 360 uses OpenGL textures to resize the image. This is the fastest option (given sufficient graphics space). However, the accuracy of the image may suffer, especially when reducing an image to a size much smaller than it was before.
Text and Geometry Alignment

- **Pixelated** - Choose this option when the image is much larger than its original size and you want to see the individual pixels. This option is slower than the Fast (textures) for increasing the size of images.
- **Smooth** - There are seven smooth options, all producing slightly different effects. These options are slower than the Fast (textures), but produce better effects for highly reduced images. In general, use the Smooth (Lanczos2) option unless you have specific image processing needs.

The resize filter has no effect on vector-based output, only on the screen and for exported images. Line Color, Line Pattern, Pattern Length, Line Thickness and Fill Color are not available for images.

18 - 3.2 Images and Tecplot 360 Files

For data files, images cannot be included in data files. When you save a data file, even if you specify to include geometries, any images in the plot are not saved.

In layout and style sheet files, the image is referenced from its original location. This reference can be a relative reference or an absolute (as with data files). See Section 24 - 1 “Layout Files, Layout Package Files, Stylesheets” for details.

For layout package files, images are included.

18 - 4 Text and Geometry Alignment

When you have a number of text and geometries, you may want to align them after placing them. You can do this using the alignment tools in the Quick Edit dialog.

You can use these tools as follows:

1. On the Toolbar, choose the Selector tool by clicking.
2. In the workspace, select a text or geometry with which you want to align other objects.
3. On the Sidebar, select the [Quick Edit] button to call up the Quick Edit dialog if it is not already displayed.
4. Drag the mouse to draw a rubber band box around the text and geometries you want to align. The Group Select dialog appears.
5. Select the Text and Geometries check boxes in the Group Select dialog, then select [OK]. Selection handles appear on the selected text and geometries.
6. Use the alignment buttons to align the selected text and geometries with the original select object as follows:
   - ![Left](image)
   - ![Center](image)
   - ![Right](image)
   - ![Top](image)
   - ![Bottom](image)

18 - 5 Text and Geometry Links to Macros

Each text or geometry you create can be linked to a macro function. This macro function is called whenever you hold down the control key and click the right mouse button on the text or geometry. Macro
functions are specified with the “Macro Function” field in the Geometry Details dialog or in the Text Options dialog (accessed by selecting your object and then selecting the [Object Details] button in the Sidebar. For example, if you have pieces of text, each representing a different well, CTRL-right-click on any piece could run a macro that brings up an XY-plot of that well’s data.

In order to be attached to a text or geometry object, the macro function must be a “retained” macro function. A macro function is “retained” via either of the following scenarios:

- running a macro that contains the required macro function.

or

- including it in your tecplot.mcr file.

In both cases, the macro function is defined using the $!MACROFUNCTION macro command. Refer to “$!MACROFUNCTION…$!ENDMACROFUNCTION” on page 162 in the Scripting Guide for additional information.
Part 4 Data Manipulation
Blanking

Blanking allows you to exclude specific portions of zones from being plotted (in other words, selectively display certain cells or data points). In 3D, the result is analogous to a cutaway view. In general, all types of blanking affect all field layers, zones, and all other plot attributes with the following exceptions:

<table>
<thead>
<tr>
<th>Type of Blanking</th>
<th>Attribute Not Blanked</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value Blanking</td>
<td>Derived Objects(^a) (slices, streamtraces, or iso-surfaces)</td>
</tr>
<tr>
<td></td>
<td>FE zones</td>
</tr>
<tr>
<td></td>
<td>Unstructured/Unorganized zones</td>
</tr>
<tr>
<td>IJK Blanking</td>
<td>Derived Objects(^a) (slices, streamtraces or iso-surfaces)</td>
</tr>
<tr>
<td>Depth Blanking</td>
<td>Derived Objects(^a) (slices, streamtraces or iso-surfaces)</td>
</tr>
</tbody>
</table>

Table 19 - 1: Plot attributes not affected by blanking.

a. Derived Objects can opt in or out of blanking. (See Section 19 - 1 "Blanking Settings for Derived Objects").

Blanking settings are only applied to the active frame. Value Blanking settings for multiple frames may be synchronized using frame linking. Refer to Section 2 - 3.4 “Frame Linking” for more information on linking. Blanking results for volume zones depend upon the Surfaces to Plot setting on the Surfaces page of the Zone Style dialog (See Section 7 - 1.2 “Surfaces” for more details).

In the following discussions, the term “cell” is used. In I-ordered datasets, a cell is the connection between two adjacent points. In IJ-ordered datasets, a cell is the quadrilateral area bounded by four neighboring data points. In IJK-ordered datasets, a cell is the six-faced (hexahedral) volume bounded by eight neighboring data points. For finite element datasets, a cell is equivalent to an element.

The forms of blanking are as follows:

- **Value Blanking** - Cells (or portions of cells) of selected zones or line plot mappings are excluded based on the value of the value blanking variable at the data point of each cell or at the point where each cell intersects a constraint boundary.

- **IJK Blanking** - Cells of one IJK-ordered zone are included or excluded based on the index values. (IJK-ordered zones ONLY)
• **Depth Blanking** - Cells in a 3D plot are visually excluded based on their distance from the viewer plane. (3D zones ONLY)

All types of blanking may be used in a single plot. They are cumulative: cells blanked from any of the options do not appear. Value Blanking and Depth Blanking affect selected zones of all types, while IJK Blanking affects a single IJK-ordered zone.

19 - 1 **Blanking Settings for Derived Objects**

You can opt to turn blanking on or off for derived objects (iso-surfaces, streamtraces, or slices) in their respective Details dialogs.

- **Iso-surfaces** - The option is located on the Style page of the Iso-surface Details dialog (located to the right of Iso-Surfaces in the Sidebar). Refer to Section 16 - 3 "Iso-Surface Style" for details.
- **Streamtraces** - The option is located on the Integration page of the Streamtrace Details dialog (located to the right of Streamtraces in the Sidebar). Refer to Section 15 - 1.6 "Integration Page" for details.
- **Slices** - The option is located on the Other page of the Slice Details dialog. Refer to Section 14 - 1.6 "Other Page" for details.

19 - 2 **Value Blanking**

Value blanking allows you to selectively eliminate or trim cells (only) and elements from Line and 3D field plots. For each active constraint, you specify: a value blanking variable, a constant value or another variable, and a conditional statement telling Tecplot 360 to blank that region in relation to the specified variable or constant.
19 - 2.1 Value Blanking for Field Plots

To include value blanking in your plot, go to the Plot menu and select Blankings-Value Blanking. The Value Blanking dialog has the following options:

- Include Value-Blanking - Toggle-on to include value blanking.
- Trim cells along constraint boundary
  - Blank entire cells when: Select one of the following blanking styles:
    - All corners are blanked - Cells are removed from the plot if all of their data points satisfy one or more of the active blanking constraints.
    - Any corner is blanked - Cells are removed from the plot if any of their data points satisfy one or more of the active blanking constraints.
    - Primary value is blanked - Cells are removed from the plot based on the primary value for a cell. The primary value for the cell is dependent upon the zone type and the variable value location, as outlined in the following table.

<table>
<thead>
<tr>
<th>Zone Type</th>
<th>Value Location</th>
<th>Source of Primary Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ordered</td>
<td>Cell Centered</td>
<td>Cell value</td>
</tr>
<tr>
<td>Finite element</td>
<td>Cell Centered</td>
<td>Cell value</td>
</tr>
</tbody>
</table>
Constraint - You can establish up to eight value blanking constraints.

Active - Toggle-on to activate a constraint, such as:

- Blank when - For each constraint, set the following parameters:
  - Select the variable to use for value blanking.
  - Specify one of the following operations, to describe how the blanking variable will be compared to the constant or variable following it.
  - Show Constraint Boundary (ONLY) - Toggle-on to display the line that separates the region of your data that is blanked from the region which is not blanked.

Value Blanking has no effect on edges of an ordered zone. If the edge is turned on, the edge of the entire zone (without value blanking) is plotted.

For finite element data, value blanking can affect the view of previously extracted boundaries because each extracted boundary is a zone (see Section “Boundary Extraction of Finite Element Zones” on page 320).

<table>
<thead>
<tr>
<th>Zone Type</th>
<th>Value Location</th>
<th>Source of Primary Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ordered</td>
<td>Nodal</td>
<td>Lowest indexed corner in the cell</td>
</tr>
<tr>
<td>Finite element</td>
<td>Nodal</td>
<td>First node in the connectivity list for the cell</td>
</tr>
</tbody>
</table>

a. Refer to the Zone/Variable Info Page of the Data Set Information dialog to determine the Zone Type and Value Location.

- It is often convenient to create a new variable for use as the value blanking variable. This allows you to manipulate its values without changing any other part of the plot. You can create a new variable using the Specify Equations dialog (accessed via Data>Alter). See Section 21 - 1.1 “Equation Syntax”.

  - Specify one of the following operations, to describe how the blanking variable will be compared to the constant or variable following it.

Value Blanking has no effect on edges of an ordered zone. If the edge is turned on, the edge of the entire zone (without value blanking) is plotted.
The following figure illustrates the various value blanking modes for plots.

Figure 19-3. The effects of the different value blanking options in field plots for a constraint where a variable is less than or equal to zero. The dark shading indicates the areas that are not blanked.

Clockwise from upper left: Blank cell when primary value is blanked. Blank cell when all corners are blanked. Trim cells along mathematical constraint boundary. Blank cell when any corner is blanked.

19 - 2.2 Blanking Settings for Individual Zones
Using the Effects page of the Zone Style dialog (accessed via the Plot menu or the Sidebar), you can turn value blanking on and off for individual zones. Simply, highlight the zone(s), and select “Yes” or “No” from the Use Value Blanking column.

19 - 2.3 Line Plot Blanking
For line plots, blanking excludes data points from consideration in the resulting plot. On a global scale, only value blanking is available. To plot specific index ranges, you can use the Indices page of the Mapping Style dialog to limit index ranges per mapping. The Curves page can provide another form of blanking by allowing you to limit the range of the independent variable for individual mappings.

Figure 19-4 shows two plots. The original data for the plots contain some “bad” data points. The bad data points were identified as those with a Y-value greater than 0.6. The plot on the left uses all data points, including the bad data points, to draw a curve. The plot on the right has filtered out the bad data points by
using value blanking, where all points are removed if \( Y > 0.6 \). Blanking does not necessarily have to be on the independent or dependent variable.

**Figure 19-4.** XY Line plots showing the effect of value blanking.

### 19 - 3 IJK Blanking

IJK Blanking is available for 2D and 3D ordered zones, in the 2D and 3D Cartesian plot types. IJK Blanking removes a selected portion of one IJK-ordered zone from the plot. This allows you to create cutaway plots: plots showing the exterior of some dataset with a section “cut away” to show the interior, such as the plot shown in Figure 19-5.

To use IJK-blanking, you must have a 2D or 3D IJK-ordered zone, and the current plot type must be 2D or 3D Cartesian. Unlike Value Blanking, which operates on all zones within a single frame, IJK Blanking can only be used on a single zone within a frame.
Figure 19-5. A cutaway plot created with IJK Blanking.

To use IJK-blanking, select Blankings-IJK Blanking from the Plot menu.

The IJK Blanking dialog has the following options.

- **Include IJK Blanking** - Toggle-on to include IJK Blanking in your plot.
- **Domain** - Specify the domain of the IJK Blanking by choosing one of the following options:
  - **Interior** - Cells within the specified index ranges are blanked. Those outside are plotted. This creates a “hole” in the zone. The left side of Figure 19-6 shows an ordered zone with IJK Blanking with Interior domain.
• **Exterior** - Cells outside the specified index ranges are blanked. Those inside are plotted. Exterior plots a sub-zone of the zone. The right side of Figure 19-6 shows an ordered zone with IJK Blanking with Exterior domain.

![Figure 19-6. IJK Blanking with Interior domain (left) and Exterior domain (right).](image)

- **Zone** - Select the zone to apply IJK Blanking to. The zone must be IJK-ordered. You may select only one zone at a time.
- **IJK - Ranges** - Specify the format in which you will specify the index ranges by selecting one of the following option buttons:
  - **Select IJK-Ranges Using Index Values** - Specify the I, J, and K-index ranges using absolute index values.
  - **Select IJK-Ranges Using% of Max** - Specify the I, J, and K-index ranges as start and end percentages of the maximum index. For example, you could blank the middle third of a dataset by setting the start percentage to 33.3 and the end percentage to 66.6.

When you save a layout, macro, or stylesheet, the IJK Blanking index ranges are stored as the percentage of the maximum index regardless of how you chose to enter them. This way, one file can be used for different zone sizes.

## 19 - 4 Depth Blanking

Depth Blanking removes cells in a 3D plot based upon how close or far they appear from the screen. Turn on Depth Blanking by selecting **Blanking>Depth Blanking** from the *Plot* menu.

![Depth Blanking](image)

Activate depth blanking with the following options:

- **Include Depth Blanking** - Toggle-on to include depth blanking.
- **Blank from Front (%)** - Blank cells appearing closer to the viewer than this plane. The value entered is the plane position in percentage of depth from the closest corner of the bounding box of the data to the furthest corner of the bounding box.

At the default of zero, the plane is at the depth of the closest corner of the bounding box. No cells on the front of the plot are blanked. At 50, the front half of the plot will be blanked. In particular, cells closer to the viewer than the front of the blanking plane, and cells further from the viewer than the blanking plane will not be blanked.
**Blank from Back (%)** - Blank cells appearing farther from the viewer than this plane. The value entered is the plane position in percentage of depth from the furthest corner of the bounding box of the data to the closest corner of the bounding box.

At the default of zero, this plane is at the depth of the furthest corner of the bounding box. No cells on the back of the plot will be blanked. At 50, the back half of the plot will be blanked.
Surface Clipping

Using slices, you can clip off portions of your displayed 3D Cartesian plot. This surface clipping allows you to view the inside of a volume, with selectively clipped zones, iso-surfaces, slices, and/or streamtraces, without changing the viewer position.

You can use up to six slices to clip at a time, along the X, Y, or Z axes. Each zone in your plot can obey all, a selection, or none of the clipping slices.

Initially, blanking and clipping may appear to accomplish the same objectives. These simple summaries can help you determine which feature to use:

- **Blanking** With blanking, you can selectively omit specific data points based on their value (Value Blanking), boundaries defined by IJK-ordered zones (IJK Blanking), or all cells a specified distance from the viewer plane (Depth Blanking). Blanking cannot be interactively adjusted as surface clipping can.

- **Surface Clipping** With surface clipping, you can clip off part of the display of your plot without affecting the viewer position, and you can interactively adjust the slice that clips off part of the display. Surface clipping can only clip on the X, Y, or Z axes.

Also, while blanking operates along cell boundaries, surface clipping operates exactly at the indicated position. Because of this, clipping allows you to display part of cells, as desired. This behavior creates a smooth “cut” in the display.

*Figure 20-1 shows an example of a selectively clipped display. In this figure, the slice clips the surface zones, but does not clip either the zones inside the cylinder or the streamtraces.*
Figure 20-1. The internal_flow.lay tutorial layout with a clipped surface. The streamtraces and zones inside the cylinder are not clipped.

20 - 1 Creating a Clipping Slice

To create a clipping slice, insert and position a slice, and then select a Clip property from the Clip menu on the Position page of the Slice Details dialog, as described following. For more information about slices, see “Slices”.

1. In your plot that you wish to clip, insert a slice. You can do this by selecting the Slice tool , or by using the Slice Details dialog, accessible in the Plot menu.
2. Open the Slice Details dialog, either by selecting the Details button next to Slices in the Sidebar, or by selecting “Slices” from the Plot menu.
3. On the Position page of the Slice Details dialog, choose a Clip property from the Clip menu. You can choose to clip “Below Primary Slice”, “Above Primary Slice”, or “None” (this default option will not use the slice to clip). See Interactively Created Slices: “Position Page” for more information.
4. To further adjust the position of your clipping slice(s), select the Slice tool and then drag the slice as desired on your plot. You can adjust the position whether or not the primary slice is shown.

You can also adjust the position of the clipping slice (whether or not the slice is shown) by moving the position slider for the primary slice in the Slice Details dialog.

20 - 2 Including Plot Objects in Clipping

To instruct different objects (slices, streamtraces, iso-surfaces) in your plot to obey or ignore the clipping slice(s), open the appropriate Details dialog and toggle-on or toggle-off “Obey Clipping Settings” for that object. When “Obey Clipping Settings” is toggled-on for an object, that object will be clipped by any clipping slices that intersect it. Use these locations to change the clipping preferences for each object:

- **Slices** To adjust the clipping preferences for slices, use the Other page of the Slice Details dialog, accessible by selecting “Slices” from the Plot menu or by selecting the Details button next to Slices in the Sidebar. For more information, see Interactively Created Slices: “Other Page”.
- **Streamtraces** To adjust the clipping preferences for streamtraces, use the Integration page of the Streamtrace Details dialog, accessible by selecting “Streamtraces” from the Plot menu or by selecting the Details button next to Streamtraces in the Sidebar. For additional information, refer to the Streamtrace Details dialog: “Integration Page”.
- **Iso-Surfaces** To adjust the clipping preferences for iso-surfaces, use the Style page of the Iso-Surface Details dialog, accessible by selecting “Iso-Surfaces” from the Plot menu or by selecting the Details button next to Iso-Surfaces in the Sidebar. For more information, see 16 - 3 “Iso-Surface Style”.

Zones require a slightly different process to customize which clipping settings they obey. To adjust the clipping preferences for zones, use the Clip By button on the Effects page of the Zone Style dialog. To open the Zone Style dialog, select the Zone Style button in the Sidebar, or select “Zone Style” from the Plot menu.
On the Effects page of the Zone Style dialog, select the zone that you wish to adjust, select the Clip By button, and select "All" to instruct the zone to obey all clipping settings. You can also select "None" to instruct that zone to ignore all clipping settings, or select "Enter Clip Groups" to assign which clip settings that zone will obey. (You can enter any of the clip groups 1-6.)

Since surface clipping can only be used with 3D Cartesian plots, the Clip By button appears on the Effects page of the Zone Style dialog only when you are using a 3D Cartesian plot type.
Data Operations

Plots in Tecplot 360 rely on the datasets attached to each frame. You can modify, create, transform, interpolate, duplicate, and delete the data in the current dataset using the Data menu. You can also use the data operation capabilities of Tecplot 360 to create plots of analytical functions. By using Tecplot 360's layout files, macro capabilities, and/or equation files, you can create complex data operations that can be repeated on different datasets.

Changes to the dataset within Tecplot 360 do not affect the original data file(s). You can save the modified data to a data file by selecting “Write Data File” from the File menu. When you save a layout file, a journal of data operations is saved and those operations are repeated when the layout file is read at a later time. If the data in the file has changed, or the data file is overridden with a different file, the operations are applied to the new data. Alternatively, any datasets that have been modified are also saved to data files (see Section 24 - 1 “Layout Files, Layout Package Files, Stylesheets” for details).

21 - 1 Data Alteration through Equations

Use the Specify Equations dialog to alter data in existing zones. The dialog allows you to change the values of entire variables or specific data points. You can also use this dialog to create new variables.

Changes made to the dataset in the Specify Equations dialog are not made to the original data file. You can save the changes by saving a layout file or writing the new data to a file. Saving a layout file will keep your data file in its original state, but use journaled commands to reapply the equations.
To modify your dataset, go to the Data menu and select Alter>Specify Equations.

The Specify Equations dialog has the following options and fields:

- **Equations** - Enter the equation(s) using the syntax described in Section 21.1 “Equation Syntax”.
- **Zones to Alter** - Select whether to alter: all zones, all active zones, a range of zones, or no zones.

If you are creating a new variable, all zones must be selected since all zones in a dataset must have the same variables defined at each data point.

- **Index Ranges** - Select the index ranges to alter in the selected zones. You may skip this step if you want to apply the equation to all points of the selected zones. Use the special value \( M_x \) or \( M_x - 1 \) to specify the maximum index. You can also use the values \( M_x - 2 \) and so forth.

For Ordered Data, the I-Index, J-Index, and K-index options correspond to the I, J, and K values in the dataset. For finite element data, the I-Index corresponds to the range of nodes and the J-Index corresponds to the cell-centered values. The K-index has no bearing on finite element data.

If you are creating a new variable, the new variable’s value is set to zero at any index value that is skipped.

- **New Var Data Type** (if applicable) - Select the data type of the new variable. The following data types are available:
  - **Auto** - Tecplot 360 assigns the data type based upon the variables used in the right-hand side of the equation.
  - **Single** - Four-byte floating point values.
  - **Double** - Eight-byte floating point values.
  - **Long Int** - Four-byte integer values.
Data Alteration through Equations

- **Short Int** - Two-byte integer values.
- **Byte** - One-byte integer values (zero to 255).
- **Bit** - Either zero or one.

- **New Var Location** (if applicable) - Select the location of the new variable. The options are:
  - **Auto** (default) - “Auto” is set to node unless all variables in the equation are located at
    the cell center.
  - **Node**
  - **Cell-Center**

- **Data Set Info** - Launches the Data Set Info dialog. See Section 5 - 4 “Dataset Information” for
  more information.

- **Remove <>’s** - Remove restrictions from all equations. See Section 21 - 1.8 “Equation
  Restriction” for more information.

- **Save Equations** - Save all equations in the Equation(s) field to a file.

- **Load Equations** - Load an equation file.

- **Compute** - Select the [Compute] button to alter the data. If an error occurs during the
  alteration (because of division by zero, overflow, underflow, and so on), an error message is
  displayed and all of the zones are restored to the state they were in before the bad equation
  was processed.

  For example, if you have three equations (A, B, and C), and equation B contains an error, the
  final state is the result of processing equation A.

21 - 1.1 Equation Syntax

You can enter multiple equations in the Equation(s) text field of the Specify Equations dialog. Each
equation occupies one line of the text field, and each equation is applied to all specified zones and data
points before subsequent equations are computed.

Tecplot 360 equations have the following form:

\[ LValue = F(RValue1, RValue2, RValue3,...) \]

Where:

- **F()** - A mathematical expression.
- **LValue** - An existing or new variable.
- **RValueN** - A value (such as a constant, variable value, or index value).

If \( LValue \) already exists in the dataset of the active frame, the equation is used to modify that variable. If the
variable does not already exist, the equation is used to create a new variable as a function of existing
variables.

There may be any number of spaces within the equation. However, there cannot be any spaces between
the letters of intrinsic-function names nor for variables referred to by name. (See Section “Equation
Operators and Functions”.)

Equation Variables and Values

A variable is specified in one of the following ways:

- **Its order in the data file** - A variable may be referenced according to its order in the data file,
  where \( V1 \) is the first variable in the data file, \( V2 \) is the second, and so forth.

307
To create a new variable using this specification, you must specify the number of the next available variable (i.e. if there are 5 variables in the dataset), the new variable must be called V6. You will receive an error message, if you attempt to assign an invalid variable number.

You can confirm the number and order of variables in the data file by selecting the [Data Set Info] button in the Specify Equations dialog and going to the Zones/Var page of the Data Set Information dialog. The variables in the dataset are listed on the right-hand side of the page.

• **By its name** - To reference a variable by its name, enclose the name with curly braces ("{" and "}"). For example, to set V3 equal to the value of the variable named R/RFR, you can enter:

\[
V3 = \{R/RFR\}
\]

Variable names are not case sensitive. Leading and trailing spaces are also not considered. However, spaces within the variable name are significant. If two or more variables have the same name, the first variable is used when the variable is referred to by name. So, if both V5 and V9 are named R/rfr, V5 is used. The curly braces can also be used on the left-hand side of the equation. In this case, if a variable with that name does not exist, a new variable is created with that name for all zones.

• **By a letter code** - Variables and index values may be referenced by the following letter codes:

  - **I** - For I-ordered and finite-element data:

    | Finite-element | Ordered               |
    |----------------|-----------------------|
    | Nodal          | I is equal to I       |
    |                | I is equal to the I-  |
    |                | index number          |
    | Cell-centered  | J is equal to the     |
    |                | element number        |
    |                | J is equal to the J-  |
    |                | index number          |

  - **J** - For J-ordered and finite-element:

    | Finite-element | Ordered               |
    |----------------|-----------------------|
    | Nodal          | J is equal to the     |
    |                | node number           |
    |                | J is equal to the J-  |
    |                | index number          |
    | Cell-centered  | J is equal to the     |
    |                | I                      |
    |                | J is equal to the J-  |
    |                | index number          |

  - **K** - For K-ordered and finite-element:

    | Finite-element | Ordered               |
    |----------------|-----------------------|
    | Nodal          | K is equal to I       |
    |                | K is equal to the K-  |
    |                | index number          |
    | Cell-centered  | K is equal to I       |
    |                | K is equal to the K-  |
    |                | index number          |

  - **X** - The variable assigned to the X-axis. In XY-plots, all active mappings must have the same X-variable in order for this variable name to be valid.
  
  - **Y** - The variable assigned to the Y-axis. In XY-plots, all active mappings must have the same Y-variable in order for this variable name to be valid.
  
  - **Z** - The variable assigned to the Z-axis (if in 3D Cartesian).
Data Alteration through Equations

• A - The variable assigned to the Theta-axis for Polar plots. For this variable to be valid, the plot type must be set to Polar Line. In addition, all active mappings must have the same Theta-variable.
• R - The variable assigned to the R-axis for Polar plots. The plot type must be Polar Line, and all active mappings must have the same R-variable for this variable name to be valid.
• U - The X-component of vectors (if defined).
• V - The Y-component of vectors (if defined).
• W - The Z-component of vectors (if defined).
• B - The value-blanking variable for the first active constraint (if applicable).
• C - The contour variable for contour group 1 (if defined in the Contour Details dialog).
• S - The scatter-sizing variable (if defined in the Scatter Size/Font dialog).
• SOLUTIONTIME - The current solution time.

Letter codes may be used anywhere on the right-hand side of the equation. Do not enclose them in curly braces.

Those letter codes representing variables (all letter codes except I, J, and K) may be used on the left-hand side of the equation as well.

The variables referenced by the letter codes are for the current frame.

Equation Operators and Functions

Binary Operators

In an equation, the valid binary operators are as follows:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
</tr>
<tr>
<td>**</td>
<td>Exponentiation</td>
</tr>
</tbody>
</table>

Binary operators have the following precedence:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Precedence</th>
</tr>
</thead>
<tbody>
<tr>
<td>**</td>
<td>Highest precedence</td>
</tr>
<tr>
<td>*/</td>
<td>Lowest precedence</td>
</tr>
</tbody>
</table>

Operators are evaluated from left to right within a precedence level.

Functions

The following functions are available (except where noted, all take a single argument):

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SIN</td>
<td>Sine (angle must be specified in radians)</td>
</tr>
<tr>
<td>COS</td>
<td>Cosine (angle must be specified in radians)</td>
</tr>
</tbody>
</table>
Notes

• LOG and ALOG are equivalent functions, as are LOG10 and ALOG10.
• Variables input into trigonometric functions must be in units of radians.
• To call an intrinsic function, place its argument within parentheses, i.e. to set V4 to the arctangent of V1, use:
  \[ V4 = \text{ATAN}(V1) \]

First and second-derivative and difference functions are also available. Refer to Section 21 - 1.2 "Derivative and Difference Functions".

21 - 1.2 Derivative and Difference Functions

The derivative functions can be called in the same manner as described above for intrinsic functions. Derivative and difference functions can be calculated with respect to the following variables:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Definition</th>
<th>Restricted to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>x, y, z</td>
<td>variable assigned to the x-axis, y-axis or z-axis, respectively</td>
<td>XY Line®, or 3D</td>
</tr>
<tr>
<td>a</td>
<td>variable assigned to the theta-axis</td>
<td>Polar Line</td>
</tr>
<tr>
<td>r</td>
<td>variable assigned to the radial-axis</td>
<td>Polar Line</td>
</tr>
<tr>
<td>i, j, k</td>
<td>index range</td>
<td>Ordered Zones</td>
</tr>
</tbody>
</table>

Table 21 - 1: Derivative and Difference Function Variables

a. If you have multiple x-axes or y-axes in an XY line plot, the variables assigned to the x and y-axis in the first available mapping will be used.
The complete set of first and second-derivative and difference functions are listed below:

The derivative function \( \frac{d}{dx} \) is used to calculate \( \frac{d^2}{dx^2} \) calculates \( \frac{d^2}{dxy} \) calculates.

The difference functions \( d_1 \), \( d_{12} \), and so forth, calculate centered differences of their argument with respect to the indices I, J, and K based on the indices of the point. For example:

\[
\frac{d_1}{d_{ij}}(V) = \frac{V_{i+j} - V_{i-j}}{2}
\]

For ordered zones, spatial derivative functions are calculated using the chain rule with difference functions. For example:

\[
\frac{\partial \phi}{\partial x} = \frac{\partial \phi}{\partial i} \frac{\partial i}{\partial x} + \frac{\partial \phi}{\partial j} \frac{\partial j}{\partial x} + \frac{\partial \phi}{\partial k} \frac{\partial k}{\partial x}
\]

or:

\[
ddx(\phi) = ddi(\phi) \cdot ddx(i) + ddy(\phi) \cdot ddx(j) + ddz(\phi) \cdot ddx(k)
\]

The spatial derivatives of indices, such as \( d_1(i) \), are calculated from their inverses, such as \( d_1(x) \), using standard curvilinear coordinate transformations.

For finite-element zones, spatial derivatives are calculated using the Moving Least-Squares technique. The variable at a particular node or cell center is assumed to vary quadratically in space about that point, and least-squares is used with all nodes surrounding the point to fit a polynomial function, whose coefficients then become the first and second derivatives of the variable.

### Boundary Values

Boundary values for first-derivative and difference functions (\( ddx, ddy, ddz, ddi, djej, \) and \( ddk \) of ordered zones are evaluated in one of two methods: simple (default) or complex\(^1\).

---

\(^1\) The \$INTERFACE parameter in the configuration file tecplot.cfg selects the method to use:

- \$INTERFACE DATA (DERIVATIVEDBOUNDARY=SIMPLE)
- Change the parameter SIMPLE to COMPLEX to use the complex boundary condition.
For simple boundary conditions, the boundary derivative is determined by the one-sided first derivative at the boundary. This is the same as assuming that the first derivative is constant across the boundary (i.e., the second derivative is equal to zero).

For complex boundary conditions, the boundary derivative is extrapolated linearly from the derivatives at neighboring interior points. This is the same as assuming that the second derivative is constant across the boundary (i.e., the first derivative varies linearly across the boundary).

For second-derivatives and differences ($\frac{\partial^2}{\partial x^2}, \frac{\partial^2}{\partial y^2}, \frac{\partial^2}{\partial z^2}, \frac{\partial^2}{\partial x \partial y}, \frac{\partial^2}{\partial y \partial z}, \frac{\partial^2}{\partial z \partial x}, \frac{\partial^2}{\partial x \partial y \partial z},$ and $\frac{\partial^2}{\partial y \partial z \partial x}$), these boundary conditions are ignored. The boundary derivative is set equal to the derivative that is one index in from the boundary. This is the same as assuming that the second derivative is constant across the boundary.

The use of derivative and difference functions is restricted as follows:

- Derivatives and differences for IJK-ordered zones are calculated for the full 3D volume. The IJK-mode for such zones is not considered.
- If the derivative cannot be defined at every data point in all the selected zones, the operation is not performed for any data point.
- Derivative functions are calculated using the active frame's axis assignments. Be careful if you have multiple frames with different variable assignments for the same dataset.
- Derivatives at the boundary of two zones may differ since Tecplot 360 operates on only one zone at a time while generating derivatives.

### 21 - 1.3 Integration

Use the Analyze menu to calculate integrals with Tecplot 360. See Section 22 - 7 “Performing Integrations” for information.

### 21 - 1.4 Auxiliary Data

You may use auxiliary data containing numerical constants in equations. The syntax for using auxiliary data in equations is:

\[
\text{AUXZONE}[\text{nnz}]:\text{Name} \\
\text{AUXDATASET}:\text{Name} \\
\text{AUXFRAME}:\text{Name} \\
\text{AUXVAR}[\text{nnv}]:\text{Name} \\
\text{AUXLINEMAP}[\text{nnm}]:\text{Name}
\]

where

- \text{nnz} = the zone number(s)
- \text{nnv} = the variable number(s)
- \text{nnm} = the line map number(s)
- \text{Name} = name of the auxiliary data

For example, a dataset auxiliary data constant called \text{Pref} would be referenced using \text{AUXDataset:Pref}.

Equations using this auxiliary data might appear as:

\[
(P) = (P_{\text{NonDim}}) \times \text{AUXDataset:Pref}
\]
21 - 1.5 Zone Number Specification

By following a variable reference with square brackets (“[” and “]”), you can specify a specific zone from which to get the variable value.

The zone number must be a positive integer constant less than or equal to the number of zones. The zone specified must have the same structure (I, J, or IJK-ordered or finite element) and dimensions (I_max, number of nodes) as the zone(s) the equation(s) will be applied to.

If you do not specify a zone, the zone modified by the left-hand side of the equation is used.

Zone specification works only on the right-hand side of the equation.

21 - 1.6 Index Specification

By following a variable reference with parentheses, you can specify indices for ordered data only. Indices can be absolute or an offset from the current index.

Index offsets are specified by using the appropriate index “i”, “j” or “k” followed by a “+” or “-” and then an integer constant. Any integer offsets may be used. If the offset moves beyond the end of the zone, the boundary value is used. For example, \( V3(i+2) \) uses the value \( V3(\text{I\_Max}) \) when \( i=\text{I\_Max}-1 \) and \( i=\text{I\_Max} \). \( V3(i-2) \) uses the value of \( V3(1) \) when \( i=1 \) or \( i=2 \).

Absolute indices are specified by using a positive integer constant only. For example, \( V3(2) \) references \( V3 \) at index 2, regardless of the current i index.

If the indices are not specified, the current index values are used.

21 - 1.7 Variable Sharing Between Zones

For zones with the same structure and index ranges, you can set a variable to be shared by specifying that the variable for those zones have the values from one zone. For example, if zones 3 and 4 have the same structure and you compute \( V3=V3[3] \) for zones 3 and 4, \( V3 \) will be shared.

Subsequent alteration of the variables may result in loss of sharing.

21 - 1.8 Equation Restriction

The zone and index restrictions specified in the Specify Equations dialog can be overridden on an equation by equation basis. To specify restrictions for a single equation add the colon character (:) at the end of the equation followed by one or more of the following:

<table>
<thead>
<tr>
<th>Equation Restrictor</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>(&lt;z=&lt;set&gt;&gt;)</td>
<td>Restrict the zones.</td>
</tr>
<tr>
<td>(&lt;i=start[,end[,skip]]&gt;&gt;)</td>
<td>Restrict the i-range.</td>
</tr>
<tr>
<td>(&lt;j=start[,end[,skip]]&gt;&gt;)</td>
<td>Restrict the j-range.</td>
</tr>
</tbody>
</table>
For example, to add one to X in zones 1, 3, 4, and 5:

\[ X = X + 1; \text{\texttt{K=start[1,3-5][1]}} \]

The following example adds one to X for every other I-index. Note that zero represents the maximum index.

\[ X = X + 1; \text{\texttt{I=1,0,2}} \]

The next example creates a new variable of type Byte:

\[ \text{\texttt{NewV}} = X - Y; \text{\texttt{D=Byte}} \]

Select the [Remove 's] button to remove Equation restrictions.

### 21 - 1.9 Macros and Equations

Tecplot 360 allows you to put your equations in macros. In fact, we sometimes refer to a macro with just equations as an equation file. An equation in a macro file is specified using the $!ALTERDATA macro command. Equation files may also include comment lines and must start with the comment $!MC 1120, like other macro files. If you are performing complex operations on your data, and/or the operations are repeated frequently, equation files can be very helpful.

You can create equation files from scratch using an ASCII text editor, or you can create your equations interactively by using the Specify Equations dialog and then save the resulting equations. The standard file name extension for equation files is .eqn.

For example, you might define an equation to compute the magnitude of a 3D vector. In the Specify Equations dialog, it would have the following form:

\[ \text{\texttt{(Mag) = sqrt(U*U + V*V + W*W)}} \]

In a macro file, it would have the following form:

\ [%!MC 1120 \]
\ [%$!ALTERDATA \]
\ [%EQUATION = "\{(Mag) = sqrt(U*U + V*V + W*W)\}" \]

The interactive form of the equation must be enclosed in double quotes and supplied as a value to the EQUATION parameter of the $!ALTERDATA macro command.

To read an equation file, select Load Equations on the Specify Equations dialog. In the Load Equation File dialog, select an equation file that contains a set of equations to apply to the selected zones of your data. The equations in the equation file will be added to the list of equations in the dialog. All equations are applied to your data when you click Compute.

Equations in equation files may be calculated somewhat differently depending on whether the computation is done from within the Specify Equations dialog or by running the equation file as a macro. When loaded into the Specify Equations dialog, equations that do not contain zone or index restrictions use the current zone and index restrictions shown in the dialog. When processed as a macro file, the equations apply to all zones and data points. To include zone and index restrictions, you must include them in the equation file as part of the $!ALTERDATA command. Refer to the Scripting Guide for more information on working with the $!ALTERDATA command.
21 - 1.10 Equation Examples

In the following equation, \( V_1 \) (the first variable defined in the data file) is replaced by two and a half times the existing value of \( V_1 \):

\[ V_1 = 2.5 \times V_1 \]

The following equation sets the value of a variable called \( \text{Density} \) to 205. A new variable is created if a variable called \( \text{Density} \) does not exist.

\[ (\text{Density}) = 205 \]

In the next equation, the values for \( Y \) (the variable assigned to the Y-axis) are replaced by the negative of the square of the values of \( X \) (the variable assigned to the X-axis):

\[ Y = -X^2 \]

The following equation replaces the values of \( V_3 \) with the values of \( V_2 \) rounded off to the nearest integer. A new variable is created if there are only two variables currently in the data set.

\[ V_3 = \text{round}(V_2) \]

In the following equation, the values of the fourth variable in the data set are replaced by the log (base 10) of the values of the third variable.

\[ V_4 = \log_{10}(V_3) \]

Suppose that the third and fourth variables are the X and Y-components of velocity and that there are currently a total of five variables. The following examples create a new variable \( V_6 \) that is the magnitude of the components of velocity.

\[ V_6 = (V_3^2 + V_4^2)^{0.5} \]

\[ V_6 = \sqrt{V_3^2 + V_4^2} \]

You can also accomplish the above operation with the following equation (assuming you have already defined the vector components for the active frame):

\[ \text{Mag} = \sqrt{U^2 + V^2} \]

The following equation sets the value of a variable named \( \text{diff} \) to the truncated value of a variable named \( \text{depth} \) subtracted from the existing value of \( \text{depth} \):

\[ \{\text{diff}\} = \{\text{depth}\} - \text{trunc}(\{\text{depth}\}) \]

In the next equation, \( C \) (the contour variable) is set to the absolute value of \( S \) (the scatter-sizing variable), assuming both \( C \) and \( S \) are defined:

\[ C = \text{abs}(S) \]

In the following example, a new variable is created (assuming that only seven variables initially existed in the data file). The value for \( V_8 \) (the new variable) is calculated from a function of the existing variables.

\[ V_8 = \sqrt{(V_1^2 + V_2^2 + V_3^2)/(287.0 \times V_4 \times V_6)} \]

The above operation could have been performed in two simpler steps as follows:

\[ V_8 = V_1 \times V_2 \times V_3 \]

\[ V_8 = \sqrt{V_8/(287.0 \times V_4 \times V_6)} \]

The following equation replaces any value of a variable called \( \text{TIME} \) that is below 5.0 with 5.0. In other words, the values of \( \text{TIME} \) are replaced with the maximum of the current value of \( \text{TIME} \) and 5.0:

\[ \{\text{TIME}\} = \max(\{\text{TIME}\}, 5) \]

The following equation creates variable \( V_4 \) which has values of \( X \) at points where \( X \neq 0 \); at other points, it has a value of zero (this does not affect any values of \( X \)):

\[ V_4 = \pi \times \text{abs}(X, 0) \]
Another example using intrinsic functions is shown below:

\[ V_8 = 55.0 \times \sin(V3 \times 3.14/180.0) + \log(V4^{3/(v1+1.0)}) \]

You can also reference the I, J, and K-indices in an equation. For example, if you wanted to cut out a section of a zone using value blanking, you could create a new variable that is a function of the I and J-indices (for IJ-ordered data). Then, by using value-blanking, you could remove certain cells where the value of the value-blanking variable was less than or equal to the value blanking cut-off value.

Here is an example for calculating a value-blanking variable that is zero in a block of cells from I=10 to 30, and is equal to one in the other cells:

\[ V_3 = \min((\max(I,30) - \min(I,10) - 20),1) \]

The following equation replaces all values of \( Y \) with the difference between the current value of \( Y \) and the value of \( Y \) in zone 1. (If zone 1 is used for the data alteration, the new values of \( Y \) will be zero throughout that zone.)

\[ Y = Y - Y[1] \]

The following equation replaces the values of \( V3 \) (in an IJ-ordered zone) with the average of the values of \( V3 \) at the four adjacent data points:

\[ V3 = (V3(i+1,j)+V3(i-1,j)+V3(i,j+1)+V3(i,j-1))/4 \]

The following equation sets the values of a variable called \( \text{TEMP} \) to the product of the values of a variable called \( T \) measured in four places: in zone 1 at two index values before the current data point, in the current zone at an absolute index of three, in zone 4 at the current data point, and in the current zone at the current data point.

\[ \{\text{TEMP}\} = (T)[1](i-2) \times (T)(3) \times (T)[4] \times (T) \]

Indices may be combined with zone specifications. The zone is listed first, then the index offset. For example:

\[ V3 = V3 - V3[1](i+1) \]
\[ Y = Y[1] - Y[2](1) + Y(1,j+3) + Y \]

Referencing variables by letter code:

\[ V3 = I + J \]
\[ V4 = \cos(X) \times \cos(Y) \times \cos(Z) \]
\[ \{\text{DIST}\} = \sqrt{U^2 + V^2 + W^2} \]
\[ \{\text{TEMP}\} = \min(B,1) \]

Specifying the Zone number for a given variable:

\[ V3 = V3 \times V3[1] \]
\[ \{\text{TEMPADJ}\} = (\{\text{TEMP}\}[7] \times \{\text{ADJ}\}) \]
\[ V8 = V8[19] \times 2^c[21] \times \{R/T\}[18] \]

### 21 - 2 Data Smoothing

You can smooth the values of a variable of any zone (in either 2D or 3D) to reduce “noise” and lessen discontinuities in data. Smoothing can also be used after inverse-distance interpolation to reduce the artificial peaks and plateaus. Each pass of smoothing shifts the value of a variable at a data point towards an average of the values at its neighboring data points.
To smooth data in Tecplot 360, select **Alter>Smooth** from the **Data** menu.

The **Smooth** dialog has the following options:

- **Zone** - Specify the zone to smooth from the **Zone** drop-down. The zone should not intersect itself.
- **Variable** - Select the variable to smooth. For the **XY Line** plot type, the variable must be a dependent variable for one active mapping for that zone.
- **Number of Passes [OPTIONAL]** - Specify the number of smoothing passes to perform. The default is 1. A greater number of passes results in greater smoothing, but takes more time.
- **Coefficient [OPTIONAL]** - Specify the relaxation factor for each pass of smoothing. Enter a number between zero and one (exclusively). Large numbers flatten peaks and noise quickly. Small numbers smooth less each pass, rounding out peaks and valleys rather than eliminating them.
- **Boundary [OPTIONAL]** - Select the boundary conditions by which to smooth from the **Boundary** drop-down.
  - **Fixed** - The points at the boundary are not changed in value. For finite element data, only fixed boundary conditions may be used.
  - **First Order** - The points at the boundary are smoothed based on the assumption that the first derivative normal to the boundary is constant. This will tend to cause contour lines of the smoothed variable to be perpendicular to the boundary.
  - **Second Order** - The points at the boundary are smoothed based on the assumption that the second derivative normal to the boundary is constant. This option may overextrapolate derivatives at the boundary.
- **Compute** - Select the [Compute] button to perform the smoothing. While the smoothing is underway, the progress is displayed in the status bar, and the [Compute] button changes to a [Stop] button, allowing you to interrupt the smoothing. If you select [Stop] during the smoothing process, you will interrupt the smoothing, and Tecplot 360 will report back the number of passes completed.

### 21 - 2.1 Limitations to Smoothing

- Finite element zones cannot be smoothed with anything other than Fixed boundary conditions.
- Tecplot 360 uses the active frame’s axis assignments to determine the variables to use for the coordinates in the smoothing, and also to determine whether the smoothing should be done with **XY Line**, **Polar**, and 2 or 3D **Cartesian** plot types. Be careful if you have multiple frames with different variable assignments for the same dataset.
- Any axis scaling is ignored by Tecplot 360 while smoothing.
- For I-ordered or finite element line segment zones, the active frame can be in the **XY Line**, or 3D **Cartesian** plot types. In **XY Line**, the variable must be the dependent variable of one active mapping for that zone.
• For IJ-ordered, finite element triangle, or finite element quadrilateral zones, the active frame can be a 2D or 3D Cartesian plot type, but you cannot smooth the variables assigned to the X and Y-axes in Cartesian.

• For IJK-ordered, finite element tetrahedral, or finite element brick zones, the plot type must be 3D Cartesian, and you cannot smooth the variables assigned to the X, Y, and Z-axes. The IJK-mode is ignored. The zone is smoothed with respect to the entire 3D volume.

• Smoothing does not extend across zone boundaries. If you use a boundary condition option other than Fixed (such that values along the zone boundary change), contour lines can be discontinuous at the zone boundaries.

• Smoothing is performed on all nodes of a zone, and disregards value blanking.

21 - 3 Fourier Transform

The Fourier transform feature (Data>Fourier Transform) allows you to transform one-dimensional ordered linear data into the frequency domain. One or more dependent variables in the data set are taken to be a representation of some function of a single independent variable, such as time, and this function is decomposed into its constituent sine waves. Variables are added to the data set to indicate these waves’ frequency in Hertz, phase, and amplitude in each selected zone. The dependent variables for a Fourier transform must be single-valued. The independent variable domain need not be constantly spaced; data will be resampled linearly if necessary.

The resulting frequency, amplitude, and phase variables (three for each dependent variable) are stored in Fourier transform result zones, one for each source zone. The result zones are given the name "Fourier Transform" followed by text indicating the source zone, independent variable, and window function used to calculate them. Result zones are assigned new time strands using the same groupings as the source zones if they belong to time stands; otherwise the resulting zones are static.

The result variables in the result zone are given the names Frequency, Amplitude and Phase followed by text indicating the dependent variable involved in the calculation. If the independent variable is non-uniform, Frequency is a uniform interpolation of the original data.

Newly-created zones are assigned passive variables for all variables that previously existed in the dataset, and all previously-existing zones are assigned passive variables for all new variables created by the Fourier transform.
Coordinate Transformation

- **Independent Variable** - The variable used as the frequency domain. If this variable’s spacing is non-uniform, this variable is used in conjunction with each dependent variable for interpolation to create a uniform frequency for the Fourier transform.
- **Window Function** - A function applied to the dependent variables before performing the transform (but after interpolation) to taper the data. Rectangular, triangular, Hann, and Hamming filters are provided.
- **Dependent Variables** - Choose the dependent variables to be transformed.
- **Source Zones** - Choose the zones for which the transform should be calculated.
- **Include Conjugates** - For purely real numbers, fully half of the results of the Fourier transform are conjugates (values with the same real part but opposite imaginary parts, which behave identically in situations where a real number is required). Toggling-off this option will allow the transform to be performed approximately twice as fast, as only one conjugate is calculated.
- **Obey Source Zone Blanking** - If value blanking is active and this option is toggled-on, value blanking is applied to the values of both independent and dependent variables before interpolation is performed. If data values eliminated by blanking cause the data to be non-uniform, the values are interpolated appropriately. All blanked data values up to the first non-blanked value, and all blanked data values after the last non-blanked value, are ignored, providing a way to constrain the domain of the transform.
- **Replace by Name** - If Latest Result Zones or Latest Result Variables is toggled-on, the results of the transform are stored in existing result zones and/or variables, based on their names, if such zones and/or variables exist. Otherwise, new result zones and/or variables are created.

21 - 4  Coordinate Transformation

By default, all 3D Tecplot 360 plots use a cartesian coordinate system, notated by X, Y, and Z axes. If your data is in polar coordinates (r, θ, and Z) or spherical coordinates (r, θ, and ϕ), you will probably want to compute the corresponding cartesian (X, Y, and Z) coordinates before visualizing your data.

To transform your data from one coordinate system to another, select **Alter>Transform Coordinates** from the **Data** menu.

The **Transform Coordinates** dialog has the following options and fields:
• **Transformation** - Select the type of transformation to change all points in one or more zones from one coordinate system to another. The options are:
  
  - **Polar to Rectangular** - Tecplot 360 assumes the current Y-variable represents the radius r, and the current X-variable represents the angle \( \theta \).
  
  - **Spherical to Rectangular** - Tecplot 360 assumes the current Y-variable represents the radius \( r \), the current X-variable the angle \( \theta \) (in radians), and the current Z-variable the angle \( \phi \).

  - **Rectangular to Polar**
  
  - **Rectangular to Spherical**

  Figure 21-2 shows \( r \), \( \theta \), and \( \phi \) in the spherical coordinate system.

![Figure 21-2. Three-dimensional angles of rotation.](image)

- **Source Variables** - Specify the source variables for each coordinate.

- **New Variables**
  
  - **Create New Variables** - This option results in new variables. Tecplot 360 names them so the dataset integrity is maintained (no two variables with same names).
  
  - **Put Results in Existing Variables** - Results are put into variables in the current dataset.

- **Angles in** - Specify whether to calculate using values in Theta and Psi variable as radians or degrees.

- **Select Zones to Transform** - Selects zones to alter.

- **Compute** - Select the [Compute] button to perform the transformation.

### 21 - 5 Two-dimensional Data Rotation

Use the Rotate dialog to rotate field data about a user specified XY-origin.

Unlike interactive 3D rotation, change made via the Rotate dialog modify the data.
To rotate data in, select Alter> Rotate from the Data menu.

The Rotate dialog has the following options:

- **Angle (deg)** - Specify the angle of rotation, in degrees.
- **X-origin and Y-origin** - Specify the coordinates of the origin of rotation.
- **Select the Zones to Rotate** - Select the zones you wish to rotate from the “Select Zones to Rotate” field.
- **Compute** - You must select the [Compute] button for rotation to occur.

### 21 - 6 Shift Pseudo Cell-centered Data

Use the Shift Pseudo Cell-centered Data dialog (accessed via Data>Alter) to shift the values of variables of cell-centered data to your grid points. Linear interpolation is used.

The following options are available:

- **Zone(s)** - Select zones to be shifted.
- **Variable(s)** - Select variables for shifting the data.

The final result is a node-centered dataset with interpolated observations at each node.

Use this option ONLY if you have legacy data that does not make use of the newer ability to supply cell-centered data directly.

### 21 - 7 Zone Creation

The Create Zone submenu of the Data menu allows you to add data to your plot. The menu has the following options:

- One-Dimensional Line Creation
- Rectangular Zone Creation
- Circular or Cylindrical Zone Creation
- Zone Duplication
- Mirror Zone Creation
- FE Surface Zone Creation (from Polylines)
• Zone Creation by Entering Values

21 - 7.1 One-Dimensional Line Creation

A 1D-line zone is an I-ordered set of points along a line. To create the 1D line zone, select Create Zone>1D Line from the Data menu.

![Create 1D Line Zone dialog](image)

The Create 1D Line Zone dialog has the following options and fields:

- **Number of Points** - Enter the number of data points you want in the zone.
- **Coordinates** - Enter the start and end points in the text fields labeled XMin and XMax.
- **Create** - Select the [Create] button to create the zone.

Tecplot 360 uniformly distributes the points along the X-axis between XMin and XMax. Y, and any other variables, are set to zero.

You can create a 1D line zone as the first step in plotting an analytic function by modifying the Y-variable of the new zone using the Specify Equations dialog.

21 - 7.2 Rectangular Zone Creation

Creating a rectangular zone is often the first step in interpolating irregular data into an ordered grid. (See Section 3 - 6.2 “Example - Unorganized Three-Dimensional Volume”.)

Tecplot 360 allows you to create a new ordered rectangular zone with the dimensions in the I, J and K-directions you specify. This is done either with the Create Rectangular Zone tool (only) or the Create Rectangular Zone dialog. The zone that you create has the same number of variables as other zones in the dataset.

To create a rectangular zone, select Create Zone>Rectangular from the Data menu.

![Create Rectangular Zone dialog](image)

The Create Rectangular Zone dialog, has the following options:

- **Dimensions** - Enter the number of data points in the I, J and K-directions.
Zone Creation

- To create an I-ordered zone, enter one for both the J and K-dimensions.
- To create an IJ-ordered zone, enter one for the K-dimension. The z-axis variable will equal ZMin throughout the created zone.
- To create an IJK-ordered zone, enter a K-dimension greater than one.

- Coordinates: Enter the start and end points of the physical coordinates (X,Y and Z).
- Create: Select the [Create] button to create the zone.

Tecplot 360 uniformly distributes the data points in the I, J and K directions. Any variable not assigned to an axis is set to zero.

By using the Specify Equations dialog under the Data>Alter menu, you can modify the X, Y, and Z-coordinates, and the values of the other variables as well, by using equations or Equation files. See Section 21 - 1 “Data Alteration through Equations”.

21 - 7.3 Circular or Cylindrical Zone Creation

Tecplot 360 allows you to create a new ordered circular or cylindrical zone with the dimensions in the I, J, and K-directions you specify. The I-dimension determines the number of points on each radius of the zones. The J-dimension determines the number of points around the circumference. The K-dimension determines the number of layers in the zone, creating a cylinder.

You create a circular or cylindrical zone with the Create Circular Zone dialog (accessed via Data>Create Zone, or with the Create Circular Zone tool (only). The zone that you create has the same number of variables as other zones in the dataset.

If you have no current dataset, Tecplot 360 creates one with two or three variables, depending on the K-dimension. If you specify K=1, the dataset is created as IJ-ordered, and has two variables. If you specify K>1, the dataset is created as IJK-ordered, and has three variables.

To create a circular zone select Create Zone>Circular from the Data menu.

The Create Circular Zone dialog has the following options:

- Dimensions: Enter the dimensions of your circular zone:
  - Radial (I): Specify the number of points the radial direction (I)
  - Circumferential (J): Specify the number of points in the circumferential direction (J)
  - Top to Bottom (K): Specify the number of points for the height of the cylinder (K). Set K equal to one to create a circular zone.
• Coordinates
  • Radius - Enter the length of the radius.
  • X-Origin and Y-Origin - Enter the coordinates for the zone center
  • ZMin and ZMax - Enter the minimum and maximum Z-coordinates. For a circular zone
    (where K=1), the Z variable is set to ZMin for all points.

• Create - Select the [Create] button to create the zone.

For (IJ-ordered), Tecplot 360 creates a zone in which I-circles are connected by J-radial lines, as shown in
Figure 21-3 (A). For 3D (K>1), Tecplot 360 creates a K-layered cylindrical zone having I-circles connected
by J-radial planes as shown in Figure 21-3 (B). All other variables are set to zero.

\[ \text{Figure 21-3. (A) A circular zone (B) A 3D circular zone.} \]

Using the Alter option from the Data menu, you can modify the X, Y, and Z-coordinates, and the values
of the other variables as well, by using equations or equation files. See Section 21 - 1 “Data Alteration
through Equations”.

324
21 - 7.4 Zone Duplication

To create a full duplicate of one or more existing zones, select Create Zone>Duplicate from the Data menu. In the Create Duplicate Zone dialog, select the source zone(s). Each duplicate zone has the same name as its source zone.

After a zone is duplicated, all variables in the newly created zone(s) will be shared with their corresponding source zone(s).

21 - 7.5 Mirror Zone Creation

To create a duplicate zone that is the mirror image of an existing zone, select Create Zone>Mirror from the Data menu.

You can only create mirrored zones along one of the standard axes (x) or the plane determined by any two axes (3D).

The Create Mirror Zone dialog, has the following options:

- **Source Zone(s)** - Select the Sources Zone(s).
- **Mirror Axis** - Specify the axis (x) or axis plane (3D) to mirror about.
- **Create** - Select the [Create] button to create the zone.
Each mirror zone has a name of the form “Mirror of zone sourcezone”, where sourcezone is the number of the zone from which the mirrored zone was created.

The variables in the newly created zone(s) are shared with their corresponding source zone(s), except for the coordinate and velocity normal to the symmetry plane.

21 - 7.6 FE Surface Zone Creation (from Polylines)

To create a finite element surface zone from two or more I-ordered zones, select Create Zone>From Polylines from the Data menu.

The data must be arranged in non-intersecting polylines, where each polyline can have any number of points.

The Create Zone from Polylines dialog has the following options:

- **Source Zone(s)** - Select two or more zones to create your new zone from. The field displays only I-ordered zones (the polylines).
- **Connect Polyline Start and End Points** - Toggle-on this option to connect the start and end points for each supplied polyline. This is especially useful when creating 3D surfaces.
- **Create** - Select the [Create] button to create the zone.

Data Examples where Create Zone from Polylines is useful

- Data is collected on the surface of an irregularly shaped object.
- Measurements were taken at various depths and distances within a fluid.

21 - 7.7 Zone Creation by Entering Values

To create an I-ordered zone for XY-plots from manually entered values, select Create Zone>Enter Values from the Data menu. In the Enter XY-Values to Create a Zone dialog, enter X and Y-value pairs, one per
Data Extraction from an Existing Zone

You may create new zones by extracting (or interpolating) data from existing zones in a number of ways. Derived objects, such as contour lines, FE-boundaries, iso-surfaces, slices, or streamtraces may be extracted to be independent zones. You may also extract data using a specified slice plane, discrete points, points from a polyline, or points from a geometry. The procedures for extracting derived objects are discussed in the chapters related to those objects. For details see Chapter 9: “Contour Layer”, Section 16 - 5 “Iso-Surface Extraction”, and Section 15 - 4 “Streamtrace Extraction as Zones”. Extracting slices, both derived and arbitrarily defined, is described in Section 14 - 2 “Slices Extracted Directly to Zones”.

21 - 8.1 Sub-Zone Extraction

To create a sub-zone of an existing zone, select Extract>Sub-Zone from the Data menu.

The Extract SubZone dialog has the following options:

- **Source Zone** - Select the source zone (ordered zones only).
- **Index Range from Source Zone** - Specify the desired sub-zone as a range of I, J, and K-indices. You may use the special value 0 or Mx to indicate the maximum of that index, and the values Mx-.
1 to represent one index less than the maximum, \( M - 2 \) for two less than the maximum, and so forth.

- **Create** - Select the [Create] button to create the zone. Each sub-zone is given the name “SubZone.”

### 21 - 8.2 Data Point Extraction

You may create an 1-ordered zone by extracting data points from the current dataset using any of three methods:

- **Discrete Point Extraction**
- **Point Extraction from a Polyline**
- **Point Extraction from a Geometry**

To extract points from a geometry or polyline, it must lie within the edges of a zone with connectivity.

#### Discrete Point Extraction

To extract a discrete set of points with the mouse:

1. From the **Data** menu, choose **Extract>Discrete Points**.
2. Click at each location from which you want to extract a point.
3. Double-click on the last data point or press **ESC** to end.
4. Use the **Extract Data Points to File** dialog to specify how to save the data.

#### Point Extraction from a Polyline

To extract points from a polyline:

1. From the **Data** menu, choose **Extract>Points from Polyline**.
2. Click at the beginning of the desired line, and at all desired breakpoints.
3. Double-click on the last data point or press **ESC** to end.
4. Use the **Extract Data Points to File** dialog to specify how you would like to save the data.

Any necessary interpolation is performed using the same method used in probing. From triangular faces, linear interpolation is used to determine the value of the extracted points. On quadrilateral faces, a point of the center of mass of the quadrilateral is created and assigned a value equal to the average of the four corners. The surface is then broken down into four triangles using this center point and the four corners, and the extracted point value is interpolated linearly on the face of the triangle that surrounds it.

If a surface utilizes cell-centered values, the nodal values at the corners are interpolated, then the extracted points are interpolated from those nodal values. Volume interpolation, piece-wise by default, calculates to first-order accuracy. For second-order accuracy (tri-linear interpolation), add the following line to your **tecplot.cfg** file:

```
$INTERFACE DATA {VOLUMECELLINTERPOLATIONMODE = TRILINEAR}
```
Data Extraction from an Existing Zone

Point Extraction from a Geometry
To extract points from a polyline geometry:
1. In the workspace, select the polyline geometry from which you want to extract data points.
2. From the Data menu, choose Extract>Points from Geometry.
3. Use the Extract Data Points to File dialog to specify how to save the data.

Data Point Extraction Controls
Use the Extract Data Points dialog to control how data points are extracted. The dialog has the following options:

- Extract Data to:
  - File - Select this option to extract the data points to an ASCII Tecplot 360 data file.
  - Zone - Select this check box if you want the data points extracted to a zone in the current dataset.
- Include distance variable - Toggle-on for the extracted data file to contain an additional variable, DISTANCE. The variable contains the accumulated distance from the first point to the last point.
- Number of points to extract - Enter the number of points to extract. This field is sensitive only if you are extracting data points from a polyline or geometry. It is insensitive if you are extracting discrete points. If you are extracting from a geometry, you must also select the check box labeled “Extract regular points along a geometry.”
- Extract regular points along geometry - Select this check box if you want to extract the specified number of points distributed uniformly along the geometry.
- Extract only points which define geometry - Select this check box if you want to extract only the endpoints of the segments in the geometry.

Boundary Extraction of Finite Element Zones
To extract the boundary of a finite element zone, select Extract>FE-Boundary from the Data menu. The Extract FE-Boundary dialog has the following options:

- Source Zone - Select the source zone for the FE-Boundary.
- Retain boundaries between blanked and unblanked cells - If blanking is on, toggle-on to include the boundary between blanked and un-blanked cells in the zone boundary.

Edge-border lines for finite element data are similar to edge-border lines in ordered data, with a few exceptions. For triangular and quadrilateral meshes, a line is drawn along the edges of elements that have no neighboring element.

In cases where each element is independent of all other elements (i.e. the elements have no common nodes), a border line will be drawn around each element.
Border lines will not be produced for finite element volume data (tetrahedral and brick element types). However, some plot styles will draw on the outer surface of these zones, in effect drawing on the boundary. Extracting the boundary of these zones extracts the outer surface.

If you are extracting the boundary from a 3D surface zone, make sure the plot type is set to 3D Cartesian. If you create the boundary zone in a Cartesian plot, the Z-coordinate is not taken into account, and points that are not coincident in 3D Cartesian plots may become coincident in plots.

### 21 - 9 Zone Deletion

In any dataset with more than one zone, you can delete any unwanted zones. To delete a zone, select **Delete>Zone** from the Data menu. You cannot delete all zones; if you attempt to delete all zones, the lowest numbered zone is not deleted.

![Delete Zone dialog](image)

### 21 - 10 Variable Deletion

To delete a variable, select **Delete>Variable** from the Data menu. The **Delete Variable** dialog is shown below.

![Delete Variable dialog](image)

When deleting a variable, keep the following issues in mind:

- Deleting a variable removes it from all zones.
- You cannot delete a variable that a Calculate-on-demand variable is a function of. See **Section 22 - 6.2 “Calculate-on-demand Variables”**.
Data Interpolation

21 - 11    Data Interpolation

In Tecplot 360, interpolation refers to assigning new values for the variables at data points in a zone based
on the data point values in another zone (or set of zones).

For example, you may have a set of data points in an I-ordered zone that are distributed randomly in the
XY-plane. This type of data is sometimes referred to as unordered, ungridded, or random data. In Tecplot
360, it is referred to as irregular data. Using data in this form, you can create mesh plots and scatter plots,
but you cannot create contour plots, light-source shading, or streamtraces.

In Tecplot 360, you can interpolate the irregular I-ordered data onto an IJ-ordered mesh, and then create
contour plots and other types of field plots with the interpolated data. You can also interpolate your 3D, I-
ordered irregular data into an IJK-ordered zone and create 3D volume plots from the IJK-ordered zone.
You can even interpolate to a finite element zone.

The accuracy of the interpolation will depend on your data, the density of the destination grid, how well
the grid fits the area of your unorganized zone and the settings used for interpolation.

There are three types of interpolation available:

• **Linear Interpolation** - Interpolate using linear interpolation from a set of finite element, IJ-
  ordered, or IJK-ordered zones to one zone.

• **Inverse-Distance Interpolation** - Interpolate using an inverse-distance weighting from a set of
  zones to one zone.

• **Kriging** - Interpolate using kriging from a set of zones to one zone.

21 - 11.1    Linear Interpolation

Use the **Linear Interpolation** dialog to interpolate data from one or more ordered or finite element zones
onto a destination zone. Irregular I-ordered data cannot be used for the source zones in linear
interpolation. (For data, you may be able to first create a finite element zone from an irregular, I-ordered
zone by using triangulation. (See Section 21 - 12 "Irregular Data Point Triangulation".)

Linear interpolation finds the values in the destination zone based on their location within the cells of the
source zones. The value is linearly interpolated to the destination data points using only the data points at
the vertices of the cell (or element) in the source zone(s).

To perform linear interpolation:

1. Read the dataset to be interpolated into Tecplot 360 (the source data).
2. Read in or create the zone onto which the data is to be interpolated (the destination zone).
3. From the Data menu, choose Interpolate>Linear.

4. From the Linear Interpolation dialog, select the zones to be interpolated from those listed in the Source Zone(s) scrolled list.

5. Select which variables are to be interpolated from those listed in the Variable(s) scrolled list.

6. Select the destination zone into which to interpolate. Existing values in the destination zone will be overwritten.

7. [OPTIONAL] Outside Points - Select how to treat points that lie outside the source-zone data field. You have two options:
   - Constant - Sets all points outside the data field to a constant value that you specify.
   - Do Not Change - Preserves the values of points outside the data field. Do Not Change is appropriate in cases where you are using one interpolation algorithm inside the data field, and another outside.

8. Select the [Compute] button to perform the interpolation.

9. While the interpolation is proceeding, a working dialog appears showing the progress of the interpolation.

If you select [Cancel] during the interpolation process, the interpolation is terminated prematurely. The destination zone will be left in an indeterminate state, and you should redo the interpolation.

21 - 11.2 Inverse-Distance Interpolation

Inverse-distance interpolation averages the values at the data points from one set of zones (the source zones) to the data points in another zone (the destination zone). The average is weighted by a function of the distance between each source data point to the destination data point. The closer a source data point is to the destination data point, the greater its value is weighted.

In many cases, the source zone is an irregular dataset—an I-ordered set of data points without any mesh structure (a list of points). Inverse-distance interpolation may be used to create or 3D surface, or a 3D volume field plots of irregular data. The destination zone can, for example, be a circular or rectangular zone created within Tecplot 360.
To perform inverse-distance interpolation in Tecplot 360, use the following steps:

1. Read the dataset to be interpolated into Tecplot 360 (the source data).
2. Read in or create the zone onto which the data is to be interpolated (the destination zone).
3. From the Data menu, choose Interpolate->Inverse Distance.

4. From the Inverse-Distance Interpolation dialog, select the zones to be interpolated from those listed in the Source Zone(s) scrolled list.
5. Select which variables are to be interpolated from those listed in the Variable(s) scrolled list.
6. Select the Destination Zone into which to interpolate. Existing values in the destination zone will be overwritten.
7. [OPTIONAL] Enter the minimum distance used for the inverse-distance weighting in the Minimum Distance text field. Source data points which are closer to a destination data point than this minimum distance are weighted as if they were at the minimum distance. This tends to reduce the peaking and plateauing of the interpolated data near the source data points.
8. [OPTIONAL] Enter the exponent for the inverse-distance weighting in the Exponent text field.

The exponent should be set between 2 and 5. The algorithm is speed-optimized for an exponent of 4, although in many cases, the interpolation looks better with an exponent of 3.5.

9. [OPTIONAL] Select the method used for determining which source points to consider for each destination point from the Point Selection drop-down. There are three available methods, as follows:
   - Nearest N - For each point in the destination zone, consider only the closest n points to the destination point. These n points can come from any of the source zones. This option may speed up processing if n is significantly smaller than the entire number of source points.
   - Octant - Like Nearest N above, except the n points are selected by coordinate-system octants. The n points are selected so they are distributed as evenly as possible throughout the eight octants. This reduces the chances of using source points which are all on one side of the destination point.
• All - Consider all points in the source zone(s) for each point in the destination zone.

10. Click Compute to perform the interpolation. While the interpolation is proceeding, a working dialog appears showing the progress of the interpolation.

If you select the [Cancel] button during the interpolation process, the interpolation is terminated prematurely. The destination zone will be left in an indeterminate state, and you should redo the interpolation.

Inverse-distance interpolation ignores the IJK-mode of IJK-ordered zones. All data points in both the source and destination zones are used in the interpolation.

Tecplot 360 uses the active frame’s axis assignments to determine the variables to use for coordinates in interpolation. However, axis scaling is ignored.

**The Inverse-Distance Algorithm**

The algorithm used for inverse-distance interpolation is simple. The value of a variable at a data point in the destination zone is calculated as a function of the selected data points in the source zone (as defined in the Point Selection drop-down, accessed via Data>Interpolate>Inverse-Distance).

The value at each source zone data point is weighted by the inverse of the distance between the source data point and the destination data point (raised to a power) as shown below:

$$\phi_d = \frac{\sum w_s \phi_s}{\sum w_s}$$

(summed over the selected points in the source zone)

where \(\phi_d\) and \(\phi_s\) are the values of the variables at the destination point and the source point, respectively, and \(w_s\) is the weighting function defined as:

$$w_s = D^{-E}$$

\(D\) in the equation above is the distance between the source point and the destination point or the minimum distance specified in the dialog, whichever is greater. \(E\) is the exponent specified in the Exponent text field.

Smoothing may improve the data created by inverse-distance interpolation. Smoothing adjusts the values at data points toward the average of the values at neighboring data points, removing peaks, plateaus, and noise from the data. See Section 21 - 2 "Data Smoothing" for information on smoothing.

**Kriging and Inverse Distance Interpolation Improvements**

For better results with 3D data, try changing the range of your Z-variable to one similar to the X-range the Y-range. Also, set Zero Value to 0.05.
21 - 11.3 Kriging

Kriging is a more complex form of interpolation than inverse-distance. It generally produces superior results to the inverse-distance algorithm but requires more computer memory and time.

To perform kriging in Tecplot 360, perform the following steps:

1. Read the dataset to be interpolated into Tecplot 360 (the source data).
2. Read in or create the zone onto which the data is to be interpolated (the destination zone).
3. From the Data menu, choose Interpolate-Kriging

4. From the Kriging dialog, select the zones to be interpolated from those listed in the Source Zone(s) scrolled list.

5. Select which variables are to be interpolated from those listed in the Variable(s) scrolled list.
6. Select the destination zone into which to interpolate. Existing values in the destination zone will be overwritten.

7. [OPTIONAL] In the Range text field, enter the distance beyond which source points become insignificant for the kriging. The value is stated as the fraction of the length of the diagonal of the box which contains the data points. A range of zero means that any point not coincident with the destination point is statistically insignificant; a range of one means that every point in the dataset is statistically significant for each point. In general, values between 0.2 and 0.5 should be used.

8. [OPTIONAL] In the Zero Value text field, enter the semi-variance at each source data point on a normalized scale from zero to one. Semi-variance is the certainty of the value at a data point. A value of zero means that the values at the source points are exact. Greater values mean the values at the source points have some uncertainty or noise. Zero is usually a good
number for the zero value, and it causes the interpolated data to fit closely to all the source data points. Increasing the zero value results in smoother interpolated values that fit increasingly more to the average of the source data.

9. **[OPTIONAL]** Select the overall trend for the data in the **Drift** drop-down. This can be **No Drift**, **Linear**, or **Quadratic**.

If the **Drift** is set to Linear or Quadratic, Tecplot 360 requires that the points selected be non-collinear (non-coplanar in 3D). To avoid this limitation, set the **Drift** to None. Alternatively, you can eliminate coincident points by **Irregular Data Point Triangulation** before you interpolate.

10. **[OPTIONAL]** Select the method used for determining which source points to consider for each destination point from the **Point Selection** drop-down. There are three available methods, as follows:
   - **Nearest N** - For each point in the destination zone, consider only the closest \( n \) points to the destination point. These \( n \) points can come from any of the source zones.
   - **Octant** - Like Nearest N above, except the \( n \) points are selected by coordinate-system octants. The \( n \) points are selected so they are distributed as evenly as possible throughout the eight octants. This reduces the chances of using source points which are all on one side of the destination point.
   - **All** - Consider all points in the source zone(s) for each point in the destination zone. In general, you should not use the All option unless you have very few source points.

The **Point Selection** option is very important for kriging, because kriging involves the computationally expensive inversion and multiplication of matrices. The computational time and memory requirements increase rapidly as the number of selected source data points increases.

11. Select [Compute] to perform the kriging. While the kriging is proceeding, a working dialog appears showing its progress.

If you select [Cancel] during the kriging process, the kriging is terminated prematurely. The destination zone is left in an indeterminate state, and you should redo the kriging.

**The Kriging Algorithm**


**Kriging and Inverse Distance Interpolation Improvements**: For better results with 3D data, try changing the range of your Z-variable to one similar to the X-range the Y-range. Also, set Zero Value to 0.05.

**21 - 12 Irregular Data Point Triangulation**

Triangulation is a process that connects data points to form triangles. You can use triangulation to convert irregular, I-ordered datasets into a finite element surface zone. Triangulation is one of the two options for creating field plots from irregular data. The other is interpolation, discussed in **Section 21 - 11 “Data Interpolation”**. Triangulation preserves the accuracy of the data by creating a finite element surface zone with the source data points as nodes and a set of triangle elements.

336
Irregular Data Point Triangulation

Triangulation works best for irregular data. However, you can triangulate 3D surface data, provided the Z-coordinate is single-valued (the surface does not wrap around on itself). When you triangulate 3D surface data, the Z-coordinate of the data is ignored, causing a less-than-optimal triangulation in some cases.

To triangulate your data, select Triangulate from the Data menu. The Triangulate dialog has the following options:

- **Source Zone(s)** - Select the zone or zones to triangulate from the list.
- **Use Boundary Zone(s)** - Toggle-on to specify a boundary zone for the triangulation. Select the boundary zone or zones from the list. The boundary zones define the boundaries in the triangulation region. If you do not include boundary zones, Tecplot 360 assumes the data points lie within a convex polygon and that all points in the interior can be connected.
  - **Include Boundary Points** - Toggle-on to include the points in the boundary zones in the triangulated zone.
  - **Triangle Keep Factor [OPTIONAL]** - This factor is used to define “bad” triangles on the outside of the triangulated zone.
    At the completion of triangulation, Tecplot 360 attempts to remove bad triangles from the outside of the triangulation. The definition of a bad triangle is stored as a number between zero (three collinear points) and 1.0 (an equilateral triangle). Typical settings are values between 0.1 and 0.3; settings above 0.5 are not allowed. Bad triangles will not be removed if removing the triangle strands a data point.
- **Compute** - Select the [Compute] button to perform the triangulation.

After triangulating your data, you can use the resulting finite element surface zone to create plots. Generally, you turn off the original zone(s) and plot the new zone only, but you can, for example, plot a scatter plot of the original zone(s) along with the contours of the new zone.
21 - 13 Data Spreadsheet

All ordered and finite element data can be viewed using Tecplot 360's data spreadsheet (accessed via Data>Spreadsheet). The data may be modified within the spreadsheet in order to change the plots Tecplot 360 produces.

Changes to the spreadsheet do not automatically alter the original data file. However, saving the plot of altered data as a layout file will save the changes in the data journal. You also have the option of overwriting your original data file, or creating a new file with the altered data.

The spreadsheet displays Tecplot 360's data differently depending on the type of zone being examined. An example of the Data Spreadsheet dialog for an IJK-ordered zone is shown in Figure 21-4.

Figure 21-4. The Data Spreadsheet for an IJK-ordered zone. The first several values of the X variable at the first index of the K plane are displayed.

I-ordered and finite element datasets are displayed with each zone’s variable displayed in a column. IJ-ordered datasets are displayed in the spreadsheet with I along the rows and J along the columns. IJK-ordered datasets are displayed one plane at a time: selecting the K-plane displays I along the rows and J along the columns, selecting the J-plane displays I along the rows and K along the columns, and selecting the I-plane displays J along the rows and K along the columns. With IJK-ordered data, the slice of interest can be selected by entering a specific index or using the up and down arrows provided.

21 - 13.1 Load Variables

If a variable was not initially loaded into Tecplot 360, “Not Loaded” will be displayed in every cell of the spreadsheet when that variable is selected. Use the [Load Variables] button to load any variables from your dataset that were not initially loaded. See Section “Load On Demand” on page 409 for more information.
21 - 13.2 Spreadsheet Format

You can change the format of data in a spreadsheet without changing the appearance of your plot. To change the data spreadsheet’s display format, select the [Format] button on the Data Spreadsheet dialog. The Data Format dialog has the following options:

- **Format**: Select a number format from the option menu that best represents the data of interest. Options are Integer, Float, Exponent, or Best Float.
- **Precision [for Float and Exponent only]**: Specify the number of places to the right of the decimal.
- **Column Width**: Specify the width of the columns in number of characters.

21 - 13.3 Spreadsheet Data Editing

You can change your dataset within Tecplot 360 without changing your original data file. You do this by editing values in the cells of the spreadsheet. To modify data:

1. From the Data Spreadsheet dialog select a desired zone and variable to modify.
2. If the variable is shared with another zone or zones, the Alter in all Shared Zones toggle will be enabled. Select this toggle to keep the variable shared as you modify data, propagating changes to the other zones that share the variable. If this toggle is not selected, the variable will be changed in the selected location and no longer shared. See also Section 5 - 3 “Data Sharing”.
3. Select the value of interest from the spreadsheet. This will highlight and expand the value to its full precision.
4. To replace the highlighted value, simply enter the new value. Anything highlighted is instantly replaced with the new digits entered.
5. To slightly modify a highlighted value, select the value a second time. This will un-highlight the value and place the edit cursor at the desired position. Make desired modifications to the existing value.
6. To undo a modification of a given cell, press ESC. To commit to a modification press the Enter, Tab, or SHIFT-tab keys, or select on another cell.
CFD Data Analysis

Tecplot 360 helps you analyze computational fluid dynamics and similar solutions. Data analysis capabilities are available via the Analyze menu, and include:

- Function calculations, including grid quality functions (such as skewness) and flow variable functions (such as vorticity). Many of these functions duplicate functions that are available in NASA's PLOT3D and FAST plotting programs.
- Integration of input or calculated data, including scalar, vector-dot-normal and vector-dot-tangential integrands, as well as a special forces and moments option for calculating lift, drag and moments.
- Turbulence variable calculations.
- Particle path and streakline calculations, including particles with mass.
- Error analysis using Richardson extrapolation.
- Flow feature detection, including vortex cores, separation and attachment lines, and shock surfaces.

Units (Dimensions)

Analysis may be performed with data representing any system of units or dimensions, including non-dimensional data. All dataset variables and other parameters must, however, be in the same set of units. Unit conversions are not available. UNIX® users may wish to use the units utility for unit conversions. Analysis results will be in the same units as the data.

22 - 1 Specifying Fluid Properties

Fluid properties, such as viscosity, describe the fluid model used to create the dataset. These properties are required for many calculations performed by other dialogs. They are set via the Fluid Properties dialog. Values entered must be dimensionally consistent with each other and with your dataset. If you imported your data using the PLOT3D data loader, the default fluid properties will most likely suit your needs.

For a layout with multiple datasets, a separate set of fluid properties is maintained for each dataset. You can copy the settings from one dataset to another using the Save Settings and Load Settings options in the Analyze menu. These actions also transfer the settings made in the Reference Values, Field Variables, Geometry and Boundaries, and Unsteady Flow Options dialogs.
The Fluid Properties dialog is accessed by selecting Fluid Properties from the Analyze menu.

The Fluid Properties dialog allows you to specify properties for a compressible or incompressible fluid. For incompressible (uniform density) fluids, you specify density, specific heat, viscosity and conductivity. For compressible (variable density) fluids, you specify the gas constant, gamma (the ratio of specific heats), viscosity and conductivity.

By default, each fluid property is a constant. However, each property can be overridden by a field (dataset) variable (with the exception of density). When a field variable is assigned, the local value of that variable is used for field calculations using that property, and the constant value is used only for global calculations, such as the calculation of reference (free-stream) quantities. To assign a field variable for a particular property, set the Use Field Variable toggle and click Select to choose a variable from the current dataset from the Select Variable dialog.

- **Incompressible** - Toggle-on to indicate the fluid is incompressible. For incompressible fluids, you must specify density, specific heat, viscosity and conductivity. For compressible fluids, you must specify gas constant, gamma, viscosity and conductivity.
- **Density** (for incompressible fluids only) - Density represents the mass of fluid occupied by a unit volume. Its dimensions are [Mass]/[Length]**3.
- **Specific Heat** (for incompressible fluids only) - Specific heat is the amount of energy required to raise a unit mass of the fluid one degree in temperature. Dimensions are [Length]**2/[Time]**2/[Temperature].
- **Gas Constant** (for compressible fluids only) - The specific gas constant has dimensions of [Length]**2/[Time]**2/[Temperature].
- **Gamma** (for compressible fluids only) - Gamma represents the ratio of the specific heat at constant pressure to the specific heat at constant volume, a non-dimensional quantity.
- **Viscosity** - The dynamic viscosity’s dimensions are [Mass] / [Length] [Time].
Specifying Fluid Properties

• Conductivity - The thermal conductivity’s dimensions are [Mass] [Length] / [Time]**3[Temperature].

Section 22 - 1.1 “Specifying Incompressible Fluid Properties”
Section 22 - 1.2 “Specifying Compressible Fluid Properties”
Section 22 - 1.3 “Working with Non-dimensional Data”

22 - 1.1 Specifying Incompressible Fluid Properties

When the Incompressible check box is selected, the density of the fluid and its specific heat (C_v), viscosity (μ), and conductivity (k) must be entered. Gamma (γ), the ratio of specific heats at constant volume and pressure, is unity for incompressible fluids, so the Gamma section is inactive. Gas Constant (R) is also inactive. The thermal and caloric equations of state for incompressible fluids are shown below. ρ is density, and ε represents the internal energy per unit mass.

\[ \rho = \text{const} \]
\[ \varepsilon = C_v T \]

Since the density entered in the Fluid Properties dialog represents the density of the fluid throughout the physical domain, you are not allowed to enter a reference value for density in the Reference Values dialog, or choose a density field variable on the Field Variables dialog (see Section 22 - 3.2 “Identifying State Variables”).

Specific heat (C_v) is the amount of energy required to raise a unit mass of the fluid one degree. It has dimensions of:

\[ \frac{\text{Length}^2}{\text{Time}^2 \times \text{Temperature}} = \frac{\text{Energy}}{\text{Mass} \times \text{Temperature}} \]

Viscosity (μ) represents the dynamic viscosity coefficient, in units of

\[ \frac{\text{Mass}}{\text{Length} \times \text{Time}} \]

Conductivity (k) is the thermal conductivity of the fluid, in units of

\[ \frac{\text{Mass} \times \text{Length}}{\text{Time}^3 \times \text{Temperature}} \]  

(EQ 1)

22 - 1.2 Specifying Compressible Fluid Properties

When the Incompressible check box is not selected, the specific gas constant, gamma, viscosity and conductivity must be entered. Since density is not a constant property of compressible fluids, the Density text field is inactive, as is the Specific Heat section of the dialog. The thermal and caloric equations of state for compressible fluids are shown below. P is pressure, and ε is internal energy per unit mass:

\[ p = \rho RT \]
\[ \varepsilon = C_v T \]  

(EQ 2)
The gas constant is the universal gas constant divided by the molecular weight of the fluid:

\[ R = \frac{R}{M} \]  \hspace{1cm} \text{(EQ 3)}

giving units of

\[ \frac{\text{Length}^2}{\text{Time}^2 \times \text{Temperature}} \]  \hspace{1cm} \text{(EQ 4)}

Gamma is the ratio of the gas specific heats and is non-dimensional:

\[ \gamma = \frac{C_p}{C_v} \]  \hspace{1cm} \text{(EQ 5)}

### 22 - 1.3 Working with Non-dimensional Data

Consider a case where temperature is non-dimensionalized by dividing it by free-stream temperature:

\[ T \rightarrow \frac{T}{T_{\infty}} \]  \hspace{1cm} \text{(EQ 6)}

and pressure is non-dimensionalized with gamma (the ratio of specific heats) and free-stream pressure:

\[ p \rightarrow \frac{p}{\gamma \rho_{\infty}} \]  \hspace{1cm} \text{(EQ 7)}

We wish to know what to enter for the gas constant in the \textit{Fluid Properties} dialog. We plug what we know into the thermal equation of state (where \( \rho \) is density and \( R \) is the gas constant):

\[ p = \rho R T \Rightarrow \frac{p}{\gamma \rho_{\infty}} = \frac{\rho}{(1) \times (2) \times \frac{T}{T_{\infty}}} \]  \hspace{1cm} \text{(EQ 8)}

Since the equation of state must hold for the free-stream conditions, we know:

\[ p_{\infty} = \rho_{\infty} R_{\infty} T_{\infty} \]  \hspace{1cm} \text{(EQ 9)}
Specifying Reference Values

From this, we see that the product of (1) and (2) in Equation 8 must equal: \( \frac{\rho R}{\gamma \rho_\infty R_\infty} \).

\[ (\text{EQ 10}) \]

This doesn’t entirely answer our question, however, and in the absence of additional information, we simply need to decide how \( \tau \) and \( R \) are each individually non-dimensionalized. The requirement we just determined is that the product of the two must be non-dimensionalized by \( \frac{\rho R}{\gamma \rho_\infty R_\infty} \). So we may decide to non-dimensionalize density by free-stream density, \( \rho_\infty \), which leaves the gas constant non-dimensionalized (that is, divided) by \( \frac{\gamma R_\infty}{\rho_\infty} \). In the Fluid Properties dialog, we enter \( \frac{1}{\gamma} \) for Gas Constant. If we chose to leave Gas Constant at unity, density would be non-dimensionalized by gamma and free-stream density, \( \rho_\infty \).

22 - 2 Specifying Reference Values

Certain calculations, such as Pressure Coefficient (see Section 22 - 6 “Calculating Variables”) require reference, or free-stream values. If you loaded your data with the PLOT3D loader, this information has probably been loaded along with the data. Otherwise, you may supply this information using the Reference Values dialog.

For a layout with multiple datasets, separate settings are maintained for each dataset. You can copy the settings from one dataset to another using the Save Settings and Load Settings options in the Analyze menu. These actions also transfer the settings made in the Fluid Properties, Geometry and Boundaries, Field Variables, and Unsteady Flow Options dialogs.

There must be data in the active frame for the Reference Values dialog to be displayed. The Reference Values dialog is shown below.

The dialog options are as follows:

- **Velocity** - In the first two text fields, you may specify free-stream velocity as either U-Velocity and V-Velocity, or as Mach Number and Angle of Attack. Z-velocity is assumed to be zero. Angle of attack must be specified in degrees; flow proceeding in the +X- and +Y-direction has a positive angle of attack. For incompressible flow (see Section 22 - 1.1 “Specifying Incompressible Fluid Properties”) only U and V-velocities may be specified.

- **Pressure/Density** - The third text field allows you to specify either Density or Pressure. Select the corresponding option in the drop-down. For incompressible flow, you must specify Pressure, because density is specified in the Fluid Properties dialog.

- **Temperature/Sound Speed** - The final text field allows you to specify Temperature or Sound Speed. Temperature must be in absolute units, such as Kelvin or Rankine. For incompressible flow you must specify temperature. For incompressible fluids, the speed of sound is undefined and the density of the fluid is constant.

22 - 3 Identifying Field Variables

Data analysis is performed on data in the active frame. Many of these calculations require information about what the data represents. For example, if you wish to calculate pressure from your data you must
identify two other thermodynamic state variables with which Tecplot 360 can perform the calculation using the thermal equation of the state. X, Y, and Z are taken from the axis assignments for the 2D or 3D plot in the active frame. The FLUENT and PLOT3D data loaders supply most or all of the remaining information to Tecplot 360. You may also supply this information using the Field Variables dialog.

For a layout with multiple datasets, separate settings are maintained for each dataset. You can copy the settings from one dataset to another using the Save Settings and Load Settings options in the Analyze menu. These actions also transfer the settings made in the Fluid Properties, Geometry and Boundaries, Reference Values, and Unsteady Flow Options dialogs.

You must have data in the active frame to open the Field Variables dialog. The Field Variables dialog is shown below.

![Field Variables dialog](image)

The top section of the dialog allows you to specify a vector of convective variables, either velocity or momentum (velocity multiplied by density). The bottom section of the dialog contains two drop-down menus and associated text fields for identifying two thermodynamic state variables in your dataset.

22 - 3.1 Choosing the Convective Variables

Select the convective variables in your dataset by clicking the [Select] button in the top section of the Field Variables dialog. Choose one of the two options on the Field Variables dialog to indicate whether these variables represent pure velocity or momentum.

The convective variables used in data analysis are not the same variables that are used to create vector plots for your solution data, though their initial values may be set the same.

22 - 3.2 Identifying State Variables

The State Variables region of the dialog allows you to identify up to two variables, such as pressure and temperature, in your data. From the two drop-downs, select any two choices from the types: Pressure, Temperature, Density, Stagnation Energy, Mach Number, or Not Used. Then click Select, and choose the corresponding variable(s) from your data. If you have only one thermodynamic variable, select “Not Used” in one of the drop-downs. For incompressible flow, (see Section 22 - 1.1 "Specifying Incompressible..."
In the Fluid Properties dialog, you may specify Pressure for one variable, and you may specify Temperature or Stagnation Energy (per unit volume) for the other. Temperature must be in absolute units, such as Kelvin or Rankin.

The [Select] button launches the Select Variables dialog which allows you to select variables in your dataset. The selections in the drop-down menus mentioned above determine whether these variables represent pressure, temperature, density, stagnation energy or Mach number.

22 - 4 Setting Geometry and Boundary Options

For certain calculations, you will need to specify information about your data that Tecplot 360 may not automatically detect. For example, a 2D solution may actually represent a 3D axisymmetric solution, affecting any integrations you perform. Adjacent zones may be connected, affecting other calculations such as grid stretch factors, gradients, and flow features such as vortex cores. Certain zones or zone surface regions may represent wall boundaries in your solution, on which separation and attachment lines may be calculated. The FLUENT data loader identifies most of these characteristics for you when you import FLUENT case and data files. You may also specify them with the Geometry and Boundaries dialog (accessed via the Analyze menu).

For a layout with multiple datasets, separate settings are maintained for each dataset. You can copy the settings from one dataset to another using the Save Settings and Load Settings options in the Analyze menu. These actions also transfer the settings made in the Fluid Properties, Reference Values, Field Variables, and Unsteady Flow Options dialogs.

You must have data in the active frame to launch the Geometry and Boundaries dialog. Select “Geometry and Boundaries” from the Analyze menu to display the dialog.

- Specifying an Axisymmetric Solution - Selecting Axisymmetric About Variable enables the Variable drop-down menu and allows you to enter a value in the Equals field. Select X or Y from the Variable drop-down, and enter the constant value of this variable that defines the axis of symmetry. If you choose the axisymmetric option, all integrations will be performed as 3D axisymmetric integrations by multiplying the integrand by \( \pi r^2 \), where \( r \) is the distance from the axis of symmetry.
the specified axis of symmetry. Integrations are described in Section 22 - 7 “Performing Integrations”.

- Connecting Adjacent Zones - Tecplot 360 can calculate whether nodes on the boundaries of adjacent zones (or the same zone) overlap. It uses this information in calculating the Stretch Ratio grid quality function (see Section E - 2.2 “I, J, or K-stretch Ratio”), calculating gradients, and extracting fluid flow features (see Section 22 - 11 “Extracting Fluid Flow Features”).

Connections between zones are calculated cell face by cell face. The two cells are considered connected wherever all nodes of a particular boundary cell face overlap all nodes of an adjacent boundary cell face.

For unsteady flows (see Section 22 - 5 “Unsteady Flow”), only zones within the same time level are examined for connections. To enable this option, select the Connect Adjacent Zones option and enter the maximum distance at which two nodes will be considered to overlap in the Nodal Proximity text field. Note that this text field value is also used for zone-type boundaries, discussed below.

The zone connection feature is overridden, cell-by-cell, by any face neighbors contained in a dataset. Both connection mechanisms are overridden by any boundary conditions set on a particular face. That is, if you specify a boundary condition in the Geometry and Boundaries dialog that covers a specific cell face, that face will not be connected to an adjacent cell, irrespective of any face neighbors or overlapping nodes present.

22 - 4.1 Performance Considerations
Establishing connections across zone boundaries allows Tecplot 360 to calculate better gradient quantities at these locations. There may be a substantial performance penalty for ordered-zone calculations, because at these boundary locations, Tecplot 360 uses the finite element least-squares formulation for calculating the gradients. Refer to Section 22 - 6.5 “Gradient Calculations” for a discussion of gradient calculations.

22 - 4.2 Specifying Boundaries and Boundary Conditions
You may associate cell boundary faces (cell faces on the exterior of a zone) with a boundary condition. There are two reasons why you might want to do this:

- To ensure that boundary faces are not connected to adjacent cells (see the above discussion on connections).
- To identify wall boundaries in 3D solutions for feature extraction (see Section 22 - 11 “Extracting Fluid Flow Features”).

If you set a boundary condition on a particular cell boundary face, that face will not be considered connected to any other cells by the gradient calculation routines. This may be advantageous, for example, in solutions containing a thin flat plate, where nodes on either side of the flat plate overlap and would otherwise be connected by the connection mechanism.

For three-dimensional flow solutions, you can use the Extract Flow Features dialog to extract separation and attachment lines. These lines are only calculated on boundaries you have identified as wall boundaries. While other boundary conditions may be specified, this information is not currently used, aside from inhibiting connections.

Specifying the Default Boundary Condition
Tecplot 360 keeps track of all unconnected boundary cell faces (see Section 22 - 4 “Setting Geometry and Boundary Options”). It applies the default boundary condition to any unconnected faces to which you do not specifically apply a boundary as described below. Choose the desired boundary condition from the Default Boundary Condition drop-down. The default boundary condition is at the bottom of the boundary ‘pecking order.’ If a cell boundary face is not covered by any other boundary condition, and is
Setting Geometry and Boundary Options

not connected to any other cells by either Geometry and Boundaries connection settings or Tecplot 360 face neighbors, then the default boundary condition is applied to it.

**Identifying Zone Boundaries**

Regions on the boundaries of zones may be explicitly identified and associated with particular boundary conditions. For ordered zones only, you may identify a boundary region by zone boundary (that is, the I=1 boundary) and index range on that boundary. For all zone types, you may identify a boundary region by selecting one or more boundary zones.

Boundary zones are zones of dimension one less than the current plot type. They are surfaces in 3D Cartesian plots, or lines in 2D Cartesian plots. Boundary conditions are considered to exist wherever the nodes of these boundary zones coincide with nodes on the boundaries of volume zones in 3D Cartesian plots, or surfaces in 2D Cartesian plots. For example, you can identify boundary regions on a tetrahedral (3D) zone using triangular zones that lie on the surface of the tetrahedral zone. The boundary is applied wherever the nodes of the triangular zone overlap boundary nodes of the tetrahedral zone. As with connecting adjacent zones, the matching is done cell face by cell face using the Nodal Proximity setting of the Geometry and Boundaries dialog to determine how close to each other nodes must be to be considered overlapping.

It is easy to create boundary zones by extracting sub-zones from ordered zones in your dataset. For finite element zones, it may be possible to extract the desired boundary region using blanking and FE-boundary extraction. In general, however, finite element boundary zones must come from your grid generator or flow solver.

New boundaries are created by clicking New on the Geometry and Boundaries dialog. This displays The Edit Boundary dialog, shown below.

**Displaying Boundaries**

The current settings of the Geometry and Boundaries dialog may be displayed by clicking the [Display Boundaries] button. This creates a new frame and plots all zone boundaries. For each zone in your solution data, one zone will be created in the new frame for each boundary condition applied to the boundary faces of that zone. The names of these zones indicate their zone of origin in your solution data and the applied boundary condition.

For each boundary face in your solution, Tecplot 360 applies some simple rules to determine that face's boundary condition. First, all faces covered by the boundary definitions in the Boundaries list have the boundary conditions prescribed in the list applied to them. If a particular face is covered by more than one of these boundaries, the boundary lowest in the list takes precedence. If you have selected the Connect Adjacent Zones option, any faces not covered by the listed boundaries are then checked to see if they overlap faces of neighboring zones. Overlapping faces are assigned the boundary condition 'Interzone Boundary.' Finally, any boundary faces not assigned any other boundary condition will be assigned the default boundary condition you have chosen.

Since the Geometry and Boundaries dialog is modeless, you can explore the boundary definitions in this new frame prior to applying your settings. This is a convenient way to make sure you are applying the desired boundary settings.

Selecting the [Display Boundaries] button records a DISPLAYBOUNDARIES macro command if you are recording a macro file.

Since this feature creates a new frame, it cannot be saved in the data journal, and the current data journal is invalidated. If you subsequently save a layout file, you will be prompted to save a new data file.
Saving Geometry and Boundary Settings

Once you are satisfied with your geometry and boundary settings, you can save them by selecting the [Apply] button. When you apply your settings, a SETGEOMETRYANDBOUNDARIES macro is recorded (if you are recording a macro file).

22 - 4.3 The Edit Boundary dialog

The Edit Boundary dialog is displayed by clicking New on the Geometry and Boundaries dialog, or by selecting an existing boundary and then selecting Edit.

It allows you to identify a boundary of one or more zones, either by entering the zone number(s), face and index range on that face, or by entering the zone numbers of boundary zones, as discussed in Section 22 - 4 “Setting Geometry and Boundary Options”. Enter the desired options and select [OK] to add the boundary to the Geometry and Boundaries dialog.

Using Index Range-type Boundaries

For ordered zones, you may identify boundary regions by choosing a zone boundary, or face, and index ranges to specify a region on the face. To create an index range-type boundary, select Zone, Face and Index Range, and choose the desired boundary condition from the Boundary Condition drop-down menu. Select the zones to which this boundary will apply by entering their zone numbers in the Zone Numbers text field, or clicking [Select] and choosing the zones from the resulting dialog. (See Section 22 - 7 “Performing Integrations” for a description of the Select Zones dialog.) If you have selected zones by clicking in the work space, you may enter these zone numbers by clicking Use Selected. Choose a face from the Zone Face drop-down and enter the index ranges in the remaining text fields. When you select [OK], the new boundary will appear in the Boundaries list in the following format:

<bc>,<set>,<face>,INDEXMIN,INDEXMAX,INDEXMIN,INDEXMAX

<bc> is the boundary condition, one of Inflow, Outflow, Wall, Slipwall, Symmetry, and Extrapolated. <set> is the set of zone numbers to which the boundary applies, enclosed in square brackets. <face> is one of I=1, 1=IMAX, J=1, J=JMAX, K=1, and K=KMAX and the remaining parameters are the minimum and maximum indices on the face, with zero indicating the maximum index value, and negative numbers indicating offsets from the maximum index value. For example, the following line would indicate a wall boundary condition set on the J = 1 face of zones 2, 4, 5, and 6 from I = 1 to IMAX and K = 3 to KMAX - 2:

Wall,[2,4-6],J=1,1,0,3,-2
Using Boundary Zone-Type Boundaries

For all zone types, you may identify boundary zones, as discussed in Section 22.4 “Setting Geometry and Boundary Options”. Toggle-on Specify Boundary Zones and choose the desired boundary condition from the Boundary Condition drop-down menu. Enter the zone numbers of the boundary zones, or click Select and choose them from the resulting dialog. The boundary will be applied to any volume (3D) or surface (2D) zones in the dataset. The boundary appears in the Boundaries list in the following format:

\(<bc>,<set>\)

where \(<bc>\) is as described above, and \(<set>\) is the set of boundary zones that define the boundary.

22 - 5 Unsteady Flow

Tecplot 360 can perform particle path and streakline calculations for unsteady flow solutions. To enable this feature, it must know which zones correspond to which solution time levels in your unsteady solution. Each solution time level may comprise one or more zones, which may be ordered, finite element, or both. Many data loaders supply this information. You may also enter it in the Unsteady Flow Options dialog.

For a layout with multiple datasets, separate settings are maintained for each dataset. You can copy the settings from one dataset to another using the Save Settings and Load Settings options in the Analyze menu. These actions also transfer the settings made in the Fluid Properties, Reference Values, Field Variables, and Geometry and Boundaries dialogs.

The Unsteady Flow Options dialog, shown below, is displayed by selecting Unsteady Flow Options in the Analyze menu.

It contains an option allowing you to specify that your solution is steady-state, a list to display unsteady time levels you enter, as well as controls for entering new time levels.

22 - 5.1 Specifying a Steady-state Solution

To direct Tecplot 360 to treat your dataset as representing a steady-state solution, select the Flow Solution is Steady-State option. This setting disables the remainder of the dialog.

To direct Tecplot 360 to treat your dataset as an unsteady solution, toggle-off Flow Solution is Steady-State. This enables the remainder of the dialog, where you can identify your solution time levels.

An unsteady flow solution consists of a sequence of zones that represent successive solution times. Each time level may be represented by one or more zones. Identify solution time levels by entering the zone number(s) for a particular solution time level in the Zones text field and the time they represent in the Time text field, then selecting [Add]. The zones and associated time appear in the Solution Time Levels
list. You may edit an existing time level by selecting it in the list. Its time and zones appear in the text fields, where you may edit them. Clicking Replace updates the currently selected list time level with the modified one.

By manually entering each time and associated zones in the text fields, you may identify all solution time levels in the current dataset. For large numbers of zones, two additional methods of entering time levels are provided. If your solution, or some portion of it was calculated with a constant time step, you may use the Group Zones by Time Step Dialog to enter all of these time levels at once. Alternatively, if your zone names contain the solution time each zone represents, you may enter all of your time levels by parsing the zone names for their corresponding solution time. These options are discussed below.

22 - 5.2 Group Zones by Time Step Dialog

The Group Zones by Time Step dialog allows you to enter a sequence of solution time levels into the Unsteady Flow dialog more easily than manually entering each time level.

- **Starting Zone** - Enter the first zone of your solution data that you wish to be included in the grouping operation.
- **Ending Zone** - Enter the final zone of your solution data that you wish to be included in the grouping operation.
- **# Zones per Level** - Enter how many zones represent each solution time level.
- **Starting Time** - Enter the solution time which will be assigned to the first zone or group of zones identified in this operation.
- **Time Step** - Enter the time step of your solution. The solution time of each time level will be calculated by adding this time step to the previous time level’s solution time.
- **Add to List** - Toggle-on to add all time levels identified by this operation to any time levels which already exist. If the time calculated for any of the new levels already exists in the list, this will generate an error.
- **Replace List** - Toggle-on to replace any time levels in the list with the time levels identified in this operation.

22 - 5.3 Parsing Zone Names for Solution Time

If the names of your solution zones contain the solution time they represent, you may automatically enter all time levels by parsing the zone names for these times. Zones of the same solution time will be grouped
Calculating Variables

The PLOT3D functions create dataset variables which are derived from CFD grids and solution data. This group of functions initially appeared in NASA's PLOT3D program and were expanded in PLOT3D's successor, FAST. The functions include grid quality measures, as well as scalar and vector flow variables. For a complete list of functions, refer to Chapter E: “PLOT3D Function Reference”. The functions are calculated with the Calculate dialog.

Many of these calculations are affected by settings in the Fluid Properties dialog (see Section 22 - 1 “Specifying Fluid Properties”), the Reference Values dialog (see Chapter 22 “Specifying Reference Values”) and the Field Variables dialog (see Section 22 - 3 “Identifying Field Variables”).

For the Calculate dialog to be displayed, the active frame must contain a dataset. The Calculate dialog, shown below, may then be displayed by selecting Calculate Variables in the Analyze menu.

- **Name** - This text field indicates which function will be used for the calculation. Type in the name of the desired function, or click Select to choose from a list of all available functions (see Selecting a Function dialog). Alternatively, you may enter the equivalent PLOT3D function number, as shown in the Chapter E: “PLOT3D Function Reference”.

- **Normalizing a Function** - A function may be normalized in one of two ways:
  - **Maximum Magnitude** - Divides the function value at each grid point by the maximum value in magnitude, such that the absolute value of the function is never greater than one. For vector functions, each vector component is divided by the maximum vector length.
  - **Reference Values** - Divides the function value at each grid point by the same function calculated with the reference values (the values entered in the Reference Values section of the dialog). This is the type of normalization performed by PLOT3D in its normalized functions. This option is not available for grid quality functions, since no meaningful reference values exist for these functions. It is also not available for functions whose reference value is zero, such as pressure coefficient.
  - **No Normalization** - Select to disable normalization.

This action will first delete all existing time levels, and then attempt to parse the zone names for new time levels. You may wish to view your zone names before attempting this action. You may view and edit zone names with the Data Set Information dialog (accessed via the Data menu).

22 - 6 Calculating Variables

The PLOT3D functions create dataset variables which are derived from CFD grids and solution data. This group of functions initially appeared in NASA's PLOT3D program and were expanded in PLOT3D's successor, FAST. The functions include grid quality measures, as well as scalar and vector flow variables. For a complete list of functions, refer to Chapter E: “PLOT3D Function Reference”. The functions are calculated with the Calculate dialog.

Many of these calculations are affected by settings in the Fluid Properties dialog (see Section 22 - 1 “Specifying Fluid Properties”), the Reference Values dialog (see Chapter 22 “Specifying Reference Values”) and the Field Variables dialog (see Section 22 - 3 “Identifying Field Variables”).

For the Calculate dialog to be displayed, the active frame must contain a dataset. The Calculate dialog, shown below, may then be displayed by selecting Calculate Variables in the Analyze menu.

- **Name** - This text field indicates which function will be used for the calculation. Type in the name of the desired function, or click Select to choose from a list of all available functions (see Selecting a Function dialog). Alternatively, you may enter the equivalent PLOT3D function number, as shown in the Chapter E: “PLOT3D Function Reference”.

- **Normalizing a Function** - A function may be normalized in one of two ways:
  - **Maximum Magnitude** - Divides the function value at each grid point by the maximum value in magnitude, such that the absolute value of the function is never greater than one. For vector functions, each vector component is divided by the maximum vector length.
  - **Reference Values** - Divides the function value at each grid point by the same function calculated with the reference values (the values entered in the Reference Values section of the dialog). This is the type of normalization performed by PLOT3D in its normalized functions. This option is not available for grid quality functions, since no meaningful reference values exist for these functions. It is also not available for functions whose reference value is zero, such as pressure coefficient.
  - **No Normalization** - Select to disable normalization.
• **New Var Location** - You may select the location (nodal or cell-centered) of new variables created during a calculation with the **New Var Location** dropdown. Variables that already exist in the dataset keep their existing locations.

• **Calculate on Demand** - This option adds the selected variable to the dataset, but delays the actual calculation until it is needed. This is discussed in more detail below.

• **Calculating the Function** - Selecting [Calculate] performs the calculation for each zone in the active frame. If this is the first time the selected function has been calculated, a new variable is added to the dataset with the name of the function. Otherwise, you will be prompted to overwrite the previously calculated variable with new values. For vector functions, each component of the function is added to the dataset, with $X$, $Y$, and $Z$ prefixed to the variable name, and (vector) removed from the name. If the function is normalized, (Max-Normalized) or (RV-Normalized) is appended to the variable name, depending on the option selected. Upon completion of the calculation, you will be informed of the new variable's minimum and maximum values and their locations.

22 - 6.1 Shared Variables

If variable sharing is enabled, all variables from which the function is calculated are shared between multiple zones, and they and the calculated variable are all at the same location (cell-centered or nodal), the new variable will be shared as well. You can see which variables in a dataset are shared in the Data Set Info dialog (accessed via the Data menu).

22 - 6.2 Calculate-on-demand Variables

Variables calculated with the Calculate-on-demand option are added to the dataset, but are not calculated until they are needed. This can save a lot of time when working with unsteady solutions where only a small number of zones are displayed at any given time. Displaying a contour plot of the calculated variable will only result in calculation of the variable for the currently active zones. Activating new zones (by, for example, advancing the solution time displayed in Tecplot 360) will result in the calculation being performed only for the newly displayed zones.

If you wish to force the variable to be calculated for all zones at once, you may re-do the calculation with the calculate-on-demand toggle-off.

A calculate-on-demand variable is a function of other variables in the dataset and is calculated using the Calculate dialog. Calculate-on-demand variables are recalculated whenever a variable that they are a function-of is recalculated. For example, given $\text{Pressure} = f(\text{Gas Constant})$, if the value of $\text{Gas Constant}$ changes, $\text{Pressure}$ is recalculated.

You cannot modify a variable that is calculated on demand.

To avoid circular data dependencies, you are prevented from selecting calculate-on-demand variables in the Fluid Properties or Field Variables dialogs. In addition, you cannot delete any variables on which a calculate-on-demand variable is dependent.

If you plan to make a sequence of changes to your data and analysis settings, you can inhibit these automatic recalculations by turning off Tecplot 360's Auto-Redraw feature. Recalculation will then take place only when you redraw the frame.
Calculating Variables

22 - 6.3 Undoing a Calculation
If the data journal is valid, alterations made to the dataset with the Calculate dialog may be undone by selecting Undo from the Edit menu. This will result in Tecplot 360 re-executing the data journal, which may be a lengthy process.

22 - 6.4 Selecting a Function
The function name may be typed into the Name text field, or selected from a list which contains all available functions. Click [Select] to display the Select Function dialog.

Selecting a function from this dialog and selecting [OK] enters that function in the appropriate area. Functions in this list which only apply to 3D solution data begin with (3D). Vector functions, whose names are appended with (vector), calculate three vector components. Each of the available functions is described in Chapter E: “PLOT3D Function Reference”.

An alternative method of selecting a function is to enter its equivalent PLOT3D function number. These numbers may also be found in Chapter E: “PLOT3D Function Reference”. If a valid function number is entered into the Name text field in the Calculate dialog, Tecplot 360 replaces the number with the name of the corresponding function and sets the Normalize drop-down to None or Reference Values as appropriate.

22 - 6.5 Gradient Calculations
Most of the PLOT3D functions are scalar functions. Gradient calculations are a notable exception to this rule, however, and depend on values at neighboring points. Understanding how these calculations are performed may help you interpret the results.

Gradients in Ordered Zones
If an ordered zone is connected to neighboring zones, its gradients are calculated using the same method as for finite element zones (see below). Gradients in unconnected ordered zones are calculated using standard finite-difference formulae. Pressure gradient, for example, is calculated in the following manner.
\[
\n\nabla p = \begin{bmatrix}
\xi p_1 + \eta p_2 + \zeta p_3 \\
\xi p_4 + \eta p_5 + \zeta p_6 \\
\xi p_7 + \eta p_8 + \zeta p_9
\end{bmatrix}
\]  

(EQ 11)

Where \( \xi \) indicates the I-direction, \( \eta \) indicates the J-direction, \( \zeta \) indicates the K-direction and subscripts indicate partial derivatives. In the zone interior, derivatives are estimated with second-order central differences, such as:

\[
\begin{align*}
\frac{p_{i, 1+1} - p_{i, 1-1}}{2} & \quad \text{or} \quad \frac{p_{i, 1+1/2} - p_{i, 1-1/2}}{2}
\end{align*}
\]  

(EQ 12)

The left-hand form is used for calculating gradients at nodes, and the right-hand form is used at cell centers. For boundary nodes, first-order one-sided differences are used.

**Gradients in Finite Element Zones**

The coordinate transformation approach used in unconnected ordered zones is generally not possible for finite element zones. Instead, the variable, say pressure, is assumed to vary linearly in all dimensions, giving:

\[
p - p_0 = \Delta p = \Delta x p_x + \Delta y p_y + \Delta z p_z = \Delta X \cdot \nabla p
\]  

(EQ 13)

where \( p_0 \) is the pressure at the node or cell center in question. Next a matrix equation is formed with the pressure difference for all nodes neighboring the current node (connected to the current node by a cell edge).

\[
\begin{bmatrix}
\Delta x_1 \\
\Delta x_2 \\
\Delta x_3 \\
\Delta x_4
\end{bmatrix}
\begin{bmatrix}
p_1 \\
p_2 \\
p_3 \\
p_4
\end{bmatrix} = \begin{bmatrix}
\Delta p_1 \\
\Delta p_2 \\
\Delta p_3 \\
\Delta p_4
\end{bmatrix}
\]  

(EQ 14)

This equation is generally over-specified and is inverted by least-squares to find the gradient vector.

**22 - 6.6 Surface Normal Calculations**

With Tecplot 360’s CFDA variable calculation feature, you can calculate and display surface normal vectors on your plot. This includes the following steps:

1. With the **Calculate** dialog, calculate the “Grid K Unit Normal (vector)”, using Cell Center as the New Var Location.
2. Turn on the Vector layer, selecting the components of the vector you just calculated as the vector components.
3. In the **Zone Style** dialog, on the Points page, choose “Cell Centers Near Surfaces” as the Points to Plot.

In detail, the steps above include the following.
Performing Integrations

To calculate the normal, choose “Calculate Variables” from the Analyze menu. In the Calculate dialog, choose “Grid K Unit Normal (vector)” as the variable to calculate (to do this, click the Select button, and scroll down in the list that appears to find “Grid K Unit Normal (vector)”, and click it). Choose “Cell Center” as the New Var Location, and click Calculate.

Next, toggle-on the Vector layer in the sidebar to turn on the normal vectors, and choose the components of the calculated vector to display in the Select Variables dialog for vectors. This dialog appears when you toggle-on the vector layer for the first time; you can also open the dialog by going to Plot > Vector > Variables in the menu. To display the “Grid K Unit Normal (vector)” normal, choose the three components “X Grid K Unit Normal”, “Y Grid K Unit Normal”, and “Z Grid K Unit Normal” for the X, Y, and Z components of the vector layer, respectively.

Lastly, click the Zone Style button in the sidebar to open the Zone Style dialog. In that dialog, switch to the Points page, and choose “Cell Centers Near Surfaces” from the Points to Plot menu.

If you wish to display normal vectors on a plot that does not have an identifiable plane to use, choose “Extract” from the Data menu, and choose “FE-Boundary”. In the Extract FE-Boundary dialog, extract a boundary zone from a source zone. You can then use the extracted zone to display the normal vectors.

22 - 7 Performing Integrations

Tecplot 360 provides a flexible integration feature. You can integrate scalar dataset variables as well as vector variables dotted with grid unit normal or unit tangential vectors, and you can integrate by zone in a single time step, or by time strand. Tecplot 360 also has several pre-defined integrations, such as mass flux, which simplify the integration process. In ordered zones, you can integrate these quantities over cell volumes, face areas, or lines. In finite element zones, you can integrate over cell volumes. In addition, you can calculate lift, drag, side force and moments due to pressure and viscous forces acting on a surface or a set of surfaces.

The results of the integration may be displayed in a text window (and subsequently saved to a text file), or plotted in a frame. In the latter case, the solution time of the integration plot's frame is linked to the original frame's solution time and a marker gridline is displayed on the integration plot to indicate the time step. All of these features are accessed via the Integrate dialog (accessed via Analyze>Perform Integration).

Many of these calculations are affected by settings in the Fluid Properties dialog (see Section 22 - 1 “Specifying Fluid Properties”), the Reference Values and Field Variables dialog (see Section 22 - 3 “Identifying Field Variables”) and the Geometry and Boundaries dialog (see Section 22 - 4 “Setting Geometry and Boundary Options”).

Integrations of a variable or variable function use the trapezoidal method, and are second-order accurate. For each segment, face, or volume cell, the appropriate nodal or cell-centered values are averaged and multiplied by the cell length, area or volume. The calculation sums the resulting quantities over the zone or specified subset to produce the integrated result. Standard deviation is calculated using the sample standard deviation method (the values are taken to be a sample of a population, and the sum of the squares of the value is divided by N-1 rather than by N).
The Integrate dialog is displayed by selecting Perform Integration from the Analyze menu.

![Integrate dialog](image)

The resulting dialog provides options to specify the zone(s) of integration, the variable to be integrated, the domain of integration and display methods.

- **Type of Integration** - Tecplot 360 can perform simple, path, surface, and volume integrals. Refer to Integrate Over to see how to select these using the current plot type. Tecplot 360 defines the following fourteen integration types:
  - **Length/area/volume** - The physical size of the integration domain.
  - **Scalar** - The integral of a single variable.
  - **Average** - The area or volume-weighted average of a single variable over the domain.
  - **Mass weighted scalar** - The integral of a single variable multiplied by density.
  - **Mass weighted average** - The weighted average of a single variable, with density as the weighting function.
  - **Weighted average** - A general weighted average—both the variable and the weighting function are specified.
  - **Scalar flow rate** - The convection of a scalar through a surface. It is calculated by integrating the dot product of the flow velocity and the surface unit normal multiplied by the scalar variable.
  - **Mass flow rate** - The convection of density through a surface. This is calculated by integrating the dot product of the flow velocity and the surface unit normal multiplied by the density.
  - **Mass weighted flow rate** - The convection of a scalar multiplied by density through a surface. This is calculated by integrating the dot product of the flow velocity and the surface unit normal multiplied by the scalar variable and density.
Performing Integrations

- **Mass flow weighted average** - The weighted average of a scalar variable on a surface. Here the weighting function is the dot product of the flow momentum vector (velocity multiplied by density) and the surface unit normal.

- **Forces and moments** - The integral of pressure and viscous stresses on a surface. The Forces and Moments option integrates pressure and shear stresses over lines (2D) and planes (3D). Pressure is assumed to act in the opposite direction of the unit normals. These are calculated by integrating the dot product of the stress tensor and the surface unit normal. This will correctly calculate lift and drag if, for example, you have a 2D airfoil defined by the J=1 line and you integrate forces and moments over I-lines (or J-planes) for J=1.

 Forces and Moments are calculated as six quantities: X, Y and Z-Force and X, Y and Z-moments about the origin. For backward compatibility, the forces are also displayed as Lift, Drag and Side force. Lift and Drag are the forces rotated in the XY-plane such that Lift is normal to the reference flow direction (specified on the Reference Values dialog) and Drag is parallel to it. Side force is equal to Z-Force. If an I-ordered zone (in 2D) or a surface zone (in 3D) has been defined as a boundary to a surface (2D) or volume (3D) zone, then you can perform a Forces and Moments integration over this boundary zone. Tecplot 360 takes the shear stress and unit normal direction from the associated zone. This allows you, for example, to perform Forces and Moments integrations for finite element solutions, provided you have a line or surface zone that defines the surface, and you have identified this zone as a boundary zone in the Geometry and Boundaries dialog.

- **Vector-dot-normal** - The integral over a surface of a vector dotted with the surface unit normals. Here the components of the vector are dataset variables.

- **Vector average** - The weighted average of a scalar variable on a surface. The weighting function is the dot product of a vector with the surface unit normal. Both the scalar and the vector components are dataset variables.

- **Vector-dot-tangential** - The integral on a line of a specified vector dotted with the line unit tangential vector.

Options that involve a unit normal must be integrated over a domain where the unit normal direction can be determined. Acceptable domains include lines in 2D or planes in 3D, as well as triangular or quadrilateral zones in 3D. The vector-dot-tangential options can only be integrated over lines. Unit normals are discussed further in Section 22 - 7 "Performing Integrations".

If you have selected the 2D Cartesian plot type and have specified that the geometry is axisymmetric, an axisymmetric integration will be performed. Tecplot 360 multiplies each grid segment’s or cell’s contribution to the integration by \( \frac{2\pi r}{R} \), where \( r \) is the distance from the centroid of the segment or cell to the axis of symmetry.

- **Integrand** - Some of the available types of integrations require you to choose variables from your dataset to be integrated. Where required, fields in the Integrand section of the dialog will be enabled. You may type in the variable names, or click Select to choose variables. For Forces and Moments integrations, pressure and the components of velocity are calculated from the field variables identified on the Field Variables dialog.

- **Specifying the Domain of Integration** - The domain of integration is defined by zone or time strand numbers and index ranges. For ordered zones, you may choose whether to integrate over lines, planes, or volumes. You may also choose to use the absolute value of calculated volumes, which can be useful for finite element zones where the node ordering may result in erroneous calculations. Finally, you can choose to exclude regions not displayed due to index or value blanking. Please refer to Chapter 19 “Blanking” for more information on blanking.
• **Integrate By**
The Integrate By drop-down menu lets you specify whether to integrate over specific zones or specific time strands.

• **Integrate Over**
The Over drop-down menu allows you to specify cells, planes of constant I, J, or K, or lines of varying I, J, or K. For tetrahedral and brick finite element zones, only volume integration is allowed. For quadrilateral and triangular finite element zones, only K-planes are allowed (selecting Cells for these zones is equivalent to selecting K-planes, since they are logically 2D). For 2D and 3D Cartesian plot types, integrations over lines are performed as path integrals and integrals over planes are performed as surface integrals. Integrals in XY line plots integrate the chosen variable along the X axis to calculate the area between the curve and the X axis. Volume integrations should be done in 3D Cartesian plots—volume integrations in 2D Cartesian plots will give zero results.

If a vector dot product is to be integrated, then the domain must have an identifiable normal or tangential direction. In 3D Cartesian plots, this usually means I, J, or K-planes will be selected. The normals in these cases will point in the +I, +J, and +K-directions, respectively, or the reverse for a left-handed grid. I, J, and K-planes do not have an identifiable tangential direction, so vector-dot-tangential integration over planes generates an error.

If I, J, or K-Lines are selected, the tangential vectors point in the positive-index direction. Vector-dot-normal integration is also available, but may not be meaningful—the normal is calculated by taking the cross-product of the tangential and the +Z-axis.

In 2D Cartesian plots, I-planes are equivalent to J-lines, J-planes is equivalent to I-lines, and K-planes is equivalent to cells. (It may be better to ignore planes in two dimensions.) Both normal and tangential directions are available in all cases. However, the normal to K-planes points in the third dimension; it may not be meaningful.

For quadrilateral and triangular finite element zones, the normal direction is found with the right-hand rule—if the fingers of the right hand are curled in the direction of a line drawn from cell node 1 to node 2, thence to node 3, then the thumb will point in the direction of the normal.

• **Zones/Time Strands** - Depending on whether you have chosen to integrate by zones or by time strands, this text field allows you to specify which zones or time strands the variable will be integrated over. You may enter a single zone or strand, a range with a hyphen (for example, 3-5), or a combination of these, separated by commas (,). For convenience, the [All] button will set this text field to indicate all zones or time strands. The [Active] button will list all zones or time strands currently active. You may also select items from a list by clicking Select, which calls up a separate selection dialog.

• **Specifying Index Ranges** - Below the Zone or Time Step field are I, J, and K-index ranges. These ranges will be applied to each zone over which the integration is performed. The three comma separated items in each index range indicate the starting index, the ending index and the skip factor, respectively. For finite element zones, only the J-index settings have effect. These indicate the range of cells over which the integration will be performed. For reasons discussed below, a skip factor of unity is probably desirable for these cases.
Performing Integrations

To enter or change an index range, select the button over the desired range's text field. The Enter Range dialog will be displayed.

Enter the starting index in the Begin field, the ending index in the End field, and the skip factor in the Skip field.

You have two options for entries into the End field. You can enter a number, in which case the maximum allowable value is displayed at the top of this dialog, and indicates the smallest size of the given index for all of the zones listed on the Integrate dialog. Alternatively, you can enter “Mx” to use the maximum index for each individual zone, “Mx - 1” to use one less than the maximum and so on. A skip factor of 1 means “use every point in the range,” a skip of two means, “use every other point”, and so forth.

For linear and planar integration, skip factors are ignored along the line, or within the plane of integration. For example, if you are integrating along I-lines, the I-skip factor will be ignored. Minimum and maximum index values are always used.

- **Time Min/Max** - When integrating by time strands, these fields appear to the right of the Index Range, allowing you to specify the starting and ending time steps for the integration. Click the Reset Min/Max button to set these fields to the first and last time steps in your data set, respectively.

- **Use Absolute Values of Volume** - Takes the absolute value of the volumes of 3D grid cells used for integration. This is useful if you have a finite element grid with arbitrary node ordering such that the calculated volume of cells may be positive or negative. Negative grid cell volumes occur when left-handed grids are used in Tecplot 360. A right-handed ordered zone will have the +J-direction proceeding to the left of the +I-direction when viewed from the +K-direction. For finite element zones, the nodes of each cell will proceed counter-clockwise when viewed from the direction of the highest-numbered node.

- **Exclude Blanked Regions** - Removes from the integration domain portions of any zones that are hidden due to value or index-blanking. (Note that 3D depth blanking has no effect.) Excluding blanked regions can lead to unexpected results, depending on the blanking settings. In particular, note that blanking options allow for a cell to be blanked when any of its nodes is blanked, when its “primary” (or lowest-numbered) index is blanked, or only when all of its nodes are blanked. As a result, cells may still be displayed where some nodes have been blanked. Figure 22-5 illustrates this effect. Index blanking has been used to blank all nodes along the J=1 line, but all cells are still displayed. An integration over volumes or K-planes would include the entire mesh, while integrations over I-lines or J-lines would exclude the J=1
line. In general, display the Mesh layer to see the domain of integration if you are integrating over volumes in 3D or planes in 2D, and display the Scatter layer to see the remaining types of integration domain. See Chapter 19: “Blanking” for more information on blanking.

Figure 22-5. The effect of blanking on nodes and cells.

- Performing the Integration - Selecting Integrate at the bottom of the Integrate dialog will perform the integration and display the results. Tecplot 360 uses the trapezoidal method, a second-order method which averages nodal values to cell, face, or edge centers, then sums the products of these values with the corresponding cell volumes, areas, or lengths.

Section 22 - 7.2 “Accessing Integration Results in Macros”
Section 22 - 7.3 “Integration Examples”
Section 21 - 1 “Data Alteration through Equations”
Section 22 - 6 “Calculating Variables”
22 - 7.1 Specifying Display Options

Displaying Tabulated Results

You can display the results of an integration in a text dialog, plotted, or both. The options at the bottom of the Integrate dialog (accessed via Analyze>Perform Integration) control these settings. When you have “Show Tabulated Results” toggled-on, integration results will appear in a text dialog, as shown below.

This dialog presents two additional options. Selecting the [Save] button displays a file selection dialog which allows you to save the integration results to a text file. The [Make Text] button places a text field containing the results into the active frame. Make sure you have the frame in which you wish to place the results selected as the active frame before you select this button.

Plotting Results

Setting the Plot Results As check box results in the integration results being plotted in a new frame. Each zone or time strand used in the integration results in a corresponding zone being created in this frame. For Cell integrations, the plot will not be useful, because it will contain only a single point in each zone. For plane (in 3D) or line integrations where multiple planes or lines are integrated in each zone or time strand, plotting can be very useful. In these cases, the results for each plane or line are plotted versus the corresponding index or indices.

When integrating by time strand, a new variable called “Solution Time” will be generated and plotted as the independent variable. Integration results for co-relevant zones are summed to a single point for each solution time. If no relevant zones exist at a given solution time, the integration is zero at that time step.

For all integrations except Forces and Moments, the text field to the right of the Plot Results As check box may be used to name the variable used to hold the integration results in the results plot. For Forces and Moments, the nine variable names will be Lift, Drag, Side, X-Moment, Y-Moment, Z-Moment, X-Force, Y-Force and Z-Force, with Lift initially being the only variable displayed.

Because the plotting feature creates a new frame, it cannot be saved to the data journal, and the current data journal is invalidated. If you subsequently save a layout file, you will be prompted to save a new data file.
22 - 7.2 Accessing Integration Results in Macros

Macro commands may access the results of the most recent integration through specific environment variables. Each of these variables represents the total over all zones (the final number shown in the Integration Results dialog). For all integration types except Forces and Moments, the single result is stored in the variable INTEGRATION_TOTAL. Table 22 - 1 shows the variable names for forces and moments.

<table>
<thead>
<tr>
<th>Integration Types</th>
<th>Environment Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forcs and Moments</td>
<td>INTEGRATION_LIFT</td>
</tr>
<tr>
<td></td>
<td>INTEGRATION_DRAG</td>
</tr>
<tr>
<td></td>
<td>INTEGRATION_SIDE</td>
</tr>
<tr>
<td></td>
<td>INTEGRATION_VMOMENT</td>
</tr>
<tr>
<td></td>
<td>INTEGRATION_ZMOMENT</td>
</tr>
<tr>
<td></td>
<td>INTEGRATION_XFORCE</td>
</tr>
<tr>
<td></td>
<td>INTEGRATION_YFORCE</td>
</tr>
<tr>
<td>All other types</td>
<td>INTEGRATION_TOTAL</td>
</tr>
</tbody>
</table>

Table 22 - 1: Environment variables for integration results.

Environment variables are accessed in macros in the same way as regular macro variables, except that a $ prefix is prefixed to the variable name. For example, the following macro command would display the most recent scalar integration:

```
$!PAUSE "integration total = \$INTEGRATION_TOTAL"
```

You can also access integration results as frame auxiliary data. For example, to access the INTEGRATION_TOTAL variable as aux data, use the following syntax:

```
$INTEGRATION_TOTAL = &($INTEGRATION_TOTAL)
DATASET.INTEGRATION_TOTAL = &/AUXFRAME:CFDA.INTEGRATION_TOTAL
```

For more information on aux data, see Section “AUXFRAME:Auxname” in the Scripting Guide.

22 - 7.3 Integration Examples

The following sections demonstrate potential uses of the Integrate dialog.

Calculating the Volume Under a Surface

Figure 22-6 shows a 3D surface. We want to calculate the volume between that surface and the Z=0 plane. To do this, integrate Z over the projection of the surface onto the Z=0 plane. To get this projection, switch
Performing Integrations

to 2D Cartesian plot type. Ensure that the same variables used for X and Y in 3D are used for X and Y in 2D using the Assign XYZ dialog (available in the Plot menu).
Figure 22-6. A 3D surface.

To set up the **Integrate** dialog to perform the integration, choose Scalar as the integration type and Z as the scalar variable. The remaining controls are left at their default settings. Selecting Integrate displays the volume under the surface. The **Integrate** dialog and the results are shown in **Figure 22-7**.

![Integrate dialog and results](image)

**Figure 22-7.** The Integration dialog and the integration results for calculating the volume under the surface shown in **Figure 22-6**.

**Internal Flow Examples**

The next few examples will demonstrate some uses of the **Integrate** dialog for internal flows, such as flow through a jet engine or a pipe. Our dataset consists of a single I-J ordered zone. It is shown with the mesh and contours of pressure in **Figure 22-8**.

![Internal flow solution](image)

**Figure 22-8.** An internal flow solution. This file, *intflow.lpk*, is located in your Tecplot 360 distribution under the examples/2D subdirectory.

**Calculating Total Mass**

To calculate the total mass we must integrate density over volume (or area in 2D). If your dataset does not contain density, it may be determined using the **Calculate** dialog. (See Section 22.6 "Calculating Variables") Select the Scalar Integral integration type, choose the density variable as the scalar, then
Performing Integrations

integrate over Cells (which is demoted to K-planes for our IJ-ordered data). When we click Integrate, the total mass appears as the result of the integration. The Integrate dialog and the results are shown in Figure 22-9.

Figure 22-9. The Integration dialog and the integration results for calculating the volume under the surface shown in Figure 22-8.

Calculating Mass Flow Rate

Calculating Mass Flow Rate

To calculate mass flow rate, you must first set your convective variables in the Field Variables dialog. See Section 22 - 3.1 "Choosing the Convective Variables" for information on setting these variables.

We will now calculate the mass flow rate at various stations in the streamwise direction. This will give us an indication of how well converged our solution is to steady-state. The Integrate dialog makes this easy with the Mass Flow Rate integration type. We select this option and specify integration over J-lines (which is equivalent to I-planes in 2D). Note that the entire Integrand section of the dialog is disabled. Tecplot 360 calculates the necessary variable (momentum) from information entered in the Fluid Properties and the Field Variables dialogs.

We only wish to plot the results, so we select this option at the bottom of the Integrate dialog, specifying that the result be named “Mass Flow.” When we select Integrate, the mass flow rate is plotted versus I-
index in a new frame. The **Integrate** dialog and the plotted results are shown in **Figure 22-10**. From the results, we see that our solution was not fully converged.

**Figure 22-10.** The **Integration** dialog and the results of calculating the mass flow rate of the object in **Figure 22-8**.

**Calculating Mass-weighted Stagnation Pressure**

We will now calculate a quantity commonly used in engine analysis, the mass-weighted stagnation (or total) pressure. Although it is referred to as “mass-weighted,” the weighting function is actually the mass flow rate. Accordingly, select Mass Flow-weighted Average for the integration type, choosing the Stagnation Pressure variable from our dataset (previously calculated with the **Calculate** dialog). Since we are only interested in this value at the exit plane, we again select J-lines (from the “Integrate Over” drop-down menu), but now specify an I-range of \((M_x, M_x, 1)\) to integrate only the \(I=I_{\text{Max}}\) plane. We choose only
Performing Integrations

to display the result in a text dialog. Select [Integrate] to perform the calculation. The Integrate dialog and the result are shown in Figure 22-11.

![Integrate dialog and results](image)

**Figure 22-11.** The Integration dialog and results for calculating the mass-flux weighted average integral for the data in Figure 22-8.

**Calculating Lift and Drag**

Our final example makes use of a three-element airfoil solution, an example of an external flow solution. Our data consists of four zones. Three zones are IJ-ordered zones which capture the Edge layer about each of the elements. The fourth zone is a triangular finite element zone that fills the remaining airspace about the elements. Pressure contours and streamtraces of this solution are shown in Figure 22-12.

![Three element airfoil solution](image)

**Figure 22-12.** A three element airfoil solution. This file, 3element.lpk, is located in your Tecplot 360 distribution under the examples/2D subdirectory.

To calculate lift and drag for this airfoil configuration we use the Forces and Moments integration type. As with Mass Flow Rate, the entire Integrand portion of the Integrate dialog is disabled, because Tecplot 360 will derive the required values (pressure, velocity gradient, and viscosity) from settings in other dialogs.
We choose integrate over the surface \((\mathbf{f} \cdot \mathbf{n})\) line for each of the three Edge layer zones, the click Integrate. The **Integrate** dialog and results appears as in **Figure 22-13**.

![Integration dialog and results](image)

**Figure 22-13. The Integration dialog and the integration results for calculating the lift and drag for the data shown in Figure 22-12.**

The results of each zone are listed separately. Scrolling to the bottom of the **Integration Results** dialog, we see the total lift and drag, along with other force and moment data.

**Specifying the Origin for Moments**

When the **Forces and Moments** integration type is selected, the [Set Origin] button is active. Selecting this button displays the **Set Origin** dialog. In this dialog, you may specify the \(X, Y, Z\)-location of the origin about which the moments will be calculated.

![Set Origin dialog](image)

**Select Zones**

To select zones, choose [All], [Active], or [Select] from the Domain of Integration portion of the **Integrate** dialog. By choosing [Select], you may select the zones you want by clicking in the list, or by selecting [Zone Num] or [Zone Name] in the resultant **Select Zones** dialog. Selecting [Zone Num] calls up the **Enter Range** dialog, allowing you to indicate the desired zones by a numeric range. Selecting [Zone Name] prompts you for a pattern string, which is matched against the names of all zones. You may use the
Calculating Turbulence Functions

asterisk as a wildcard when entering the zone name pattern. All zones whose names match the pattern are then selected in the list ht.

22 - 8  Calculating Turbulence Functions

Tecplot 360 allows you to calculate and add to your dataset any of four turbulence-related quantities, provided you already have any given two in your dataset. Turbulent kinetic energy, dissipation rate, frequency and kinematic viscosity, and dynamic viscosity are available via the Turbulence dialog.

The Turbulence dialog is displayed by selecting Calculate Turbulence Functions from the Analyze menu.

It contains two drop-down menus and associated text fields for you to identify the two turbulence-related variables in your dataset, drop-downs for you to select the function you wish to calculate and the location of the calculated variable, a toggle to select calculate-on-demand, and a [Calculate] button to perform the calculation.

22 - 8.1  Identifying Turbulence Variables

The first two drop-down menus on the Turbulence dialog allow you to specify which turbulence variables are contained in your dataset. The options are Kinetic Energy ($\mathcal{K}$), Dissipation Rate ($\mathcal{c}$), Turbulent Frequency ($\omega$), Turbulent Kinematic Viscosity ($\nu_t$), and Turbulent Dynamic Viscosity ($\mu_t$). This last option is the kinematic viscosity, which is equal to the dynamic viscosity divided by the density.

22 - 8.2  Selecting the Variable Location

You may select the location (nodal or cell-centered) of new variables Tecplot 360 creates during a calculation with the New Var Location dropdown. This setting only affects new variables added to the dataset when you click Calculate. Variables that already exist in the dataset keep their existing locations. If you wish to change the location of an existing variable, you can delete or rename the variable and then perform the calculation with the desired setting for New Var Location.
22 - 8.3 Calculating on Demand

Selecting the Calculate on Demand option results in the calculated variable being added to the dataset when you click the [Calculate] button, but the actual calculation is delayed until it is actually needed. Please refer to the discussion of calculate-on-demand in Section 22 - 6 "Calculating Variables".

22 - 8.4 Performing the Calculation

Once you have identified two turbulence variables in your dataset, you may calculate either of the other two. Select the desired function from the Function drop-down menu and click [Calculate]. The function is calculated and added to your dataset as a variable with the same name as the function selected. If your dataset variables are \( k \) and \( \varepsilon \), the following formulae will be used for the calculations of \( \omega \) and \( v_t \):

\[
\omega = \frac{\varepsilon}{C_{\mu} k} \quad \text{(EQ 15)}
\]

\[
v_t = \frac{C_{\mu} k^2}{\varepsilon} \quad \text{(EQ 16)}
\]

with \( C_{\mu} = 0.09 \). Equations for other input variables are derived from these.

22 - 8.5 Shared Variables

If both variables from which the turbulence function is calculated are shared between multiple zones, and they and the calculated variable are all at the same location (cell-centered or nodal), the new variable will be shared as well. This mimics the behavior of the Data>Alter>Specify Equations dialog.

22 - 9 Calculating Particle Paths and Streaklines

For steady-state solutions, Tecplot 360 allows you to track the paths of massless particles by placing streamtraces in the flow. The Particle Paths and Streaklines dialog augments this capability by providing two additional visualization methods, particle paths and streaklines, for particles with or without mass.

Please note that these calculations, particularly for streaklines, may be very lengthy to perform, especially for cases with large grids.
Calculating Particle Paths and Streaklines

The Particle Paths and Streaklines dialog is displayed by selecting Calculate Particle Paths and Streaklines from the Analyze menu.

It contains a drop-down menu allowing you to choose particle paths or streaklines, as well as options pertaining to the path integrations, particles with mass, storage and display of the calculated particle paths. In addition, the results of streaklines may be animated.

**22 - 9.1 Calculating Particle Paths**

A particle path is the path that a single particle follows through a solution. In steady flow, particle paths are the same as streaklines and streamtraces for massless particles. To calculate particle paths, you must:

1. Place streamtraces at the locations where you wish particles to be released, then select Particle Paths from the drop-down menu at the top of the dialog. (Details on placing streamtraces may be found in the Chapter 15: "Streamtraces".)
2. Specify an integration time step. For steady-state calculations, specify the maximum number of time steps to be performed (see Section 22 - 5 "Unsteady Flow" for specifying steady or unsteady flow).
3. Set the Particles Have Mass option for particles with mass. Click Mass Options to set mass-related options.
4. Optionally, set the Create Single Ordered Zone From Particle Paths toggle to create a single IJ-ordered zone from all particle paths instead of a separate I-ordered zone from each path.
5. Select [Calculate].

**Specifying the Integration Time Step and Maximum Number of Steps**

Particle Paths are calculated by integrating the velocity field of your solution using a constant time step, which you enter in the Integration Time Step text field. A smaller time step will result in more accurate particle paths but will take longer to calculate. For unsteady calculations, the time step is set equal to the time interval between your solution time levels by default. If you specify so large a time step that a particle passes out of your solution domain in the first integration time step, you will get a warning message.

If you have set the Flow Solution is Steady-state option, you must also enter the maximum number of integration time steps to be performed (see also Section 22 - 5 "Unsteady Flow" on page 351).
Specifying Mass-Related Options

For particles with mass, set the Particles Have Mass option. This enables other mass-related controls in the dialog. Click Mass Options to display the Particle Mass Options dialog. (See Section 22 - 9.3 “Particles with Mass”) In addition, you have the option of storing the particle's velocity and other particle properties or the local flow properties along the calculated particle path. Select Store Particle Velocity, Temperature, and Mass to store these values along the particle path. Select Store Interpolated Solution Variables to store these values instead. Following the calculation, you will be informed of which dataset variables contain these values.

Performing the Particle Path Calculation

When you select Calculate, a particle is placed at the starting point for each streamtrace you have placed. If you did not place any streamtraces, you will get an error message. From these starting locations, beginning with the time equal to the time of your first solution time level (or zero for steady-state calculations), the particle positions are advanced by performing a second-order Runge-Kutta integration of the velocity field. For unsteady calculations, linear interpolation is performed between solution time levels. Integration for each particle is continued until the final time level is reached (unsteady calculations), the specified number of time steps has been performed (steady-state calculations), or until the particle passes out of your solution domain. The particle paths are displayed as new I-ordered zones in your dataset, with each integration step represented by a node in the new zones, unless you selected the Create Single Zone From Particle Paths option, which results in a single IJ-ordered zone.

Examining the Particle Paths

Each I-ordered zone created by a Particle Path calculation represents a path through space and time. The paths' non-grid variables will hold interpolated values of your solution data that the particle “saw” as it passed through your solution, except as discussed in Section “Specifying Mass-Related Options” on page 374. You can visualize this by coloring the particle zones' mesh plots with one of your solution variables. The following steps will accomplish this:

1. Turn on the Mesh plot layer by toggling-on the Mesh in the Sidebar.
2. Call up the Zone Style dialog (accessed via the Plot menu or the Sidebar).
3. Turn off mesh plotting for your solution zones by selecting the solution zones, clicking Mesh Show and selecting No.
4. If necessary, turn on mesh plotting for the Particle Path zones by selecting them, clicking Mesh Show and selecting Yes.
5. Color the Particle Path zones with a variable by selecting these zones, clicking Mesh Color and selecting Multi-color. If you had not previously chosen a contour variable, the Contour Variable dialog will open to allow you to select it. Choose the variable you wish to use to color the particle paths.
6. If Auto Redraw has not been selected, click Redraw to redraw your plot. You will see the particle paths displayed and colored with the contour variable.

You may wish to turn on the Scatter plot layer to see the size of these steps. If you do this, you will first want to turn off scatter plotting for your solution zones. You can also do this with the Zone Style dialog.

22 - 9.2 Calculating Streaklines

Streaklines simulate experimental techniques which involve the periodic or continuous release of a tracer substance, such as oil drops or smoke. Tecplot 360 produces streaklines by releasing a sequence of particles from the release points and integrating the unsteady velocity field to find their positions in the flow at the end solution time. The final positions of all particles emitted from a particular release point form one streakline. Once streaklines have been calculated, they may be animated on screen or to a file.
Calculating Particle Paths and Streaklines

To calculate Streaklines, perform the following actions:

1. Identify the solution time levels in your dataset. (See Section 22 - 5 “Unsteady Flow.”)
2. Place streamtraces at the locations where you wish particles to be released.
3. Select Streaklines from the drop-down menu at the top of the Particle Paths and Streaklines dialog.
4. Enter the integration time step as with particle path calculations. (See Section “Specifying the Integration Time Step and Maximum Number of Steps” on page 373.)
5. Specify the particle release frequency. (See Section “Specifying the Particle Release Frequency” on page 375.)
6. For particles with mass, set the Particles Have Mass option. Click Mass Options to set mass-related options.
7. Select [Calculate].

It is not reasonable to calculate streaklines for steady-state flow, because in steady-state flow, even for particles with mass, streaklines are the same as particle paths (just more time consuming to compute).

**Specifying the Particle Release Frequency**

For Streakline calculations, a sequence of particles is released throughout the solution time. Each particle’s position is integrated using the specified integration time step. The frequency with which particles are released is specified by the controls just above the [Calculate] button. In the Release text field, enter the number of particles to be released in the specified time interval. In the particles per drop-down menu, identify this time interval by selecting either Solution Time Level or Unit Solution Time.

If you select Solution Time Level, the indicated number of particles will be released, evenly spaced in time, between each pair of solution time levels you have identified. If you select Unit Solution Time, the particles will be released at regular intervals throughout the time covered by your solution. In either case, a particle will be released at the final time of your solution, so that the streaklines will include the release points themselves. Releasing particles more frequently will produce more detailed streaklines (the accuracy is determined by the Integration Time Step), but will take longer to calculate.

**Performing the Streakline Calculation**

When you click Calculate, the streaklines are calculated and added to your dataset as new 3-ordered zones. To see them, turn on the Mesh plot layer and disable mesh plotting for your solution zones. See Section “Examining the Particle Paths” on page 374.

**Animating Streaklines**

Once you have performed a streakline calculation, the animation controls of the Particle Paths and Streaklines dialog are enabled. A streakline animation displays each successive step in the integration, and can be an effective means of visualizing the unsteadiness of a flow. Toggle-on Include Zone Animation in the Particle Paths and Streaklines dialog to animate the zones along with the streaklines.

Please note that subsequent particle path or streakline calculations will replace the current streakline calculation, making it unavailable for animation.

You may display the animation in the frame in which the streaklines were calculated or save it to a video file in a number of formats. One of these formats, Raster MetaFile, can be played by the Framer utility; other may formats require viewer software available at various places on the Internet. To perform a streakline animation, do the following steps:

---

375
1. Delete the I-ordered zones of any streaklines you do not wish to be part of the animation using the Delete Zone dialog.

2. Select the animation destination from the Animate Streaklines dropdown.

3. Select Animate.

4. If you chose to save the animation to a file, the Animate Options dialog will be displayed. Enter your choices for the animation and select [OK]. Then choose a file name in the resulting file selection dialog.

While animating on the screen, the [Animate] button's text will change to Cancel, allowing you to stop the animation. While animating to a file, a progress dialog will be displayed that allows you to cancel the animation.

**Deleting Particle Paths and Streaklines**

Particle paths and streaklines are saved either as I-ordered zones or as a single IJ-ordered zone. You may delete these individually using the Delete Zone dialog (accessed via Data>Delete>Zone). If you wish to delete all previously calculated particle paths and streaklines, you may do so using the [Delete All Particle Paths and Streaklines] button. This deletes all zones whose names begin with 'Particle Path' or 'Streakline.'

**Animate Options**

The Animation Options dialog allows you to specify options for saving the streakline animation to a file. The following options are available:

- **Width (pixels)** - Enter a value in the text field for your exported image's width. The image region is rendered to the image file to exactly fit a size of Width by Height. This text field initially displays the frame's actual width.

- **Height (pixels)** - Displays the height of the image based on the value entered for Width, preserving the shape of the region to be exported. (Calculated by Tecplot 360.)

- **Animation Speed (frames/sec)** - Applicable only to AVI files. Enter a value in the text field to set your speed in frames per second.

- **Use Multiple Color Tables** - Selecting this check box will create a color table for each frame of the animation. If this check box is not selected, Tecplot 360 will scan each frame in your AVI file and create an optimal color table from 256 colors for the entire animation.

**22 - 9.3  Particles with Mass**

Whereas massless particles always travel with the local fluid velocity, particles with mass travel according to a more complicated equation of motion where the fluid creates drag on the particle. In addition,
Calculating Particle Paths and Streaklines

particles with mass may have a temperature that is different from the local fluid temperature, and they may lose mass due to ablative processes such as vaporization. The Particle Mass Options dialog allows you to enter coefficients and particle properties to indicate how these mass-related effects are calculated.

The Particle Mass Options dialog is displayed by selecting Mass Options on the Particle Paths and Streaklines dialog. It allows you to specify either general or detailed coefficients related to the particle trajectory and heat transfer calculations, plus options related to gravity and the initial particle velocity. If you choose to calculate the particle temperature, you may choose to terminate the particle at a specified temperature, or, with the detailed coefficient option, to ablate the particles until their mass reaches zero.

Selecting a Coefficient Set

You may enter either general coefficients or detailed coefficients. General coefficients are a convenient way of characterizing the particles, but result in less accurate calculations. They should only be used when the particle drag coefficient and heat transfer coefficient (if particle temperature is being calculated) are essentially constant. Detailed coefficients result in more accurate calculations, and should be used whenever the drag coefficient or heat transfer coefficient may not be constant, such as when the particle Reynolds number is less than 1000 (see page 380 for a definition of particle Reynolds number). In addition, if you wish to calculate particle ablation, you must specify detailed coefficients. Indicate your choice of coefficients by making the appropriate selection in the option box at the top of the Particle Mass Options dialog.

Calculating Particle Temperature

If you wish to calculate each particle's temperature along its path, set the Calculate Particle Temperature option. Particles begin with their temperature equal to the local fluid temperature at their insertion point (the beginning of each streamtrace you have placed). If you have chosen to enter general coefficients, enter the Temperature Time Constant in the General Coefficients section of the dialog. Otherwise, enter the specific heat (per unit mass) and the Nusselt number in the Detailed Coefficients section of the dialog. Also, select from the available options in the Termination Options section of the dialog. All of these options are discussed below.

Specifying the Effects of Gravity and Buoyancy

If you wish to include the effects of gravity in your calculation, enter the value in the gravity field and select the axis direction in which gravity acts.

If you choose the detailed coefficient set and non-zero gravity, the effects of buoyancy will also be included. Buoyancy acts in the opposite direction of gravity. It is included by subtracting from the particle mass the mass of the fluid it displaces, and multiplying the result by the gravitational constant to calculate the force due to gravity.

Buoyancy effects are not included if you choose the general coefficient set because the particle size is not specified. In this case, the value for gravity is simply added to the particle acceleration that is calculated from the general coefficients and local flow conditions.

Specifying the Initial Particle Velocity

Each particle injected into the flow begins either at the velocity of the flow at the point where the particle is injected, or at zero velocity or at a specified velocity. Select one of these options from the drop-down menu and, if you have chosen Specified Velocity, enter the U, V, and W velocities.
**General Coefficients**

Figure 22-14 shows the Particle Mass Options dialog with the general coefficients displayed. The General Coefficients consist of the Ballistic Coefficient and, if you are calculating particle temperature, the Temperature Time Constant.

![Figure 22-14: The Particle Mass Options dialog with general coefficients.](image)

**Ballistic Coefficient.**

The Ballistic Coefficient is defined by the following:

\[
B = \frac{m_p}{SC_D}
\]

**(EQ 17)**

where \( B \) is the Ballistic Coefficient, \( S \) is the frontal area of the particle, \( C_D \) is the particle's drag coefficient and \( m_p \) is the particle's mass. Given the Ballistic Coefficient, the acceleration of a particle due to fluid drag is calculated from

\[
a_i = \frac{0.5 \rho_f (u_i - u_p) \left| u_i - u_p \right|}{B}
\]

**(EQ 18)**

where \( a \) is particle acceleration, \( i \) stands for each spatial dimension, \( \rho_f \) is the local fluid density and \( u_i \) and \( u_p \) are the velocity components of the fluid and the particle. If non-zero gravity has been specified, the acceleration in the specified direction is augmented by the value for gravity. For example, if a gravitational constant, \( g_C \), acts in the \(-Z\) direction, the acceleration in the \( Z \) direction becomes:
Calculating Particle Paths and Streaklines

\[ a_z = \frac{0.5 \rho_f (u_l - u_r) t_{a_l} - u_r t_{a_r}}{B} \]  

(EQ 19)

Temperature Time Constant

For the general coefficient option, particle temperature is calculated with a simple relaxation:

\[ \frac{dT}{dt} = \frac{1}{\tau_T} (T_f - T_p) \]  

(EQ 20)

where \( T \) is temperature, and \( \tau_T \) is the Temperature Time Constant you enter in this text field. \( \tau_T \) has units of time, and indicates the "e-folding" time of this relaxation—the amount of time it takes to reduce the difference between the fluid temperature and the particle temperature by a factor of about 2.7.

Comparing (20) with the convective heat transfer equation,

\[ Q = hA(T_w - T_p) = -m_p c_p \frac{dT_p}{dt} \]  

(EQ 21)

we see that \( \tau_T \) may be thought of as a combination of the convective heat transfer coefficient, \( h \) and the surface area, mass, and specific heat of the particle:

\[ \tau_T = \frac{\pi \rho_f h}{m_p c_p} \]  

(EQ 22)

Note from (21) that the Temperature Time Constant is only constant if the heat transfer coefficient is also constant. In general, however, this coefficient will vary with the particle's velocity relative to the fluid, so this approximation should be viewed with skepticism.
**Detailed Coefficients**

Figure 22-15 shows the Particle Mass Options dialog with detailed coefficients displayed. The detailed coefficients consist of particle mass radius and drag coefficient. In addition, if particle temperature is being calculated, the detailed coefficients consist of particle specific heat and Nusselt number.

![Particle Mass Options dialog](image)

- **Mass** - Each particle begins with the same mass, entered in this text field. If ablation is being calculated, the particle's mass may be reduced by the ablative process as it travels through the flow field.

- **Radius** - As with Mass, each particle begins with the same radius, entered in this text field and may be reduced by ablation.

- **Specify/Calculate Drag Coefficient** - You may elect to specify a constant drag coefficient or have Tecplot 360 calculate it. If you specify a constant drag coefficient, enter its value in the corresponding text field. For calculated drag coefficient, Tecplot 360 uses a formula from *Multiphase Flow and Fluidization: Continuum and Kinetic Theory Descriptions* (D. Gidaspow, 1994):

  \[
  C_D = \begin{cases} 
  \frac{24}{Re} (1 + 0.15(Re^{0.847}) & \text{if } Re < 1000 \\
  0.44 & \text{if } Re \geq 1000 
  \end{cases}
  \]

  (EQ 23)

  with the particle Reynolds number:

  \[
  Re = \frac{\rho_d \left| U_p - U_f \right|}{\mu_f}
  \]

  (EQ 24)

  where \( d_p \) is the particle diameter, \( \left| U_p - U_f \right| \) is the speed of the particle relative to the fluid and \( \mu_f \) is the dynamic viscosity of the gas. The acceleration then becomes:
Calculating Particle Paths and Streaklines

If non-zero gravity has been specified, the acceleration in the specified direction is augmented by the gravitational constant adjusted for buoyancy. For example, if a gravitational constant, $g_c$, acts in the $Z$ direction, the acceleration in the $Z$ direction becomes:

$$a_z = \frac{\pi^2 \rho_p (u_z - u_p) \left| u_z - u_p \right| C_D}{m_p} - g_c \left(1 - \frac{\rho_f}{\rho_p}\right)$$  \hspace{1cm} (EQ 26)

where $\rho_p$ is the density of the particle.

- **Specific Heat** - If particle temperature is being calculated, enter the specific heat per unit mass of the particles, in units of energy per mass per degree.
- **Specify/Calculate Nusselt Number** - The Nusselt number is a non-dimensional measure of heat transfer. The temperature change of the particle is calculated from this number using the following formula:

$$\frac{dT_p}{dt} = \frac{-Q_{in}}{m_p c_p} \frac{2\pi r_p \kappa_p Nu (T_f - T_p)}{m_p r_p^2}$$  \hspace{1cm} (EQ 27)

where $\kappa_p$ is the conductivity of the fluid.

If you specify a constant Nusselt number, enter its value in the text field. Otherwise, Tecplot 360 will calculate it using a formula from An Eulerian-Lagrangian Analysis for Rocket Motor Internal Flows (Jayant S. Sabnis, et al., 1989):

$$Nu = 2 + 0.53(Re)^{0.5} \hspace{1cm} Re \leq 278.92$$

$$0.37(Re)^{0.6} \hspace{1cm} Re > 278.92$$  \hspace{1cm} (EQ 28)

**Termination Options**

When solving for particle temperature, you may terminate particles when they reach a specified temperature, or calculate particle ablation (mass reduction due to off-gassing or some sort of sloughing of material from the particle).

- **Terminate/Ablate Particles** - If you elect to terminate the particles at a particular temperature, you must enter the temperature. When the particle reaches this temperature, its path will be terminated at that location. If you elect ablation, you must enter the temperature at which ablation begins, and the latent heat of the ablative process. If you wish to model boiling of initially solid particles, enter the latent heat of fusion plus the latent heat of vaporization, as a positive number. Once the particle reaches the specified temperature, any additional heat transferred to the particle will result in ablation instead of an additional temperature rise. If the particle's mass reaches zero, it will be terminated at that location.
- **Temperature** - For temperature-based termination, this is the temperature in absolute units at which the particle will be terminated. For ablation, this is the temperature at which the ablation begins.
- **Latent Heat** - This is the combined latent heat of fusion and vaporization for the particle, used only for particle ablation. Its units are energy per unit mass.
22 - 10 Analyzing Solution Error

Tecplot 360 allows you to examine a sequence of CFD solutions on successively finer meshes, estimate the order of accuracy of the solutions, as well as perform Richardson extrapolation to improve the accuracy of the solutions. These features are applicable only to smooth solutions (solutions with no discontinuities). They are available via the Error Analysis dialog.

The Error Analysis dialog is displayed by selecting Analyze Error from the Analyze menu.

It contains controls for specifying the solution zones to analyze, the maximum accuracy of your CFD solver, some options specific to accuracy calculation, and buttons to perform the analyses.

You cannot perform error analysis on polygonal or polyhedral zones.

22 - 10.1 Calculating Solution Accuracy

The accuracy of a sequence of three solutions is estimated using Richardson extrapolation on a particular dataset variable you select. The resulting accuracy in both the 1-norm and the Max- (infinity-) norm is reported in a text dialog. You also have the options of plotting the overall error versus grid spacing, or plotting the calculated accuracy at each grid node.

22 - 10.2 Selecting Solution Zones

To calculate solution accuracy, you must identify three zones from your dataset. The zones must represent coarse, medium, and fine grid solutions of the same problem. The order in which you enter the zone numbers does not matter. The medium grid must have twice the number of cells in each index direction as the coarse grid, or twice, plus one, the number of nodes. The fine grid must have four times the number of cells, or four times, plus one, the number of nodes as the coarse grid.

Since finite element zones do not have identifiable index directions, the requirement for the coarse, medium and fine grid sizes is only in terms of the total number of cells. It is assumed that successively finer grids have been refined equally in all directions. The requirement is that the medium grid have eight times as many cells (four in 2D) as the coarse grid and the fine grid have 64 times as many cells (sixteen in 2D).

For all zone types, the medium and fine grids must have nodes that overlap the coarse grid nodes.
You may type the zone numbers in the text field, or select them by clicking Select and choosing three zones from the resulting list.

**Error Analysis is not supported for polygonal or polyhedral zone types.**

### 22 - 10.3 Specifying the Solver’s Maximum Accuracy

Under some circumstances, Richardson extrapolation can report an accuracy in excess of the solver’s theoretical maximum accuracy. For this reason, Tecplot 360 limits the accuracy used by this technique to the value you enter in the Maximum Accuracy text field. Although fractional values are allowed in this text field, you should enter the theoretical maximum order of accuracy of your solver as an integer. That is, two for a second-order accurate solver.

### 22 - 10.4 Selecting the Dataset Variable

For the accuracy calculation, Tecplot 360 performs Richardson extrapolation on one variable in your dataset. It must not be a grid variable. Enter the name of the variable in the Use Data Set Variable text field, or click Select to choose the variable.

### 22 - 10.5 Plotting the Solution Accuracy

You can plot the results of the accuracy calculation in either or both of two ways. First, you can plot the accuracy at each grid node as a contour plot (XY-plot for 1D data) by setting the Plot Accuracy at All Grid Nodes check box. Second, you can plot the overall error as a log-log XY-plot by setting the Plot Overall Accuracy (log-log) check box. If you select either of these options, new frames will be created to display the plots when you perform the calculation.

The plot of overall accuracy plots the error in the 1-norm and max- (infinity-) norm versus grid spacing for each of the three zones. The grid spacing of the coarse grid zone is taken as unity for this plot. The 1-norm is the average absolute value of the difference between the extrapolated solution and the solutions of the input zones. The max-norm is the maximum absolute value of this difference. Figure 22-16 shows an example of this plot. The slopes of the two lines represent the accuracy of the solver. A significant
difference in the slopes may indicate discontinuities in your solution, or other problems with the calculation.

Figure 22-16. A plot of the overall accuracy.

The plot of accuracy at all grid nodes plots the calculated accuracy on the grid from your coarse solution. For 2D and 3D grids, it is plotted as a contour plot. For 1D solutions, it is plotted as an XY-plot.

Because this feature creates a new frame, it cannot be saved in the data journal, and the current data journal is invalidated. If you subsequently save a layout file, you will be prompted to save a new data file.

22 - 10.6 Performing the Calculation

When you select [Calculate Accuracy], the accuracy calculation is performed. The accuracy in the 1-norm and max-norm is reported in a text dialog. If you selected either of the plot options, the plots are created in new frames.

22 - 10.7 Extrapolating a Solution

Given three solutions on successively finer grids, Tecplot 360 can perform Richardson extrapolation to improve the accuracy of the solution, and report the difference between the extrapolated solution and the original, fine grid solution.

To perform this extrapolation, three zones must be identified in the Error Analysis dialog as previously discussed (see Section 22 - 10.2 “Selecting Solution Zones”) and the maximum accuracy of the solver entered (see Section 22 - 10.3 “Specifying the Solver’s Maximum Accuracy”). Once these are entered, clicking Extrapolate Solution creates two new zones in the solution dataset. The first new zone contains the extrapolated solution on the coarse grid. The second new zone contains the difference between the extrapolated solution and the original fine grid solution.

22 - 11 Extracting Fluid Flow Features

Tecplot 360 can display important features in 3D fluid flow solutions that make analyzing the solutions much easier. For trans-sonic flow, it can display shock surfaces. For all flows, including incompressible flows, it can display lines indicating the location of vortex cores, as well as separation and attachment lines. These calculations make use of MIT’s FX library. For more information on this library, please see http://raphael.mit.edu/fx/. These features are accessed through the Extract Flow Features dialog.
The **Extract Flow Features** dialog is displayed by selecting **Extract Flow Features** from the **Analyze** menu.

![Extract Flow Features dialog](image)

It contains a drop-down for selecting the desired feature, options for specifying the algorithm to use when extracting vortex cores, as well as an [Extract] button, which performs the desired task.

Flow features are identified using field variables you have identified on the **Field Variables** dialog. (See Section 22 - 3 "Identifying Field Variables") and may be affected by settings on the **Fluid Properties** dialog. (See Section 22 - 1 "Specifying Fluid Properties") The feature extraction may also be affected by your boundary settings. In particular, separation and attachment lines are only calculated on boundaries you have identified as wall boundaries. Refer to Section 22 - 4 "Setting Geometry and Boundary Options" for more information on specifying boundary conditions for your data.

### 22 - 11.1 Extracting Shock Surfaces

To extract shock surfaces, select Shock Surfaces from the Feature drop-down, then click Extract. The remaining controls on the dialog are disabled. After calculation, shock surfaces are then displayed as isosurfaces of a new dataset variable named ShockFeature. This variable is similar to the **Shock** variable available on the **Calculate** dialog.

![Shock Feature](image)

You may note that the displayed shock surface is obscured by clutter due to the sensitivity of the shock function capturing minor oscillations in the solution. A useful technique for displaying only the true shock is to use the value blanking feature to eliminate regions where this clutter appears. Use Tecplot 360’s **Calculate** dialog to calculate the Pressure Gradient Magnitude variable, then use the value blanking to blank the plot where this variable is less than some constant. A good value to use is \(0.1 \rho_\infty c_\infty^2\), or for PLOT3D non-dimensional data, just 0.1.

### 22 - 11.2 Extracting Vortex Cores

To extract vortex cores, select Vortex Cores from the Feature drop-down, choose from the two available extraction methods, then click Extract. The cores consist of a group of line segments that may not all be connected. As a result, they are displayed using a line segment finite element zone. Display the Mesh or Edge plot layer to see the new zone. NOTE: the new vortex core zone is a static zone.

If you are using value blanking, you may need to interpolate the blanking variable to the new zone. Refer to Section 21 - 11 "Data Interpolation" for information on interpolation and Section 19 - 2 "Value Blanking" for information on value blanking.
Due to the properties of the algorithm used, vortices that happen to exactly align with grid lines may not be properly extracted. This is unlikely to occur in real-world solutions, but is common in test data generated by extruding 2D solutions to produce artificial 3D solutions.

**Choosing a Vortex Core Extraction Method**

Two algorithms for determining the location of the vortex cores are available. These methods are represented by the Vorticity Vector and Velocity Gradient Eigenmodes options. The Vorticity Vector method determines the location of vortex cores by examining the vorticity vector. The Velocity Gradient Eigenmodes method is more sophisticated and a little more expensive, using the eigenvalues and eigenvectors of the velocity gradient tensor. The eigenmode method tends to give fewer spurious vortex cores.

**Visualizing the Vortex Core Strength**

If you have chosen a contour variable for your dataset, the vortex strength returned by the FX library will be stored in this variable in the new zone. You may visualize this vortex strength by turning on the Mesh plot layer and choosing to color the mesh of this zone with the contour variable. You may need to modify the contour levels to get an acceptable display of the vortex strength. You may also wish to use the value blanking feature using this variable to blank out the vortex cores where they are very weak or unrealistically strong (as can happen at a no-slip wall boundary).

**22 - 11.3 Extracting Separation and Attachment Lines**

Separation and attachment lines show where a fluid flow separates from or reattaches to a no-slip wall boundary. These lines can give you an indication of where separation bubbles or recirculation regions appear in your data. To calculate them you must first identify one or more Wall boundaries using the Geometry and Boundaries dialog. (See Section 22 - 4 “Setting Geometry and Boundary Options.”) The separation and attachment lines will be calculated on these boundaries.

Due to the algorithm used by the FX library to detect separation and attachment lines, these lines may not be detected for flows that are essentially two-dimensional. (That is, flows which contain no variation along one of the three spatial dimensions.)

To calculate separation and attachment lines, select this option in the Feature drop-down and click Extract. The lines, if any, will be displayed in new static zones, one zone for separations lines and a separate zone for attachment lines. As with vortex cores, the lines consist of sets of possibly unconnected line segments, which are displayed using line segment finite element zones. Display the Mesh or Edge layer to see the lines.

**22 - 11.4 Excluding Blanked Regions**

For vortex core and separation/attachment line calculations in ordered zones, you may choose to exclude blanked regions from the calculation. Select this option by selecting the Exclude Blanked Regions from Ordered Zones toggle. This will prevent lines from being calculated in regions of ordered zones that are not plotted due to blanking. Note, however, that this will invalidate the data journal. If you subsequently save a layout file, you will be prompted to save a new data file as well.
The Probe tool allows you to select a location in your plot and view the values of all variables at that location. You can also view information about the dataset itself while probing. The probe-to-edit feature allows you to modify your data interactively.

With the Probe At dialog (accessed via Data>Probe At), you can specify the location of the probe as a set of spatial coordinates X, Y, and Z, one of the polar coordinates Theta and R, or as a set of I, J, and K-indices. You select one or more locations in the data field where information is to be collected, and the resulting information is displayed in the Probe dialog.

When you probe with the mouse, you can probe in either of two modes: Interpolate or Nearest Point. In Interpolate mode (accessed by a single mouse click) the value returned is the linearly interpolated value for the specified locations. In Nearest Point mode, accessed by CTRL-click, the value returned is the exact value at the closest data point in the field.

If Tecplot 360 appears to be unloading variables that you are trying to Probe, you may need to adjust your memory threshold. Refer to Section "Load On Demand" on page 489 for additional information.

23 - 1 Field Plot Probing with the Mouse

The most direct method of probing is to use the Probe tool. Click at any point in your plot to probe in Interpolate mode, which calls up a dialog showing the probe information interpolated for that point. CTRL-click at any location to probe in Nearest Point mode which will obtain probe information for the data point closest to the cross-hair.
The following table shows the information returned for each type of probe action for field plots. (All mouse click operations are using the left mouse button.)

<table>
<thead>
<tr>
<th>Probe Action</th>
<th>Information Returned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>If the pointer is over a valid cell, the value returned is the interpolated field values from all nodes in the cell.</td>
</tr>
<tr>
<td></td>
<td>2D Cartesian plots - If multiple cells are candidates, the cell from the highest number zone is used.</td>
</tr>
<tr>
<td></td>
<td>3D Cartesian plots - The closest cell in a zone, slice, iso-surface or streamtrace is selected. If multiple cells are candidates, the cell closest to the viewer is used, with priority given to surfaces drawn with mesh, flooded contours or shading. Translucent zone surfaces are excluded from probing priority.</td>
</tr>
<tr>
<td>CTRL+Click</td>
<td>If the pointer is over a valid cell, the field value from the nearest node in the cell is returned.</td>
</tr>
<tr>
<td></td>
<td>If multiple cells are candidates:</td>
</tr>
<tr>
<td></td>
<td>2D Cartesian plots - The cell from the highest number zone is used</td>
</tr>
<tr>
<td></td>
<td>3D Cartesian plots - The cell closest to the viewer is used. If the pointer is not over any cell, then the field values from nearest data point (as measured in distance on the screen) are returned.</td>
</tr>
<tr>
<td>SHIFT-CTRL+Click</td>
<td>Return the field values from the nearest point on the screen (ignoring surfaces, zone number or depth of the point).</td>
</tr>
<tr>
<td></td>
<td>This is useful in 3D for probing on data points that are on the back side of a closed surface without having to rotate the object.</td>
</tr>
<tr>
<td></td>
<td>In 2D this is useful for probing on data points for zones that may be underneath other zones because of the order in which they were drawn.</td>
</tr>
<tr>
<td>ALT-Click (3D only)</td>
<td>Same as Click except ignore zones while probing. (Probe only on streamtraces, iso-surfaces, or slices.)</td>
</tr>
<tr>
<td>ALT-CTRL+Click</td>
<td>Same as CTRL+Click except ignore zones while probing. (Probe only on streamtraces, iso-surfaces, or slices.)</td>
</tr>
<tr>
<td>ALT-CTRL+SHIFT-Click</td>
<td>Same as SHIFT-CTRL+Click except ignore zones while probing. (Probe only on streamtraces, iso-surfaces, or slices.)</td>
</tr>
</tbody>
</table>
Field Plot Probing by Specifying Coordinates and Indices

The probe results are displayed in the Probe dialog.

![Probe dialog with variable values](image)

Interpolate mode does not work for I-ordered data displayed in a 2D or 3D Cartesian plot; if you probe such data you will always get the error message "Point is outside of data field," because Tecplot 360 cannot interpolate without a field mesh structure. You can, however, use the Nearest Point mode in such situations.

### 23 - 2 Field Plot Probing by Specifying Coordinates and Indices

Use the Probe At dialog for: precise control over your probe location, probing using I, J, and K-indices, or probing inside a 3D volume. You can launch the Probe At dialog from the Data menu, from the Var Values page of the Probe dialog, or by selecting Tool Details from the Sidebar while in Probe mode.
23 - 2.1 Probe At Position

To probe at a specified location using spatial coordinates (in Interpolate mode), launch the Probe At dialog (accessed via the Data menu).

The Position page of the Probe At dialog has the following options:

- **Enter Coordinates** - Enter the X, Y, and Z-coordinates of the desired probe location.
- **Probe Within Volume [DEFAULT]** - If the zone you are probing is a 3D volume zone, toggle on Probe Within Volume to ensure that the probe is performed at the indicated point. If you specify a position within a 3D volume zone and the Probe Within Volume is not selected, Tecplot 360 probes at the surface of the zone nearest to the user.
- **Do Probe** - Select the [Do Probe] button to perform the probe. The Probe dialog will appear with interpolated values for the specified location.

If the entered location is not within a cell, Tecplot 360 will return the closest surface to the entered location along the line-of-sight ray.

23 - 2.2 Probe at Index

To probe at a specified location using dataset indices (in Nearest Point mode), launch the Probe At dialog (accessed via the Data menu) and select the Index page (shown below).

The Index page of the Probe At dialog has the following options:

- **Mapping/Zone** - Select the desired zone or mapping from the drop-down.
Field Plot Probed Data Viewing

- **I, J, K** - Enter the I, J, and K-indices of the desired probe location. (For finite element and I-ordered data, you can enter only the I-index. For IJ-ordered data, you can enter both I- and J-indices. For IJK-ordered data, you can enter I, J, and K-indices.)

- **Do Probe** - Select the [Do Probe] button to perform the probe. The Probe dialog will appear with interpolated values for the specified location.

23 - 3 Field Plot Probed Data Viewing

You can view probed data in the **Probe** dialog. The **Probe** dialog has four pages:

- **Variable Values** - Examine values of all variables at any selected location.
- **Zone and Cell Information** - Report characteristics of any location in a data field. The characteristics reported include the indices of the selected cell or point, the zone number, the dimensions of the zone, and the type of zone (ordered or finite element).
- **Cell Center** - Examine values of all variables at the center of the clicked-on cell.
- **Face Neighbor** - Examine neighboring cells of the click-on cell.

23 - 3.1 Variable Values

The **Var Values** page of the **Probe** dialog lists every variable in the current dataset, together with its value at the specified probe point. The **Var Values** page also displays the zone name and number and the current solution timer.

![Variable Values Page](image.png)

By default, each variable is shown on a single line, which allows display of about the first ten characters of the variable name and seven significant digits of the variable value. To display longer variable names or see more digits of the value, deselect the check box labeled **One Line per Variable**.
Load Variables

The value (on the Var Values page) and Cell Center Value (on the Cell Center page) will display “Not Loaded” for variables from your dataset that were not automatically loaded into Tecplot 360. To load these variables into Tecplot 360, select the [Load Variables] button (on either the Var Values or Cell Center page of the Probe dialog) and select the variables desired from the Load Variable dialog. See Section “Load On Demand” on page 489 for more information on load on demand.

23 - 3.2 Zone and Cell Information

The Zone/Cell Info page of the Probe dialog lists the following information about any probed data point, regardless of the format of the data.

The Zone Cell Info page displays the following information:

- The number and name of the probed zone.
- The format of the zone, either ordered or one of the finite element formats (FE-Triangle, FE-Quad, FE-Tetra or FE-Brick).
- Time - The Current Solution time of the probed point.

For ordered zones, the following additional information is displayed:

- I-Max - Maximum I-index of the zone.
- J-Max - Maximum J-index of the zone. (J-Max is one for I-ordered data.)
- K-Max - Maximum K-index of the zone. (K-Max is one for IJ-ordered data.)
- Plane - Shows the type of plane, I, J, or K displays the index of the point at the principal data point of the cell containing the probed point. (If the point is probed using CTRL-click for Nearest Point, the label reads “I,J or K-Index.”)
Field Plot Probed Data Viewing

- **Face Plane** - The I, J, or K-plane that is probed.
- **Face Indices** - The planes that are not mentioned in Face Plane, these are the other faces that are showing in 3D, or are the axes in 2D.

For cell-based finite element zones (FE-Triangle, FE-Quad, FE-Tetra or FE-Brick), the following additional information is displayed:

- **Total Pts** - Total number of points in the zone.
- **Total Elems** - Total number of elements (cells) in the zone.
- **Node Num** - Number of the probed node. This field is filled in only if the point is probed using CTRL-click for Nearest Point.
- **Elem Num** - Number of the probed element.
- **Node 1 - 8** - Number of the node defining Node 1-8 of the cell.
  - **Node 4** - FE-Quad, FE-Tetra, and FE-Brick only.
  - **Node 5-8** - FE-Brick only.

### 23 - 3.3 Cell Center

The **Cell Center** page of the **Probe** dialog lists the value of every variable in the current dataset at the center of the cell that was selected. The Zone name and number and the current solution time are also displayed.

![Cell Center dialog](image)

By default, each variable is shown on a single line, with the first ten characters of the variable name and first seven significant digits of the variable value.

To display longer variable names or see more digits of the value, deselect the check box labeled **One Line per Variable**.
See Section “Load Variables” on page 392 for information on the [Load Variable] button.

23 - 3.4 Face Neighbor

The Face Neighbor page of the Probe dialog displays cells that neighbor the selected cell.

A cell is considered a neighbor if one of its faces shares all nodes in common with the selected cell, or if it is identified as a neighbor by face neighbor data in the dataset. The current solution time is also displayed.

For ordered (IJ or IJK) zones, cell numbers are defined by the index value of the first node

\[ \text{Index} = i + (j - 1)I_{\text{max}} + (k - 1)I_{\text{max}}J_{\text{max}} \]

where, \(i\), \(j\), and \(k\) are the \(i\), \(j\), and \(k\) values for the location of the first node.

Because the number of nodes in each direction is one greater than the number of cells in that direction, there is no cell to correspond with the last point in each row. In the example below, there is no cell numbered “3”, yet the first cell in the second row is numbered “4”. As you define face neighbors, it may
help you to think of a “ghost cell” at the end of each row (where \( I = \text{MaxI} \)) and at the end of each column in 3D (where \( J = \text{MaxJ} \)).

For FE zones, the cells are numbered in the order that they appear in the connectivity list. In the following example “7 8 19 11” is the cell number 2:

```
#Example connectivity list of 3 cells:
2 4 8
7 8 19
1 2 4 5
```

Refer to “TECFACE112” on page 30 of the Data Format Guide for more information on face neighbor data.

### 23 - 4 Line Plot Probing with the Mouse

You may probe XY and Polar Line plots in much the same way you probe field plots. You can use the probe mouse mode to obtain interpolated variable values at any given location, or obtain exact values from a specified (X, Y) or (Theta, R) data point. When you probe an XY Line plot in the standard mode, Tecplot 360 displays a vertical or horizontal line, depending on whether you are probing along an X- or a Y-axis. When you probe a Polar Line plot, a radial line or a circle is displayed depending on whether you are probing along the Theta- or R-axis. In either case, the probe is performed along the displayed line (or circle).

To probe in interpolate mode: activate the probe tool and click anywhere on your plot. Axis variable values of all active mappings that lie along the probe line are interpolated and displayed.

To probe in Nearest Point mode: activate the probe tool and CTRL-click anywhere on your plot. When you CTRL-click, Tecplot 360 displays the exact X and Y, or Theta and R-values of the data point closest to the location clicked.

### 23 - 4.1 Line Plot Probing in Interpolate Mode

Interpolate mode is the standard probe mouse mode in line plots just as for field plots. For XY Line plots, you can probe along any of Tecplot 360’s five X-axes, or along any of Tecplot 360’s five Y-axes. By default, probing is performed along the X1 axis. For Polar Line, probing is done along the Theta-axis by default.

Note: In Polar Line, many combinations of Theta- and R-values can result in the same point on the screen. When using the mouse in Interpolate mode to probe along the Theta-axis, Tecplot 360 uses the Theta-value within the current Theta-axis range to determine the corresponding R-values reported in the Probe dialog. This behavior may result in no probe information shown for a mapping that has Theta-values entirely outside the current Theta-axis range, even though the mapping crosses the probe line on the screen. (For example, probing along the Theta-axis in interpolate mode misses a mapping representing only Theta-values several cycles outside the current Theta-axis range.) Similarly, when using the mouse in Interpolate mode to probe along the R-axis, Tecplot 360 uses the R-value within the current R-axis range and may miss mappings that are shown on the plot but have R-values different from the R-axis range.
To enter the **Probe Interpolate** mode, select the **Probe** tool from the Toolbar and select the [Tool Details] button from the Sidebar. The **Probe At** dialogs for XY and Polar Line plots are shown in Figure 23-17. The **Probe At** dialog has the following options:

**Figure 23-17.** The **Probe At** dialog for XY (left) and Polar Line (right) plots.

- **Select Axis to Probe** - Select the button corresponding to the axis you want to probe along.

Alternatively, you can press the X, Y, T, or R keys on the keyboard while moving the mouse over the plot to select the axis to probe along. You can also press the 1, 2, 3, 4, or 5 keys to select different X or Y-axes.
• Do Probe - Select the [Do Probe] button (or , from the Toolbar) to perform the probe. The Probe dialog will open, as shown below.

For interpolated values, the Probe dialog lists every active mapping and the interpolated value the opposing axis variable for that mapping. The value along the probed axis is listed at the bottom of the dialog. For example, the example above shows a probe along the X1 axis and the corresponding Y-values.

In the Probe dialog, the probe value is dashed (---) if the probe is out of range for the mapping. The probe value is gray (inactive) if the mapping is not using the specific axis which you are probing. For example you probe the X1 axis and the mapping uses the X2 axis. This will only happen in XY Line plots with multiple X or Y-axes.

By default, each mapping is shown on a single line, which allows display of about the first ten characters of the mapping name and seven significant digits of the variable value.

To display longer mapping names or see more digits of the value, deselect the check box labeled One Line per Mapping. The position of the probe is listed below the list of mappings.

• X-Value, Y-value - X, Y-value of the nearest data point to the probe position.
• I, J, or K-Index - I, J or K-index of the nearest data point to the probe position.
• Map - Number and name of the nearest map to the probe position.
• Zone - Number and name of the nearest zone to the probe position.
• I, J, or K-Max - Maximum I, J or K-index of the current zone.
• X or Y-Axis - X or Y-axis associated with the current map.

23 - 4.2 Line Plot Probing in Nearest Point Mode

Nearest Point probe mode provides the exact X and Y or Theta and R-values of the data point closest on the screen to the probed location, together with information on the mapping and the zone to which the
probed point belongs. If a data point is common to multiple mappings, the probe returns information on the highest numbered mapping. For example, if a data point is plotted as part of two mappings, numbered 1 and 2, the probe results are displayed for mapping 2.

To enter the **Probe Nearest Point** mode select the **Probe** tool, from the Toolbar and CTRL-click at the desired probe location. The nearest point is calculated from the actual location of the cross-hair and is independent of the axis you were probing along.

In **Nearest Point** mode, the **Probe** dialog appears with the heading **Specific Values**. The following information about the nearest data point is displayed:

- X or Theta-value.
- Y or R-value.
- I, J, or K-index.
- The number and name of the mapping associated with the data point.
- The number and name of the zone referenced in the mapping.
- The maximum I, J, and K-indices of the zone.
- For XY Line plots, the X-axis and Y-axis associated with the mapping.

## 23 - 5 Data Editing

Using the **Adjustor** tool, you can probe and edit specific data points. In **Adjustor** mode, you can actually modify the coordinates of your data with the mouse.

You can edit data points either by moving them with the mouse (in XY Line and 2D Cartesian plots only), or by using the **Probe/Edit Data** dialog to enter new values for any variable in the probed data point. To access the **Probe/Edit Data** dialog, double-click on a point in your plot with the adjustor tool.

If you modify a shared variable with the **Adjustor** tool, the variable will be branched—a separate copy of the variable will be created for the edited zone. If you use the **Probe/Edit Data** dialog, you can inhibit branching by selecting the **Alter in all Shared Zones** toggle.

### 23 - 5.1 Data Editing with the Mouse

In XY Line and 2D Cartesian plots, you can select and move data points with the **Adjustor** mouse mode. You can select multiple data points and move them as a group. When you move data points with the mouse, you will not actually see the changes until you redraw the screen.

See Section “**Adjustor Tool**” on page 21 for more information.

If you attempt to double-click, but move the mouse between clicks, you may find that you have moved your data point.

### 23 - 5.2 Data Editing with the Probe/Edit Data Dialog

To probe to edit using the **Probe/Edit Data** dialog:

1. On the Toolbar, choose the **Adjustor** tool, indicated by the button.
2. Move the pointer into the workspace, where it becomes the **Adjustor**.
3. Double-click on the point you want to edit, or click on the point and then click **Object Details** on the Sidebar.
4. From the **Probe/Edit Data** dialog (shown in Figure 23-18), enter new values as desired.
5. If the variable you wish to modify is shared by other zones and you want the modification to be used by all zones (and the variable to remain shared), select the Alter in all Shared Zones toggle.

Figure 23-18. Probe/Edit Data dialog for field plots (left) and XY Line plots (right).

**Edit Options for Field Plots**

The lower half of the Probe/Edit Data dialog is a copy of the Probe At dialog’s Index page. All variables in the zone or mapping are listed, along with their values at the probed point. You can use this area to specify a new zone or mapping to probe, along with the specific points to probe and edit.
For 2D and 3D plot types, the **Probe/Edit Data** dialog has [Scroll Up] and [Scroll Down] buttons which are active if the dataset has more variables than can be displayed on one page of the dialog. Thus, you can edit one point, then increase or decrease the displayed indices to edit the next point along a mapping.

- **Variable** - Lists all variables in the current dataset. If there are more than ten variables, the [Scroll Up] and [Scroll Down] buttons are active.
- **Value** - Lists the value of the named variable at the probed point.
- **Scroll Up/Down** - Click this to scroll up or down one page of variables. This button is active only if there is more than one page of variables.
- **Load Variables** - See Section “Load Variables” on page 392.
- **Enter Zone/Index to Probe** - Specify a grid point by index for editing. There are four controls in this region:
  - **Zone** - Select a zone to probe from the drop-down.
  - **I, J or K** - Specify the I, J or K-index of the probed point. You can either enter a value, or use the up and down arrows to increase or decrease the current value.
Data Editing

Edit Options for XY Plots

- **Variable** - Display the names of the X and Y-variables for each of the selected mappings.
- **Value** - Display the values of the X and Y-variables for each of the selected mappings.
- **Enter Map/Index to Probe** - Specify a data point by index for editing. There are four controls in this region:
  - **Map** - Select a map to probe from the drop-down.
  - **I, J, or K** - Specify the I, J or K-index of the probed point. You can either enter a value, or use the up and down arrows to increase or decrease the current value.
Part 5 Final Output
Output

Tecplot 360 provides a variety of formats for you to output and export your complete plots. This chapter discusses saving your settings using layout files or stylesheets, preparing plots for web publishing, and writing data files to a file.

For information on exporting or printing your completed plot(s), please refer to Chapter 26: “Exporting” or Chapter 25: “Printing”, respectively.

24 - 1  Layout Files, Layout Package Files, Stylesheets

Tecplot 360 has three different types of files for storing plot information:

- **Stylesheets (.sty)** - Stylesheets store information about a single frame and do not include any information about the data used by the frame.
- **Layout Files (.lay)** - Layout files store information about all the frames in the workspace, including identification of the data used by each frame.
- **Layout Package Files (.lpk)** - Layout package files are an extension to layout files where data and an optional preview image are included.

Layout and layout package files are the preferred method for saving the style of your plot. They save a complete picture of the workspace and are quick-and-easy to load and save. Stylesheets contain the style of a single frame in Tecplot 360.

24 - 1.1  Creating Layout and Stylesheets for Tecplot 360 and Tecplot Focus

If you are working with stylesheets or layouts in Tecplot 360 that you wish to share with Tecplot Focus users, please be aware that the following features are not available in Tecplot Focus:

- Iso-surface or slice groups of group number two or higher.
- Any aspect of the CFD Analyzer (i.e. options available from the Analyze menu in Tecplot 360).
- Data files that contain polygonal or polyhedral zones will not load in Tecplot Focus.

If any of the above items are included in your stylesheet or layout file, it will not load in Tecplot Focus. However, stylesheets and layouts created in Tecplot Focus will load in either product. As such, if you want
to create stylesheets or layout files that work with either product, we recommend creating the files in Tecplot Focus. This will guarantee that the files will work for all users.

24 - 1.2 Working with Layout Files from Previous Releases

If you are working with layout files from previous releases of Tecplot 360, Tecplot Focus, or Tecplot, please note the following:

- **Transform Coordinates** - Previous versions incorrectly recorded the $\text{TRANSFORMCOORDINATES}$ command. In previous versions, the variable number sub-command options to this command were recorded as zero-based values instead of one-based values. Macros or layout files created with versions up through Tecplot 10, Tecplot 360 2006 R2, or Tecplot Focus 2006 containing $\text{TRANSFORMCOORDINATES}$ should increment each variable sub-command option by “one” in order to operate correctly with Tecplot 360 or Tecplot Focus versions 2008 and newer.

24 - 1.3 Exporting Backward Compatible Data Files

While Tecplot 360 layouts and layout package files are not backward compatible, you do have the option to export data files written in one version of Tecplot 360 to be read by an earlier version. To do this, use the **Write Data File Options** dialog as described in Section 24 - 3 “Data File Writing”.

24 - 1.4 Stylesheets

Stylesheets are useful, when:

- Pre-processing must be done to a dataset prior to attaching a style. You may need to load a dataset and run some equations or do interpolation or zone extraction before assigning a style. The style may reference objects or variables that do not exist in the original data and it is necessary to assign the style after they are created.

- Switching styles on large datasets. You may want to load a large dataset and generate two full page plots. Each plot has a different style. By using a stylesheet for the second plot you avoid having to reload the dataset.

- Copying the style of one frame to another frame in the same layout.

- Saving just part of a frame's style, such as just the contour levels.

A stylesheet includes the following attributes (Figure 24-19):

- **Type of plot** (a 2D contour plot in 2D or an XY Line plot)
- **Colors used**
- **Current view of the data**
- **Axes display**

Tecplot 360’s data journaling capabilities together with layout files eliminate this situation in many cases.
• Text, geometry, and images

Figure 24-19. Some of the items considered part of the frame style.

If the frame contains any image geometries (see Section 18 - 3 "Images"), Tecplot 360 will save references to the image files in the stylesheet. If the images came from a layout package file, Tecplot 360 will save references to this file in the stylesheet.

To learn how to use a stylesheet, see Section 2 - 3.14 "Save Frame Style" and Section 2 - 3.15 "Load Frame Style".

24 - 1.5 Layout Files

A plot often consists of multiple frames or even multiple datasets. Layout files allow you to capture all the information on the plot. Layout files include instructions on how to create the data used in the plot, the frame layout and dataset attachments, axis and plot attributes, the current color map, and so forth.

Figure 24-20 shows a layout with four frames. The frame in the upper left-hand corner is attached to dataset 1. The two frames on the right are both attached to dataset 2. The frame in the lower left is not attached to a dataset.

Figure 24-20. Layout of four frames using two datasets.

If a frame defined in a layout file requires an attached dataset, the data files necessary to build the dataset are referenced in the layout file. These data files can be referenced using absolute paths or relative paths.
When using relative paths on Windows operating systems, the data files must be on the same drive as the layout file.

A layout file may also contain the data journal; a set of macro commands which alter the data or create new data. The data journal commands replicate the data modifications made to the original data (in files) during prior Tecplot 360 sessions. Not all data operations are supported by the data journal. For more information, see Section 5 - 2 “Data Journaling”.

In addition to storing the individual style of each frame, layout files record:

- Page layout information (including the size and orientation of the paper).
- Color spectrum information, including the global color maps in use.

To include the field data with a layout, use a layout package file. For more information, see Section 24 - 1.6 “Layout Package Files”.

### 24 - 1.6 Layout Package Files

Layout package files allow you to transmit raw data, along with style information in a single file. With layout package files the view can be changed, different plot types tested, and so forth.

Layout package files are very useful if you are making large documents containing many images, or other situations when you need to catalog your images. You can extract contents using the command line utility lpkv. This utility allows you to look at thumbnail sketches of each image in a layout package file without having to load each separately into Tecplot 360. For more information refer to the Quick Reference Guide.

Layout package files have the same properties as standard layout files. (See Section 24 - 1.5 “Layout Files”). Layout package files also contain all data associated with frames in the layout, and an optional preview image of the Tecplot 360 workspace. An extension of .lpk is used.

### 24 - 1.7 Working with Layout and Layout Package Files

#### New Layout

File>New Layout creates a new layout in your workspace after removing any existing frames and resetting the paper setup to the default configuration. Anything not saved before this action will be removed. Use New Layout to reset your workspace.

#### Layout Saving

Save layout files using the Save Layout (CTRL-S) or Save Layout As (CTRL-W) options under the File menu.

The Save Layout dialog has the following options:
• **Save As Type** - Choose “Linked Data (*.lay)” or “Packaged Data” (*.lpk)

• **Use Relative Path (Linked Layout ONLY)** - By default, Tecplot 360 saves the name of the data files used in the layout with their relative file paths. To save your layout using absolute file paths, toggle-off **Use Relative Path**.

• **URL [OPTIONAL]** - On Windows machines, you may specify a URL by selecting the URL check box. When selected, you may enter a full URL as the file name. The two file types are mutually exclusive. You cannot browse disk files when the URL check box is selected, and you cannot enter a URL if the URL check box is not selected.

• **Include Preview Image [OPTIONAL]** - Toggle-on **Include Preview Image** to include a preview image with the file. (Layout Package files ONLY).

After saving the layout file, you will be prompted to specify any dataset changes. See [Dataset Changed](#) and [Dataset Changed - Create New File](#) and for more information.

### Dataset Changed

In Tecplot 360, layout files contain references to the data files in use. The datasets are not copied directly into the layout file. As such, if you make changes to the dataset using Tecplot 360 and wish to save the layout, Tecplot 360 will ask you whether to (1) save a set of instructions (journal) to recreate your changes or (2) create new data files reflecting the changes made. You do not have the option to overwrite the original dataset(s).

The option **Use original dataset along with journaled instructions** is available only if the changes made to the dataset are supported by journaling (see [Section 5 - 2 “Data Journaling”](#) for more information). This option minimizes disk storage. Changes to the original data are reflected in later Tecplot 360 sessions.

### Dataset Changed - Create New File

If you choose to save the current data to new files and reference the new files in the layout, or if you have modified the data in ways not supported by the data journal, Tecplot 360 prompts you for a file name under which to save the changed data. If your layout has multiple datasets, Tecplot 360 prompts you for a file name for each modified dataset.
Layout File Opening

Open layout files using the Open Layout (CTRL-O) option under the File menu. To combine the layout file with the current layout in Tecplot 360, select the Append check box.

Layout File Opening with Different Data Files

When you open your layout files in Tecplot 360, you have the option of overriding the data files that are referenced in the layout file. This does not change the saved layout file.

To open a layout file with different data files than those specified in the layout file, select Data Override from the Open Layout dialog. In the Override Layout dialog (shown below), one line is listed for each dataset in the layout file. Each line contains the data reader name (TECPLOT for Tecplot-format data files). If the dataset is being loaded by the Tecplot 360 reader, this line shows the number of files making up the dataset, and a partial list of file names. If a data loader add-on is used, instructions used by the loader are listed here. (This could be a list of file names identical to the Tecplot 360 loader’s list.)

To change the data files or instructions making up a dataset, double-click on the appropriate line, or select the line and select Change. This process includes one or more dialogs allowing you to change the list of file names or instructions. Tecplot-format data files include a dialog to select new files. If the data loader does not have the capability to override the instructions, an error message appears.

Examples for overriding the datasets in the layout file are described in Table A-3.

Plot Publishing for the Web

Publish allows saving plots directly to an HTML file, from which you may read and write data and layout files to ftp:// and http:// sites. A Tecplot 360 HTML file could include a reference to a layout package file of
your analysis, enabling other Tecplot 360 users browsing your files to review your results directly. The Publish Options dialog and a Tecplot 360 HTML file are shown in Figure 24-21.

Figure 24-21. The Publish Options dialog creates layout package files for the Web.

Publish creates an HTML file referencing the plot images in your Tecplot 360 workspace. Publish also creates layout package files with a link from the HTML file to the layout package file.

To create a Tecplot 360 HTML file, select “Publish” from the File menu. The Publish dialog has the following options:

- Include Reference to Layout Package - Selecting this option creates a layout package file, along with a reference to that file in the resulting Publish file.
- Make Single Image for Workspace - Creates a single image file of your entire Tecplot 360 workspace. A single reference is added to your Publish file for this image file.
- Make Separate Images for Each Frame - Creates an image for each frame in your Tecplot 360 workspace. A separate reference for each frame is added to your Publish file.
- Convert to 256 Colors

Use the CTRL-U keyboard shortcut to launch the Publish dialog.

24 - 3 Data File Writing

Using the Write Data File Options dialog, you can write out the dataset in the active frame as either an ASCII or binary data file. You can also use this dialog to export backward compatible data files (binary only). To do this, you must choose which zones and variables of the data to write, as well as the format for the saved file (if applicable).
To write the dataset in the active frame to a file, select “Write Data File” from the File menu. This action will open the Write Data File Options dialog, which has the following options:

- **Details to Save** - Specify which record types you want to include in the data file by selecting the appropriate check boxes. By default, all record types present in the active frame’s dataset are selected. These details include:
  - **Text**
  - **Geometries**
  - **Custom Labels**
  - **Field Data** - Select this detail to save zone data.
  - **Data Linkage (If Possible)** - Save the variable and connectivity sharing between zones existing in the dataset, reducing its size and loading time.

- **Face Neighbor Information Generated by Tecplot 360** - Automatically save the face neighbor information generated by Tecplot 360 for finite element zones. This increases the dataset size and loading time, but speeds performance after loading.

- **File Format Version** - Usually, Tecplot 360 data files are not backward compatible. That is, data files written as one version of Tecplot 360 cannot be read with an earlier version. However, by selecting a file format version, you can choose to write a backward compatible data file.
  
  From the File Format Version menu, you can choose to write the data file in the current Tecplot 360 format (listed as “Tecplot 2009”), since the Tecplot 360 file format has not changed since that version, or in two older formats, Tecplot 360 2006 R1 (“Tecplot 2006”) and Tecplot 360 2008 R1 (“Tecplot 2008”).

  If you want the file written quicker, at the expense of file size, you can toggle-off “Data Sharing Linkage” to lower the time it takes to write the file.
Data File Writing

• **Tecplot 2008** - A data file written in the 2008 format will be readable by Tecplot 360 versions 2008 R1 and later. Since Tecplot 360 2008 R1 allows up to 32,700 zones or variables in a dataset, this format cannot be used to write a dataset with more than 32,700 of either zone or variables in the data file.

• **Tecplot 2006** - A data file written in the 2006 format will be readable by Tecplot 360 versions 2006 R1 and later (not Tecplot Focus 10, but subsequent versions). This format will also disallow the writing of a data file that contains more than 32,700 of either zones or variables. In addition, the 2006 format will automatically exclude any shared grids or polyhedral/polygonal zones, since these features did not appear in Tecplot 360 2006 R1.

A few limitations apply to the compatibility:

• Only features that existed for that Tecplot 360 version will be included in the written data file. Any data associated with zones that are not valid for the chosen file format will also be absent from the data file.

• Layouts and LPK files cannot be written out as older versions.

• Finally, only binary block output is allowed when writing out a data file for an older version of Tecplot 360.

• **Save Data Using** - Choose whether to save the file as ASCII or Binary (when writing a data file as the current version of Tecplot 360).

  • **Precision [ASCII ONLY]** - Specify the precision of your Float and Double variables. These variable types are written in exponent format and the precision determines the number of digits included past the decimal point.

• **Zone/Geometry Format** - For ASCII, choose to write the file in POINT format or BLOCK format (BLOCK is required if any variables are cell-centered). See "ASCII Data" in the Data Format Guide for a complete description of both formats.

• **Zone(s)/Variable(s)** - Select the zones and variables to include.

• **Associate Layout with Newly Saved Data File [OPTIONAL]** - Tecplot 360 associates this data file with the layout’s style. If not selected, Tecplot 360 asks you for a file name when writing out the file.
Printing

Printing your plot is the process of sending the plot image to an output device, print spooler, or a file. Typically the output device is a printer, but it may be a plotter, film recorder, file or typesetting machine. If you are creating files for use in another program, you should use Tecplot 360’s Export option (accessed via the File menu) to create your files—Export includes all the supported print file types, as well as several standard graphics formats, including: TIFF, WMF, JPEG, and EPS. See Chapter 26: “Exporting” for complete details.

25 - 1 Plot Printing

To print a plot, select “Print” from the File menu.

Tecplot 360 supports the standard printer drivers for Windows operating systems. You can also configure Tecplot 360 to use the native Tecplot 360 print drivers for Adobe® PostScript®.

The Print dialog has the following options:

- **Format** - Indicates the current printer for the plot.
- **Send Output to File [OPTIONAL]** - Selecting this check box will send your output to a file instead of a printer.
- **Print Setup** - Calls up the Print Setup Dialog dialog.
- **Render Options** - Calls up the Print Render Options dialog.
25 - 2 Setup

You can set various parameters relating to the paper, including paper size and orientation, using the Paper Setup dialog or the Print Setup dialog. A change to your paper settings in either the Paper Setup dialog or the Print Setup dialog will automatically update the other.

25 - 2.1 Printing Setup for Windows

Print Setup Dialog

On Windows platforms, use the Print Setup dialog to set up your paper. The Print Setup dialog is accessed via the Print dialog (accessed via the File menu) and has the following options:

- **Printer** - Specify the printer and set its properties.
- **Paper** - Specify the paper size and source tray using the following drop-downs:
  - **Size** - Select the paper size. The choices are printer-dependent.
  - **Source** - Choose a paper tray from the drop-down.
- **Orientation** - Specify one of the following options:
  - **Portrait** - The horizontal axis of the plot is aligned with the short side of the paper.
  - **Landscape** - The vertical axis of the plot is aligned with the short side of the paper.

By default, Tecplot 360 uses the standard Windows print drivers. You can choose to use Tecplot 360’s native print drivers, by adding the following line to your tecplot.cfg file:

```
$!INTERFACE USETECPLOTPRINTDRIVERS=YES
```

If you use Tecplot 360’s native print driver, you will use the Print Setup dialog for subsequent printing.

Paper Setup Dialog

To adjust the paper size, orientation, and background color for your plots, select the Paper Setup option from the File menu. The current settings for these options are reflected in the representation of the paper in the workspace. (To view the paper, select the “Show Paper on Screen” check box in either the Paper
Setup dialog or the Ruler/Grid dialog (accessed via the Options menu). This check box is selected by default.)

The Paper Setup dialog, in contrast with the Print Setup dialog on Windows platforms, offers you only six paper sizes. These may not be compatible with the paper sizes your printer supports. You cannot select from multiple paper trays with the Paper Setup dialog. You may set screen display options and fill colors with the Paper Setup dialog. The following options are available in the Paper Setup dialog:

- **Size** - Choose the size of the paper from the following six selections:
  - Letter (8.5 x 11 inches).
  - Double (11 x 17 inches).
  - A4 (21 x 29.7 cm).
  - A3 (29.7 x 42 cm).
  - Custom 1 (8.5 x 14 inches).
  - Custom 2 (8 x 10 inches).

On Windows machines, paper size Custom 2 is overwritten with the size selected in Print Setup if that size does not exist in Tecplot 360. You can customize all six paper sizes in the configuration file, as well as their hard-clip limits. The hard-clip limits are the lines on the edges of the paper that show where your printer cannot print. You can set the hard-clip limits to larger values for use as guides in placing your plots on the paper.

- **Orientation** - Choose the paper orientation. You have two options: Portrait and Landscape. In Portrait orientation, the long axis of the paper is aligned with the vertical axis of the plot. In Landscape orientation, the long axis of the paper is aligned with the horizontal axis of the plot.

- **Paper Fill Color** - Select a color to use for the paper background. This color is used to display the paper in the workspace. You can select the check box Use Paper Fill Color when Printing to have Tecplot 360 print this background color on the hard-copy as well.

### 25 - 2.2 UNIX Printing

Setting up to print on UNIX operating systems includes the following tasks:

- **Spool Command** - This may include specifying a device-dependent startup string to condition the output device for the Tecplot 360 output, or a mopup string to reset the output device upon completion of plotting. Printers on most UNIX systems are accessed via print spoolers that manage the print queue. Typically you use either the lpr or lpr commands to send files to the print spooler. There may be command-line options that need to be set on your system, as well, such as a flag to specify a particular printer.

In the Spooler Cmd text field, enter the appropriate spool command for your system, using the symbol to represent a file name.

For example, suppose you routinely use the following spool command to print a file named myfile.ps: "lpr -m -r myfile.ps." The appropriate spooler command to enter in the Spooler Cmd field is then "lpr -m -r @." When printing to a spooler, Tecplot 360 creates temporary files with names of the form tp??????, where the s are randomly generated characters. Tecplot 360 does not delete these temporary files automatically; commands to do so should be included in your spool command. In our example, the -r flag says to remove the file when done.

- **Startup and Mopup Strings** - A startup string is an initialization string that sets up your output device to accept the plot created by Tecplot 360. A mopup string is a reset signal that
tells your output device that the special output has ended. For most devices no startup or mopup strings are needed.

Enter the appropriate startup string or mopup string in the appropriate text field. Special characters are generated by using Macro Codes (such as “\e” for the escape character and “\n” for any ASCII character with a decimal ordinal value of \n). Check your printer documentation for the appropriate strings.

- **Printing Precision** - For PostScript output, you can control the numerical precision used in your print files. Print files contain numbers that define sizes and positions of pieces of the plot on the output paper. These numbers are defined as integers between zero and about 8,000. Usually, this provides sufficient resolution for most output devices. Occasionally, you may need more resolution. For example, printing to a high-resolution output device like a Linotronic typesetter may require more precision; making print output with very small cells or elements may also require more precision.

To increase the precision of the output, increase the value in the Extra Precision field of the Print Setup dialog. You specify one Extra Precision value for all formats that supports precision control. The precision is defined as the number of digits to the right of the decimal. Normally, precision is zero. The disadvantage of setting precision high is that the print files increase in size. The higher the Extra Precision setting, the larger your print files, but the more accurate the plot. The maximum setting for the precision is eight.

**PostScript (color or monochrome)**

PostScript supports all Tecplot 360 fonts, color flooding (or gray-scale flooding), hidden surface (or line) removal, and overlaid frames (plots).

The following options are available:

- **Color** - Select this check box to prepare output using Color PostScript; otherwise, use monochrome output.
- **Spooler Cmd** - Enter the command to spool print output in this text field. Use the @ sign to specify wildcard file names. For example, if you print files using the command lpr filename, where filename is the name of the file to be printed, you should enter lpr @ in the Spooler Command text field.
- **Startup String** - Enter any necessary startup string in this text field. For example, if your device requires PostScript Level 2, you may need the following setpagedevice command:
  ```
  %!PS-Adobe-3.0\010<</PageSize [792 1224]>> setpagedevice\010
  ```
- **Mopup String** - Enter any necessary mopup string in this text field. A mopup string is any string required by your printer to understand that the Tecplot 360 print job is complete and the printer should now be ready to accept additional jobs.
- **Extra Precision** - Enter the number of decimal places (0 to 8, inclusive) to which plotting calculations are stored. The default is 0, which should be adequate for most situations.
Print Render Options

Select Print Render Options the Print dialog to set the rendering options for your output (shown in Figure 25-22).

Figure 25-22. The Print Render Options dialog (Windows).

The Print Render Options dialog offers you the following choices:

- **Color** - Select this check box for color output; deselect the check box for monochrome output.
- **Render Type**:
  - **Vector** - Select this option to create print output using the drawing commands of the printer. The printer renders the plot, yielding higher resolution, but some plot options, such as translucency and surface clipping, are not available.
  - **Image** - Select this option to create print output using an image. Rendering is done by Tecplot 360 at the specified resolution, usually less than the printer's resolution. However, all plot options are available.
- **Force Extra Sorting for all 3D Frames** - This option is available when the Vector option has been selected. Selecting this check box will cause Tecplot 360 to use extra sorting in all 3D frames. This overrides the setting in the Advanced 3D dialog. If this check box is not selected, Tecplot 360 will choose sorting algorithms based on the Advanced 3D dialog options that were chosen for each frame. When printing 3D plots in a vector graphics format, Tecplot 360 must sort the objects so that it can draw those farthest from the screen first and those closest to the screen last. By default, Tecplot 360 uses a quick sorting algorithm. This is not always accurate and does not detect problems, such as intersecting objects. If Extra Sorting is selected, Tecplot 360 uses a slower, more accurate approach that detects problems.
- **Resolution (dpi)** - Available when the Image option is selected. Enter the resolution in terms of dpi in the text field. Larger resolutions may result in an out-of-memory condition, or produce very large files. Smaller resolutions may yield less-attractive output images.
- **Minimum Memory Required** - Indicates the amount of memory your final output will require when the selected Render Type is Image.
25 - 4 Print Preview

A preview of your screen image as it will be rendered for the printer may be generated by selecting Print Preview from the File menu or by selecting [Preview] on the Print dialog.

As discussed in Section 25 - 3 “Print Render Options”, the default sorting algorithm used by Tecplot may have problems with intersecting objects. This will typically not show up in the OpenGL-rendered screen image. However, sorting errors may occur for vector print output and will be visible in the preview.

The Print Preview option provides access to the Print Render Options dialog, where you may improve sorting by selecting Force Extra Sorting for All 3D Frames. If extra sorting does not solve the problem, the only option available is to export the plot using an image format, discussed in Chapter 26: “Exporting”. By increasing the resolution for an image format you can obtain a quality comparable to PostScript without the sorting errors.

Limitations of Print Preview:

- **Print Preview** will not display translucency.
- **Gouraud** shading for contour flooding will be reduced to Paneled shading.
- Continuous color flooding will be reduced to color flooding with average-cell color.

When you print, warning messages will be displayed to advise you of unsupported plot styles.
Exporting

The Export dialog, accessible from the File menu, can be used to create files for export to other applications or to the Tecplot viewer. Tecplot 360 can export files in the Tecplot Viewer format as well as in many variations of three export types: vector graphics, image and movie file formats.

Tecplot 360 exports the following vector graphics formats:

- **EPS Export** - Vector or image graphics in a special type of PostScript file designed for inclusion in other applications.
- **PostScript (PS) Export** - Vector or image graphics suitable for direct printing, but usually unsuitable for import into other applications. It is recommended that you use the Encapsulated PostScript (EPS) format for importing into other applications.
- **WMF Export** - Vector graphics to import into various Windows applications.

Tecplot 360 exports the following image formats:

- **BMP Export** - Image in Windows Bitmap format.
- **JPEG Export** - JPEG files are very small for their resolution and quite common on the internet, but they do involve some loss of image quality that may affect certain plot images.
- **PNG Export** - Also common on the internet, PNG images have a high image quality but larger file size than JPEG.
- **SunRaster (RAS) Export** - Image in SunRaster™ format.
- **TIFF Export** - Image in Tagged Image File Format.
- **X-Windows Format (XWD) Export** - Image in “xwd” (X-Window Raster) format.

Tecplot 360 exports the following movie formats:

- **AVI Export** - A common Windows movie file format also widely supported on other platforms. However, other, more modern formats may be more appropriate as they provide smaller files, better quality, or both.
- **Flash Export** - Adobe Flash® is an interactive file format commonly used on the Internet. The Flash export format produces a self-contained Flash file (*.swf) suitable for embedding in Web pages. You do not need the Adobe Flash product.
• **Flash Video (FLV) Export** - FLV is Flash Video, the video format used by Adobe Flash. This is a video file suitable for including in a Flash project you are developing. You need the Adobe Flash product to turn this into a self-contained Flash file suitable for deployment on a Web site.

  Some other video players will play this format natively.

  • **MPEG-4 Export** - MPEG-4 is a modern standard for video providing small files and high quality. It is well-supported by QuickTime and many other video players.

  • **Windows Media (WMV) Export** - Windows Media Video is a Microsoft standard format and widely supported by Windows applications.

  • **.Raster Metafile (.RM) Export** - Image in NASA's Raster Metafile format. Raster Metafile files may contain multiple images for animations. Used for creating movies for Framer.

  Tecplot 360 also exports X3D graphics, a universal interchange format for integrated 3D graphics and multimedia. Refer to Section 26 - 4 "X3D Export" for additional information.

  On Windows and Macintosh systems, Tecplot 360 can export directly to the clipboard instead of to a file. Windows systems export BMP and WMF directly to the clipboard. Macintosh systems export PICT files directly to the clipboard. PICT files are an image format unique to the version of Tecplot 360 provided for Macintosh operating systems, and are only available when copying directly to the clipboard. See Section 26 - 6 "Clipboard Exporting to Other Applications" for more information.

  Certain images formats support anti-aliasing, a feature that smooths jagged edges on text, lines and edges. This feature is discussed at the end of this chapter. See Section 26 - 7 "Antialiasing Images".

**Performance Tips**

If exporting is taking an unusually long time, or you get an error message saying that the image cannot be exported, the most likely cause is that the image width you are trying to export is too large. Selecting a smaller image width will greatly speed up the export process.

For an image export size of Length x Width, the file size for an uncompressed true color image is approximately Length x Width x 3. Memory requirements to export such an image can be up to twice this size.

For 256 color images, the maximum file size is approximately Length x Width, but is usually less since all 256 color image files are compressed. However, the memory requirements for exporting are the same as they are for a true color uncompressed image.

Anti-aliasing can dramatically increase the memory requirements during image generation. This is because a larger image is rendered first and then super-sampled to render to the final image. A smaller super-sample allows for faster rendering time. See Section 26 - 7 "Antialiasing Images".

### 26 - 1 The Tecplot Viewer

Tecplot 360 2009 includes the new Tecplot Viewer export format, with which you can export a 3D Cartesian plot from Tecplot 360 as a smaller-sized LPK file. You can reload the result file into Tecplot 360 for viewing and rotation. The plot will appear visually identical to the original plot, although you cannot manipulate the variables and other plot elements as in the source plot.

By streamlining the elements included in the Lightweight LPK export, the Tecplot Viewer export reduces the size of the resulting LPK to an average of 25% of the original LPK or layout file size (although the reduction varies greatly depending on what the original LPK or layout includes).

To export your current (3D Cartesian) plot with the Tecplot Viewer export format, choose “Export” from the File menu. In the Export dialog that appears, select “Tecplot Viewer” as the Export Format, and click OK.
The Select Export File dialog will appear, in which you can specify where to save the exported file. When you click Save, Tecplot 360 will export the active frame of your plot.

To reduce the file size, the lightweight file includes only the following:
- Data for only the current surfaces and lines drawn for the current plot
- Derived elements (such as slices and iso-surfaces) as zones
- The variables necessary to draw each zone (For example, if an iso-surface displays a contour flood, only the spatial variables and the contour variable data will be output to the file for that iso-surface's zone)
- Text, geometries, custom labels, and all visible data elements displayed on your plot

The following restrictions apply to the Tecplot Viewer export format.
- Only the active frame of a 3D Cartesian plot may be exported
- Only the current timestep of a transient data set may be exported
- The plot must include at least one zone, slice, streamtrace, or iso-surface
- Several plot features will not be reflected in the exported plot:
  - Finite element volume zones with the Contour or Shade layer enabled and a “Surfaces to Plot” setting other than “None” or “Boundary Faces” will not display.
  - Volume zones with the Scatter layer enabled and a “Points to Plot” setting other than “Nodes on Surface” or “Cell Centers Near Surfaces” will not display.
  - Finite element volume zones with the Scatter layer enabled and a point index I-Skip other than one (1) may render scatter symbols in different locations.
  - IJK blanking of ordered zones will not display.
  - Streamtrace arrowheads may render at different locations and with different sizes.
  - On Linux platforms, the Edge layer will not be reflected in the exported plot.

The resulting file will not be compatible with earlier versions of Tecplot 360. To learn how to export a data file compatible with earlier versions of Tecplot 360, see Section 24-1.3 “Exporting Backward Compatible Data Files”.

### 26 - 2 Vector Graphics Format

Vector export files have device-independent resolution and thus can be easily resized, but they have the same limitations as vector print output. Table 26-1 provides a summary of the advantages and disadvantages of using vector graphics file formats.

<table>
<thead>
<tr>
<th>Advantages</th>
<th>Disadvantages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resolution Independent (can be re-sized over and over to any size)</td>
<td>Does not support translucency or surface clipping</td>
</tr>
<tr>
<td>Always journal quality</td>
<td>Lines can appear different than on screen</td>
</tr>
<tr>
<td>Small file sizes for XY and 2-D output</td>
<td>Very large 3D output files</td>
</tr>
<tr>
<td></td>
<td>Not Web friendly</td>
</tr>
<tr>
<td></td>
<td>Can be manipulated in 3rd party programs, but those programs are usually more expensive</td>
</tr>
<tr>
<td></td>
<td>Needs a PostScript printer for PS output</td>
</tr>
</tbody>
</table>

Table 26-1: Advantages and Disadvantages of Vector Graphics format
26 - 2.1 EPS Export

Encapsulated PostScript file (EPS) are PostScript files with additional commands that another program can use to determine the size of your plot. After you import your EPS file into another program, you can position it and usually resize it before printing.

If you try to send an EPS directly to a printer, it may not be positioned correctly on the paper. Use Tecplot 360’s PS export format to create files to send directly to a printer.

For some applications, if you import an EPS file and print to a non-PostScript printer, only the preview image is printed. On Windows platforms, you must specify that the printer is a PS printer, or you will also get a print-out the preview image.

The Export dialog for EPS format has the following options:

- **Color** - Choose between color and gray-scale EPS output.
- **Vector/Image** - Choose the Render Type: vector PS commands or a PS image in the file. Vector commands generally result in a smaller file, but a PS image is required to accurately represent translucency or smooth color gradations.

If you choose Vector Render Type, the following options are available:

  - **Extra Precision** - Specify the number of decimal places to carry-out the size and position parameters in the resulting vector-based EPS output. Larger values create more accurate plots, but result in larger file sizes.
  - **Force Extra Sorting for All 3D Frames** - Toggle-on to use extra sorting in all 3D frames. This overrides the setting in the Advanced 3D dialog. If this check box is not selected, Tecplot 360 chooses sorting algorithms based on the Advanced 3D dialog options for a given frame.

If you choose Image Render Type, the following options are available:

  - **Region** - Choose to export only the active frame, or the smallest rectangle containing all frames, or everything shown in the workspace.
  - **Resolution** - Enter the resolution of the image in dots per inch. Larger values create more accurate plots, but result in larger file sizes.
  - **EPS Preview Type** - Tecplot 360 provides the following options for the preview image:
    - **None** - No preview image information is include. This is good for importing into applications that do not use preview image information.
    - **TIFF** - Include a monochrome or gray-scale TIFF preview image. (Color preview images are not available.) This is the most common preview image format. You may specify an image depth for the preview image in the **Depth** drop-down. TIFF image depth options are described in Section 26 - 3.6 “TIFF Export”. (This preview image depth is separate from the depth of the actual image for EPS files generated with Render Type Image. The actual image depth is determined by Tecplot 360.)
Vector Graphics Format

- EPSV2 - Include a monochrome (one bit per pixel) Encapsulated PostScript Version 2 preview image. This is also a common preview image type in EPS files.
- FrameMaker - Include a monochrome preview image compatible with older versions of Adobe® FrameMaker®. This preview image type is rarely necessary.

When using Render Type Image, these preview image width and height values are separate from the size of the actual EPS image. The actual EPS image size is determined by the Resolution setting.

See also: Section 31 - 2 “Movie File Creation Manually” and Section 31 - 5.1 “AVI Files”.

26 - 2.2 PostScript (PS) Export

The Export dialog allows you to export plots in PostScript (PS), although this format is usually used for printing directly to a printer or print spooler. It is recommended that you use the Encapsulated PostScript (EPS) format for importing into other applications. See Section 26 - 2.1 “EPS Export” for details.

If you want to export PostScript file (perhaps for later printing), the process for creating a PostScript export file is very similar to printing to a file on a UNIX system. See Chapter 25: “Printing” for details.

26 - 2.3 WMF Export

WMF (Windows Metafile) is a vector graphics format and thus can be easily resized by the importing application. WMF files can be imported into many applications. As a vector format, WMF cannot accurately represent plots with translucency or smooth color gradations. Selecting WMF from the Export Format drop-down displays WMF options (as shown below).
The following options are available:

- **Region** - Choose to export only the active frame, or the smallest rectangle containing all frames.
- **Color** - Toggle-on for color WMF output. Toggle-off for grayscale.
- **Force Extra Sorting for All 3D Frames** - Selecting this check box causes Tecplot 360 to use extra sorting in all 3D frames. This overrides the setting in the [Advanced 3D](#) dialog. If this check box is not selected, Tecplot 360 chooses sorting algorithms based on the [Advanced 3D](#) dialog options for a given frame.

### 26 - 3 Image Format

Image output has the advantage of accurately representing translucency and smooth color gradations, but with the disadvantage of generally being larger than vector output, particularly when a high image resolution is specified. Image files are sometimes called raster or bit-mapped. [Table 26-2](#) provides a summary of the advantages and disadvantages of image file formats.

<table>
<thead>
<tr>
<th>Advantages</th>
<th>Disadvantages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Looks like the screen image, or better</td>
<td>Resolution dependent (starts to lose quality if stretched)</td>
</tr>
<tr>
<td>Adjustable export size</td>
<td>For super-high resolution printing, images will be very large</td>
</tr>
<tr>
<td>Supports translucency</td>
<td></td>
</tr>
<tr>
<td>Relatively small file size</td>
<td></td>
</tr>
<tr>
<td>Easily managed by presentation packages</td>
<td></td>
</tr>
<tr>
<td>Web friendly</td>
<td></td>
</tr>
<tr>
<td>Easily manipulated in inexpensive 3rd party programs</td>
<td></td>
</tr>
<tr>
<td>Prints on any printer</td>
<td></td>
</tr>
</tbody>
</table>

**Table 26-2: Advantages and Disadvantages of Image file formats**

#### 26 - 3.1 Exporting Images with a Specific DPI

You can customize the DPI of your exported image. To do this, first set the width of the frame to the size of the image that you wish to export, using the [Edit Active Frame](#) dialog (accessible by selecting “Edit Active Frame” from the [Frame](#) menu). Next, when exporting in an image format (BMP, JPG, or another image format described following), multiply the frame width (in inches) by the desired DPI, and use that number to define your exported image dimension (enter the number in the Enter Width field of the [Export](#) dialog).

For example, to export a 4 inch by 6 inch image at 300 DPI, set the frame dimensions to 4 inches by 6 inches, and then when exporting, select the Enter Width option in the [Export](#) dialog and enter a width of 1200 (4 times 300).
26 - 3.2 BMP Export

BMP (Bitmap) is an image format, and thus accurately represents plots with translucency and smooth color gradations. The BMP export options are shown below.

When you select BMP in the Export dialog, you have the following options:

- **Region** - Choose to export only the active frame, or the smallest rectangle containing all frames, or everything shown in the workspace.
- **Use Width of Image on Screen** - Select this option to generate an image file the same size as the current plot on the screen. This option is required, if you use on-screen image rendering in the Display Performance dialog. See Section 32 - 3 “Performance Dialog” for details.
- **Enter Width** - Select this option to specify a width (in pixels) for the generated image. A larger width increases the quality of your image. However, the greater the width you specify, the longer it will take to export the image and the larger the exported file. This option is not available if you have chosen to use on-screen image rendering.
- **Antialiasing** - Select this option to smooth jagged edges in the image. See Section 26 - 7 “Antialiasing Images” for details.
- **Supersample Factor** - Control the amount of antialiasing used in the image. See Section 26 - 7 “Antialiasing Images” for details.
- **Convert to 256 Colors** - Select this option to generate an image with only 256 colors (down from a possible 16 million colors). Tecplot 360 selects the best color match. The image will have a greatly reduced file size, but for plots with many colors, the results may be suboptimal. Using this option with transparency, smooth color gradations, or antialiasing may result in poor image quality.
26 - 3.3 JPEG Export

JPEG (Joint Photographic Experts Group) is an image format, and thus accurately represent plots with translucency and smooth color gradations. However, JPEG is a highly compressible, “lossy” format, and can result in poor image quality for some types of images. The advantage of JPEG is very small file sizes and near universal acceptance on the internet. JPEG supports different qualities of compression, and Tecplot 360 allows you to control the image quality (and thus, inversely, the file size).

When you select JPEG in the Export dialog, you have the following options:

- **Region** - Choose to export only the active frame, or the smallest rectangle containing all frames, or everything shown in the workspace.
- **Use Width of Image on Screen** - Select this option to generate an image file the same size as the current plot on the screen. This option is required, if you use on-screen image rendering in the Display Performance dialog. See Section 32 - 3 “Performance Dialog” for details.
- **Enter Width** - Select this option to specify a width (in pixels) for the generated image. A larger width increases the quality of your image. However, the greater the width you specify, the longer it will take to export the image and the larger the exported file. This option is not available if you have chosen to use on-screen image rendering.
- **Antialiasing** - Select this option to remove “jagged edges” from the image. See Section 26 - 7 “Antialiasing Images” for details.
- **Supersample Factor** - Control the amount of antialiasing used in the image. See Section 26 - 7 “Antialiasing Images” for details.
- **Encoding** - Choose an encoding method for the JPEG file.
  - **Standard** - Creates a JPEG which downloads one line at a time, starting at the top line.
  - **Progressive** - Creates a JPEG image that can be displayed with a “fade in” effect in a browser. This is sometimes useful when viewing the JPEG in a browser with a slow connection, since it allows an approximation of the JPEG to be drawn immediately, and the browser does not have to wait for the entire image to download.

Given the same Quality level, **Standard** encoded JPEG files look better than equivalent **Progressive** encoded JPEG files. However, they have a larger file size.

- **Quality** - Select the quality of JPEG image. Higher quality settings produce larger files and better looking export images. Lower quality settings produce smaller files. For best results, use a quality setting of 75 or higher.
**26 - 3.4 PNG Export**

PNG (Portable Network Graphics) is an image format, and thus accurately represent plots with translucency and smooth color gradations.

When you select PNG in the **Export** dialog, you have the following options:

- **Region** - Choose to export only the active frame, or the smallest rectangle containing all frames, or everything shown in the workspace.
- **Use Width of Image on Screen** - Select this option to generate an image file the same size as the current plot on the screen. This option is required, if you use on-screen image rendering in the **Display Performance** dialog. See Section 22 - 3 “Performance Dialog” for details.
- **Enter Width** - Select this option to specify a width (in pixels) for the generated image. A larger width increases the quality of your image. However, the greater the width you specify, the longer it will take to export the image and the larger the exported file. This option is not available if you have chosen to use on-screen image rendering.
- **Antialiasing** - Select this option to smooth jagged edges in the image. See Section 26 - 7 “Antialiasing Images” for details.
- **Supersample Factor** - Control the amount of antialiasing used in the image. See Section 26 - 7 “Antialiasing Images” for details.
- **Convert to 256 Colors** - Select this option to generate an image with only 256 colors (down from a possible 16 million colors). Tecplot 360 selects the best color match. The image will have a greatly reduced file size, but for plots with many colors, the results may be suboptimal. Using this option with transparency, smooth color gradations, or antialiasing may result in poor image quality.
26 - 3.5 SunRaster (RAS) Export

SunRaster is an image format, and thus accurately represent plots with translucency and smooth color gradations. SunRaster files can be created in either of two formats—the standard format, which is not compressed, and a byte-encoded format, which is compressed.

When you select SunRaster in the Export dialog, you have the following options:

- **Region** - Choose to export only the active frame, or the smallest rectangle containing all frames, or everything shown in the workspace.
- **Use Width of Image on Screen** - Select this option to generate an image file the same size as the current plot on the screen. This option is required, if you use on-screen image rendering in the Display Performance dialog. See Section 32 - 3 "Performance Dialog" for details.
- **Enter Width** - Select this option to specify a width (in pixels) for the generated image. A larger width increases the quality of your image. However, the greater the width you specify, the longer it will take to export the image and the larger the exported file. This option is not available if you have chosen to use on-screen image rendering.
- **Antialiasing** - Select this option to smooth jagged edges in the image. See Section 26 - 7 "Antialiasing Images" for details.
- **Supersample Factor** - Control the amount of antialiasing used in the image. See Section 26 - 7 "Antialiasing Images" for details.
- **Encoding** - You may select Standard, which will create an uncompressed file, or Byte-Encoded, which will create a compressed file. You should select Byte-Encoded unless you have a compelling reason to do otherwise.
TIFF Export

TIFF (Tagged Image File Format) is an image format, and thus accurately represent plots with translucency and smooth color gradations. Tecplot 360 generates both color and gray-scale TIFF images.

When you select TIFF in the Export dialog, you have the following options:

- **Color** - Choose between color and gray-scale TIFF output.
- **Region** - Choose to export only the active frame, or the smallest rectangle containing all frames, or everything shown in the workspace.
- **Use Width of Image on Screen** - Select this option to generate an image file the same size as the current plot on the screen. This option is required, if you use on-screen image rendering in the Display Performance dialog. See Section 32 - 3 “Performance Dialog” for details.
- **Enter Width** - Select this option to specify a width (in pixels) for the generated image. A larger width increases the quality of your image. However, the greater the width you specify, the longer it will take to export the image and the larger the exported file. This option is not available if you have chosen to use on-screen image rendering.
- **Antialiasing** - Select this option to smooth jagged edges in the image. See Section 26 - 7 “Antialiasing Images” for details.
- **Supersample Factor** - Control the amount of antialiasing used in the image. See Section 26 - 7 “Antialiasing Images” for details.
- **Convert to 256 Colors** - Select this option to generate an image with only 256 colors (down from a possible 16 million colors). Tecplot 360 selects the best color match. The image will have a greatly reduced file size, but for plots with many colors, the results may be suboptimal. Using this option with transparency, smooth color gradations, or antialiasing may result in poor image quality.
- **Depth** - For gray-scale images, this specifies the number of shades of gray by how many bits of gray-scale information is used per pixel. The larger the number of bits per pixel, the larger the resulting file. Your options are:
  - **On/Off** - One bit per pixel using an on/off strategy. All background pixels are made white (on), and all foreground pixels, black (off). This setting creates small files and is good for images with lots of background, such as line plots and contour lines.
  - **1 Bit/Pixel** - One bit per pixel using gray scale values of pixels to determine black or white. Those pixels that are more than 50 percent gray are black; the rest are white. This setting creates small files that might be useful for a rough draft or a preview image.
  - **4 Bit/Pixel** - Four bits per pixel resulting in sixteen levels of gray scale. This setting generates fairly small image files with a fair number of gray levels. This setting works well for most preview image purposes.
  - **8 Bit/Pixel** - Eight bits per pixel resulting in 256 levels of gray. This setting is useful for full image representation, but the files generated by this setting can be large.
26 - 3.7 X-Windows Format (XWD) Export

XWD (X-Windows format) is an image format, and thus accurately represent plots with translucency and smooth color gradations. XWD can be generated using Tecplot 360 on Windows, Macintosh, and UNIX platforms.

When you select XWD in the Export dialog, you have the same options as BMP or PNG. See Section 26 - 3.2 “BMP Export” or Section 26 - 3.4 “PNG Export” for details.

26 - 4 X3D Export

X3D is an XML-based file format for 3D data. Output is based on version 3.2 of the X3D specifications as described by ISO/IEC CD 19775-1r1:200x., Extensible 3D.

To export your plot in X3D format, select the X3D option in the Export dialog (accessed via the File menu). Only 3D Grid plots can be exported into X3D format.

Since X3D is an interpreted language, the rendering of the same document will vary from viewer to viewer (similar to HTML). In particular, 2D overlays via the X3D LayerSet element is currently only supported in Xj3D.

To view X3D data, you may download any of the following X3D viewers:

- Octaga Player: http://octagavs.com/software/octaga-player - Closed-source commercial viewer. Player is free for non-commercial use. Supports Windows and Linux® platforms. Does not support 2D overlays, but seems to have the most robust support for the elements we use in 3D. Also has web browser plug-in.
- X3D: www.x3d.org - An open-source project by the Web3D consortium, which oversees the X3D specification. It's written in Java and has good platform support. It has some issues with orienting objects toward the viewer (such as scatter symbols) and continuous contours.
- FreeWRL: freewrl.sourceforge.net/index.html - Open source viewer for Linux/Mac.

Exporting Smaller X3D Files

Large file size can become a concern because X3D files include 3D elements that are hidden from the current view (unlike JPG files, for example). To reduce the size of X3D files, try the following:

- Reduce the amount of active styles in your plot.
- Use value blanking to remove elements from your plot.
- Reduce the size of the input data (e.g. index skipping).

26 - 5 Movie Format

Movie files can be created in Tecplot 360 using any of the options in the Animate menu or by selecting AVI, Flash or Raster Metafile from the Export dialog (accessed via the File menu).

Most of the available video formats have similar options, which are described here. The following sections will describe only the settings unique to specific formats.
Movie Format

- **Region** - Select the region of the workspace to animate.
  - **Active Frame** - Captures only the active frame
  - **All Frames** - Captures the smallest rectangular area containing all frames
  - **Work Area** - Captures the workspace
- **Use Width of Image on Screen** - Select this option to generate an image file the same size as the current plot on the screen. This option is required, if you use on-screen image rendering in the Display Performance dialog. See Section 32 - 3 “Performance Dialog” for details.
- **Enter Width** - Select this option to specify a width (in pixels) for the generated image. A larger width increases the quality of your image. However, the greater the width you specify, the longer it will take to export the image and the larger the exported file. This option is not available if you have chosen to use on-screen image rendering.
- **Antialiasing** - Select this option to smooth jagged edges in the image.
- **Supersample Factor** - Control the amount of antialiasing used in the image.
- **Animation Speed (frames/sec)** - Enter a value in the text field to set your speed in frames per second.

### 26 - 5.1 AVI Export

The AVI (Audio-Visual Interleaved) format is used for viewing movies created in Tecplot 360. AVI is an image format, and the AVI compression options may take advantage of more than 256-color images with AVI files. Thus, AVI can accurately represent some plots with translucency and smooth color gradations. When you select AVI in the Export dialog, you have the following options besides those common to all movie formats (see Movie format):

- **AVI Compression** - Select one of these compression options to maximize the quality of your output:
  - **Color Preserving (Windows Only)** - This compression option optimizes the smoothness of motion over picture detail. Select this option when your animation has over 256 colors and you would like to preserve the color quality of your output.
  - **Line Preserving** - This compression option optimizes the smoothness of lines in your output. Select this option if you would like to preserve the line quality of your output.
  - **Lossless Uncompressed** - This compression option gives the highest picture quality and preserves complete 24-bit pixel information. However, this option produces a larger file size. Select this option if you will be subsequently converting your output to another format.

See also: Section 31 - 2 “Movie File Creation Manually” and Section 31 - 5.1 “AVI Files”
26 - 5.2 Flash Export

Flash is a movie file format commonly used on the Internet. Flash supports twenty-four-bit “true color,” which may give better results for 3D shaded or translucent plots.

The following options are available in addition to the settings common to all video export formats (see Movie Format):

- **Image Type** - Choose an image type. Your options are:
  - **True Color** - Select this option to create twenty-four-bit images with lossless (ZLIB) compression.
  - **JPEG** - Select this option to create twenty-four-bit images with lossy compression. This produces smaller files than True Color, and the images will be of lower quality.
  - **256 Colors** - Select this option to reduce each image to 256 colors and compress it with ZLIB. This gives essentially the same output as AVI.

- **Optimize for Speed** - For True Color or 256 Colors image types, select this option to create the output as quickly as possible. This reduces the compression level and results in larger files. It does not affect playback speed.

- **Optimize for File Size** - For True Color or 256 Colors image types, select this option to produce the smallest possible files. This setting does not affect playback speed.

See also: Section 31 - 2 “Movie File Creation Manually” and Section 31 - 5.2 “Flash Files”

26 - 5.3 Flash Video (FLV) Export

Flash Video (FLV) files can be used with Adobe Flash to create interactive presentations containing video and is the format used by most video streaming sites. You will need Adobe Flash to combine a FLV file with a SWF file for deployment on the Web. However, some video player applications can play FLV files without the Adobe Flash plug-in. FLV export does not have any additional options other than those common to all types of video export (see Movie Format).

See also: Section 31 - 2 “Movie File Creation Manually” and Section 31 - 5.3 “Flash Video (FLV) Files”

26 - 5.4 MPEG-4 Export

MPEG-4 is a modern video format that is widely supported by computer operating systems, video playback software, mobile media players, and even some televisions and set-top boxes. Native support is available on the Macintosh using QuickTime, and QuickTime and other compatible software is also available on Windows. Windows Media Player on Windows 7 supports the format natively; earlier versions of Windows will need to have QuickTime or an MPEG-4 codec installed. MPEG-4 Export does not have any additional options other than those common to all types of video export (see Movie Format).

See also: Section 31 - 2 “Movie File Creation Manually” and Section 31 - 5.4 “MPEG-4 Files”
26 - 5.5 Windows Media (WMV) Export

Windows Media Video (WMV) is a widely-supported video format on Microsoft Windows operating systems and in Windows applications. It is also supported on Macintosh computers using Flip4Mac, a third-party product. WMV Export does not have any additional options other than those common to all types of video export (see Movie Format).

See also: Section 31 - 2 "Movie File Creation Manually" and Section 31 - 5.5 "Windows Media (WMV) Files".

26 - 5.6 Raster Metafile (RM) Export

The image format Raster Metafile can accurately represent some plots with translucency and smooth color gradations. However, Raster Metafiles are only 256-color images (Tecplot 360 selects the best color match). Plots with many colors may have poor results when exported as Raster Metafiles, when compared exports as true-color image formats (such as PNG). Using Raster Metafiles with transparency or smooth color gradations may result in poor image quality.

When you select Raster Metafile in the Export dialog, you have the following additional options:

- **Use Multiple Color Tables** - Select this check box to create a Raster Metafile with a separate color table each step in the animation. If this check box is not selected, Tecplot 360 scans all steps in the animation and creates one color table for the entire animation. Multiple color tables can provide better per-step image quality for the animation, but may result in flicker during playback.

See also: Section 31 - 2 "Movie File Creation Manually" and Section 31 - 5.6 "Raster Metafiles Viewing in Framer".

26 - 6 Clipboard Exporting to Other Applications

The Cut, Copy, and Paste commands work only within Tecplot 360. However, the Copy Plot to Clipboard command (available only for Windows and Macintosh operating systems) allows you to copy and paste Tecplot 360 images directly into other applications. To access this dialog, select "Copy Plot to Clipboard" from the Edit menu. The following options are available:

- **Region** - Choose to export only the active frame, or the smallest rectangle containing all frames, or everything shown in the workspace.

- **Format** - On Windows platforms, you can copy plots as a vector (WMF) or image (BMP) format. See Section 26 - 3.2 “BMP Export” and Section 26 - 2.3 “WMF Export” for a discussion of these formats. On Macintosh
systems, the plot is copied as a PICT image, and this is the only way to generate a PICT image from within Tecplot 360.

- **Force Extra Sorting for All 3D Frames** - Toggle-on this option to use extra sorting in all 3D frames. This overrides the setting in the Advanced 3D dialog. When you have this option toggled-off, Tecplot 360 chooses sorting algorithms based on the Advanced 3D dialog options for a given frame. This option is only available for WMF, and thus only on Windows platforms.

- **Color** - Choose between color and gray-scale output.

- **Convert to 256 Colors** - On Windows platforms, select this check box generate an image with only 256 colors (down from a possible 16 million colors). Tecplot 360 selects the best color match. The image will take up less memory on your Windows clipboard, but for plots with many colors, the results may be suboptimal. Using this option with transparency, smooth color gradations, or antialiasing may result in poor image quality. On Macintosh systems, the image is always generated with only 256 colors because that is all the PICT format supports.

- **Use Width of Image on Screen** - Select this option to generate an image file the same size as the current plot on the screen. This option is forced on if you use on-screen image rendering in the Display Performance dialog. See Section 32-3 "Performance Dialog" for details. This option is only available for BMP and PICT.

- **Enter Width** - Select this option to specify a width (in pixels) for the generated image. The greater the width you specify, the longer it will take to export the image and the larger the exported file. However, a larger width increases the quality of your image. This option is not available if you have chosen to use on-screen image rendering. This option is only available for BMP and PICT.

- **Antialiasing** - Select this option to smooth jagged edges in the image. See Section 26-7 "Antialiasing Images" for details. This option is only available for BMP and PICT.

- **Supersample Factor** - Control the amount of antialiasing used in the image. See Section 26-7 "Antialiasing Images" for details. This option is only available for BMP and PICT.

### 26 - 7 Antialiasing Images

Antialiasing smooths jagged edges on text, lines, and edges of image output formats by the process of supersampling. A large intermediate image is rendered and then reduced to the final image size. Each pixel on the final image is created from multiple rendered pixels. The width and height of the intermediate image are the width and height of the final image times some scale factor. This scale factor is the Supersample Factor. You can use values from 2 to 16. Factors greater than 3 are seldom necessary. Large scale factors take a lot more time and memory. Some graphics cards limit the dimensions of rendered images to a maximum of 2048x2048 or 4096x4096 pixels, and thus Tecplot 360 cannot antialias if the intermediate image would be larger than this limit.

Antialiasing uses many colors. Certain image formats are limited to 256 colors, and cannot represent all antialiased images correctly. The image formats limited to 256 color include X-Windows, AVI, Raster Metafile, SunRaster, and any image format with the Convert to 256 Colors option selected. With these formats, the antialiasing works for plots with a very limited selection of colors (like a red mesh on a black field). Otherwise, antialiasing with 256 colors wastes time and may decrease plot quality.

Using animation formats can amplify the antialiasing and 256-color problem. Both AVI and Raster Metafile support only 256-colors, and need to use them to display multiple frames. For these formats, try a test animation of a few steps with antialiasing on before creating the entire animation.

Antialiasing is available only if image export rendering is performed off-screen (default). In some cases, off-screen rendering must be turned-off (usually due problems with the graphics card). In UNIX you can work around this by turning-off screen rendering and using the -mesa flag to run the mesa version of Tecplot 360.
Part 6 Scripting
# Introduction to Scripting

The Tecplot 360 installation provides three methods of scripting or automating Tecplot 360: macros, Python™ scripts, and the Add-on Developer's Kit. These three methods can be used as independent of each other or in a combined form. To extend Tecplot 360's capabilities beyond the scope of the Add-on Developer's Kit, the Software Developer's Kit is available separately. The following table should help guide you toward which method is appropriate for your specific needs. The simplest, least technical methods are at the top, and the technical difficulty increases as you go down the table.

If you wish to simply automate some of Tecplot 360’s functionality (such as plot style or the loading data files), recording a macro file is the simplest method. If you wish to extend a functionality of Tecplot 360, such as data alteration, writing a simple Python script is the best method. The most powerful method involves working with a combination of Tecplot 360 macro commands and Python scripts. Refer to Section 30.1 “Combining Python scripts with macro commands” for details.

If you wish to systematically extend a functionality of Tecplot 360, like creating the ability to load a new type of data file, use the Add-on Developer’s Kit (ADK). To learn more, see the ADK User’s Manual.

<table>
<thead>
<tr>
<th>Method</th>
<th>Best For</th>
<th>Common Use Case</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macros</td>
<td>Automating Tecplot 360 processes.</td>
<td>Batch processing.</td>
<td>Cannot add functionality to Tecplot 360.</td>
</tr>
<tr>
<td>Python scripting</td>
<td>Automating Tecplot 360 processes and extend capabilities.</td>
<td>Fast-fourier transforms.</td>
<td>Not all of Tecplot 360’s functionality is accessible^a.</td>
</tr>
<tr>
<td>Add-on Developer’s Kit</td>
<td>Extending Tecplot 360 functionalities in systematic ways.</td>
<td>Creation of add-ons.</td>
<td>Requires some programming knowledge.</td>
</tr>
<tr>
<td>Tecplot SDK (Software Developer’s Kit)</td>
<td>Combining Tecplot visualization capabilities with an external application.</td>
<td>Add plots to solver data.</td>
<td>Requires programming knowledge.</td>
</tr>
</tbody>
</table>

^a. If you need to extend Tecplot 360’s capability in a way that is not supported by Tecplot 360’s Python interpreter, you will need to write an add-on. Refer to the ADK User’s Manual for additional information.
You can access macro or Python files in the Tecplot 360 interface by selecting either “Quick Python Scripts” or “Quick Macros” via the Scripting menu. The Quick Macro Panels allow you to execute existing macro files or Python modules. Refer to Section 28 - 2.1 “Quick Macro Panel” and Section 30 - 2 “Using the Python Quick Scripts Panel” for details.

For details regarding macro files and commands, refer to Chapter 28: “Macros” along with the Scripting Guide. For details regarding working with Python scripts, refer to Chapter 30: “Working With Python Scripts”.
This chapter focuses on the Tecplot 360 menu options for recording and playing back macros. The Scripting Guide describes the Tecplot 360 macro language in detail.

Macros are very useful for performing repetitive operations such as setting up frames, reading in data files and layout files, manipulating data, and creating plots. They are also necessary for running Tecplot 360 in batch mode. See Chapter 29: “Batch Processing”.

28 - 1 Macro Creation

Tecplot 360’s Macro Recorder records a macro as you perform a sequence of actions interactively (including loaded and executing Python scripts). After recording your macro, you can edit your macro file with an ASCII text editor to remove redundant operations, compress repetitive actions into loops, and otherwise modify the macro.

To record a macro with the Macro Recorder dialog select “Record Macro” from the Scripting menu. Specify a macro file name in the Write Macro File dialog and select [OK] in the Information dialog to initiate the recording. The Macro Recorder dialog will remain open during the recording session.

The Information dialog warns you that Auto Draw will be disabled during macro recording. However, you can manually redraw your plot by selecting the [Redraw] or [Redraw All] buttons located on the Sidebar.
While recording macros, you can use any of the following buttons on the Macro Recorder dialog to add specific macro commands to your macro:

- **Insert “Pause”** - Adds a “pause” command to the macro. When you play a macro including a pause command, Tecplot 360 displays a message box when it reaches the pause command, and waits for you to click OK before continuing to process the macro.
- **Insert “Graphics Off”** - Adds a “graphics off” command to the macro. When you play a macro containing a “graphics off” command, Tecplot 360 stops displaying graphics in the workspace from the “graphics off” command until a “graphics on” command is encountered.
- **Insert “Graphics On”** - Adds a “graphics on” command to the macro.
- **Insert Raw Command** - Brings up a dialog in which you can enter any valid Tecplot 360 macro command. For example, you can add “$!LOOP 10” at the start of a section you want to repeat 10 times, then “$!ENDLOOP” at the end. See the Scripting Guide for information on the Tecplot 360 macro language.
- **Stop Recording** - Select when you have completed the sequence of actions you want recorded.

Macros are guaranteed to be forward compatible (i.e. work with future releases) only if the file is started with a layout or stylesheet. Refer to the Scripting Guide for more information.

The commands in a macro file typically rely on Tecplot 360 being in a particular state. It is a good practice to use commands at the start of a macro that force Tecplot 360 into a known state. For example, the $!NEWLAYOUT command deletes all data sets and frames and creates a single empty frame with a default size and position.

### 28 - 1.1 Macro Functions

When editing a macro file, you can add macro function definitions and macro function calls. Macro functions have the following form:

```$!MACROFUNCTION
NAME = functionname
   
   
$!ENDMACROFUNCTION```

442
Between $!MACROFUNCTION$ and $!ENDMACROFUNCTION$, you can include any legal macro command except $!MACROFUNCTION$.

For example, the following macro function turns on the Contour zone layer, turns off the Mesh zone layer, sets the contour plot type to Both Lines and Flood for zones 1, 2 and 3, then chooses gray scale color mapping:

```
$!MACROFUNCTION
NAME = "graycontour"
RETAIN = Yes
$!FIELDLAYERS SHOWCONTOUR = YES
$!FIELDLAYERS SHOWMESH = NO
$!FIELDMAP [1-3] CONTOUR{CONTOURTYPE = BOTHLINESANDFLOOD}
$!COLORMAP 1 CONTOURCOLORMAP = GRAYSCALE
$!REDRAW
$!ENDMACROFUNCTION
```

The RETAIN parameter tells Tecplot 360 to retain the macro function definition for use in subsequent macro calls; this allows you to define a macro function once in some macro you load every time you run Tecplot 360, and continue to use it throughout your Tecplot 360 session.

Use the $!RUNMACROFUNCTION$ macro command to call your macro function. For example, to call the "graycontour" macro function defined above, use the following macro command:

```
$!RUNMACROFUNCTION "graycontour"
```

You can use the $!RUNMACROFUNCTION$ command within other macro functions; calls may be nested up to ten deep.

To access parameters from within a macro function use "|n|", where n is the parameter number (do not include the double quotes). For example, the following function uses two parameters for the assignments to SHOWCONTOUR and SHOWMESH:

```
$!MACROFUNCTION
NAME = "AssignContourAndMesh"
$!FIELDLAYERS SHOWCONTOUR = |1|
$!FIELDLAYERS SHOWMESH = |2|
$!ENDMACROFUNCTION
```

Use $!RUNMACROFUNCTION "AssignContourAndMesh"$ (YES,NO) as follows:

28 - 1.2 Macro Linking to Text and Geometries

Each text or geometry you create can be linked to a macro function. This macro function is called whenever the user holds down the control key and clicks the right mouse button on the text or geometry. For example, if you have pieces of text, each representing a different well, CTRL+right click on any piece could run a macro that brings up an XY-plot of that well’s data.

Macro functions are specified with the Link to Macro function field in the Geometry dialog or in the Text Options dialog.

28 - 2 Macro Play Back

Once you have created a macro file, you have four methods in Tecplot 360 for playing it back:

- **From the command line** - You can play a macro when Tecplot 360 is launched by including the name of the macro file on the command line, i.e.:
If your macro file does not have the `.mcr` extension, run Tecplot 360 with the macro file by including the `-p` flag on the command line, such as:

```
tecplot -p mymacro.mcr
```

If you want the macro viewer to automatically appear, include the `-z` flag.

- **From the Tecplot 360 interface** - You can play a macro from within Tecplot 360 by using the "Play Macro/Script" option (accessed via the Scripting menu).
- **Using the Macro Viewer** - Use the Macro Viewer (accessed via Scripting-View/Debug Macro) to step-through and debug your macro file. This dialog allows you to add and delete breakpoints, view and set watch variables, and view state variables local to the macro currently loaded into the Macro Viewer. See Section 28 - 3 "Macro Debugging" for more information.
- **Using Quick Macro Panel** - The Quick Macro Panel (accessed via the Scripting menu) allows you to quickly play a macro function by clicking on the button in the panel that is linked to that macro function. See Section 28 - 2.1 "Quick Macro Panel" for more information.

In Windows operating systems, you can also launch Tecplot 360 by dragging and dropping a macro file onto the Tecplot 360 icon. However, in this case, the macro file must have the `.mcr` extension. Otherwise, the file will be treated as an ASCII data file.

### 28 - 2.1 Quick Macro Panel

The Quick Macro Panel, accessible by selecting "Quick Macros" from the Scripting menu, is Tecplot 360's quick access mechanism for storing and retrieving your favorite, commonly used macro functions.

This panel comes with a number of useful macro functions already accessible on the panel. In particular, it includes several buttons to navigate pages in Tecplot 360.

The Quick Macro Panel is linked to a special macro file that contains only macro function definitions. When Tecplot 360 first launches, it looks for this file under one of the following names, in the following order:

1. The file `tecplot.mcr` in the current directory.
2. The file `.tecplot.mcr` in your home directory (UNIX), or `tecplot.mcr` in your home directory (Windows). On Windows platforms, your home directory is determined by the two environment variables `HOMEDRIVE` and `HOMEPATH`. If they are not set, Tecplot 360 skips your home directory.
3. The file `tecplot.mcr` in the Tecplot 360 home directory.

If Tecplot 360 finds the file, it loads it and associates each button on the Quick Macro Panel with a specific macro function.

You can specify a different Quick Macro file by adding the `-qm` option flag in front of the macro file name to the command line.

When you load a layout or file, Tecplot 360 automatically begins with one page as the workspace. To create a new page, rename the active page, and more, use the descriptive buttons in the Quick Macro Panel. Use the [Page >>] and [Page <<] buttons to go to the next page or the previous page. To learn more about pages, see Section 1 - 1.5  "Tecplot 360 Workspace".
The following command starts Tecplot 360 and installs the macro functions defined in the file myteccmd.mcr into the Quick Macro Panel:

```
tecplot -qm myteccmd.mcr
```

If you want Tecplot 360 to call up the Quick Macro Panel immediately after start up, include the `-showpanel` flag at the end of the command.

To see an example of a macro file, you can open one of the macro files in the Tecplot 360 standard installation, such as tecplot.mcr.

**28 - 3 Macro Debugging**

Use the Macro Viewer to step through and debug your macro file. This dialog allows you to add and delete breakpoints, view and set watch variables, and view state variables local to the macro currently loaded into the Macro Viewer. The Macro Viewer is accessed via “View/Debug Macro in the Scripting menu.

The Macro Viewer dialog displays the text of the currently loaded macro file at the top of the dialog. The greater-than symbol (“>”) marks the currently active line. It moves to the next command after the currently active command is evaluated.

The Macro Viewer dialog has the following options:

- **Load Macro** - Select this button to load a macro file into the Macro Viewer. This calls up the Load/Play Macro File dialog for you to specify which macro file to load. Macro files typically have the extension .mcr.
- **Step** - Use the [Step] button to evaluate a macro command. When a `$RUNMACROFUNCTION` command is encountered, the Macro Viewer steps into the called function.
- **Step Over** - The [Step Over] button also processes each macro command, line-by-line. However, when a `$RUNMACROFUNCTION` command is encountered, the entire function is processed.
• **Go** - Plays the macro without stopping after each step. Tecplot 360 continues until it either receives a stop signal from the [Stop] button, it finishes playing the macro, or it encounters a breakpoint.

• **Reset** - Restarts the evaluation of a macro within the Macro Viewer.

If your macro assumes Tecplot 360 is in a particular state when it starts processing then you must make sure Tecplot 360 is in this state before you click **Reset**.

• **Macro** - The Macro field displays the name of the macro or macro function you are currently evaluating. In most cases, this field displays the name `MAIN`, (indicating that the macro commands currently shown in the macro text display are from within the main macro body). If the macro you are viewing contains a call to a macro function, then the name is displayed in the Macro field when the called function is active.

If you switch context to the called macro function using the up and downs arrows, the `$RUNMACROFUNCTION` command that called the macro is displayed with a `^` (caret) in front of it. This helps you quickly determine which command line called the macro function currently under evaluation. The down arrow then moves you back down a level to the called macro you were just viewing.

• **Macro Command Display Format Changes** - Tecplot 360 displays the macro in the viewer in one of two formats:
  - **List Commands** [default] - A short format that lists the macro commands, one command per line.
  - **Expand Commands** - A long format which expands a single, simple macro command to show all of its sub-commands and parameters.

• **Breakpoint Addition and Deletion** - An important debugging feature that the Macro Viewer provides is the ability to add breakpoints within a macro’s command stream. A breakpoint is a flag you can insert anywhere in a macro that tells Tecplot 360 to immediately suspend evaluation. Tecplot 360 stops the action of a playing macro at the breakpoint to allow you to explore what is happening at that point in the macro file.
  - **Add Break** - Add a breakpoint at the selected macro command. A `^` displayed at the beginning of the highlighted macro command indicates the breakpoint’s placement.
  - **Delete Break** - Remove the breakpoint from the selected command.
  - **Delete All Breaks** - Removes all breakpoints set in the macro.

• **Watch Variables** - The Watch Variables dialog provides the ability to specify and view specific user defined, or system defined internal variables.

**28 - 3.1 Watch Variables**

To specify a watch variable in a macro, select [Watch Variables] in the Macro Viewer dialog. In the Macro Variables dialog, type the name of the variable you want to watch in one of the User-Defined or Internal Variable text fields.
While your macro is playing, an alert dialog is displayed whenever the tagged variable is accessed by the macro.

The **Macro Variables** dialog also automatically displays the values of any loops and the parameter values of any macro function calls to the stack as the macro is playing.

- **Loops** - When the macro viewer evaluates a loop macro command it automatically displays the current iteration value in the **Value** text fields. The total iterations value of that loop are displayed in the **End Value** text fields.
- **Call Stack** - When the macro viewer evaluates a nested macro command, the parameter values that the nest macro is called with are displayed in the **Call Stack** parameter text fields.

All the text fields in this dialog are editable, including the value text fields. This means you can change the value of a watch variable or parameter value as the macro is running to correct a problem or test a situation.

### 28 - 4 Moving Macros Among Computers or Directories

The file `tecplot.phy` is created each time you run Tecplot 360 interactively. It contains information about the physical characteristics of your computer system as well as information about the size of the Tecplot 360 process window used during the last Tecplot 360 session. It also contains the name of the last layout file used by Tecplot 360. If you are developing macros on one computer, but using them for batch processing on a different computer, you must transfer the `tecplot.phy` file from the development computer to the computer where you will run Tecplot 360 in batch mode. On UNIX platforms, the same is true if you are developing macros in one directory, but will be processing them in batch mode in a different directory. See [Section 32 - 5 “Tecplot.phy”](#) for information on the location of your `tecplot.phy` file.
Batch Processing

You can run Tecplot 360 in batch mode to create plots without displaying any graphics to the screen. This saves time when processing multiple files for printing or export. In batch mode, Tecplot 360 can be executed locally on your workstation computer or remotely using an ASCII terminal (UNIX only). The only limitation for batch mode operation is that under UNIX, you must use the Mesa version of Tecplot 360 if your macro creates export files in bitmap formats. (The OpenGL version requires screen resources not available in batch mode.)

29 - 1 Batch Processing Setup

To prepare for batch processing, follow these basic steps:

1. Create a macro file to control the batch processing. You may do this either by using Scripting->Record Macro and recording a Tecplot 360 session, or using an ASCII text editor. See Chapter 28: “Macros”.
2. Create layout and stylesheet files, as necessary.
3. Prepare data files.
4. Debug the macro file by running Tecplot 360 while not in batch mode.

Macros are required for batch processing. When Tecplot 360 is launched in batch mode it requires that you provide the name of a macro file to execute. The minimal command to launch Tecplot 360 in batch mode is as follows:

```
tec360 -b -p macrofile
```

The -b flag instructs Tecplot 360 to run in batch mode and the -p macrofile tells Tecplot 360 the name of the macro file to execute. Refer to the Quick Reference Guide for more command line options.
29 - 2  Batch Processing Using a Layout File

Combining layout files with batch processing is both powerful and flexible. It is also the recommended method. With layout files you can organize a plot using one or more frames in a single file. The layout file manages datasets and can be altered on the fly, either on the command line or within a macro that loads the layout file.

For example, to do the following sequence of tasks in batch mode:

- Load a data file from a user supplied file name.
- Create a specific style of plot.
- Create a PostScript file of the plot.

You can set up the batch script as follows:

1. Obtain a representative data file to be plotted.
2. Create a layout of the style of plot you want. (For this example, name the file batch.lay).
3. Use a text editor to create the following macro (For this example call this macro batch.mcr):

```text
#TPC 1120
$!EXPORTSETUP ExportFormat = PS
$!PRINTSETUP PALETTE = MONOCHROME
$!EXPORTSETUP PRINTRENDERTYPE = VECTOR
$!EXPORTSETUP EXPORTFNAME = "myfile.ps"
$!EXPORT
$!EXPORTREGION = CURRENTFRAME
$!Quit
```

4. Use the following command to run the job in batch mode:

```
tec360 -b -p batch.mcr -y psoutput.ps batch.lay mydatafile.
```

<table>
<thead>
<tr>
<th>tec360</th>
<th>launches Tecplot 360 in batch mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>-b</td>
<td>tells Tecplot 360 to use the following macro file</td>
</tr>
<tr>
<td>-p batch.mcr</td>
<td>macro file</td>
</tr>
<tr>
<td>-y psoutput.ps</td>
<td>export file</td>
</tr>
<tr>
<td>batch.lay</td>
<td>layout file to use</td>
</tr>
<tr>
<td>mydatafile</td>
<td>data file to use</td>
</tr>
</tbody>
</table>

29 - 3  Multiple Data File Processing

In Section 29 - 2 "Batch Processing Using a Layout File" we set up Tecplot 360 to process a user-supplied data file (or data files) and create a single output file. If the above procedure is to be repeated for a large number of input files (one at a time), you can do this by using a loop: either outside Tecplot 360 in the operating system or within Tecplot 360 using the flow-of-control commands in the Tecplot 360 macro language.

29 - 3.1  Looping Outside Tecplot 360

The following examples show the command files for launching Tecplot 360 in an operating system loop on two different operating systems. Tecplot 360 processes five data files named dm*.plt and creates ten output files named dm*.out where m goes from 1 to 10.
Batch Processing Diagnostics

**Looping Outside Tecplot 360 (UNIX):** Create a shell script with the following commands:

```bash
#!/bin/sh
n=1
while test $n -le 10
  do
tec360 -b -p batch.mcr -y d$n.out batch.lay d$n.plt
  n=`expr $n+1`
done
```

**Looping Outside Tecplot 360 (Windows):** Create a batch file with the following commands:

```bash
for %%f in (d1 d2 d3 d4 d5 d6 d7 d8 d9 d10) do
tec360 -b -p batch.mcr -y %%f.out batch.lay %%f.plt
```

**29 - 3.2 Looping Inside Tecplot 360**

In Section 29 - 3.1 “Looping Outside Tecplot 360” we set up Tecplot 360 to process multiple data files using the operating system language to do the looping. There are two drawbacks to this procedure:

- The operating system languages are not portable between different operating systems.
- Tecplot 360 must be continuously started and stopped each time a new dataset is processed.

A more efficient approach is to loop through the data files inside Tecplot 360. Here, the layout file and the data files are all named within the Tecplot 360 macro. The command line in this example is simple, as follows:

```
tec360 -b -p batch.mcr
```

The Tecplot 360 macro is set up as follows:

```xml
$OPENLAYOUT "batch.lay"
ALTDATALOADINSTRUCTIONS = "d|LOOP|.plt"
$EXPORTSETUP EXPORTFORMAT = PS
$PRINTSETUP PALETTE = MONOCHROME
$LOOP 10
$ENDLOOP
$QUIT
```

The `$OPENLAYOUT` command loads in `batch.lay` but replaces the data file referenced in the layout with the file names in the `ALTDATALOADINSTRUCTIONS` sub-command. The `$EXPORTSETUP` command is used in two places. Initially it is used to set the export format. Later it is used just to change the name of the file to export to. The `$EXPORT` command does the actual exporting.

If you want to make many different plots using the same dataset, stylesheets will be more efficient than layout files.

**29 - 4 Batch Processing Diagnostics**

Each time Tecplot 360 is run in batch mode it creates a file defined by the name in the `BATCHLOGFILE` environment variable, or, if the environment variable is not defined, by a file named `batch.log` in the directory where Tecplot 360 was started. If the name given in the `BATCHLOGFILE` environment variable is
relative path, the directory name where Tecplot 360 was started is prefixed. A running commentary on actions performed in Tecplot 360, as well as warning and error messages, are sent to the batch.log file.
Working With Python Scripts

There are a number of different ways to run Python scripts with Tecplot 360. The simplest method is to combine Python scripts with Tecplot 360's macro language. Alternatively, you can use the Python Quick Macro Panel or run standalone Python scripts. Refer to the remainder of this chapter for complete details regarding each of these methods. Refer to “Python Syntax Rules” in the Scripting Guide for details.

Refer to www.tecplotalk.com/python for sample Python scripts, as well as a user forum.

30 - 1 Combining Python scripts with macro commands

One of the primary benefits of working with Tecplot 360's macro language is that you can record a macro file while you interactively create your plots with Tecplot 360 (see Section 28.1 “Macro Creation”). If you load a Python module while you are recording a macro file in Tecplot 360, the steps to load the Python file will be added to your macro file. The syntax will appear as follows:

```python
COMMANDPROCESSORID = 'Python Utility'
COMMAND = 'LOADPYFILE NAME = "mypythonscript"
```

As you interactively work with your Python module(s) (during macro recording), the Python functions you call and the parameters you enter will also be recorded to your macro file. For example, if you run a module called “curvefit”, run the “bspline” function within that module and enter a parameter input of “1”, the syntax would appear as follows:

```python
COMMANDPROCESSORID = 'Python Utility'
COMMAND = 'RUNPYFUNCTION MODULE="curvefit" FUNCTION = "bspline" ARGUMENTS="1"
```

Once you have completed recording the macro, you can play the macro file back at anytime to recreate your plot using Python modules. For more information on recording and playing back macros refer to Chapter 28: “Macros”. For information regarding macro syntax refer to the Scripting Guide.
Using the Python Quick Scripts Panel

A second option for working with Python scripts in Tecplot 360 is to use the Python Quick Scripts Panel (accessed via Scripting>Quick Python Scripts). The Python Quick Scripts dialog allows you to interactively run existing Python scripts.

In order for functions to be available in the Python Quick Scripts Panel, the function definition must begin with "TP_". For example, consider the content of the following module:

```python
def TP_PickedZonesDelete():
    zones = []
    count = TecUtil.PicklistGetCount()
    if count > 0:
        for idx in range(count):
            if TecUtil.PicklistGetType(idx + 1) == TecVals.PickObject_Zone:
                zones.append(TecUtil.PicklistGetZoneNumber(idx + 1))
    TecUtil.DataSetDeleteZone(zones)

def InputZoneDelete(zoneNum):
    zones = [zoneNum]
    TecUtil.DataSetDeleteZone(zones)
```

If the above module is loaded into Tecplot 360's Python Quick Scripts dialog, the PickedZonesDelete function would be available in the panel. However, the InputZoneDelete function would not be available.

The Python Quick Macros dialog has the following options:

- **Browse** - Use the browse button to navigate to the Python module you wish to load.

In order to run a given Python module, it must be stored in a directory that is defined in your PYTHONPATH variable. Refer to the Section 30 - 4 "Modifying the Python Path" for details.
Running an entire Python Module

- **Load** - Once you have navigated to the module you wish to load (via the [Browse] button), use the [Load] button to load the module into Tecplot 360.

  The [Load] button also allows you to re-load the file after you have edited it (outside of the Tecplot 360 environment). Simply press the button again to re-load the file.

- **Function** - You are not limited to running an entire Python module, you may run functions within your loaded modules individually via the function region of the dialog. The name of the module that contains the function you have selected will be displayed in the Module field of the dialog. Use the Parameters field to enter any input parameters.

  - +/- - Use the [+-] button to either display all of the functions contained within each loaded module (+) or collapse the list (-).

  - **Parameters** - When a function is selected, the argument list will be displayed. Use the box to enter comma delimit values for input parameters.

    Do not enter the surrounding parentheses. These will be added for you automatically.

- **Run** - Use the run button to execute the selected module or function.

30 - 3 Running an entire Python Module

If you wish to run a Python module in its entirety, you may either use the method described in Section 30 - 2 "Using the Python Quick Scripts Panel" or the method described here.

You may run an entire Python module by selecting Scripting: Play Macro/Script and navigating to the desired Python module.

In order to run a given Python module, it must be stored in a directory that is defined in your PYTHONPATH variable. Refer to the Section 30 - 4 "Modifying the Python Path" for details.
This method has the following limitations:

- You may not pass input parameters to the module.
- Python scripts cannot be recorded (while Tecplot 360 macro commands can be).
- You are required to run the entire module and cannot run its functions individually.

30 - 4 Modifying the Python Path

When you load a Python module into Tecplot's Python Interpreter, the module (or file) must be stored in a directory (or a subdirectory of a directory) defined in your PYTHONPATH variable. You may interactively modify your PYTHONPATH variable via the Python Folders dialog (accessed via Scripting>Configure Python Search Path).

To append the value of your PYTHONPATH variable, use the [Browse] button to navigate to the desired directory and then select the [Add to list] button.

When you modify the PYTHONPATH variable via the Python Folders dialog, the new value(s) will be available during the current Tecplot 360 session only. If you will regularly use the same directory, we recommend modifying your environment variables directly.

30 - 5 Python Installation Notes

When you install Tecplot 360, a Python library (version 2.7.2) and supporting Python files for Tecplot 360 are installed in $TEC_360_2013R1/Python, where $TEC_360_2013R1 is your Tecplot 360 installation directory. This private copy of the Python interpreter will be used to run Python scripts inside Tecplot 360. Changes to Python environment variables made within Tecplot 360, such as PYTHONPATH, apply only to the current Tecplot 360 session.

If you would rather use your own Python 2.7.2 installation, set the environment variable TEC_PYTHON_HOME to point to it, and Tecplot 360 will use the specified Python interpreter instead of the included copy.

1. For Windows users, $TEC_360_2013R1 is typically C:\Program Files\Tecplot\Tec360 2013R1.
You may make SciPy, NumPy, and other Python modules available in the Tecplot 360 Python interpreter by installing them relative to the aforementioned directory.

In order to execute a Python script, the full path for the directory the script is in must be defined in the PYTHONPATH environment variable. If it is not feasible to change PYTHONPATH system-wide, set the variable in a script or batch file that then launches Tecplot 360.

Several Python scripting samples have been included for your reference. These scripts are located in your Tecplot 360 installation directory and are also available at www.tecplottalk.com/python.
Animation

Tecplot 360 provides a variety of methods for creating animated plots and exporting them to movie files for playback at a later time. There are three basic animation methods available:

- **Animation Tools** - Perform simple animations using the dialogs in the *Animate* menu. The *Animate* menu allows you to animate zones, mappings, iso-surfaces, IJK-planes, IJK-blanking, slices, time, or streamtraces. The animation is viewed within Tecplot 360 or exported to a movie file.
- **Movie File Creation Manually** - Interactively create movies by creating an initial plot, exporting the image to a movie, then repeatedly changing the plot and appending new images to the same movie file.
- **Movie File Creation with Macros** - Use a macro to perform multiple, repetitive changes, and write each image to a movie file.

**31 - 1  Animation Tools**

Use the *Animate* menu to have Tecplot 360 cycle through your data, automatically display zones, IJK-planes, or any of several other plot elements, one after the other, until your entire dataset has been displayed.

When you need a particular size for your animation image, such as 300 by 250 pixels, first edit your frame to the correct width and height. Then export only the active frame.

**31 - 1.1  Time Animation**

To animate over time, simply press the play button in the Sidebar. The active frame will be animated from the Current Solution (displayed in the Sidebar) Time to the last time step.

This option is available for transient field plot data ONLY.
Alternatively, you may select “Time” from the Animate menu. The Animate page of the Time Details dialog has the following options:

- **Start Time** - Enter the value of the first solution time to include in the animation. If the Solution Time entered does not exist, the nearest Solution Time less than the entered time is used. The default value is the first Solution Time. The value of the first Solution Time in the dataset is displayed in Min.
- **End Time** - Enter the value of the last Solution Time to include in the animation. If the Solution Time entered does not exist, the nearest Solution Time less than the entered time is used. The default value is the last Solution Time. The value of the last Solution Time in the dataset is displayed in Max.
- **Time Step Skip** - Enter the skip number between time steps. A value of 2 results in every other time steps being animated, a value of 3 animates every 3 time steps, and so on.
- **Number of Time Steps** - A read-only field that displays the number of time steps in the data between the Start Time and the End Time.
- **Destination** - Specify the output format for the animation, “On Screen” or “To File”.

Selecting “To File” brings up the following options:
- **File Format** - Select an available movie format (see Section 26 - 5 “Movie Format”).
- **Generate Animation File** - Select this button to launch the Export dialog associated with the selected file format.

Selecting “On Screen” brings up the following options:
- **Operation** - Select from the following options:
  - **Forward** – Animation makes one pass from the current step to the ending value.
  - **Backward** – Animation makes one pass from the current step to the starting value.

The Current Solution Time determines which transient zones are displayed in the active frame. The slider control can be used to interactively change the Current Solution Time. See Section 7 - 2.1 “Time Details Dialog - Settings Page” for more information on the Time Details dialog.
• **Loop** – Animation starts at the current step and proceeds to the ending value, at which point it jumps to the starting value and continues looping until interrupted by pressing the [Stop] button.

• **Bounce** – The animation starts at the current step and proceeds to the ending value, then “bounces” backward and reverses the animation to the starting value. This repeats until interrupted by pressing the [Stop] button.

• **Animation Step** - This field displays the time step for the active frame of the animation. The field is updated while an animation is in progress.

• **Go To** - Use the [Go To] button to jump to the nᵗʰ animation step, where n is the value entered in the Animation Step field.

• **Slider** – The slider can be dragged to change the current solution time.

  - [ ] – Jumps to the value in Start Time.
  - [ ] – Moves toward the value in Start Time by one step.
  - [ ] – Runs the animation as specified by the ‘Operation’ field. The [Play] button becomes a [Stop] button while the animation is playing.
  - [ ] – Moves toward the value in End Time by one step.
  - [ ] – Jumps to the value in End Time.

• **Limit Animation Speed** - Toggle-on to limit the animation speed to the value specified in the Max Speed field. You can enter a frame speed value in the Max Speed text box.

• **Drop dialog during animation** - Toggle-on this option to close the dialog during animation. The dialog will reopen after the animation is complete.

  Toggle-on “Drop dialog during animation” and close any other time-sensitive dialogs for any animations where speed is important [On Screen animation only].

  Also, to stop the animation when the dialog is “dropped”, press the [Stop] button located on the status bar.

### 31.1.2 IJK-plane Animation

Use the **Animate IJK-Planes** dialog to display all or a specified subset of the IJK-planes in the current dataset, one at a time. You can choose to animate either the I, J, or K-planes.
To animate IJK-planes, select “IJK-planes” from the **Animate** menu. The **Animate IJK-Planes** dialog has the following options:

- **Planes to Animate** - Specify the set of planes to animate: I, J, or K-planes.
- **Index** - Specify a Start Index (the first plane you want to display), an End Index (the last plane you want to display), and an Index Skip in the fields provided. If you specify a start index that has a higher number than the end index, Tecplot 360 cycles backward from the Start Index number to the End Index number.
- **Animate To** - Use the **Animate** drop-down menu to select the output format for the animation. You can animate to a number of formats, or “On Screen.” See also: Section 26.5 “Movie Format.”
- **Animate Button** - Select the [Animate] button to run the animation automatically, or use the + and - buttons in the Current Index area to “step through” the animation one plane at a time. Both options cycle through the range of planes specified by Start Index and End Index; if your range is reversed, so are their actions.

*Figure 31.1* shows an example of animating I-planes in an IJK-ordered zone.
31 - 1.3 IJK Blanking Animation

Use the Animate IJK Blanking dialog to animate a sequence of Tecplot 360 renderings, starting with an initial set of blanked IJK indices and proceeding in a series of interpolated steps to a final set of blanked IJK indices. To animate a sequence of IJK blankings, you must first turn on IJK blanking and then select "IJK Blanking" from the Animate menu. The Animate IJK Blanking dialog has the following options:

- **Starting Index (% of Max)** - Specify an initial set of blanked IJK-indices in the text fields. Enter a range of indices for: I, J, and K (index values are entered as percentages of the maximum index).
- **Ending Index (% of Max)** - Specify a final set of blanked IJK-indices. Enter a range of indices for each: I, J, and K.
- **Number of Steps** - Specify the number of steps. The minimum number is two.
- **Animate drop-down menu** - Select the destination for the animation: "On Screen" or a movie file (see Section 26 - 5 "Movie Format").
- **Animate button** - Select the [Animate] button to run the animation automatically, or use the [+] and [-] buttons in the Current Step area to “step through” the animation one plane at a time.

31 - 1.4 Iso-surfaces Animation

Use the Animate page of the Iso-surface Details dialog to define iso-surfaces to animate either on screen or to a file.

To animate iso-surfaces, select "Iso-Surfaces" from the Animate menu. Alternatively, you can open the Iso-Surfaces Details dialog from the Plot menu or Sidebar and select the Animate page.
Specify a starting value, an ending value, and the number of steps in the fields provided. If you specify a start level with a higher number than the end level, Tecplot 360 cycles backward from the Starting Value to the Ending Value.

The remaining controls are dependent upon the Destination selected.

**On-Screen Animation**

If you select “On-Screen” as the animation destination, you have the following controls:

- **Operation**
  - **Forward** – Animation makes one pass from the current step to the ending value.
  - **Backward** – Animation makes one pass from the current step to the starting value.
  - **Loop** – Animation starts at the current step and proceeds to the ending value, at which point it jumps to the starting value and continues to the ending value until interrupted by selecting the [Stop] button.
  - **Bounce** – The animation starts at the current step and proceeds to the ending value, then “bounces” backward and animates to the starting value. This continues until interrupted by selecting the [Stop] button.
- **Current Step** – Indicates the active step of the animation. This may be edited to jump to a specific step.
- **Current Value** – Displays the iso-surface value at the current step.
- **GoTo** – While an on-screen iso-surface animation is playing, the iso-surface can be repositioned (independently of the animation) via the Definitions page, a macro, or an add-on. Use the [GoTo] button to reset the position to the step value in the Current Step field.
- **Slider** – The slider can be dragged to change the current solution time.
  - **←** – Jumps to the value in Start Time.
  - **→** – Moves toward the value in Start Time by one step.
  - **Run the animation as specified by the ‘Operation’ field. The Play button becomes a Stop button while the animation is playing.
  - **+** – Moves toward the value in End Time by one step.
Animation Tools

- **Limit Animation Speed** – If the animation on-screen is too fast you may limit the animation speed by enabling this toggle.
- **Max Speed (fr/sec)** – To use this feature, toggle-on “Limit Animation Speed. This specifies the maximum frames per second that will be displayed during the animation. This guarantees that the frame rate will be no faster than the value specified. You can input a specific frame speed value by entering the value in the Max Speed text box. However, the frame rate may be slower than the value specified, depending on the complexity of the animation and size of the dataset.
- **Drop dialog during animation** – Toggle-on this option to close the dialog during animation. The dialog will reopen after the animation is complete.

Toggle-on “Drop dialog during animation” and close any other time-sensitive dialogs for any animations where speed is important [On Screen animation only].

Also, to stop the animation when the dialog is “dropped”, press the [Stop] button located on the status bar.

This option will not work when animating to a file if Image Export Options is set to Safe on the Rendering page of the Performance dialog (see Section 32 - 3.1 “Rendering”).

**Animation To File**

If you select “To File” as the animation destination, select the file format and press the [Generate Animation File] button.

**31 - 1.5 Mapping Animation**

Use the Animate Mappings dialog to display all or a specified subset of the XY or Polar Line mappings defined in the active frame, one at a time.

To animate mapping, select “Mappings” from the Animate menu. The Animate Mappings dialog has the following options:

- **Start Map** - Specify the first line mapping you want displayed.
- **End Map** - Specify the last line mapping you want displayed. If you specify a Start Map having a higher number than the End Map, Tecplot 360 cycles backward from the start to the end.
- **Max Skip** - Specify the number of maps to skip.
- **Animate To** - Use the Animate drop-down menu to select the output format for the animation. You can animate to a variety of movie formats, or “On Screen”. See also: Section 26 - 5 “Movie Format”.
• **Animate** - Select the [Animate] button to run the animation automatically, or use + and - in the Current Index area to “step through” the animation one plane at a time. Both options cycle through the range of planes specified by Start Index and End Index; if your range is reversed, so are their actions.

You can try animating mappings with the data file *rainfall.plt*. This file is located in your Tecplot 360 distribution under the examples/XY subdirectory.

### 31 - 1.6 Slice Animation

To animate slices, select “Slices” from the Animate menu. Alternatively you can open the Slice Details dialog from the Plot menu or Sidebar and select the Animate page.

![Slice Details dialog](image)

Specify a Starting Value, an Ending Value, and the Number of Steps in the fields provided. If you specify a start value having a higher number than the end value, Tecplot 360 cycles backward from the start to the end.

Only the primary slice of the current slice group (specified on the Position page) is changed during animations. The start and end slice and any intermediate slices of the current slice group are unchanged. It is possible that the animated primary slice will overlap the start slice, end slice, or an intermediate slice. The animation will proceed, without changing those values.

The remaining controls are dependent upon the Destination selected.

**On-Screen Animation**

If you select “On-Screen” as the animation destination, you have the following controls:

- **Operation**
  - **Forward** – Animation makes one pass from the current step to the ending value
  - **Backward** – Animation makes one pass from the current step to the starting value.
• **Loop** – Animation starts at the current step and proceeds to the ending value, at which point it jumps to the starting value and continues to the ending value until interrupted by pressing the [Stop] button.

• **Bounce** – The animation starts at the current step and proceeds to the ending value, then “bounces” backward and animates to the starting value. This continues until interrupted by pressing the [Stop] button.

• **Current Step** – Indicates the active step of the animation. This may be edited to jump to a specific step.

• **Current Value** – Displays the slice value at the current step.

• **GoTo** – While an on-screen Slice animation is playing, the Slice can be repositioned (independently of the animation) via the Position page, a macro, or an add-on. Use the [GoTo] button to reset the position to the step value in the Current Step field.

• **Slider** – The slider can be dragged to change the current solution time.
  - – Jumps to the value in Start Time.
  - – Moves toward the value in Start Time by one step.
  - – Runs the animation as specified by the ‘Operation’ field. The Play button becomes a Stop button while the animation is playing.
  - – Jumps to the value in End Time by one step.
  - – Moves toward the value in End Time by one step.

• **Limit Animation Speed** – If the animation on-screen is too fast you may limit the animation speed by enabling this toggle.

• **Max Speed (fr/sec)** – To use this feature, toggle-on “Limit Animation Speed. This specifies the maximum frames per second that will be displayed during the animation. This guarantees that the frame rate will be no faster than the value specified. You can input a specific frame speed value by entering the value in the Max Speed text box. However, the frame rate may be slower than the value specified, depending on the complexity of the animation and size of the dataset.

• **Drop dialog during animation** – Toggle-on this option to close the dialog during animation. The dialog will reopen after the animation is complete.

  Toggle-on “Drop dialog during animation” and close any other time-sensitive dialogs for any animations where speed is important [On Screen animation only].
  Also, to stop the animation when the dialog is “dropped”, press the [Stop] button located on the status bar.

This option will not work when animating to a file if Image Export Options is set to Safe on the Rendering page of the Performance dialog (see Section 32 - 3.1 “Rendering”).

---

**Animation To File**

If you select “To File” as the animation destination, select the file format and press the [Generate Animation File] button.
31 - 1.7 Streamtrace Animation

To animate your streamtraces, select “Streamtraces” from the Animate menu.

Specify the number of steps per cycle and the number of cycles in the fields provided in the Animate Streamtraces dialog.

- Use the Animate drop-down menu to select the output format for the animation. You can animate to a file or the screen (see also: Section 26 - 5 “Movie Format”).

31 - 1.8 Zone Animation

To animate zones, select “Zones” from the Animate menu. From the Animate Zones dialog, specify the Start Zone, End Zone, and Zone Skip in the fields provided.

- If you specify a Start Zone having a higher number than the End Zone, Tecplot 360 cycles backward from the start to the end. Use the Animate drop-down menu to select the output format for the animation. You can animate to a file or “On Screen”. (See also: Section 26 - 5 “Movie Format”.)

Use the Mode drop-down menu to select from the following options:

- **Step by Number** - Animate all zones from the first zone to the last zone with a skip specified in the Zone Skip field. A Zone Skip of 1 animates all zones.

- **Group Step by Number** - Animate zones in groups (as specified by the Group Size field). A Group Size of 2 will animate all zones in groups of 2 (i.e. zones 1 and 2, followed by zones 3 and 4).
**Step by Time** - Legacy option. Use this option if you have the Common.Time variable in your auxiliary data. Otherwise, use Time Animation (see Section 31 - 1.1 “Time Animation”).

The Animate Zones dialog is not available for transient datasets.

### 31 - 2 Movie File Creation Manually

You can create a movie file interactively by using the “Export” option in the File menu. This option allows you capture and append consecutive images to the same movie file.

Follow these steps to manually create your movie file:

1. Create your plot.
2. Select “Export” from the File menu.

![Export dialog](image)

3. In the Export dialog,
   a. Select the desired formats from the Export Format drop-down menu.
   b. Select Active Frame, All Frames, or Work Area from the Region drop-down menu.
   c. Select the “Use Width of Image on Screen” radio button, or enter your own desired dimensions for the exported images.
   d. If you have text in your plot, select “Antialiasing” to improve the appearance of text in the exported file.
   e. Choose the desired Color options and Animation Speed (if available for your output format).
4. Select the [OK] button.
5. In the Select Export File dialog, specify a filename or URL destination for your movie file and select the [Save] button.
After you have selected your movie file name, the **Record Animation File** dialog will launch.

6. In the **Record Animation File** dialog, select the frame you want to record and press the [Record Next Image] button.

7. Change desired aspects of your plot, and select the [Record Next Image] button. Repeat for as many images as you would like to capture.

8. Select the [Finish Animation] button when you have completed capturing your images.

**31 - 2.1 Record Animation File dialog**

The Record Animation File dialog will launch after you have selected your movie file name. Select [Record Next Image] for each snapshot of the active frame you wish to record.

**31 - 3 Movie File Creation with Macros**

The Tecplot 360 macro language expands the capabilities of Tecplot 360's standard animation features. The macro commands allow you to do almost anything you can do interactively, and export images to movie files. You can also use loops to repeatedly rotate 3D objects, cycle from one active zone to another, and so on, to create your movie. See Chapter 28: "Macros" for detailed information regarding the Tecplot 360 macro language.

A typical macro file for making movies has the following form:

```plaintext
#!MC 1120
... optional commands to set up the first image
$!EXPORTSETUP EXPORTFORMAT = AVI
$!EXPORTSETUP EXPORTFNAME = "mymovie.avi"
$!EXPORTSTART
EXPORTREGION = CURRENTFRAME
$!LOOP 50
... commands to set up next image
$!REDRAWALL
$!EXPORTNEXTFRAME
$!ENDLOOP
$!EXPORTFINISH
```
Advanced Animation Techniques

For example, the following macro file duplicates the actions performed by the Animate Zones dialog:

31 - 4 Advanced Animation Techniques

31 - 4.1 Text Changes

There may be times when you want to include information in your animation which tells viewers about the time step, current zones, or a mapping. There are two ways this can be done.

Using Dynamic Text

The best way to do this is to add dynamic text to your text box. See Section 18 - 1.5 "Dynamic Text".

Attaching Text to Zones

This method works best if you are animating zones. First, create several text strings in your data file, and use the ZN= parameter to attach each text string to a zone or mapping. You should have a separate text string for each zone that will be used in your animation. For example:

```
ZONE T= "Temp. distribution, Distance = 0.5 m" I=51, J=51 F=POINT

TEXT X=70, Y=90, T= "Distance = 0.5 m", F=COURIER, CS=FRAME, H=2, ZN=1

ZONE T= "Temp. distribution, Distance = 1.0 m" I=51, J=51 F=POINT

TEXT X=70, Y=90, T= "Distance = 1.0 m", F=COURIER, CS=FRAME, H=2, ZN=2
```
You can also use Tecplot 360’s dynamic text feature (see Section 18.1.5 “Dynamic Text”) to insert a zone name into your text strings. For example

```
Zone T = "Distance= 1.0 m, I=51, J=51"
```

31 - 4.2 Multiple Frames Animation

Animation of plots in multiple frames requires the use of a macro. Macros can use the $FRAMECONTROL commands to switch between each frame. The following template demonstrates how this is done with a layout where each frame contains a similar plot:

```
#MC 1120
#Set the number of images (movie frames) in the animation.
$VARSET |NumCycles| = 10
$EXPORTSETUP EXPORTFORMAT = RASTERMETAFILE
$EXPORTSETUP EXPORTFNAME = "2frames.rm"
BITDUMPREGION = ALLFRAMES

# Insert commands to set up first frame, if necessary.
## Outer loop
$LOOP |NumCycles|
## Inner loop cycles through each frame in the current layout.
$LOOP |NumFrames|
## Push the top (active) frame to the back.
$FRAMECONTROL MoveToBottomByNumber
## Activate new top frame
$FRAMECONTROL ActivateTop
$EndLoop
## This series of $IF statements ensures
## that a new AVI file will be created when
## the macro is started.
$IF |Loop| == 1
$EXPORTSTART
EXPORTREGION = CURRENTFRAME
$ENDIF
$IF |Loop| != 1
$EXPORTNEXTFRAME
$ENDIF
$ENDLOOP
$EXPORTFINISH
```

31 - 5 Movie File Viewing

The following tools allow you to view movie files you have created with Tecplot 360.

31 - 5.1 AVI Files

AVI format is an older video format for Windows platforms. Below are some applications that can be used to view and/or edit AVI files:
Movie File Viewing

- **Xanim** - A program for playing a wide variety of video formats on UNIX X11 machines. More information is available at [http://xanim.polter.net](http://xanim.polter.net).
- **Adobe® Premier®** - A powerful tool for professional digital video editing. More information is available at [www.adobe.com](http://www.adobe.com).

### 31 - 5.2 Flash Files

#### Playback

- Flash movies can be played in several freely distributed Flash players. Swiff Player is a very good stand-alone player that enables Flash users to easily play their Flash movies.
- You can play Flash movies using QuickTime® software.
- There are several tools at [Download.com](http://www.download.com) that can help manage, browse, convert, and display all kinds of Flash files on your computer.

#### Flash in PowerPoint

The easiest way to insert and play SWF files into Microsoft® PowerPoint® presentations is to download the Swiff Point Player — a free Microsoft PowerPoint Add-In.

A secondary option is to play it in a PowerPoint presentation using a specific Microsoft® ActiveX® control and the Macromedia Flash Player. To run the Flash file, you add an ActiveX control to the PowerPoint slide and create a link from it to the Flash file. You also have the option of embedding the file in the presentation. The following tutorial will help you do this:


#### Flash on the Web

Flash files can be inserted into Web and HTML documents using several different Web design tools such as Adobe® Dreamweaver® and Adobe® GoLive®, as well as free tools and using straight-hand code.

Once inserted, Flash movies play directly within your browser. An outside media player is not needed to launch the animation.

### 31 - 5.3 Flash Video (FLV) Files

FLV files are intended to be used with Adobe Flash as part of complete Flash presentations. As such, you will need Adobe Flash to use them to their full potential. You may also use them with pre-built Flash video players, which reference an external FLV file hosted on a Web site. A video player program, VLC, can play them without Adobe Flash.

- **VideoLAN Client (VLC)** - [http://www.videolan.org/vlc](http://www.videolan.org/vlc)

### 31 - 5.4 MPEG-4 Files

MPEG-4 video files can be played by a wide variety of computer software, portable devices, and set-top software. For Macintosh and Windows computers, QuickTime Player can be used.

Windows Media Video (WMV) files are widely supported by Windows applications, including Windows Media Player and Microsoft Office (PowerPoint, etc.). They may also be played on Macintosh computers using Flip4Mac.

- Flip4Mac: [http://www.telestream.net/flip4mac/overview.htm](http://www.telestream.net/flip4mac/overview.htm)

**31 - 5.6 Raster Metafiles Viewing in Framer**

Raster Metafile is a NASA-defined standard format for storing bit images and may contain one or more images. You can create a Raster Metafile in Tecplot 360 either interactively, or using a Tecplot 360 macro. For many types of repetitive plots (such as rotations, where each image is a slightly rotated version of the previous image), macros provide a very convenient means of simplifying Raster Metafile creation.

The Raster Metafile format is defined in the following reference:


Once you have created your Raster Metafile, you can view the resulting file with Framer. Framer is a utility program that is included with Tecplot 360. It allows you to view files stored in Raster Metafile format and runs independently of Tecplot 360.

The UNIX version of Framer is run from your shell prompt; the Windows version can be launched from the Tecplot 360 program folder under the [Start] button. You may freely distribute the Framer executable to allow others to view your animation.

To launch Framer at a command line (shell prompt, Run command, and so forth), use the following command:

```
framer [options] [rmfile]
```

where `[rmfile]` is the name of a file containing Raster Metafile bitmaps created by Tecplot 360, and `[options]` is one or more of the options listed in Section B - 2 "Framer".

To run Framer on UNIX type:

```
framer [filename]
```

If you do not specify a file name, Framer prompts you for one. In this dialog, you can choose to set buffering [equivalent to the `-b` flag] and/or multiple color maps [equivalent to the `-m` flag]. For a list of Framer command lines, see Section B - 2 "Framer".
Figure 31-2 shows the main Framer window on Windows platforms.

Figure 31-2. The Framer application window for a Windows machine.
Customization

Use the Preferences menu (accessed via the File menu) and the Options menu to customize Tecplot 360. This chapter discusses the Preferences menu. Please refer to Section 2-4 "Workspace Management Options Menu" for information pertaining to the Options menu.

32 - 1 Configuration Files

A Tecplot 360 configuration file is a special type of Tecplot 360 macro file that Tecplot 360 reads on start up. Use customized configuration files to override any or all of Tecplot 360's factory default settings.

You can create a configuration file from scratch using any ASCII text editor, or using the Preferences>Save Configuration option in the File menu.

32 - 1.1 Loading Configuration Files in Tecplot 360

Tecplot 360 looks for configuration files (named tecplot.cfg) in one of three places: the current working directory, the user’s home directory, and the Tecplot 360 home directory. Tecplot 360 looks for the configuration file (in the respective order listed above) and uses the first configuration file found.

The names of the default configuration files used in Tecplot 360 vary from platform to platform; this chapter concentrates on UNIX and Windows files.

If you want to force Tecplot 360 to load a specific configuration file (instead of one of the standard files named above), you may use the -c command line option when starting Tecplot 360.

System administrators can use the tecplot.cfg file in the Tecplot 360 home directory to set system-wide defaults, then others on the system can copy the system configuration file to their own home directories.
and make any desired changes. The settings in your local configuration file are used instead of the settings in the system configuration file.

Tecplot 360 on UNIX platforms has a second type of configuration file: an X11 resource file (app-defaults file) that controls the appearance of the Tecplot 360 application and its dialogs. Most users do not need to concern themselves with this file; nothing in the resource file has any affect on the plots you create with Tecplot 360, either on screen or on paper. However, if you are an experienced UNIX and X11 user, you may want to modify some of the resources to improve the appearance of Tecplot 360’s windows and dialogs on your display. Section 32 - 4 “Interface Configuration (UNIX)” explains how to do this.

32 - 1.2 Configuration File Creation

The simplest way to create a configuration file is to change the appropriate settings using the Tecplot 360 interface, then save the configuration. For example, suppose you want to have your paper orientation default to be portrait and have your default export format be Encapsulated PostScript (EPS). You can modify the settings using the appropriate Tecplot 360 dialogs, then save the configuration file.

To save a Tecplot 360 configuration file, change settings as desired using Tecplot 360 dialogs and select Preferences > Save Configuration from the File menu.

Include Factory Defaults.

If “Include Factory Defaults” is toggled-on, the created file will contain the factory defaults for the following types of Tecplot 360 settings:

- Interface details.
- RGB color assignments for Tecplot 360’s basic colors.
- Default paper layout.
- Print and export setup information.

If you modify any setting from these four types interactively and then save your configuration, the modifications are saved. However, modifications to other types of settings will not be saved.
**32 - 1.3 Editing the Configuration File**

You are not limited to customizing only those settings that appear in the saved configuration file. Most settings that can be modified by the `$Field`, `$LineMap`, or `$Interface` macro commands can be changed in the configuration file directly. The `$LIMITS` macro command can be used in the configuration file only.

The simplest way to do this is to create a layout or macro with the settings you want, then copy and paste the appropriate commands into your configuration file. See the Scripting Guide for complete details on macro commands.

**SetValue Commands**

SetValue Commands are macro commands used to specify the value of a given plot attribute. You may add SetValue commands to your `tecplot.cfg` file to override any of Tecplot 360’s default settings. For example, suppose you want your 2D axes to appear cyan. You can add this preference to your configuration file as follows:

1. Using the Tecplot 360 interface, create a 2D plot with cyan axes while either recording your steps as a macro, or saving the result as a Tecplot 360 layout.
2. Edit the resulting macro or layout, scanning for the lines that set the 2D axis colors. The following example shows the commands that specify the X- and Y-axis details in a layout of a 2D plot with cyan axes:

3. Discard everything but the lines that actually set the color:

4. Paste the resulting lines into your configuration file.

**Plot Default Setting - FIELDMAP and LINEMAP**

A single `$FIELDMAP` command can be included to set plot defaults. The zone cannot be specified in the configuration file, and the command is not effective for values set dynamically by Tecplot 360, such as Mesh Color. In the example below, the default contour type is Flood, scatter symbol shape is Delta, and scatter size is 1.8.

```
$FIELDMAP CONTOUR{CONTOURTYPE = FLOOD}
$FIELDMAP SCATTER{SYMBOLSHAPE{GEOMSHAPE = DEL}}
$FIELDMAP SCATTER{FRAMESIZE = 1.8}
```
In the same way as above, a single $\$\text{LINEMAP}$ command can be added for line mapping defaults. In the example below, XY and Polar Line mappings will have a dashed line pattern, and symbols will be filled circles.

```
$\$\text{LINEMAP LINES\{LINEPATTERN = DASHED\}}$
$\$\text{LINEMAP LAYERS\{SHOWSYMBOLS = YES\}}$
$\$\text{LINEMAP SYMBOLS\{SYMBOLSHAPE = GEOMSHAPE = CIRCLE\}}$
$\$\text{LINEMAP SYMBOLS\{FILLMODE = USELINECOLOR\}}$
```

**Override Automatic View>Fit Everything**

When loading a plot, Tecplot 360 automatically fits all 3D surfaces, data points, text, and geometries to the frame. To revert to the old Tecplot 360 behavior, remove the # from the following line in your `tecplot.cfg` file:

```
$\$\text{FrameSetup Initial3DScale = 0.7}$
```

**Interface Configuration**

The many members of the $\$\text{INTERFACE}$ macro help you configure Tecplot 360's user interface and graphics drawing capabilities. Although some of these commands can be executed in any Tecplot 360 macro, the best place to put these is in the Tecplot 360 configuration file: `tecplot.cfg`. Below are a few examples. Refer to the [Scripting Guide](#) for a complete listing.

**General Interface Configuration Options**

$\$\text{INTERFACE}$ followed by:

- $\$\text{MOUSEACTIONS \{MIDDLEBUTTON \{SIMPLEDRAG=ZOOMDATA\}\}}$ - Specify the action of the middle mouse button click and drag. Several other options for the middle and right mouse buttons are listed in the [Scripting Guide](#). These commands can only be executed in the Tecplot 360 configuration file.
- $\$\text{UNIXHELPBROWSERCMD = string}$ - Specify the browser for viewing the Help files (UNIX only). This command can only be executed from the Tecplot 360 configuration file.
- $\$\text{SHOWWAITDIALOGS = \{YES, NO\}}$ - Disable the launch and display of all Wait dialogs by setting this to NO. (Wait dialogs are launched during long operations and give you the ability to cancel the operation.) This is useful on some Linux systems where transient dialogs do not drop properly, leaving a gray box that obscures part of Tecplot 360's drawing area.
- $\$\text{USESTROKEFONTSFOR3DTEXT = \{YES, NO\}}$ - If set to YES, all 3D text drawn in the work area will be drawn using Tecplot 360's internal stroke fonts. For 3D text, this setting overrides the setting of $\$\text{USESTROKEFONTSONSCREEN}$. If set to NO, TrueType fonts will be used instead. This option has no effect on UNIX platforms.

**OpenGL-Specific Configuration Options**

Several options are available to further tune Tecplot 360 to operate with the OpenGL capabilities of your platform. To assign values to these parameters you must use the $\$\text{INTERFACE OPENGLCONFIG}$ command. A complete list of these options is given in the [Scripting Guide](#).

$\$\text{INTERFACE OPENGLCONFIG}$ followed by:

482
Configuration Files

- \{(ALLOWHWACCELERATION = (YES, NO)\} - In some cases, bugs in OpenGL drivers cause problems in Tecplot 360. In these situations, Tecplot 360 will typically behave better if this option is set to NO. However, Tecplot 360 will also be slower.
- \{(SCREENRENDERING \{DOEXTRADRAWFORLASTPIXEL = (YES, NO)\}\} - Some OpenGL implementations use an optimization for line drawing that omits the last pixel in the line. Set this to YES to change all line drawing to force the last pixel to be drawn. This setting applies only to drawing on the screen.
- \{(SCREENRENDERING \{STIPPLEALLLINES = (ALL, CRITICAL, NONE)\}\} - Set to ALL to make all lines drawn using stippling. Set to CRITICAL to use stippling for stroke and user-defined fonts. Set to NONE to disable stippling. This setting applies only to drawing on the screen.
- \{(SCREENRENDERING \{MAXMULTISAMPLES = <integer>\}\} - Specifies the number of multisamples to be used for antialiasing displayed images. The default is 4. A value of 0 may be used for faster rendering (with some roughness in the display). Higher values may be used at some cost in performance.
- \{(IMAGERENDERING \{DOEXTRADRAWFORLASTPIXEL = (YES, NO)\}\} - Some OpenGL implementations use an optimization for line drawing that omits the last pixel in the line. Set this to YES to change all line drawing to force the last pixel to be drawn. This setting applies only to exporting images from Tecplot 360.
- \{(IMAGERENDERING \{STIPPLEALLLINES = (ALL, CRITICAL, NONE)\}\} - Set to ALL to make all lines drawn using stippling. Set to CRITICAL to use stippling for stroke and user-defined fonts. Set to NONE to disable stippling. This setting applies to exporting images from Tecplot 360.
- \{(IMAGERENDERING \{MAXMULTISAMPLES = <integer>\}\} - Specifies the number of multisamples to be used for antialiasing exported images. The default is 0. A higher value, such as 4, may be used to smooth exported images at some cost in performance.

32 - 1.4 Default File Name Extensions

The default extensions for file names in file input/output dialogs can also be changed in the configuration file. These settings are changed via the FNAMEFILTER sub-command in the $!FILECONFIG macro command.

\$!FILECONFIG FNAMEFILTER followed by:

- \{COLORMAPFILE = <string>\} - Specifies the default extension for color map files.
- \{INPUTDATAFILE = <string>\} - Specifies the default extension for input data files.
- \{OUTPUTASCIIOUTPUTFILE = <string>\} - Specifies the default extension for ASCII output files.
- \{OUTPUTBINARYDATAFILE = <string>\} - Specifies the default extension for binary output files.
- \{INPUTLAYOUTFILE = <string>\} - Specifies the default extension for input layout and layout package files.
- \{OUTPUTLAYOUTFILE = <string>\} - Specifies the default extension for output layout files.
- \{OUTPUTLAYOUTPACKAGEFILE = <string>\} - Specifies the default extension for output layout package files.
- \{STYLEFILE = <string>\} - Specifies the default extension for stylesheet files.
- \{MACROFILE = <string>\} - Specifies the default extension for macro files.
- \{EQUATIONFILE = <string>\} - Specifies the default extension for equation files.

For example, to change the default extension for input data files to be .tbl use:

\$!FILECONFIG FNAMEFILTER \{INPUTDATAFILE = "*.tbl" \}
32 - 1.5 Default Temporary Directory
Tecplot 360 writes out a number of temporary files. To tell Tecplot 360 where to place these files, put the following macro command in the tecplot.cfg file:

```
$!FILECONFIG TEMPFILEPATH = "tempfilepath"
```

where tempfilepath is the new path. The default path is system dependent.

32 - 2 Interactive Customization
Using the Preferences submenu from the File menu, you can interactively control the colors used throughout Tecplot 360, the size options available in most Tecplot 360 dialogs, as well as several miscellaneous parameters.

32 - 2.1 Color Preferences Dialog
To change the RGB values of Tecplot 360’s basic colors, use the Color Preferences dialog (accessed via Preferences>Colors from Tecplot 360’s File menu).

To change a color, click on the color in the palette and alter its RGB values with the sliders. As you move the sliders, the box in the upper right corner of the dialog shows the color as it is currently specified. You may alter multiple colors by selecting those colors and changing their RGB values. Choosing [Reset Selected Color] or [Reset All Colors] will restore the default RGB values.

See also: Section 5 - 5 “Select Color.”
**32 - 2.2 Size Preferences Dialog**

To set size options, use the Size Preferences dialog (accessed via Preferences>Sizes from the File menu).

These options determine the choices available in text box columns such as Line Thickness that occur throughout the interface.

You can control the following sets of sizes:

- Line thickness.
- Symbol size.
- Pattern length.
- Arrowhead size.
- Tick mark length.
- Text height (in both points and frame units).
- Translate step size.
- Rotate step size.
- Magnification step size.
- Stroke font line thickness.

**32 - 2.3 Miscellaneous Preferences dialog**

Use the Miscellaneous Preferences dialog (accessed via File>Preferences>Miscellaneous) to customize the following settings.

- **Allow Old Text Formatting** - Beginning with version 10, Tecplot 360 uses HTML-like formatting tags. Selecting "allow old text formatting" will cause Tecplot 360 to process text first using the HTML-style formatting rules and second using the old character-by-character formatting rules.

- **Allow Data Sharing** - Selecting this option enables zones to share variables and connectivity. If a variable or connectivity list is shared, then only a single copy of it exists and is used by two or more zones. Refer to help on the Data Sharing Page page of the Data Set Info dialog for more information on data sharing.
32 - 3 Performance Dialog

Use the Rendering page of the Performance dialog (accessed via the Options menu) to adjust the Plot Approximation, Graphics Cache, and Image Export Options. Use the Miscellaneous page of the Performance dialog (accessed via the Options menu) to adjust Data I/O, Load On Demand, Variable Derivation, and Status Information.

32 - 3.1 Rendering

The Rendering page of the Performance dialog has the following options:

- **Use Auto Redraw** - When selected, Tecplot 360 will automatically redraw the plot whenever style or data changes. Some users prefer to turn this option off while setting multiple style settings and then manually pressing Tecplot 360’s [Redraw] or [Redraw All] button on the Sidebar to see a full plot.

  Auto-redraw can be interrupted with a mouse click or key press.

- **Subdivide all volume cells (to resolve saddle point issues)** - Select this toggle to eliminate holes in iso-surfaces near saddle points. If selected, all cells are subdivided for the purpose of contouring, slicing, and isosurface generation. This layout property applies to all frames and isosurface groups.

**Plot Approximation**

- **Approximate Plots for Better Speed** - An approximate plot may be used when manipulating the plot to improve interactive performance. This feature is most useful on older, slower hardware and defaults to off. Approximate plots may also be used for non-active frames. The degree of detail of the approximation is controlled by the following settings:
  - **Automatic** - When the number of data points is above the point threshold, Tecplot 360 will render the approximate plot for style, data, and interactive view changes, followed immediately by the full plot. This option provides for good interactive performance with the final plot always displayed in the full representation.
  - **Non-Active Frames Always Approximated** - When only one frame exists, this option is equivalent to automatic mode. If more than one frame exists, the active frame is set to automatic mode while the other frames are approximated.
Performance Dialog

- **All Frames Always Approximated** - When the number of data points is above the point threshold, Tecplot 360 will render the approximate plot in any frame. To see the full representation press the [Redraw] or [Redraw All] button on the Sidebar.

- **Point Threshold for Automatic Approximation** - This value controls when Tecplot 360 will consider using approximate plots. The value to use is highly dependent on the computer’s hardware capabilities.

- **Approximate Plot as % of Full Plot** - This value controls the percentage of geometric detail represented by the approximate plot. The larger the percentage the more closely the approximation represents the original plot. However, the interactive performance is reduced. This number should be adjusted until there is a balance between good interactive performance and sufficient detail. Typically, the percentage should be set to be less than or equal to 50. If values larger than 50% are needed to provide sufficient detail, consider not using approximate plots.

Graphics Cache

Tecplot 360 uses OpenGL to render plots. OpenGL provides the ability to cache graphic instructions for rendering and can re-render the cached graphics much faster. This is particularly true for interactive manipulation of a plot. However, this performance potential comes at the cost of using more memory. If the memory need is too high, the overall performance could be less.

Use one of the following Graphics Cache modes to optimize your computer’s performance:

- **Cache All Graphics** - When selected, Tecplot 360 assumes that there is enough memory to generate the graphics cache. If this is valid, Tecplot 360’s rendering performance will be optimal for interactive manipulation of plots.

- **Cache Only Lightweight Graphics Objects** - Lightweight objects include approximate plots and some other minor items, but do not include full plots. This is a good setting for memory constrained problems. Consider using this option in conjunction with the “Plot Approximation” mode set to “All Frames Always Approximated”.

- **Do Not Cache Graphics** - Consider using this option when memory is very limited. If you intend to interact with the plot, also consider setting the “Plot Approximation” mode set to “All Frames Always Approximated”.

In order to optimize animation, graphics caching is temporarily disabled during animations that include zones, line mappings, time, or blanking elements. Graphics caching is not altered during animations that include slices, streamtraces, or iso-surfaces.

High Quality Font Usage

Tecplot 360 supports high quality TrueType fonts. A few of these fonts are shipped with the product. Tecplot 360 can also use other TrueType fonts installed on your system. (See Section 18.1.2 “Font Folders and Fallback” for more information on how fonts work with Tecplot 360.)

Tecplot 360 has three high quality font modes:

- **When Possible** (Default setting for Windows) - Tecplot 360 uses available TrueType fonts for any size text. This produces the best rendering quality; however, performance is slower for large amounts of text.

- **For Large Characters Only** - Tecplot 360 uses the TrueType fonts for large characters only. Small characters will use Tecplot 360’s built-in stroke fonts. This is a good blend of quality and performance. However, small characters may not have the same appearance as large characters.
Never - Tecplot 360 never uses TrueType fonts.

**Image Export Options**

Some graphics card’s hardware does not support off-screen rendering (needed for exporting images). In addition, most graphic hardware is slower at producing images off-screen than on-screen.

To accommodate a variety of graphic hardware Tecplot 360 provides two image export modes:

- **Safe (Render Image Off-Screen)** - (Default) Tecplot 360 will render all exported images off-screen. This allows images to be created that are not bound by the physical size and state of the Tecplot 360 drawing area.
- **Fast (Use On-Screen Image)** - Tecplot 360 will grab the pixels from the physical Tecplot 360 drawing area. Any rendering damage, such as occluding windows or partially drawn images will become part of the exported image. In addition, the image size is bound by the physical size of the Tecplot 360 drawing area.

**Best Practices For Rendering Performance**

The factory settings in the Performance dialog are designed for moderately-sized data and occasionally may need to be adjusted to optimize Tecplot 360’s rendering performance. For example, if you are doing a lot of interactive work with your data, you may wish to turn on Plot Approximation to make these operations more responsive. If you do not have much spare memory, you may wish to turn off the Graphics Cache, or set it to “Cache only Lightweight Graphics Objects.”

The size of the data isn’t the only factor when rendering in Tecplot 360. If your plot includes slices or iso-surfaces, you may also need to adjust your plot approximation mode and graphics cache settings.

If you are using Plot Approximation, adjust the “Approximate Plot as% of Full Plot” value to give an acceptable balance between interactive performance and plot detail.

**32 - 3.2 Miscellaneous**

The Miscellaneous page of the Performance dialog has the following functions:
**Performance Dialog**

**Data I/O**

- **Use Memory Mapped I/O** - When toggled-on, Tecplot 360 will use system level memory mapping functions to map Tecplot 360 variables directly over block data in a binary data file or layout package file. The advantage of mapping variable data is that Tecplot 360 will only load the variable when it is first used. In addition, the mapped variable data can be shared between other Tecplot 360 sessions running on the same machine. Memory mapped I/O is most useful when there is a large number of data points to load from a file and they are not all being used by Tecplot 360 at the same time. Only variable data that is in a binary block format (the default for .plt files generated by Tecplot 360) can be memory mapped.

**Load On Demand**

With load-on-demand activated, Tecplot 360 generates plots faster and using less memory by only loading data that is needed for the plot. If changes to the plot style require additional variables to be loaded, Tecplot 360 will automatically load them, and if necessary, unload variables that are no longer used. Tecplot 360's ability to automatically load and unload variables on demand allows you to examine data that is much larger than the physical or virtual memory of your computer.

For large datasets, only the zones and variables currently in use will be loaded. However, for small datasets, some other zones and variables may be loaded for you (based on the Memory Threshold).

- **Unload Strategy** - Specifies how to manage unloading variables and other load-on-demand resources.
  - **Auto Unload** - This strategy attempts to keep Tecplot 360's memory use within the defined Min and Max Memory Thresholds. Tecplot 360 uses these values to determine when and how much it should unload. **This is the best option for exploring data as Tecplot 360 only unloads if and when the memory threshold has been exceeded.**
  - **Minimize Memory Use** - This strategy is used if more aggressive unloading of variables and other load-on-demand resources is required. **This option is best suited for animating through a very large number of time steps, where each time step consumes a significant part of the computer's available physical and virtual memory.**
  - **Never Unload** - This strategy disables the unloading capability of load-on-demand while still preserving the ability to load variables on demand.

Most users should select either the "Auto Unload" or "Minimize Memory Use" options.

- **Memory Threshold (%) [Auto Unload ONLY]** - When Tecplot 360 uses at least the maximum percentage of the available physical and virtual memory, it will attempt to unload variables and other load-on-demand resources until the available physical and virtual memory is at or below the specified minimum percentage.

**Variable Derivation**

When Tecplot 360 needs to create a nodal variable from a cell centered variable, it uses a prescribed derivation method. Tecplot 360 provides two such derivation methods: fast and accurate.

- **Fast (Linear)** - When selected, Tecplot 360 uses simple averaging to derive a nodal variable from a cell centered one.
- **Accurate (Laplacian)** - When selected, Tecplot 360 uses Laplacian interpolation to derive a nodal variable from a cell centered variable.
**Status Information**

Use the following controls in the Status Line region of the Performance dialog to customize what is displayed in the status line:

- **Show Status Line** - Turn this preference on/off to control the display of status messages.

  If you are remotely displaying Tecplot 360 on an X terminal, updating the status line can slow down processing. If this is the case, turn off the Show Status Line control.

- **Show Continuous State Messages** - Turn on this control to receive context-sensitive commentary in the status line.

- **Show Continuous Running Coordinates** - Turn on this control to display the coordinates of your mouse cursor in the status line.

- **Show Tool Tips** - Use this option to turn tool tips on or off.

### 32 - 4 Interface Configuration (UNIX)

On UNIX platforms, the style of the graphical user interface for Tecplot 360 is configured, for the most part, by a resource file called `Tecplot360`, which resides in the `app-defaults` sub-directory below the Tecplot 360 home directory. If you edit this file, the changes will affect all users. Alternatively, if you want the changes to apply only to your own execution of Tecplot 360, you can add entries to a file called `.Xdefaults`, which resides in your own `HOME` directory. If the file `.Xdefaults` does not already exist in your home directory, you can create one.

#### 32 - 4.1 Default Size of Tecplot 360

The resource lines that affect the default Tecplot 360 process window size are:

```plaintext
*Tecplot.main_dialog.width: 900
*Tecplot.main_dialog.height: 720
```

Changing either the value 900 or the value 720 will change the default size of the Tecplot 360 process window.

### 32 - 4.2 Look and Feel

Tecplot 360 now ships with two options: using the “old” look and feel, where the text is bold and larger or using the “new” look and feel, where the interface is closer to the style for Windows operating systems. In order to change from one option to the other, refer to the Tecplot 360 file as mentioned above.

### 32 - 5 Tecplot.phy

Whenever Tecplot 360 starts, it tries to load a `tecplot.phy` file. This file contains information that is useful for running macros in batch mode (see Chapter 29: “Batch Processing”). The file also contains the file names of the most recently used layouts in Tecplot 360, which populates the bottom of the File menu. Whenever Tecplot 360 exits, a new `tecplot.phy` file is written.

#### 32 - 5.1 Contents

The first uncommented line of the file contains the following numbers:

```plaintext
WIDTH  HEIGHT  ID0TSPECVD0TSPECVCONTOURCOLORS
```

- WIDTH and HEIGHT define the width and height of the Tecplot 360 workspace.
Custom Character and Symbol Definition

- IDOTSPERCM and JDOTSPERCM are the pixels per centimeter in the I and J directions. Their values are determined by your graphics card.
- CONTOURCOLORS defines the number of colors available to create a flooded contour plot.

32 - 5.2 File Location Configuration

The place Tecplot 360 looks for the tecplot.phy file is based on the following search:

1. Tecplot 360 checks the environment variable TECPHYFILE. If this variable is set, Tecplot 360 uses the value of this variable as the name of the tecplot.phy file. By default, this variable is not set. You can set this environment variable to control the location and name of the tecplot.phy file on a user-by-user basis.

2. (Windows Only) Tecplot 360 checks the Windows registry for the key HKEY_LOCAL_MACHINE\SOFTWARE\Tecplot, Inc\Tecplot 360 2013 R1. If the value PhyFile is set under this key, then it is used as the name of the tecplot.phy file. This value is set by the installation program. You can use the command regedit from the Start Menu’s Run option to edit the registry if you want to change or delete this key.

3. Tecplot 360 uses the file called tecplot.phy in the directory where Tecplot 360 is started. Note that this is the default behavior on UNIX platforms.

Thus, using the default installation, Windows versions of Tecplot 360 will write a tecplot.phy to one specific location (usually the Tecplot 360 home directory), and UNIX versions will always use a tecplot.phy file in the directory where Tecplot 360 is started.

On both Windows and UNIX platforms, the environment variable TECPHYFILE can be set to override this behavior.

32 - 6 Custom Character and Symbol Definition

When Tecplot 360 launches, it reads the font file (tecplot.fnt). This file contains information that defines the appearance of text characters on the screen. Tecplot 360 defines and draws characters on the screen as a set of straight lines called strokes. These stroked characters approximate the appearance of characters for the screen.

The font file is an ASCII file. You can modify the shape, size, and resolution of existing stroke font characters or add completely new ones. In PostScript print files, text characters are generated using PostScript defined fonts, not the stroked fonts. If you are using the Windows version of Tecplot 360 and the Windows print drivers are active, then all text except text using the User-Defined fonts is serviced by the Windows printer driver. However, the text characters in bitmap export files are in stroked fonts (since they are generated from the screen). The inter-character spacing in all output files is determined by the character-width definitions in the font file. When using PostScript print files or the Windows print drivers, changing the font commands affects only the character shape for User-Defined fonts and the character spacing for all fonts.
The Font File is structured as follows:

```
FF 4
CharCellHeight
Stroke command set for Helvetica Font
Stroke command set for Greek Font
Stroke command set for Math Font
Stroke command set for User-Defined Font
Stroke command set for Times Font
Stroke command set for Times Italic Font
Stroke command set for Courier Font
```

The file type and version are on the first line ("FF" refers to Font File). CharCellHeight is the interline spacing (the height of a capital M plus some vertical space) in the units of a two-dimensional coordinate system used to define the stroke-font characters. The baseline of the characters is at zero. Before Tecplot 360 uses the character definitions, they are normalized by the character cell height.

Following the character cell height, there are seven sets of stroke commands, one set for each font as shown above. Each stroke command set consists of definitions for the characters in the font. Each font has a base set of 96 characters (character indices 32 to 127). Some fonts also include an extended set of characters (character indices 160 to 255). The extended characters are needed to complete the character sets for most of the common European languages.

All seven stroke command sets must be present, and each must have at least one character defined. Each stroke command set begins with the definition for a space (character index 32). After that, characters within a stroke command set may be defined in any order. If a character is not defined in the Font File, it is drawn as a blank.

Each character in a stroke command set is defined as follows:

```
CharIndex NumCommands CharWidth
Command1
Command2
Command3
...
CommandNumCommands
```

CharIndex is the character index that ranges from 32 to 127 and 160 to 255 for each font (see Table 18 - 2 for the matching of the character index to the English, Greek, Math, and standard User-Defined font characters). NumCommands is the number of stroke commands defining the character that follows. CharWidth is the character width, which determines the spacing of the characters.

A command may be in one of the following forms:

- \texttt{m x y}.
- \texttt{d x y}.
- \texttt{mr dx dy}.
- \texttt{dr dx dy}.

Where:

- A command that begins with an \texttt{m} is a move command.
- A command that begins with a \texttt{d} is a draw command.
- \texttt{mr} and \texttt{dr} are relative move and relative draw commands.
- The \texttt{x} and \texttt{y} are the absolute coordinates within the character cell.
Custom Character and Symbol Definition

- The $dx$ and $dy$ are the relative coordinates with respect to the previous location (increments from the position attained by the previous command).
- All coordinates are specified as integers.

Figure 32-3 shows an example of a character cell and the commands used to define the lowercase letter "y". The height of the character cell is 48.

![Creating a Letter](image)

Figure 32-3. Defining a user-defined character.

Figure 32-4 shows a symbol being defined. Symbols should be centered about (0, 0) so that they are centered about the point they mark. The font file included with Tecplot 360 contains many User-Defined font stroke commands. Most of these are for creating extra plotting symbols, accessible when you use the Symbol Type “Other”, enter an ASCII character, and specify the User-Defined font.

![Creating a Symbol](image)

Figure 32-4. Defining a user-defined plotting symbol.
Add-ons

Add-ons are a way to extend the basic functionality of Tecplot 360. They are executable modules designed to perform specific tasks. Tecplot Inc. has produced a number of add-ons that load data in a variety of formats, allow advanced editing, or extend Tecplot 360's capabilities. By using the Tecplot 360 Add-on Developer's Kit (ADK), users can create their own add-ons to generate plots, transform or analyze data, or perform a broad range of specialized tasks.

Add-ons are external programs that attach themselves to Tecplot 360 and are accessed through the Tecplot 360 interface. When Tecplot 360 launches, it goes through various initialization phases, including the processing of the tecplot.cfg file, the loading of the Tecplot 360 stroke font file (tecplot.fnt), and the initialization of the graphics. After completing this, Tecplot 360 looks for add-ons.

33 - 1 Add-on Loading

You can load add-ons by several different methods: using the Drag-and-Drop Method, editing the Tecplot.add File, using the Command Line Specification for AddOns, or by Specifying a Secondary Add-On Load File.

If you are working with add-ons created with Tecplot 360, Tecplot Focus or Tecplot RS version 2006 R2 or earlier, and you wish to use these add-ons with Tecplot 360, Tecplot Focus or Tecplot RS version 2008 or later, you must recompile these add-ons. Add-ons must be recompiled in order to accommodate the transition of Ent_Index from 16 to 32-bit. If your add-on is not recompiled, it will likely crash when it is executed. In addition, InitTecAddOn has been deprecated and replaced with InitTecAddOn113.

C++ users - InitTecAddOn will automatically convert to InitTecAddOn113 upon recompiling.
Fortran users - You must manually change instances of InitTecAddOn to InitTecAddOn113 before recompiling.
If you are working on a Windows machine, we also strongly recommend that you update the add-on source code to link with libtec.lib (in lieu of tecplot.lib).
33 - 1.1 Drag-and-Drop Method
The easiest method for loading an add-on for a single use is the drag-and-drop method. This method works best when you only want to load the add-on for the current session of Tecplot 360 (rather than every subsequent launch of Tecplot 360 loading the add-on).

To use this method, find the libname of the add-on you wish to load in the bin subdirectory of your Tecplot 360 installation. Select the libname, and, while holding down the mouse, drag the libname into the Tecplot 360 window and release. If you executed this action successfully, a dialog will appear to notify you that the add-on loaded.

This action will load the add-on only for the rest of the current Tecplot 360 session. The next time you close and reopen Tecplot 360, you will need to reload the add-on.

33 - 1.2 Tecplot.add File
Every time that Tecplot 360 launches, it reads a file called tecplot.add from the Tecplot 360 home directory and loads all add-ons indicated in that tecplot.add file.

The tecplot.add file contains multiple $!LoadAddOn commands that load add-ons into Tecplot 360. This special macro file accepts only $!LoadAddOn macro commands, which require this syntax:

```
$!LoadAddOn "libname"
```

In this example, libname represents the name of an add-on's shared object library file. The libname must be enclosed in quotes.

To unload an add-on (that is, to prevent Tecplot 360 from loading that add-on when launching), comment out the appropriate line in tecplot.add by adding a pound ("#") symbol in front of the load command. For example, the pound ("#") symbol at the beginning of the following line will prevent the Auxiliary Data Editor add-on (libname "editauxdata") from loading:

```
# $!LoadAddOn "editauxdata"
```

To load an add-on that does not load automatically, remove the pound ("#") symbol from in front of the $!LoadAddOn command that includes the libname of the add-on you wish to load. If the tecplot.add file does not list the libname of the add-on you wish to load, add a $!LoadAddOn command followed by the libname of that add-on.

Libname
Special rules govern how the libname name is specified in the tecplot.add file. In all cases, the filename extension is omitted. If you assign libname to the basename of the shared object library, then Tecplot 360 will do the following:

- **UNIX** - The shared library to load will come from the file specified by: Tecplot-Home-Directory/lib/libbasename+platform-specific-extension, where platform-specific-extension is .sl for HP platforms and .so for all others.
- **Windows** - Tecplot 360 will search for the add-on basename.dll in the following directories (in this order):
  - The directory where the Tecplot 360 executable resides.
  - The Windows system directories.
  - The directories in your PATH environment variable.

On Windows machines using VC\ActiveX style add-on libraries, Tecplot 360 connects to the add-on via the libname entry in the registry.
Add-ons included in the Tecplot 360 distribution

If an absolute path name is used in `libname`, then on Windows platforms, `.dll` is appended and on UNIX platforms `.so` or `.sl` is appended.

**Add-Ons Loaded in Default Installation**

In a default installation of Tecplot 360, the `tecplot.add` file (located in the Tecplot 360 home directory) lists each add-on that Tecplot 360 will load automatically, in this manner:

```plaintext
#PK 1110
$!LoadAddOn "cfdtool"
$!LoadAddOn "streamtool"
```

The `tecplot.add` file also includes add-ons that will not load automatically. To load these optional add-ons, delete the pound (“#”) symbol.

### 33 - 1.3 Command Line Specification for Add-ons

You can also instruct Tecplot 360 to load a particular add-on by using the command line. The following flags are available:

```plaintext
-loadaddon libname
```

where:

- `libname` - The full name (including path and extension) of an add-on

You may specify the `-loadaddon` flag as many times as you want at the command line.

If your add-on is named with the proper suffix for your platform (.dll for Windows, .sl for HP UNIX platforms, and .so for all other UNIX platforms) you can simply name the add-on on the command line without using the `-loadaddon` flag.

After add-ons are loaded, Tecplot 360 re-processes all command line arguments not processed earlier (for graphics and add-on initialization). This ordering allows for a data reader add-on (discussed later) to be used to load data specified on the command line.

### 33 - 1.4 Specifying a Secondary Add-On Load File

You may also instruct Tecplot 360 to load a different list of add-ons by naming a second add-on load file using one of the following methods:

- Include `-addonfile` `addonfilename` on the command line.
- Set the environment variable `TECADONFILE`.

Both of these methods tell Tecplot 360 the name of another add-on load file to process.

### 33 - 2 Add-ons included in the Tecplot 360 distribution

The following add-ons load automatically when you launch Tecplot 360:

- Data file loaders or converters load automatically:
  - `plot3d` - A PLOT3D data loader
  - `loadxls` - An Excel file loader (Windows)
  - `loadss` - A spreadsheet file data loader
  - `loadxls` - An Excel worksheet file data loader
  - `loaddx` - A Data eXchange Format (DXF) data loader
  - `loadgen` - A general text file loader
• **loadhdf** - A Hierarchical Data Format (HDF) data loader
• **h5load** - An HDF5 data loader
• **loaddem** - A Digital Elevation Map (DEM) data loader
• **loadcgn** - A CFD General Notation System (CGNS) data loader
• **fluent** - A FLUENT data loader for .cas and .dat files, as well as compressed .cas.gz and .dat.gz files (versions 5 to 6.3)
• **loadensight** - An EnSight Gold data loader
• **loadflow3d** - A FLOW3D data loader
• **loadensight** - An EnSight data loader
• **loadply** - A PLY (polygon) data loader
• **loadkiva** - A KIVA data loader
• **loadfena** - A FEA (Finite Element Analysis) data loader

These show up under the “Load Data File(s)” option of the File menu. The primary difference between loaders and converters are that loaders have more complex options than converters. See Chapter 4: “Data Loaders” for information on working with each data loader.

• Extended curve fits for XY Line plots (accessed by selecting “Extended” from the Curve Type menu, on the Curves page of the Mapping Style dialog).
  • **crvakima** - A curve fit using the Akima method
  • **crvstineinterp** - A curve fit using Stineman interpolation.
  • **crvgen** - A curve fit in which users define the equation.

See Section 21 - 11 “Data Interpolation” for information on working with each of these add-ons.

Your Tecplot 360 installation includes the additional add-ons listed following (alphabetically) and described in Section 33 - 3 “Working with Tecplot 360 Add-ons”. Some of these load automatically with your installation; others require you to load the add-on by uncommenting the appropriate line from your tecplot.add file (located in your Tecplot 360 home directory), or by any of the other methods described in Section 33 - 1 “Add-on Loading”:

• Advanced Quick Edit
• Auxiliary Data Editor
• Circle Stream
• CFD Analyzer (see Chapter 22: “CFD Data Analysis”)
• Code Generator
• Compare XY Maps
• Create Multiple Frames
• Create Finite Element Sub-Zone
• Distribution Plots
• Export DXF
• Extend Macro
• Extend Time Macro
• Extract Over Time
• Extrude
• Key Frame Animator
• Multi-Frame 3D
• Prism Grid
Working with Tecplot 360 Add-ons

- Solution Time and Strand Editor
- Sort
- Statistics Calculator
- Tecplot GUI Builder
- Tensor Eigensystem
- Tetra Grid
- Time Series
- View Binary
- Write Data as Formatted Text

33 - 3 Working with Tecplot 360 Add-ons

The default Tecplot 360 installation includes the add-ons discussed in this section. To load or unload them, use the methods described in Section 33 - 1 “Add-on Loading”.

33 - 3.1 Advanced Quick Edit

The Advanced Quick Edit add-on, with the libname “advqet”, loads automatically, and causes the “Advanced Quick Edit Tool” to appear in the Tools menu. This add-on allows you to make rapid changes to text and geometries selected in the active frame. It also allows additional editing operations that the standard Quick Edit dialog (accessible from the Sidebar) does not support.

To unload this add-on, comment out the line in your Tecplot.add File (located in your home directory) that loads the advqet library by adding a “#” symbol at the beginning of the line with the text $!LoadAddon “advqet”.

To use this add-on, select “Advanced Quick Edit Tool” in the Tools menu to open the Advanced Quick Edit Tool dialog.

Controls in the Advanced Quick Edit Tool dialog are active only when you have one or more text and/or geometries selected. Some controls are specific to either text or geometries, while others apply to both. If the selected objects are a mix of text and geometries, the controls that apply only to geometries will affect the specific geometries you have selected. Similarly, controls that apply specifically to text will only affect text, even if the selected objects are a mix of text and geometries.
The Advanced Quick Edit Tool dialog includes the following options:

- **Geometry Coordinate System** - Change selected geometries to the Frame or Grid coordinate system by selecting the appropriate button in the Coord Sys/Char Height region of the dialog. Changing the coordinate system in this dialog will modify each geometry's anchor position and size so that it appears visually unchanged in your plot.

- **Text Coordinate System and Character Height Units** - Change the position coordinate system and character height units of all selected text by selecting the appropriate button in the Coord Sys/Char Height region of the dialog. There are four valid combinations: [Frame/Frame], [Frame/Point], [Grid/Grid], and [Grid/Frame]. Changing a coordinate system in this dialog will modify each text object's anchor position and character height so that it appears visually unchanged in your plot.

- **Text Box Margin** - Change the text box margin of all selected text with the [Text Box Margin] button.

- **Text Line Spacing** - Change the line spacing of all selected text by using the [Text Line Spacing] button.

- **Text Anchor Location** - Change the text anchor location for all selected text by selecting one of the nine possible anchor points from the button grid located in the Text Anchor Location region of the dialog.

- **Text and Geometry Scope** - Change the scope of all selected text and geometries by selecting either [Local] or [Global] scope. Objects with local scope appear only in the frame in which they were originally created. If the objects are defined as having global scope they will appear in all "like" frames, that is, those frames using the same data set as the one in which the objects were originally created.

- **Text and Geometry Zone or Map Attachment** - Change the zone or map with which the selected text or geometries are associated by selecting Zone Attachment [Select]. This calls up the Attachment Selection dialog. The Attachment Selection dialog lists zone names or numbers when Tecplot 360 is in the 2D or 3D Cartesian or Sketch plot types, and mappings when Tecplot 360 is in the XY Line plot type. The "<Unattach Object>" entry dissociates each selected text or geometry from its zone or map.

### 33 - 3.2 Auxiliary Data Editor

The Auxiliary Data Editor add-on loads automatically with Tecplot 360. This add-on enables you to edit auxiliary data within Tecplot 360 and journal the results into the saved layout file. To unload the add-on, comment out the line including the `libname editauxdata` in your Tecplot.add file.

Auxiliary data are name-value pairs associated with a data set, frame, line map, page, variable, or zone, which Tecplot 360 stores as text strings. You can view all auxiliary data included in your layout in the Data Set Information dialog (by going to Data>Data Set Info).

To use this add-on, select "Auxiliary Data" from the Data menu to open the Edit Auxiliary Data dialog.
The Edit Auxiliary Data dialog contains the following controls:

- **Show auxiliary data** - In the drop-down menu at the top of the dialog, select the level at which you wish to view, add or delete auxiliary data. Choose from Zones, Variables, Line Maps, Active Frame, Active Page, Data Set, or Everything.

- **Auxiliary data box** - In the box in the middle of the dialog, all auxiliary data for the selected level will display. You can select any item in this box to edit it or delete it, with the [Edit] button or [Delete] button, respectively.

- **Add auxiliary data** - With the [Add] button, you can add auxiliary data at any of the available locations (zone, variable, etc.).

- **Edit auxiliary data** - With the [Edit] button, you can edit any existing auxiliary data. First, select the item you wish to edit in the Auxiliary data box, and then select the [Edit] button.

- **Delete auxiliary data** - Use the [Delete] button to delete any existing auxiliary data. Select the item you wish to delete in the Auxiliary data box, and then select the [Delete] button.

You can view auxiliary data on the Aux Data page of the Data Set Information dialog (accessible by going to Data>Data Set Info).

Tecplot 360 will journal all added or edited auxiliary data to layout and packaged layout files when you save your layout or packaged layout file after editing the auxiliary data.

**Macro Commands**

You can add auxiliary data using the $!EXTENDEDCOMMAND macro, with the following syntax:

```
$!EXTENDEDCOMMAND
COMMANDPROCESSORID = 'Aux Data Editor'
COMMAND = '<operator> Name = <string> Value = <string> Location = <location>
LocationIndex = 1'
```

With this syntax, the following rules apply:

- **Operator** - Use "Add" or "Delete" as the operator
- **Name** - Use an alphabetic character followed by zero or additional alphanumeric characters and underscores (no spaces)
- **Value** - Use a value only for the Add operator, to associate a value to the named data piece. Surround the value with quotation marks if it has spaces
- **Location** - Use Zone, Var, Frame, Page, DataSet or LineMap as the location
- **LocationIndex** - This value indicates which Zone, Var, Frame, or LineMap to which Tecplot 360 attaches the auxiliary data. If adding auxiliary data to a Page or Dataset, do not indicate a LocationIndex.
Following is an example of a macro command adding an auxiliary data piece named “TestID” with the value of “Sequence 23, test 2” to the first zone.

```
COMMANDPROCESSORID = 'Aux Data Editor'
COMMAND = 'Add Name = TestID Value = "Sequence 23, test 2" Location = Zone LocationIndex = 1'
```

**Adding Auxiliary Data**

The Add Auxiliary Data dialog enables you to add auxiliary data at any of several levels. To reach this dialog, select the [Add] button in the Edit Auxiliary Data dialog. Data added in the Add Auxiliary Data dialog will subsequently appear in the Edit Auxiliary Data dialog, in the Auxiliary Data display box. The Add Auxiliary Data dialog has the following controls:

- **Location** - Choose the level at which to add the data from the Location drop-down menu. You can choose to add it at the zone, variable, line map, active frame, active page, or dataset level.
- **Number** - When the Location indicates “Zone”, “Variable”, or “Line Map”, the Number box will activate for you to specify the Zone Number, Variable Number, or Line Map number at which to add the auxiliary data.
- **Name** - Enter the name of your data in the Name box.
- **Value** - Enter the value of your data in the Value box.

Select the [OK] button in the Add Auxiliary Data dialog to finish adding a piece of auxiliary data to the selected location.

**33 - 3.3 Circle Stream**

The Circle Stream add-on, which does not load automatically, enables the ability to place a “rake” of streamtraces starting from a selected circle geometry (in 2D Cartesian mode only). To load this add-on, use "cstream" as the libname, and follow one of the methods discussed in Section 33 - 1 “Add-on Loading”.

Loading this add-on will cause “Circle Stream” to appear in the Tools menu. To place a rake of streamtraces in a circular pattern, first create one or more circle geometries and place them in your frame where you want the streamtraces to start. Then, select the circle geometries you want streamtraces to emanate from and select “Circle Stream” from the Tools menu. Select the direction for the streamtraces to travel in the Circle Stream dialog, and select the [Add Streamtraces] button to add the streamtraces in the selected direction.

To set the number of streamtraces that are placed around the circle, edit the Number of Sides box in the Geometry dialog (double-click on the circle to call up the Geometry dialog).

See also: Chapter 15: “Streamtraces”.

**33 - 3.4 Code Generator**

Tecplot 360 offers an enormous array of style settings. If you are writing a Tecplot 360 add-on or creating an application to working with the Tecplot SDK, use the Code Generator add-on to determine the hierarchy of the Style Value you need. The add-on displays the Set Value and/or Get Value code corresponding to the style changes you have made in the Tecplot 360 user interface. The output can be
Working with Tecplot 360 Add-ons

either displayed using the Style Value class of the Tecplot Toolbox or Tecplot 360’s classic code (also referred to as the “TecUtil layer”).

To launch the add-on, add $!LoadAddon "codegenerator" to your tecplot.add file and relaunch Tecplot 360. Refer to Section 33 - 1 “Add-on Loading” for additional details. After this step, you can select “Code Generator” from the Tools menu.

Once you have launched the add-on, the style value code corresponding to any style changes you make will be displayed in the dialog.

The dialog has the following options:

- **Create Set Value Code** - Toggle-on “Create Set Value Code” to display the syntax for setting the style value corresponding to any style changes you have made through the user interface. The dialog will only display changes made after the dialog was launched (and, if applicable, after the Set Value Code was selected).
- **Create Get Value Code** - Toggle-on “Create Get Value Code” to display the syntax for obtaining the style value corresponding to any style changes you have made through the user interface. The dialog will only display changes made after the dialog was launched (and, if applicable, after the Get Value Code was selected).
- **Toolbox Code** - Select the “Toolbox Code” radio button to display code using the Tecplot Toolbox’s StyleValue class. We recommend working with the Toolbox code in lieu of the Classic Code. The StyleValue class is simpler to use and also requires a fraction of the code.
- **Classic Code** - Select the “Classic Code” radio button to display the code using Tecplot’s classic TecUtil layer. The TecUtil functions are all in C, and many are available in Fortran.
- **Python Code** - Select the “Python Code” radio button to display code using Tecplot’s Python capabilities. Python code is only available for set value code because of a limitation in Tecplot’s Python layer. For more information on Tecplot’s Python layer, please see the Tecplot 360 Scripting Guide.

If you receive output that includes “Undetermined Data Type”, you can harness the Tecplot 360 Macro language to determine the data type using the following steps:

- Select “Record a Macro” from the Scripting menu, and specify a macro file name (refer to Section 28 - 1 “Macro Creation” for background information).
- Reproduce the steps that resulted in the “Undetermined Data Type” output in the Code Generator, and stop recording the macro.
• Open the macro file you just created using either a text editor or the macro viewer. You will see output similar to that in the Code Generator (refer to Section 28.3 “Macro Debugging” for background information).
• Determine the culprit macro command (starting with “$!”) and look up the command syntax in the Tecplot 360 Scripting Guide. The command syntax table will yield the missing data type.

Refer to the ADK Reference Manual for the syntax for the Tecplot Toolbox StyleValue class, as well as Classic Code.

33 - 3.5 Compare XY Maps

The Compare XY Maps add-on allows the user to quickly generate new XY plots showing comparison and statistical data without requiring the use of Data Alter equations or complex macros. Choose “Compare XY Maps” from the Data menu to begin using this add-on.

You must have at least one frame in XY Line mode containing a minimum of two active line maps. Using the data in those line maps, the add-on will compute and display additional maps for:

• Delta values between maps
• Variance
• Standard Deviation
• Average
• Sum
• Minimum
• Maximum

You can calculate one or more of these results by highlighting them in the list. You can also add new comparison maps to frames where you earlier solved other comparison maps (existing comparison maps will not be included in the computations for subsequent comparison maps). If multiple frames exist in the workspace, you can choose whether to calculate the selected results for all frames or just the active frame.

The original line maps must follow one of two patterns:

• Single zone. Line maps share the same zone, with each map using the same variable on the X-axis and a different variable on the Y-axis. The Y-axis variables should generally have the same units. The Fuel Prices and Rainfall example data sets match this pattern.

• Single variable. Each line map references a different zone and has matching variables on both the X- and Y-axis. The Field_plot_labeled example matches this pattern.

Inactive line maps are ignored. This fact can be used to temporarily remove them from the computations. They can be turned back on once the comparison has been computed.

When determining whether the above criteria are met, the add-on starts with the first active line map, which is considered the master. The remaining maps are then inspected to locate any that match the master using either the single zone or single variable pattern. Only matching maps are used for computations.
The master map also determines how delta values are computed. For example, if you have three line maps comparing rainfall in Seattle, Dallas, and Miami, and the Seattle map is the first map, all delta computations will be relative to Seattle.

If you would prefer to compute deltas between Miami and the other two maps, move the Miami map to the top in the Mapping Style dialog. If you first create deltas with Seattle and then with Miami, you can show both sets of deltas.

New variables, zones, and maps are created to hold and display the comparison results. Variable names will reflect the comparison type. Delta results will also identify the maps being compared. In the case of the single zone pattern, the new variable name will use the variable for each map (e.g. Miami – Seattle in the rainfall example). In the case of the single variable pattern, the new variable will use the map names. New zones are made for each unique combination of a frame and a master map.

When creating the new maps, the program copies some styles from the master map, including line visibility, thickness and pattern length, symbol show, size, fill mode, and skipping, and bar chart visibility, size, thickness, and fill mode. Colors, patterns, and symbols use the Tecplot defaults so that the lines are more easily differentiated. Once the comparison maps have been created, you can change the styles as needed.
When performing comparisons with multi-zone maps where lines do not fully overlap, the master map is used to determine the range and spacing of the calculated data points. Locations where a line is missing are ignored; values are not extrapolated, nor are zero values used for missing data. In other words, if you are computing average values for four maps and the third map covers only half of the length of the others, the comparison map reflects the average of only three maps in the range where only three have data, and the average of all four where all four have data.

33 - 3.6 Create Multiple Frames

Use the Create Multiple Frames add-on to make a set of new frames with uniform size and spacing within the active frame. This add-on does not load automatically; load this add-on using “mulframe” as the libname in one of the methods discussed in Section 33 - 1 “Add-on Loading”.

To use this add-on, select “Create Multiple Frames” in the Tools menu. This will open the Create Multiple Frames dialog.

The Create Multiple Frames dialog has the following options:

- **Frames Across** - Enter the number of frames to be displayed in each row of frames.
- **Frames Down** - Enter the number of rows of frames.
- **Space Between Frames** - Enter the amount of space to display between each frame in each direction, in paper ruler units.

Select the [Create] button to create the multiple frames as specified. See Section 2 - 3.2 “Frame Creation” for information on creating a single frame.

33 - 3.7 Create Finite Element Sub-Zone

The Create SubFEZone add-on enables creation of a finite element zone containing all elements that are completely visible in the active frame. To load this add-on, use “crsfez” as the libname in one of the methods discussed in Section 33 - 1 “Add-on Loading”.

After loading this add-on and re-launching Tecplot 360, load your layout and then select “Create SubFEZone” from Tecplot 360’s Tools menu. You can use this add-on only for 2D Cartesian plot types, and all elements must be of the same type: either triangular or quadrilateral.
The Distribution Plots add-on produces two plots that show the distribution of data values in a 2D or 3D plot: histograms and cross plots. The add-on is available by choosing “Distribution Plots” from the Tools menu. A single dialog appears, with a page for each type of plot. You can enable or disable each plot using the “Show” toggle at the top of the dialog. One or both types of plots can be created in a single use of the add-on.

A new frame is created for each plot. The histogram is initially positioned in the top right corner of the original frame, and the cross plot is positioned in the lower right corner. The frames may be rearranged and resized after they are created and may also be deleted when they are no longer needed.

Alterations made to the master frame, such as changing the time step or choosing a different contour variable, are immediately reflected in the distribution plots. Changes you make to selections within the Distribution Plots dialog are not normally applied until you click Update Plot. However, you can toggle-on Auto-Update to have your dialog selections applied immediately whenever options are changed.

Items in the Select box are common to both plots. All zones are selected by default. (For transient data, most individual zones are not shown. Instead, the list displays the unique time strands plus static zones.) The Values options allow you to use blanking to limit the values shown in the distribution plots. If you are not using blanking, select All instead of Unblanked for best performance.
**Histogram**
Values for histograms are extracted according to their native value location: nodes or cell centers.

Three simple controls determine the appearance of the histogram. The “Contour Group” option controls both the selection of the variable and the binning levels for the histogram through the selected Contour Group of the master frame (not of the histogram frame). To change the binning options in the histogram, activate the master frame and adjust the group and contour levels. You may use a contour group that is not being used in the master frame.

The “Statistics” option (None, Basic, and Complete) controls the display of statistical analyses of the data. Basic includes minimum, maximum, mean, and standard deviation. Complete expands this to include the 1st, 2nd (Median), and 3rd quartiles. Because two passes through the data are needed for the quartiles, it may take a bit longer to display a histogram with Complete data.

You may also turn the histogram legend on and off.

**Cross Plot**
The cross plot allows you to see the relative distribution of two, three, or four variables in your data set. The values are represented by the plot axes (two or three) plus the symbol color.

In the first sample plot, we see U and Velocity Magnitude on each axis, and color is used to display the pressure value.
In the 3D example, the Z-axis adds variable V.

As with the histogram plots, the contour group from the master frame is used to select the variable and levels for the symbol color. You may also select a fixed color. Unlike histograms, you must select the value location from which to extract the values shown, either nodal or cell-centered.

Macro Processing

The Distribution Plots add-on can be invoked from the macro language by using the following commands. First you use the SELECTDATA command to indicate which data is to be used, then use CREATEHISTOGRAM and/or CREATECROSSPLOT to specify the appearance of the plots. The example plots shown in this section were created using these following macro.

There is no specific command for the Show toggles or the Update Plot button. Inclusion of the CREATEHISTOGRAM command will both activate and update the plot, and the same is true for CREATECROSSPLOT. The frames containing the distribution plots can be managed using the usual frame management macro commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Parameter</th>
<th>Options</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>SELECTDATA</td>
<td>ZONES</td>
<td>Zone or strand numbers, enclosed in square brackets and separated by commas.</td>
<td>All zones</td>
</tr>
<tr>
<td></td>
<td>INCLUDE</td>
<td>ALL, BLANKED, UNBLANKED</td>
<td>ALL</td>
</tr>
</tbody>
</table>
The DXF Export add-on enables export of data in DXF (drawing interchange) format. To load this add-on, use “exdxf” as the libname in one of the methods discussed in Section 33 - 1 “Add-on Loading”.

After loading the add-on, select “Export DXF” from the Tools menu to open the Export DXF File dialog. Use this dialog to choose which zones to export and where to output the export file, and to export the selected zones.

The DXF export created depends on the data structure (FE or ordered), the data structure type (for example, I-ordered), and the plot type. Table 33 - 1 displays the conditions required to create each entity type.

<table>
<thead>
<tr>
<th>Data Structure</th>
<th>Data Structure Type</th>
<th>Plot Type</th>
<th>Entity Created</th>
</tr>
</thead>
<tbody>
<tr>
<td>FE</td>
<td>triangle or quadrilateral</td>
<td>3D</td>
<td>DXF 3DFACE</td>
</tr>
<tr>
<td>FE</td>
<td>triangle or quadrilateral</td>
<td>2D, XY, Polar</td>
<td>DXF POLYLINE</td>
</tr>
</tbody>
</table>

Table 33 - 1: Entities created for DXF export.
Working with Tecplot 360 Add-ons

See also: Section 4 - 3.1 "Load DXF File Dialog".

33 - 3.10  Extend Macro

The Extend Macro add-on extends Tecplot 360's macro language to include additional commands. You may use the Extend Macro add-on by adding the following function call to your macro file:

```$!EXTENDECOMMAND COMMANDPROCESSORID='extendmcr' COMMAND='command option'```

where `command option` is any of the commands listed in the following table:

<table>
<thead>
<tr>
<th>Command</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>QUERY.ZONENAMEBYNUM nnn VVV</td>
<td>Get the string for zone nnn and assign to variable VVV.</td>
</tr>
<tr>
<td>QUERY.VARNAMENBBYNUM nnn VVV</td>
<td>Get the string for variable nnn and assign to variable VVV.</td>
</tr>
<tr>
<td>QUERY.ZONENUMBYNAME &quot;zonename&quot; VVV</td>
<td>Get the number of zone named zonename and assign to variable VVV.</td>
</tr>
<tr>
<td>QUERY.VARNUMBYASSIGNMENT assignment VVV</td>
<td>Get the number of variable by assignment and assign to variable VVV. VVV may have any of the following values:</td>
</tr>
<tr>
<td></td>
<td>• X, Y or Z - Variable assigned to the X, Y or Z-axis.</td>
</tr>
<tr>
<td></td>
<td>• U, V or W - Variable assigned to be the U, V or W-vector component.</td>
</tr>
<tr>
<td></td>
<td>• C - Variable assigned to contours.</td>
</tr>
<tr>
<td></td>
<td>• S - Variable assigned to scatter sizing.</td>
</tr>
<tr>
<td></td>
<td>• B - Variable assigned to the first constraint for value-blanking.</td>
</tr>
<tr>
<td>QUERY.DATASETITLE VVV</td>
<td>Get the string for the dataset title and assign to variable VVV.</td>
</tr>
<tr>
<td>STRING.LENGTH StrSource VVV</td>
<td>Get the length of string StrSource and assign to variable VVV.</td>
</tr>
<tr>
<td>STRING.FINDPATTERN StrSource StrPattern VVV</td>
<td>Get the sub-string from StrSource starting at pattern StrPattern and going to the end of StrSource. Returns &quot;NOTFOUND&quot; if not found.</td>
</tr>
<tr>
<td>STRING.SUBSTRING StrSource start end VVV</td>
<td>Get the sub-string from StrSource starting at position start and ending at position end. Put the result in VVV.</td>
</tr>
</tbody>
</table>

Table 33 - 1: Entities created for DXF export.

See also: Section 4 - 3.1 "Load DXF File Dialog".

Table 33 - 2: Command Options for Extend Macro
If you have declared macro variables and would like to use them with the Extend Macro add-on, you can do so by surrounding the command call with single quotes and the macro variable with double-quotes. For example:

\[
\text{QUERY.ACTIVEZONES VVV} \quad \text{Get the set of active zones and put the result in VVV. Note: The set string does not include any blank spaces. If zones 2, 4, 6, 7 and 8 are active, VVV would have the string "2, 4, 6-8."}
\]

\[
\text{QUERY.MAPNAMEBYNUM nnn VVV} \quad \text{Returns a string (the name of the map) and places it in variable VVV. The active plot must be XY-Line or Polar-Line.}
\]

\[
\text{QUERY.ISADDONLOADED COMMANDPROCESSORID VVV} \quad \text{Return "YES" if Add-on COMMANDPROCESSORID is loaded, otherwise return "NO"}
\]

\[
\text{QUERY.FILEEXISTS "filename" VVV} \quad \text{If the file exists, VVV will be "YES" otherwise VVV will be "NO"}
\]

\[
\text{QUERY.ISZONEACTIVE ZZZ VVV} \quad \text{Test to see if zone ZZZ is active. If so, VVV is set to "YES," otherwise it is set to "NO."}
\]

Refer to Scripting Guide for additional information on working with Tecplot 360's macro language.

### QUERY.DATASETTITLE

The following example, uses the QUERY.DATASETTITLE command to place the title of the dataset at a specific position on the plot.

\[
\text{

$!VARSET |[COMMAND]| = "Unknown"
$!EXTENDEDCOMMAND
COMMANDPROCESSORID = "extendmcr"
COMMAND='query.datasettitle |[ZNUM]|'
$!RemoveVar |[ZoneName]|
$!VARSET |[VNAME]| = "X"
$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'extendmcr'
COMMAND='QUERY.VARNAMEBYNUM 2 |[VNAME]|'

$!ATTACHTEXT
XYPOS
{X = 5
 Y = 90}
TEXT = "Title is: |[ZNUM]|"

$!VARSET |[VNAME]| = "A"
$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'extendmcr'
COMMAND='QUERY.VARNAMEBYNUM 1 |[VNAME]|'

Table 33 - 2: Command Options for Extend Macro}

If you have declared macro variables and would like to use them with the Extend Macro add-on, you can do so by surrounding the command call with single quotes and the macro variable with double-quotes. For example:

\[
\text{QUERY.ACTIVEZONES VVV} \quad \text{Get the set of active zones and put the result in VVV. Note: The set string does not include any blank spaces. If zones 2, 4, 6, 7 and 8 are active, VVV would have the string "2, 4, 6-8."}
\]

\[
\text{QUERY.MAPNAMEBYNUM nnn VVV} \quad \text{Returns a string (the name of the map) and places it in variable VVV. The active plot must be XY-Line or Polar-Line.}
\]

\[
\text{QUERY.ISADDONLOADED COMMANDPROCESSORID VVV} \quad \text{Return "YES" if Add-on COMMANDPROCESSORID is loaded, otherwise return "NO"}
\]

\[
\text{QUERY.FILEEXISTS "filename" VVV} \quad \text{If the file exists, VVV will be "YES" otherwise VVV will be "NO"}
\]

\[
\text{QUERY.ISZONEACTIVE ZZZ VVV} \quad \text{Test to see if zone ZZZ is active. If so, VVV is set to "YES," otherwise it is set to "NO."}
\]
Working with Tecplot 360 Add-ons

$$!ATTACHTEXT$$

XYPOS

{X = 5
Y = 85}

TEXT = "Var 2 is: |VNAME|"

$$!VARSET |ZNAME| = 'HELLO'

$$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'extendmcr'
COMMAND = 'QUERY.ZONENAMEBYNUM 1 ZNAME'

$$!ATTACHTEXT$$

XYPOS

{X = 5
Y = 80}

TEXT = "Zone is: |ZNAME|"

$$!VARSET |ZNUMS| = 'blank'

$$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'extendmcr'
COMMAND = 'QUERY.ACTIVEZONES ZNUMS'

$$!ATTACHTEXT$$

XYPOS

{X = 5
Y = 70}

TEXT = "Active zones are: |ZNUMS|"

33 - 3.11 Extend Time Macro

The Extend Time Macro add-on simplifies the macro interface by allowing you to use a simple loop to query the number of solution times in the dataset and advance the time step. This differs from Tecplot 360's native macro language as it does not require that you know the solution time of your data.

This add-on uses a different algorithm than Tecplot 360 for sorting the solution times. Because Tecplot 360 combines time steps that are sufficiently close together, the number of time steps reported by this add-on may differ from the number of time steps reported by Tecplot 360.

You can load this add-on by adding the following line to your Tecplot.add File:

$$!LoadAddOn "Extend Time Mcr"$$

Macro Processing

The Extend Time Macro add-on can be invoked from the macro language by using the following commands:
These two lines retrieve the number of time steps. This number is represented here as the macro variable VVV.

This line sets the solution time at time step nnn. The acceptable value range number for nnn is: 1 - NumTimeSteps.

This line retrieves the solution time at time step nnn. This number is represented here as the macro variable VVV.

The following is a sample loop that uses the Extend Time Macro add-on:


33 - 3.12 Extract Over Time

The Extract Over Time add-on, which loads automatically with Tecplot 360, extracts slices, iso-surfaces, streamtraces, and points from polyline geometries in transient data. The resulting zones are assembled into a new strand with proper solution times set for each zone.

To save a layout file, you must also save a data file when using this add-on.

To unload this add-on, add a “#” symbol in front of the following line in your Tecplot.add File.

To use this add-on, go to Data>Extract and selecting one of the following menu options.

- Extract Slices Over Time - The frame must be in 3D, contain one or more slices, and contain transient data.
- Extract Iso-Surfaces Over Time - The frame must be in 3D, contain one or more iso-surfaces, and contain transient data.
- Extract Streamtraces Over Time - The frame must be in 2D or 3D, contain one or more streamtraces, and contain transient data.
• **Extract Geometries Over Time** - The frame must be in 2D or 3D, have exactly one polyline geometry selected, and contain transient data. When the menu option is selected, you will be prompted for the number of points along the polyline to extract.

After extracting, the new strand is available and may be animated or saved to a file.

**Macro Processing**

The Extract Over Time add-on can be invoked from the macro language by using the following commands:

<table>
<thead>
<tr>
<th>Slices</th>
<th>$EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time' COMMAND='ExtractSliceOverTime'</th>
</tr>
</thead>
<tbody>
<tr>
<td>Iso-Surfaces</td>
<td>$EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time' COMMAND='ExtractIsoSurfaceOverTime'</td>
</tr>
<tr>
<td>Streamtraces</td>
<td>$EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time' COMMAND='ExtractStreamOverTime'</td>
</tr>
</tbody>
</table>
| Geometries | $EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time' COMMAND='ExtractGeomOverTime' 
  Optionally, you may specify the number of points to extract by using the following format: 
  $EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time' COMMAND='ExtractGeomOverTime:nnn'
  Where nnn >= 2. If this condition is not met when the macro is played back, the action will silently fail and your macro will continue processing. |


**33 - 3.13 Extrude**

The Extrude add-on creates a 3D volume or surface zone by duplicating the source zone and translating it in the Z-direction until the specified number of K-cells are created. If the source zone is a surface, a volume zone will be created. If the source zone is a line, a surface zone will be created.

The Extrude add-on does not load automatically. You can load this add-on using “extrud” as the libname in one of the methods discussed in Section 33 - 1 “Add-on Loading”.

After loading this add-on, use it by selecting “Extrude” from the Tools menu. This will open the Extrude Options dialog.
The Extrude Options dialog includes the following options:

- **Source Zone** - In the Source Zone region of the dialog, select the surface or line zone defining the initial surface or edge.
- **Z-Variable** - In the Z-Variable region of the dialog, select the variable to increment to create the volume or surface zone.
- **Number of K-Cells** - In the Number of K-Cells box, enter the number of K-cells to be added.
- **Extrusion Distance** - In the Extrusion Distance box, enter the total distance, in the Z-direction, to extrude the initial zone. The distance between planes in the Z-direction is (Extrusion Distance)/(Number of K Cells).

**Macro Processing**

To invoke the Extrude add-on from the macro language, use the following command:

```
$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'Extrude'
COMMAND = "ExtrudeGrid SourceZone=<int> Variable=<int> NumLayers=<int> Distance=<double>"
```

If a variable is not specified in `COMMAND`, the macro command will use the defaults (SourceZone=1, Variable=3, NumLayers=10, and Distance=1.0).

**Extrude Example**

Follow this example use of the Extrude add-on to create a cylindrical (open-ended) surface by extruding a circular line. For simplicity, this example will create the circular line as a sub-zone of a 2D, generated circular zone.

To do this, perform the following steps:

1. Create a circular zone by selecting Data>Create Zone>Circular.
2. In the Create Circular Zone dialog, set K to 1 and select [Create]. Select [Close].
3. Select the “Extrude” from the Tools menu.
4. In the Extrude Options dialog, set the Extrusion Distance to “5”, use the defaults for the other fields, and select [OK].
5. Select [Yes] to create the Z-variable. Upon creation of the extruded sub-zone, the plot will automatically switch to 3D Cartesian plot mode.
6. Select the [Zone Style] button in the Sidebar and go to the Surfaces page of the Zone Style dialog.
7. On the Surfaces page, select Zone 2, the “3D extruded zone”, and then select “I-Planes” from the [Surfaces to Plot] button. Select the [Range For I-Planes] button, and in the Enter Range
Working with Tecplot 360 Add-ons

In the dialog, set the range to Begin: “Mx”, End: “Mx”, and Skip: “1”. The resulting plot will resemble Figure 33-5.

Figure 33-5. A cylinder created with the Extrude add-on.

### 33 - 3.14 Key Frame Animator

The Key Frame Animator add-on loads automatically with Tecplot 360. With this add-on, you can easily animate a smooth progression through two or more specified views (key frames) and export them as an AVI, Flash, or Raster Metafile animation.

To use this add-on, first create a layout and use the 3D Cartesian mode to view your plot. Then select “Key Frame Animation” in the Animate menu to open the **Key Frame Animation** dialog.

You must be in 3D Cartesian mode to use the Key Frame Animator add-on. This add-on works only with Tecplot 360 2008 R2 and newer versions.

To unload this add-on, comment out the line containing the `libname “keyframe”` in your `Tecplot.add` file.
To create a key frame animation using this dialog, follow these general steps:

1. Rotate and/or zoom the plot to the initial view for the animation, and select the [Append] button in the dialog. If you wish, you may change the name of the view (key frame) by selecting the frame (“View 1”) in the Key Frame box and editing the name in the View Name field of the dialog (for example, “End of Airfoil”).

2. Rotate and/or zoom the plot to the next view you wish your animation to include, and select the [Append] button to add that view to the end of the animation. Or you can select the [Insert] button to insert a view above the selected one in the list. These key frames are snapshots of the view in Tecplot 360, so limit rotations to 180 degrees or less between key frames, or the animation may not rotate as you expect.

3. Continue to rotate and/or zoom and select [Append] or [Insert] to add additional key frames to your animation, if desired.

4. When finished adding key frames, select [Animate All] to perform a complete animation of your views, or [Animate Selected] to animate only the views selected in the Key Frame box. Tecplot 360 will interpolate all views in between your views to create an animation.

5. To export an animation, change the Destination from “On Screen” to “To File”. Then select the [Animate All] or [Animate Selected] to open the Export Options dialog. You can choose to export the file as AVI, Flash, or Raster Metafile. Refer to Chapter 26: “Exporting” for details on exporting your file.

The Key Frame Animation dialog includes these controls:

- **Append** - The [Append] button adds the current view in the active frame to the list.
- **Insert** - Use the [Insert] button to insert the current view above the currently selected view in the key frame list.
- **Update** - The [Update] button replaces the view selected in the list with the current view in Tecplot 360. This also re-captures the current solution time.
- **Apply** - Use the [Apply] button to display the selected view as the current view of your plot.
- **Delete** - Select the [Delete] button to delete the selected key frame from the list.
- **Clear** - Use the [Clear] button will delete all key frames from the list.
- **View Name** - Use the View Name field to rename the view selected in the key frame list. By default, Tecplot 360 names the views as “View 1”, “View 2”, etc.
- **Frame Count** - The Frame Count box sets the number of frames drawn by Tecplot 360 between the selected view and the next view in the animation.
- **Destination** - In the Destination drop-down menu, choose whether to animate the key frames On Screen or To File.
- **Animate All** - Select [Animate All] to animate through all the key frames in the list.
• **Animate Selected** - Select [Animate Selected] to animate only the selected views. This allows you to refine a subset of animation without performing the complete animation.

### Animation Customizations

The Key Frame Animator add-on includes additional capabilities in customized *File* and *Options* menus at the top of the Key Frame Animation dialog. These menus give you the following additional options:

- **File>Open/Save Animation** - In the *File* menu, you can save an animation that you have created, or you can open an animation that you have previously saved. An animation file stores settings and all key frames, and defaults to the name `animation.keyframe`. The ability to save and load animation files enables you to keep track of created animations without having to recreate them.

- **Options** - In the *Options* menu, each choice is a toggle except for “Time Animation Options” (which opens the *Time Animation Options* dialog). Select an option from this menu to turn on that preference. When an option is toggled-on, a checkmark will appear next to that option in the *Options* menu.
  - **Animate Time Concurrently** - Select this option to animate time when animating the key frames, as specified in the Time Animation Options dialog.
  - **Animate Streamtraces Concurrently** - If streamtraces display as markers or dashes in your plot, enable “Animate Streamtraces Concurrently” to animate streamtrace markers or dashes concurrently with key frame animation.
  - **Fade In/Fade Out** - Toggle-on “Fade In” and/or “Fade Out” to fade lighting intensity and background lighting during the start and/or end of the key frame animation. The fade will last either 30 frames or the first ten percent of all frames, whichever is shorter. Fade In and Fade Out work best with a black background and without any plot features that do not have light sensitivity (mesh lines, edge lines, etc.).

### Time Animation Options

*Time Animation Options* - With the *Time Animation Options* dialog (opened by selecting “Time Animation Options” in the *Options* menu), you can specify additional options for animating your key frames. Choose to animate the frames by any of the following methods.

- **Forward** - With “Forward” selected, Tecplot 360 will display the earliest solution time in the first key frame, and will progress solution time throughout key frame animation so that the latest solution time displays with the final frame of the animation.

- **Loop** - With “Loop” selected, the solution time will progress as in the “Forward” option, except that the complete cycle of solution times displays multiple times over one key frame animation cycle. Set the number of solution time cycles to display in the Num Cycles box.

- **Bounce** - With “Bounce” selected, the solution time will progress forward during animation, until the solution time cycle completes. The solution time will then decrement in equal intervals until the initial solution time displays. Specify the number of times to repeat this bounce in the Num Cycles box.

- **As Captured** - Select “As Captured” to link each key frame with the solution time that the frame displayed when that frame was added to the key frame list. During the key frame animation, the solution time will vary in equal intervals between successive pairs of key frames so that each key frame displays the linked solution time.
Export Animation Options

In the Key Frame Animation dialog, when animating a set of key frames, you can export your animation by selecting “To File” from the Destination drop-down menu. Then select either [Animate All] or [Animate Selected] to launch the Export Options dialog. In this dialog, you can customize the export settings for your animation. Then select [OK] to select file location and export your animation.

The Export Options dialog includes the following export settings for your animation:

- **Format** - Select the format of your exported file.
- **Region** - Select the portion of your workspace that you wish to export. You can export the Active Frame, All Frames, or the entire Work Area.
- **Width** - Choose the width of the exported animation. You can use the default width of image on screen, or enter your own dimensions.
- **Animation Speed** - Enter a number to indicate how quickly you would like your animation to progress, in units of frames per second.
- **Antialiasing** - Toggle-on “Antialiasing” to use antialiasing in your exported animation. For more information on antialiasing, refer to Section 26 - 7 “Antialiasing Images”.
- **AVI Compression** - If exporting as AVI, select the manner in which to compress your animation, if at all. A compressed export will result in a lower-resolution animation with a smaller file size.
- **Image Type** - If exporting as Flash, choose the type of image on which to base your animation.
- **Optimize** - With the two Optimize choices at the bottom of the dialog, you can choose to optimize your animation for either faster speed or smaller file size.

Macro Processing

To invoke the Key Frame Animator from the macro language, use the following commands:

Save Animation File:

```
$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'Key Frame Animation'
COMMAND = 'Animate AnimationDestination=<animationdest>'
```

In this command, use either OnScreen or ToFile for the <animationdest>.

Open Animation File:

```
$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'Key Frame Animation'
COMMAND = 'OpenSettingsFile FileName = <string>'
```

Use the $!ExportSetup commands to set up the necessary parameters for exporting to file (to set format, filename, etc.) You can read more about these commands in the Scripting Guide.

See Also: Section 33 - 3.14 “Key Frame Animator”.

33 - 3.15 Multi-Frame 3D

The Multi-Frame 3D add-on, which loads automatically with Tecplot 360, adds two menu items to the Frame pull-down menu: Tile Frames and 3D Multi-Frames. Each command displays a small dialog giving you options for managing the frames in your plot.

To unload this add-on, add a “#” symbol in front of the following line in your Tecplot.add File:

```
$!LoadAddon "multiframe3d"
```
Tile Frames

The Tile Frames dialog lets you quickly arrange multiple frames on a page in a variety of layouts. Clockwise from upper left, these are:

• Square: Frames are made as close to square as possible and arranged in a grid with approximately equal numbers of rows and columns.
• Wrap: The first frame is displayed in a larger size and the rest of the frames are wrapped around the right and bottom edge. The size of the main frame depends on the number of additional frames that need to be wrapped around the page.
• Horizontal: Equal-size horizontal frames are stacked vertically.
• Vertical: Equal-sized vertical frames are arranged horizontally.

When frames are resized, no attempt is made to re-fit the data to them. If a frame's aspect ratio changes, data may no longer fit the frame as it did before tiling.

3D Multi-Frames

The 3D Multi-frames dialog, available only when the active frame is in 3D Cartesian mode, creates three additional frames displaying top (XY), front (XZ), and side (YZ) views of the 3D frame.

You may choose from five options for arranging the frames. Four of these options use a large frame for the original 3D frame and place the top, front, and side views along the top, bottom, or side of the large frame. For these views, the slider chooses the size of the large frame from 25% to 75% of the paper area. A grid arrangement giving equal prominence to all four frames is also provided. The button with the red X is for deleting the auxiliary frames (they may also be deleted manually).

When the new frames are created, the data and styles are shared with the original frame, and the new views are fit to their frames. The program also links field layer toggles, such as Mesh, Contour, Lighting, and so forth, so that a change in one frame is automatically reflected in the others.

Macro Processing

To tile frames using the Tecplot macro language, use the following command.

The command can be TILEFRAMESQUARE, TILEFRAMESVERT, TILEFRAMEZHORIZ, or TILEFRAMESWRAP.
To generate the top/front/side frames from a 3D view, use the following command.

```
COMMANDPROCESSORID = 'Multi Frame Manager'
COMMAND = 'MAKEFRAMES3D ARRANGE=LEFT SIZE=25'
```

ARRANGE may be LEFT, TOP, RIGHT, BOTTOM, or TILE, and the first four accept the SIZE parameter, which indicates a percentage of the paper size and can be 25-75.

To delete the top/front/side frames, use the following command.

```
COMMANDPROCESSORID = 'Multi Frame Manager'
COMMAND = 'DELETEFRAMES3D'
```

### 33 - 3.16 Pick and Change

The Pick and Change add-on is considered prototype software. It is not enabled by default in this release of Tecplot 360. To enable it, make sure the following line is in your `tecplot.add` file: `#LoadAddon "tecutiltools_pickalter"` (or use one of the other methods in Section 33 - 1 "Add-on Loading" to load it).

Pick and Change allows you to do simple data alterations or assignments to a selected portion of your dataset. You choose which elements to alter by either selecting individual cells or nodes, or by using simple geometries to define a boundary around the area that contains the desired cells or nodes. You can use the add-on in two modes:

- **The Alter mode** allows you to choose the variable to be modified and to either assign a new constant value or make simple modifications to the existing value.
- **The Blank mode** is used to selectively blank areas of your data, allowing you to focus on areas of interest.

Pick and Change requires a data set in either 2D or 3D Cartesian mode (it does not work on line maps). The data may be either ordered or finite element and may be either cell-centered or nodal. Select Data > Pick and Change to bring up this dialog:

The following procedure is the typical Pick and Change workflow.
1. Choose the mode (Alter or Blank) by choosing the tab at the top of the dialog.
2. For Alter mode, choose the variable to be altered and the modifier, which defines the alteration. For Blank mode, use the check box to activate blanking.
3. Choose the inside/outside rule. When using a boundary, you can tell the program to apply the alteration to elements either inside or outside the boundary.
4. If the variable is cell-centered or when using blanking mode, you must also decide whether all nodes (corners) of the cell must be included by the boundary, or whether any corner of the cell satisfies the inside/outside rule.
5. Choose the pick mode using the toggle buttons. From left to right, the mode options are single element, rectangular boundary, circular boundary, irregular boundary, 3D cube boundary, and 3D sphere boundary.
   - For single element picks, the operation will be applied as soon as you click the node or cell.
   - For 2D geometries, use the mouse to draw a new boundary or select an existing boundary, then press the Apply button.
   - For 3D boundaries, additional controls will appear on the dialog allowing you to precisely define the anchor point and dimensions. When the boundary is correct, press the Apply button to make the changes.

Choosing a Variable
When using the Alter mode, all variables in the current data set will be displayed in a list. You may wish to choose the same variable to be displayed as your contour variable in order to see the results of your alterations. The program will do this for you if you toggle-on Sync C1 Contours. When this function is active, changing the variable in the Pick & Change dialog will also change the variable assigned to contour group 1 in your plot. The opposite is not true: changing the C1 variable by way of the Contour Details dialog does not change the selection in this dialog.
Variables may be nodal or cell-centered, and this may impact how you make selections. For example, if your pick option is for a single element and the variable is nodal, you must use Control-Click to snap to the nearest point. If the variable is cell-centered, clicking anywhere on a cell face works, but you should not use the Control key. If the variable is cell-centered, this also impacts the inside/outside option.

Modifying Variables
The modifier is composed of an operand and a value that defines how the selected variable will be altered. Supported operands are =, +, -, *, and /, for assign, add, subtract, multiply, and divide, respectively. If no operand is included, assignment is assumed. For example:

<table>
<thead>
<tr>
<th>Entry</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>=100 or 100</td>
<td>Assigns the value 100 to the selected variable for picked elements.</td>
</tr>
<tr>
<td>-60</td>
<td>Subtracts 60 from the current value.</td>
</tr>
<tr>
<td>= -60</td>
<td>Assigns a value of -60.</td>
</tr>
<tr>
<td>* 1.5</td>
<td>Multiplies the current value by 1.5</td>
</tr>
<tr>
<td>/ 4</td>
<td>Divides the current value by 4.</td>
</tr>
</tbody>
</table>
Choosing a Pick Mode

The pick mode determines the method used for choosing the elements to be altered. Once you select a mode, it remains in effect until you choose another mode or toggle it off. There are three general categories: a single element (cell or node), a 2D boundary, or a 3D boundary.

- **Single Elements**
  When using the single element option, the mouse pointer changes to a crosshair as it does when you do a probe. When you click an element (or Control-Click for nodes if the variable is nodal) the alteration is applied immediately.

- **2D Boundaries**
  2D boundaries are created just like geometries. You may also select these modes using the buttons on the main toolbar. Ellipse boundaries are not supported.
  
  When defining a boundary using the irregular polygon option, it is not necessary to try to click back to the starting point. The add-on will automatically close the path for you. Sides may be concave but lines should not intersect.
  
  When using a 2D boundary on a 3D data set, the program will drill through the data to find elements that fall behind the visible surfaces. The alterations are NOT limited to just the cells you can see. The drilling direction is determined by the line-of-sight on the image that is displayed on the screen.
  
  Because drilling of this nature is often more useful when done on an orthogonal axis, there are buttons in the Pick & Change dialog that allow you to easily switch to an XY, XZ, or YZ view. The 3D button will return to your initial view.
  
  If multiple geometries exist in a frame, you will need to identify the one to be used for the pick operation. With the mouse pointer in select mode, simply click on the geometry. Pick handles appear to verify your selection.
  
  Only one geometry at a time can be selected for the Pick & Change operation. You can reuse geometries for Undo operations or to alter multiple variables, and you can also move them around to easily apply changes in different areas.
  
  Once the dimensions and position are as desired, click **Apply** to make the changes.

- **3D Boundaries**
  A 3D boundary is available only when the frame is in 3D Cartesian mode. When this mode is selected, additional controls appear on the dialog, allowing you to precisely set the boundary configuration. A cube is defined by its anchor point and dimensions, a sphere by its center and radius.
  
  You can use the spin controls or enter values directly in the text boxes. An outline of the boundary appears on the plot and is updated as the values change. By default, only the edges are shown; turn on the **Shade** toggle to display shaded boundary faces, which may provide a better sense of what is inside or outside the box. (You must also have the Shade layer activated on the sidebar to see shaded boundary faces.)
  
  Once the dimensions and position are as desired, click **Apply** to make the changes.
Selecting Inside or Outside a Boundary

When using either a 2D or 3D boundary, you can elect to apply the modifications to either the elements falling inside or outside the boundary using a drop-down menu.

If the variable is cell-centered, the add-on needs to determine whether the cell falls inside or outside the boundary. In this case, you can differentiate according to whether a single node (corner) of the cell is sufficient to make the determination, or whether all nodes must meet the inside/outside condition. A second menu gives you this option.

If the variable is nodal, the add-on needs only the inside or outside option for Alter mode. The Blanking mode, however, applies to whole cells, and does require the any/all option.

The determination about whether to include the cell is dependent on the cell corners and not the cell body. For example, you could have the situation shown here. Even though several cells intersect the boundary, since none of the corners fall inside the boundary, the cell would not be picked.

Applying Changes

Except when selecting individual elements, the Apply button is always needed to initiate your changes. You may also use the button to perform multiple alterations in a single area: after completing one operation, change the variable and/or modifier as appropriate and click Apply again.

Undoing Changes

When using the Alter mode, you may be able to undo your last alter operation by pressing the Undo Last Alter button, subject to the following limitations:

- Only a single operation can be undone.
- Assignment modifications (i.e. =30) may not be undone.
- Mathematical operations are undone by applying the inverse operation. For this reason, the undone alteration may not exactly match the original value, though it will be very close. (This is a limitation of the floating-point representation used internally.)
- The alteration must be undone immediately after its original application, and any pick boundary must be in its original size and location. Most changes to options, styles, or the view will disable the Undo button.

In the Blank mode, the button reads Undo all pick blanks. In this case, all elements previously blanked using the Pick & Change add-on will be reset so they are again visible. Blanking criteria that you set independently using the Plot > Blanking options, though, will not be affected.

Which Elements Are Picked

- Zones
  Pick & Change works on only active zones. If you are working with transient data, only the zones that are relevant to the current time step are altered.
  In general, this means that if you can't see the zone then it won't be altered. However, it is possible to have an active zone that isn't visible, for example if you had Zone Show turned on but turned off all the layers (mesh, contour, scatter, etc.). If in doubt, see the Zone Style dialog.
- Blanked Elements
  If part of the data are blanked (whether via the Blanking mode of Pick & Change or by other means), the Pick Alter modifications will never be applied to the blanked cells/nodes, even if they meet the boundary conditions.
This suggests a useful workflow: use Pick Blank to display only the elements you want to modify, and then use Pick Alter to do the modification.

- Passive and Shared Variables
  When using the Alter mode, passive variables are not modified. When shared variables exist, the changes will be made only to the active zone, and sharing for that zone and variable will be disabled.

**Blanking Details**

When you select the Blank mode, these changes happen in the background:

- A new cell-centered variable named PICK_BLANK is created. Allowable values are 0 or 1. If this variable already exists, it will be used (a second one will not be created).
- Constraint #8 will be defined to blank when PICK_BLANK = 1, which will blank any picked cells. Note that this may replace existing settings for this constraint.

There is also an Include Blanking toggle. You’ll need to turn this on in order to see the results of your picks. However, this will also turn on any other blanking constraints that are defined and active. Choose Plot > Blanking > Value Blanking to deactivate or change those settings.

**Macros**

You may record and play back macros for Pick & Change operation. Changes made using 2D geometries are totally dependent on the view. For these to work as expected, you must ensure you have the same view of your data when you run the macro as you had when it was recorded. This dependency on the view also means that Pick & Change operations cannot be journaled.

Macro commands are of two general types: Those that define the pick boundary (PICKRECTANGLE, PICKCIRCLE, PICKPOLYGON, PICKCUBE, PICKSPHERE) and those that define what changes to apply (ALTERAREA, BLANKAREA, ALTERELEMENT, BLANKELEMENT). Except for ALTERELEMENT and BLANKELEMENT, there will always be a pair of commands recorded for defining both parts.

Example:

```plaintext
$!ADDONCOMMAND
ADDONID = 'Pick and Change'
COMMAND = 'ALTERELEMENT VARIABLE="T(K)" MODIFIER="+1000" ZONE=2 ELEMENT=165'
$!ADDONCOMMAND
ADDONID = 'Pick and Change'
COMMAND = 'PICKRECTANGLE ANCHORX=0.0575227 ANCHORY=0.766247 SIZEX=0.635865 SIZEY=0.572908'
$!ADDONCOMMAND
ADDONID = 'Pick and Change'
COMMAND = 'ALTERAREA VARIABLE="T(K)" MODIFIER="+1000" RULE=ALLINSIDE'
```

**Commands that define pick boundaries**

The picking operation is view dependent, and the values may represent paper coordinates as opposed to the grid values used for your data, so they may not be immediately recognizable.

<table>
<thead>
<tr>
<th>Command</th>
<th>Parameters</th>
<th>Type</th>
<th>Required?</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>PICKRECTANGLE</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ANCHORX</td>
<td>Floating point</td>
<td>Yes</td>
<td>Coordinates of the anchor corner of the rectangle</td>
<td></td>
</tr>
<tr>
<td>ANCHORY</td>
<td>Floating point</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

526
### Working with Tecplot 360 Add-ons

<table>
<thead>
<tr>
<th>Command</th>
<th>Parameters</th>
<th>Type</th>
<th>Required?</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>SIZEX</td>
<td></td>
<td>X and Y dimensions of the rectangle</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SIZEX</td>
<td>Floating point</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SIZY</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PICKCIRCLE</td>
<td>ANCHORX</td>
<td>Center of the circle</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ANCHORY</td>
<td>Floating point Yes</td>
<td></td>
<td>Radius</td>
</tr>
<tr>
<td></td>
<td>RADIUS</td>
<td>Floating point Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PICKPOLYGON</td>
<td>CORNERS</td>
<td>Comma-separated list of X,Y pairs of coordinates defining the corner points</td>
<td>Yes</td>
<td>A minimum of three corners must be specified</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PICKCUBE</td>
<td>ANCHORX</td>
<td>Coordinates of the anchor corner of the cube</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ANCHORY</td>
<td>Floating point Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ANCHORZ</td>
<td>Floating point Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>SIZEX</td>
<td>Floating point Yes</td>
<td></td>
<td>Dimensions of the cube sides in the X, Y, and Z directions.</td>
</tr>
<tr>
<td></td>
<td>SIZY</td>
<td>Floating point Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>SIZEZ</td>
<td>Floating point Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ROTATEX</td>
<td>Floating point No Default = 0</td>
<td></td>
<td>Angles (in degrees) of rotation about the X, Y, and Z axes.</td>
</tr>
<tr>
<td></td>
<td>ROTATEY</td>
<td>Floating point No Default = 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ROTATEZ</td>
<td>Floating point No Default = 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PICKSPHERE</td>
<td>ANCHORX</td>
<td>Coordinates of the center of the sphere</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ANCHORY</td>
<td>Floating point Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ANCHORZ</td>
<td>Floating point Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>RADIUS</td>
<td>Floating point Yes</td>
<td></td>
<td>Sphere radius</td>
</tr>
</tbody>
</table>
### Commands that define pick changes

<table>
<thead>
<tr>
<th>Command</th>
<th>Parameters</th>
<th>Type</th>
<th>Required?</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLANKAREA</td>
<td>Rule</td>
<td>One of ALLINSIDE, ALLOUTSIDE, ANYINSIDE, ANYOUTSIDE</td>
<td>Yes</td>
<td>Apply blanking using the currently defined pick boundary.</td>
</tr>
<tr>
<td>ALTERAREA</td>
<td>Rule</td>
<td>One of ALLINSIDE, ALLOUTSIDE, ANYINSIDE, ANYOUTSIDE</td>
<td>Yes</td>
<td>X and Y dimensions of the rectangle</td>
</tr>
<tr>
<td></td>
<td>VARIABLE</td>
<td>String</td>
<td>Yes</td>
<td>Name of variable to be modified</td>
</tr>
<tr>
<td></td>
<td>MODIFIER</td>
<td>String</td>
<td>Yes</td>
<td>Modifier (i.e. “+50”, “*10”, etc.)</td>
</tr>
<tr>
<td>BLANKELEMENT</td>
<td>ZONE</td>
<td>Integer</td>
<td>Yes</td>
<td>Zone number containing cell to be blanked</td>
</tr>
<tr>
<td></td>
<td>ELEMENT</td>
<td>Integer</td>
<td>Yes</td>
<td>Cell number to blank</td>
</tr>
<tr>
<td>ALTERELEMENT</td>
<td>ZONE</td>
<td>Integer</td>
<td>Yes</td>
<td>Zone number containing element to be altered</td>
</tr>
<tr>
<td></td>
<td>ELEMENT</td>
<td>Integer</td>
<td>Yes</td>
<td>Cell or node number</td>
</tr>
<tr>
<td></td>
<td>VARIABLE</td>
<td>String</td>
<td>Yes</td>
<td>Name of variable to be modified</td>
</tr>
<tr>
<td></td>
<td>MODIFIER</td>
<td>String</td>
<td>Yes</td>
<td>Modifier (i.e. “+50”, “*10”, etc.)</td>
</tr>
</tbody>
</table>

### Other Commands (no parameters)

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNDOALTER</td>
<td>Undoes the last pick alter (if possible).</td>
</tr>
<tr>
<td>UNDOBLANK</td>
<td>Clears (undoes) all pick blanking selections</td>
</tr>
<tr>
<td>VIEWXY</td>
<td>Rotates the view on a 3D Cartesian frame to the XY axis orientation</td>
</tr>
<tr>
<td>VIEWXZ</td>
<td>Rotates the view on a 3D Cartesian frame to the XZ axis orientation</td>
</tr>
<tr>
<td>VIEWYZ</td>
<td>Rotates the view on a 3D Cartesian frame to the YZ axis orientation</td>
</tr>
<tr>
<td>VIEW3D</td>
<td>Rotates the view on a 3D Cartesian frame to the orientation that existed before selecting one of the orthographic options.</td>
</tr>
<tr>
<td>PICKGEOMETRY</td>
<td>During macro recording, this command will be inserted before the commands to create a geometry using the mouse. Its purpose is to flag the geometry for deletion during macro re-execution, just as they are cleaned up during live operation.</td>
</tr>
</tbody>
</table>
33 - 3.17 Prism Grid

The Prism Grid add-on, which does not load automatically with Tecplot 360, creates a 3D volume grid from a surface grid. (For example, it could create a volume from measured points defining the bed and banks of a river.) The volume grid (composed of layers of prisms) extends from the bottom to the surface. Points in the original surface zone above the specified water level are not used in the definition of the volume grid.

To load this add-on, uncomment (remove the "#" symbol) from the following line in your tecplot.add file:

```
$!LoadAddon "prismgrid"
```

Or, use "prismgrid" as the libname in one of the methods discussed in Section 33 - 1 "Add-on Loading".

After loading the add-on, select "Prism Grid" from the Tools menu to open the Prism Grid Options dialog.

The Prism Grid Options dialog includes the following options:

- **Source Zone** - In the Source Zone box, select the surface zone defining the bottom (depth) of the body of water.
- **Depth Variable** - In the Depth Variable box, select the variable containing the water depth in the source zone.
- **Positive is Down** - Toggle-on this option if the depth variable is increasing positively for increasing depth in the source zone. In the final volume zone, increasing depth will always increase negatively.
- **Shift so Surface is Zero** - If the water level is specified as something other than zero, the depth (Z) variable in the volume zone may be shifted so that it is zero at the surface of the water.
- **Water Level** - Enter the water level, where negative values indicate that the water level is lower than normal.
- **Number of Layers** - Enter the number of layers of prismatic cells between the bottom of the body of water and the surface. The number of points in the vertical direction is one greater than the number of layers (10 layer will have 11 points in the vertical direction).

**Macro Processing**

To invoke the Prism Grid add-on from the macro language, use the following command:

```
COMMAND $!EXTENDEDCOMMAND COMMANDPROCESSORID = 'Prism Grid' COMMAND = 'Caricatured SourceZone=<int> DepthVar=<int> NumLayers=<int> WaterLevel=<double> PositiveDown=<Boolean> ShiftSurface=<Boolean>'
```

The COMMAND string should be on one line. If a variable is not specified in COMMAND, it will use the defaults (SourceZone=1, DepthVar=3, NumLayers=10, WaterLevel=0.0, PositiveDown='F', and ShiftSurface='F').

**Prism Grid Example**

As a good use of the Prism Grid add-on, follow this example to define the bottom of a body of water. Normally, the data defining the bottom (depth) of the body of water would be read from a file. In this example, however, we generate a rectangular zone with a simple parabolic variation of depth.

To do this, perform the following steps (after loading the Prism Grid add-on):

1. Open Tecplot.
2. Go to the Tools menu and select "Prism Grid".
3. In the Source Zone box, select the surface zone defining the bottom (depth) of the body of water.
4. In the Depth Variable box, select the variable containing the water depth in the source zone.
5. Toggle on the "Positive is Down" option.
6. Enter the water level in the Water Level box.
7. Enter the number of layers in the Number of Layers box.
8. Click OK to create the volume grid.

This will create a volume grid with a parabolic variation of depth based on the specified parameters.
1. Begin to create a rectangular zone by selecting Create Zone>Rectangular from the Data menu.

2. In the Create Rectangular Zone dialog, set XMin to “-1”, YMin to “-1”, the I and J dimensions to “50”, and the K-dimension to “1”. Accept the defaults for the rest of the fields and select [Create] and [Close].

3. Open the Specify Equations dialog (by going to Data >Alter>Specify Equations).

4. Create the depth variable with the equation \( \text{Depth} = x^2 + y^2 - 0.5 \). To do this, enter the equation in the Equation(s) field and select [Compute].

5. Select “Prism Grid” from the Tools menu. Accept the defaults and select [OK].

6. Now we need only to show the newly created zone. Select the [Zone Style] button in the Sidebar. On the Surfaces page of the Zone Style dialog, select the created Zone 2: Semi-structured zone. Select the [Surfaces To Plot] button, and select “Exposed Cell Faces” from that drop-down menu.

Sections of the surface that are above the water level (zero) are removed, the rest of the surface is triangulated, and the volume between the bottom and the water level is filled with ten layers of triangular prisms. The result is shown in Figure 33-6.

Figure 33-6. An example of using Prism Grid.

At this point, experimental data (such as water temperatures or velocities) could be interpolated into the volume data, and iso-surface, slices, or streamtraces could be generated.

### 33 - 3.18 Solution Time and Strand Editor

The Solution Time and Strand Editor add-on allows you to modify the strand and solution time values from the user interface. This helps when loading a series of data files that do not have a solution time or strand ID. Adding the solution time simplifies both animating and setting component styles.

This data loads automatically with Tecplot 360. To unload the add-on, comment out the following line from your Tecplot.add file:

```plaintext
$!LoadAddon "StrandEditor"
```
To access this add-on, select “Edit Time Strands” from the Data menu. The Strand Editor dialog has the following options:

- **Zones to Edit** - In the Zones to Edit box, select a set of zones to edit.
- **Data Specifications** - Toggle-on “Multiple Zones Per Time Step” in order to select grouping by time step or strand. Use this Data Specifications region of the dialog to specify how the add-on groups zones.
- **Strand ID** - In the Time Strand region of the dialog, toggle-on "Assign Strands" to assign strand IDs.
- **Solution Time** - In the Solution Time region of the dialog, toggle-on "Assign Solution Time" to assign the solution time using one of the following options:
  - **Single Value** - The Single Value option assigns the specified solution time to all selected zones.
  - **Constant Delta** - The Constant Delta option applies a constant delta between zones (or groups of zones, depending on the Data Specification settings).
  - **Automatic** - The Automatic option attempts to determine the solution time for each zone in this order:
    - Examines the Common.Time auxiliary data attached to the zone.
    - Tries to read a number from the zone name.
    - Tries to find a dataset variable that contains the time value. If found, uses the minimum value of this variable for that zone.
    - If an existing solution time is defined for the zone, the Automatic option uses it.
    - If all previous efforts fail, the Automatic option will fall back to use the Constant Delta option.
### 33 - 3.19 Sort

The Sort add-on, which does not load automatically with Tecplot 360, sorts the values of a dataset using one variable as a key. Select additional variables to further define how the data is sorted.

Warning: Sorting will only work with ordered data.

Load this add-on by uncommenting the following line in your `Tecplot.add` File:

```plaintext
# $!LoadAddon Sort.
```

For details on loading an add-on, see Section 33 - 1 "Add-on Loading".

After loading the Sort add-on, use it by selecting “Sort” from the Tools menu. This will launch the Sort dialog, which includes the following options for sorting:

- **Zone(s)** - Select the zone(s) to sort.
- **Sort Type** - Choose whether to sort data in ascending or descending order.
- **Sort Option** - Choose the location of sorted data:
  - **In Place** - Select this option to sort the data within its current zone.
  - **To Zone** - Select this option to place the sorted data in a new zone or zones. With this option, sorting will not alter the original data, and the Sort add-on will create a new I-ordered zone for each zone sorted.

#### Macro Language

While recording a macro, a macro function is recorded for Sort upon a successful sort operation. Sort uses the macro command `$!EXTENDEDCOMMAND`. See the Scripting Guide for additional information.

An example of the syntax of `$!EXTENDEDCOMMAND` for Sort is:

```plaintext
$!EXTENDEDCOMMAND $PROCESSORID = 'sort'
COMMAND = 'Z=1,Z=3,V1=4,V2=5,V3=2,Increasing,ToZone'
```
The above command sorts zones 1 and 3, using variable 4 as the key. If variable 4 has values that are equal, variable 5 is used to determine the order. Likewise, if variable 5 has equal values, variable 2 is used to determine the proper order. If variable 2 also has equal values, the original order of variable 4 is used. The data will be sorted in increasing order, and it will be sorted to a zone.

**Syntax of COMMAND**

Each zone that is to be sorted will have the syntax `Z={zone num};` multiple zones may be specified in the same `COMMAND`. The key variable is `V1={key}`, the secondary variable is `V2={key 2}`, and the final key is `V3={key 3}`. The sort type is either “Increasing” or “Decreasing”. Finally, the sort options are either `InPlace` or `ToZone`—these options must be spelled as one word with no spaces. For all options, case is ignored. All the variable keys default to variable 1. The default for Sort Type is “Increasing”, the default for Sort Option is `ToZone`.

**33 - 3.20 Statistics Calculator**

The Statistics Calculator add-on, which does not load automatically with Tecplot 360, extends Tecplot 360's capability to compute simple descriptive statistics. It computes mean, median, variance, standard deviation, average deviation, geometric mean, and chi squared. To load this add-on, use “stats” as the `libname` in one of the methods discussed in Section 33 - 1 “Add-on Loading”.

The Statistics Calculator computes for the active frame only. You must have a frame containing a dataset selected for the Statistics Calculator to perform a computation.

Once you have loaded the Statistics Calculator add-on and have a frame with a dataset selected, launch the Statistics Calculator by selecting “Statistics” from the `Tools` menu.

The Statistics dialog has the following options:

- **Select a Statistic** - Toggle-on one or more statistic(s) to calculate in the left region of the dialog. **Value blanking does not affect calculations.**
- **Select a Format** - The Statistics Calculator can display results in two formats: scientific notation or fixed floating point. The scientific notation format has three digits of precision, while the floating point format has five digits of precision. If any statistic has a magnitude greater than 1010, and less than infinity, the format will automatically revert to scientific notation.
• Select Compute Over All Zones or Compute Over Active Zones/Maps - The Statistics Calculator includes all variables in its calculation. Select which zones to apply the calculations to: "All Zones" or "Active Zones/Maps":
  • All Zones - When selected, the Statistics Calculator uses data points from all zones in the active frame.
  • Active Zones/Maps - When selected, the Statistics Calculator uses only data points from the active zones. (Activate and deactivate zones through the Zone Style dialog.) When working with Lines, the Statistics Calculator computes the statistics for the zones referenced by the active mappings.

• Compute Button - Select the [Compute] button to make the calculations and launch the Statistics Output dialog. The format of the output depends on the options selected in the Statistics dialog. Use the scroll bars to see all the statistics. The output is limited to 2,100 statistics, which translates to 300 variables if all seven statistic options are calculated. This value is defined in the file stats.c by the variable MAXSTATS.

• Write Output to File Button - In the Statistics Output dialog, toggle-on “Write Output to File” to launch the Save Text File dialog and save the calculated statistics to a text file. This text file will save in ASCII format and will appear in the Statistics Output dialog.

Macro Language

While recording a macro, a macro function is recorded for the Statistics Calculator upon successfully writing output to a file. The Statistics Calculator uses the macro command $!EXTENDEDCOMMAND. See the Scripting Guide for additional information. An example of the syntax of $!EXTENDEDCOMMAND for the Statistics Calculator is as follows:

```$!EXTENDEDCOMMAND
COMPUTERID = 'stats'
COMMAND = 'Mean,Median,SD,GeoMean,ChiSquared,ActiveZones,Scientific,AUX,FNAME=myfile.txt'
```

Syntax of COMMAND

The only required portion of COMMAND is the file name. If the file name is not specified or not valid, an error message will be displayed, and the macro will abort. The file name must be preceded by the string 'FNAME=', similar to the example above. The word 'FNAME' must be followed by an equals sign (=). If the string 'FNAME' is missing or misspelled, the macro will display an error message and abort.

If the “All/Active Zones” or “Scientific/Float” options are left out, a warning message will be displayed and the default values of “All Zones” and “Scientific Notation” will be used. The order of the string does not matter. All items must be delimited by commas, and spaces between items do not matter. Any statistic either not specified or misspelled will not be calculated. If no statistics are specified in the string, all statistics will be calculated.

The spelling for each item is as follows (case is ignored):
  • Mean- Mean
  • Median- Median
  • Variance- Variance
  • Standard Deviation- SD
  • Average Deviation- AvgDev
  • Geometric Mean- GeoMean
  • Chi Squared- ChiSquared
  • All Zones- AllZones
Working with Tecplot 360 Add-ons

- Active Zones/Maps- ActiveZones
- Scientific Notation- Scientific
- Floating Point- Float

See also: Statistics Calculator Formulas.

**Statistics Calculator Formulas**

The formulas used for the statistics calculator are as follows. In each case, \( \bar{X} \) represents the dataset, \( n \) represents the total number of points in the dataset, and \( X_i \) represents a given point in the dataset (where \( i = 1, \ldots, n \)).

- **Mean**
  \[
  \bar{X} = \frac{1}{n} \sum_{i=1}^{n} X_i
  \]

- **Median** - Middle quantitative value of a dataset.
  - **Odd N** - If the dataset contains an odd number of data points, the data point in the middle of the sorted dataset determines the median. How the median is determined for datasets containing an odd number of data points is described by the formula:
  \[
  X_{\text{median}} = X\left[\frac{n + 1}{2}\right]
  \]
  - **Even N** - If the dataset contains an even number of data points, the value is determined by the average of the two central data points. How the median is determined for datasets containing an even number of data points is described by the formula:
  \[
  X_{\text{median}} = \frac{1}{2} \left[ X\left[\frac{n}{2}\right] + X\left[\frac{n}{2} + 1\right] \right]
  \]

- **Variance** - Variance is the sum of the squares of the deviations of the sample values from the mean, divided by \( n-1 \). It measures the dispersion, or variance, of the sample values from the mean. Variance is calculated by the formula:
  \[
  X_{\text{variance}} = \frac{1}{(n-1)} \sum_{i=1}^{n} (X_i - \bar{X})^2
  \]

- **Standard Deviation** - Standard deviation is the square root of the variance. Standard Deviation is calculated by the formula:
  \[
  \sigma = \sqrt{\frac{1}{n-1} \sum_{i=1}^{n} (X_i - \bar{X})^2}
  \]

- **Average Deviation** - Average deviation is the sum of the magnitudes of the deviations of the sample values from the median, divided by \( n \). Average Deviation is calculated by the formula:
  \[
  X_{\text{average deviation}} = \frac{1}{n} \sum_{i=1}^{n} |X_i - \text{median}|
  \]

- **Geometric Mean** - Geometric mean is the \( n \)th root of the product of a series. If any value of the dataset is zero, the result will be zero. For large datasets, or datasets with large values, this statistic will overflow. Geometric Mean is calculated by the formula:
  \[
  X_{\text{geometric mean}} = \left(\prod_{i=1}^{n} X_i\right)^{1/n}
  \]
The geometric mean can also be described by the use of logarithms. The representation of the geometric mean, as seen below, is used by the Statistics Calculator. Given the formula for the geometric mean, it is easy to see that if any value of the dataset is zero, the geometric mean is zero. Although the logarithm of zero is undefined, the Statistics Calculator will return zero if any member of the dataset is equal to zero. Likewise, the geometric mean is only useful for datasets with all positive members. If any member of the dataset is negative, the Statistics Calculator will return infinity for the geometric mean.

\[
X_{\text{geometric mean}} = \left( \prod_{i=1}^{n} X_i \right)^{\frac{1}{n}}
\]

The geometric mean can also be described by the use of logarithms. The representation of the geometric mean, as seen below, is used by the Statistics Calculator. Given the formula for the geometric mean, it is easy to see that if any value of the dataset is zero, the geometric mean is zero. Although the logarithm of zero is undefined, the Statistics Calculator will return zero if any member of the dataset is equal to zero. Likewise, the geometric mean is only useful for datasets with all positive members. If any member of the dataset is negative, the Statistics Calculator will return infinity for the geometric mean.

\[
\log(X_{\text{geometric mean}}) = \frac{1}{n} \sum \log X_i
\]

- **Chi Squared** - Chi Squared is the measure of how close observed values were to expected values. The smaller the result, the closer the observed values are to the expected values. Chi Squared assumes a contingency table of one column and \( n \) rows, where \( n \) is the number of data points for the particular variable. The expected value is assumed to be the mean. If the mean is zero, Chi Squared will return infinity. Chi Squared is calculated by the formula:

\[
X_{\text{chisquared}} = \sum_{i=1}^{n} \frac{(X_i - \bar{X})^2}{\bar{X}}
\]

See also: Statistics Calculator.

### 33 - 3.21 Tecplot GUI Builder

You can use the Tecplot GUI Builder add-on to generate graphical user interfaces for Tecplot 360 add-ons. You will commonly start with the file, gui.lay, which was created by default if you used the CreateAddOn shell scripts to create your add-on. (Windows users can find example gui.lay files in the adk\samples subdirectory with the ADK templates.) To build an interface, open this layout file in Tecplot 360 and add an assortment of controls to modal or modeless dialogs. Refer to the ADK User’s Manual for more information on working with the Tecplot GUI Builder.

### 33 - 3.22 Tensor Eigensystem

The Tensor Eigensystem add-on loads automatically with Tecplot 360. This add-on enables you to calculate the eigenvalues and eigenvectors of a 3-by-3 symmetric tensor whose components are stored in your data set. The add-on calculates for each node in the data set and stores the results as new data set variables.

To use this add-on, select “Tensor Eigensystem” from the Tools menu to open the Tensor Tools dialog. To unload the add-on, comment out the line including the libname “tensoregn” in your Tecplot.add File.

In the Tensor Tools dialog, select variables from your data set to represent the 6 components of the tensor. Toggle-on “Sort by Eigenvalue” to sort the results by the eigenvalues, and/or toggle-on “Save Eigenvectors” to store the calculated eigenvectors in addition to the calculated eigenvalues, which the calculation always saves. Then select [OK] to perform the calculation.

Tecplot 360 will store the eigenvalues of the tensor as variables EgnVal1, EgnVal2, and EgnVal3 in your data set. If you choose to save the eigenvectors as well, Tecplot will store these as variables EgnVec11
Working with Tecplot 360 Add-ons

through EgnVec33. If you toggled-on “Sort by Eigenvalue”, the eigenvalues and their corresponding eigenvectors will be sorted smallest-to-largest at each grid node.

A common use of Tensor Eigensystem is to visualize vortex cores in a flow solution. You can do this by the following method:

1. Calculate Velocity Gradient in Analyze>Calculate Variables
2. Calculate the symmetric tensor S2 + Ohm-2 with Data>Alter>Specify Equations (see below for an equation file to perform this)
3. Use the Tensor Eigensystem dialog to calculate the sorted eigenvalues
4. Display an iso-surface of Lambda-2, the middle of the three eigenvalues, which is negative in the vicinity of a vortex core

The following equation file calculates the required symmetric tensor components of S2 + Ohm-2 from the velocity gradient for step 2 above. Save the below to a text file, then load it into the Specify Equations dialog by selecting “Load Equations” and selecting the file.

Remember that the Tensor Eigensystem add-on can only analyze 3-by-3 symmetric tensors (not 2-by-2, anti-symmetric, or non-symmetric tensors).
**Macro Language**

To invoke the tensor eigensystem add-on with a macro, use the following syntax.

```
$EXTENDEDCOMMAND = 'Tensor Eigensystem'
COMMAND = 'T11VarNum = <integer>
T12VarNum = <integer>
T13VarNum = <integer>
T22VarNum = <integer>
T23VarNum = <integer>
T33VarNum = <integer>
SortEgnV = <Boolean>
SaveEgnVect = <Boolean>
'
```

### 33 - 3.23 Tetra Grid

The Tetra Grid add-on, which does not load automatically with Tecplot 360, takes well data and generates a tetrahedral mesh. You can use value-blanking to eliminate wells and/or data points within wells. To load this add-on, use “tetragrid” as the *libname* in one of the methods discussed in Section 33 - 1 “Add-on Loading”.

The following requirements must be met for Tetra Grid to work:

- The current dataset must include wells as I-ordered zones.
- The current dataset must include at least three wells.
- Each well must contain at least two data points that are not blanked.

The Tetra Grid dialog contains a list of I-ordered zones in the active dataset. Choose the zones you want to use and select [OK]. The add-on will create the tetrahedral zone and add it to the end of the list of zones.

You must activate this zone yourself.

As an example of using Tetra Grid, imagine that data for five different wells has been collected. Some wells have three data points, others have four. The data for each well is assigned to a separate I-ordered zone in Tecplot 360.

The input data is:

```
VARIABLES = "Easting (m)" "Northing (m)" "Elevation (ft)"
ZONE T= "41-14-08" I=3, J=1, K=1, F=POINT
  3.437500000E+00 9.375000000E-02 2.819946289E+00
  3.375000000E+00 9.375000000E-02 1.811889648E+00
  3.437500000E+00 9.375000000E-02 8.199462891E-01
ZONE T= "41-14-09" I=4, J=1, K=1, F=POINT
  2.687500000E+00 1.796875000E+00 2.212158203E+00
  2.687500000E+00 1.796875000E+00 1.500000000E+00
  2.437500000E+00 1.796875000E+00 1.179992676E+00
  2.375000000E+00 1.796875000E+00 1.799926758E-01
ZONE T= "41-14-11" I=3, J=1, K=1, F=POINT
  1.875000000E+00 4.000000000E+00 2.509948730E+00
  1.500000000E+00 4.000000000E+00 1.509948730E+00
  1.812500000E+00 4.000000000E+00 5.018920898E-01
  1.250000000E+00 4.000000000E+00 8.996582031E-02
ZONE T= "41-15-02" I=4, J=1, K=1, F=POINT
  0.000000000E+00 2.375000000E+00 2.889565820E+00
  0.000000000E+00 2.375000000E+00 1.889565820E+00
  0.000000000E+00 2.375000000E+00 5.889565820E-01
  0.000000000E+00 2.375000000E+00 8.96582831E-02
ZONE T= "41-15-03" I=3, J=1, K=1, F=POINT
  1.250000000E+00 0.000000000E+00 2.000000000E+00
  1.500000000E+00 0.000000000E+00 1.016113281E+00
  1.250000000E+00 0.000000000E+00 4.68708315E-10
```
The wells do not have to be vertical or even straight. The resulting plot is shown in Figure 33-7. The figure shows the wells before and after running Tetra Grid. A slice is added to the plot with the new tetrahedral mesh to show how you can demonstrate volume properties with the new zone.

Figure 33-7. Tetra Grid example. The original well data (A), tetrahedral zone from the well data (B). This file, addon_tetra_grid.lpk, is located in your Tecplot 360 distribution under the examples/3D subdirectory.

**Macro Processing**

To invoke the Tetra Grid add-on from the macro language, use the following command:

```latex
$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'Tetra Grid' COMMAND = "SOURCEZONES = zoneset"
```

In this command, `zoneset` represents the set of I-ordered zones to use to generate the tetrahedral zone. Specify the `zoneset` using the standard set notation for the macro language.

### 33 - 3.24 Time Series

The Time Series add-on, which loads automatically with Tecplot 360, extracts a single point over time and plots the result in a new frame as an XY Line Plot. The solution time of the time series plot’s frame is linked to that of its parent, and a marker gridline is added to show the current solution time. If a nearest point probe is performed (using CTRL-click), you may follow a particular node through time, or through an XY(Z) location.

To use the Time Series add-on, go to `Tools>Time Series Plot` and select one of the following menu options:

- **Probe To Create Time Series Plot** - This option sets the mouse mode to probe. You can use either the mouse or the `Probe At` dialog to probe a point. The probed location will be sampled over time (for transient data) and a resulting XY Line Plot will be created. If a nearest point probe is done (CTRL-click), a dialog appears to ask if you want to track the node or the XY(Z) location through time. If you track the node, it is important that your data has the same node map for each zone through time.

When tracking a node through time, each zone must have the same node map (or a shared node map).

This add-on may not work as expected when there are multiple zones in the same strand at the same solution time.
• **Send Time Series Data To New Frame** - This option creates a new frame for each point extracted. By default, the frame used for the time series data is reused to avoid creating an excess of frames.

• **Keep Probed Frame On Top** - When probing the same frame multiple times, toggle-on this menu option to keep the probed frame on top of the frame stack after the Time Series frame is created. When toggled-off, the Time Series frame will remain on top of the frame stack.

See also: Section 33 - 3.12 “Extract Over Time”, Section 33 - 3.11 “Extend Time Macro”, Section 33 - 3.18 “Solution Time and Strand Editor”, Section 33 - 3.10 “Extend Macro”, Section 7 - 2 “Time Aware”.

### 33 - 3.25 View Binary

The View Binary add-on allows you to view the information in a Tecplot 360 binary data (.plt) file. To load this add-on, use “viewbin” as the libname in one of the methods discussed in Section 33 - 1 “Add-on Loading”.

After loading the View Binary add-on, use it by selecting “View Binary” from the Tools menu.

The View Binary dialog has the following option:

• **Select File** - Use the [Select File] button to choose a binary data file to view.

• **Show Raw Data** - Toggle-on “Show Raw Data” to view zone data in the dialog.

On some machines, the font used to display the header information may not be a mono-pitch font, and consequently, some of the results may not line up directly below the table header.

### 33 - 3.26 Write Data as Formatted Text

The Data as Formatted Text add-on, which does not load automatically with Tecplot 360, enables you to write data to a text file in *.csv format (for comma separated data) or in *.txt format (for any other data separators). You can load this add-on using “excsv” as the libname in one of the methods discussed in Section 33 - 1 “Add-on Loading”. Or add the following line to your Tecplot.add File:

```
$!LoadAddOn "excsv"
```

Once you have loaded the add-on, to use it, select “Write Data As Formatted Text” from the Tools menu. This will open the Write Data as Text File dialog.
The Write Data as Text File dialog includes the following options:

- **Choose Frames** - Use the Choose Frames region of the dialog to specify which frames to include in the text file. Choose from the following options:
  - **Current Frame** - Select “Current Frame” to include the active frame only.
  - **Selected Frames** - When “Selected Frames” is active, the box to the right will become sensitive. Use the SHIFT and CTRL keys to select from the list.
  - **All Frames** - Select “All Frames” to include all frames in the text file.

- **Choose Data setsZones** - Toggle-off the “All” option to select a subset of Data setsZones to include in the text file. Because different frames may have different Data setsZones, this option is available only when “Current Frame” is selected in the Choose Frames region of the dialog.

- **Choose Variables** - Toggle-off the “All” option to select a subset of variables to include in the text file. Because different frames may have different variables, this option is available only when “Current Frame” is selected in the Choose Frames region of the dialog.

- **Value Separator** - Use the Value Separator options to specify the delimiter to use in the text file.

- **Other Text** - Toggle-on any of the options in the Other Text region of the dialog to include the values in the text file. Tecplot 360 will write values in the “best format”, except variables named “Time” or “Date”.

- **Change Variable Format** - Select the [Change Variable Format] button to launch the Change Format dialog. If you choose not to change the variable format, values will be written in the “best” format.

### Change Format

Use the Change Format dialog to change the format for one or more variables. Use the [Change Variable Format] button in the Write Data as Text File dialog to access the Change Format dialog. To change the format for all variables simultaneously, toggle-on “Select All Variables”. Choose a new format with the [Select Format] button.

Use the Width.Precision box to specify the width and precision of your new variable format. Width refers to the total number of characters, while Precision refers to the number of places beyond the decimal point. Leading zeros (other than the first) are not displayed.

For example, a width.Precision of 8.2f yields:

```
Month,Seattle Rainfall,Dallas Rainfall,Miami Rainfall,Error 1,
1.00, 4.30, 4.00, 4.00, 0.20,
2.00, 4.50, 4.00, 4.10, 0.22,
3.00, 4.00, 3.50, 4.50, 0.24,
4.00, 4.20, 3.40, 4.20, 0.24,
```
While a width precision of %3.2f yields:

<table>
<thead>
<tr>
<th>Month</th>
<th>Seattle Rainfall</th>
<th>Dallas Rainfall</th>
<th>Miami Rainfall</th>
<th>Error 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>4.30</td>
<td>4.00</td>
<td>4.00</td>
<td>0.20</td>
</tr>
<tr>
<td>2.00</td>
<td>4.50</td>
<td>4.00</td>
<td>4.10</td>
<td>0.22</td>
</tr>
<tr>
<td>3.00</td>
<td>4.00</td>
<td>3.50</td>
<td>4.50</td>
<td>0.24</td>
</tr>
<tr>
<td>4.00</td>
<td>4.20</td>
<td>3.40</td>
<td>4.20</td>
<td>0.24</td>
</tr>
</tbody>
</table>
Part 8 Appendices
Command Line Options

A - 1  Tecplot 360 Command Line

The general form of the Tecplot 360 command line is:

    tec360 [options] [layoutfile] [datafiles] [macrofile]

where:

- **[layoutfile]** - File with extension *.lay or *.lpk. See also Section 24.1 “Layout Files, Layout Package Files, Stylesheets”.

- **[datafiles]** - One or more data files. If both a layout file (*.lay only) and data files appear on the command line, Tecplot 360 substitutes the data files referenced in the layout file with the data files listed in the command line.

- **[macrofile]** - Macro file name. See also Chapter 28: “Macros”.

- **[options]** - one or more of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>layoutfile</td>
<td>List the layout file you would like to load (*.lay or *.lpk).</td>
</tr>
<tr>
<td>datafiles</td>
<td>List the data file(s) you would like to load. If both a layout file (*.lay only) and data files are listed, the data files referenced in the layout file will be substituted with the data files in the command line.</td>
</tr>
<tr>
<td>macrofile</td>
<td>List the macro file you would like to load (*.mcr).</td>
</tr>
<tr>
<td>-addonfile filename</td>
<td>List the add-on(s) you would like to load.</td>
</tr>
<tr>
<td>-b</td>
<td>Run in batch mode.</td>
</tr>
<tr>
<td>-c cfgfile</td>
<td>Use cfgfile for the configuration instead of the default configuration file, tecplot.cfg.</td>
</tr>
<tr>
<td>-d or -display computername</td>
<td>Display on computer computername (UNIX/Linux only). The computer, computername, must have X-server capability with the GLX extension.</td>
</tr>
<tr>
<td>-datafile filename</td>
<td>Load data file filename.</td>
</tr>
</tbody>
</table>
-debug dbugfile

Send debug information to the file dbugfile. Information is displayed to aid in debugging a new configuration file, macro file, or binary data file. You may specify the minus sign (“-“) for dbugfile to send the debug output to the “standard output” (UNIX/Linux only).

-develop

Launch in a mode used to develop add-ons (UNIX/Linux only).

-f fontfile

Use fontfile instead of the default font file, tecplot.fnt.

-h homedir

Use homedir for the home directory instead of the default home directory.

-loadaddon "addonname"

Load an add-on named addonname.

-m colormapfile

Use colormapfile as the initial color map file.

-nobatchlog

Suppress creation of the file batch.log during batch mode operation.

-nostdaddons

Do not load the add-ons listed in the tecplot.add file.

-notoolbar

Run with the toolbar deactivated.

-p scriptfile

Play the macro commands/python modules in the file scriptfile (*.mcr, *.py).

-q

Use quick playback mode. Ignores delay and pause commands.

-qm quickpanelfile

Place the macro functions in quickpanelfile in the Quick Macro Panel, instead of using the macros from the default file, tecplot.mcr.

-quiet

Turns off all standard-out messages (UNIX/Linux only).

-r printfile

Set the filename for routing Print Files to printfile.

-s stylefile

Use stylefile as a stylesheet for the first frame (*.sty).

-showpanel

Open the Quick Macro Panel upon startup.

-v

Display the version number.

-x

Run in full screen mode.

-y exportfile

Set the filename for export files to exportfile.

-z

Display macro commands in the Macro Viewer. This allows you to see macro commands prior to their launch.

Most of the Tecplot 360 command line options are available for Windows operating systems. To use them, you should start Tecplot 360 from the Run command or the command prompt.

### Table A - 3: Tecplot 360 Command Line Examples

<table>
<thead>
<tr>
<th>Command Line Input</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>tec360</td>
<td>Run Tecplot 360 without pre-loading any data files</td>
</tr>
<tr>
<td>tec360 ex1.plt</td>
<td>Run Tecplot 360 loading the data file ex1.plt as the first dataset</td>
</tr>
<tr>
<td>tec360 ex1.plt ex2.plt ex3.plt</td>
<td>Run Tecplot 360 loading the data files ex1.plt, ex2.plt, and ex3.plt as the first dataset</td>
</tr>
</tbody>
</table>
Using Command Line Options in Windows Shortcuts

All of the command line options that can be entered at the DOS or Command prompt by using the Run command can also be used in a Windows shortcut.

If you frequently run Tecplot 360 using the same command line flags, it may be useful to create a shortcut on your Windows desktop that launches Tecplot 360 with the desired command line flags. Here’s how this can be done:

1. Right click in any blank space on your Windows desktop.
2. Select New>Shortcut from the resulting Menu.
3. In the Create Shortcut dialog, type the location of the Tecplot 360 executable, along with any command flags you want to specify. An example command line is: 
   
   `"C:\Program Files\Tecplot\Tec360 2013R1\BIN\Tec360.exe" -p \MyHome\myset.cfg`

4. Click [Next].
5. Select a name for your shortcut, then click on [Finish].
6. A new shortcut icon will be placed on your Windows desktop.

A - 2.1 Changing Shortcuts

You can alter an existing shortcut by doing the following:

1. Right-click on the shortcut icon you want to change and select Properties.
2. On the Shortcut page, modify the command line by changing the setting for Target. To change the working directory that Tecplot 360 runs under, change the Start in location.

A - 3 Additional Command Line Options in UNIX

On UNIX platforms, you can use additional command line flags which are passed to the window manager to control how the application window is displayed. These include -geometry (for specifying the location and position of the application window), -fg and -bg (for specifying foreground and background window colors), and others. See the X11 reference for your system for complete details on these options.

To determine the path or alias that the tecplot command calls, you would use:

which tecplot
Tecplot 360 Utilities

The following utilities are included with the Tecplot 360 distribution:

- **Excel Macro** - Allows you to load Excel spreadsheet data directly into Tecplot 360.
  - **Frame** - A shareware utility for viewing Raster Metafile animations created by Tecplot 360.
- **LPK View** - A utility to catalog, preview or unpack a layout package file into its component data and layout files.
- **Preplot** - A utility to convert an ASCII data file into a Tecplot 360 binary file.
- **Raster Metafile to AVI (rmtoavi)** - A utility to convert a Raster Metafile animation into an AVI animation.
- **Pltview** - A utility to view the header information for a Tecplot 360 binary file.

**B - 1 Excel Macro**

The Excel Macro provides a convenient way to load data directly from your Excel spreadsheet into Tecplot 360. When loaded it adds an option to Excel's Tools menu called Tecplot 360, and a toolbar containing a button marked Tecplot 360. Both launch Tecplot 360 and load the data in the highlighted region of the spreadsheet. The Excel macro offers many advantages over the Excel loader in Tecplot 360 (accessible from the Load Data File(s) option from the File menu).

The Excel Macro is available on Windows platforms only.

These include:

- **Highlight and Plot** - The Excel Macro is easier to use than the conventional Excel loader. Click in the upper left cell of the region or highlight the entire region, and then click on the Tecplot button in the tool bar or on the Tecplot option in Excel's Tools menu.
- **Multiple Zones** - The Excel Macro makes loading multiple zones much easier. Highlight the entire region and then click on the Tecplot button in the tool bar or on the Tecplot option in Excel's Tools menu. If your zones are separated by blank rows or columns, then the macro will load them to Tecplot 360.
• **Formulas** - The highlighted region of the spreadsheet can contain formulas, or can be created entirely with formulas. Tecplot 360’s Excel Loader (accessed via the Load Data File option from the File menu) does not work where formulas are present.

A Read Me file, located in the Utit/Excel directory, further describes installation and use of this macro.

As an example, let’s say you have 3D data obtained by drilling a number of wells and measuring contaminant concentrations of various chemicals at different depths. Your data is in Excel spreadsheet software, and you want to load the data into Tecplot 360 to get a visual representation of the contamination. The data has nine variables and twenty-seven zones, as shown in Figure B-8.

**Figure B-8.** The beginning well data displayed in Excel.

Perform the following steps to import your data and visualize the contaminant plumes:

1. Load your Excel data using the new Excel Macro. (Accessing this dialog is shown in Figure B-9)

2. Starting with the top left-hand cell, highlight all twenty-seven zones and nine variables.

3. Click on Tecplot in Excel’s Tools menu. The menu option launches Tecplot 360 with the selected data loaded.

![Figure B-9. Accessing the Excel Loader macro via Excel’s menu bar.](image-url)

Make sure you have a blank row separating the zones in your Excel spreadsheet.

550
4. Switch to 3D Cartesian plot mode to see the location and measurement depths of the well samples. The resulting plot is shown in Figure B-10.

Figure B-10. The Excel well data plotted in Tecplot 360.

5. Your wells have different depths, so the number of measurements are not the same for each well (there are only three measurements at well five).

**B - 2 Framer**

Framer is a shareware utility for viewing Raster Metafile animations created by Tecplot 360. To launch Framer from a command line, use the following command:

```
framer [options] [rmfile]
```

where [rmfile] is the name of a file containing Raster Metafile bitmaps created by Tecplot 360, and [options] is one or more of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-b [nf]</td>
<td>Use buffered mode. Framer reads nf frames into memory and displays only those frames. Frames not read are not displayed. This mode displays images much faster, but requires extra memory. If nf is not specified, Framer reads as many frames as possible up to the total limit on frames (see -max parameter).</td>
</tr>
<tr>
<td>-c nc</td>
<td>Use no more than nc colors (X-Windows only). On some machines, you may need to use &quot;-c 128&quot; to allow two copies of Framer to run at the same time.</td>
</tr>
<tr>
<td>-cycle nn</td>
<td>Start Framer in “cycle” mode (as if C were pressed), and continue for nn complete cycles, and then exit.</td>
</tr>
<tr>
<td>-d dfile</td>
<td>Send debug information to dfile. Use “-d2,” “-d3,” “-d4,” etc., for more detailed debug information.</td>
</tr>
<tr>
<td>-f start,end,skip</td>
<td>Display frames starting with frame number start and ending with frame number end, skipping by skip frames.</td>
</tr>
<tr>
<td>-g</td>
<td>Use gray scale</td>
</tr>
<tr>
<td>-help</td>
<td>Print help information.</td>
</tr>
<tr>
<td>-loop nn</td>
<td>Start Framer in “loop” mode (as if L were pressed), and continue for nn complete loops, and then exit.</td>
</tr>
</tbody>
</table>
If you do not specify a file name, Framer prompts you for one. You can choose to set buffering (equivalent to the `-b` flag) and/or multiple color maps (equivalent to the `-m` flag).

While Framer is running, you can press the following keys to control it:

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Move backward through frames (or left mouse button).</td>
</tr>
<tr>
<td>C</td>
<td>Cycle forward and backward through frames.</td>
</tr>
<tr>
<td>F</td>
<td>Move forward through frames (or middle mouse button on a three-button mouse or right mouse button on a two-button mouse).</td>
</tr>
<tr>
<td>L</td>
<td>Loop repeatedly forward through frames.</td>
</tr>
<tr>
<td>Q</td>
<td>Quit Framer (or right mouse button on three button mouse) or ESC key.</td>
</tr>
<tr>
<td>S</td>
<td>Stop cycling or looping (or spacebar).</td>
</tr>
<tr>
<td>R</td>
<td>Redraw the active frame.</td>
</tr>
<tr>
<td>1</td>
<td>Move to the first frame.</td>
</tr>
<tr>
<td>+</td>
<td>Move forward one frame.</td>
</tr>
<tr>
<td>-</td>
<td>Move backward one frame.</td>
</tr>
<tr>
<td>&lt;</td>
<td>Increase the minimum delay between frames by 50 milliseconds. This decreases the speed at which frames are displayed.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Decrease the minimum delay between frames by 50 milliseconds. This increases the speed at which frames are displayed.</td>
</tr>
</tbody>
</table>

On Windows platforms, these Framer commands are also available from the Go and Step menus. See also Section 31 - 5.6 “Raster Metafiles Viewing in Framer”.

### B - 3 LPK View

As a convenience a command line utility, `lpkview` is provided to catalog and unpack layout packages. In its simplest form (when no options were included), the utility to unpack the preview image (if present), the layout, and all associated data files into the directory in which the utility was run.

For example:

`lpkview myplot.lpk`
LPK View

might unpack the following files in the current directory:

- myplot.png
- myplot.lay
- myplot_1.plt
- myplot_2.plt
- myplot_3.plt

Tecplot 360 determines the names for unpacked files when the package is created. Tecplot 360 eliminates name conflicts within the package by appending unique numbers to non-unique names. However, no attempt is made by lpkview to ensure that names are unique with other files located in the directory where the items are unpacked.

The utility’s syntax is as follows:

```
lpkview [ [-t] | [ -ild ] | [ [-c <preview command>] -p] ] filename
```

Brackets ([]) surround optional parameters and the vertical bar (|) separates one mutually exclusive set of options from another. The options are described as follows:

- `-t` Show table of contents.
- `-i` Extract image (for example, a Portable Network Graphics or .png format).
- `-l` Extract layout.
- `-d` Extract data.
- `-c` (UNIX only) Specify preview command.
- `-p` (UNIX only) Preview image.

Option `-t` may not be used with any other options, and options `-i`, `-l`, and `-d` may not be used with options `-c` and `-p`. If no command line options are specified `-i`, `-l`, and `-d` are assumed by default.

**Note:** (UNIX only) if the `-p` option is specified without specifying a preview command, `-c`, the following default preview command is used:

```
$MOZILLA_HOME/netscape -remote "OpenURL(%s)"
```

where `%s` is substituted by `lpkview` with the file name of the temporarily extracted preview image. The default command assumes: the environment variable `$MOZILLA_HOME` is set, Netscape is installed under `$MOZILLA_HOME`, and that `lpkview` has been added to Netscape as a helper application.

To add `lpkview` as a helper application, bring up Netscape’s Preferences dialog and select the Applications page. Within the Applications page select New and add `lpkview` as a new helper application by entering the following information:

- **Description:** <optionally leave this blank>
- **MIMEType:** application/x-tecplot-lpk
- **Suffixes:** .lpk
- **Handled By:** <select “Application”>

```
Application: $TEC_360_2013R1/bin/lpkview -p %s
```

If you choose to specify your own preview command, there are several requirements:

- The path to the preview command must be fully specified.
- If relative, it must be located in one of the directories specified in your `PATH` environment variable.

553
The command must contain a %s that can be substituted by lpkview with the file name of the temporarily extracted preview image.

For example, if you want the preview command to be the UNIX file utility. Then, running the following command:

```
lpkview -c "file %s" -p myplot.lpk
```
might produce the following output:

```
/var/tmp/aaaa005L7:    data
```

Where file /var/tmp/aaaa005L7 is the temporarily extracted preview image. The temporary file is removed as soon as the preview command completes.

### B - 4 Preplot

The Preplot executable included in the standard Tecplot 360 installation converts Tecplot 360 format ASCII data files to binary data files. The following options are used with standard Tecplot 360 data files:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-d</code></td>
<td>Turn on debug echo. Use <code>-d2</code>, <code>-d3</code>, <code>-d4</code> for more detailed debug information.</td>
</tr>
<tr>
<td><code>-foreignplt</code></td>
<td>Reverse the bytes of the output binary data file (generally not required).</td>
</tr>
<tr>
<td><code>-iset</code></td>
<td>Create the binary data file using only the specified range and skipping for the I-index. The zone parameter specifies which zone this option affects; if not specified, all zones are affected. The start parameter is the starting I-index; the default is one. The end parameter is the ending I-index; the default is the last index value. The skip parameter specifies the I-interval, that is, the distance between indices; one means every index is used, two means every other index, and so on. For example, <code>-iset 1, 3, 7, 2</code> indicates that for zone 1 only I-index values of 3, 5, and 7 are used. Only one <code>-iset</code> option is allowed per zone.</td>
</tr>
<tr>
<td><code>-jset</code></td>
<td>Same as <code>-iset</code> above, except with respect to the J-index.</td>
</tr>
<tr>
<td><code>-kset</code></td>
<td>Same as <code>-iset</code> above, except with respect to the K-index.</td>
</tr>
<tr>
<td><code>-zonelist</code></td>
<td>Specify the zones to process. You may supply more than one specification. By default Preplot processes all zones.</td>
</tr>
</tbody>
</table>

See also: Section "Polyhedral - complex example" in the Data Format Guide.

### B - 5 Raster Metafile to AVI (rmtoavi)

The rmtoavi utility will convert a Raster Metafile animation to an AVI animation. The following is a description of the utility’s syntax. Brackets ([ ]) surround optional parameters. Options must be specified separately.

```
rmtoavi [options] filename.rm [outputfilename]
```

Filename is the name of the Raster Metafile to convert. Only one file name may be specified. The input file must end with the .rm extension.

554
The [outputfilename] is the name of the converted output AVI file. If the output file name is not specified, the input file name is used with a .avi extension. If any of the file names contain spaces, they must be enclosed in quotes.

For example, the command `rmtoavi test.rm` will create the file `test.avi`. If the output file exists, `rmtoavi` will prompt to overwrite it unless the `-y` option is used (see below).

The [options] are described as follows

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-help</td>
<td>Prints help information.</td>
</tr>
<tr>
<td>-q</td>
<td>Suppress startup banner and information message.</td>
</tr>
<tr>
<td>-y</td>
<td>Suppress query to overwrite an existing AVI file.</td>
</tr>
<tr>
<td>-d [nn]</td>
<td>Progress indicator. This prints a dot (.) every [nn] frames processed. If [nn] is not specified, it defaults to ten.</td>
</tr>
<tr>
<td>-m</td>
<td>Use multiple color palettes in the converted AVI file. Each frame of an AVI animation is limited to 256 colors. AVI animations can use either one set of 256 colors for the entire animation or a separate set of 256 colors for each frame. If you use the -m option, then each frame of the output AVI file will use a separate set of 256 colors. Since color information is read from the input Raster Metafile, this option only affects the output AVI animation if the Raster Metafile was originally exported using multiple color palettes.</td>
</tr>
<tr>
<td>-speed nn</td>
<td>Sets the speed of the output AVI file to nn frames per second. The default is ten.</td>
</tr>
</tbody>
</table>

### B - 6 Pltview

Pltview is a command line utility to examine the header information for binary Tecplot 360 data files. It is included in your Tecplot 360 distribution and installed in `$TEC_360_2013R1/bin`. To run pltview:

1. Launch the Command Prompt
2. navigate to `$TEC_360_2013R1/bin`
3. in the command prompt, type: `pltview "fullpath/filename.plt"`
   You must enter the full path for your file.
4. The command prompt will display:
   - File Name
   - File Version
   - File Type
   - Data Set Title
   - Number of Zones
   - Number of Variables
   - Variable Names
   - Auxiliary Data
   - I, J and K Max for each ordered zone
   - Total number of Nodes, Elements, Faces, as well as the element type, for each finite element zone
An example session using the pltview utility is shown here.
Shortcuts

C - 1   Keyboard Shortcuts

Avoid using Num Lock on UNIX platforms. Num Lock interferes with keyboard shortcuts.

C - 1.1   3D Rotate Tools

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click-and-drag</td>
<td>Rotate about the rotation origin.</td>
</tr>
<tr>
<td>ALT-Click-and-drag</td>
<td>Rotate about the viewer position using the active Rotate tool.</td>
</tr>
<tr>
<td>Middle-click-and-drag/ALT-Right-click-and-drag</td>
<td>Smoothly zoom in and out of the data.</td>
</tr>
<tr>
<td>Right-click-and-drag</td>
<td>Translate the data.</td>
</tr>
<tr>
<td>C</td>
<td>Move the rotation origin to the probed point, ignoring zones.</td>
</tr>
<tr>
<td>O</td>
<td>Set the center of rotation.</td>
</tr>
<tr>
<td>R</td>
<td>Switch to Rollerball rotation.</td>
</tr>
<tr>
<td>S</td>
<td>Switch to Spherical rotation.</td>
</tr>
<tr>
<td>T</td>
<td>Switch to Twist rotation.</td>
</tr>
<tr>
<td>X</td>
<td>Switch to X-axis rotation.</td>
</tr>
<tr>
<td>Y</td>
<td>Switch to Y-axis rotation.</td>
</tr>
<tr>
<td>Z</td>
<td>Switch to Z-axis rotation.</td>
</tr>
</tbody>
</table>
### C - 1.2 Contour Add Tool

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT-click</td>
<td>Place a contour line by probing on a streamtrace, slice, or iso-surface.</td>
</tr>
<tr>
<td>Click</td>
<td>Place a contour line.</td>
</tr>
<tr>
<td>CTRL-click</td>
<td>Replace the nearest contour line with a new line.</td>
</tr>
<tr>
<td>Click-and-drag</td>
<td>Move the new contour line.</td>
</tr>
<tr>
<td>-</td>
<td>Switch to the Contour Remove tool.</td>
</tr>
</tbody>
</table>

### C - 1.3 Contour Remove Tool

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Remove the contour line nearest to the probed location.</td>
</tr>
<tr>
<td>+</td>
<td>Switch to the Contour Add tool.</td>
</tr>
</tbody>
</table>

### C - 1.4 Geometry Polyline Tool

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Allow translation of polyline segments in all directions.</td>
</tr>
<tr>
<td>H</td>
<td>Restrict translation of the current polyline segment to horizontal.</td>
</tr>
<tr>
<td>U</td>
<td>End the current polyline and start a new one.</td>
</tr>
<tr>
<td>V</td>
<td>Restrict translation of current polyline segment to vertical.</td>
</tr>
</tbody>
</table>

### C - 1.5 Probe Tool

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>If the pointer is over a single valid cell, the interpolated field values from all nodes in the cell are returned. If multiple cells are candidates, the action is dependent upon the plot type: For 2D, the cell from the highest number zone is used. For 3D, the cell closest to the viewer is used.</td>
</tr>
<tr>
<td>CTRL-click</td>
<td>If the pointer is over a single valid cell, the field values from the nearest node in the cell are returned. If multiple cells are candidates, the action is dependent upon the plot type: For 2D, the cell from the highest number zone is used. For 3D, the cell closest to the viewer is used.</td>
</tr>
<tr>
<td>SHIFT-CTRL-click</td>
<td>The field values from the nearest point on the screen are returned (ignoring surfaces, zone number, and depth of the point). This is useful in 3D for probing on data points that are on the back side of a closed surface without having to rotate the object. In 2D, this is useful for probing on data points for zones that may be underneath other zones.</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ALT-click</strong></td>
<td>Probe only on streamtraces, iso-surfaces, or slices. If multiple cells are candidates, the action is dependent upon the plot type: For 2D, the cell from the highest number zone is used. For 3D, the cell closest to the viewer is used.</td>
<td></td>
</tr>
<tr>
<td><strong>ALT-CTRL-click</strong></td>
<td>Probe only on streamtraces, iso-surfaces, or slices. If multiple cells are candidates, the action is dependent upon the plot type: For 2D, the cell from the highest number zone is used. For 3D, the cell closest to the viewer is used. If the pointer is not over any cell, then the field values from nearest data point (as measured in distance on the screen) are returned.</td>
<td></td>
</tr>
<tr>
<td><strong>ALT-CTRL-SHIFT-click</strong></td>
<td>Probe only on streamtraces, iso-surfaces, or slices. The field values from the nearest point on the screen are returned.</td>
<td></td>
</tr>
<tr>
<td><strong>X, Y</strong></td>
<td>When probing, press X or Y in XY Line to switch dependencies, or R or T in Polar Line.</td>
<td></td>
</tr>
<tr>
<td><strong>T, R</strong></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### C - 1.6 Slice Tool

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>+</strong></td>
<td>Turn on start/end slices, or increment the number of intermediate slices.</td>
<td></td>
</tr>
<tr>
<td><strong>-</strong></td>
<td>Turn off start/end slices, or decrement the number of intermediate slices.</td>
<td></td>
</tr>
<tr>
<td><strong>Click</strong></td>
<td>If no slices are displayed for the current slice group, place the primary slice. Otherwise, move the closest displayed start, end, and primary slice from its current position to the clicked position.</td>
<td></td>
</tr>
<tr>
<td><strong>ALT-click</strong></td>
<td>Place the start, end, or primary slice (whichever is closer to the click position) on the nearest derived object (streamtrace, slice or iso-surface).</td>
<td></td>
</tr>
<tr>
<td><strong>CTRL-click</strong></td>
<td>Place the start, end, or primary slice (whichever is closer to the click position) on the nearest derived object (streamtrace, slice or iso-surface).</td>
<td></td>
</tr>
<tr>
<td><strong>I, J, K</strong></td>
<td>Switch to slicing constant I, J, or K-planes, respectively. Available for ordered zones only.</td>
<td></td>
</tr>
<tr>
<td><strong>X, Y, Z</strong></td>
<td>Switch to slicing constant X-, Y-, or Z-planes, respectively.</td>
<td></td>
</tr>
<tr>
<td><strong>1-8</strong></td>
<td>Switch between slice groups. (Slice groups are available in Tecplot 360 only.)</td>
<td></td>
</tr>
</tbody>
</table>

### C - 1.7 Streamtrace Placement tools (3D Cartesian plots only)

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>D</strong></td>
<td>Change the streamtrace style to streamrods.</td>
<td></td>
</tr>
<tr>
<td><strong>R</strong></td>
<td>Change the streamtrace style to streamribbons.</td>
<td></td>
</tr>
<tr>
<td><strong>S</strong></td>
<td>Change the streamtrace style to surface lines.</td>
<td></td>
</tr>
<tr>
<td><strong>V</strong></td>
<td>Change the streamtrace style to volume lines.</td>
<td></td>
</tr>
<tr>
<td><strong>1-9</strong></td>
<td>Change the number of streamtraces to be added when placing a rake of streamtraces.</td>
<td></td>
</tr>
</tbody>
</table>
### C - 1.8 Translate/Magnify Tool

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>Reduce the magnification of the data.</td>
</tr>
<tr>
<td>+</td>
<td>Increase the magnification of the data.</td>
</tr>
<tr>
<td>Drag</td>
<td>Translate the data.</td>
</tr>
<tr>
<td>SHIFT-drag</td>
<td>Translate the paper.</td>
</tr>
<tr>
<td>SHIFT - -</td>
<td>Reduce the magnification of the paper.</td>
</tr>
<tr>
<td>SHIFT - +</td>
<td>Increase the magnification of the paper.</td>
</tr>
</tbody>
</table>

### C - 1.9 Zoom Tool

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Center the zoom around the location of your click.</td>
</tr>
<tr>
<td>CTRL-click</td>
<td>Center the zoom around the location of your click and zoom out.</td>
</tr>
<tr>
<td>Drag</td>
<td>Draw a box to set the frame view.</td>
</tr>
</tbody>
</table>

### C - 1.10 Picked Object Options

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>Reduce the size of the object. If multiple objects are selected, all object positions will be shifted towards the first object selected.</td>
</tr>
<tr>
<td>+</td>
<td>Increase the size of the object. If multiple objects are selected, all object positions will be shifted away from the first object selected.</td>
</tr>
<tr>
<td>DEL</td>
<td>Delete picked object(s).</td>
</tr>
<tr>
<td>CTRL-C</td>
<td>Copy picked object(s) to the clipboard.</td>
</tr>
<tr>
<td>CTRL-V</td>
<td>Paste picked object(s) from the clipboard.</td>
</tr>
<tr>
<td>CTRL-X</td>
<td>Cut picked object(s).</td>
</tr>
</tbody>
</table>

### C - 1.11 Other Keyboard Operations

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL-A</td>
<td>Paste View - Paste stored frame view to current frame.</td>
</tr>
<tr>
<td>CTRL-D</td>
<td>Redraw all frames.</td>
</tr>
<tr>
<td>CTRL-F</td>
<td>Fit Surfaces (3D Only) - Resize plot so that all surfaces are included in the frame, excluding any volume zones. Fit to Full Size (2D, XY, Polar, Sketch) - Fit the entire plot into the frame (including data, text and geometries).</td>
</tr>
<tr>
<td>CTRL-E</td>
<td>Fit Surfaces (3D Only) - Resizes plot so that all data points, text, and geometries are included in the frame.</td>
</tr>
<tr>
<td>CTRL-L</td>
<td>Last - Restore the last frame view.</td>
</tr>
<tr>
<td>CTRL-O</td>
<td>Open a layout file.</td>
</tr>
<tr>
<td>CTRL-P</td>
<td>Print.</td>
</tr>
</tbody>
</table>
Keyboard Shortcuts

C - 2 Extended Mouse Operations

The middle and right mouse buttons are powerful tools you may use to immediately zoom and translate your data without having to switch to the Zoom or Translate tools on the Toolbar. This advanced mouse/keyboard functionality is available when using any 3D rotate, Contour, Geometry (except Polyline), Probe, Slice, Streamtrace Placement, Translate, Zoom, or Zone Creation tools. If you have a two button mouse use the CTRL key in conjunction with the right mouse button to achieve middle mouse button capabilities.

The following table lists all of the capabilities of the middle and right mouse buttons, when the active mouse tool is the “Selector” or the “Adjustor”.

<table>
<thead>
<tr>
<th>Action</th>
<th>Middle Button/CTRL+Right Button</th>
<th>Right Button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Redraw. If the pointer is in the active frame, Tecplot 360 will redraw the active frame. Otherwise, redraw all frames.a</td>
<td>Switch from the current tool to the Selector.b</td>
</tr>
<tr>
<td>Drag</td>
<td>Smoothly zoom in or out. An upward motion zooms out. A downward motion zooms in.</td>
<td>Translate.</td>
</tr>
<tr>
<td>ALT-drag</td>
<td>In 3D Cartesian plots, move the viewer further from (upward motion) or closer to (downward motion) the object. In all other plot types, this behaves like the Drag action</td>
<td>Same as the Drag action.</td>
</tr>
</tbody>
</table>

a. This is the default action for a click. It may be configured with the 
$INTERFACE MOUSEACTIONS {MIDDLEBUTTON...} command.
b. This is the default action for a click. It may be configured with the
$INTERFACE MOUSEACTIONS {RIGHTBUTTON...} command.

Refer to the following sections for information regarding Toolbar buttons with special capabilities tied to mouse buttons or keyboard keys.
The following terms are used throughout the Tecplot 360 User’s Manual and are included here for your reference.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>2D</td>
<td>Plotting in two dimensions. Line plots of one or more variables (XY and Polar Line plots) are not considered.</td>
</tr>
<tr>
<td>2D Cartesian Plot</td>
<td>A plot displaying a 2D scattering of points, surfaces, or volumes using two orthogonal axes.</td>
</tr>
<tr>
<td>3D</td>
<td>Plotting in three dimensions. Three-dimensional plotting can be subdivided into 3D surface and 3D volume.</td>
</tr>
<tr>
<td>3D Cartesian Plot</td>
<td>A plot displaying a 3D scattering of points, surfaces, or volumes using three orthogonal axes.</td>
</tr>
<tr>
<td>3D Sorting</td>
<td>The process that Tecplot 360 uses to determine which surface to plot first. In this process, the cells are sorted relative to the viewer and plotted beginning with the farthest point away and ending with the closest. Sorting is used when printing 3D plots or rendering translucent 3D objects on the screen.</td>
</tr>
<tr>
<td>3D Surface</td>
<td>Three-dimensional plotting confined to a surface. For example, the surface of a wing.</td>
</tr>
<tr>
<td>3D Volume</td>
<td>Three-dimensional plotting of data that includes interior data points of a volume, as well as those on the surface. For example, the vector field around a wing.</td>
</tr>
<tr>
<td>Active Zone</td>
<td>A zone that is displayed in the active plot, as determined in the Zone Style dialog.</td>
</tr>
<tr>
<td>Add-on</td>
<td>Any component or program which provides additional functions to Tecplot 360.</td>
</tr>
<tr>
<td>ADK</td>
<td>Add-on Developer’s Kit designed to create add-ons for use with Tecplot 360.</td>
</tr>
<tr>
<td>Anchor point</td>
<td>The fixed point of an object on the plot.</td>
</tr>
<tr>
<td>Antialiasing</td>
<td>The process of removing or reducing the jagged distortions in curves and diagonal lines.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------</td>
<td>------------</td>
</tr>
<tr>
<td>ASCII Data File</td>
<td>A data file composed of code representing English characters as numbers, where each letter is assigned a number from 0 to 127.</td>
</tr>
<tr>
<td>Aspect Ratio</td>
<td>The ratio of lengths of the sides of an object. In the 3D Cartesian plot type, the ratio is that of the longest side to the shortest side.</td>
</tr>
<tr>
<td>Auxiliary Data</td>
<td>Metadata attached to zones, datasets, and frames.</td>
</tr>
<tr>
<td>Banded Contour Flooding</td>
<td>A field plot where the region between contour lines is filled with a constant color that corresponds to each variable.</td>
</tr>
<tr>
<td>Bars Mapping Layer</td>
<td>Mapping Layer (XY line plots only) where bars are used to depict the relationship between the dependent and independent variables.</td>
</tr>
<tr>
<td>Binary Data File</td>
<td>A data file composed of machine-readable data. This type of file is created by converting ASCII data files with Preplot, or by directly creating them from an application.</td>
</tr>
<tr>
<td>Blanking</td>
<td>A feature of Tecplot 360 that excludes certain cells and points from a plot. There are three types of blanking: Value-Blanking, IJK-Blanking, and Depth Blanking.</td>
</tr>
<tr>
<td>Block</td>
<td>A data file format in which the data is listed by variable. All the point values of the first variable are listed first, then all the point values of the second variable, and so forth.</td>
</tr>
<tr>
<td>Boundary Cell Faces</td>
<td>A set of un-blanked cell faces in a 3D volume zone which have only one neighboring volume cell. In contrast, interior cell faces have two neighboring volume cells, one on either side, which share the face. For an IJK-ordered zone the boundary cell faces are on the exterior of the zone. That is, the first and last I-planes, the first and last J-planes, and the first and last K-planes. For a finite element 3D volume zone, boundary cell faces are on the exterior of the zone and the surface of any voids within the zone.</td>
</tr>
<tr>
<td>Bounding Box of Data</td>
<td>The smallest rectangular box, aligned with the coordinate axes, which completely encloses all data points.</td>
</tr>
<tr>
<td>Brick</td>
<td>An element type of finite element volume data composed of eight node points arranged in a hexahedron-like format. This element type is used in 3D volume plotting.</td>
</tr>
<tr>
<td>Carpet Plot</td>
<td>A 3D surface plot formed by a 3D plot where the variable is plotted in the third dimension and is singular-valued with respect to the independent variables.</td>
</tr>
<tr>
<td>Cartesian Plot</td>
<td>A plot of some variable by location on a single plane using two axes.</td>
</tr>
<tr>
<td>Cell</td>
<td>Either an element of finite element data, or the space contained by one increment of each index of IJK or IJK-ordered data.</td>
</tr>
<tr>
<td>Cell-centered Values</td>
<td>Values located at the center of the cell (assumed to be the centroid).</td>
</tr>
<tr>
<td>Code Generator</td>
<td>Add-on that generates style value code for any style changes made in the Tecplot 360 user interface.</td>
</tr>
<tr>
<td>Coordinate</td>
<td>Any of a set of numbers used in specifying the location of a point on a plot.</td>
</tr>
<tr>
<td>Configuration File</td>
<td>File containing initial Tecplot 360 defaults.</td>
</tr>
<tr>
<td>Color Map</td>
<td>A color spectrum used to plot contour flooding and multi-colored objects.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Connectivity List</td>
<td>The portion of a finite element data file which defines the elements or cells by listing the relationships between points. The number of points per cell is determined by the element type.</td>
</tr>
<tr>
<td>Continuous Contour Flooding</td>
<td>A field plot where a color is assigned to each point in a mesh, based upon the contour variable and the color map. Each face is filled with colors interpolated between the corner nodes. This results in a smooth variation of color over the surface.</td>
</tr>
<tr>
<td>Contour</td>
<td>A field plot type that plots iso-valued lines, or color flooding based on the values of a specified variable.</td>
</tr>
<tr>
<td>Curve Type</td>
<td>The function used to fit the data points in an XY-plot.</td>
</tr>
<tr>
<td>Custom Labels</td>
<td>Text strings contained within a data file or text geometry file which define labels for your axes or contour table. You may select Custom Labels anywhere you can choose a number format, the result is the text strings in place of numbers.</td>
</tr>
<tr>
<td>Cutaway Plot</td>
<td>A 3D volume plot where a portion of a 3D volume zone is cut-away by blanking to reveal the interior.</td>
</tr>
<tr>
<td>Cutting Plane</td>
<td>A planar surface used to slice 3D volume or surface zones.</td>
</tr>
<tr>
<td>Data File</td>
<td>A file that contains data used for plotting in Tecplot 360.</td>
</tr>
<tr>
<td>Data Format</td>
<td>The type of zone data as specified by the format parameter in a Tecplot 360 data file, such as BLOCK or POINT.</td>
</tr>
<tr>
<td>Data Loader</td>
<td>A Tecplot 360 add-on which allows you to read non-Tecplot 360 data files.</td>
</tr>
<tr>
<td>Data Point</td>
<td>An XYZ point at which field variables are defined.</td>
</tr>
<tr>
<td>Data Smoothing</td>
<td>A process that shifts the value of a variable at a data point towards an average of the values at its neighboring data points to reduce “noise” and lessen discontinuities in data.</td>
</tr>
<tr>
<td>Dataset</td>
<td>A set of one or more zones. A dataset may be plotted in one or more frames. However, a single frame may only plot one dataset. A dataset may be created by loading one or more data files.</td>
</tr>
<tr>
<td>Dependent</td>
<td>An axis mode requiring the axes to maintain a fixed ratio to one another.</td>
</tr>
<tr>
<td>Depth</td>
<td>For image export, the number of bits stored per pixel. For depth-blanking, the component of distance from the viewer position in a screen normal coordinate system.</td>
</tr>
<tr>
<td>Depth Blanking</td>
<td>A blanking option which excludes cells in a 3D plot, based upon their depth into the image. Cells closer than a plane of a certain depth, as well as cells further than a plane of another depth, may be blanked.</td>
</tr>
<tr>
<td>Derived Volume Objects</td>
<td>Graphic objects which are visible in the plot and created from zone data, but are not zones, i.e. an Iso-Surface, a Slice, or a Streamtrace.</td>
</tr>
<tr>
<td>Display List</td>
<td>A group of OpenGL commands that have been stored for subsequent execution. Using a display list can, depending upon the hardware involved, dramatically speed up graphics rendering. Using display lists also requires more memory.</td>
</tr>
<tr>
<td>Draw Level</td>
<td>A draw behavior setting for modifying the image quality and rendering speed during various operations, such as rotation. Options vary from Trace (a simplified wire-frame mesh which is rendered quickly) to Full.</td>
</tr>
<tr>
<td>Dynamic Text</td>
<td>Special placeholders added to text that change with the data or the display environment.</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Edge</td>
<td>A 2D or 3D field plot option. Plotting the edge of a zone plots the connection of all outer lines (IJ-ordered zones), finite element surface zones, or planes (IJK-ordered zones).</td>
</tr>
<tr>
<td>Element Type</td>
<td>The form of individual elements in a finite element zone. There are four types of cell-based finite element zones: Triangle and Quadrilateral (finite element surface types), and Tetrahedron and Brick (finite element volume types). For cell-based finite elements, the element type of a zone determines the number of nodes per element and their orientation within an element. There are two types of face-based finite element zones: polygonal (2D) and polyhedral (3D). For face-based elements, the number of nodes per element is variable.</td>
</tr>
<tr>
<td>Error Bars Mapping Layer</td>
<td>XY Line mapping layer where a second dependent variable (error) is used to show the accuracy of the first dependent variable, typically used in conjunction with the Bars Mapping Layer.</td>
</tr>
<tr>
<td>Exposed Cell Faces</td>
<td>The set of those cell faces in 3D volume zones that have only one un-blanked neighboring volume cell. By comparison, interior cell faces have two neighboring cells, one on either side, which share the face. The exposed cell faces include boundary cell faces and interior cell faces exposed by blanking. (One of the neighboring cells has been blanked.)</td>
</tr>
<tr>
<td>Extended Curve-fit</td>
<td>A Tecplot 360 add-on which extends Tecplot 360’s XY-plot curve-fitting capabilities.</td>
</tr>
<tr>
<td>Eye Coordinate System</td>
<td>Coordinate system aligned with the Grid coordinate system so that objects that are drawn move with the data as you zoom and translate, but remain fixed when you rotate the plot.</td>
</tr>
<tr>
<td>Extra 3D Sorting</td>
<td>Perform extra work to resolve hidden surface problems encountered during 3D sorting.</td>
</tr>
<tr>
<td>Face Neighbor</td>
<td>A neighboring cell whose faces share all nodes in common with the selected cell.</td>
</tr>
<tr>
<td>FE</td>
<td>An abbreviation for finite element (a common means of arranging data for calculations, often referred to as “unordered” or “unstructured”).</td>
</tr>
<tr>
<td>FEA</td>
<td>An abbreviation for finite element analysis. See Section 4 - 6 “FEA Loader” for information and supported formats.</td>
</tr>
<tr>
<td>Fence Plot</td>
<td>A plot of planes of a 3D data field.</td>
</tr>
<tr>
<td>FE Surface</td>
<td>A finite element zone of the element type Triangle, Quadrilateral, or Polygon. These zones are used for 2D and 3D surface plots.</td>
</tr>
<tr>
<td>FE Volume</td>
<td>A finite element zone of the element type: Tetrahedron, Brick or Polyhedron. These zones are used for 3D volume plots.</td>
</tr>
<tr>
<td>Field Map</td>
<td>A collection of zones for 2D and 3D field plots. A common style can be easily applied to all zones in the selection.</td>
</tr>
<tr>
<td>Field Plot</td>
<td>Includes 2D Cartesian and 3D Cartesian plot types. Generally used to display the spatial relationship of data. Mesh, Contour, Vector, Scatter, and Shade are all considered field plots. XY and Polar Line plots and the Sketch plot type are not field plots.</td>
</tr>
<tr>
<td><strong>File Path</strong></td>
<td>An option which specifies the directory for Tecplot 360 to search for a given type of file. For instance, a linked layout saved with an absolute file path contains the complete directory structure to load the associated file.</td>
</tr>
<tr>
<td><strong>Finite Element</strong></td>
<td>A type of data point ordering. Data is arranged by listing the data points (called nodes), and then listing their relationships (called elements). The element type of the zone determines the number of nodes which are contained in each element, as well as the exact relationship of nodes within an element. There are six different element types supported by Tecplot 360: Triangle, Quadrilateral, Tetrahedron, Brick, Polyhedral, and Polyhedral. See also: Connectivity List and Node.</td>
</tr>
<tr>
<td><strong>Font Modifier</strong></td>
<td>The modifier used to embed Greek, Math, or User-Defined characters in a text string.</td>
</tr>
<tr>
<td><strong>Frame</strong></td>
<td>Area within the workspace where sketches and plots are created.</td>
</tr>
<tr>
<td><strong>Frame Coordinate System</strong></td>
<td>Coordinate system fixed to the frame that does not change when the plot is zoomed, translated, or rotated.</td>
</tr>
<tr>
<td><strong>Gouraud Shading</strong></td>
<td>Shading used to achieve smooth lighting on low-polygon surfaces by linearly interpolating a color or shade across a polygon.</td>
</tr>
<tr>
<td><strong>Grid Area</strong></td>
<td>One or more rectangular regions defined and bounded by the grid axes.</td>
</tr>
<tr>
<td><strong>Grid Axes</strong></td>
<td>An axis option which displays the coordinates of the grid along the various spatial dimensions.</td>
</tr>
<tr>
<td><strong>Grid Coordinate System</strong></td>
<td>The grid coordinate system consists of two dimensional physical coordinates that are aligned with the coordinate system used by the plot axes.</td>
</tr>
<tr>
<td><strong>Gridline</strong></td>
<td>A set of lines drawn from one or more axes that extend from the tick marks on an axis across the grid area.</td>
</tr>
<tr>
<td><strong>Grid Point</strong></td>
<td>In 2D, the intersection of gridlines.</td>
</tr>
<tr>
<td><strong>Hidden Line</strong></td>
<td>Mesh type where mesh lines that appear behind other plot layers are not drawn.</td>
</tr>
<tr>
<td><strong>I-Ordered</strong></td>
<td>A type of data point ordering where each point is listed one at a time (that is, by one index). Used mainly in XY plots. In 2D or 3D, this type of data point ordering is sometimes called irregular, and is only useful for scatter plots, or for interpolating or triangulating into 2D, 3D surface, or 3D volume zones. (This type of data can also be used for 2D or 3D vector plots if streamtraces are not required.)</td>
</tr>
<tr>
<td><strong>IJ-Ordered</strong></td>
<td>A type of data point ordering where the points are arranged in an array used for 2D and 3D surface plotting.</td>
</tr>
<tr>
<td><strong>IJK-Blanking</strong></td>
<td>A feature to include or exclude portions of an IJK-ordered zone based on index ranges.</td>
</tr>
<tr>
<td><strong>IJK-Ordered</strong></td>
<td>A type of data ordering where the points are arranged in a 3D array. Used for 3D volume plotting as well as 2D and 3D surface plotting.</td>
</tr>
<tr>
<td><strong>Image Format</strong></td>
<td>Any of the raster or bit-mapped graphic formats supported by Tecplot 360.</td>
</tr>
<tr>
<td><strong>Inactive Zone</strong></td>
<td>A zone loaded into Tecplot 360 which does not appear in the plot. A zone can be deactivated using the Zone Show option on any page of the Zone Style dialog.</td>
</tr>
<tr>
<td><strong>Independent</strong></td>
<td>Axis mode allowing each axis to have a range that is not affected by the ranges of any other axis or axes.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Interpolate</td>
<td>To assign new values for the variables at data points in one zone based on the data point values in another zone (or set of zones).</td>
</tr>
<tr>
<td>Interpolate Mode</td>
<td>When probing is activated using a single mouse click, the value returned is linearly interpolated from all nodes in the cell. See also: Section “Nearest Point Mode” on page 569.</td>
</tr>
<tr>
<td>Internal Macro Variable</td>
<td>A read-only macro variable which allows you to access certain key values in Tecplot 360. For example, $NUMVARS gives the number of variables.</td>
</tr>
<tr>
<td>I-Plane</td>
<td>In an ordered zone, the connected surface of all points with a constant I-index. In reality, I-planes may be cylinders, spheres, or any other shapes.</td>
</tr>
<tr>
<td>Irregular Data</td>
<td>Points which have no order, or at least no order which can be easily converted to IJK or IJK-ordering.</td>
</tr>
<tr>
<td>Iso-Surface</td>
<td>A surface within a 3D zone where the contour variable has a constant value at all locations.</td>
</tr>
<tr>
<td>Journal</td>
<td>Log of data manipulation/creation/deletion instructions.</td>
</tr>
<tr>
<td>J-Plane</td>
<td>In an ordered zone, the connected surface of all points with a constant J-index. In reality, J-planes may be cylinders, spheres, or any other shape.</td>
</tr>
<tr>
<td>Kriging</td>
<td>A technique to interpolate the value of a random field at an unobserved location from observations of its value at nearby locations.</td>
</tr>
<tr>
<td>K-Plane</td>
<td>In an IJK-ordered zone, the connected surface of all points with a constant K-index. In reality, K-planes may be cylinders, spheres, or any other shape.</td>
</tr>
<tr>
<td>Layout File</td>
<td>A specialized macro file with extension .lay which preserves a plot created within Tecplot 360. When the layout is opened, it restores Tecplot 360 to the state it was in when the layout file was saved.</td>
</tr>
<tr>
<td>Layout Package File</td>
<td>A binary layout file with the .lpk extension which has the data embedded in the file.</td>
</tr>
<tr>
<td>Line Map</td>
<td>A set of points from a single zone where one variable is assigned to an X-axis and another is assigned to a Y-axis. You can define many XY-maps for an XY-plot.</td>
</tr>
<tr>
<td>Macro</td>
<td>A file containing a list of instructions, called macro commands, which can duplicate virtually any action performed in Tecplot 360.</td>
</tr>
<tr>
<td>Macro Command</td>
<td>An instruction given to Tecplot 360 in a macro file. Macro commands always start with a dollar sign and then an exclamation mark. For example, $!Redraw refreshes a plot view.</td>
</tr>
<tr>
<td>Macro File</td>
<td>A file which contains a series of macro commands. Macro files are run from the command line, or through the Play option of the Scripting menu.</td>
</tr>
<tr>
<td>Macro Function</td>
<td>A self-contained macro sub-routine.</td>
</tr>
<tr>
<td>Macro Variable</td>
<td>A holding place for numeric values in a macro file. There are two types of macro variables: user-defined (you set and retrieve the value), or internal (Tecplot 360 sets the value and you may retrieve it).</td>
</tr>
<tr>
<td>Map Layer</td>
<td>One way of displaying a line mapping, such as with line, bars, symbols, and so forth. One mapping may be displayed with one or more layers.</td>
</tr>
<tr>
<td>Median Axis</td>
<td>In 3D, the grid axis which when scaled is not the shortest nor the longest axis.</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>The top bar of the Tecplot 360 screen used to select menu options.</td>
</tr>
<tr>
<td>Mesh</td>
<td>A 2D or 3D field plot type which plots connections between data points.</td>
</tr>
<tr>
<td>Multi-Colored</td>
<td>Any Tecplot 360 object which is colored by the value of the contouring variable. Multi-colored objects may include mesh, scatter symbols, vectors, contour lines, and streamtraces.</td>
</tr>
<tr>
<td>Nearest Point Mode</td>
<td>When probing is activated using a CTRL+click, the value returned is the precise value of the closest data point. See also: Section “Interpolate Mode” on page 568</td>
</tr>
<tr>
<td>Node</td>
<td>A point in finite element data.</td>
</tr>
<tr>
<td>Number Format</td>
<td>The style of numbers to display for a data or axis label; exponent, integer, float, and so forth.</td>
</tr>
<tr>
<td>OpenGL</td>
<td>A graphics library for high-end 3D graphics. It commonly takes advantage of hardware acceleration for 3D rendering.</td>
</tr>
<tr>
<td>Ordered Data</td>
<td>A type of data point organization which consists of a parameterized series of points. There are seven types of ordered data: I, J, K, JK, IK, and UK-ordered. I, J, and UK-ordered are the most common.</td>
</tr>
<tr>
<td>Orthographic Projection</td>
<td>A plot view in which the shape of the object is independent of distance. This is used for displaying physical objects when preserving the true lengths is important.</td>
</tr>
<tr>
<td>Overlay</td>
<td>Mesh type where mesh lines are drawn over all field-plot layers, except for vector and scatter layers.</td>
</tr>
<tr>
<td>Pick</td>
<td>Select an item in the plot area by clicking on it with the mouse.</td>
</tr>
<tr>
<td>Plot Type</td>
<td>Determines the type of plot which is displayed in a frame. For example, 2D Cartesian plot, 3D Cartesian plot, XY Line plot, Polar Line plot, or Sketch plot.</td>
</tr>
<tr>
<td>PLOT3D</td>
<td>A plotting package developed by NASA.</td>
</tr>
<tr>
<td>Polar Line Plot</td>
<td>A plot of radius versus angle, or vice versa. The polar axes are the radial axis (by default zero at the origin) and theta axis (by default zero for any data on the right running horizontal line).</td>
</tr>
<tr>
<td>Polygonal</td>
<td>A 2D, face-based finite element type. The number of nodes per element is variable. That is, a single polygonal zone may contain triangular, quadrilateral, hexagonal, ... etc. elements.</td>
</tr>
<tr>
<td>Polyhedral</td>
<td>A 3D, face-based finite element type. The number of nodes per element is variable. That is, a single polyhedral zone may contain tetrahedral and brick (and other) elements.</td>
</tr>
<tr>
<td>Polylines</td>
<td>A continuous line composed of one or more line segments.</td>
</tr>
<tr>
<td>Polytope</td>
<td>The generalization to any dimension of polygon in two dimensions, polyhedron in three dimensions, and polychoron in four dimensions</td>
</tr>
<tr>
<td>Pop</td>
<td>Bring selected geometries or text to the top of the viewstack.</td>
</tr>
<tr>
<td>Precise Dot Grid</td>
<td>The points of intersection of the imaginary lines extending from the X- and Y-axes’ tick marks.</td>
</tr>
<tr>
<td>Primary Corner</td>
<td>The point in an ordered zone’s cell that has the minimum index values for that cell, or the first listed node of a finite element cell.</td>
</tr>
<tr>
<td>Probe</td>
<td>To obtain interpolated values of the dataset variables at a specified location by clicking on any point in the data region.</td>
</tr>
<tr>
<td>Term</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Push</td>
<td>Send selected geometries or text to the bottom of the viewstack.</td>
</tr>
<tr>
<td>Quadrilateral</td>
<td>An element type of finite element surface data which is composed of four node points arranged in a quadrilateral. Used in 2D and 3D surface plotting.</td>
</tr>
<tr>
<td>Quick Macro Panel</td>
<td>A user-defined panel accessed from the Scripting menu which allows quick access to your macro functions.</td>
</tr>
<tr>
<td>Rake</td>
<td>A specified line from which two or more streamtraces are generated.</td>
</tr>
<tr>
<td>RGB Color Flooding</td>
<td>The assignment of color based on Red, Green, and Blue components defined at field data locations.</td>
</tr>
<tr>
<td>Ribbon</td>
<td>(See Streamribbon.)</td>
</tr>
<tr>
<td>Richardson Extrapolation</td>
<td>A sequence acceleration method, used to improve the rate of convergence of a sequence.</td>
</tr>
<tr>
<td>Rod</td>
<td>(See Streamrod.)</td>
</tr>
<tr>
<td>Scatter</td>
<td>A 2D or 3D field plot type which plots a symbol at each data point.</td>
</tr>
<tr>
<td>SDK</td>
<td>A Tecplot software development kit, providing a library that integrates visualization capabilities into an application.</td>
</tr>
<tr>
<td>Shade Plot</td>
<td>A 2D or 3D field plot type which plots solid color or colors with lighting effect over the cells of the data.</td>
</tr>
<tr>
<td>Sharing</td>
<td>Variable sharing allows a single storage location to be used by more than one party. For example, if the X-variable is shared between zones five and seven, only one storage location is created. The storage is not freed by Tecplot 360 until the number of parties accessing the data is reduced to zero. Variables and connectivity information may be shared.</td>
</tr>
<tr>
<td>Sidebar</td>
<td>The bar located on the left side of the Tecplot 360 screen which provides access to frequently used plot controls.</td>
</tr>
<tr>
<td>Sketch Plot</td>
<td>A plot which displays only text and geometries.</td>
</tr>
<tr>
<td>Slice</td>
<td>A set of data created by the intersection of a plane with 3D zones.</td>
</tr>
<tr>
<td>Snap-to-Grid</td>
<td>Lock any object on the screen to the closest grid point. The position and size of the object will be affected by changes to the grid.</td>
</tr>
<tr>
<td>Snap-to-Paper</td>
<td>Lock any object on the screen to the underlying paper. The position and size of the object will not be affected by changes to the grid.</td>
</tr>
<tr>
<td>Sort</td>
<td>A measurement from one to two of the amount of work Tecplot 360 should do to resolve hidden-surface problems during 3D sorting. Selecting two will increase the time required for each redraw and will generate messages about the number of cells with a potential conflict.</td>
</tr>
<tr>
<td>Specular Highlights</td>
<td>Rendering a surface such that it displays qualities similar to those of a smooth reflecting surface such as metal.</td>
</tr>
<tr>
<td>Status Line</td>
<td>The bar located at the bottom of the Tecplot 360 screen which provides “hover” help for tools and acts as a progress bar during calculations.</td>
</tr>
<tr>
<td>Strand</td>
<td>A series of transient zones that represent the same part of a dataset at different times.</td>
</tr>
<tr>
<td>Stream</td>
<td>Particle traces through the vector field.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Stream Format</td>
<td>The current type of streamtraces being placed in Tecplot 360. For example, Surface Line, Volume Line, Volume Ribbon, or Volume Rod.</td>
</tr>
<tr>
<td>Streamline</td>
<td>A 2D or 3D line which is parallel to the vector field along its entire length. For a steady state vector field, this is the same as a simple particle trace which marks the path of a massless particle in the vector field.</td>
</tr>
<tr>
<td>Streamribbon</td>
<td>A particle trace with a width which not only follows the flow field (its center being a regular streamline), but which also twists with the vorticity of the vector field.</td>
</tr>
<tr>
<td>Streamrod</td>
<td>A particle trace with a polygonal cross-section and a width which not only follows the flow field (its center being a regular streamline), but which also rotates with the vorticity of the vector field.</td>
</tr>
<tr>
<td>Streamtrace</td>
<td>Any type of particle trace: streamlines, streamribbons, or streamrods.</td>
</tr>
<tr>
<td>Streamtrace Termination Line</td>
<td>A polyline that terminates any streamtraces that cross it.</td>
</tr>
<tr>
<td>Streamtrace Zone</td>
<td>Any streamtrace which has been extracted to form a new zone.</td>
</tr>
<tr>
<td>Stylessheet</td>
<td>A type of file which contains the definition of how the plot in a single frame is to be plotted. The stylesheet does not contain any zone data but does contain information about views, axes positions, zone attributes, and so forth.</td>
</tr>
<tr>
<td>Supersampling Factor</td>
<td>When antialiasing an image for export, the factor Tecplot 360 uses when creating an intermediate image that is then resized down to the final image size. The larger the value, the smoother the resulting image at the cost of performance. Values of more than 3 are seldom necessary.</td>
</tr>
<tr>
<td>Surface Line</td>
<td>A type of 3D streamline which is confined to remain on a 3D surface. Also used to refer to streamlines.</td>
</tr>
<tr>
<td>Symbols Mapping Layer</td>
<td>Line plot where symbols are used to depict the relationship between the dependent and independent variables.</td>
</tr>
<tr>
<td>Tecplot Toolbox</td>
<td>The Tecplot Toolbox is a convenience library that provides alternate method for communicating with the Tecplot Engine.</td>
</tr>
<tr>
<td>Time/Date</td>
<td>A type of axis label format with which you can label axes by using a multitude of codes that can display data in years, months, days, hours, minutes, and seconds.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>The bar at the top of the Tecplot 360 workspace.</td>
</tr>
<tr>
<td>Tetrahedron</td>
<td>An element type of finite element volume data which is composed of four node points arranged in a tetrahedron. (Used in 3D volume plotting.)</td>
</tr>
<tr>
<td>Transient Data</td>
<td>Data that has a time component in addition to a spatial coordinate.</td>
</tr>
<tr>
<td>Translucency</td>
<td>A property allowing you to see through an object to areas within or beyond it. In Tecplot 360 you may vary the amount of translucency, controlling the extent that an object closer to you obscures an object it overlays.</td>
</tr>
<tr>
<td>Triangle</td>
<td>An element type of finite element surface data which is composed of three node points arranged in a triangle. (Used in 2D and 3D surface plotting.)</td>
</tr>
<tr>
<td>Unordered or Unorganized Data</td>
<td>(See Irregular Data.)</td>
</tr>
<tr>
<td>Value-Blanking</td>
<td>A feature of Tecplot 360 used to trim or eliminate cells based on one or more user-defined constraints for variable values.</td>
</tr>
<tr>
<td>Term</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Variable</td>
<td>One of the values defined at every data point in a Tecplot 360 dataset or data file.</td>
</tr>
<tr>
<td>Vector Layer</td>
<td>A field plot showing the direction and or the magnitude of vector qualities.</td>
</tr>
<tr>
<td>Volume Line</td>
<td>A type of 3D streamline which is not confined to remain on a surface and may travel through 3D volume data.</td>
</tr>
<tr>
<td>Volume Zone</td>
<td>Any zone that is IJK-ordered, finite element tetrahedron, or finite element brick.</td>
</tr>
<tr>
<td>Vorticity</td>
<td>The measurement of the tendency of a vector field to rotate about a point. (Also called “curl.”)</td>
</tr>
<tr>
<td>Wire Frame</td>
<td>Mesh type where mesh lines are drawn behind all other plot layers.</td>
</tr>
<tr>
<td>Workspace</td>
<td>The portion of your screen where you can create Tecplot 360 frames. This includes but is not limited to the region covered by the displayed paper.</td>
</tr>
<tr>
<td>XY-Dependent</td>
<td>A 3D axis mode where X and Y are fixed (dependent), but Z is free to vary in ratio (independent).</td>
</tr>
<tr>
<td>XY Line Plot</td>
<td>Plots one variable assigned to one axis versus another variable assigned to another axis. Log plots, bar charts, and curve fitted lines are all examples of XY Line plots.</td>
</tr>
<tr>
<td>Zone</td>
<td>A subset of a dataset which is assigned certain plot types. Zones may be activated (plotted) or deactivated (not plotted). Each zone has one type of data ordering: I, IJ, IJK, or finite element. Zones are typically used to distinguish different portions of the data. For example, different calculations, experimental versus theoretical results, different time steps, or different types of objects, such as a wing surface versus a vector field around a wing.</td>
</tr>
<tr>
<td>Zone Layers</td>
<td>One way of displaying a 2D or 3D plot’s dataset. The plot is the sum of the active zone layers, which may include mesh, contour, vector, shade, scatter and edge.</td>
</tr>
</tbody>
</table>
This chapter details the PLOT3D functions available in the Calculate dialog (accessed via the Analyze menu). Formulae, where not trivial, are given for each function. For functions that have equivalent PLOT3D function numbers, the numbers are listed as well. Refer to Section 22 - 6.4 "Selecting a Function" for a description of how to use these numbers.

### E - 1 Symbols

The following symbols are used in formulae below. Other symbols are defined in context.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \gamma )</td>
<td>Reference or free-stream quantity.</td>
</tr>
<tr>
<td>( g )</td>
<td>Ratio of specific heats, ( \frac{c_p}{c_v} ).</td>
</tr>
<tr>
<td>( \rho )</td>
<td>Density, mass per unit volume (area in 2D).</td>
</tr>
<tr>
<td>( \xi )</td>
<td>Generalized curvilinear coordinate in the I-direction.</td>
</tr>
<tr>
<td>( \eta )</td>
<td>Generalized curvilinear coordinate in the J-direction.</td>
</tr>
<tr>
<td>( \zeta )</td>
<td>Generalized curvilinear coordinate in the K-direction.</td>
</tr>
<tr>
<td>( \omega )</td>
<td>Vorticity</td>
</tr>
<tr>
<td>( a )</td>
<td>Speed of sound.</td>
</tr>
<tr>
<td>( c_p )</td>
<td>Specific heat at constant pressure.</td>
</tr>
<tr>
<td>( c_v )</td>
<td>Specific heat at constant volume.</td>
</tr>
</tbody>
</table>

*Table E - 1: Analyze Symbology.*
E - 2.1 I, J, K-aspect Ratio

The ratio of maximum edge length squared to face area:

\[ AR = \frac{\text{Max edge length}^2}{\text{Area}} \]

For a rectangle or square, this simplifies to: \( AR = \frac{\text{height}}{\text{width}} \)

For collapsed faces where the area is zero, the aspect ratio is set to zero.

For Polyhedral zones, the maximum aspect ratio is calculated for all faces of a given cell.

E - 2.2 I, J, or K-stretch Ratio

The ratio of the length of line segment I2-I3 to segment I1-I2 (or I or J):

\[ \text{stretch ratio} = \frac{\text{length of segment I2-I3}}{\text{length of segment I1-I2}} \]

such that the stretch ratio is always > 1.

If either segment has zero length, the stretch ratio is set to one.

Note: If you have specified on the Geometry and Boundaries dialog that adjacent zones are connected, these stretch ratios will be made continuous across connected zone boundaries provided that the index directions are aligned.
E - 2.3 I, J, or K-face Skewness
The ratio of the two face diagonal lengths subtracted from one (the diagonals are ratioed so that this number is always non-negative):

\[ \text{face skewness} = 1 - \frac{\text{length of shorter face diagonal}}{\text{length of longer face diagonal}} \]

For polyhedral zones, the cell value is the maximum skewness over all cell faces.

E - 2.4 Cell Diagonal1 or Diagonal2 Skewness
The ratio of the lengths of two body diagonals subtracted from one (always non-negative). There are four body diagonals. We choose pairs which would be coplanar in an unskewed cell, that is, \((i,j,k) \rightarrow (i+1,j+1,k+1)\) and \((i,j,k+1) \rightarrow (i+1,j+1,k)\).

\[ \text{cell skewness} = 1 - \frac{\text{length of shorter body diagonal}}{\text{length of longer body diagonal}} \]

For polygonal zones, the ratio of the lengths will be zero.

E - 2.5 IJ, JK, KI, or Max Normals Skewness
The dot product of face unit normals for the two given faces.

\[ S_{IJ} = \hat{n}_I \cdot \hat{n}_J \]

The following figure illustrates this for IJ-skewness.

E - 2.6 I, J, K, or Min Orthogonality
One minus the absolute value of the dot product of two unit vectors which point in the direction of two adjacent edges of the given face.
Two triangles are formed with the four nodes of the face, and the dot product of the two unit normals of those triangles is subtracted from one.

For polyhedral zones, the max over all cell faces is found.

**E - 2.7 I, J, K, or Min Nonplanarity**

Two triangles are formed with the four nodes of the face, and the dot product of the two unit normals of those triangles is subtracted from one.

non-planarity of the four-node face shown below = 1 - $\hat{E}_{11} \cdot \hat{E}_{12}$

For ordered zones, the Jacobian is calculated with the standard formula.

$$J = \frac{1}{x_1(y_2z_3 - y_3z_2) - x_2(y_1z_3 - y_3z_1) + x_3(y_1z_2 - y_2z_1)}$$

The subscripts above represent partial derivatives, which are approximated with finite differences.

For finite element zones, Tecplot 360 approximates the Jacobian by inverting the average areas or volumes of the grid cells surrounding each node, 1/A or 1/V.

If the denominator of the above formula is zero (ordered zones), or all cells surrounding a node have zero area (finite element zones), the Jacobian is set to zero.

**E - 2.9 Cell Volume**

For ordered zones, the cell volume for a particular node (I, J, K) is the volume of the cell between nodes (I, J, K) and (I+1, J+1, K+1). In 2D, this function becomes cell area. Nodes on the IMax, JMax, and KMax boundaries are assigned the same value as the nodes at IMax-1, JMax-1, and KMax-1 respectively.

For finite element zones, the cell volume for a node is the average volume (area in 2D) of all cells of which that node is a part.
Vector Grid Quality Functions

E - 3   Vector Grid Quality Functions

E - 3.1   Grid I, J, or K-unit Normal
Vectors of unit length normal to I=, J=, or K= constant grid planes.
unit normal for I = \( \vec{n}_I \).
For polyhedral zones, the result will be set to (1, 0, 0).

E - 4   Scalar Flow Variables

E - 4.1   Density
The mass per unit volume of the fluid: \( \rho = \frac{\text{mass}}{\text{volume}} \). PLOT3D function numbers: 100 (not normalized), or 101 (normalized).

E - 4.2   Stagnation Density
\[ p^0 = \rho \left( 1 + \frac{\gamma - 1}{2} M^2 \right)^{\frac{\gamma}{\gamma - 1}} \]  
(compressible)  
\[ p^0 = \rho \left( 1 + \frac{\gamma - 1}{2} \right)^{\frac{\gamma}{\gamma - 1}} \]  
(incompressible)  
PLOT3D function numbers: 102 (not normalized), or 103 (normalized).

E - 4.3   Pressure
\[ p = \rho R T \] (compressible)
PLOT3D function numbers: 110 (not normalized), or 111 (normalized).

E - 4.4   Stagnation Pressure
\[ p^0 = p \left( 1 + \frac{\gamma - 1}{2} M^2 \right)^{\frac{\gamma}{\gamma - 1}} \] (compressible)
\[ p^0 = p + \frac{1}{2} |\vec{V}|^2 \] (incompressible)  
PLOT3D function numbers: 112 (not normalized), or 113 (normalized).

E - 4.5   Pressure Coefficient
\[ C_p = \frac{p - p_\infty}{\frac{1}{2} \rho u^2} \]  
PLOT3D function number: 114 (not normalized). There is no function number for normalized pressure coefficient, since reference value normalization is not possible (the free-stream pressure coefficient is zero).

E - 4.6   Stagnation Pressure Coefficient
\[ C_{p0} = \frac{p^0 - p_\infty}{\frac{1}{2} \rho u^2} \]  
PLOT3D function number: 115 (not normalized). As above, there is no function number for normalized stagnation pressure coefficient.

E - 4.7   Pitot Pressure
Equals stagnation pressure for subsonic/incompressible flow. For supersonic flow:
PLOT3D function number: 116 (not normalized).

**E - 4.8 Pitot Pressure Ratio**
The pitot pressure divided by the free-stream pressure. PLOT3D function number: 117 (not normalized).

**E - 4.9 Dynamic Pressure**
\[ q = \frac{1}{2} |\mathbf{U}|^2 \]
PLOT3D function number: 118 (not normalized).

**E - 4.10 Temperature**
\[ T = \frac{p}{\rho R} \] (compressible)
PLOT3D function numbers: 120 (not normalized), or 121 (normalized).

**E - 4.11 Stagnation Temperature**
\[ T^* = \begin{cases} \frac{T(1 + \frac{1}{2}M^2)}{T} & \text{(compressible)} \\ T & \text{(incompressible)} \end{cases} \]
PLOT3D function numbers: 122 (not normalized), or 123 (normalized).

**E - 4.12 Enthalpy**
per unit mass:
\[ h = c_p T \]
\[ c_p = \frac{2R}{\gamma - 1} \] (compressible only)
PLOT3D function numbers: 130 (not normalized), or 131 (normalized).

**E - 4.13 Stagnation Enthalpy**
per unit mass:
\[ h^* = c_p T + \frac{1}{2} |\mathbf{U}|^2 \]
PLOT3D function numbers: 132 (not normalized), or 133 (normalized).

**E - 4.14 Internal Energy**
per unit mass:
\[ e = c_v T \]
\[ c_v = \frac{R}{\gamma - 1} \] (compressible only)
PLOT3D function numbers: 140 (not normalized), or 141 (normalized).
**E - 4.15 Stagnation Energy**

Per unit mass: \( e^0 = c_s^2 + \frac{1}{2}U^2 \)

PLOT3D function numbers: 142 (not normalized), or 143 (normalized).

**E - 4.16 Stagnation Energy per Unit Volume**

Stagnation energy multiplied by density. PLOT3D function number: 163 (not normalized).

**E - 4.17 Kinetic Energy**

Per unit mass, one-half the square of the velocity magnitude.

\[ KE = \frac{1}{2} \| U \|^2 \]

PLOT3D function numbers: 144 (not normalized), or 145 (normalized).

**E - 4.18 Velocity Components \( U, V, \) or \( W \)**

The scalar velocity components. PLOT3D function numbers: 150 (\( u \); not normalized), 151 (\( v \); not normalized), or 152 (\( w \); not normalized).

**E - 4.19 Velocity Magnitude**

The 2-norm of the velocity vector components:

\[ \| U \| = \sqrt{u^2 + v^2 + w^2} \]

PLOT3D function number: 153 (not normalized).

**E - 4.20 Mach Number**

The flow speed divided by the local speed of sound, for compressible flow:

\[ M = \frac{\| U \|}{a} \]

PLOT3D function number: 154 (not normalized).

**E - 4.21 Speed of Sound**

\[ a = \sqrt{\gamma RT} = \sqrt{\frac{\gamma}{\rho}} = \left(\frac{\gamma - 1}{\rho} \right) \left( \frac{1}{2} \| U \|^2 \right) \text{ (compressible)} \]

PLOT3D function number: 155 (not normalized).

**E - 4.22 Cross Flow Velocity**

This presumes that free-stream velocity is purely in the X-direction:

\[ v_{CF} = \sqrt{v^2 + w^2} \]

PLOT3D function number: 156 (not normalized).

**E - 4.23 Equivalent Potential Velocity Ratio**

The ratio of velocity magnitude to the potential velocity, as calculated with the incompressible Bernoulli equation. Refer to previous sections for definitions of \( \| \| \) and \( \gamma \).

\[ \frac{\| U \|}{\sqrt{0.5 \rho}} \]

PLOT3D function number: 159 (not normalized).
E - 4.24 X, Y, Z-momentum Component
Per unit volume, the product of density and the scalar velocity components.
\[ \text{momentum} = \rho u \]

PLOT3D function numbers: 160 (X-momentum, not normalized), 161 (Y-momentum, not normalized), 162 (Z-momentum, not normalized).

E - 4.25 Entropy
\[ s = c_s \ln \left( \frac{P}{\rho^2} \right) + c_p \ln \left( \frac{T}{T_\infty} \right) \]

PLOT3D function number: 170 (not normalized).

E - 4.26 Entropy Measure S1
\[ s_1 = \left( \frac{P}{\rho_u^2} \right)^{1/3} - 1 \]

PLOT3D function number: 171 (not normalized).

E - 4.27 X-, Y-, Z-Vorticity
\[ \omega_x = \frac{\partial v}{\partial y} - \frac{\partial u}{\partial z} \]
\[ \omega_y = \frac{\partial w}{\partial z} - \frac{\partial u}{\partial x} \]
\[ \omega_z = \frac{\partial u}{\partial x} - \frac{\partial v}{\partial y} \]

PLOT3D function numbers: 180 (X-Vorticity, not normalized), 181 (Y-vorticity, not normalized), 182 (Z-vorticity, not normalized).

E - 4.28 Vorticity Magnitude
\[ |\omega| = \sqrt{\omega_x^2 + \omega_y^2 + \omega_z^2} \]

PLOT3D function number: 183 (not normalized).

E - 4.29 Swirl
\[ Swirl = U \cdot \omega \]

PLOT3D function number: 184 (not normalized).

E - 4.30 Velocity Cross Vorticity Magnitude
\[ |U \times \omega| \]

PLOT3D function number: 185 (not normalized).

E - 4.31 Helicity
\[ H = U \cdot \omega \]

PLOT3D function number: 186 (not normalized).

E - 4.32 Relative Helicity
\[ H_r = \frac{U \cdot \omega}{|\omega|} \]

580
Scalar Flow Variables

E - 4.33 Filtered Relative Helicity

\[ H_r \] as calculated above, but set to zero when \[ \| \mathbf{U} \cdot \mathbf{u} \| < 0.1 U_a^2 \].

PLOT3D function number: 187 (not normalized).

E - 4.34 Shock

For compressible flow:

\[ \frac{U}{a} \left[ \frac{V}{\rho} \right] \]

PLOT3D function number: 188 (not normalized).

E - 4.35 Filtered Shock

Shock, as shown above, but set to zero when the magnitude of the pressure gradient \[ |\nabla p| < 0.1 \gamma p \].

PLOT3D function number: 190 (not normalized).

E - 4.36 Pressure Gradient Magnitude

\[ |\nabla p| = \sqrt{p_x^2 + p_y^2 + p_z^2} \]

PLOT3D function number: 191 (not normalized).

E - 4.37 Density Gradient Magnitude

\[ |\nabla \rho| = \sqrt{\rho_x^2 + \rho_y^2 + \rho_z^2} \]

PLOT3D function number: 192 (not normalized).

E - 4.38 X, Y, Z-density Gradient

\[
\begin{bmatrix}
\rho_x \\
\rho_y \\
\rho_z
\end{bmatrix}
\]

PLOT3D function numbers: 194 (X-density Gradient, not normalized), 195 (Y-density Gradient, not normalized), 196 (Z-density Gradient, not normalized).

E - 4.39 Shadowgraph

The Laplacian of density, \[ \nabla^2 \rho \].

PLOT3D function number: 197 (not normalized).

E - 4.40 Divergence of Velocity

\[ \mathbf{V} \cdot \mathbf{U} = \frac{\partial u}{\partial x} + \frac{\partial v}{\partial y} + \frac{\partial w}{\partial z} \]

PLOT3D function number: 158 (not normalized).
**E - 4.41 Sutherland’s Law**

Sutherland’s Law is a method of estimating the viscosity of a fluid from its temperature. The formula is:

$$\mu = C_1 \frac{T^{\frac{32}{5}}}{T+C_2}$$

For the constants, Tecplot 360 uses the meters/kilograms/seconds values for air,

$$C_1 = 1.458 \times 10^8 \frac{\text{kg}}{\text{m} \cdot \text{s} \cdot \text{K}}$$

and $C_2 = 110.4 \text{ K}$. Unlike other functions, this function is units-specific. Tecplot 360 uses the meters/kilograms/seconds units for this calculation, so the input temperature (data set variable) must be in Kelvin. The resulting viscosity will be in units of $\text{kg}/\text{m} \cdot \text{s}$.

**E - 4.42 Isentropic Density Ratio**

$$\frac{\rho_i}{\rho} = \left(1 + \frac{\gamma - 1}{2} M^2 \right)^{\frac{2}{\gamma - 1}}$$

**E - 4.43 Isentropic Pressure Ratio**

$$\frac{p_i}{p} = \left(1 + \frac{\gamma - 1}{2} M^2 \right)^{\gamma - 1}$$

**E - 4.44 Isentropic Temperature Ratio**

$$\frac{T_i}{T} = 1 + \frac{\gamma - 1}{2} M^2$$

**E - 5 Vector Flow Variables**

**E - 5.1 Velocity**

The velocity vector, $\mathbf{U}$. PLOT3D function number: 200 (not normalized).

**E - 5.2 Vorticity**

See above for vorticity components. PLOT3D function number: 201 (not normalized).

**E - 5.3 Momentum**

Per unit volume, density multiplied by the velocity vector. PLOT3D function number: 202 (not normalized).

**E - 5.4 Perturbation Velocity**

$U' = U - U_0$

PLOT3D function number: 203 (not normalized).

**E - 5.5 Velocity Cross Vorticity**

$U \times \omega$

PLOT3D function number: 204 (not normalized).

**E - 5.6 Pressure Gradient**

The vector of pressure partial derivatives in space.
E - 5.7 Density Gradient

The vector of density partial derivatives in space:

\[ \nabla \rho = \begin{pmatrix} \frac{\partial \rho}{\partial x} \\ \frac{\partial \rho}{\partial y} \\ \frac{\partial \rho}{\partial z} \end{pmatrix} \]

PLOT3D function number: 211 (not normalized).

E - 6 The Velocity Gradient Tensor

In addition to the scalar and vector variables listed in the previous sections, Tecplot 360 can calculate one tensor variable, the velocity gradient:

\[ \nabla \mathbf{U} = \begin{pmatrix} \frac{\partial u}{\partial x} & \frac{\partial u}{\partial y} & \frac{\partial u}{\partial z} \\ \frac{\partial v}{\partial x} & \frac{\partial v}{\partial y} & \frac{\partial v}{\partial z} \\ \frac{\partial w}{\partial x} & \frac{\partial w}{\partial y} & \frac{\partial w}{\partial z} \end{pmatrix} \]

Each component in the tensor is stored as a separate variable in the dataset. The names indicate which component they represent, such as \(\frac{\partial u}{\partial x}\), \(\frac{\partial v}{\partial y}\), and so on.
## Limits of Tecplot 360

### F - 1  Hard Limits

The following hard limits apply to Tecplot 360 Version 2013 R1:

**Table F - 1: Hard limits for Tecplot 360 Version 2013 R1**

<table>
<thead>
<tr>
<th>Item</th>
<th>Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of data points per variable</td>
<td>Over 2 billion</td>
</tr>
<tr>
<td>Largest floating point absolute value</td>
<td>$10^{30}$</td>
</tr>
<tr>
<td>Smallest non-zero floating point absolute value</td>
<td>$10^{-30}$</td>
</tr>
<tr>
<td>Maximum number of datasets</td>
<td>2048 (Limited by the number of frames)</td>
</tr>
<tr>
<td>Maximum number of frames</td>
<td>2048</td>
</tr>
<tr>
<td>Maximum number of pages</td>
<td>2048 (Limited by memory)</td>
</tr>
<tr>
<td>Maximum number of macro variables</td>
<td>400</td>
</tr>
<tr>
<td>Maximum number of value blank constraints</td>
<td>8</td>
</tr>
<tr>
<td>Maximum number of contour groups</td>
<td>8</td>
</tr>
<tr>
<td>Maximum number of geometries</td>
<td>limited by memory</td>
</tr>
<tr>
<td>Maximum number of polylines per line geometry^a</td>
<td>50</td>
</tr>
<tr>
<td>Maximum number of points per circle or ellipse</td>
<td>720</td>
</tr>
<tr>
<td>Maximum number of custom label sets</td>
<td>Limited by available memory</td>
</tr>
</tbody>
</table>
Table F - 1: Hard limits for Tecplot 360 Version 2013 R1

<table>
<thead>
<tr>
<th>Item</th>
<th>Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of custom labels per set</td>
<td>5000</td>
</tr>
<tr>
<td>Minimum frame width or height</td>
<td>0.1 inches</td>
</tr>
<tr>
<td>Maximum frame width</td>
<td>500 inches</td>
</tr>
<tr>
<td>Maximum streamtraces per frame</td>
<td>32,000</td>
</tr>
<tr>
<td>Maximum number of streamtrace steps</td>
<td>10,000</td>
</tr>
<tr>
<td>Maximum number of color map overrides</td>
<td>16</td>
</tr>
<tr>
<td>Maximum preview width for EPS files</td>
<td>1024</td>
</tr>
<tr>
<td>Maximum preview height for EPS files</td>
<td>1024</td>
</tr>
<tr>
<td>Maximum number of user-defined color map control points</td>
<td>50</td>
</tr>
<tr>
<td>Maximum number of raw user-defined color map entries</td>
<td>800</td>
</tr>
<tr>
<td>Maximum number of characters in variable name</td>
<td>128</td>
</tr>
<tr>
<td>Maximum number of characters in zone title</td>
<td>128</td>
</tr>
<tr>
<td>Maximum number of characters in dataset title</td>
<td>256</td>
</tr>
<tr>
<td>Maximum number of views per view stack</td>
<td>16</td>
</tr>
<tr>
<td>Maximum number of characters in an auxiliary data string</td>
<td>32,000</td>
</tr>
<tr>
<td>Line length limit in ASCII .dat files (character limit per line)</td>
<td>120,000</td>
</tr>
</tbody>
</table>

a. A polyline is a continuous series of line segments, and can be a subset of a line geometry.

Table F - 2: Hard Limits for plot styles

<table>
<thead>
<tr>
<th>Item</th>
<th>Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing Gouraud shaded plots with continuous flooding</td>
<td>On screen or exported bitmap image only</td>
</tr>
<tr>
<td>Printing plots with translucency</td>
<td>On screen or exported bitmap image only</td>
</tr>
</tbody>
</table>
Soft Limits

The following soft limits may be changed by editing your Tecplot 360 configuration file. The configuration file, tecplot.cfg, is installed in your Tecplot 360 home directory. Refer to “$!LIMITS” on page 155 in the Tecplot Scripting Guide for the syntax required to edit your configuration file.

Table F - 3: Soft limits Tecplot 360 Version 2013 R1

<table>
<thead>
<tr>
<th>Limit</th>
<th>Windows</th>
<th>UNIX</th>
<th>Hard Limit</th>
<th>Macro Parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Points per linea</td>
<td>3000</td>
<td>5000</td>
<td>500,000</td>
<td>MAXPTSINALINE</td>
</tr>
<tr>
<td>Contour levels</td>
<td>150</td>
<td>400</td>
<td>5,000</td>
<td>MAXNUMCONTOUR</td>
</tr>
<tr>
<td>Characters per text label</td>
<td>16,000</td>
<td>16,000</td>
<td>100,000</td>
<td>MAXCHRSINTEXT</td>
</tr>
<tr>
<td>Picked objects</td>
<td>1500</td>
<td>&gt;2 billion</td>
<td></td>
<td>MAXNUMPICKOBJECTS</td>
</tr>
<tr>
<td>Load on demand - min threshold</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>LODTHRESHOLDMIN</td>
</tr>
<tr>
<td>Load on demand - max threshold</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>LODTHRESHOLD</td>
</tr>
<tr>
<td>Available processors</td>
<td>64</td>
<td>64</td>
<td>64</td>
<td>MAXAVAILABLE</td>
</tr>
</tbody>
</table>

1. Points per line is the limit on the number of points allowed in the following: line segment geometries, stream termination lines, and contour lines. For line segment geometries, this is the total number of points used in all polylines contained in the geometry.

F - 3 Limits When Working Remotely

When working with complex geometries in Tecplot 360 on non-Windows platforms, running the -mesa version of Tecplot 360 may enhance performance. Since using -mesa causes geometry computation to occur at the server level (causing the remote machine to receive only the resulting video files drawing the plot), display, zooming, and other capabilities will work faster. Using the -mesa option will reduce rendering quality, however; this option works advantageously primarily for large or complex geometries.

1. In the range of 50M polygons or elements
This diagram illustrates the high-level computation differences when a computer uses the `-mesa` flag.
Index

Numerics

2D
  range options 252
  rotate dialog 320
3D 53, 183–187
  axis limits dialog 183
  orientation axis dialog 184
  reset axis 183
  rotate dialog 185
  rotation 23
  view details dialog 53, 187
A
  ABAQUS files, load 86
  Absolute path 48
  Add-on 495–542
    Extrude 515
    Load 495
    Multi-Frame 520
    Prism grid 529
    Solution time/strand editor 530
    Sort 532
    Tecplot GUI Builder 536
    Tetra grid 538
    Time-series 539
    View binary 540
    Write data as formatted text 540
  Adjustor tool 21
  Advanced 3D control dialog 184
  Advanced quick edit dialog 499
  Anchor alignment 204
  snap modes 19
  Anchor alignment dialog 141
  Animite 18, 433, 434, 461–477, 554
  advanced techniques 473
  AVI export 433
    controls 18
  Flash export 434
  IJK blanking 465
  IJK-plane 463
  IJK-planes 463
  iso-surfaces 465
  mapping 467
  mappings dialog 467
  movie file 471–474
  on-screen 468
  Raster Metafile to AVI animation 554
  slice 468
  streaklines 375
  streamtrace 470
  streamtrace dialog 470
  time 461
to file 469
tools 461
zone 470
  Animite dialog 470
  Animation options dialog 376
  ANSYS files, load 82
  Antialiasing 436
  Arrowhead
    quick edit 34
  vector 210
  Aspect ratio 183
calculate 574
  Attachment lines 386
  Auto spacing 259
  AutoCAD loader 75
  Auxiliary data
    PLOT3D auxiliary data 115
  average 504
  AVI export 433
    Axis 183, 251–269
    axis details dialog 251
    custom labels 261
details dialog 251–269
display 251
grid area 266
  grid options 256
  lines 263
  polar range options 254
  reset 3D 183
tick mark labels 259
tick marks 258
time/date format 266
title 263
  variable assignment 251
  XY, 2D, 3D range options 252
B
  Backward Compatibility
    exporting data files 406
    write data files for previous versions 412
  Ballistic coefficient, calculate 378
  Batch processing 449–452
    Bitmap image 427
    Blankning 291–299
    animate IJK blanking 465
depth blanking 298
    IJK blanking 296
    value blanking 292
    BMP 427
    BMP file 427
    Border, show invisible 50
    Boundary cell face 177
edit 350
specify 348
C
  Cache graphics 20
  Calculate 91, 305–339, 341–386, 577–582
  alter data 305
table 305
  ballistic coefficient 378
  boundary values 311
  conductivity 342
  coordinate transformation 319
density 342, 345
drag coefficient 380
  examples 315
  FLOW3D derived variables 91
gamma 342
  gas constant 342
  gradient 355
  IJK aspect ratio 574
  IJK stretch ratio 574

589
INDEX

integrals 312
lift and drag 369
mass flow rate 367
mass-weighted stagnation pressure 368
Nusselt number 381
on-demand variables 354
particle paths 372
pressure 345
scalar flow variables 577–582
select function 355
shock surfaces 385
skewness 575
solution accuracy 382
sound speed 345
specific heat 342
statistical formulas 535
streaklines 372
temperature 345
total mass 366
turbulence 371
undo 355
variables 353
vector flow variables 582
vector grid quality functions 577
viscosity 342
volume under a surface 364
Calculating normal vector 356
Carpet data format 79
Cartesian plot 173–188
Cell face
boundary 177
exposed 177
CFD 341–386
boundary options 347
calculate turbulence 371
calculate variable 353
field variables 345
fluid flow, extract features 384
fluid properties 341
geometry options 347
integrate 357–371
particle paths 372–381
reference values 345
solution error 382
specify boundary 348
streaklines 372–381
unsteady flow 351
Change format dialog 541
Character
ASCII 164
custom 491
Choose extended curve fit dialog 156
Clear 56
Clipping 301–302
Code generator 502
Collapse zone/variable list 121
Color
contour layer 198
customize preferences 484
map dialog 138
preferences dialog 484
quick edit 33
select color 137–141
Command line options 545–548
Compare XY Maps 504
Compressible fluid 343
Conductivity, calculate 342
Configuration files, customize 479, 587
conjugates 319
Connectivity list 57
Contour details dialog 195–204
Contour layer 193–205
active slice group 230
add/delete levels 25
bands 199
coloring 198
groups 195
labels 201
add/delete 26
tepend 203
line extract 204
lines 201
modify 194
quick edit 29
Coordinate system 39
Copy 55
Copy plot to clipboard dialog 435
Copy view 53
create
1D-line zone dialog 322
circular zone dialog 323
duplicate zone dialog 325
frames 40
mappings dialog 147
mirror zone dialog 325
multiple frames dialog 506
rectangular zone dialog 322
zone 321
zone from polylines dialog 326
cross plot 508
Current solution time 462
Curve fit settings dialog 152
Curve information dialog 160
Curve-fit
exponential 152
extended 156
general 157
goodness of fit 160
information dialog 160
none 158
polynomial 152
power 153
weighting variables 159
write data points to file 162
write details to file 162
Custom axis label 261
Customize 479–493
cartesian definition 491
color preferences 484
configuration files 479
interface configuration 490
plot rendering 486–490
symbol definition 491
tecplot.add 496
tecplot.cfg 587
tecplot.phy 490
Cut 55

590
INDEX

error analysis 382
exponential fit 153
export 424–435
extract contour lines 204
extract FE boundary 329
extract flow features 384
extract sub-zone 327
field variables 345
fluid properties 341
graph variables and boundary options 347
graph geometry details 285
group select 46
group zones by time step 352
image geometry details 285
integrate 357–371
inverse-distance interpolation 332
iso-surface details 247–250, 466
kriing 335
label points and cells 182
light source 225
line legend 168
linear interpolation 331
load ANSYS results 82
macro recorder 441
macro variables 446
macro viewer 445
mapping style 144–149
mappings, create 147
paper setup 49, 416
parametric spline settings 135
particle mass 380
particle mass options 378
particle paths 372
performance 486–490
polar drawing options 170
power fit 154
print 415
print render options 419
print setup 416
probe at 387–401
publish options 410
python folders 456
python quick macros 454
python quick scripts 454
quick edit 29
record animation file 472
reference scatter symbol 218
reference values 345
reference vector 212
RGB coloring options 140
RGB legend 141
rotate 53
scatter legends 219
scatter size/font 217
select all 55
select color 137
select function 355
select import format 67
select variables 165, 207
set links for active frame 44
set origin 270
size preferences 485
slice details 228, 468
smooth 316
specify equations 305
spline settings 155
statistics 533
stinean interpolation 158
streamlines 372
streamtrace 236–246
streamtrace details 235–246
text details 272
text options 274
time details 181, 461
transform coordinates 319
translate/magnify 53
triangulate 336
turbulence 371
unsteady flow 351
value blanking 293
vector arrowheads 210
vector length 211
view binary 540
write data file options 411, 540
zone style 174–179
Draw, polar options 170
Dynamic Text 276

E
Edge layer 189–192
display 192
modify 192
quick edit 31
Edit 54
active frame 41
boundary dialog 350
clear 55, 56
copy 55
cut 55
paste 55, 56
pop 55
push 55
select all 55
undo 54
Enter ASCII character dialog 164
Enter contour level range dialog 197
Enter mapping name dialog 147
Enter range dialog 361
Enter test string dialog 174
Enter values to create a zone dialog 326
EPS export 424
Equations, see Calculate 315
Error analysis dialog 382
Error Bars, XY line 165
Excel
carpet format 79
load restrictions 80
macro 549
other formats 80
Exponential curve-fit 152
Exponential fit settings dialog 153
Export 403–436
antialiasing 436
AVI 433
BMP 427
clipboard 435
dialog 424–435

592
saving 47
saving frame style 47
Stylesheet 406
Super sampling 436
Surfaces, view fit 52
Symbol
custom 491
map layer 163
quick edit 32
Syntax
load add-on 495
loaders 67–125
T
Tecplot
gui builder 536
tecplot.add file 496
tecplot.cfg file 587
tecplot.phy file 490
tecplot viewer 422
Termination line 242
Tetra grid add-on 538
Text 271–288
alignment 287
detail dialog 272
dynamic 276
insert 26
macro, link to 287
options 272
options dialog 274
quick edit 34, 35
special characters 275
Tick mark
spinner 259
tiling frames 521
Time
current solution time 462
time aware 179–181
time details dialog 181, 461
time, animate 461
time/date format 266
time-series add-on 539
Toolbar 20
3D rotation 23
adjuster 21
circular zone 27
contour labels 26
contour level 25
create new frame 27
eXtract discrete points 27
group select 21
insert geometries 26
insert text 26
probe 26
rectangular zone 27
selector 20
show 51
slice 24
streamtrace 25
termination line 25
translate 22
zoom 22
Total mass, calculate 366
Transform coordinates dialog 319
Transient data 461–477
Translate 53
Translate tool 22, 188
Translate/magnify dialog 53
Translucency 223–226
Triangulate, irregular data point 336
TrueType fonts 73
Turbulence dialog 371
Turbulence, calculate 371
Twist rotation 23
U
Undo 54
unsteady flow dialog 351
Utilities 549–556
Excel macro 549
framer 551
LPK view 352
PView 553
Preplot 554
Raster Metatile to AVI 554
V
Value blanking dialog 293
Variable 62, 346, 353
calculate 353
cell centered 62
convective 346
curve-fit weighting 159
delete 330
dependent 158
independent 158
nodal 62
variance 504
Vector arrowheads dialog 210
Vector layer 30, 207–212, 231
active slice group 221
arrowheads 210
length 211
modify 208
quick edit 30
reference vectors 212
variables 207
View 187, 474, 552, 555
3D 187
fit all frames to paper 47
fit everything 52
fit surfaces 52
last 53
LPK 552
movie file 474
nice fit 52
PView 555
redraw frame 51
workspace options 54
View Binary add-on 340
View Binary dialog 540
Views
load style 48
load style from file 48
Viscosity, calculate 342
Volume, calculate 364
INDEX

W
window function 319
Windows Media 435, 476
WMF export 425
WMV 435, 476
Workspace, see Interface
Write Data as Formatted Text add-on 540
Write data file options dialog 411, 540

X
X-axis rotation 23
XY plots 32, 143-171, 252
axis range options 252
bar chart 167
curve types 149-163
line legend 168
line map layer 149-163
quick edit 32
specify number format 169

Y
Y-axis rotation 23

Z
Z-axis rotation 23
Zone 38, 232-234, 321, 327-330
animate zones dialog 470
create 321
create circular 27
create rectangular 27
data extract from existing 327
delete 330
extract streamtrace 246
point extraction 328
slice extract 232
surfaces 17
variable sharing, 313
Zone style dialog 174-179
Zoom 51
Zoom tool 22, 188